精华内容
下载资源
问答
  • 华为交换机telnet配置方法
    万次阅读
    2021-03-19 11:28:13

    前言

    提示:此文章目的是记录自己学习的笔记,顺便分享给有需要的人,本人小萌新一个,如文章中有出错欢迎各位大佬指正!


    提示:以下是本篇文章正文内容,下面案例可供参考

    示例:以下内容是以华为交换机S2700作为实验设备,当然华为交换机的配置大同小异,其他型号的华为交换机亦可参照此文档进行配置。

    Telnet的两种配置方式:

    1.仅密码登录验证

    代码如下(示例):
    <Quidway>system-view -----进入配置模式
    [Quidway]interface vlan 1 -----进入管理vlan
    [Quidway-Vlanif1]ip address 192.168.28.49 255.255.255.0 -----配置管理ip地址
    [Quidway-Vlanif1]quit -----退出
    [Quidway]telnet server enable -----打开telnet服务 (一般默认开启)
    [Quidway]user-interface vty 0 4 -----用户指定虚拟用户终端接口
    [Quidway-ui-vty0-4]authentication-mode password -----配置用户终端接口认证方式 密码验证
    [Quidway-ui-vty0-4]set authentication password cipher huawei123 -----设置接口验证密码,密码为huawei123
    [Quidway-ui-vty0-4]user privilege level 15 -----设置用户优先级 (可选)
    [Quidway-ui-vty0-4]idle-timeout 1 -----设置登陆超时为一分钟 (可选)
    [Quidway-ui-vty0-4]return -----返回用户视图
    <Quidway>save -----保存

    2.配置AAA登录

    代码如下(示例):
    <Quidway>system-view -----进入配置模式
    [Quidway]interface vlan 1 -----进入管理vlan
    [Quidway-Vlanif1]ip address 192.168.28.49 255.255.255.0 -----配置管理ip地址
    [Quidway-Vlanif1]quit -----退出
    [Quidway]telnet server enable -----打开telnet服务 (一般默认开启)
    [Quidway]user-interface vty 0 4 -----用户指定虚拟用户终端接口
    [Quidway-ui-vty0-4]authentication-mode aaa -----配置用户终端接口认证方式 aaa验证
    [Quidway-ui-vty0-4]user privilege level 15 -----设置用户优先级
    [Quidway-ui-vty0-4]idle-timeout 1 -----设置登陆超时为一分钟
    [Quidway-ui-vty0-4]quit -----退出
    [Quidway]aaa -----进入aaa
    [Quidway-aaa]local-user huawei password cipher huawei123 -----创建用户名huawei 密码huawei123
    [Quidway-aaa]local-user huawei privilege level 15 -----设置用户优先级
    [Quidway-aaa]local-user huawei service-type telnet -----授权用户使用telnet
    [Quidway-ui-vty0-4]return -----返回用户视图
    <Quidway>save -----保存


    总结

    提示:这里对文章进行总结:文章中若有出差,请给位大佬指正。

    更多相关内容
  • telnet配置

    千次阅读 2021-05-02 17:05:15
    H3C设备telnet配置 1. 客户端配置: 启动telnet服务(这里以windows为列) 进入控制面板---->网络和Internet------>网络和共享中心-------> 查看网络状态和任务------>网络连接 ------> 属性------>...

    H3C设备telnet配置

    1. 客户端配置:
    启动telnet服务(这里以windows10为例)
    进入控制面板---->网络和Internet------>网络和共享中心------->
    查看网络状态和任务------>网络连接 ------> 属性------>IPv4配置 ------>
    设置到同一网段(如下图)

    配置

    本地主机器开启telnet:
    进入控制面板 ------> 程序 ------> 打开或关闭Windows功能 ------>
    勾选上Telnet相关服务
    启动服务

    2.服务端配置:
    S12_0这里是设备名称

    [S12_0]vlan 10  
    [S12_0-GigabitEthernet1/0/x]port access vlan 10  #把客户端所在端口加入vlan
    [S12_0]int Vlan-interface 10  #进入vlan接口
    [S12_0-Vlan-interface10]ip address 192.168.1.1 24 #设置接口ip和mask
    [S12_0-Vlan-interface10]quit
    [S12_0]telnet server enable     #在系统界面开启telnet服务
    [S12_0]local-user admin218      #设置账户名
    New local user added.
    [S12_0-luser-manage-admin218]password simple 123456 #设置格式为密文账户名密码
    [S12_0-luser-manage-admin218]authorization-attribute user-role level-15     #设置账户权限等级,最高为十五级。
    [S12_0-luser-manage-admin218]service-type telnet #用户对应的登陆类型为远程登陆
    [S12_0-luser-manage-admin218]quit   
    [S12_0]user-interface vty 0 4  #配置虚拟终端0-4
    [S12_0-line-vty0-4]authentication-mode scheme  #认证方式为组合认证(用户名+密码)
    [S12_0-line-vty0-4]quit
    

    3.配置验证
    客户端输入命令:telnet 192.168.1.1
    配置成功
    配置成功

    展开全文
  • 可以通过上述文档学会初始化配置华三的交换机的初始化配置
  • 《华为基础实验》VRP 基础操作与 Telnet 配置.docx
  • 华为交换机s2300的telnet配置 连接 console 口: <Quidway>sys [Quidway]interface vlanif 1 进入到vlan 1 [Quidway-Vlanif1]ip address 你的网段ip 你的掩码 设置ip:我的例子:ip address 192.168.0.200 255....
  • 交换机telnet配置

    2021-05-28 10:51:01
    交换机telnet配置 网络拓扑 配置命令 查看交换机mac地址表 # 查看 交换机mac 地址表 [sw1]display mac-address 配置交换机的远程管理IP地址 <Huawei>system-view [Huawei]sysname sw1 #配置交换机的远程...

    交换机telnet配置

    网络拓扑

    swtelnet

    配置命令

    查看交换机mac地址表

    # 查看 交换机mac 地址表
    [sw1]display mac-address 
    

    配置交换机的远程管理IP地址

    <Huawei>system-view 
    [Huawei]sysname sw1
    #配置交换机的远程管理IP地址
    [sw1]interface Vlanif 1
    [sw1-Vlanif1]ip address 192.168.1.1 255.255.255.0
    [sw1-Vlanif1]quit
    [sw1]ip route-static 0.0.0.0 0.0.0.0 192.168.1.254
    
    

    显示 vlan 信息

    # 显示vlan 信息
    <sw1>display vlan
    

    显示当前配置信息

    # 显示当前配置
    <sw1>display current-configuration
    # save 保存配置
    <sw1>save
    

    配置交换机端口

    #配置交换机端口速率、双工、ARP
    [sw1]interface GigabitEthernet 0/0/1   # 进入接口 0/0/1
    [sw1-GigabitEthernet0/0/1]
    [sw1-GigabitEthernet0/0/1]description dtwlxy      # 端口描述
    [sw1-GigabitEthernet0/0/1]undo negotiation auto   # 取消自动协商
    [sw1-GigabitEthernet0/0/1]duplex full             # 全双工
    [sw1-GigabitEthernet0/0/1]auto duplex full
    Error: Please config negotiation auto first.
    [sw1-GigabitEthernet0/0/1]speed 10     # 速率 10M
    [sw1-GigabitEthernet0/0/1]speed 100    # 速率 100M
    [sw1]arp static 192.168.1.100   5489-9851-729b   # arp 绑定
    [sw1]display arp       # 查看 arp
    [sw1]display arp all   # 查看 arp
    
    # 设置自动协商
    [sw1-GigabitEthernet0/0/1]negotiation auto 
    

    配置交换机 vlan

    # 配置交换机 vlan相关命令
    [sw1]vlan 10                            # 创建 vlan
    [sw1-vlan10]description testvlan10      # vlan 描述
    [sw1]vlan batch 30 40 50                # 创建多个 vlan
    [sw1]display vlan                       # 查看vlan 信息
    
    # 配置 access vlan
    [sw1]interface GigabitEthernet 0/0/2
    [sw1-GigabitEthernet0/0/2]port link-type access 
    [sw1-GigabitEthernet0/0/2]port default vlan 10
    [sw1-GigabitEthernet0/0/2]q
    [sw1]interface GigabitEthernet 0/0/3	
    [sw1-GigabitEthernet0/0/3]port link-type access
    [sw1-GigabitEthernet0/0/3]port default vlan 10
    [sw1-GigabitEthernet0/0/3]q
    [sw1]
    [sw1]display port vlan  # 查看端口 vlan
    
    [sw1]interface GigabitEthernet 0/0/4
    [sw1-GigabitEthernet0/0/4]port link-type trunk    # 配置接口模式为 trunk
    [sw1-GigabitEthernet0/0/4]port trunk allow-pass vlan all  # 允许所有 vlan 通过
    [sw1-GigabitEthernet0/0/4]port trunk allow-pass vlan 30 40  # 允许 vlan 30 40 通过
    [sw1-GigabitEthernet0/0/4]undo port trunk allow-pass vlan 30 40  # 不允许 vlan 30 40 通过
    
    
    [sw1]interface GigabitEthernet 0/0/5
    [sw1-GigabitEthernet0/0/5]port link-type hybrid 
    [sw1-GigabitEthernet0/0/5]port hybrid pvid vlan 30  # 设置默认vlan
    

    设置交换机密文密码

    #设置交换机密文密码
    
    <Huawei>system-view 
    [Huawei]sysname sw1
    [sw1]
    [sw1]user-interface console 0
    [sw1-ui-console0]authentication-mode password
    [sw1-ui-console0]set authentication password cipher 123456
    [sw1-ui-console0]quit
    [sw1]
    
    展开全文
  • H3C-路由器、交换机-telnet配置步骤H3C-路由器、交换机-telnet配置步骤
  • 路由器 telnet配置

    千次阅读 2021-05-28 10:41:47
    路由器 telnet配置 基于password 的远程登录 R1 <R1>system-view [R1]interface GigabitEthernet 0/0/0 [R1-GigabitEthernet0/0/0]ip address 10.0.12.1 24 [R1-GigabitEthernet0/0/0]q [R1]telnet server ...

    路由器 telnet配置

    基于password 的远程登录

    telnet-password

    R1

    <R1>system-view 
    [R1]interface GigabitEthernet 0/0/0
    [R1-GigabitEthernet0/0/0]ip address 10.0.12.1 24
    [R1-GigabitEthernet0/0/0]q
    [R1]telnet server enable      # 开启telnet
    Info: The Telnet server has been enabled.
    [R1]user-interface vty 0 4    # 进入用户虚拟模板
    [R1-ui-vty0-4]authentication-mode password  # 配置认证方式
    [R1-ui-vty0-4]set authentication password cipher 123456  # 配置密码为密文传输
    [R1-ui-vty0-4]user privilege level 3    # 定义用户权限级别为3级
    [R1-ui-vty0-4]protocol inbound telnet   # 使用telnet 协议远程登录访问
                       # 这里可以配置为 ssh 或 telnet 或者all(ssh and telnet)
    

    R2

    在 R2 上主要是验证 telnet 远程连接

    <R2>system-view 
    [R2]interface GigabitEthernet 0/0/0
    [R2-GigabitEthernet0/0/0]ip address 10.0.12.2 24
    [R2-GigabitEthernet0/0/0]q
    [R2]q     # 要退出到用户视图才能使用 telnet 远程登录到其它设备
    <R2>telnet 10.0.12.1
    Trying 10.0.12.1 ...
    Press CTRL+K to abort
    Connected to 10.0.12.1 ...
    
    
    Login authentication
    
    
    Password:
    Info: The max number of VTY users is 10, and the number
          of current VTY users on line is 1.
          The current login time is 2021-05-13 14:10:51.
    <R1>
    

    基于aaa 的远程登录

    telnet-aaa

    R3

    <Huawei>system-view
    [Huawei]sysname R3
    [R3]
    [R3]interface GigabitEthernet 0/0/0
    [R3-GigabitEthernet0/0/0]ip address 10.0.34.3 24
    [R3-GigabitEthernet0/0/0]q
    [R3]
    [R3]telnet server enable 
    [R3]user-interface vty 0 4
    [R3-ui-vty0-4]authentication-mode aaa  # 配置认证方式为aaa 认证
    [R3-ui-vty0-4]protocol inbound telnet 
    [R3-ui-vty0-4]q
    [R3]
    [R3]aaa    # 进入 aaa 视图
    [R3-aaa]local-user test password cipher 123456
    [R3-aaa]local-user  test service-type telnet
    [R3-aaa]q
    [R3]
    

    R4

    在R4 上面验证 telnet aaa 验证方式是否成功。

    <Huawei>system-view 
    [Huawei]sysname R4
    [R4]
    [R4]interface GigabitEthernet 0/0/0
    [R4-GigabitEthernet0/0/0]ip address 10.0.34.4 24
    [R4-GigabitEthernet0/0/0]ping 10.0.34.3    # 连通性测试
      PING 10.0.34.3: 56  data bytes, press CTRL_C to break
        Reply from 10.0.34.3: bytes=56 Sequence=1 ttl=255 time=30 ms
    May 13 2021 14:19:02-08:00 R4 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.
    191.3.1 configurations have been changed. The current change number is 2, the ch
    ange loop count is 0, and the maximum number of records is 4095.
        Reply from 10.0.34.3: bytes=56 Sequence=2 ttl=255 time=10 ms
        Reply from 10.0.34.3: bytes=56 Sequence=3 ttl=255 time=50 ms
        Reply from 10.0.34.3: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.0.34.3: bytes=56 Sequence=5 ttl=255 time=30 ms
    
      --- 10.0.34.3 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 10/30/50 ms
    
    [R4-GigabitEthernet0/0/0]q
    [R4]q
    <R4>
    <R4>telnet 10.0.34.3
    Trying 10.0.34.3 ...
    Press CTRL+K to abort
    Connected to 10.0.34.3 ...
    
    
    Login authentication
    
    
    Username:test
    Password:
    Info: The max number of VTY users is 10, and the number
          of current VTY users on line is 1.
          The current login time is 2021-05-13 14:29:06.
    <R3>
    <R3>
    <R3>
    <R3>
    <R3>q
    <R4>
    
    展开全文
  • 华为路由器Telnet配置详细命令,适合新手学习!
  • 该程序telnet登录设备并进行自动配置登录的网络设备的模板程序
  • eNSP 简易telnet配置

    2022-02-26 22:12:27
    在r2上面配置telnet telnet登录用户名为telnet、密文密码:huawei 给这个用户的级别为3 为telnet这个用户开启telnet服务 选择aaa认证的模式 [a2]aaa [a2-aaa]local-user telnet password cipher huawei [a2-aaa]...
  • 思科交换机telnet配置

    千次阅读 2021-08-16 16:05:01
    通过配置S1和S2的vlan1地址实现telnet功能。 为了更好的验证telnet功能pc1、pc3为vlan10。 pc2、pc4为vlan20。 下面开始配置 pc1 pc2 pc3 pc4 配置S1 Switch(config)#...
  • Telnet配置实验

    2021-05-15 09:00:03
    按照图示连接到真机,并配置IP地址(真机IP地址配置到VirtualBox Host-Only Ethernet Adapter网卡) 打开网络连接找到VirtualBox Host-Only Ethernet Adapter网卡,配置ip1.1.1.2 在R1上开启Telnet服务,创建...
  • 任务1. 交换机的端口配置与管理 ... 掌握采用Telnet方式配置交换机的方法。 实验背景 第一次在设备机房对交换机进行了初次配置后,你希望以后在办公室或出差时也可以对设备进行远程管理。现要在交换机上做适当配置
  • h3c交换机配置telnet配置教程

    万次阅读 2020-12-24 05:49:03
    下面YJBYS小编为大家整理了关于h3c交换机配置telnet配置教程,希望对你有所帮助。配置实例一:通过Console口连接配置交换机Vlan1的IP地址system-view[h3c]interface vlan-interface 1[h3c-vlan-interface1]ip ...
  • H3C交换机Telnet配置.pdf

    2022-04-15 11:39:41
    H3C交换机Telnet配置.pdf
  • eNSP之Telnet配置

    千次阅读 2020-11-02 17:20:56
    eNSP之Telnet配置 实验环境 实验需求 1、SW1使用密码认证,SW2上使用AAA认证。 2、设置同一的管理VLAN为100,用于远程等登陆时使用,其中SW1IP为 实验配置 SW1配置 <Huawei>undo terminal monitor //关闭设备...
  • 华为路由器两种Telnet配置模式

    千次阅读 多人点赞 2021-05-26 21:28:13
    文章目录实验拓扑图:实验配置思路:实验基本配置:R1——配置接口IP地址R2——配置接口IP地址配置AAA认证R2——配置认证模式为AAA认证R1——Telnet登录192.168.10.2设备配置passwrd认证R2——配置认识模式为...
  • telnet配置Cisco路由器和交换机,有拓扑图,有实验结果
  • 交换机telnet配置ppt

    2018-08-03 23:48:30
    交换机初始配置telnet,适合新手学习,请多多批评指正。
  • 开启telnet配置文件

    2018-08-06 10:25:35
    斐讯刷机用的,其实没什么可以说的,有需要的就带走吧
  • telnet配置和命令telnet is very important protocol used to connect remote systems via command line. It has some security defects but used widely because of its simple and widespread usage. In this ...
  • 华为交换机三种Telnet配置模式

    千次阅读 多人点赞 2021-05-26 12:57:09
    文章目录实验拓扑图:实验配置思路:实验基本配置:SW1——配置VLAN和接口模式SW2——配置VLAN和接口模式配置AAA认证SW2——配置认证模式为AAA认证SW1——Telnet登录192.168.10.2设备配置none认证SW2——配置认证...
  • 思科Telnet配置操作

    千次阅读 2020-07-24 17:32:21
    1、通过Telnet方式,登录网络设备(交换机或者路由器) 通过enable命令进入特权模式; 通过configure terminal命令进入全局配置模式, 通过vlan 1命令,设置vlan 1,通过exit命令退出valn配置模式, 在全局配置...
  • 配置步骤 1,开启Telnet服务 [Huawei] Telnet server enable 2,配置VTY用户界面的终端dao属性 [Huawei] user-interface vty 0 4 [Huawei] protocol inbound telnet 3,console和Telnet启用aaa认证(这样就可以同...
  • 主要介绍了Ubuntu下Telnet服务器的配置方法的相关资料,非常不错,具有参考借鉴价值,需要的朋友可以参考下
  • H3C_路由器_Telnet配置

    千次阅读 2022-03-16 16:36:22
    一、实验环境 win7操作系统 HCL v2.1.2 二、拓扑结构 三、模拟环境 使用Telnet协议远程登陆设备,进行调试。
  • 交换机Telnet配置

    2019-12-01 12:58:11
    交换机Telnet配置 pc1 192.168.1.2 255.255.255.0 pc2 192.168.1.3 255.255.255.0 pc3 192.168.1.4 255.255.255.0 switch 192.168.1.5 255.255.255.0 pc配置步骤 1 交换机配置步骤 交换机配置命令 S1>en ...
  • 华为telnet配置

    千次阅读 2020-06-03 10:51:45
    user-interface vty 0 4 authentication-mode password 然后按照提示输入密码 user privilege level 3 设置用户等级为3 quit ...local-user huawei service-type telnet 设置用户huawei的方式为t...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 139,113
精华内容 55,645
关键字:

telnet配置

友情链接: Cerere radiere.rar