为您推荐:
精华内容
最热下载
问答
  • 5星
    1.99MB Han1254686887 2021-06-09 14:57:31
  • 5星
    3.13MB qq_52745968 2021-06-17 11:18:37
  • 5星
    147KB weixin_45709829 2021-07-12 16:46:57
  • 5星
    12.11MB weixin_41581125 2020-12-28 21:05:29
  • 5星
    1.52MB huawei222000 2013-01-03 15:40:50
  • 12.27MB songyufeishibyr 2020-07-03 23:38:42
  • 16.36MB weixin_44765402 2020-12-18 22:26:41
  • 14.05MB yxh505613923 2019-12-19 14:10:58
  • 2.43MB weixin_43975374 2020-06-22 19:15:21
  • 2.18MB sonya_ 2018-07-07 19:32:53
  • 718KB weixin_38542354 2021-09-17 16:49:53
  • 一、 题目 下图是模拟A公司的网络拓扑简图,在A公司各接入级的二层交换机(S1)按部门划分了VLAN,各接入级...二、 实验步骤 a) 网络拓扑图 b) 确定IP地址 c) 配置交换机 i. 配置Switch0,在Switch0上创建vlan10,

    一、 题目
    下图是模拟A公司的网络拓扑简图,在A公司各接入级的二层交换机(S1)按部门划分了VLAN,各接入级交换机连接到汇聚层交换机S2上,然后连接到公司出口路由器R1,R1通过DDN连接到互联网服务提供商ISP的路由器R2,最后连接到ISP的一台PC(用配有公网IP地址的PC4模拟),实现连接Internet。请对该公司的交换机和路由器进行相应的配置实现以下功能。
    在这里插入图片描述

    二、 实验步骤
    a) 网络拓扑图
    在这里插入图片描述

    b) 确定IP地址
    在这里插入图片描述

    c) 配置交换机
    i. 配置Switch0,在Switch0上创建vlan10,将Fa0/1-10加入到vlan10中
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    ii. 配置Switch0,在Switch0上创建vlan20,将Fa0/11-20加入到vlan20中
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    iii. 配置交换机switch1,在switch1上创建vlan30,将Fa0/1加入到vlan30中
    在这里插入图片描述
    在这里插入图片描述

    iv. Show vlan结果
    在这里插入图片描述

    d) 配置快速生成树,确保s1作为Root switch
    i. 在switch0上show spanning-tree
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    验证0/23和0/24接口状态
    在这里插入图片描述

    ii. 在switch1上show spanning-tree
    在这里插入图片描述在这里插入图片描述

    iii. 设置switch1生成树优先级,使其成为根节点
    在这里插入图片描述

    验证0/23和0/24接口状态
    在这里插入图片描述

    e) 相互ping情况
    PC0->PC1,PC0->PC2
    在这里插入图片描述

    PC2->PC1,PC2->PC3
    在这里插入图片描述

    PC3->PC1,PC3->PC2
    在这里插入图片描述

    f) 将switch1配置成路由器,配置成不同vlan接口
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述

    g) 查看switch1的路由表信息
    在这里插入图片描述

    h) 测试连通性
    PC0->PC1,PC0->PC2
    在这里插入图片描述

    PC2->PC1,PC2->PC3
    在这里插入图片描述

    PC3->PC1,PC3->PC2
    在这里插入图片描述

    i) 配置R0,R1的IP地址
    i. Router0
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    ii. Router1

    在这里插入图片描述
    在这里插入图片描述

    j) 配置Router0和Switch1的RIP协议
    i. Router0
    在这里插入图片描述
    在这里插入图片描述

    ii. Switch1
    在这里插入图片描述

    在这里插入图片描述

    k) 配置Router0和Switch1的ospf协议
    i. Router0

    在这里插入图片描述
    在这里插入图片描述

    ii. Router1
    在这里插入图片描述
    在这里插入图片描述

    l) 测试PC3和R1的S0/0/0接口的连通性
    在这里插入图片描述

    m) 默认路由重发布
    在这里插入图片描述

    n) 配置NAT
    在这里插入图片描述

    o) 测试连通性
    PC0->PC3
    在这里插入图片描述

    PC1->PC3
    在这里插入图片描述

    PC2->PC3

    在这里插入图片描述

    展开全文
    sen_77 2021-06-09 21:34:51
  • 166KB weixin_38542354 2021-09-17 16:56:00
  • 1.43MB weixin_44765402 2020-12-18 22:27:07
  • 0x8100,表示该帧载有 802.1Q 标记信息 标记控制信息(TCI): VLAN ID:12 比特,表示 VID,可用范围 1-4094 Priority:3 比特,表示优先级 Canonical format indicator:1 比特,表示总线型以太网、FDDI、令牌环 ...

    常用命令

    # 开机快速清空网络设备
    reset saved-configuration
    reboot
    
    show running-config   // 查看路由器运行配置
    

    VLAN 原理与配置

    VLAN 工作原理

    802.1Q 帧

    在这里插入图片描述

    • 在标准以太网帧头部增加 TAG 字段
      • 标记协议标识(TPID): 固定值 0x8100,表示该帧载有 802.1Q 标记信息
      • 标记控制信息(TCI):
        • VLAN ID:12 比特,表示 VID,可用范围 1-4094
        • Priority:3 比特,表示优先级
        • Canonical format indicator:1 比特,表示总线型以太网、FDDI、令牌环网

    端口类型

    • 交换机的两种端口类型
      • Access: 一般用于连接用户终端,承载标准的以太网帧,只能关联一个 VLAN
      • Trunk: 一般用于交换机互联,承载 802.1Q 帧 ,缺省关联交换机上配置的所有 VLAN
        在这里插入图片描述

    VLAN 配置

    • 创建 VLAN
      • Switch(config)# 为命令行的提示符
      • vlan 为命令名
      • vlan-id 为想要创建的 VLAN 的 ID
    Switch(config)# vlan vlan-id
    
    • 命名 VLAN
    Switch(config-vlan)# name vlan-name
    
    • 配置 Access 口
    步骤1:进入端口配置模式
    Swtich(config)# interface interface
    Swtich(config)# interface range interface-range	// 也可以同时配置多个端口
    
    步骤2:将端口模式设置为接入端口 (可选)
    Switch(config-if)# switchport mode access 
    
    步骤3:将端口添加到特定VLAN
    Switch(config-if)# switchport access vlan vlan-id
    
    • 配置 Trunk
    步骤1:进入端口配置模式
    Swtich(config)# interface interface
    
    步骤2:将端口模式设置为Trunk
    Switch(config-if)# switchport mode trunk
    
    步骤2:定义Trunk的VLAN列表
    Switch(config-if)# switchport trunk allowed vlan { all | [add | remove | except ]} vlan-list
    
    // 配置为 Trunk 端口,但是不包含 VLAN2
    Switch(config-if)# switchport trunk allowed vlan remove 2
    
    • 查看 / 删除 VLAN
    Swtich(config)# no vlan VLAN-id
    
    • 验证配置信息
    Swtich# show interfaces fastethernet0/20 switchport
    Swtich# show vlan
    

    网络拓扑

    在这里插入图片描述

    配置端系统的 IP 地址以及子网掩码

    在这里插入图片描述

    配置交换机 (下面是 Switch0 的配置,Switch1 的配置同理)

    Switch> en		// 进入特权模式
    Switch# configure terminal // 进入配置模式
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Switch(config)# vlan 10		// 添加 VLAN
    Switch(config-vlan)# name VLAN-10
    Switch(config-vlan)# vlan 20
    Switch(config-vlan)# name VLAN-20
    Switch(config-vlan)# end
    
    Switch# show vlan	// 查看 VLAN 配置情况
    
    VLAN Name                             Status    Ports
    ...
    10   VLAN-10                          active    
    20   VLAN-20                          active    
    ...
    
    Switch# configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Switch(config)# interface range f0/1-2	// 配置 access 接口
    Switch(config-if-range)# switchport access vlan 10
    Switch(config-if-range)#exit
    Switch(config)#interface range f0/3-4
    Switch(config-if-range)#switchport access vlan 20
    Switch(config-if-range)#exit
    
    Switch(config)#interface f0/5	// 配置 trunk 口
    Switch(config-if)#switchport mode trunk
    

    结果检验

    • 如下图所示,PC0 可以 ping 通 PC1 和 PC6,但 ping 不通 PC2
      在这里插入图片描述

    路由原理与静态路由

    • 静态路由配置命令
      • 例:ip route 192.168.10.0 255.255.255.0 172.16.2.1
      • 例:ip route 192.168.10.0 255.255.255.0 serial 1
    RSR(config)# ip route [网络号] [子网掩码] [下一跳路由器的IP地址/本地接口]
    
    • 配置默认路由
    router(config)# ip route 0.0.0.0 0.0.0.0 [转发路由器的IP地址/本地接口]
    
    • 查看路由表
    RSR# show ip route
    

    单臂路由配置

    参考:单臂路由的详解及简单配置

    • VLAN 能有效分割局域网,实现各网络区域之间的访问控制。但现实中,往往需要配置某些 VLAN 之间的互联互通
    • 单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同 VLAN 之间的互联互通
      • 逻辑子接口: 路由器的物理接口可以被划分成多个逻辑接口,这些被划分后的逻辑接口被形象的称为子接口。值得注意的是这些逻辑子接口不能被单独的开启或关闭,也就是说,当物理接口被开启或关闭时,所有的该接口的子接口也随之被开启或关闭
      • 子接口封装协议是 802.1Q 并指定对应的 VLAN,每个子接口配置 IP 地址作为网关
        在这里插入图片描述

    网络拓扑图
    在这里插入图片描述

    配置端设备的 IP 地址、子网掩码以及网关

    • 以 PC9 为例,设置它的 IP 地址和子网掩码,并将路由器的一个逻辑子接口作为它的默认网关
      在这里插入图片描述

    配置交换机

    Switch> en
    Switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    
    Switch(config)# vlan 10  // 创建vlan10端口和vlan20端口
    Switch(config-vlan)# name VLAN10
    Switch(config-vlan)# vlan 20
    Switch(config-vlan)# name VLAN20
    Switch(config-vlan)# exit
    
    Switch(config)# interface range f0/1-2  // 划分1-2为vlan10,3-4为vlan20
    Switch(config-if-range)# switchport access vlan 10
    
    Switch(config-if-range)# interface range f0/3-4
    Switch(config-if-range)# switchport access vlan 20
    Switch(config-if-range)# exit
    
    Switch(config)# interface f0/5 // 设置连接路由器的接口为Trunk类型
    Switch(config-if)# switchport mode trunk
    
    Switch# show vlan
    
    VLAN Name                             Status    Ports
    ...
    10   VLAN10                           active    Fa0/1, Fa0/2
    20   VLAN20                           active    Fa0/3, Fa0/4
    

    配置路由器

    Router> en			// 进入特权模式
    Router# conf t		// 进入配置模式
    Enter configuration commands, one per line. End with CNTL/Z.
    
    Router(config)# interface f0/0.1  				// 创建 f0/0.1 逻辑子接口 (属于物理接口 f0/0)
    Router(config-subif)# encapsulation dot1q 10 	// 设置该逻辑子接口接收 802.1Q 帧, 并指定接口所属 VLAN
    Router(config-subif)# ip address 192.168.1.1 255.255.255.0 // 设置逻辑子接口IP地址和地址掩码
    
    Router(config-subif)# interface f0/0.2
    Router(config-subif)# encapsulation dot1q 20
    Router(config-subif)# ip address 192.168.0.1 255.255.255.0 // 为子接口设置 IP 地址,作为对应 VLAN 内主机的网关
    
    Router(config-subif)# interface f0/0  // 开启f0/0接口和子接口
    Router(config-if)# no shutdown
    
    • 用 PC9 ping PC10,第一次 ping 时,第一个 ICMP 数据包超时,其他数据包正常发送。这是因为交换机在转发数据帧的时候,最开始不知道目的主机的 IP 地址,于是只能进行 ARP 广播请求,而不是 ping 请求,这一次的 ping 数据帧就被扔掉了,当知道了具体主机的 IP 地址后,之后就可以准确送达
    C:\>ping 192.168.0.2
    
    Pinging 192.168.0.2 with 32 bytes of data:
    
    Request timed out.
    Reply from 192.168.0.2: bytes=32 time<1ms TTL=127
    Reply from 192.168.0.2: bytes=32 time<1ms TTL=127
    Reply from 192.168.0.2: bytes=32 time<1ms TTL=127
    
    Ping statistics for 192.168.0.2:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms
    
    C:\>ping 192.168.0.2
    
    Pinging 192.168.0.2 with 32 bytes of data:
    
    Reply from 192.168.0.2: bytes=32 time<1ms TTL=127
    Reply from 192.168.0.2: bytes=32 time<1ms TTL=127
    Reply from 192.168.0.2: bytes=32 time=3ms TTL=127
    Reply from 192.168.0.2: bytes=32 time=27ms TTL=127
    
    Ping statistics for 192.168.0.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 27ms, Average = 7ms
    

    静态路由配置

    • 在上一部分的基础上,增加一台路由器和交换机,通过手工配置路由使数据报按照预定路径传送到指定目标网络
      • VLAN 10 可以和 VLAN 30 互通,但 VLAN 20 不能和 VLAN 30 互通

    网络拓扑
    在这里插入图片描述

    配置端设备 PC11, PC12 的 IP 地址、子网掩码、网关
    在这里插入图片描述
    配置交换机

    Switch>en
    Switch# conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Switch(config)# vlan 30
    Switch(config-vlan)# name VLAN30
    Switch(config-vlan)# exit
    
    Switch(config)# interface f0/2 
    Switch(config-if)#switchport access vlan 30
    Switch(config-if)#exit
    Switch(config)# interface f0/3 
    Switch(config-if)#switchport access vlan 30
    Switch(config-if)#exit
    
    Switch(config)#interface f0/1
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#end
    
    Switch# show vlan
    
    VLAN Name                             Status    Ports
    ...
    30   VLAN30                           active    Fa0/2
    ...
    

    配置路由器

    // 配置 R0
    Router(config)# interface f1/0
    Router(config-if)# no shutdown
    Router(config-if)# ip address 192.168.3.1 255.255.255.0
    Router(config-if)# exit
    Router(config)# ip route 192.168.2.0 255.255.255.0 192.168.3.2	// 设置静态路由
    
    // 显示 R0 路由表
    Router# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    C    192.168.0.0/24 is directly connected, FastEthernet0/0.2
    C    192.168.1.0/24 is directly connected, FastEthernet0/0.1
    S    192.168.2.0/24 [1/0] via 192.168.3.2
    C    192.168.3.0/24 is directly connected, FastEthernet1/0
    
    Router> en
    Router# conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Router(config)# interface f0/0
    Router(config-if)# ip address 192.168.3.2 255.255.255.0
    Router(config-if)# no shutdown
    Router(config-if)# exit
    Router(config)# ip route 192.168.1.0 255.255.255.0 192.168.3.1
    
    Router(config)# interface f1/0
    Router(config-if)# no shutdown
    
    Router(config-if)# interface f1/0.1
    Router(config-subif)# encapsulation dot1Q 30
    Router(config-subif)# ip address 192.168.2.1 255.255.255.0
    Router(config-subif)# end
    
    Router# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    S    192.168.1.0/24 [1/0] via 192.168.3.1
    C    192.168.2.0/24 is directly connected, FastEthernet1/0.1
    C    192.168.3.0/24 is directly connected, FastEthernet0/0
    

    结果验证

    • 用 PC11 ping PC9 可以 ping 通;用 PC11 ping PC10 不可以 ping 通,达到效果
    C:\>ping 192.168.1.2
    
    Pinging 192.168.1.2 with 32 bytes of data:
    
    Reply from 192.168.1.2: bytes=32 time=5ms TTL=126
    Reply from 192.168.1.2: bytes=32 time<1ms TTL=126
    Reply from 192.168.1.2: bytes=32 time<1ms TTL=126
    Reply from 192.168.1.2: bytes=32 time<1ms TTL=126
    
    Ping statistics for 192.168.1.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 5ms, Average = 1ms
    
    C:\>ping 192.168.0.2
    
    Pinging 192.168.0.2 with 32 bytes of data:
    
    Reply from 192.168.2.1: Destination host unreachable.
    Reply from 192.168.2.1: Destination host unreachable.
    Reply from 192.168.2.1: Destination host unreachable.
    Reply from 192.168.2.1: Destination host unreachable.
    
    Ping statistics for 192.168.0.2:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    

    OSPF 动态路由配置

    在这里插入图片描述

    • 首先配置 PC0 和 PC1 的 IP 地址、子网掩码以及网关
      在这里插入图片描述在这里插入图片描述
    • 设置路由器接口 IP 地址并设置使用 RIP 路由选择算法 (下面以 Router 0 为例,其他路由器的设置同理)
    Router>enable 
    Router#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#ip address 192.168.0.1 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface serial 0/0/1
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface serial 0/0/0
    Router(config-if)#ip address 192.168.3.1 255.255.255.0
    Router(config-if)#no shutdown 
    
    Router(config)#router ospf 1	// Enables OSPF routing and enters router configuration mode.
    Router(config-router)#network 192.168.0.0 0.0.0.255 area 0	// Defines an interface on which OSPF runs and defines the area ID for that interface.
    Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
    Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
    Router(config-router)#end
    
    • 当三个路由器配置完成后,查看路由表发现相关路由表项已经被自动填入了路由表
      • 下面以 Router0 的路由表为例, 可以看到,到达 192.168.1.0 的下一跳地址为 192.168.3.2,也就是 Router1。它的确选择的是最短路径
    // Router 0
    Router#show ip route 
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.0.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.0.1/32 is directly connected, GigabitEthernet0/0
    O    192.168.1.0/24 [110/65] via 192.168.3.2, 00:00:19, Serial0/0/0
         192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, Serial0/0/1
    L       192.168.2.1/32 is directly connected, Serial0/0/1
         192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.3.0/24 is directly connected, Serial0/0/0
    L       192.168.3.1/32 is directly connected, Serial0/0/0
    O    192.168.4.0/24 [110/128] via 192.168.3.2, 00:00:19, Serial0/0/0
                        [110/128] via 192.168.2.2, 00:00:19, Serial0/0/1
    
    • 用 PC0 ping PC1 发现 ping 通,说明实验成功
      在这里插入图片描述
    • 下面测试 OSPF 的动态性,删掉 Router0 和 Router1 之间的串口线,即刚才 Router 0 到 192.168.1.0/24 网络走的路线。可以看到,Router0 到 192.168.1.0/24 网络的下一跳路线变成了 192.168.2.2,即 Router2;PC0 仍然可以 ping192.168.1.2
      在这里插入图片描述
    // Router 0
    Router#show ip route 
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.0.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.0.1/32 is directly connected, GigabitEthernet0/0
    O    192.168.1.0/24 [110/129] via 192.168.2.2, 00:00:05, Serial0/0/1
         192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, Serial0/0/1
    L       192.168.2.1/32 is directly connected, Serial0/0/1
    O    192.168.4.0/24 [110/128] via 192.168.2.2, 00:00:05, Serial0/0/1
    

    在这里插入图片描述

    RIP 路由协议配置

    在这里插入图片描述

    • 首先配置 PC0 和 PC1 的 IP 地址、子网掩码以及网关
      在这里插入图片描述在这里插入图片描述
    • 设置路由器接口 IP 地址并设置使用 RIP 路由选择算法 (下面以 Router 0 为例,其他路由器的设置同理)
    Router>enable 
    Router#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#ip address 192.168.0.1 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface serial 0/0/1
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface serial 0/0/0
    Router(config-if)#ip address 192.168.3.1 255.255.255.0
    Router(config-if)#no shutdown 
    
    Router(config)#router rip
    Router(config-router)#network 192.168.0.0
    Router(config-router)#network 192.168.2.0
    Router(config-router)#network 192.168.3.0
    Router(config-router)#version 2
    Router(config-router)#end
    
    • 当三个路由器配置完成后,查看路由表发现相关路由表项已经被自动填入了路由表
      • 下面以 Router0 的路由表为例, 可以看到,到达 192.168.1.0 的下一跳地址为 192.168.3.2,也就是 Router1。它的确选择的是最短路径
    // Router 0
    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.0.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.0.1/32 is directly connected, GigabitEthernet0/0
    R    192.168.1.0/24 [120/1] via 192.168.3.2, 00:00:18, Serial0/0/0
         192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, Serial0/0/1
    L       192.168.2.1/32 is directly connected, Serial0/0/1
         192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.3.0/24 is directly connected, Serial0/0/0
    L       192.168.3.1/32 is directly connected, Serial0/0/0
    R    192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:13, Serial0/0/1
                        [120/1] via 192.168.3.2, 00:00:18, Serial0/0/0
    
    • 用 PC0 ping PC1 发现 ping 通,说明实验成功
      在这里插入图片描述
    • 下面测试 RIP 的动态性,删掉 Router0 和 Router1 之间的串口线,即刚才 Router 0 到 192.168.1.0/24 网络走的路线。可以看到,Router0 到 192.168.1.0/24 网络的下一跳路线变成了 192.168.2.2,即 Router2;PC0 仍然可以 ping192.168.1.2
      在这里插入图片描述
    // Router 0
    Router#show ip route 
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.0.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.0.1/32 is directly connected, GigabitEthernet0/0
    R    192.168.1.0/24 [120/2] via 192.168.2.2, 00:00:05, Serial0/0/1
         192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.2.0/24 is directly connected, Serial0/0/1
    L       192.168.2.1/32 is directly connected, Serial0/0/1
    R    192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:05, Serial0/0/1
    

    在这里插入图片描述

    IPv4 与 IPv6 协议互通

    • 要求完成不同 VLAN 下, IPv4 协议下局域网设备与 IPv6 协议下局域网终端之间的互通

    # 查看配置情况
    Router# show ipv6 interface
    Router# show ipv6 interface brief 
    

    双栈技术

    在这里插入图片描述

    6to4 隧道

    参考:IPv6和IPv4共存技术_双栈技术和6to4隧道技术

    • 6to4 隧道 使用的 IPv6 地址有固定的格式:
      • 地址前缀为 2002:: 开头,固定 2002: 后面拼接全球 IPv4 单播地址 (32 位),形成 48 位前缀,最后 64 位拼接任意方式形成的主机标识

    ISATAP 隧道

    参考:IPv6和IPv4共存技术_ISATAP隧道技术

    Intra-site (internal site) Automatic Tunnel Address Protocol

    ISATAP 隧道

    在这里插入图片描述

    • 在一个 IPv4 网络中,主机与 ISATAP 路由器之间创建一条使用 IPv6 地址的 ISATAP 隧道 (IPv6 数据报被封装在 IPv4 数据报中)。如此一来,这台 PC 就能够通过 ISATAP 路由器访问 IPv6 资源。同理,IPv6 主机也能通过 ISATAP 路由器来访问 ISATAP 主机,从而实现了 IPv4 协议下局域网设备与 IPv6 协议下局域网终端之间的互通
    • 条件:IPv4 中的 PC 主机需要支持 IPv4 和 IPv6 双栈协议,然后需要一台支持 ISATAP 的路由器。该路由器可以在网络中的任何位置,只要 PC 能通过 IPv4 地址 ping 通它

    ISATAP 隧道原理详解

    在这里插入图片描述

    • ISATAP 路由器配置
      • (1) 分配 IPv4 地址2.2.2.2/24。该地址用于在 IPv4 网络中与 ISATAP 主机通信
      • (2) 创建 tunnel 接口用于 ISATAP,该接口会根据 IPv4 地址产生一个 64 位的接口标识,并搭配 fe80:: 形成 tunnel 接口的 LinkLocal 地址,格式 : fe80::0000:5efe:x.x.x.x(其中的 0000:5efe 表明这是一个 IPv6 ISATAP 地址;x.x.x.x 为 IPv4 地址)
      • (3) 为 tunnel 接口配置一个全局单播 IPv6 地址,可以手工配置,也可以通过 +EUI64 的方式构成。这个 IPv6 地址是用来访问外部 IPv6 网络的
        • ISATAP uses a well-defined IPv6 address format composed of any unicast IPv6 prefix (/64), which can be link local, or global (including 6to4 prefixes), enabling IPv6 routing locally or on the Internet. The IPv4 address is encoded in the last 32 bits of the IPv6 address, enabling automatic IPv6-in-IPv4 tunneling.
          在这里插入图片描述
        • The ISATAP router provides standard router advertisement network configuration support for the ISATAP site. This feature allows clients to automatically configure themselves as they would do if they were connected to a GigabitEthernet or FastEthernet. It can also be configured to provide connectivity out of the site.

    地址后面的 64 bit (0000:5EFE:x.y.z.w) 称为 interface ID

    • ISATAP 主机配置
      • (1) ISATAP 主机配置的主要任务就是向 ISATAP 路由器获取它的 IPv6 地址。Win7 系统上默认安装了 IPv6 协议栈,默认就会有一个 ISATAP 的虚拟网卡。当给 PC 的物理网卡配置 IPv4 地址(如 1.1.1.1/24) 时,ISATAP 虚拟网卡会自动根据该地址计算出一个 LinkLocal 地址,格式如:fe80::0000:5efe:1.1.1.1
      • (2) 当主机上配置 ISATAP 后(用 netsh 命令,使其指向 ISATAP 路由器),向 ISATAP 路由器发送 RS 消息请求 IPv6 前缀 (注意:IPv4 数据报中封装的 IPv6 数据报的源地址和目的地址分别为 ISATAP 主机和 ISATAP 路由器的 link local 地址 (下图中 0200 应为 0000))
        在这里插入图片描述
      • (3) 这个 RS 消息会在 IPv4 网络中被路由,最终转到 ISATAP 路由器。这将使得路由器立即以一个 RA (Router Advertisement) 进行回应,这个 RA 消息里就包含 ISATAP 上所配置的那个 IPv6 全局单播地址的前缀
      • (4) PC 主机收到 RA 回应后,会拿出里头的 IPv6 前缀,随后在后面加上自己的 ISATAP 虚拟网卡的 64 位接口标识地址,构成一个 IPv6 全局单播地址,并被自动关联到 ISATAP 虚拟网卡上,同时产生一条默认路由,指向 ISATAP 路由器的 LinkLocal 地址
    • 至此,PC 主机就可以访问 IPv6 网络中的资源。它首先将 IPv6 数据包封装在 IPv4 数据包中,然后传给 ISATAP 路由器,再由 ISATAP 路由器解封装后转发给 IPv6 网络
      在这里插入图片描述

    在这里插入图片描述

    配置 IPv4 网络

    • 配置 PC2 的 IP 地址、子网掩码和网关
      在这里插入图片描述
    • 配置交换机 (添加 VLAN、设置 Access 和 Trunk 接口)
    // Switch0
    Switch>enable 
    Switch#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Switch(config)#vlan 10
    Switch(config-vlan)#name VLAN-10
    Switch(config-vlan)#exit
    
    Switch(config)#interface fastEthernet 0/1
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    	
    Switch(config)#interface fastEthernet 0/2
    Switch(config-if)#switchport mode trunk 
    Switch(config-if)#end
    
    • 配置路由器
    // Router 0
    Router>enable
    Router#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Router(config)#interface gigabitEthernet 0/0/0
    Router(config-if)#no shutdown 
    Router(config)#exit
    
    Router(config)#interface gigabitEthernet 0/0/0.1
    Router(config-subif)#encapsulation dot1Q 10
    Router(config-subif)#ip address 192.168.1.1 255.255.255.0
    Router(config-subif)#exit
    
    Router(config)#interface gigabitEthernet 0/0/1
    Router(config-if)#no shutdown 
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#end
    

    配置 IPv6 网络

    • 配置 PC1 的 IPV6 地址、网络掩码和默认网关
      在这里插入图片描述
    • 配置交换机
    // Switch1
    Switch>enable 
    Switch#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Switch(config)#vlan 20
    Switch(config-vlan)#name VLAN-20
    Switch(config-vlan)#exit
    
    Switch(config)#interface fastEthernet 0/2
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit
    
    Switch(config)#interface fastEthernet 0/1
    Switch(config-if)#switchport mode trunk 
    Switch(config-if)#end
    
    • 配置路由器
    // Router2
    Router#enable 
    Router#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Router(config)#ipv6 unicast-routing 
    
    Router(config)#interface gigabitEthernet 0/0/0
    Router(config-if)#ipv6 address 2001:2::2/64
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface gigabitEthernet 0/0/1
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface gigabitEthernet 0/0/1.1
    Router(config-subif)#encapsulation dot1Q 20
    Router(config-subif)#ipv6 address 2001:1::1/64
    Router(config-subif)#end
    

    ISATAP隧道配置

    // Router 1
    Router> enable 
    Router# configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    Router(config)#interface gigabitEthernet 0/0/0
    Router(config-if)#ip address 192.168.2.2 255.255.255.0
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#interface gigabitEthernet 0/0/1
    Router(config-if)#ipv6 address 2001:2::1/64
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    Router(config)#ipv6 unicast-routing 
    Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
    Router(config)#ipv6 route 2001:1::/64 2001:2::2
    
    Router(config)#interface tunnel 0					// Specifies a tunnel interface and number, and enters interface configuration mode.
    Router(config-if)#ipv6 address 2001:3::/64 eui-64	// Specifies the IPv6 address assigned to the interface and enables IPv6 processing on the interface
    Router(config-if)#no ipv6 nd ra suppress 			// Reenable the sending of IPv6 router advertisements to allow client auto configuration
    Router(config-if)#tunnel source gigabitEthernet 0/0/0	// Specifies the source interface type and number for the tunnel interface.
    Router(config-if)#tunnel mode ipv6ip isatap 
    Router(config-if)#no shutdown 
    Router(config-if)#exit
    
    // Router2
    Router(config)# ipv6 route 2001:3::/64 2001:2::1	// 设置完隧道后,IPv4 网络中使用隧道的主机使用的 IPv6 地址即为 2001:3::x.y.z.w,因此 R3 需要增设路由项
    

    配置 ISATAP 主机

    注:每次重新打开 .pkt 文件都需要重新进行配置 ISATAP 主机的操作

    // 可以发现 ISATAP 路由器
    C:\>netsh interface ipv6 show potentialrouters
    
    Idx  Router Address
    ---  ------------------------
    2     FE80::5EFE:C0A8:202
    
    // 向 ISATAP 路由器发送 RS 消息,请求 IPv6 全局单播地址的前缀
    C:\>netsh interface isatap set router 192.168.2.2
    Ok.
    
    // 使能 isatap
    C:\>netsh interface isatap set state enabled
    Ok.
    

    测试

    注:如果以上配置都正确无误但模拟测试仍不成功,可以关掉 Cisco 模拟器再打开一下,然后重复配置 ISATAP 主机的操作就行了。我就是在这边卡了好久

    • 查看 ISATAP 主机的 ISATAP 虚拟网卡配置
    C:\>ipconfig
    
    FastEthernet0 Connection:(default port)
    
       Connection-specific DNS Suffix..: 
       Link-local IPv6 Address.........: FE80::210:11FF:FE0C:558E
       IPv6 Address....................: ::
       IPv4 Address....................: 192.168.1.2
       Subnet Mask.....................: 255.255.255.0
       Default Gateway.................: FE80::5EFE:C0A8:202
                                         192.168.1.1
    
    Bluetooth Connection:
    
       Connection-specific DNS Suffix..: 
       Link-local IPv6 Address.........: ::
       IPv6 Address....................: ::
       IPv4 Address....................: 0.0.0.0
       Subnet Mask.....................: 0.0.0.0
       Default Gateway.................: ::
                                         0.0.0.0
    
    IsatapTunnel0 Connection:									// ISATAP 虚拟网卡
     --More-- 
       Connection-specific DNS Suffix..: 
       Link-local IPv6 Address.........: FE80::5EFE:C0A8:102	// Link local 地址,后 32 位为 IPv4 地址
       IPv6 Address....................: 2001:3::C0A8:102		// 获取的 IPv6 前缀加上自己的 IPv4 地址
       IPv4 Address....................: 0.0.0.0
       Subnet Mask.....................: 0.0.0.0
       Default Gateway.................: FE80::5EFE:C0A8:202	// 默认网关被自动设置为 ISATAP 路由器的 link local 地址
                                         0.0.0.0
    
    IsatapTunnel1 Connection:
    
       Connection-specific DNS Suffix..: 
       Link-local IPv6 Address.........: FE80::200:5EFE:0:0
       IPv6 Address....................: ::
       IPv4 Address....................: 0.0.0.0
       Subnet Mask.....................: 0.0.0.0
       Default Gateway.................: ::
                                         0.0.0.0
    
    • IPv4主机 (ISATAP 主机) ping IPv6主机
      在这里插入图片描述
    • IPv6 主机 ping IPv4 主机 (ISATAP 主机). 注意这里不是直接 ping IPv4 地址,而是 ping ISATAP 主机对应的 IPv6 地址 2001:3::C0A8:102,其中最后 32 位 C0A8:102 对应 ISATAP 主机的 IPv4 地址 192.168.1.2
      在这里插入图片描述

    无线网络配置及通讯

    • 每组发一个TPLINK 家用无线路由器,2 块无线网卡,要求每组电脑(6 台)全部同时联网

    在这里插入图片描述

    展开全文
    weixin_42437114 2021-03-23 23:43:26
  • 957KB qq_47888212 2021-11-18 17:34:44
  • 43.71MB weixin_43838915 2019-07-11 18:36:20
  • 实验1 以太网帧与ARP协议分析 实验内容 一、实验目的 分析以太网帧,MAC地址和ARP协议 二、实验环境 与因特网连接的计算机网络系统;主机操作系统为windows;使用Wireshark、IE等软件。 实验步骤 三、定义解析: ...

    首推文章:快速了解wireshark捕获界面原理

    点击这里click me

    实验1 以太网帧与ARP协议分析

    实验内容

    一、实验目的
    分析以太网帧,MAC地址和ARP协议
    二、实验环境
    与因特网连接的计算机网络系统;主机操作系统为windows;使用Wireshark、IE等软件。

    实验步骤

    三、定义解析:
    原存有疑问的加粗(已解决)
    IP地址用于标识因特网上每台主机,而端口号则用于区别在同一台主机上运行的不同网络应用程序。在链路层,有介质访问控制(Media Access Control,MAC)地址。在局域网中,每个网络设备必须有唯一的MAC地址。设备监听共享通信介质以获取目标MAC地址与自己相匹配的分组。Wireshark 能把MAC地址的组织标识转化为代表生产商的字符串,例如,00:06:5b:e3:4d:1a也能以Dell:e3:4d:1a显示,因为组织唯一标识符00:06:5b属于Dell。地址ff:ff:ff:ff:ff:ff是一个特殊的MAC地址,意味着数据应该广播到局域网的所有设备。
    在因特网上,IP地址用于主机间通信,无论它们是否属于同一局域网。同一局域网间主机间数据传输前,发送方首先要把目的IP地址转换成对应的MAC地址。这通过地址解析协议ARP实现。每台主机以ARP高速缓存形式维护一张已知IP分组就放在链路层帧的数据部分,而帧的目的地址将被设置为ARP高速缓存中找到的MAC地址。如果没有发现IP地址的转换项,那么本机将广播一个报文,要求具有此IP地址的主机用它的MAC地址作出响应。具有该IP地址的主机直接应答请求方,并且把新的映射项填入ARP高速缓存。
    发送分组到本地网外的主机,需要跨越一组独立的本地网,这些本地网通过称为网关或路由器的中间机器连接。网关有多个网络接口卡,用它们同时连接多个本地网。最初的发送者或源主机直接通过本地网发送数据到本地网关,网关转发数据报到其它网关,直到最后到达目的主机所在的本地网的网关。

    操作流程

    (一)、俘获和分析以太网帧
    (1)启动Wireshark 分组嗅探器
    (2)在浏览器地址栏中输入如下网址:
    http://www.sicnu.edu.cn 会出现四川师范大学主页。
    (4)停止分组俘获。在俘获分组列表中(listing of captured packets)中找到HTTP GET 信息和响应信息。(如果你无法俘获此分组,在Wireshark下打开文件名为ethernet–ethereal-trace-1的文件进行学习)*

    因为我没法(不会)打开,就只能自己琢磨了。(谁会的欢迎指教我,谢谢!)
    所以在这里,我就胡乱的在“标签”图案那里输入了http,然后,还是可以的。

    HTTP GET信息被封装在TCP分组中,TCP分组又被封装在IP数据报中,IP数据报又被封装在以太网帧中)。在分组明细窗口中展开Ethernet II信息(packet details window)。回答下面的问题:

    1、你所在的主机48-bit Ethernet 地址是多少?
    1)解读:找出你的主机的IP地址。
    2)方法:看向你的捕获分组界面,一共划分了三层,第二层可以展开。找到Ethernet II,……,展开它。展开Sourse:……,然后你会看到你的IP地址Address……。

    Ethernet:以太网
    Sourse:来源、出处

    2、Ethernet 帧中目的地址是多少?这个目的地址是www.sicnu.edu.cn的Ethernet 地址吗?
    1)解读:找出你主机浏览网站的目的地址。
    2)方法:确保你现在只打开了这一个网站,那么这个Ethernet地址确定。然后,按上一道题的方法,找到:Destination:……,展开他,找到Address:……。

    destination:目的地

    (二)、分析地址ARP协议
    (1)ARP Caching
    ARP协议用于将目的IP转换为对应的MAC地址。Arp命令用来观察和操作缓存中的内容。虽然arp命令和ARP有一样的名字,很容易混淆,但它们的作用是不同的。在命令提示符下输入arp -a可以看到在你所在电脑中ARP缓存中的内容。为了观察到你所在电脑发送和接收ARP信息,我们需要清除ARP缓存,否则你所在主机很容易找到已知IP和匹配的MAC地址。
    步骤如下:
    (1)清除ARP cache,具体做法:首先以管理员身份打开MSDOS环境,输入命令arp –d ;查看ARPcache,具体做法:首先以管理员身份打开MSDOS环境,输入命令arp -a;以管理员身份打开MSDOS环境方式:右键“命令提示符”,点击“以管理员方式打开”。
    (2)启动Wireshark分组俘获器
    (3)在浏览器地址栏中输入如下网址:
    www.sicnu.edu.cn,得到四川师范大学的主页,或者其他网页地址都可以。
    (4)停止分组俘获。
    (5)选择 Analyze->Enabled Protocols->取消IP选项->选择OK。

    第5步最好谨慎一点!或者直接在“标签”图案那里输入arp,我觉得是一样的。

    实验结果

    四、实验报告
    根据实验,回答下面问题:
    1.包含ARP 请求消息的以太帧的十六进制目的地和源地址是什么?

    1)目的地址:ff:ff:ff:ff:ff:ff(请求的时候是在广播,因为在捕捉之前我们以管理员的身份在“命令行提示符”中清除了连接记录,所以没有这个目的地址的MAC地址,广播)
    2)源地址:就是你的Sourse地址哈~

    2.给出两字节的帧类型域的十六进制值?

    1)帧类型就是你用的什么协议。
    2)两字节就是这协议写法、另一种命名(我这里说的不太标准,书上有解释,我后面再翻翻)。
    3)如图:
    协议类型对应字节

    :0x0800

    3.ARP 操作码出现在以太帧从最前端开始的第几字节?

    提示:操作码:Opcode

    1)解读:你的操作码在第几个字节,从0000(也就是第一排)位置的第一个字节(占两个位置,例如:00)开始数。
    2)如图:
    操作码在编码中的位置

    :在第21个字节处出现

    4.当一个ARP 响应被给出时这个以太帧ARP 载荷部分的操作码字段的值是多少?

    1)解读:得到目的地址响应后的操作码字段,值为多少。
    2)方法:同上一题。只不过你最开始要找到捕获分组列表中的Info列中含有(reply)的行。点击它。因为是值,所以你只需要在把阴影部分的0002前加上0x表示十六进制。
    :0x0002

    响应:reply

    5.和早先请求的IP 地址相应的以太网地址在ARP 响应中位于何处?

    1)解读:找你访问网站的IP地址的MAC地址
    2)方法:同前几题一样,逐个展开,根据英文,翻译一下吧!
    :第23到28个字节处

    6.包含ARP 响应消息的以太帧的十六进制目的地和源地址是什么?

    1)解读:找你访问的网址reply响应你的请求的目的地址和源地址

    目的地址:ff:ff:ff:ff:ff:ff(我这里有错,一般如果真的成功了的话,这里应该是一段具体的地址码,而不是广播)
    源地址:访问的网址的地址。现在他作为请求端给你/其他接口,发送请求/回复

    7.如果有计算机在网络上发出ARP 请求,为什么不一定有ARP 回复?

    有可能该IP对应的网络设备没有开启或者不存在;.

    已证实回答

    遇到问题及解答

    点号后的是增加的内容
    //表示不重要或者未证实

    1. MAC与IP地址的区别:

    MAC地址:
    (1)本质:接口的名称,站的名字,主机的标识符;不是地理位置;不等于接口(在路由器的多个接口中:接口是一台计算机)只是一个名称
    (2)midear:说英文:Hardware Address就显而易见了。所以在传输过程中,遇到路由器(左右)接口,会导致源地址和目的地址改变。(一段线上的两端名字不一样,一条线上有多条段)。由硬件实现。
    (3)唯一性:固化在每一个适配器的ROM中;一个主机或者路由器可以有多个网卡(适配器),而每一个网卡中的MAC地址不一样。
    (4)EUI-48:扩展的唯一标识符
    OUT:这个电脑的生产商,什么牌子,比如:Dell;
    +//这里可以不看了:
    扩展标识符:主机号

    前三个字节后三个字节
    OUT组织唯一标识符扩展标识符

    IP地址:
    (1)本质:互联网协议地址,逻辑地址,用于屏蔽物理地址差异。
    (2)midear:有软件实现的,用于网络层及其上层使用的地址;在传输中,,所以IP地址不变。接入了多个网络,网络号一定不同,主机号不变。
    (3)组成:
    网络号:代表这个主机(或路由器)在哪一个网中;

    网络号主机号
    记作IP地址 ::= {<网络号>,<主机号>}

    已解决问题

    提问

    1.主机号和MAC是一样的吗?

    主机号:标志该主机(或路由器),一台主机号在它前面的网络号所指明的网络范围内必须是唯一的。它是这台计算机在这个局域网内的编号,只起编号作用而已。
    MAC:接口的名称、站的名称,标识符
    可能答案:
    //错:是。书P121(2):实际上IP地址是标志一台主机(或路由器)和一条链路的接口。
    正解:不是。书P126:B适配器坏了,换了适配器后导致接口名称换了,硬件地址换了;如果主机号是站的名字(接口名称),那么A在进行广播时找不到才对。

    • 而他成功的找到了!所以编号没变,变得只是适配器,只是适配器中固化的MAC地址。

    2.端口号与IP地址的联系

    端口号:用于区别在同一台主机上运行的不同网络应用程序;

    • !!!这章我还没学,据说是数据链路层的。

    3.每个网络设备必须有唯一的MAC地址?

    书P94:如果连接在局域网上的主机(或路由器)安装有多个适配器,那么这样的主机或路由器就有多个地址(接口)。

    • 这么说吧,用路由器来说,他有多个接口,每一个接口就是一个计算机,然一个计算机就是一个网络设备,所以。每个计算机必须有唯一的MAC地址,而我们又可以有多个计算机,也就会有多个MAC地址。

    MAC:网卡

    4.网络号到底是指什么?

    一个网络是指具有相同的网络号net-id的主机的集合。用转发器或网桥连接起来的若干局域网仍为一个网络,具有相同的网络号。具有不同的网络号的局域网必须使用路由器进行互连。
    !问!网络号可以是你主机现在接入的这个网,比如说:川师的网:sicnu;?

    • 是的,网络号就是相当于把一个局域网再分为多个子网络,每个子网络起一个网络名字。

    5."选择 Analyze->Enabled Protocols->取消IP选项"干嘛?

    在“分析—启用的协议”中取消IP协议会导致?
    IP协议在网络层使用,再使用ARP地址解析协议??

    6.IP与MAC区别

    一个只在乎表面,一个要看内在;先看表面,再看内在。

    • IP是网络层的,你只用管他的在网络层中应用。
    • MAC是与接口有关的,那么你在传输的时候,找物理(看得见摸得着)的接口,就相当于再找MAC

    7.为什么一会儿出现request,一会儿出现reply?

    为什么不能同时出现?

    • 因为先要请求,找到对方后对方才能给你回复、响应。可以参考“客户-服务机”方式

    实验总结及心得

    1.实验太难了,球球大佬带带!!
    2.问题太多了,请指教!!
    3.看书很重要!!要理解!!

    • 多问老师,虽然在他眼里你是一个上课不听讲的学生,哈哈哈
    展开全文
    qq_56170439 2021-11-04 19:04:59
  • 实验一 Socket编程实验1.1环境开发环境:Windows 10 64 位,Intel Core i5-7300HQ CPU, 8GB 内存1.1. 1开发平台Microsoft Visual Studio Community 2017 结合 QT5.9.21.1.2运行平台硬件配置:Windows 10 64 位,Intel ...

    实验一 Socket编程实验

    1.1环境

    开发环境:Windows 10 64 位,Intel Core i5-7300HQ CPU, 8GB 内存

    1.1. 1开发平台

    Microsoft Visual Studio Community 2017 结合 QT5.9.2

    1.1.2运行平台

    硬件配置:Windows 10 64 位,Intel Core i5-7300HQ CPU, 8GB 内存

    系统软件组件:Windows SDK 10. 0. 16299. 0

    第三方组件:QT5. 9. 2 MSVC 2015

    1.2系统功能需求

    基于TCP和UDP协议实现一个即时通讯工具,具体功能要求包括:

    工具包括服务器端和客户端;

    具备用户注册、登录、找回密码功能(基于TCP协议);

    两个用户如果同时在线,采用点到点通信方式进行聊天,信息不需要通过服

    务器中转,服务器也不保存(基于TCP协议);

    支持离线消息(基于TCP协议);

    支持点到点可靠文件传输(基于UDP协议);

    存储在服务器端的数据需要进行强加密;

    支持不少于两组用户同时在线交流和传输文件;

    文件传输具有良好的性能,能够充分利用网路带宽;

    人机交互友好,软件易用性强。

    1. 3系统设计

    1.3.1系统架构

    本即时通讯系统分为两大部分,分别为用户端和服务器端。用户端为用户提 供交互界面,使用户能够进行用户注册、登录、找回密码、点对点聊天、发送离 线消息、传输文件等操作。服务器则为这些操作提供服务支持,包括存储用户数 据、为用户提供好友列表、存放离线消息和匹配用户等等。

    1.3.2功能模块划分

    系统功能共分为6大模块,其中包括用户注册、用户登入、找回密码、好友 列表、点对点聊天、传输文件。其中点对点聊天支持实时在线聊天和离线消息。 此外,用户登录和注册时向服务器发送的密码。系统功能模块图如图1.1.所示

    图1.1 socket编程功能模块

    用户注册模块

    这一模块实现用户的注册功能。当用户填写正确信息后,注册内容将会被传 到服务器。此时服务器将会把用户的注册内容与用户数据库屮的内容进行比较。 如果用户名或邮箱与数据库中有重复,则提示注册失败。如果不重复,则将新用 户数据存入数据库,并在客户端提示用户,注册成功。

    用户登入模块

    这一模块实现用户的登录功能。将用户输入的账号和密码与服务器数据库中 的内容进行兀配。如果用户输入的账号存在,且账号和密码与数据库中的一致, 那么用户登入成功。否则,提示登入失败。

    找回密码模块

    这一模块实现用户的密码找回功能。当用户选择“找回密码”操作后,用户 将进入找冋密码页面。在找冋密码页面,用户需要输入用户名和注册吋的邮箱。 输入的内容会发送到服务器与服务器数据库中的用户信息进行比对。如果比对无 误,将向用户页面呈递密码信息,否则将提示“找回密码失败”。

    好友列表模块

    当用户成功登入后,将显示好友列表界面。好友列表界面会根据服务器的数 据库中的用户数据而提供所有用户名的列表(相当于每个注册者会成为所有人的 好友)。用户点击相应的用户名,即可与对应的用户进行聊天。

    点对点聊天模块

    这一模块实现用户之间的聊天功能。如果双方用户均在线,那么将直接实现 点对点的聊天。如果只有一方用户在线,那么发送的信息会暂存到服务器;待另 一用户上线后,服务器再将暂存的信息发冋该用户。

    传输文件模块

    在建立点对点的连接后,一方用户可以向另一方用户发送文件。当发送方提 交发送文件表单时,接收方会收到是否接收的表单。当接收方确认接收后,文件 即会开始向接收方进行传输,直至传输完成。

    1.3.3应用层协议设计

    用户注册、登入、找回密码、点对点聊天以及离线消息的发送均采用TCP 协议。使用QT库中的QTcpSocket/QTcpServer库进行实现。

    点对点的文件传输采用的是udp协议,使用QT库屮的QUdpSocket实现。 为了保证文件传输的可靠性,本程序采用了停等协议和超时重传的机制。

    1.4系统实现

    服务器与客户端间的连接与交流

    服务器和客户端的连接是建立在TcpServer和TcpSocket的基础上的。在服 务器端,一个TcpServer监听着来自固定端口的所有ip地址的连接;而在客户端, 则在开启时,就向服务器所在IP和端口发起连接请求。在服务器正常工作的情 况下,客户端和服务器端就建立了相应的连接。

    在连接建立后,客户端和服务器端的相互交流就可以用TcpSocket来进行。 TcpSocket->write()BP可发送相应的报文。为了使不同的报文得到不同方式的处理, 报文的头部会加上一些前缀来进行区别。具体的前缀与功能如表1.1所示。

    表1.1 Tcp报文头部的前缀及意义

    头部前缀

    发送方

    意义

    REGE

    客户端

    向服务器发送注册用户的请求

    LOGIN

    客户端

    展开全文
    weixin_42542669 2021-07-10 00:51:43
  • 5星
    2.73MB u010757249 2015-04-19 12:06:59
  • 1.2MB weixin_42217699 2018-11-27 20:39:07
  • Grpoison_ 2018-06-01 14:15:44
  • weixin_39933356 2021-06-25 02:33:48
  • weixin_34684094 2021-07-05 03:09:46
  • 5星
    611KB yuanbohx 2012-01-03 09:37:20
  • 373KB jal960 2010-07-28 17:28:07
  • weixin_31759829 2021-07-27 08:15:41
  • weixin_30229705 2021-07-16 02:28:46
  • 5星
    1.46MB chenguangleeee 2009-12-08 12:19:37
  • weixin_42473904 2020-12-29 23:40:07
  • 1.03MB qq_42257666 2021-08-15 20:53:33
  • 5星
    1.29MB buyanyu4689 2013-10-14 12:35:01
  • weixin_42320061 2021-07-06 05:17:51
  • weixin_42121272 2021-06-25 13:32:08

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,999
精华内容 6,399
关键字:

计网实验报告

友情链接: UDF手册.zip