精华内容
下载资源
问答
  • 三层交换机连接路由器

    千次阅读 2015-02-26 15:35:49
    三层交换机确实具有一定的“路由”功能,它可以实现不同的子网连接功能,但是特别注意的问题是,它的路由功能相对路由器来说还是要弱许多的,而且三层交换机只能使用一个网络。 而且通常只是局域网子网之间的互联...

    三层交换机确实具有一定的“路由”功能,它可以实现不同的子网连接功能,但是特别注意的问题是,它的路由功能相对路由器来说还是要弱许多的,而且三层交换机只能使用一个网络。
    而且通常只是局域网子网之间的互联,并不能把局域网与广域网,或者互联网连接起来,因为三层交换机所支持的路由协议非常有限,毕竟这不是它的主要功能。我们知道,在局域网上,二层的交换机通过源MAC 地址来标识数据包的发送者,根据目的MAC 地址来转发数据包。
    对于一个目的地址不在本局域网上的数据包,二层交换机不可能直接把它送到目的地,需要通过路由设备(比如传统的路由器)来转发,这时就要把交换机连接到路由设备上。如果把交换机的缺省网关设置为路由设备的IP 地址,交换机会把需要经过路由转发的包送到路由设备上。
    路由设备检查数据包的目的地址和自己的路由表,如果在路由表中找到转发路径,路由设备把该数据包转发到其它的网段上,否则,丢弃该数据包。专用路由器昂贵、复杂、速度慢、易成为网络瓶颈,因为它要分析所有的广播包并转发其中的一部分,还要和其它的路由器交换路由信息,而且这些处理过程都是由CPU 来处理的(不是专用的ASIC )。
    第三层交换机既能像二层交换机那样通过MAC 地址来标识转发数据包,也能像传统路由器那样在两个网段之间进行路由转发。传统路由器采用软件来维护路由表,而三层交换机是通过专用的ASIC芯片来处理路由转发的。与传统路由器相比,第三层交换机的路由速度一般要快十倍或数十倍。
     
    大家都知道,路由器可以连接企业局域网和广域网(如因特网),但却忽略了一路由器的另一个应用,那就是它的局域网连接功能。路由器的广域网连接可参见拓扑图图和三层交换机的路由连接图。
    路由器的作用因不同的路由器类型而定,我们常说的路由器通常是指边界路由器,就是位于不同类型网络的边界,如拓扑图图和三层交换机的路由连接图所示。还有一种路由器。
    它设计的目的就不是用于不同类型网络的连接,而是用于同为局域网的不同局域网或不同子网之间的连接,这就是“中间节点路由器”。它的网络结构如下图所示。它与三层交换机的路由连接图相比,只是用中间节点路由器接替了原来的三层交换机。
    “边界路由器”处于网络边界的边缘或末端,用于不同网络路由器的连接,这也是目前大多数路由器的类型。如前面介绍的互联网接入路由器和后面要介绍的VPN路由器都属于边界路由器。这类路由器所支持的网络协议和路由协议比较广,背板带宽非常高,具有较高的吞吐能力,以满足各类不同类型网络(包括局域网和广域网)的互联。
    而“中间节点路由器”则处于局域网的内部,通常用于连接不同局域网,起到一个数据转发的桥梁作用。中间节点路由器更注重MAC地址的记忆能,要求较大的缓存。因为所连接的网络基本上是局域网,所以所支持的网络协议比较单一,背板带宽也较小,这些都是为了获得最高的性价比,适应一般企业的随能力。
    它与三层交换机的路由功能相比,在路由功能上肯定比三层交换机的强,但在局域网这种数据交换频繁的网络中,采用中间节点路由器来进行局域网的连接,网络性能可能会受到一定影响。
    总的来说,如果所连接的局域网或子网较多、网络互访不是很频繁、路由较复杂的环境中,最好采用中间节点路由器连接方案。但在少数子网连接、网络间互访频繁的环境中,最好还是采用三层交换机连接方式。而且还可节省设备投资,因为三层交换机不仅具有满足应用需求的路由功能,还可当作交换机用,连接许多网络设备。

     原文地址:http://www.pw0.cn/article/ruodian/20150237645.html

    展开全文
  • 1.在交换机端配置到路由器的默认路由 [R1]ip route-static 0.0.0.0 0 next-hop 2.在路由器配置静态路由到...3.交换机连接路由器接口配置成access,该接口属于与路由器连接的那个网段的vlan(vlanif对应的vlan) ...

    1.在交换机端配置到路由器的默认路由 [R1]ip route-static 0.0.0.0 0 next-hop
    2.在路由器配置静态路由到交换机各网段的静态路由
    3.交换机连接路由器接口配置成access,该接口属于与路由器连接的那个网段的vlan(vlanif对应的vlan)

    展开全文
  • 基础配置参考: PacketTracer---静态路由: https://blog.csdn.net/qq_40163937/article/details/88957269 Cisco Packet Tracer---三层交换机实现VLAN间路由: ... 三层交换机连...

    基础配置参考:

    PacketTracer---静态路由:

    https://blog.csdn.net/qq_40163937/article/details/88957269

    Cisco Packet Tracer---三层交换机实现VLAN间路由:

    https://blog.csdn.net/qq_40163937/article/details/88818650

    三层交换机连接路由器配置

    1.将端口配置为trunk全通

    Switch>ena     //进入配置

    Switch#conf t   //进入全局配置

    Switch(config)#int fa0/1    //进入fa0/1端口

    Switch(config-if)#switchport mode trunk   //设置为串口trunk模式

    Switch(config-if)#switchport trunk allowed vlan all   //设置为VLAN全通

    Switch(config-if)#ex   //退出

    Switch(config)#int fa0/2    //进入fa0/1端口

    Switch(config-if)#switchport mode trunk    //设置为串口trunk模式

    Switch(config-if)#switchport trunk allowed vlan all    //设置为VLAN全通

    Switch(config-if)#ex   //退出

    Switch(config)#int fa0/3   //进入fa0/1端口

    Switch(config-if)#switchport mode trunk    //设置为串口trunk模式

    Switch(config-if)#switchport trunk allowed vlan all    ///设置为VLAN全通

    Switch(config-if)#ex  //退出

    2.在VLAN中添加主机网关ip

    Switch(config)#vlan 2  //创建进入VLAN2

    Switch(config-if)#ip address 192.168.2.1 255.255.255.0   //在VLAN2中添加主机网关ip

    Switch(config-vlan)#exit  //退出

    Switch(config)#vlan 3  //创建进入VLAN3

    Switch(config-if)#ip address 192.168.3.1 255.255.255.0   //在VLAN3中添加主机网关ip

    Switch(config-vlan)#exit///退出

    Switch(config)#int vlan 1 //进入VLAN1这是交换机默认全通VLAN,不需要创建

    Switch(config-if)#ip address 192.168.4.2 255.255.255.0   //重:此次添加的是与路由器相连网段的ip,此处应当作路由与路由相连中的端口ip,用于路由表中下一跳。

    Switch(config-if)#ex //退出VLAN1

    Switch(config)#ex  //退出全局配置

    Switch#show ip rou   //查询三层交换机路由表

    C    192.168.2.0/24 is directly connected, Vlan2   //自动生成相邻的路由

    C    192.168.3.0/24 is directly connected, Vlan3   //自动生成相邻的路由

    C    192.168.4.0/24 is directly connected, Vlan1   //自动生成相邻的路由

    Switch#conf t  //进入全局配置

    Switch(config)#ip route 192.168.5.0 255.255.255.0 192.168.4.1   //添加静态路由

    Switch(config)#ip route 192.168.6.0 255.255.255.0 192.168.4.1   //添加静态路由

    Switch(config)#

    3.测试:

    此文核心在三层交换机用来下一跳的ip写在全通的VLAN1中,并且需要对路由表进行添加,这在二层路由中是没有的。

    https://www.lanzous.com/i3nsrof

     

    展开全文
  • 华为三层交换机和路由器建立OSPF邻居利用三层交换的路由功能,把三层交换看成路由器。它与两台路由器建立ospf的区别是,交换机连接路由器的接口设置access链路模式,建立一个vlan,给vlan设置ip地址。拓扑和命令SW1...

    华为三层交换机和路由器建立OSPF邻居

    利用三层交换的路由功能,把三层交换看成路由器。

    它与两台路由器建立ospf的区别是,交换机连接路由器的接口设置access链路模式,建立一个vlan,给vlan设置ip地址。

    拓扑和命令

    e471de6f3d9f2684ee8f51d8d1fcab50.png

    SW1

    [sw1]vlan batch 10 20

    [sw1]int vlan10

    [sw1-Vlanif10]ip a 192.168.10.1 24

    [sw1-Vlanif10]int g0/0/1

    [sw1-GigabitEthernet0/0/1]p l a

    [sw1-GigabitEthernet0/0/1]p d v 10

    [sw1]ospf 1 router-id 1.1.1.1

    [sw1-ospf-1]area 0

    [sw1-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255

    SW2

    [SW2]vlan batch 10 20

    [SW2]int vlan20

    [SW2-Vlanif20]ip a 192.168.20.1 24

    [SW2]int g0/0/1

    [SW2-GigabitEthernet0/0/1]p l a

    [SW2-GigabitEthernet0/0/1]p d v 20

    [SW2]ospf 1 router-id 2.2.2.2

    [SW2-ospf-1]area 0

    [SW2-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255

    AR

    [AR]int g0/0/0

    [AR-GigabitEthernet0/0/0]ip a 192.168.10.2 24

    [AR]int g0/0/1

    [AR-GigabitEthernet0/0/1]ip a 192.168.20.2 24

    [AR]ospf 1 router-id 3.3.3.3

    [AR-ospf-1]area 0

    [AR-ospf-1-area-0.0.0.0]network 192.168.10.0 0.0.0.255

    [AR-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255

    查看ospf邻居和路由表

    查看此设备ospf邻居

    display ospf peer brief

    查看路由表

    display ip routing-table

    235de061f7ab2bd87854d8baa316be14.png

    338bc6400dff047540b6614a3493cc59.png

    f3add46521ae255cb85863c1c9ee9eb3.png

    b4da43da26d60e3c3b7438ff748324c6.png

    进入sw1 ping 192.168.20.1,能ping通,成功。

    展开全文
  • 三层交换机简介三层交换机是具有路由功能的交换机,由于路由属于OSI模型中第三层网络层的功能,所以称为三层交换机三层交换机既可以工作在二层也可以工作在三层,可以部署在接入层,也可以部署在汇聚层,作为用户...
  • 三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。 ...
  • 针对二层交换机和路由器互连:可使用单臂路由,二层交换机连接路由器的口设置成trunk口,路由器进入子端口,封装802.1q,配上VlanIP地址。 针对三层交换机和路由器互连:可把交换机当成路由器使用,给连接路由器的...
  • eNSP基础实验交换机连接路由器(二层交换机和三层交换机)一、实验题目二、实验拓扑图三、实验内容(一)二层交换配置(二)三层交换机配置五、实验总结 一、实验题目 一台交换机,一台路由器,两台电脑。使得两台...
  • 三层交换机路由器连接(sisco)

    千次阅读 2009-12-26 21:16:00
    三层交换机路由器连接(sisco)网络拓朴如下:三层交换机路由器连接一般要求设置交换机的连接端口工作在三层模式。 路由器的参考设置如下(可以不设置ospf):router#conf trouter(config)#int f0/1router...
  • 但是三层交换机的主要功能仍是数据交换,它的路由功能通常比较简单,因为它所面对的主要是简单的局域网连接,路由路径远没有路由器那么复杂,它用在局域网中的主要用途还是提供快速数据交换功能,满足局域网数据交换...
  • 三层交换机路由器连接三层交换机路由器连接一般要求设置交换机的连接端口工作在三层模式。 这个实验接上一个实验,交换机和计算机的基本设置不变。 上一个实验:XFBAY学习笔记=++=实验十五 三层交换...
  • 三层交换机所能提供的路由功能和快速转发能力使得很多新人网工自然而然的产生了一个疑问,这两者究竟有什么区别?这个问题的实在是答案在网上汗牛充栋,且答案也都相对详尽。笔者在参考总结各路大神资料的基础上力争...
  • 三层交换机:位于网络层,可以处理不同IP子网之间的数据交换,即具有简单传统路由的功能,又有二层交换的速度,适于大型局域网内的数据路由与交换。 路由器:主要是用于不同类型的网络之间。它最主要的功能就是路由...
  • 一、实验要求:1、 在交换机上创建VLAN10及VLAN20;将连接PC1的接口分配到VLAN10;...2、 在交换机上创建VLAN200并配置vlanif 200,作为与路由器对接的VLAN及三层接口;3、 在交换机路由器上完成静...
  • 一、实验要求:1、 在交换机上创建VLAN10及VLAN20;将连接PC1的接口分配到VLAN10;...2、 在交换机上创建VLAN200并配置vlanif 200,作为与路由器对接的VLAN及三层接口;3、 在交换机路由器上完成静...
  • 重点:三层交换机路由器配置(理解它的目的,主要是敲命令)实验步骤一:二层交换机的配置:在三个二层交换机上分别划出两VLAN,并将二层交换机上与三层交换或路由器上的接线设置为trunk接口实验步骤二:三层交换机...
  • 交换机路由器之间的链路连接的方法: 方法一:设置vlanif 和 静态路由 方法二:在交换机路由器上运行ospf 拓扑图如下: 方法一配置命令: sw1 interface GigabitEthernet0/0/1 port link-type access port...
  • 在本次网络综合实验中,需要涉及的知识点主要有,进行服务器的配置,三层交换机的VLAN的划分及通信,以及与路由器连接等等。
  • 一、交换机的工作原理 当交换机收到数据时,它会...某一数据帧需要转发时,交换机根据该数据帧的目的MAC地址来查找MAC地址表,从而得到该地址对应的端口,即知道具有该MAC地址的设备是连接交换机的哪个端口上,然...
  • 交换机的工作原理当交换机收到数据时,它会...某一数据帧需要转发时,交换机根据该数据帧的目的MAC地址来查找MAC地址表,从而得到该地址对应的端口,即知道具有该MAC地址的设备是连接交换机的哪个端口上,然后交换...
  • 交换机的工作原理当交换机收到数据时,它会检查它的...某一数据帧需要转发时,交换机根据该数据帧的目的MAC地址来查找MAC地址表,从而得到该地址对应的端口,即知道具有该MAC地址的设备是连接交换机的哪个端口上...
  • 集线器,二层交换机,路由器三层交换机

    千次阅读 多人点赞 2013-04-15 15:09:51
    集线器:以前10M共享式以太网专用,现在用得比较少,只工作在物理,端口与主机之间使用半双工通信,一般来说无论物理连接是总线型还是星型,它的逻辑连接都是总线型的,只要其中一台主机发出信息,集线器会把信息...
  • 设计以下网络:两个部门各使用一台交换机连接,然后连接到总交换机,再通过路由器与外网以及其他部门网络相连。为了控制网络上的广播风暴,增加网络的安全性,在交换机上需要设置VLAN,在路由器与交换机之间需要设置...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 885
精华内容 354
关键字:

三层交换机连接路由器