精华内容
下载资源
问答
  • 这是我制作的关于华为ENSP的MSTPVRRP组网的基本配置文件
  • 4.需要合理配置MSTP,ETH-TRUNK,VRRP使网络达到最佳可用性 5.配置动态路由协议,使全网互通,私有地址不允许出现在ISP中 要求:AR3不允许配置任何路由 6.将PC5配置成DHCP服务器,所有的PC都需要通过DHCP自动获取地址...

    要求

    1.规划拓扑图
    2.合理配置IP地址
    3.如图规划VLAN信息,PC1/PC2/PC3属于VLAN123,AR1属于VLAN111
    4.需要合理配置MSTP,ETH-TRUNK,VRRP使网络达到最佳可用性
    5.配置动态路由协议,使全网互通,私有地址不允许出现在ISP中
    要求:AR3不允许配置任何路由
    6.将PC5配置成DHCP服务器,所有的PC都需要通过DHCP自动获取地址。
    7.在AR3上配置telnet功能,使AR1可以使用huawei/123456登陆到AR1上进行远程管理
    8.只允许AR1 TELNET到AR3,其余所有设备都不能TELNET到AR3

    第一步 ,搭建拓扑图

    在这里插入图片描述

    合理规划ip地址

    首先配置vlan 111 和123 然后划分两个网段 10.1.1.0 /24 20.1.1.0 /24 lsw1 配置自己的ip地址 vlan111 是20.1.1.252 vlan123 为 10.1.1.252 。 lsw2 vlan111 20.1.1.253 vlan 123 为10.1.1.253 。虚拟网关分别是 10.1.1.254 20.1.1.254 。
    路由器上面的接口ip 我没有演示。

    规划vlan 111 123 PC1/PC2/PC3属于VLAN123,AR1属于VLAN111

    lsw1 配置,先配置trunk 然后把1和2接口链路聚合,lsw2 同理

    interface GigabitEthernet0/0/3  # 进入接口
     port link-type trunk  # 配置接口模式
     port trunk allow-pass vlan 111 123
    interface GigabitEthernet0/0/4
     port link-type trunk
    interface GigabitEthernet0/0/5
     port link-type trunk  
     配置ospf的时候 需要在再划分一个vlan 我这里用vlan 1 为了给5 口配置ip地址 
     interface Vlanif1
     ip address 40.1.1.2 255.255.255.0
     配置lacp
     port trunk allow-pass vlan 111 123
     interface Eth-Trunk 1      #将物理接口绑定到eth-trunk中
     mode lacp-static  # 模式lacp-static
    trunkport GigabitEthernet 0/0/1 0/0/3  # 将两个接口变成一个接口
    

    sw3 配置,lsw4 同理 ,交换机和交换机用trunk 交换机和pc 用access 口 交换机和路由器也是trunk

    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 111 123
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 111 123
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 111
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 123
    

    配置mstp多生成树协议,首先交换机本身默认的就是mstp 模式 ,每一个交换机都需要打这个

    stp region-configuration
    region-name huawei  
    revision-level 2021 
    instance 1 vlan 111
    instance 2 vlan 123
    active region-configuration  # 不打这一句配置就没有写进去
    quit
    stp mode mstp
    stp instance 1 root primary  #在第一个交换机里面是主根
    stp instance 2 root secondary # 在第二个交换机是备跟
    stp instance 2 root primary #  在第二个交换机是主
    stp instance 1 root secondary # 在第一个交换机是备
    

    现在需要配置vrrp 虚拟网关

    lsw1 
     interface Vlanif111 
     ip address 20.1.1.253 255.255.255.0
     vrrp vrid 111 virtual-ip 20.1.1.254  # 这是vlan 111 的虚拟网关 
     interface Vlanif123
     ip address 10.1.1.253 255.255.255.0
     vrrp vrid 123 virtual-ip 10.1.1.254 # 这是vlan 123 的虚拟网关 
     lsw2 
     interface Vlanif111
     ip address 20.1.1.252 255.255.255.0
     vrrp vrid 111 virtual-ip 20.1.1.254
     interface Vlanif123
     ip address 10.1.1.252 255.255.255.0
     vrrp vrid 123 virtual-ip 10.1.1.254
    

    现在可以测试连通性 ,做完最好测试连通性 方便后面出问题了查错。
    在这里插入图片描述

    现在配置ospf 动态路由协议

    ar2 的配置

    ospf 10 router-id 2.2.2.2 
     default-route-advertise always
     area 0.0.0.0 
      network 40.1.1.0 0.0.0.255 
      network 50.1.1.0 0.0.0.255 
      退出去
      ip route-static 0.0.0.0 0.0.0.0 100.1.1.3 默认路由
    

    lsw1 的配置

      ospf 10
     area 0.0.0.0
      network 40.1.1.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
      network 20.1.1.0 0.0.0.255
    

    lsw2 配置

     ospf 10
     area 0.0.0.0
      network 50.1.1.0 0.0.0.255
      network 20.1.1.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
    

    配置 ar2 nat

    ar2 的配置
    acl number 2000  
     rule 5 permit source 20.1.1.0 0.0.0.255 
     rule 10 permit source 10.1.1.0 0.0.0.255 
     rule 15 permit source 40.1.1.0 0.0.0.255 
     rule 20 permit source 50.1.1.0 0.0.0.255
     interface GigabitEthernet0/0/2
     nat outbound 2000
     ip address dhcp-alloc
    

    ar3 的配置

    interface LoopBack0  // 配置私有地址 
     ip address 8.8.8.8 255.255.255.255 
    

    dhcp配置 pc5 做服务器

    首先所有设备都要打 dhcp enable // 开启dhcp服务
    pc5配置

    interface GigabitEthernet0/0/0
     ip address 10.1.1.5 255.255.255.0 
     dhcp select global
     
     ip pool isp
     gateway-list 100.1.1.3 
     network 100.1.1.0 mask 255.255.255.0 
     dns-list 8.8.8.8 
    
    ip pool vlan111
     gateway-list 20.1.1.254 
     network 20.1.1.0 mask 255.255.255.0 
     dns-list 8.8.8.8 
     
     ip pool vlan123
      gateway-list 10.1.1.254 
     network 10.1.1.0 mask 255.255.255.0 
     excluded-ip-address 10.1.1.252 10.1.1.253 
     dns-list 8.8.8.8
     默认路由
    ip route-static 0.0.0.0 0 10.1.1.254
    <Huawei>reset ip pool name vlan103 all //重置地址池分配地址的情况
    

    lsw1 配置

    interface Vlanif111
     dhcp select relay
     dhcp relay server-ip 10.1.1.5  // 中继的意思 
    

    lsw2 配置

      interface Vlanif111
     dhcp select relay
     dhcp relay server-ip 10.1.1.5
    

    r1 的配置

    interface GigabitEthernet0/0/0
     ip address dhcp-alloc  // 获取ip地址的方式为dhcp
     默认路由
     ip route-static 0.0.0.0 0.0.0.0 20.1.1.254
    

    高级acl 3000

    ar2 的配置

    rule 5 deny icmp source 20.1.1.251 0 destination 100.1.1.3 0 
     rule 10 deny icmp source 20.1.1.251 0 destination 8.8.8.8 0 
     rule 15 deny tcp source 10.1.1.5 0 destination 8.8.8.8 0 
     rule 20 deny tcp source 10.1.1.5 0 destination 100.1.1.3 0 
    还得去接口里面禁用规则 ar2 1口和2口 
    acl traffic-filter inbound acl 3000 
    

    telnet远程登录

    aaa
    local-user huawei password cipher 123456
    local-user huawei service-type telnet
    local-user huawei privilege level 15
    退出aaa
    user-interface vty 0 4
    authentication-mode password
    authentication-mode aaa
    

    按要求所示 ar1 不能ping ar3 但是可以远程登录ar3
    在这里插入图片描述
    pc5 可以ping 8.8.8.8 但是不能telnet ar3
    在这里插入图片描述
    如有错误,请指出,谢谢浏览!!!

    展开全文
  • int vlan 10 ip address 192.168.10.252 255.255.255.0 vrrp 10 ip 192.168.10.254 vrrp 10 track 1 decrement 10 //调用跟踪事件1,发现上行链路down后优先级会减10 vrrp 10 priority 105 no sh ...

    拓扑图

    image.png

    JR

    创建vlan及更改设备名

    HOSTNAME mamu-CORE-01  
    vlan 10
    name jwc
    vlan 20
    name xzc
    vlan 30
    name xsc
    vlan 40
    name cwc

    HJ-01

    创建vlan及更改设备名,开启三层交换机路由功能

    HOSTNAME mamu-hj-01
    
    ip routing
    
    vlan 10
    name jwc
    vlan 20
    name xzc
    vlan 30
    name xsc
    vlan 40
    name cwc

    HJ-02

    创建vlan及更改设备名,开启三层交换机路由功能

    HOSTNAME mamu-hj-02
    ip routing
    vlan 10
    name jwc
    vlan 20
    name xzc
    vlan 30
    name xsc
    vlan 40
    name cwc

    JR将端口封装dot1q协议并设置为trunk口

    int range e0/0
    switchport trunk encapsulation dot1q 
    switchport mode trunk
    no sh
    int range e0/1
    switchport trunk encapsulation dot1q 
    switchport mode trunk
    no sh

    HJ-1

    将端口封装dot1q协议并设置为trunk口

    将e1/1-2加入聚合组

    int range e1/1-2
    switchport trunk encapsulation dot1q 
    switchport mode trunk
    channel-group 1 mode on 
    no sh
    int port-channel 1
    switchport trunk encapsulation dot1q 
    switchport mode trunk
    no sh

    HJ-2

    将端口封装dot1q协议并设置为trunk口

    将e1/1-2加入聚合组

    int range e1/1-2
    switchport trunk encapsulation dot1q 
    switchport mode trunk
    channel-group 1 mode on 
    no sh
    int port-channel 1
    switchport trunk encapsulation dot1q 
    switchport mode trunk
    no sh

    JR

    将e1/0-3分别划分vlan到vlan10-40

    并设置该端口为快速端口 把一个port设置了portfast,就是让那个port不再使用STP的算法

    启用BPDU防护功能,在此端口不接受BPDU

    int e1/0
    switchport access vlan 10
    description con-to-jwc-1 
    spanning-tree portfast       //设置该端口为快速端口 把一个port设置了portfast,就是让那个port不再使用STP的算法
    spanning-tree bpduguard enable           //启用BPDU防护功能,在此端口不接受BPDU
    no sh
    int e1/1                 
    switchport access vlan 20
    description con-to-xzc-1 
    spanning-tree portfast
    spanning-tree bpduguard enable 
    int e1/2
    switchport access vlan 30
    description con-to-xsc-1 
    no sh
    spanning-tree portfast
    spanning-tree bpduguard enable 
    int e1/3              
    switchport access vlan 40
    description con-to-cwc-1
    no sh
    spanning-tree portfast
    spanning-tree bpduguard enable

    HJ-1

    配置instance 1(实例1)并关联 vlan 10,30

     

    配置instance 2(实例2)并关联 vlan 20,40

    spanning-tree mode mst   //启用多生成树协议
    spanning-tree mst configuration    //进入MST配置模式
    name ruijile
    revision 1
    instance 1 vlan 10,30
    instance 2 vlan 20,40
    spanning-tree mst 1 priority 4096   //配置三层交换机在instance 1中的优先级为4096
    spanning-tree mst 2 priority 8192    //配置三层交换机在instance 2中的优先级为8192

    HJ-2

    instance1:包括vlan10,30

    instance2:包括:vlan 20,40

    spanning-tree mode mst   //启用多生成树协议
    spanning-tree mst configuration   //进入MST配置模式
    revision 1
    instance 1 vlan 10,30
    instance 2 vlan 20,40
    spanning-tree mst 1 priority 8192
    spanning-tree mst 2 priority 4096

    H1-1

    创建监听端口并配置vlan svi接口IP充当各部门网关

    配置VRRPip及优先级等信息

    track 1 int e3/0 line-protocol //创建E3/0为监听端口 
    !
    int vlan 10
    ip address 192.168.10.252 255.255.255.0
    vrrp 10 ip 192.168.10.254
    vrrp 10 track 1 decrement 10  //调用跟踪事件1,发现上行链路down后优先级会减10
    vrrp 10 priority 105
    no sh
    !
    int vlan 20
    ip address 192.168.20.252 255.255.255.0
    vrrp 20 ip 192.168.20.254
    no sh
    !
    int vlan 30
    ip address 192.168.30.252 255.255.255.0
    vrrp 30 ip 192.168.30.254
    vrrp 10 track 1 decrement 10    //调用跟踪事件1,发现上行链路down后优先级会减10
    vrrp 30 priority 105
    no sh
    !
    int vlan 40
    ip address 192.168.40.252 255.255.255.0
    vrrp 40 ip 192.168.40.254
    no sh
    !

    优先级调整后 

    HJ-1作为VLAN 10,VLAN30的主,VLAN20,VLAN40的备,HJ-2作为VLAN20,VLAN40的主,VLAN 10,VLAN30的备,2台设备上联口设置Track跟踪,若主设备故障,主动降级为备设备)

    show vrrp brief命令查看VRRP

    image.png

    image.png

    HJ-2

    创建监听端口并配置vlan svi接口IP充当各部门网关

    配置VRRPip及优先级等信息

     

    HJ-1作为VLAN 10,VLAN30的主,VLAN20,VLAN40的备,HJ-2作为VLAN20,VLAN40的主,VLAN 10,VLAN30的备,2台设备上联口设置Track跟踪,若主设备故障,主动降级为备设备)

    track 1 int e3/0 line-protocol    //创建E3/0为监听端口
    !
    int vlan 10
    ip address 192.168.10.253 255.255.255.0
    vrrp 10 ip 192.168.10.254
    no sh
    !
    int vlan 20
    ip address 192.168.20.253 255.255.255.0
    vrrp 20 ip 192.168.20.254
    vrrp 20 track 1 decrement 10   //调用跟踪事件1,发现上行链路down后优先级会减10
    vrrp 20 priority 105
    no sh
    !
    int vlan 30
    ip address 192.168.30.253 255.255.255.0
    vrrp 30 ip 192.168.30.254
    no sh
    !
    int vlan 40
    ip address 192.168.40.253 255.255.255.0
    vrrp 40 ip 192.168.40.254
    vrrp 40 track 1 decrement 10   //调用跟踪事件1,发现上行链路down后优先级会减10
    vrrp 40 priority 105
    no sh
    !

    HJ-1

    配置e0/1端口ip

    interface e0/1
    no switchport    //开启三层功能
    ip address 192.168.99.2 255.255.255.252
    no sh

    如果是三层交换机的话,可以用到此命令。

    三层交换机是带有三层路由功能的交换机,也就是这台交换机的端口既有三层路由功能,也具有二层交换功能。三层交换机端口默认为二层口,如果需要启用三层功能就需要在此端口输入no switchport命令。如果是二层交换机就不会用到no switchport命令.

     

    HJ-2

    配置e0/1端口ip

    interface e0/1
    no switchport     //开启三层功能
    ip address 192.168.99.6 255.255.255.252
    no sh

     

    core

    ip routing   //开启路由功能
    !
    interface e0/0
    no switchport     //开启三层功能
    ip address 192.168.99.1 255.255.255.252
    no sh
    interface e0/1    
    no switchport
    ip address 192.168.99.5 255.255.255.252
    no sh
    ! 
    int loopback 0   //配置环回口
    ip add 1.1.1.1 255.255.255.0
    no sh

    配置充当PC的四台路由器IP及ospf

    pc1
    
    interface e0/0
    ip address 192.168.10.10 255.255.255.0
    no sh
    exit
    ip default-gateway 192.168.10.252   //设置默认网关
    !
    router ospf 100         //配置ospf
    network 192.168.10.0 0.0.0.255 area 0
    
    -------------------------------------
    pc2
    interface e0/0
    ip address 192.168.20.20 255.255.255.0
    no sh
    exit 
    ip default-gateway 192.168.20.252    //设置默认网关
    !
    router ospf 100            //配置ospf
    network 192.168.20.0 0.0.0.255 area 0
    
    ---------------------------------------------
    pc3
    interface e0/0
    ip address 192.168.30.30 255.255.255.0
    no sh
    exit
    ip default-gateway 192.168.30.252   //设置默认网关
    !
    router ospf 100                 //配置ospf
    network 192.168.30.0 0.0.0.255 area 0
    -------------------------------------------
    
    pc4
    interface e0/0
    ip address 192.168.40.40 255.255.255.0
    no sh
    exit
    ip default-gateway 192.168.40.252    //设置默认网关
    !
    router ospf 100                     //配置ospf
    network 192.168.40.0 0.0.0.255 area 0

    HJ-1

    配置HJ-1的OSPf

    router ospf 100
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    network 192.168.40.0 0.0.0.255 area 0
    network 192.168.99.0 0.0.0.3 area 0

    HJ-2

    配置HJ-2的OSPf

    router ospf 100
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    network 192.168.40.0 0.0.0.255 area 0
    network 192.168.99.0 0.0.0.3 area 0

    core

    配置core的OSPf

    router ospf 100
    network 1.1.1.0 0.0.0.255 area 0
    network 192.168.99.0 0.0.0.3 area 0

    show ip route查看路由表

    core

    image.png

    HJ-1 

    image.png

    HJ-2

    image.png

     

    core核心连通ping测试

    ping各个部门测试

    image.png

    测试主备切换功能

    当vlan20 master VRRP2(HJ-2) down机后,网络出现一定延时丢包,但很快恢复

    将vlan 20down掉

    image.png

    快速切换查看,发现五个包丢了一个包,不过后面就马上切换正常

    image.png

     
    展开全文
  • 校园网双核心(MSTP+VRRP)的拓扑实现和配置实例. 校园网双核心(MSTP+VRRP)的拓扑实现和配置实例.
  • 华为VRRP+MSTP配置实例

    2018-07-16 21:37:44
    配置MSTP+VRRP组合组网示例 配置MSTP+VRRP组合组网示例
  • MSTP最佳配置 VRRP最佳配置 OSPF最佳配置 IRF最佳配置 VLAN最佳配置 链路聚合最佳配置 网管最佳配置 接口批量配置 AAA最佳配置 BGP最佳配置
  • MSTP+VRRP

    万次阅读 多人点赞 2020-08-04 00:14:48
    六、VRRP配置 一、MSTP 1、作用 (1)防止二层环路与链路冗余 (2)基于VLAN的数据负载分担 小结 在MSTP中,最为关键的就是在阻塞链路时是基于接口所在vlan对应的生成树实例来对应接口角色;配置MSTP需要保证三个统一+一...

    人品,才是一个人最硬的底牌。

    一、MSTP

    1、作用

    (1)防止二层环路与链路冗余
    (2)基于VLAN的数据负载分担

    2、端口角色

    端口角色: 4

    RP,DP; AP (RP备份) ; BP (DP备份)
    端口选举:同STP
    端口状态: 4种
    收敛时间:同RSTP
    拓扑变更:同RSTP
    拓扑变更的处理:同RSPT

    3、MSTP向下兼容

    STP, 失去快速收敛特性(连接STP的接口,其他接口不会变化)
    RSTP,保持快速收敛特性

    4、生成树与VLAN的关系

    一个或者多个VLAN可以共享一个生成树

    5、小结

    在MSTP中,最为关键的就是在阻塞链路时是基于接口所在vlan对应的生成树实例来对应接口角色;配置MSTP需要保证三个统一+一个激活,这个要点不要忘记;另外就是对于连接路由器的接口也要配置边缘接口,因为正常情况路由器所在的链路不会形成环路也不会发BPDU没有必要等待。

    二、MSTP 简介

    1、定义

    多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE 802.1s中定义的生成树协议,通过生成多个生成树,来解决以太网环路问题。

    2、目的

    在以太网中部署MSTP协议后可实现如下功能:
    (1)形成多棵无环路的树,解决广播风暴并实现冗余备份。
    (2)多棵生成树在VLAN间实现负载均衡,不同VLAN的流量按照不同的路径转发。

    3、MSTP 出现的背景

    STP/RSTP 的缺陷

    RSTP在STP基础上进行了改进,实现了网络拓扑快速收敛。但RSTP和STP还存在同一个缺陷:由于局域网内所有的VLAN共享一棵生成树,因此无法在VLAN间实现数据流量的负载均衡,链路被阻塞后将不承载任何流量,还有可能造成部分VLAN的报文无法转发。

    4、MSTP 对 对 STP 和 和 RSTP 的改进

    为了弥补STP和RSTP的缺陷,IEEE于2002年发布的802.1s标准定义了MSTP。MSTP兼容STP和RSTP,既可以快速收敛,又提供了数据转发的多个冗余路径,在数据转发过程中实现VLAN数据的负载均衡。

    三、拓扑

    在这里插入图片描述

    四、基础配置

    1、如图配置底层信息(系统名称,接口地址)
    2、路由器和路由器,路由器和SW级连链路运行OSPF
    3、SW连接Router的链路接口配置为access;SW之间的级联链路配置为trunk,放行vlan自行决定

    AR2

    [AR2]ospf 1 router-id 2.2.2.2
    [AR2-ospf-1]area 0.0.0.0 
    [AR2-ospf-1]network 12.1.1.2 0.0.0.0 
    [AR2-ospf-1]network 100.1.1.2 0.0.0.0 
    
    [AR2]ip route-static 192.168.1.0 255.255.255.0 100.1.1.200
    [AR2]ip route-static 192.168.2.0 255.255.255.0 100.1.1.200
    
    [SW-1]int g0/0/24
    [SW-1-GigabitEthernet0/0/24]port link-type access
    [SW-1-GigabitEthernet0/0/24]port default vlan 100
    

    AR1配置类似

    五、配置与分析

    1、在SW运行MSTP来实现环路阻塞;与链路冗余;流量分担
    MSTP配置注意:同一个区域保证
    (1)所有SW域名一致
    (2)所有SW修订版本号一致
    (3)所有SW生成树实例和vlan映射关系一致
    (4)最后一定要记得激活生成树配置

    2、所有SW运行生成树模式为MSTP
    域名统一为MSTP;修订版本配置为0

    [SW-4]stp mode mstp 
    

    3、vlan 10对应实例 1; SW-1主根,SW-2备
    vlan 20对应实例 2; SW-2主根,SW-1备
    其余vlan 默认实例0,SW-1主根,SW-2备

    [SW-1]stp region-configuration      //配置多生成树实例
    [SW-1-mst-region]region-name MSTP   //修改本SW的域名为MSTP(默认为SW的背板MAC,全网统一)
    [SW-1-mst-region]revision-level 0   //修订版本号为0(默认为0,全网统一)
    [SW-1-mst-region]instance 1 vlan 10 //创建生成树实例1映射vlan 10
    [SW-1-mst-region]instance 2 vlan 20 //创建生成树实例2映射vlan 20
    
    [SW-1-mst-region]active region-configuration //激活以上对MSTP的配置 
    
    [SW-1]stp instance 0 root primary            //本SW-1为生成树实例0的主根桥
    [SW-1]stp instance 1 root primary            //本SW-1为生成树实例1的主根桥
    [SW-1]stp instance 2 root secondary          //本SW-1为生成树实例2的备份根桥
    

    SW-2配置类似

    [SW-1]dis stp region-configuration
    在这里插入图片描述
    4、所有连接终端的链路配置edge-port边缘接口

    接入层SW连接终端设备的接口配置为边缘接口,实现discarding到forwarding的跳跃过渡,避免因拓扑变化导致的无意义等待。

    [SW-3]int e0/0/1
    [SW-3-Ethernet0/0/1]port link-type access
    [SW-3-Ethernet0/0/1]port default vlan 10
    [SW-3-Ethernet0/0/1]stp edged-port enable //此接口的生成树状态配置为边缘接口(不受生成树计时器的影响)
    

    SW-1

    [SW-1-GigabitEthernet0/0/24]stp edged-port enable 
    

    SW-2

    [SW-2-GigabitEthernet0/0/24]stp edged-port enable 
    

    SW-4配置类似

    六、VRRP配置

    1、SW-1的vlanif 10为192.168.1.0的主网关,SW-2的vlanif 10作为备份192.168.1.0网段的虚拟网关地址为192.168.1.254

    [SW-1]int Vlanif 10
    [SW-1-Vlanif10]ip address 192.168.1.1 255.255.255.0
    [SW-1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.1.254
    //创建VRRP工作组,组编号为1,设置虚拟网关地址为192.168.1.254(工作组编号和虚拟网关必须一致)
    [SW-1-Vlanif10]vrrp vrid 1 priority 120
    //设置本VRRP工作组1在本路由器的优先级为120(默认100.越大越优先,优先者会成为数据的实际转发者)
    [SW-1]int Vlanif 20
    [SW-1-Vlanif20]ip address 192.168.2.1 255.255.255.0
    [SW-1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.2.254
    

    [SW-1]display vrrp brief
    在这里插入图片描述
    2、SW-2的vlanif 20为192.168.2.0的主网关,SW-1的vlanif 20作为备份192.168.2.0网段的虚拟网关地址为192.168.2.254

    [SW-2]int Vlanif 10
    [SW-2-Vlanif10]ip address 192.168.1.2 255.255.255.0
    [SW-2-Vlanif10]vrrp vrid 1 virtual-ip 192.168.1.254
    //创建VRRP工作组,组编号为1,设置虚拟网关地址为192.168.1.254(工作组编号和虚拟网关必须一致)
    
    [SW-2]int Vlanif 20
    [SW-2-Vlanif20]ip address 192.168.2.2 255.255.255.0
    [SW-2-Vlanif20]vrrp vrid 2 virtual-ip 192.168.2.254
    [SW-2-Vlanif20]vrrp vrid 2 priority 120
    //设置本VRRP工作组2在本路由器的优先级为120(默认100.越大越优先,优先者会成为数据的实际转发者)
    

    [SW-2]display vrrp brief
    在这里插入图片描述
    3、AR-1与AR-2的路由表中针对192.168.1.0和192.168.2.0路由信息的截图

    dis ip routing-table
    在这里插入图片描述
    dis ip routing-table
    在这里插入图片描述
    4、PC-1长pingPC-2 切断 SW-1与SW-3线路的截图,测试MSTP备份是否生效

    ping 192.168.2.100 -t
    在这里插入图片描述
    已生效

    5、PC-1长pingPC-2 关闭SW-1 截图,测试MSTP与BRRP的备份是否生效

    ping 192.168.2.100 -t
    在这里插入图片描述
    已生效


    在这里插入图片描述

    我是艺博东!古人云:以利相交,利尽则散;以势相交,势去则倾;以权相交,权失则弃;以情相交,情逝人伤。也欢迎你和我一起讨论,我们下期见。

    展开全文
  • ensp router+mstp+vrrp+单nat

    千次阅读 2020-06-24 19:20:24
    router+mstp+vrrp+单nat 拓扑图 ![image.png]...

    router+mstp+vrrp+单nat

    拓扑图

    image.png

    使用技术

    使用到的技术:
    	单区域ospf 
      dhcp
      nat
    
      mstp
      vrrp+track
    
    	端口聚合
      
      
    

    接入层

    huijuA

    sys
    sysname huijuA
    
    # 创建vlan
    vlan batch 10 20 30 40
    
    # 端口分配
    int e0/0/1
    port link-type access 
    port default vlan 10
    
    int e0/0/2
    port link-type access 
    port default vlan 20
    
    int e0/0/3
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    int e0/0/4
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    # mstp 
    stp region-configuration 
    region-name wlgc
    instance 1 vlan 10 30
    instance 2 vlan 20 40 
    active region-configuration
    
    

    huijuB

    sys
    sysname huijuB
    
    # 创建vlan
    vlan batch 10 20 30 40
    
    # 端口分配
    int e0/0/1
    port link-type access 
    port default vlan 30
    
    int e0/0/2
    port link-type access 
    port default vlan 40
    
    int e0/0/3
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    int e0/0/4
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    # mstp 
    stp region-configuration 
    region-name wlgc
    instance 1 vlan 10 30
    instance 2 vlan 20 40 
    active region-configuration
    

    核心层

    coreA

    sys
    sysname coreA
    
    # 创建vlan
    vlan batch 10 20 30 40 50
    
    # 端口分配
    int g0/0/1
    port link-type access 
    port default vlan 50
    
    int g0/0/3
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    int g0/0/4
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    # 链路聚合
    int Eth-Trunk 1
    port link-type trunk 
    port trunk allow-pass vlan 10 20 30 40
    # 加入
    int g0/0/23 
    eth-trunk 1
    
    int g0/0/24
    eth-trunk 1
    
    # mstp 
    stp region-configuration 
    region-name wlgc
    instance 1 vlan 10 30
    instance 2 vlan 20 40 
    active region-configuration 
    
    quit
    # mstp 根桥指定
    stp instance 1 root primary 
    stp instance 2 root secondary 
    
    # vrrp配置
    int vlan 10
    ip address 192.168.10.252 24
    vrrp vrid 10 virtual-ip 192.168.10.254
    vrrp vrid 10 priority 110
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 10 track interface g0/0/1 reduced 50
    
    int vlan 20
    ip address 192.168.20.252 24
    vrrp vrid 20 virtual-ip 192.168.20.254
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 20 track interface g0/0/1 reduced 50
    
    int vlan 30
    ip address 192.168.30.252 24
    vrrp vrid 30 virtual-ip 192.168.30.254
    vrrp vrid 30 priority 110
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 30 track interface g0/0/1 reduced 50
    
    int vlan 40
    ip address 192.168.40.252 24
    vrrp vrid 40 virtual-ip 192.168.40.254
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 40 track interface g0/0/1 reduced 50
    
    ## 这里配置完,建议display ip int brief
    ## 顺带验证vlan pc间是否能够通信
    
    # 上联接口vlan
    int vlan 50
    ip address 192.168.252.1 24
    
    # 配置ospf
    ospf 100 router-id 1.1.1.1
    area 0 
    network 0.0.0.0 255.255.255.255
    
    
    

    core B

    sys
    sysname coreB 
    
    # 创建vlan
    vlan batch 10 20 30 40 60
    
    # 端口分配
    int g0/0/1
    port link-type access 
    port default vlan 60
    
    int g0/0/3
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    int g0/0/4
    port link-type trunk 
    port trunk allow-pass vlan all 
    
    # 链路聚合
    int Eth-Trunk 1
    port link-type trunk 
    port trunk allow-pass vlan 10 20 30 40
    
    # 加入
    int g0/0/23 
    eth-trunk 1
    
    int g0/0/24
    eth-trunk 1
    
    # mstp 
    stp region-configuration 
    region-name wlgc
    instance 1 vlan 10 30
    instance 2 vlan 20 40 
    active region-configuration 
    
    quit
    # mstp 根桥指定
    stp instance 2 root primary 
    stp instance 1 root secondary 
    
    # vrrp 配置
    int vlan 10
    ip address 192.168.10.253 24
    vrrp vrid 10 virtual-ip 192.168.10.254 
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 10 track interface g0/0/1 reduced 50
    
    int vlan 20
    ip address 192.168.20.253 24
    vrrp vrid 20 virtual-ip 192.168.20.254
    vrrp vrid 20 priority 110
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 20 track interface g0/0/1 reduced 50
    
    int vlan 30
    ip address 192.168.30.253 24
    vrrp vrid 30 virtual-ip 192.168.30.254
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 30 track interface g0/0/1 reduced 50
    
    int vlan 40
    ip address 192.168.40.253 24
    vrrp vrid 40 virtual-ip 192.168.40.254
    vrrp vrid 40 priority 110
    # 配置上联接口检测,直连接口(配置的是本机的端口)检测不通时,降级
    vrrp vrid 40 track interface g0/0/1 reduced 50
    
    ## 这里配置完,建议display ip int brief,验证vlan ip
    ## 顺带验证vlan pc间是否能够通信
    
    # 上联接口vlan
    int vlan 60
    ip address 192.168.253.1 24
    
    # 配置ospf
    ospf 100 router-id 2.2.2.2
    area 0 
    network 0.0.0.0 255.255.255.255
    
    

    对外

    核心路由器(AR1)

    sys
    sysname AR1 
    
    
    int g0/0/0
    ip address 192.168.252.2 24
    
    int g0/0/1
    ip address 192.168.253.2 24
    
    int g0/0/2
    ip address 12.1.1.1 30
    
    
    # 默认路由
    ip route-static 0.0.0.0 0.0.0.0 12.1.1.2
    
    
    # ospf
    ospf 100 router-id 3.3.3.3
    # 默认路由重分布
    default-route-advertise 
    area 0 
    network 192.168.0.0 0.0.255.255
    
    # nat 
    acl number 3000 
    rule 10 permit ip source 192.168.0.0 0.0.255.255
    
    int g0/0/2
    nat outbound 3000
    
    
    

    ISP

    sys
    sysname ISP
    
    int g0/0/1
    ip address 9.9.9.254 24
    
    int g0/0/0
    ip address 12.1.1.2 30
    
    

    效果图

    核心层

    coreA

    display ip int brief
    

    image.png

    vrrp
    display vrrp brief
    

    image.png

    stp
    display stp brief
    

    image.png

    coreB

    display ip int brief
    

    image.png

    vrrp
    display vrrp brief
    

    image.png

    stp
    display stp brief
    

    image.png

    dis ip routing-table
    

    image.png

    汇聚层

    huijuA

    display stp brief
    

    image.png

    huijuB

    display stp brief
    

    image.png

    核心路由器

    dis ip int brief
    

    错误排查

    交换机mac漂移

    大致原因是环路
    https://support.huawei.com/enterprise/zh/doc/EDOC1000141442/b2b79367
    

    ospf router-id 冲突

    先看看是否手工指定时,确实失误了。
    再排查和交换机的接口,是否已经配置了vlan,测试和交换机的对应vlan能否互通。
    

    vrrp 主备未切换

    1. 确认使用shutdown命令,模拟故障。
    2. 确认配置了vrrp track,且配置的接口,是上联接口
    
    展开全文
  • 华为MSTP+VRRP(双机热备)

    千次阅读 多人点赞 2019-08-14 17:42:34
    华为MSTP+VRRP 【项目拓扑】 如图,PC1、PC2是企业内网的主机,分别属于VLAN10和VLAN20,LSW1和LSW2之间的g0/0/23口和g0/0/24口之间形成链路聚合。AR1是企业边界路由器,用于和外网通信。AR1、LSW1和LSW2之间运行RIP...
  • 策略路由pbr+mstp +vrrp +双线nat

    千次阅读 2020-06-24 21:55:38
    策略路由pbr+mstp +vrrp +双线nat 拓扑 使用技术 使用到的技术: 单区域ospf dhcp nat mstp vrrp+track 端口聚合 nqa+pbr 策略路由 接入层 jieruA sys sysname jieruA # 创建vlan vlan ...
  • ensp mstp+vrrp配置实验

    2021-12-07 20:37:14
    port link-type trunk [SW1-GigabitEthernet0/0/3]port trunk allow-pass vlan all 2:配置mstp实例 以SW1为例(4台配置一模一样): [SW1]stp mode mstp #默认为mstp不写也行,前面少了一个stp enable也是默认开启...
  • 网工配置MSTP+VRRP组合组网示例

    千次阅读 2019-10-15 14:01:37
    VRRP 虚拟路由冗余协议,简称VRRP是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议。网络中部署VRRP负载分担时,多台设备同时承担业务,每个虚拟设备都包括一个Master设备和若干个Backup设备。...
  • 配置 MSTP+VRRP 组合应用实验

    千次阅读 多人点赞 2020-04-19 15:33:38
    配置 MSTP+VRRP 组合应用。 实验目的 在接入层和分布层交换机上配置 MSTP 并进行验证。 配置基于 SVI的 VRRP 多备份组实验,实现 VRRP 的负载均衡模式。 需求分析 利用 MSTP 除了可以实现网络中的冗余链路外,还能够...
  • type trunk port trunk permit vlan 10 20 100 int g1/0/13 port link-type trunk port trunk permit vlan 10 20 100 quit int vlan 10 ip add 192.168.10.2 24 VRRP VRID 1 virtual-ip 192.168.10.1 VRRP VRID 1 ...
  • Ethernet0/0/3]p l t [Huawei-Ethernet0/0/3]p t a v a [Huawei-Ethernet0/0/3]int e0/0/4 [Huawei-Ethernet0/0/4]p l t [Huawei-Ethernet0/0/4]p t a v a 断掉R2的G0/0/1口 实验二:交换机配置mstp+vrrp,s1作为vlan...
  • 防火墙+route+vrrp+mstp

    千次阅读 2020-06-24 21:49:39
    防火墙+route+vrrp+mstp 拓扑图 使用技术 使用到的技术: 单区域ospf dhcp nat mstp vrrp+track 链路聚合 telnet+aaa 接入层 huijuA sys sysname huijuA # 创建vlan vlan batch 10 20 30 40...
  • MSTP muliti stp多生成树(华为交换机默认运行mstp)工作原理:将多个VLAN捆绑在一起,运行在一个stp实例里面,不同实例间的stp互相独立。注:默认情况下所有VLAN都在实例0里面。 多生成树(MSTP)解决: 去掉环 ...
  • 试验拓扑如下,该拓扑结构存在两个生成树实例,且互为备份,pc 1 3 5 7 属于VLAN 100,pc 2 4 6 8 属于VLAN 200,并且网关必须配置在汇聚层 一、配置VLAN,链路聚合 二、生成树配置(修改根网桥的位置) 三、VRRP...
  • MSTP要求:在交换机SW1和SW2上配置MSTP防止二层环路,创建两个实例,实例1包含vlan10和vlan20,实例2中包含vlan30和vlan40。配置SW1为实例1的主根,实例2的从根,设置主根交换机的优先级为4096,从根交换机的优先级...
  • 华为hcie示例,已通过。 使用ensp打开即可。 有修改均已在示例中注明。
  • 网络拓扑 AR2配置: # sysname r1 # dhcp enable # ip pool 1 gateway-list 146.44.31.254 //设置网关 network 146.44.31.0 mask 255.255.255.0 //设置网段 excluded-ip-address 146.44.31.252 146.44.31.253 /...
  • ensp mstp+vrrp高可用组网实验

    千次阅读 2020-12-12 18:04:30
    ensp mstp+vrrp高可用组网实验一、实验topo二、实验目标三、IP地址分配表四、基础配置五、OSPF路由配置 一、实验topo 二、实验目标 网关位于汇聚层,接入和汇聚层采用trunk的方式进行互联,汇聚层和核心层之间采用...
  • MSTP_VRRP综合实验

    2014-05-02 21:10:02
    按照拓扑结构和地址规划,合理部署MSTP实现VLAN负载分担;部署VRRP实现网关冗余。
  • 1.SW1、 SW2、 SW3、 SW4 运行 MSTP, SW1 为 instance 1 的主根、 为 instance 2 的备根; SW2 相反; 参数要求:region-name为huawei; revision版本为1; 主根优先级为4096,从根优先级为8192; 2.SW1、 SW2 ...
  • 基于三层交换机的VRRP技术--MSTPVRRP的综合运用

    万次阅读 多人点赞 2018-08-18 10:46:26
    MSTP (多生成树) 每个VLAN或者几个VLAN拥有一颗生成树,基于实例的...VRRP虚拟路由冗余协议(Virtual Router Redundancy Protocol)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议。 注意:当MS...
  • ensp VRRP+MSTP综合性实验

    千次阅读 多人点赞 2020-11-21 23:40:08
    Vlanif10]q [Huawei]int Vlanif 20 [Huawei-Vlanif20]vrrp vrid 20 virtual-ip 192.168.2.2 [Huawei-Vlanif20]vrrp vrid 20 priority 120 [Huawei-Vlanif20]vrrp vrid 20 track interface g0/0/1 查看VRRP的状态 LSW...
  • ensp综合实验练习(mstpVRRP、BGP、DHCP等)

    千次阅读 多人点赞 2021-03-29 19:31:53
    第一部分:链路聚合、MSTPVRRP和RIP 第一部分要求: PC1和PC3为实例1走sw1为主路(Master),PC2和PC4为实例2走sw2为备用路(Backup); 链路聚合要求:2条活跃,一条备用 SW3配置如下: ###########################...
  • VRRPMSTP配置详情

    2021-05-08 19:16:46
    VRRP(虚拟路由冗余协议) VRRP:保证了当主机的下一跳路由器出现故障时,由另一台路由器来代替出现故障的路由器进行工作,从而保持网络通信的连续性和可靠性。 作用:实现分担、将事故问题降低最小 工作模式: 虚拟...
  • VRRP&MSTP的经典组网 以及BFD的配置

    千次阅读 2020-03-05 00:53:41
    MSTP:二层网络的负载均衡 VRRP 负责三层的负载均衡 12.9Vrrp的特性&常见配置错误 配置VRRP与BFD联动实现VRRP快速切换 VRRP备份组故障时,Backup设备需要等待Master_Down_Interval定时器超时后才能感知故障...
  • MSTPVRRP 一.实践目的 理解mstp原理;熟悉配置命令。 验证VRRP的功能;测试VRRP网络中成员的通信。 二.实践拓扑 三.地址规划 四.实践原理 理解生成树协议STP的配置及原理,通过MSTP把一个交换网络划分成多个域...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,605
精华内容 642
关键字:

mstpvrrp