精华内容
下载资源
问答
  • 实验:RIP路由项欺骗攻击防御实验,该实验验证了RIP的安全缺陷,包含以下主要内容:RIP实施路由项欺骗攻击的过程,入侵路由器截获IP分组的过程,RIP源端鉴别功能的配置过程和RIP防御路由项欺骗攻击过程,所有命令和...
  • 掌握在路由器上如何配置 RIP 路由协议。两台路由器通过快速以太网端口连接在一起,每个路由器上设置 2 个 Loopback 端口模拟子网,在所有端口运行 RIP 路由协议,实现所有子网间的互通。
  • 静态路由和RIP路由的配置
  • 掌握RIP路由配置。 二.实验要点: 1)根据拓扑图进行网络布线。 2)清除启动配置并将路由器重新加载为默认状态。 3)在路由器上执行基本配置任务。 4)解释 debug ip routing 的输出。 5)配置并激活串行接口和以太网...
  • RIP路由协议基本配置

    2015-12-24 09:18:02
    假设在校园网在地理上分为2个区域,每个区域内分别有一台路由器连接了2个子网,需要将两台...为了在未来每个校园区域扩充子网数量的时候,管理员不需要同时更改路由器的配置,计划使用RIP路由协议实现子网之间的互通
  • RIP路由协议

    2015-01-21 14:21:08
    RIP 路由 首先,rip是动态路由协议的一种。动态路由协议有三种,距离矢量类路由协议、链路状态类路由协议和混合型路由协议。 rip为代表的距离矢量类路由协议在选路的时候仅以跳数(hop)为唯一参考,也就是那条路径...
  • 计算机网络原理实验五,是关于RIP路由协议的,自己做的实验,代码和结果截图都有,步骤详细
  • RIP路由协议详解

    千次阅读 2021-04-07 09:44:49
    RIP是Routing Information Protocol(路由信息协议)的简称,它是一种较为简单的内部网关协议(Interior Gateway Protocol) RIP是一种基于距离矢量(Distance-Vector)算法的协议,它使用跳数(Hop Count)作为...

    一、RIP简介

    RIP是Routing Information Protocol(路由信息协议)的简称,它是一种较为简单的内部网关协议(Interior Gateway Protocol)

    RIP是一种基于距离矢量(Distance-Vector)算法的协议,它使用跳数(Hop Count)作为度量来衡量到达目的网络的距离。设备到与他直连网络的设备跳数为0,然后每经过一个三层设备跳数增加1,也就是度量值等于从本网络到达目网络间的三层设备数量,但并不等于所经过的网段数

    RIP通过UDP报文进行路由信息的交换,使用的端口号为520。所以它又是一个不可靠的路由协议

    由于RIP的实现较为简单,在配置和维护管理方面也远比OSPF和IS-IS容易,因此RIP主要应用于规模较小的网络中,例如校园网以及结构较简单的地区性网络。对于更为复杂的环境和大型网络,一般不使用RIP协议

    RIP包括RIP-1和RIP-2两个版本,RIP-2对RIP-1进行了扩充,使其更具有优势

    二、RIP原理

    RIP是一种基于距离矢量(Distance-Vector)算法的协议,它使用跳数(Hop Count)作为度量值来衡量到达目的地址的距离

    在RIP网络中,缺省情况下,设备到与它直接相连网络的跳数为0,通过一个设备可达的网络的跳数为1,其余依此类推。也就是说,度量值等于从本网络到达目的网络间的设备数量。为限制收敛时间,RIP规定度量值取0~15之间的整数,大于或等于16的跳数被定义为无穷大,即目的网络或主机不可达。由于这个限制,使得RIP不可能在大型网络中得到应用

    RIP协议有两种更新机制:

    一是定期更新,二是触发更新。定期更新是根据设置的更新计时器定期发送RIP路由通告。而触发更新是RIP路由器一旦察觉到网络变化,就尽快甚至是立即发送更新报文,而不等待更新周期结束。只要触发更新的速度足够快,就可以大大地防止“计数到无穷大”的发生,但是这一现象还是有可能发生的

    无论是定期更新,还是触发更新,RIP路由的更新规则如下:

    1. 如果更新的某路由表项在路由表中没有,则直接在路由表中添加该路由表项
    2. 如果路由表中已有相同目的网络的路由表项,且来源端口相同,那么无条件根据最新的路由信息更新其路由表
    3. 如果路由表中已有相同目的网络的路由表项,但来源端口不同,则要比较它们的度量值,将度量值较小的一个作为自己的路由表项
    4. 如果路由表中已有相同目的网络的路由表项,且度量值相等,保留原来的路由表项

    三、RIP运行例子

    1.  在一开始,所有路由器中的路由表只有自己所直接连接的网络的路由表项信息。但不是RIP路由表项,是直连路由表项,无需下一跳(用“--”表示),度量“距离”也均为0 ,各路由器的初始路由表如图所示,均只有两条直连网络的路由表项

    2. 接下来,各路由器就会按设置的周期(默认为30秒)向邻居路由器发送路由更新了。具体哪个路由器会先发送路由更新,取决于哪个路由器先开了。现假设路由器R2先收到来自路由器R1和R3的路由更新,然后就更新自己的路由表,如图所示。从中可以看出,它新添加了分别通过R1和R3到达10.0.0.0网络和30.0.0.0网络的路由表项,度量值均为1,因为它只经过了一跳

     

    3. R2更新自己的路由表后,会把完整的路由表发给邻居路由器R1和R3。路由器R1和R3分别再进行更新。根据前面介绍的RIP路由表更新的规则可以知道,R1对每项度量进行加1,得到的路由表如图所示

    4. 然后R1再把图8-9所示的路由表与自己原来的路由表进行比较,凡是新添加的,和度量值小于等于原来的路由表项均将更新,度量值更大的路由表项将忽略更新。经过行比较发现有两条新的路由表项,其目的网络分别为30.0.0.0和40.0.0.0,直接在路由表中添加。而原来已有的两条10.0.0.0和20.0.0.0表项,发现路由度量(“距离”)值1比原来的0还大,忽略更新,结果就得到R1更新后的路由表,如图所示

    四、其他

    RIP封装在UDP之上,端口为520

    组播,为了降低那些没有监听RIP Version 2 报文的主机的不必要的开销,IP多目传送地址被用于定时广播。IP 多目地址是224.0.0.9



    作者:语文小子
    链接:https://www.jianshu.com/p/f542d5b415a1
    来源:简书
    著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

     

    展开全文
  • 动态路由协议及RIP工作原理一级目录二级目录三级目录 一级目录 二级目录 三级目录 配置实例 1、配置R1 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]un in en Info: Information ...

    一、动态路由

    动态路由是基于某种路由协议实现的,。动态路由是指路由器能够自动地建立自己的路由表,并且能够根据实际情况的变化适时地进行调整。

    (1)动态路由协议基础

    1、度量值

    跳数、带宽、负载、时延、可靠性、成本
    路由器会通过度量值来确定最优路径

    2、动态路由特点

    (1)减少了管理任务
    (2)占用了网络带宽
    (3)在路由器上运行路由协议,使路由器可以自动根据网络拓朴结构的变化调整路由条目
    (4)网络规模大、拓扑复杂的网络

    3、收敛

    使所有路由表都达到一致状态的过程

    4、静态路由与动态路由的比较

    网络中静态路由和动态路由互相补充
    路由少,配置简单,精度要求高时用静态路由,节省带宽
    路由多,配置麻烦时用动态路由,动态路由占用带宽

    (2)动态路由协议分类

    1、按照路由执行的算法分类

    (1)距离矢量路由协议:
    根据跳数来选择,跳数越少越好。依据从源网络到目标网络所经过的额路由器的个数选择路由。
    RIP、IGRP(思科私有协议),BGP(高级距离矢量路由协议)
    (2)链路状态路由协议
    综合考虑从源网络到目标网络的各路径的情况选择路由。
    OSPF、IS-IS(大型网络公司)

    2、按照工作区域不同分类

    分为局域网内IGP(内部网关路由协议)和互联网EGP(外部网关路由协议):
    (1)局域网内IGP:
    域内路由协议是负责一个路由域(在一个管理域内运行同一种路由协议的域,称为一个路由域)内路由的路由协议。
    RIP、OSPF、IS-IS等。
    (2)互联网EGP:
    域间路由协议负责在自治系统之间或域间完成路由和可到达信息的交互,主要用于传递路由。
    BGP。

    二、RIP路由协议工作原理

    路由信息协议(RIP) 是内部网关协议IGP中最先得到广泛使用的协议。RIP是一种分布式的基于距离向量的路由选择协议,是因特网的标准协议,其最大优点就是实现简单,开销较小。

    (1)RIP路由协议工作原理

    RIP是距离矢量路由选择协议

    1、RIP基本概念

    (1)定期更新
    (2)邻居
    (3)广播更新
    (4)全路由表更新

    2、路由表的形成

    (1)路由器学习到直连路由
    (2)更新周期30s到时,路由器会向邻居发送路由表
    (3)再过30s,第二次更新时间到了再次发送路由表
    最终到达收敛状态
    在这里插入图片描述

    3、RIP的度量值与更新时间

    (1)RIP度量值为跳数
    最大跳数为15跳,16跳不可达(最多16个路由器)。
    (2)RIP更新时间
    每个30s发送路由更新消息,UDP520端口
    (3)RIP路由更新消息
    发送整个路由表信息

    4、水平分割

    从一个接口学习到的路由信息,不再从这个接口发送出去
    (1)执行水平分割可以阻止路由环路的发生
    (2)同时也能减少路由更新信息占用的链路带宽资源
    在这里插入图片描述

    5、毒性逆转

    路由器从某个接口上接收某个网段的路由信息之后,并不是不往回发送消息了,而是发送,只不过是将这个网段标志为不可达(16跳),再发送出去。收到此种的路由信息后,接收方路由器会立刻抛弃该路由,而不是等待其他老化时间到来,这样可以加速路由的收敛。

    (2)RIP路由协议的配置

    [R1]rip 1   ###启动RIP
    [R1-rip-1]version 2   ###启动版本2 ( 缺省为版本1)
    [R1-rip-1]undo summary  
    ### 关闭路由自动聚合(即所有路由信息都会按照IP地址分类归类)
    [R1-rip-1]network 192.168.10.0   
    ###宣告主网络号,v2会携带掩码组播更新224.0.0.9,v1不携带掩码广播更新255.255.255.255
    [R1-rip-1]network 200.1.1.0
    
    ----兼容模式-----
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]rip version 2 multicast
    ###把设置成rip1路由器的某一接口单独设置成rip版本2
    ###rip1和rip2不兼容,rip1是广播,rip2是组播(224.0.0.9

    (3)RIP路由协议v1和v2的区别

    RIP v1RIP v2
    有类路由协议无类路由协议
    广播更新(255.255.255.255)组播更新(224.0.0.9)
    不支持VLSM支持VLSM
    自动路由汇总,不可关闭自动汇总可关闭,可手工汇总
    不支持不连续子网支持不连续子网

    (4)RIP v2的配置实例

    配置实例:实现主机12之间的通信
    在这里插入图片描述

    1、配置R1

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R1
    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 192.168.100.1 24
    [R1-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R1-GigabitEthernet0/0/1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 12.0.0.1 24
    [R1-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R1-GigabitEthernet0/0/0]q
    [R1]rip
    [R1-rip-1]version 2
    [R1-rip-1]undo summary
    [R1-rip-1]network 192.168.100.0
    [R1-rip-1]net 12.0.0.0
    [R1-rip-1]dis th
    [V200R003C00]
    #
    rip 1
     undo summary
     version 2
     network 192.168.100.0
     network 12.0.0.0
    #
    return
    [R1-rip-1]q
    [R1]dis ip routing-table

    在这里插入图片描述

    2、配置R2

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R2
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2-GigabitEthernet0/0/0]un sh 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 23.0.0.2 24
    [R2-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R2-GigabitEthernet0/0/1]q
    [R2]rip
    [R2-rip-1]version 2
    [R2-rip-1]undo summary
    [R2-rip-1]net 12.0.0.0
    [R2-rip-1]net 23.0.0.0
    [R2-rip-1]dis th
    [V200R003C00]
    #
    rip 1
     undo summary
     version 2
     network 12.0.0.0
     network 23.0.0.0
    #
    return
    [R2-rip-1]q
    [R2]dis ip routing-table
    

    在这里插入图片描述

    3、配置R3

    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]un in en
    Info: Information center is disabled.
    [Huawei]sys R3
    [R3]int g0/0/1
    [R3-GigabitEthernet0/0/1]ip add 23.0.0.3 24
    [R3-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R3-GigabitEthernet0/0/1]int g0/0/0
    [R3-GigabitEthernet0/0/0]ip add 34.0.0.3 24
    [R3-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R3-GigabitEthernet0/0/0]q
    [R3]rip
    [R3-rip-1]version 2
    [R3-rip-1]undo summary
    [R3-rip-1]net 23.0.0.0
    [R3-rip-1]net 34.0.0.0
    [R3-rip-1]dis th
    [V200R003C00]
    #
    rip 1
     undo summary
     version 2
     network 23.0.0.0
     network 34.0.0.0
    #
    return
    [R3-rip-1]

    在这里插入图片描述

    4、配置R4

    [Huawei]sys R4
    [R4]int g0/0/0
    R4-GigabitEthernet0/0/0]ip add 34.0.0.4 24
    [R4-GigabitEthernet0/0/0]un sh
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [R4-GigabitEthernet0/0/0]int g0/0/1
    [R4-GigabitEthernet0/0/1]ip add 192.168.200.1 24
    [R4-GigabitEthernet0/0/1]un sh
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [R4-GigabitEthernet0/0/1]q
    [R4]rip
    [R4-rip-1]v 2
    [R4-rip-1]un summary
    [R4-rip-1]net 192.168.200.0
    [R4-rip-1]net 34.0.0.0
    [R4-rip-1]dis th
    [V200R003C00]
    #
    rip 1
     undo summary
     version 2
     network 192.168.200.0
     network 34.0.0.0
    #
    return
    [R4-rip-1]q

    在这里插入图片描述

    5、配置PC机

    在这里插入图片描述
    在这里插入图片描述

    6、检测连通性

    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • RIP路由配置实验

    2021-02-03 19:18:48
    一、实验目的 掌握路由器中rip动态路由的配置方法和结果验证...图1-1 RIP路由的基本配置实例 2、业务配置流程图 图1-2 RIP路由的基本配置实验流程 3、实验配置过程 1.路由器的基本配置 步骤1:路由器R1的配置 ZXR10(c

    一、实验目的

    掌握路由器中rip动态路由的配置方法和结果验证。

    二、实验内容

    完成中兴1800路由器RIP动态路由的配基本置和结果查看。

    三、实验过程

    1、实验任务说明
    如图1-1所示,按照以下的网络拓扑完成网络的连接和设置,通过配置RIP动态路由实现192.168.2.0和192.168.1.0两个网络之间可以互相ping通。
    在这里插入图片描述

    图1-1 RIP路由的基本配置实例

    2、业务配置流程图
    在这里插入图片描述

    图1-2 RIP路由的基本配置实验流程

    3、实验配置过程
    1.路由器的基本配置
    步骤1:路由器R1的配置
    ZXR10(config)#interface gei_0/1
    ZXR10(config-if)#ip addresss 40.1.1.5 255.255.255.252
    ZXR10(config-if)#exit
    ZXR10(config)#interface loopback1
    ZXR10(config-if)#ip addresss 192.168.2.1 255.255.255.0
    ZXR10(config-if)#exit
    步骤2:路由器R2的配置
    ZXR10(config)#interface gei_0/1
    ZXR10(config-if)#ip addresss 40.1.1.6 255.255.255.252
    ZXR10(config-if)#exit
    ZXR10(config)#interface loopback1
    ZXR10(config-if)#ip addresss 192.168.1.1 255.255.255.0
    ZXR10(config-if)#exit

    1.RIP路由的基本配置
    步骤1:路由器R1的配置
    ZXR10(config)#router rip
    以上命令用来启动rip路由协议。接着宣告RIP路由器接口上的网络,命令如下:
    ZXR10(config-route)#network 192.168.2.0 0.0.0.255
    注:宣告网络时使用反掩码。
    ZXR10(config-route)#network 40.1.1.4 0.0.0.3
    指定RIP协议版本,命令如下:
    ZXR10(config-route)#version 2
    关闭路由协议的自动汇总功能,命令如下:
    ZXR10(config-route)#no auto-summary

    步骤2:路由器R2的配置
    ZXR10(config)#router rip
    以上命令用来启动rip路由协议。接着宣告RIP路由器接口上的网络,命令如下:
    ZXR10(config-route)#network 192.168.1.0 0.0.0.255
    注:宣告网络时使用反掩码。
    ZXR10(config-route)#network 40.1.1.4 0.0.0.3
    指定RIP协议版本,命令如下:
    ZXR10(config-route)#version 2
    关闭路由协议的自动汇总功能,命令如下:
    ZXR10(config-route)#no auto-summary

    3.查看和验证
    步骤1:查看两个路由器的路由表
    路由器R1的输出结果如图1-3所示:
    在这里插入图片描述

    图1-3 路由器R1的路由表

    路由器R2的输出结果如图1-4所示:
    在这里插入图片描述

    图1-4 路由器R2的路由表

    步骤2:从两台路由器互ping对方的loopback1接口的地址。
    从路由器R1ping路由器R2的loopback1接口地址192.168.1.1,结过可以ping通,如图1-5所示:
    在这里插入图片描述

    图1-5 在路由器R1上的ping通结果

    四、实验验证

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    五、实验思考与总结

    1. 动态路由:是运行在路由器上的软件进程,通过该进程路由器上相同路由协议之间交换路由信息。
      优点:是可以自动适应网络状态的变化,自动维护路由信息而不用网络管理员的参与。
      缺点:由于需要相互交换路由信息,需要占用网络带宽,并且要占用系统资源,另外安全性也不如静态路由。
    2. 常见的动态路由协议:
      1 ) RIP ( Routing Information Protocol )路由选择信息协议,使用UDP作为传输协议,端口号520,协议号为17。
      2 ) OSPF ( Open Shortest Path First )开放式最短路径优先, OSPF工作在网络层,协议报文直接封装在IP报文中,协议号89 ,可靠性需要自身保证。
      3 ) BGP ( Border Gateway Protocol )边界网关协议,使用TCP作为传输协议,端口号179,协议号是6。
    展开全文
  • RIP路由协议原理

    2020-06-13 14:18:13
    路由协议基础1.1 自治系统(AS)1.2 路由协议分类2. RIP协议基本原理3. RIP路由表形成4. RIP消息格式5. RIP-1与RIP-25 .1RIP-1的报文格式5.2 RIP-2的报文格式5.3 运行RIP-1和RIP-2版本的不同5.3.1 运行RIP-1的时候...

    RIP


    思维导图

    1. 路由协议基础

    1.1 自治系统(AS)

    自治系统(Autonomous System,AS):在网络中一个自治系统指的是若干个二层网络及若干路由器组成的集合,集合中的这些网络和这些路由器属于同一个管理机构。规模大小不同,一个 internet 可以包含一个或多个AS

    1.2 路由协议分类

    • 路由协议分为两大类,一类是IGP(Interior Gateway Protocol,内部网关协议),一类是EGP(Exterior Gateway Protocol ,外部网关协议 )
    • IGP成员有RIP(Routing Information Protocol)OSPF(Open Shortest Path First)IS-IS(Intermediate System to Intermediate System)等;
    • EGP成员虽然也有若干个协议,但是目前使用的就只有一个BGP(Border Gateway Protocol)

    2. RIP协议基本原理

    • RIP是一种基于距离矢量(Distance Vector,简称DV)算法的IGP协议,其协议的优先级为100(华为),120(思科);

    • 以“跳数”作为开销,所谓“跳数”就是到达目的地需要经过的路由器个数,跳数>=16时视为不可达路由,使得RIP只能应用于小规模的网络;

    • 周期性更新路由表,即使在稳定状态下,路由交换过程仍然会继续进行;

    3. RIP路由表形成

    一台路由器在创建RIP路由表初期,RIP路由表中只包含直连路由。随后路由器会不断接收从邻居发来的路由信息,并根据这些路由信息来完善自己的路由表。同时路由器会每隔30s向邻居路由器发起更新请求。

    4. RIP消息格式

    • RIP的消息格式有两种:一种是RIP请求消息(Request),另一种是RIP响应消息(Response)

    • RIP路由器发送请求消息给邻居路由器,邻居路由器收到后就会立即发送响应消息给邻居路由器;

    • RIP路由器可以随时向邻居发出请求消息;

    • RIP路由器总是会每隔30s周期性向邻居路由器发送响应消息

      RIP请求消息有两种

      1. 请求消息用来请求关于某一些指定的路由信息;
      2. 请求关于整个RIP网络的路由信息,RIP刚刚启动的时候应该是采用第二种RIP请求消息

    5. RIP-1与RIP-2

    ​ RIP协议有两个版本,RIP-1和RIP-2,基于UDP协议,使用的端口号为520

    5 .1RIP-1的报文格式

    RIP-1报文由头部(Header)和多个路由表项(Route Entries)部分组成。在一个RIP报文中,最多可以有25个路由表项。RIP是一个基于UDP协议的,并且RIP-1的数据包不能超过512字节

    字段名长度含义
    Command(命令)8比特标识报文的类型: 1:Request报文,向邻居请求全部或部分路由信息; 2:Reponse报文,发送自己全部或部分路由信息,一个Response报文中最多包含25个路由表项。
    Version(版本)8比特RIP的版本号: 1:RIP-1 2:RIP-2
    Must be zero16 比特必须为零字段。
    AFI(Address Family Identifier)协 议簇16比特地址族标识,其值为2时表示IP协议。对于Request报文,此字段值为0。
    Route Tag16比特外部路由标记。
    IP Address32比特该路由的目的IP地址,可以是自然网段的地址,也可以是子网地址或主机地址。
    Metric32比特路由的开销值。对于Request报文,此字段为16。

    5.2 RIP-2的报文格式

    字段名长度含义
    Command(命令)8比特标识报文的类型: 1:Request报文,向邻居请求全部或部分路由信息; 2:Reponse报文,发送自己全部或部分路由信息,一个Response报文中最多包含25个路由表项。
    Version(版本)8比特RIP的版本号: 1:RIP-1 2:RIP-2
    Must be zero16比特必须为零字段。
    AFI(Address Family Identifier)协议簇16比特地址族标识,其值为2时表示IP协议。对于Request报文,此字段值为0。
    Route Tag16比特外部路由标记。
    IP Address32比特该路由的目的IP地址,可以是自然网段的地址,也可以是子网地址或主机地址。
    Subnet Mask32比特目的地址的掩码。
    Next Hop32比特提供一个更好的下一跳地址。如果为0.0.0.0,则表示发布此路由的路由器地址就是最优下一跳地址。
    Metric32比特路由的开销值。对于Request报文,此字段为16。

    5.3 运行RIP-1和RIP-2版本的不同

    5.3.1 运行RIP-1的时候

    1. 对于请求消息或周期性的响应消息(情况1),IP报文的目的地址为广播地址255.255.255.255,源地址为发送该请求消息或响应消息的接口的IP地址,协议字段的值为0x11

    2. 为了回应请求消息而发送的响应消息(情况2),IP报文的目的地址为发送请求消息接口的IP地址,源地址为发送响应消息的接口的IP地址,协议字段0x11

      • 接下来,IP报文又是封装在以太网帧中(假设路由器的接口都是以太网接口)
    • 对于情况1,以太网帧的目的MAC地址是ff-ff-ff-ff-ff-ff,源地址是发送请求消息或响应消息的接口的MAC地址,类型字段为0x0800。

    • 对于情况2,以太网帧的目的MAC地址是发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,类型字段为0x0800。

    5.3.2 运行RIP-2的时候

    1. 对于请求消息或周期性的相应消息(情况1),IP报文的目的地址为组播地址224.0.0.9,也可以为广播地址255.255.255.255,源地址为发送该请求消息或响应消息的接口的IP地址,协议字段的值为0x11。

    2. 为了回应请求消息而发送的响应消息(情况2),IP报文的目的地址为发送请求消息接口的IP地址,源地址为发送响应消息的接口的IP地址,协议字段0x11。

      • 接下来,IP报文又是封装在以太网帧中(假设路由器的接口都是以太网接口)

        • 对于情况1,以太网帧的目的MAC地址是ff-ff-ff-ff-ff-ff,源地址是发送请求消息或响应消息的接口的MAC地址,类型字段为0x0800。

        • 对于情况2,以太网帧的目的MAC地址是发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,类型字段为0x0800。

    5.3.3 RIP-1与RIP-2的不同

    1. RIP-1只支持有类路由;RIP-2支持无类路由,支持VLSM,CIDP等特性;
    2. RIP-1不支持认证功能;RIP-2可以支持认证功能,因此安全性得到提高;
    3. RIP-1不能采用组播方式发布消息;RIP-2可以采用组播方式发布消息,因此RIP-2比RIP-1占用更少的设备处理资源;

    6. RIP定时器

    RIP协议有三种定时器:分别是更新定时器(Update Timer)无效定时器(Invalid Timer)垃圾收集定时器(Carbage Collection Timer)

    6.1 更新定时器

    更新定时器也可以称为周期定时器(Periodic Timer),每台RIP路由器都有一个属于自己的RIP更新定时器。缺省情况下,周期值为30s。每当更新定时器倒计时值为0时,路由器就会向所有邻居发送RIP响应消息,当路由器收到RIP请求消息时候,会立即发送RIP响应消息,但是不影响基于更新定时器的周期性RIP响应消息的发送

    6.2 无效定时器

    每个路由器都建立并维护一个无效定时器。缺省情况下,无效定时器值为180s(更新定时器周期的6倍)。当一个路由项的无效定时器的值倒计时为0时,就说明该路由表项已经有180s的时间没有别更新,此时路由表会认为该路由项已经变为一个无效的路由项,也就是认为该路由项所指的所指的目的地已经变为不可达,于是路由器会将该路由的cost值设置为16.

    6.3 垃圾收集定时器

    • 当无效定时器值倒计时为0时,该路由项是一个无效路由项,其cost值就会被设置为16。此时路由器不会立即将这个无效的路由项删除掉,而是会为该路由项启用一个被称为垃圾收集定时器的倒数计时器。垃圾收集定时器的缺省值为120s。

    • 在垃圾收集定时器倒计时为0之前,该路由器仍然会周期性在RIP响应消息中携带这条无效的路由信息,其目的是为了告诉他的所有邻居这条路由项对于自己来说已经无效,以便路由器能够及时对各自的RIP路由表中的相应的路由项进行更新。

    • 一旦垃圾收集定时器的值倒计时为0时,路由器就会将这条无效路由项删除。(注意:在垃圾收集定时器为0前的某一时刻,该无效路由被更新,即Cost的值更新为小于16,则该路由项的的无效定时器会被复位成初始值,然后重新计时,相应的垃圾收集定时器则会被删除掉

    7. RIP环路问题

    假设路由器C发生故障(E0接口down掉),RC监测到该故障后会立即向RB发送故障信息(跳数设置为16)表示10.4.0.0为无效路由。然而,在RC准备将这条无效路由周期性响应消息发给RB的时候,收到RB周期性的相应消息,其中包含10.4.0.0 网段的路由信息,那么这个时候RC就会认为通过RB可以到达10.4.0.0网段,所以RC就在10.4.0.0路由项的跳数上+1,RB又会从RC学习到这条路由并且会通告给自己的邻居,那么不断往复,就产生了环路。

    8. 环路解决

    华为的环路解决方案提供了触发更新水平分割毒性逆转三种

    8.1 触发更新

    • 所谓触发更新,就是指RIP路由表中的某些路由项的内容发生改变时,路由器应立即向它的所有邻居发布响应消息,而不用等待更新定时器所规定的下一个响应消息的发送时刻。(立即更新)

    • 另外,触发更新响应消息中只需要包含路由信息发生了改变的路由项,减少带宽及路由器处理资源的消耗

    注意如果对方未收到触发更新的消息,本端就收到一个周期性响应消息,这种情况下仍然会产生路由。但是触发更新在一定程度上降低了环路产生的概率。

    8.2 水平分割

    水平分割的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由器在通过Interface-x接口向外发送响应消息时,响应消息一定不要包含关于z/y这个路由项的信息。(从哪里学到就不发回哪里

    8.3 毒性逆转

    毒性逆转的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由通过Interface-x接口向外发送消息时,响应消息中仍然需要包含z/y这个路由项,但是这个路由项的Cost值总是16。

    里`)

    8.3 毒性逆转

    毒性逆转的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由通过Interface-x接口向外发送消息时,响应消息中仍然需要包含z/y这个路由项,但是这个路由项的Cost值总是16。

    展开全文
  • RIP路由协议实验

    2020-12-07 11:33:27
    RIP路由协议实验 RIP简介:RIP是Routing Information Protocol(路由信息协议)的简称,它是一种较为简单的内部网关协议(Interior Gateway Protocol)。RIP是一种基于距离矢量(Distance-Vector)算法的协议,它...
  • (转)示例化讲解RIP路由更新机制

    千次阅读 2019-08-15 16:10:02
    该通告报文中携带了除“水平分割”机制抑制的RIP路由之外本地路由器中的所有RIP路由信息。而“触发更新”则是RIP路由器仅在有路由表项发生变化时发送的RIP路由通告, 仅携带本地路由表中有变化的路由信息 。RIP...
  • 由于RIP部分涉及内容较多,此博文将持续更新。更新结束,会删除此行。 RIP理论知识:https://blog.csdn.net/weixin_45839854/article/details/105743828
  • 实验原理 是最早的距离矢量IP路由协议,也是最先得到广泛使用的一种路由协议,使用跳数来衡量网络间的距离,从一台路由器到直连网络的跳数定义为1,到非直连的距离没经过一台路由器...掌握测试rip路由网络连通性的方法
  • 还可配置RIP路由优先级、开销、3个定时器参数、水平分隔、毒性反转、RIPv2的路由聚合、RIPv2报文验证及RIP路由信息发布和接收控制、RIP与静态BFD/动态BFD联动。 RIP基础 RIP是一种较为简单的内部网关协议(IGP),...
  • RIP路由特点

    2020-12-23 14:10:16
    RIP(Routing Information Protocol,路由信息协议)是一种较为简单的内部网关协议(Interior Gateway Protocol,IGP),主要用于规模较小的网络中,比如校园网以及结构较 简单的地区性网络。对于更为复杂的环境和...
  • RIP路由协议配置

    千次阅读 2020-05-07 21:45:03
    一、 实验目标和要求:(分条目来写) 实验目的: 掌握RIP动态路由协议的配置、诊断方法。...RIP路由信息协议:是应用较早、使用较普遍的IGP,适用于小型同类网络,是典型的距离矢量协议。 RIP协议以跳数做为衡...
  • RIP 路由配置实验

    2020-01-01 23:23:27
    (2)RIP路由的基本配置 1、路由器R1的配置 Cgt01(config)#router rip Cgt01(config-router)#network 10.51.2.1 0.0.0.0 Cgt01(config-router)#network 10.51.1.0 0.0.0.3 Cgt02(config-router)#network 10.51...
  • 实验原理 当路由条目很多的时候,可以使用路由汇总来减少路由条目,加快收敛和...基于RIP进程的有类自动汇总:比如对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,聚合成自然网段路由10.0.0.0/8
  • RIP路由协议(距离矢量路由选择协议) 运行距离矢量的路由器就关心两样事情: 1、将路由通过广播或组播的形式发送给所有配置了该协议的接口。 2、从接口接收邻居路由器发来的路由信息,并根据距离和矢量的组合放入到...
  • 1. RIP路由算法   RIP协议是基于Bellham-Ford(距离矢量)算法,即贝尔曼算法,该路由算法可以根据路径参数,也就是度量值的好坏来生成路由条目。 如图1所示,如果收到邻居给的路由,若本地没有,则接收。 ...
  • RIP路由信息协议 标准的距离矢量型路由协议,基于UDP 520端口工作,优先级100 采用跳数作为度量,默认仅存在更新包,邻居间直接共享路由表 更新包—数据包—携带路由条目 跳数:经过路由器的个数 周期更新—30s ...
  • RIP路由和静态路由

    千次阅读 2019-11-19 21:02:08
    使用route rip进行路由学习,路由器配置如下 ////////////////////////////////////////////////// 路由器R1 R1(config)#router rip R1(config-router)#version 2 R1(config-router)#network 192.168.1.0 R1...
  • 作者:最铁头的网工 (全球首批HCIA-DATACOM认证者) 认证技术:关于华为认证技术知识会在我...一、RIP路由汇总功能介绍 rip的路由汇总功能,能够对rip 学习/自己产生 的明细路由做汇总后传递给rip邻居,减少路由器...
  • 路由篇一:RIP路由环路形成及防环

    千次阅读 2019-07-25 11:59:40
    RIP路由环路形成及防环 认识环路及防环前先清楚RIP路由算法: Bellman算法(贝尔曼): ①如果收到邻居给的路由,若本地没有,则接收; ②如果收到邻居给的路由,若本地有,根据度量值对比,若优则录入, 若...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 39,940
精华内容 15,976
关键字:

rip路由