精华内容
下载资源
问答
  • 两个不同网段的计算机与三层交换机直连,通过SVI实现VLAN间通信vlan 1 //几个不同网段就创建几个VLANvlan 2int f0/1 //划分VLANswitchport mode accessswitchport access vlan 1int f0/2 //划分VLANswitchport mode ...

    两个不同网段的计算机与三层交换机直连,通过SVI实现VLAN间通信

    vlan 1 //几个不同网段就创建几个VLAN

    vlan 2

    int f0/1 //划分VLAN

    switchport mode access

    switchport access vlan 1

    int f0/2 //划分VLAN

    switchport mode access

    switchport access vlan 2

    int vlan 1 //进入VLAN,配置SVI接口地址

    ip address 192.168.1.1 255.255.255.0

    no shutdown

    int vlan 2 //进入VLAN,配置SVI接口地址

    ip address 192.168.2.1 255.255.255.0

    no shutdown

    ip routing // 开启 路由功能!!!!!!!!!!!!!

    两个不同网段的计算机通过二层交换机与三层交换机相连,通过SVI实现VLAN间通信

    在二层交换机上创建vlan

    将二次交换机上与主机相连的口划进vlan

    switchport trunk encapsulation dot1q

    将二次交换机上与三层交换机相连的口的工作模式改为trunk(命令为:switchport mode trunk)

    在三层交换机创建vlan

    进入vlan配置SVI接口地址(命令为:ip address [ip] [子网掩码])

    配置完成后需要开启接口!!!!(命令为:no shutdown)

    然后将三层交换机上与二次交换机相连的口的工作模式改为trunk(命令为:switchport mode trunk)

    ip routing // 开启 路由功能!!!!!!!!!!!!!

    展开全文
  • 二层交换机,只做同网段或同vlan转发功能,要实现vlan间的数据转发需要使用单臂路由,或者使用三层交换机2.在三层交换机上使用iprouting命令将交换机转到三层工作模式3.此时可以在每个vlan上配上不同网段的IP,不同...

    先总结一下,后面的是实验结果:

    1.

    二层交换机,只做同网段或同

    vlan

    转发功能,要实现

    vlan

    间的数据转发需要使用单臂路

    由,或者使用三层交换机

    2.

    在三层交换机上使用

    ip routing

    命令将交换机转到三层工作模式

    3.

    此时可以在每个

    vlan

    上配上不同网段的

    IP

    ,不同

    vlan

    之间的终端设备

    (

    pc)

    可以通过交

    换机互相通信

    (

    不需指定网关

    )

    不知道下面这段话有没有实际意义:

    如果某些接口所连设备是属于不同

    vlan(

    网段

    )

    的路由器,

    [

    由于路由器的路由功能,

    不同

    vlan

    间路由器不像

    pc

    可以

    ping

    通,

    除非进行后面的配置:

    ]

    路由器必须加静态路由或者在交换机上和路由器上启动路由协议,如

    ospf

    4.

    还可以将交换机接口配置成三层接口:

    no switchport

    ,取消命令:

    switchport

    成为三层接口后就可以在其上配置

    IP

    地址,可以在路由器和交换机上走路由协议来连通不

    同网段,或在路由器上配静态路由也可以

    以上

    2

    为必做,

    3

    vlan

    间需要转发数据的场景,

    4

    为仅仅把三层交换机当路由器的功能来

    3

    也叫

    SVI

    ,即

    VLAN

    虚接口

    SW#show ip route

    *Mar

    1 00:05:01.927: %SYS-5-CONFIG_I: Configured from console by console

    Default gateway is not set

    Host

    Gateway

    Last Use

    Total Uses

    Interface

    ICMP redirect cache is empty

    如果没有启动

    ip routing

    ,则启用路由协议的时候会报错

    SW(config)#router ospf 100

    IP routing not enabled

    开启交换机三层功能:

    SW(config)#ip routing

    SW#show ip route

    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

    ia - IS-IS inter area, * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    SW(config)#int fa 0/0

    展开全文
  • 二层交换机,只做同网段或同vlan转发功能,要实现vlan间的数据转发需要使用单臂路由,或者使用三层交换机2.在三层交换机上使用ip routing命令将交换机转到三层工作模式3.此时可以在每个vlan上配上不同网段的IP,不同...

    先总结一下,后面的是实验结果:

    1.二层交换机,只做同网段或同vlan转发功能,要实现vlan间的数据转发需要使用单臂路由,或者使用三层交换机

    2.在三层交换机上使用ip routing命令将交换机转到三层工作模式

    3.此时可以在每个vlan上配上不同网段的IP,不同vlan之间的终端设备(如pc)可以通过交换机互相通信(不需指定网关)

    不知道下面这段话有没有实际意义:如果某些接口所连设备是属于不同vlan(网段)的路由器,[由于路由器的路由功能,不同vlan间路由器不像pc可以ping通,除非进行后面的配置:],路由器必须加静态路由或者在交换机上和路由器上启动路由协议,如ospf

    4.还可以将交换机接口配置成三层接口:no switchport,取消命令:switchport

    成为三层接口后就可以在其上配置IP地址,可以在路由器和交换机上走路由协议来连通不同网段,或在路由器上配静态路由也可以

    以上2为必做,3为vlan间需要转发数据的场景,4为仅仅把三层交换机当路由器的功能来用

    3也叫SVI,即VLAN虚接口

    SW#show ip route

    *Mar 1 00:05:01.927: %SYS-5-CONFIG_I: Configured from console by console

    Default gateway is not set

    Host Gateway Last Use Total Uses Interface

    ICMP redirect cache is empty

    如果没有启动ip routing,则启用路由协议的时候会报错

    SW(config)#router ospf 100

    IP routing not enabled

    开启交换机三层功能:

    SW(config)#ip routing

    SW#show ip route

    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

    ia - IS-IS inter area, * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    SW(config)#int fa 0/0

    SW(config-if)#ip address 10.0.0.1 255.255.255.0

    % IP addresses may not be configured on L2 links.

    配成三层交换机后,端口可以打no switchport将二层端口变为三层端口

    SW(config-if)#no switchport

    注:如果使用了这条命令,switchport mode access(trunk)不可用,要使用的话必须用switchport命令改回来

    SW(config-if)#ip address 10.0.0.1 255.255.255.0

    SW(config-if)#end

    SW#show ip route

    10.0.0.0/24 is subnetted, 2 subnets

    C 10.1.2.0 is directly connected, FastEthernet0/1

    C 10.0.0.0 is directly connected, FastEthernet0/0

    成为三层交换机后路由表也有了信息

    三层交换机也可以走ospf等路由协议

    与路由器连接口不一定要启用no switchport

    也可以用svi,svi也是一个3层概念的接口

    IP地址配在VLAN上:

    SW#vlan database

    SW(vla

    展开全文
  • 2.使用SVI实现VLAN间的通信(图)环境:一台三层交换机,两台pc机三层交换机的配置:Switch》enableSwitch#configure terminalEnter configuration commands, one per line. End with CNTL/Z.创建vlan 10 20Switch...

    2.使用SVI实现VLAN间的通信(图)

    环境:一台三层交换机,两台pc机

    三层交换机的配置:

    Switch》enable

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    创建vlan 10 20

    Switch(config)#vlan 10

    Switch(config-vlan)#vlan 20

    Switch(config-vlan)#exit

    配置SVI接口ip

    Switch(config)#interface vlan 10

    %LINK-5-CHANGED: Interface Vlan10, changed state to up

    Switch(config-if)#ip address 192.168.10.1 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#interface vlan 20

    %LINK-5-CHANGED: Interface Vlan20, changed state to up

    Switch(config-if)#ip address 192.168.20.1 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    改变接口模式并加入vlan

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 10

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

    Switch(config-if)#interface fastEthernet 0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 20

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

    Switch(config-if)#

    看三层交换机的路由表:

    Switch#show ip route

    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

    * - candidate default, U - per-user static route, o - ODR

    P - periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.10.0/24 is directly connected, Vlan10

    C 192.168.20.0/24 is directly connected, Vlan20

    Switch#

    两主机的配置与单臂路由中两主机的配置一样

    3.跨交换机实现VLAN间的通信(图)

    环境:一台三层交换机,两台二层交换机,两台pc机

    三层交换机的配置(SW3)

    Switch》enable

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    创建vlan 10 、 20 并设置ip

    Switch(config)#vlan 10

    Switch(config-vlan)#vlan 20

    Switch(config-vlan)#exit

    Switch(config)#interface vlan 10

    %LINK-5-CHANGED: Interface Vlan10, changed state to up

    Switch(config-if)#ip address 192.168.10.1 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#interface vlan 20

    %LINK-5-CHANGED: Interface Vlan20, changed state to up

    Switch(config-if)#ip address 192.168.20.1 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    设置接口模式并加入相应的vlan(注意trunk口的设置)

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#interface fastEthernet 0/1

    Switch(config-if)#switchport access vlan 10

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#interface fastEthernet 0/2

    Switch(config-if)#switchport access vlan 20

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

    Switch#

    看路由表

    Switch#show ip route

    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

    * - candidate default, U - per-user static route, o - ODR

    P - periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.10.0/24 is directly connected, Vlan10

    C 192.168.20.0/24 is directly connected, Vlan20

    SW21的配置

    Switch》enable

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#vlan 10

    Switch(config-vlan)#exit

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#switchport mode trunk

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

    Switch(config-if)#interface fastEthernet 1/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 10

    Switch(config-if)#exit

    Switch(config)#

    SW22的配置

    Switch》

    Switch》en

    Switch#

    Switch#configure ter

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#inter fas 1/1

    Switch(config-if)#switchport mode trunk

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up

    Switch(config-if)#switchport mode access

    Switch(config-if)#inter fas 2/1

    Switch(config-if)#switchport mode trunk

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to up

    Switch(config-if)#exit

    Switch(config)#vlan 20

    Switch(config-vlan)#inter fas 1/1

    Switch(config-if)#switchport access vlan 20

    Switch(config-if)#

    注意:两交换机之间的链接是trunk链路

    4.以上配置在模拟器上都可实现

    在模拟器上配置其中pc图片

    上述三种方式pc机的配置都一样

    验证:

    展开全文
  • 【实验名称】VLAN/802.1Q-VLAN 间通信。【实验目的】通过三层交换机实现VLAN 间互相通信。【背景描述】假设某企业有两个主要部门:销售部和技术部,其中销售部门的个人计算机系统分散连接在两台交换机上,他们之间...
  • 不同VLAN在二层肯定不能通信,如果要通信只能走三层。例如交换机上接了两台处于不同VLAN的PC,它们间要通信只能走三层。你可以将每个VLAN的以太口和路由器连接,但VLAN多的话路由器口不够用。所以通常路由器只用一个...
  • ip default-gateway 192.168.255.254 //为交换机自身指定网关创建VLAN和创建SVI的方法也是不一样的:switch(config)#interface vlan 255 //这是创建VLAN对应的SVI在二层交换机中,很多人会把VLANSVI混淆,...
  • 验名称:利用三层交换机(SVI方法)实现不同vlan间的通信。实验目的:通过三层交换机实现vlan间相互通信,掌握三层交换机VLAN路由的配置方法。技术原理:三层交换机的每一个接口连接一个独立的VLAN,为每个VLAN创建...
  • 例如我们创建了VLAN10,那么VLAN10对应的SVI接口就是interface vlan10或者叫SVI10,是一个三层接口,可以为这个SVI口配置IP地址,与VLAN10内的PC用户的IP地址同一网段。如此一来,VLAN10的用户就能够将网关指...
  • 三层交换机完美地解决了VLAN间的互通,不过还有个问题:网络中VLAN的数量如果很多,那就需要给每个VLAN配置一个SVI接口!这可不是件轻松的活,如果有1000个VLAN,那你就要弄出1000个SVI接口,配置1000个IP地址作为每...
  • 这里就需要用到所谓的路由子接口了,大概意思就是说去往路由器的路径在这里只有一条,而pc1与pc2又属于不同vlan,那么就需要在路由器端模拟把这条唯一的路径拆成两个路径。设置trunk转发那么首先要让LSW1交换机的...
  • 使用SVI实现VLAN间的互访

    千次阅读 2019-03-06 17:13:22
    例如我们创建了VLAN10,那么VLAN10对应的SVI接口就是interface vlan10或者叫SVI10,是一个三层接口,可以为这个SVI口配置IP地址,与VLAN10内的PC用户的IP地址同一网段。如此一来,VLAN10的用户就能够将网关指向...
  • 从这篇文章开始我和大家一起学习...VLAN,是英文VirtualLocalAreaNetwork的缩写,中文名为"虚拟局域网",VLAN是 一种将局域网(LAN)设备从逻辑上划分(注意,不是从物理上划分)成一个个网段(或者 说是更小的局...
  • 主要为大家介绍了二层交换机中VLANSVI区别,SVI的实质是一个接口,只是是软件虚拟的,不是物理的,它和VLAN是对应的,一个VLAN可以对应一个逻辑的VLAN接口,也就是这里的SVI,但他们是不同的对象
  • VLANSVI是两个不同的概念

    千次阅读 2016-03-26 08:07:08
    VLANSVI是两个不同的概念,SVI(switch virtual interface)的实质是一个接口,只是是软件虚拟的,不是物理的,它和VLAN是对应的,一个VLAN可以对应一个逻辑的VLAN接口,也就是这里的SVI,但他们是不同的对象,不可...
  • 1、 总公司配置SVI接口(虚拟交换接口,给vlan配置IP地址)的vlan间通信 2、 分公司配置单臂路由(物理接口下面的逻辑子接口)的vlan间通信 3、 总公司三层交换机的f0/2接口使用SVI接口方式配置IP地址,使的与R1...
  • 目录vlan介绍vlan的优点vlan的配置实现不同交换机上的同一个vlan通信实现不同vlan间通信方法一:使用三层交换机,配置SVI虚拟接口作为不同vlan网关,并开启路由功能来实现方法二:使用单臂路由来实现 vlan介绍 ...
  • 例如我们创建了VLAN10,那么VLAN10对应的SVI接口就是interface vlan10或者叫SVI10,是一个三层接口,可以为这个SVI口配置IP地址,与VLAN10内的PC用户的IP地址同一网段。如此一来,VLAN10的用户就能够将网关指...
  • vlan虚拟局域网(虚网,交换机所特有的技术) 作用: 1.交换机通过划分虚拟局域网,从而隔离广播域—就是从二层,从MAC地址,让他们变成不同的局域网。 2.在大型的企业内网,可以通过交换机(二层、三层)上部署...
  • VLANSVI是两个不同的概念,SVI(switch virtual interface)的实质是一个接口,只是是软件虚拟的,不是物理的,它和VLAN是对应的,一个VLAN可以对应一个逻辑的VLAN接口,也就是这里的SVI,但他们是不同的对象,不可...
  • SVI接口 (交换机虚拟接口)

    万次阅读 2013-10-13 10:59:07
     SVI接口 (交换机... 一个交换机虚拟接口(Switch Virtual Interface,SVI)代表一个由交换端口构成的VLAN(其实就是通常所说的VLAN接口),以便于实现系统中路由和桥接的功能。一个交换机虚拟接口对应一个VL
  • VLAN---虚拟局域网

    2020-05-13 22:20:01
    VLAN虚拟局域网 二层交换机与3层的设备协同工作后,将原来的一个广播域逻辑的切分为多个 一、思科逻辑配置思路: 1、交换机上创建VLAN 2、接口划入VLAN 3、Trunk干道 4、VLAN间路由—路由器子接口 多层交换机svi ...
  • 交换机虚拟接口----vlan-interface

    千次阅读 2014-01-08 10:26:52
    交换机虚拟接口(switch virtual interface,SVI)定义:是指通常所说的VLAN接口,不过它是虚拟的,用于连接整个也叫作逻辑三层接口和三层接口。 SVI创建时间:在全局命令(在N5501i中为interface vlan-interface)...
  • vlan

    2021-01-14 22:37:03
    汇聚层(分布层)— 流量的聚合 – VLAN STP SVI HSRP VRRP CHENNL… 核心层 高速转发—路由-NAT 冗余—备份 设备冗余 线路冗余 网关冗余 UPS电源冗余 VLAN虚拟局域网 逻辑的将一个广播域切分为多个; 配置思路:...
  • VLAN

    2020-05-22 16:22:44
    VLAN虚拟局域网 二层交换机与三层的设备协同工作后,将原来的一个广播域逻辑的切分为多个 思科逻辑配置思路: 1、 交换机上创建VLAN 2、 接口划入VLAN 3、 Trunk干道 4、 VLAN间路由 - -路由器子接口 多层交换机 -...
  • SVI、channel

    2019-11-26 20:10:15
    但正常的二层设备不能配置IP地址,故二层交换机上默认存在一个SVI-交换虚拟接口; 该接口可以配置ip地址,出厂就存在MAC地址–该MAC还用于STP的选举; 又因为交换机上存在vlan技术,该SVI接口处于哪个vlan,...
  • SVI -- 交换虚拟接口 一台正常的二层交换机,物理接口是无法配ip地址,且MAC地址也没有; 故在二层交换机上只存在一个SVI接口,该接口出厂存在MAC地址,且该接口可以配置ip,作为被远程登录时的设备ip; 该MAC...
  • 1、创建VLAN其实只要分为2步,只需要2条命令:①如果需要把网关放在EX2200里,就是需要创建一个虚拟的三层接口SVI,所以我们可以先创建一个SVI作为即将创建的VLAN网关。②创建VLAN的同时,把虚拟接口SVIvlan匹配...
  • 目录VLAN概述VLAN配置实例单臂路由使用SVI实现VLAN间路由基于三层交换机的VLAN间的通信Private VLAN(解决VLAN数量受限)Super VLAN(节省IP地址) VLAN概述 VLAN出现的背景:分割广播域而出现 VLAN(Virtual Local...

空空如也

空空如也

1 2 3 4 5
收藏数 98
精华内容 39
关键字:

svi虚拟vlan