精华内容
下载资源
问答
  • 2019-06-12 09:31:31

    1.设置主机名/系统名 switch(config)# hostname “hostname” switch(enable) set system name name-string
    2.设置登录口令 switch(config)# enable password level 1 password switch(enable) set password
    switch(enable) set enalbepass
    3.设置远程访问 switch(config)# inte***ce vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address switch(enable) set inte***ce sc0 ip-address netmask broadcast-address
    switch(enable) set inte***ce sc0 vlan
    switch(enable) set ip route default gateway
    4.启用和浏览CDP信息 switch(config-if)# cdp enable
    switch(config-if)# no cdp enable switch(enable) set cdp {enable|disable} module/port
    5.查看Cisco邻接设备的CDP通告 switch# show cdp inte***ce [type modle/port]
    switch# show cdp neighbors [type module/port] [detail] switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
    6.端口描述 switch(config-if)#description escription-string switch(enable)set port name module/number description-string
    7.设置端口速度 switch(config-if)# speed{10|100|auto} switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}
    8.设置以太网的链路模式 switch(config-if)# duplex {auto|full|half} switch(enable) set port duplex module/number {full|half
    9.配置静态VLAN switch# vlan database
    switch(vlan)# vlan vlan-num name vla
    switch(vlan)# exit
    switch# configure teriminal
    switch(config)#inte***ce inte***ce module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list
    10.配置VLAN中继线 switch(config)# inte***ce inte***ce mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)#switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list switch(enable)set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]

    更多相关内容
  • 交换机基本状态:hostname>/用户模式hostname#/特权模式hostname(config)#/全局配置模式hostname(config-if)#/接口状态交换机口令设置:switch>enable/进入特权模式switch#configterminal/进入全局配置模式...

    交换机基本状态:

    hostname>/用户模式

    hostname#/特权模式

    hostname(config)#/全局配置模式

    hostname(config-if)#/接口状态

    交换机口令设置:

    switch>enable/进入特权模式

    switch#configterminal/进入全局配置模式

    switch(config)#hostname/设置交换机的主机名

    switch(config)#enablesecretxxx/设置特权加密口令

    switch(config)#enablepasswordxxa/设置特权非密口令

    switch(config)#lineconsole0/进入控制台口

    switch(config-line)#linevty04/进入虚拟终端

    switch(config-line)#login/允许登录

    switch(config-line)#passwordxx/设置登录口令xx

    switch#exit/返回命令

    交换机VLAN设置:

    switch#vlandatabase/进入VLAN设置

    switch(vlan)#vlan2/建VLAN

    2switch(vlan)#novlan2/删vlan

    2switch(config)#intf0/1/进入端口1

    switch(config-if)#switchportaccessvlan2/当前端口加入

    vlan2switch(config-if)#switchportmodetrunk/设置为干线

    switch(config-if)#switchporttrunkallowedvlan1,2/设置允许的

    vlanswitch(config-if)#switchporttrunkencapdot1q/设置vlan中继

    switch(config)#vtpdomain/设置发vtp域名

    switch(config)#vtppassword/设置发vtp密码

    switch(config)#vtpmodeserver/设置发vtp模式

    switch(config)#vtpmodeclient/设置发vtp模式

    交换机设置IP地址:

    switch(config)#interfacevlan1;进入vlan1

    switch(config-if)#ipaddress;设置IP地址

    switch(config)#ipdefault-gateway;设置默认网关

    switch#dirflash:;查看闪存

    交换机显示命令:

    switch#write/保存配置信息

    switch#showvtp/查看vtp配置信息

    switch#showrun/查看当前配置信息

    switch#showvlan/查看vlan配置信息

    switch#showinterface/查看端口信息

    switch#showintf0/0/查看指定端口信息

    补充:3层交换机多出的就是路由能力,体现在vlan的互相通信功能和端口的路由能力

    下面介绍:

    开启路由功能:iprouting进入vlan配置网段网关与路由配置接口相同

    interfacevlan1ip192.168.1.1255.255.255.0

    路由配置与路由器配置相同只是把接口换为VLAN+VLAN号,开启接口路由功能,进入接口配置:noswichport

    绿茶小编猜你还喜欢:

    无线路由器当交换机用:无线路由器做交换机设置教程

    交换机接无线路由器教程:交换机下接无线路由器步骤介绍

    展开全文
  • 思科交换机常用命令汇总

    千次阅读 2021-04-02 13:57:58
    思科交换机常用命令汇总 show version show running-config show vlan brief show ip interface brief show running-config interface f0/1 show ip route show inventory //显示设备SN、设备名 更换MAC地址 在...

    思科交换机常用命令汇总

    show version
    show running-config
    show vlan brief
    show ip interface brief
    show running-config interface f0/1
    show ip route
    show inventory			//显示设备SN、设备名
    

    更换MAC地址

    在网管服务器上找到相应的报警信息,记录下交换机的IP地址及端口号。
    telnet交换机的IP地址(这里使用CRT)

    #show running-configuration interface f0/1
    右键标记,选择有MAC地址的那行命令,回车
    conf t
    interface f0/1
    no 右键粘贴			//删除原先绑定的MAC地址,这个端口会自动学习到新的MAC
    end
    show run interface f0/1
    wr				   //一定要保存配置MAC地址绑定才能生效
    

    更改业务

    show vlan brie
    conf t
    interface f0/1
    switchport access vlan 2	//把端口加入新的VLAN中
    end
    show run interface f0/1
    wr
    

    新增端口

    conf t
    show run interface f0/1
    switchport port-security
    switchport port-security violation restrict
    switchport port-security mac-address sticky
    
    如果没有配置过,则打开一个配置过的端口
    复制除VLAN和绑定MAC地址以外的命令行
    
    switchport access vlan 2
    no shutdown
    end
    show run interface f0/1
    看到端口在VLAN2中,已经学到MAC地址
    wr
    

    清除MAC记录

    no switchport port-security mac-address sticky XXXX.XXXX.XXXX vlan access
    

    关闭端口

    清除MAC地址
    interface f0/1
    shutdown
    

    关闭端口安全

    interface f0/1
    no switchport port-security
    

    备份配置

    copy run tftp
    Address or name of remote host []? 192.168.32.1
    Destination filename [config.text]?TEST-3560-1 
    

    恢复配置

    copy tftp: run
    Address or name of remote host []? 192.168.32.1
    Source filename []? test.text
    Destination filename [running-config]? 
    

    清除配置

    清除交换机配置命令:write erase
    	当然也可以使用erase startup-config就可以实现清除了
    删除VLAN信息:delete flash:vlan.dat
    

    IOS升级

    1.确保路由器与服务器的连通性(路由器配IP地址)
    
    2.从服务器更新IOS镜像
    #copy tftp flash
    []192.168.1.100					服务器的地址
    []c1841-advipservicesk9-mz.124-15.Tw.bin	新IOS的名称,注意大小写
    []						复制过来后的名称
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...!!!!!!	开始复制文件
    
    3.察看并删除旧的IOS(在需要更新的路由器上进行操作)
    #show flash				察看要删除的镜像名称
    #delete flash
    []c1841-ipbasek9-mz.124-12.bin		输入删除的镜像名称,注意大小写
    
    4.重新配置系统并重启
    (c)#no boot system flash 旧镜像名	不让系统从旧的镜像启动
    (c)#boot system flash 新镜像名称	让系统以新镜像启动
    #copy running-config startup-config	将新的配置写到NVROM5.重启
    #reload
    
    展开全文
  • 思科交换机配置命令(详细命令总结归纳)

    千次阅读 多人点赞 2021-09-30 11:48:39
    一、交换机介绍 二、交换机配置 1、基本命令 2、常用命令 3、交换机恢复出厂配置 4、telnet 远程登录设置 5、交换机VLAN设置 (1)添加,删除 vlan (2)命名vlan (3)将端口加入vlan 6、交换机设置VLAN ...

    目录

    前言

    一、交换机介绍

    二、交换机配置

    1、基本命令

    2、常用命令

    3、交换机恢复出厂配置

    4、telnet 远程登录设置

    5、交换机VLAN设置

    (1)添加,删除 vlan

    (2)命名vlan

    (3)将端口加入vlan

    6、交换机设置VLAN IP地址

    7、Trunk的配置

    8、以太网通道配置(二层口)

    9、以太网通道配ip地址(三层口)

    10、VTP的配置

    11、三层交换机配置

    (1)配置虚拟接口IP地址

    (2)配置物理接口IP地址

    (3)配置DHCP中继

    12、STP生成树配置

    13、HSRP(热备份)配置

    结语


    前言


         交换机的配置过程复杂,而且根据品牌及产品的不同配置方法也各不相同,下面主要介绍一下思科交换机的配置方法(包含二层交换机与三层交换机)


    一、交换机介绍


         交换机分为网管型交换机和非网管型交换机(俗称傻瓜式交换机)

         非网管交换机插上网线即可使用,它可以识别数据包中的MAC地址信息, 然后根据MAC地址进行转发, 并将这些MAC地址与对应的端口记录在自己内部的一个地址表中

         网管型交换机就是可以根据自己的配置进行网络管理的交换机,网管型交换机常用Console端口对交换机进行配置


    二、交换机配置


    1、基本命令

    switch>用户模式
    switch>enable进入特权模式
    switch#特权模式
    switch#config terminal进入配置模式
    switch(config)#配置模式
    switch(config)#enable password abc123设置特权模式密码为abc123
    switch(config)#enable secret abc123设置特权模式密码为加密的密码abc123
    switch(config)#hostname sw1设置主机名为sw1
    sw1(config)#主机名变为sw1
    sw1(config)#end退回到特权模式
    sw1#特权模式
    sw1#exit退回到上一个模式
    sw1>

    用户模式

    2、常用命令

    switch(config)#enable password 密码配置交换机进入特权模式密码
    switch(config)#no enable secret取消特权模式加密密码
    switch#show version查看系统中的所有版本信息
    switch#show ip int b查看各接口状态
    switch#show  vlan 10查看交换机有关vlan10配置信息
    switch#show  vlan int b查看交换机所有vlan信息
    switch#show running-configure查看交换机当前起作用的配置信息
    switch#show interface fastethernet0/1查看交换机接口1具体配置和统计信息
    switch#show mac-address-table查看mac地址转发表

    switch#write

    保存配置信息(写入配置信息)
    switch#show vtp查看vtp配置信息
    switch#show run查看当前配置信息
    switch#show vlan brief查看vlan配置信息
    switch#show interface brief查看端口信息
    switch#show int f0/0查看指定端口信息
    switch#copy running-config startup-config保存交换机配置
    switch(config-if)#speed 100设置速率
    switch(config-if)#duplex full设置该端口为全双工,full全双工  half半双工  auto为自动
    switch#show ip route查看是否有路由表,是否开启路由功能

    在配置模式中无法使用show命令,如果要使用的话show前必须加do和空格

    例:do show ip int b

                       

    3、交换机恢复出厂配置

    switch> enable
    switch# erase startup-configure
    switch# write erase
    switch# reload

    4、telnet 远程登录设置

    switch>en
    switch#configure terminal
    swich(conf)#enable password abc123abc123特权模式密码(明文加密)
    swich(conf)#enable secret abc123密文加密
    swich(conf)#interface vlan 1以vlan 1端口作为远程登录的接口,其他端口亦可
    swich(conf-if)#ip address 192.168.1.1 255.255.255.0
    swich(conf-if)#no shut
    swich(conf-if)#exit
    swich(conf)line vty 0 4设置0-4个用户可以telnet 远程登陆
    swich(conf-line)#password 123456

    swich(conf-line)#login

    5、交换机VLAN设置


    (1)添加,删除 vlan

    switch#vlan database进入vlan设置
    switch(vlan)#vlan 2建立vlan2
    switch(vlan)#no vlan 2删除vlan 2

    (2)命名vlan

    switch(config)# valn 2
    switch(config-vlan)# name 名字


    (3)将端口加入vlan

    switch(config)# interface range fastethernet 0/1 - 5进入同种类型多端口配置
    switch(config)#interface range fastethernet 0/1 - 5,gigabitethernet 0/1 - 2进入不同类型多端口配置
    switch(config-if)#switchport access vlan 2当前端口加入vlan 2

                                    

    6、交换机设置VLAN IP地址

    switch(config)#interface vlan 1进入vlan 1
    switch(config-if)#ip address  ip地址设置IP地址
    switch(config-if)#exit
    switch(config)#ip default-gateway 网关地址设置交换机默认网关,telnet交换机时可以使用vlan ip地址连接

           

    7、Trunk的配置

    switch(config-if)#switchport trunk encap dot1q设置vlan中继执行的协议
    switch(config-if)#switchport mode trunk将接口设置为中继
    switch(config-if)#switchport trunk allowed vlan 1,2设置允许通过的vlan
    switch(config-if)#switchport trunk allowed vlan remove vlan号禁止trunk中某个VLAN的传输


    8、以太网通道配置(二层口)

    switch1(config)#int range f0/1 -2进入接口f0/1和f0/2
    switch1(config-if-range)#channel-group 1 mode on绑定
    switch#show etherchannel summary查看绑定的接口

           

    9、以太网通道配ip地址(三层口)

    switch1(config)#int port-channel 1
    switch1(config-if)#ip add ip地址 子网掩码


    10、VTP的配置

    sw1(config)#vtp domain 域名设置域名
    sw1(config)#vtp mode server或client或transparent设置交换机VTP模式
    sw1(config)#vtp password 密码设置服务器密码,需要同步vtp的交换机需要设相同的密码

    VTP修剪

    sw1(config)#vtp pruning启动VTP修剪
    sw1(config)#vtp version 2配置VTP版本,默认1
    sw1(config)#switchport trunk pruning vlan remove vlan号从可修剪列表中去除某VLAN
    例:switchport trunk pruning vlan remove 2-4,6,8
    sw1#show interface pruning查看哪些接口以及哪几个vlan被修剪了
    sw1#show vtp status查看vtp配置信息

                                      

    11、三层交换机配置


    (1)配置虚拟接口IP地址

    switch(config)# interface vlan vlan号
    switch(config-if)# ip address ip地址 子网掩码
    switch(config-if)# no shutdown


    (2)配置物理接口IP地址

    switch(config)#ip routing启用路由功能
    switch(config)# interface f0/1
    switch(config-if)#no switchport将物理二层接口转换为物理三层接口
    switch(config-if)#ip address ip地址 子网掩码
    switch(config-if)# no shutdown


    (3)配置DHCP中继

    switch(config)#service dhcp开启DHCP服务
    switch(config-if)#ip helper-address dhcp服务器ip地址



    12、STP生成树配置

    启用stp生成树

    switch(config)#spanning-tree vlan  vlan号

    设置网桥优先级,值小的优先级高

    switch(config)#spanning-tree vlan vlan号 priority 32768{默认32768,范围0~65535}

    指定根网桥

    switch(config)#spanning-tree vlan  vlan号 root primary (primary优先级为24576,secondary优先级为28672)

    指定端口成本

    switch(config-if)#spanning-tree vlan vlan号 cost  成本

    指定交换机端口优先级

    switch(config-if)#spanning-tree vlan vlan号  port-prioty 优先级 {优先级0~255,默认128}  

    配置速端口

    switch(config-if)#spanning-tree portfast

    查看生成树配置信息

    switch#show spanning-tree

    查看详细生成树配置信息

    switch#show spanning-tree vlan detail

    查看详细生成树端口配置信息

    switch#show spanning-tree interface f0/1 detail

    查看某个VLAN生成树配置信息

    switch#show spanning-tree vlan vlan号 brief



    13、HSRP(热备份)配置
     

    sw1(config)#int vlan 10
    sw1(config-if)#ip add 192.168.10.1 255.255.255.0
    sw1(config-if)#standby hsrp组号{组号默认0,范围0~255} ip 网段网关地址配置为hsrp成员
    sw1(config-if)#standby hsrp组号 priority 200{默认100,范围0~255}配置端口优先级
    sw1(config-if)#standby hsrp组号 preempt配置抢占权
    sw1(config-if)#standby hsrp组号 track 端口类型 端口号 优先级配置端口跟踪和减去的优先级
    例:sw1(config-if)#standby 10 track fastethernet 1/1 100
    sw1#show standby brief查看hsrp的状态
    sw1#show standby 端口类型 端口号 hsrp组号 brief查看指定端口hsrp的状态

    结语


         在对交换机进行配置时,如果某个关键词记得不是很清楚,只记得此关键词的开头一个或几个字符,可在输入关键词的开头一个或几个字符后按下Tab键,系统自动会补全关键词,如果某个命令记得不是很清楚,输入命令开头关键词,接着输入问号,系统会列出以该词开头的有关命令

    展开全文
  • 一、思科交换机基本配置命令 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名 ...
  • 思科交换机:基本命令(上)

    千次阅读 2020-10-26 19:35:52
    五、show查看命令 查看交换机接口 Switch>show ip interface brief 查看vlan Switch>show vlan 查看路由表 R1(config)#do show ip route Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - ...
  • 思科交换机工作模式及基本命令

    千次阅读 2020-03-07 16:27:06
    1.)交换机基本工作模式及命令 第一次配置网络设备,需要使用console线,在pc使用crt配置 交换机4种工作模式(思科) 1)用户模式: switch> 可以查看交换机的基本简单信息,且不能做任何修改配置! 2)特权模式...
  • cisco思科交换机命令参考大全

    千次阅读 2020-12-10 09:04:14
    1.设置主机名/系统名 IOS:switch(config)# hostname "hostname" CLI:switch(enable) set system name name-string 2.设置登录口令 IOS:switch(config)# enable password level 1 password ...
  • 思科交换机配置命令大全

    千次阅读 2021-06-30 19:10:32
    思科交换机配置命令(陆小马公众号) 简写命令 完整命令 1 用户模式: 用户模式: switch> switch> 2 ...
  • CISCO交换机常用命令》 一、交换机四种基本模式 1、四种模式介绍 2.进入四种模式 (1)从用户模式进入特权模式:enable (2)从特权模式进入全局配置模式:conf t (3)从全局端口配置模式进入视图模式...
  • 思科交换机常用命令及配置

    千次阅读 2019-10-01 10:19:13
    打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。 Switch>enable Switch# 2 从特权模式进入全局配置模式 Switch#configure terminal Switch(config)# 3 ...
  • 功能 华为命令 进入全局模式 system 显示当前配置 display current-configuration 显示版本信息 display version 显示vlan信息 display vlan 显示接口信息 display interface 接口 交换机路由器命名 sysname 名字 ...
  • 思科(Cisco)交换机路由器命令大全

    千次阅读 多人点赞 2021-06-20 20:06:16
    思科(Cisco)路由器常用命令总结 视图模式介绍 普通视图router> 特权视图router# / 在普通模式下输入enable 全局视图router(config)#/ 在特权模式下输入configt 接口视图router(config-if)#/在全局模式下输入int ...
  • 思科交换机常用指令

    千次阅读 2020-11-23 12:19:39
    title: 思科交换机常用指令(持续更新) tags: 教程 author: caijinbo date: 2019-11-19 思科交换机常用指令 vlan设置 console>enable //进入特权模式 console#configure //进入配置视图 console(config)#vlan ...
  • 思科交换机配置基础 Cisco 2960-24

    千次阅读 2022-03-14 12:42:42
    Cisco 2960-24配置命令及验证过程
  • 基本配置命令Switch>enable 进入特权模式Switch #config terminal 进入全局配置模式Switch(config)#hostname 设置交换机的主机名Switch(config)#enable password 进入特权模式的密码(明文形式保存)Switch(config)...
  • 思科交换机基本配置命令

    千次阅读 2021-06-30 11:20:18
    思科交换机基本配置命令 switch>enable 进入特权模式 switch#config terminal 进入全局模式 switch(config)#hostname+xxx 设置主机名 switch(config)#enable password 明文密码 switch(config)#enable ...
  • 使用tftp32软件对思科交换机导入导出配置 在几种常见类型的交换机里,华三、华为、赫斯曼都可以通过网页或bootrom导入/导出配置文件,思科交换机导入和导出配置的方法比较特别,tftp导出导入配置的方法操作步骤见...
  • 思科交换机如何配置Trunk?

    千次阅读 2021-02-25 14:30:58
    检查SW2: SW2#show vlan brief VLAN Name Status Ports---- -------------------------------- --------- -------------------------------1 default active Et0/310 IT active Et0/120 HR active Et0/21002 fddi-...
  • 查看系统时间 enable show clock 更改系统时间 enable clock set 13:42:00 Nov 12 2021
  • 思科交换机配置命令

    2020-12-31 10:07:41
    思科交换机配置命令简写命令完整命令1用户模式:用户模式:switch>switch>2特权模式:特权模式:switch>enswitch>enableswitch#switch#3全局配置模式全局配置模式switch#conftswitch#configterminalswitch...
  • Cisco Packet Tracer 命令大全基本配置文件操作启动配置密码设置接口配置CDP路由RIPIGRPEIGRPOSPFACLNAT PAT 配置负载分发DHCPHDLCPPPFRARP(默认启用)ISDNIS-ISBGP路由优化异步连接QoS 转载自:...
  • Cisco思科交换机/路由器的操作系统称为Cisco IOS(Cisco Internetwork Operating System)。Cisco IOS基于Linux,其命令从Linux的Shell学习了一些特性,但又有很大的不同。 IOS命令模式层级结构 Cisco IOS命令最大的...
  • 思科交换机配置vlan 1、创建多个VLAN Switch>enable (进入特权模式) Switch#vlan data (进入vlan配置模式) Switch(vlan)#vlan 10 name IT (划分vlan10,名称为IT) Switch(vlan)#vlan 20 name HR (划分vlan...
  • 思科交换机常用命令——调试命令 a、显示所有配置命令:Switch#show run b、显示所有接口状态:Switch#show ip int brief c、显示所有VLAN的信息:Switch#show vlan brief switch>enable  进入特权模式   switch#...
  • 当我们想要查看交换机配置是否正确,不可能将每条命令都看一遍,毕竟数据庞大,这时候就需要精准使用交换机的巡检命令,下面我们来介绍一下几个常见厂商的巡检命令
  • conf t ...#设置时间同步服务器,这里同步的是清华大学的授时服务器 clock timezone GMT 8 ...service timestamps debug datetime msec localtime show-timezone service timestamps log datetime msec lo.
  • 、备份配置 copy running-config startup-config 2、清楚启动文件 write erase 3、查看系统相关信息 show version 4、查看硬件相关信息 show module 5、查看相关特性 ...show feature
  • 思科交换机Debug调试命令

    千次阅读 2015-09-30 07:46:36
    下面列出了部分常用的debug ...要使用debug功能,需要在特权用户模式下进行配置:命令 功能Switch#debug 显示所有可用的debug指令及简短的说明Switch #show debugging 显示当前各个调试开关的状态Switch #debug all 打...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,499
精华内容 1,799
关键字:

思科交换机show命令