精华内容
下载资源
问答
  • 思科路由器NAT配置详解(转)

    千次阅读 2019-08-07 20:23:10
    思科路由器NAT配置详解(转) 网络技术 2010-07-11 17:48:14 阅读104 评论0 字号:大中小订阅 思科路由器NAT配置详解 一、NAT简介: NAT(Network Address Translation)网络地址转换。 最早出现在思科...

    思科路由器NAT配置详解(转)

    网络技术 2010-07-11 17:48:14 阅读104 评论0   字号: 订阅

    思科路由器NAT配置详解 - ILCHN - ILCHN

    思科路由器NAT配置详解

    一、NAT简介: 

    NAT(Network Address Translation)网络地址转换。 

    最早出现在思科11.2 IOS中,定义在RFC1631和RFC3022中。

    NAT最主要的作用是为了缓解IPv4地址空间的不足。

    同时也带来了一些问题,如每个数据包到达路由器后都要进行包头的转换操作,所以增加了延迟;DNS区域传送,BOOTP/DHCP等协议不可穿越NAT路由器;

    改动了源IP,失去了跟踪到端IP流量的能力,所以使责任不明确了。   

    但是利还是要大于弊的,不然也不会学习它了!最新的CCNA640-802学习指南中依然有专门的一章来讲解NAT,它的重要性可见一斑。   

    二、NAT术语:比较难理解,所以这里用最明了的语言总结如下 -  

    内部本地地址( inside local address ):局域网内部主机的地址,通常是RFC1918地址空间中的地址,称为私有地址。(待转换的地址)  

    内部全局地址(inside global address):内部本地地址被NAT路由器转换后的地址,通常是一个可路由的公网地址。

    外部全局地址(outside global address):是与内部主机通信的目标主机的地址,通常是一个可路由的公网地址。

    外部本地地址(outside local address):是目标主机可路由的公网地址被转换之后的地址,通常是RFC1918地址空间中的地址。

    三、NAT配置详解:  

    静态NAT:将一个私有地址和一个公网地址一对一映射的配置方法,这种方式不能节省IP,通常只为需要向外网提供服务的内网服务器配置。

     

    如图所示:

              PC1地址:192.168.0.2/24  

              PC2地址:192.168.0.3/24

              R1 E0/0地址:192.168.0.1/24     

              R1 S0/0地址:202.106.0.1/24

              R2 S0/0地址:202.106.0.2/24 

              R2 E0/0地址:202.106.1.1/24

              PC3地址:202.106.1.2/24

    各接口地址按上面配置好之后,在R1和R2上配置路由(注意不要为192.168.0.0网络增加路由项,因为私有网络不可以出现在公网路由表中,不然也不叫私有地址了)  

    路由配置好之后在R1上可以ping通PC3,但是PC1只能ping到R1的S0/0,再向前就ping不通了。因为没有192.168.0.0网络的路由表项,所以被丢弃了!下面在R1上配置静态NAT让PC1可以和PC3通信。 

    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口   

    Router(config-if)#int s0 /0/0

    Router(config-if)#ip nat outside //将该接口标记为外部接口

    Router(config-if)#exit

    Router(config)#ip nat inside source static 192.168.0.2 202.106.0.3 //将来自标记为内部接口的地址做为转换源,将 192.168.0.2一对一的转换成 202.106.0.3   

            2、动态NAT:现在PC1就可以和PC3通信了。但是PC2不能,因为R1并没有为PC2提供地址转换。当然我们可以在R1上像给PC1做静态转换一样也给PC2做一个,可如果我们有100台机器工作量就太大了。下面在R1上再继续配置:   

    Router(config)#access-list 10 permit 192.168.0.0 0.0.0.255  //定义标准访问控制列表10只允许定义的地址能够被转换

    Router(config)#ip nat pool out 202.106.0.4 202.106.0.24 netmask 255.255.255.0  //定义名称为out的地址池。

    Router(config)#ip nat inside source list 10 pool out //将访问控制列表定义的地址和地址池关联这样就有前21个内部主机能够得到公网地址。  

    现在PC2也可以和PC3通信了。这就是动态NAT,这种方式也不能节约IP地址。有一百台主机就要100个公网IP,不常用。 

           3、PAT(Port Address Translation)端口地址转换:用一个或多个公网IP为多个私有地址提供转换,能够节省大量IP地址,这种方式在现实网络环境中最常用。

    Router(config)#ip nat inside source list 10 pool out  overload //只需要在动态NAT的基础上多出一个“overload”就可以让上面的21个公网地址反复使用。  

    如果我们只有一个公网地址且已经分配给了R1的S0/0口,可以使用下面的命令来对这仅有的一个公网地址反复利用或叫超载。   

    Router(config)#ip nat inside source list 10 interface serial 0 overload //就是在R1上不设置地址池,因为只有一个公网地址,而只对S0/0接口的地址超载。 

    注意:一条NAT转换条目要占用160字节内存,因此NAT的转换数目受路由器的内存限制。 

       4、配置端口映射:看配置就明白了

    还是上面的图和IP,看下面的配置   

    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口  

    Router(config-if)#int s0  

    Router(config-if)#ip nat outside //将该接口标记为外部接口  

    Router(config-if)#exit  

    Router(config)#ip nat inside source static tcp 192.168.0.2 80 202.106.0.3 80 //将 192.168.0.2的80端口一对一的转换成 202.106.0.3的80端口,也就外网用户在浏览器里输入202.106.0.3时,会打开192.168.0.2上的WWW服务。这里公网地址也可以改成interface Serial1/0 80,如下: 

    Router(config)#ip nat inside source static tcp 192.168.0.3 21  interface Serial1/0 21 //如果只有一个公网地址还可以这样来转换。这样外网访问的不同服务就会定向到不同的内网服务器。   

        5、配置TCP负载平衡:还是上图IP也不变,假如PC1和PC2提供的是相同的WWW服务,为了实现负载平衡可以做如下配置:  

    Router(config)#ip nat pool www 192.168.0.2 192.168.0.3 netmask 255.255.255.0 type rotary //配置地址池www并设成旋转。

    Router(config)#access-list 10 permit 202.106.0.3

    Router(config)#ip nat inside destination list 10 pool www //这样当外网主机访问202.106.0.3的时候路由器会自动定向到192.168.0.2再有请求就定向到192.168.0.3如果地址池里还有别的地址会依次循环,实现负载平衡的目的。注意,地址有了,网络中还要有对应的主机存在,否则会使对方第一次连接失败。

    转载于:https://www.cnblogs.com/mac_arthur/archive/2011/05/26/2057835.html

    展开全文
  • NAT是将IP数据报报头中的IP...本文为大家介绍一个思科路由器的NAT配置实例,把内网地址转换成公网地址,并通过ACL控制,有选择地对内网地址段进行NAT转换,从而灵活控制可以上网的用户。 一、组网结构和需求 ...

           NAT是将IP数据报报头中的IP地址转换为另一个IP地址的过程,主要用于实现内部网络(私有IP地址)访问外部网络(公有IP地址)的功能。在实际应用中,内部网络一般使用私有地址。本文为大家介绍一个思科路由器的NAT配置实例,把内网地址转换成公网地址,并通过ACL控制,有选择地对内网地址段进行NAT转换,从而灵活控制可以上网的用户。

    一、组网结构和需求

           某工厂的网络拓扑图如下,内网主要分为三个网段:工厂车间(10.10.10.0/24)、工厂办公室(20.20.20.0/24)、研发中心(30.30.30.0/24)。三个网段接到同一台路由器上,此路由器通过专线连接到互联网,专线公网IP地址是:211.111.112.2。现要求在此路由器上配置NAT数据,允许工厂办公室和研发中心的内网地址转换成公网地址访问互联网;但工厂车间的地址段不允许上网,需禁止NAT转换。

     

     

     

     

     

     

     

    二、配置方法

    请查看原文链接:http://www.net1980.com/2010/11/29/cisco-nat/

    转载于:https://blog.51cto.com/daotianquan/646622

    展开全文
  • NAT(Network Address Translation)网络地址转换。 最早出现在思科11.2 IOS中,定义在RFC1631和RFC3022中。 NAT最主要的作用是为了缓解IPv4地址空间的不足。 同时也带来了一些问题,如每个数据包到达路由器后...
    一、NAT简介:
     
    1. NAT(Network Address Translation)网络地址转换。<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

    2. 最早出现在思科11.2 IOS中,定义在RFC1631和RFC3022中。

    3. NAT最主要的作用是为了缓解IPv4地址空间的不足。

    4. 同时也带来了一些问题,如每个数据包到达路由器后都要进行包头的转换操作,所以增加了延迟;DNS区域传送,BOOTP/DHCP等协议不可穿越NAT路由器;

    5. 改动了源IP,失去了跟踪到端IP流量的能力,所以使责任不明确了。

    6. 但是利还是要大于弊的,不然也不会学习它了!最新的CCNA640-802学习指南中依然有专门的一章来讲解NAT,它的重要性可见一斑。
    二、NAT术语:比较难理解,所以这里用最明了的语言总结如下
     
    1. 内部本地地址( inside local address ):局域网内部主机的地址,通常是RFC1918地址空间中的地址,称为私有地址。(待转换的地址)
    2. 内部全局地址(inside global address):内部本地地址被NAT路由器转换后的地址,通常是一个可路由的公网地址。

    3. 外部全局地址(outside global address):是与内部主机通信的目标主机的地址,通常是一个可路由的公网地址。
    4. 外部本地地址(outside local address):是目标主机可路由的公网地址被转换之后的地址,通常是RFC1918地址空间中的地址。

    三、NAT配置详解:
     
    1. 静态NAT:将一个私有地址和一个公网地址一对一映射的配置方法,这种方式不能节省IP,通常只为需要向外网提供服务的内网服务器配置。
    如图所示: PC1地址:192.168.0.2/24
              PC2地址:192.168.0.3/24
              R1 E0/0地址:192.168.0.1/24  
              R1 S0/0地址:202.106.0.1/24
              R2 S0/0地址:202.106.0.2/24
              R2 E0/0地址:202.106.1.1/24
              PC3地址:202.106.1.2/24 (模拟公网服务器)
    各接口地址按上面配置好之后,在R1和R2上配置路由(注意不要为192.168.0.0网络增加路由项,因为私有网络不可以出现在公网路由表中,不然也不叫私有地址了)
    路由配置好之后在R1上可以ping通PC3,但是PC1只能ping到R1的S0/0,再向前就ping不通了。因为没有192.168.0.0网络的路由表项,所以被丢弃了!下面在R1上配置静态NAT让PC1可以和PC3通信。
    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口

    Router(config-if)#int s0

    Router(config-if)#ip nat outside //将该接口标记为外部接口

    Router(config-if)#exit

    Router(config)#ip nat inside source static 192.168.0.2 202.106.0.3 //将来自标记为内部接口的地址做为转换源,将 192.168.0.2一对一的转换成 202.106.0.3
            2、动态NAT:现在PC1就可以和PC3通信了。但是PC2不能,因为R1并没有为PC2提供地址转换。当然我们可以在R1上像给PC1做静态转换一样也给PC2做一个,可如果我们有100台机器工作量就太大了。下面在R1上再继续配置:
    Router(config)#access-list 10 permit 192.168.0.0 <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com:office:smarttags" />0.0.0.255  //定义标准访问控制列表10只允许定义的地址能够被转换
    Router(config)#ip nat pool out 202.106.0.4 202.106.0.24 netmask 255.255.255.0  //定义名称为out的地址池。
    Router(config)#ip nat inside source list 10 pool out //将访问控制列表定义的地址和地址池关联这样就有前21个内部主机能够得到公网地址。
    现在PC2也可以和PC3通信了。这就是动态NAT,这种方式也不能节约IP地址。有一百台主机就要100个公网IP,不常用。
     
           3、PATPort Address Translation)端口地址转换:用一个或多个公网IP为多个私有地址提供转换,能够节省大量IP地址,这种方式在现实网络环境中最常用。
    Router(config)#ip nat inside source list 10 pool out  overload //只需要在动态NAT的基础上多出一个“overload”就可以让上面的21个公网地址反复使用。
     
    如果我们只有一个公网地址且已经分配给了R1的S0/0口,可以使用下面的命令来对这仅有的一个公网地址反复利用或叫超载。
    Router(config)#ip nat inside source list 10 interface serial 0 overload //就是在R1上不设置地址池,因为只有一个公网地址,而只对S0/0接口的地址超载。
    注意:一条NAT转换条目要占用160字节内存,因此NAT的转换数目受路由器的内存限制。

     
       4、配置端口映射:看配置就明白了
    还是上面的图和IP,看下面的配置
     
    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口

    Router(config-if)#int s0

    Router(config-if)#ip nat outside //将该接口标记为外部接口

    Router(config-if)#exit

    Router(config)#ip nat inside source static tcp 192.168.0.2 80 202.106.0.3 80 // 192.168.0.2的80端口一对一的转换成 202.106.0.3的80端口,也就外网用户在浏览器里输入202.106.0.3时,会打开192.168.0.2上的WWW服务。这里公网地址也可以改成interface Serial1/0 80,如下:
    Router(config)#ip nat inside source static tcp 192.168.0.3 21  interface Serial1/0 21 //如果只有一个公网地址还可以这样来转换。这样外网访问的不同服务就会定向到不同的内网服务器。
     
        5、配置TCP负载平衡:还是上图IP也不变,假如PC1和PC2提供的是相同的WWW服务,为了实现负载平衡可以做如下配置:
    Router(config)#ip nat pool www 192.168.0.2 192.168.0.3 netmask 255.255.255.0 type rotary //配置地址池www并设成旋转。
    Router(config)#access-list 10 permit 202.106.0.3
    Router(config)#ip nat inside destination list 10 pool www //这样当外网主机访问202.106.0.3的时候路由器会自动定向到192.168.0.2再有请求就定向到192.168.0.3如果地址池里还有别的地址会依次循环,实现负载平衡的目的。注意,地址有了,网络中还要有对应的主机存在,否则会使对方第一次连接失败。
     
    上面的内容已经包含了NA的所有内容和NP的大部分内容。现实工作中NAT,PAT还是很常用的!多学点,应该会有好处!愿我们共同进步^-^!
    展开全文
  • 思科cisco路由器实现nat转换 要求: 使用三台路由器,在R2上配置1.0和2.0网段的静态路由,在R1和R3上不配置到R2的路由,通过NAT转换实现R2对R1和R3的访问。 在R1上的配置 R1#conf t R1(config)#...

     

     

    思科cisco路由器实现nat转换

     

     

     

     

     

    要求:

    使用三台路由器,在R2上配置1.02.0网段的静态路由,在R1R3上不配置到R2的路由,通过NAT转换实现R2R1R3的访问。

     

    R1上的配置

    R1#conf t

    R1(config)#line console 0

    R1(config-line)#no exec-timeout

    R1(config-line)#logging synchronous

     

    R1(config)#inter f0/0

    R1(config-if)#ip add 192.168.1.254 255.255.255.0

    R1(config-if)#loop

    R1(config-if)#no shut

    R1(config-if)#exit

    R1(config)#inter s1/0

    R1(config-if)#ip add 192.168.4.1 255.255.255.0

    R1(config-if)#shut

    R1(config-if)#no shut

     

    R2上的配置

    R2

    R2#conf t

    R2(config)#line console 0

    R2(config-line)#no exec-timeout

    R2(config-line)#logging synchronous

     

    R2(config)#inter s1/0

    R2(config-if)#ip add 192.168.4.2 255.255.255.0

    R2(config-if)#shut

    R2(config-if)#no shut

    Router(config)#inter f0/0

    Router(config-if)#ip add 192.168.3.254 255.255.255.0

    Router(config-if)#loop

    Router(config-if)#exit

    Router(config)#inter s1/1

    Router(config-if)#ip add 192.168.5.2 255.255.255.0

    Router(config-if)#shut

    Router(config-if)#no shut

     

    R3上的配置

    R3

    R3#conf t

    R3(config)#line console 0

    R3(config-line)#no exec-timeout

    R3(config-line)#logging synchronous

     

    R3(config)#inter f0/0

    R3(config-if)#ip add 192.168.2.254 255.255.255.0

    R3(config-if)#loop

    R1(config-if)#no shut

    R3(config-if)#exit

    R3(config)#inter s1/0

    R3(config-if)#ip add 192.168.5.1 255.255.255.0

    R3(config-if)#shut

    R3(config-if)#no shut

     

    R2上设置默认路由

    R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.4.1

    R2(config)#ip route 192.168.2.0 255.255.255.0 192.168.5.1

    配置结果如下

     

     

     

    R2上做NAT转换

    R2(config)#access-list 100 permit ip 192.168.3.254 0.0.0.255 192.168.1.254 0.0.0.255

    R2(config)#inter s1/0

    R2(config-if)#ip nat outside

    R2(config-if)#exit

    R2(config)#inter f0/0

    R2(config-if)#ip nat inside

    R2(config)#ip nat inside source list 100 interface serial1/0    //SNAT转换

    测试结果

     

     

    R2(config)#access-list 101 permit ip 192.168.3.254 0.0.0.255 192.168.2.254 0.0.0.255

    R2(config)#inter s1/1

    R2(config-if)#ip nat outside

    R2(config-if)#exit

    R2(config)#ip nat inside source list 101 interface serial1/1

    测试结果

     

     

     路漫漫其修远兮,吾将上下而求索!

    转载于:https://blog.51cto.com/nshao/1069889

    展开全文
  • NAT也就是我们常说的地址转换,这是每台路由器必备的功能,今天我们就以思科路由器,为大家介绍NAT的基础知识,方便大家在设置路由器时心中有数,NAT属接入广域网技术,是一种将私有地址转化为合法IP地址的转换技术...
  • 我们都知道思科路由器NAT是用来转换ip地址的,但是很少有人知道Cisco路由器是采用哪种转换方式,只认为它可以采用非注册ip地址转换成注册的公网地址。这其实是很片面的,NAT不仅可以把一个或者多个内部网络IP地址...
  • 在CiscoIOS12.3(4)T后的IOS软件上支持NAT的单用户限制,即可以对做地址转换的单个IP限制其NAT的表项数,因为P2P类软件如BT的一大特点就是同时会有很多的连接数,从而占用了大量的NAT表项,因此应用该方法可有效...
  • 思科华为NAT实验

    2020-07-13 21:06:15
    此文章主要以静态NAT和动态NAT来分别演示思科华为的主要配置。(PC终端可自行配置ip地址) 1.静态NAT 将一个私有IP地址转换为一个公有IP地址. 2.动态NAT 多个私有IP地址转换为多个公有IP地址,源端口号标识每个会话....
  • 实验名称:思科路由器网络地址转换NAT)实验目的:实现所有内网IP使用少量的公网IP连接Internet实验介绍: 借助NAT技术,内网私有地址向路由器发送数据包时,私有地址被转换成合法的公网IP地址,从而实现大量内网...
  • 如何配置NAT (网络地址转换),从而使得互联网上的计算机通过其思科路由器访问其内部的Web和电子邮件服务器。这需要在专门公用的IP地址和专门私用的IP地址之间配置一个静态的NAT转换。下面笔者谈一下解决这个问题的...
  • 拓扑图: 需求:R1作为局域网出口路由器,承担这PAT地址转换功能。ASA需要跟R3建立***R4作为局域网内部机器可以跟R3互联,并可以上外网步骤:给所有设备配置ip地址,地址规划如上图所示并默认路由在R4上面配置ip地址...
  • 7.0以后开始 nat-control 是默认关闭的,关闭的时候是没有nat转换的,相当于路由器一样,但是ACL的规则还是存在的默认情况的变化:在6.3的时候只要是穿越防火墙都需要创建转换项,比如:nat;static等等,没有转换项...
  • 静态NAT转换

    2009-05-08 11:14:30
    最近有人问我,如何配置NAT (网络地址转换),从而使得互联网上的计算机通过其思科路由器访问其内部的Web和电子邮件服务器。这需要在专门公用的IP地址和专门私用的IP地址之间配置一个静态的NAT转换。下面笔者谈一下...
  • NAT:网络地址转换cisco篇) 在一台路由器上对进或出流量进行ip地址的修改;常用规则为从内部去往外部时修改源ip地址;从外部进入内部时修改目标ip地址; 静态nat – 地址间的映射关系为固定; 动态nat,临时地址...
  • 最近有人问我,如何配置NAT (网络地址转换),从而使得互联网上的计算机通过其思科路由器访问其内部的Web和电子邮件服务器。这需要在专门公用的IP地址和专门私用的IP地址之间配置一个静态的NAT转换。下面笔者谈一下...
  • 思科ei ccie网工一定要了解的网络地址转换NAT-动态NAT的使用范围和配置,什么...当同一时刻地址池中地址被NAT转换完毕,则其他私有地址不能够被NAT转换。 使用范围: 一般是我们公司内网中有设备需要去访问我们公网,
  • 基于思科抓包-nat分析

    2021-02-27 10:08:24
    本次实验主要是nat的pat模式(端口复用): ...2.实验开始前路由器nat配置: 3.实验开始pc0 ping 主机模拟: 4.抓包显示: 经过路由源ip发生改变,模拟实际改变为公网地址 路由nat转换条目也可以看到: ...
  • NAT(Network Address Translation,网络地址转换)是1994年提出的。当在专用网内部的一些主机...这样,所有使用本地地址的主机在和外界通信时,都要在NAT路由器上将其本地地址转换成全球IP地址,才能和因特网连接。
  • 思科拓扑---nat的使用

    2018-01-16 22:40:19
    一、拓扑图展示—思科nat(网络地址转换)使用 二、实验目的1.把pc0和pc1划入vlan10网段,vlan10 :192.168.1.0/242.公司路由器R1通过外网与运维员家路由器R2联通3.在R1上使用动态nat划分内外地址转换:让公司...
  • 思科设备ACL与NAT技术

    2019-07-17 10:52:00
    ACL 访问控制列表(Access Control Lists),是应用在路由器(或三层交换机)接口上的指令列表,用来告诉路由器哪些数据可以接收,哪些数据是...NAT 网络地址转换(Network Address Translation),是一个互联网工程任务组的...
  • 如图所示,要让家庭内的设备连接到外部网络,必须要设置静态路由,连接到外部网段,因为外部网段很多,不能一个一个手动添加,所以只能将路由器设置成默认路由 即:ip route 0.0.0.0 0.0.0.0 f0/1,这样就可以连接到...
  • NAT用来将你的私有IP地址转换为全球的外部地址,在internet上使用,从而保护和隐藏内部网络中的IP地址。 NAT工作原理: 默认情况下,内部IP地址是无法被路由到外网的,内部主机10.1.1.1要与外部internet通信,IP包...
  • 一、实验拓扑:Twice NAT好处:可以节省主机或者路由器的配置,R1可以不需要有默认路由,R2(PC)可以不写网关;二、实验要求:1、当Inside网络10.1.1.0/24,去往Outside地址1.1.1.1时,转换内部网络10.1.1.0/24到...
  • H3CNE-网络地址转换NAT

    千次阅读 2018-02-27 10:53:11
    网络地址转换华三上私网(inside)—————路由器————-公网(internet)(思科叫global)Basic NAT:企业用户从运营商获取到N个公有地址。 当私有PC要访问internet,临时建立NAT映射关系 NAT映射只允...
  • NAT[Network Address Translation]网络地址转换在IP地址缺乏的情况下...NAT有静态NAT(内部地址和外部地址一对一)和动态NAT(内部地址池和外部地址池一对一)本次我们来了解一下静态NAT配置思路1配置路由器1和路由...
  • 谷德威天津思科CCNA培训之访问控制列表和NAT设置 实验五 访问控制列表及地址转换5.1 实验目的:1. 熟悉路由器的包过滤的核心技术:访问控制列表;2. 掌握访问控制列表的相关知识;3. 掌握访问控制列表的应用,灵活...
  • *HSRP概述: -HSRP:热备份路由器协议 -HSRP是思科的私有协议,与VRRP功能类似 -HSRP不支持将真实的接口...-NAT:网络地址转换 -通常是配置在公网和私有网络的边界设备上, 具体是配置在连接公网的接口上; -NA.

空空如也

空空如也

1 2 3
收藏数 51
精华内容 20
关键字:

思科路由器nat转换