精华内容
下载资源
问答
  • 从特权模式进入全局配置模式 Switch#configure terminal Switch(config)# 在特权模式下可以对交换机进行命名,这样在配置多台交换机时,避免将配置写错交换机。 Switch(config)#hostname cisco-sw1 配置交换端口...

    思科交换机的配置模式基本配置命令

    • 打开思科交换CLI,首先进入的是用户模式,如果要进行配置操作需要进入特权模式。

    Switch>enable

    Switch#

    • 从特权模式进入全局配置模式

    Switch#configure terminal

    Switch(config)#

    • 在特权模式下可以对交换机进行命名,这样在配置多台交换机时,避免将配置写错交换机。

    Switch(config)#hostname cisco-sw1

    • 配置交换端口密码,登录特权模式时需要输入该密码,避免设备被其他人使用。

    cisco-sw1(config)#enable password cisco

    ps:password表示密码为明文

    • 给交换机配置使能密码,进入特权模式时需要输入密码才能进入,避免设备可以被其他人员使用。

    cisco-sw1(config)#enable secret ciscoswitch

    ps:secret表示密码用的密文

    • 交换机配置VLAN,并给将端口加入到该VLAN:

    cisco-sw1(config)#vlan 2

    cisco-sw1(config-vlan)#name test

    cisco-sw1(config-vlan)#exit

    cisco-sw1(config)#interface  fastEthernet 0/1

    cisco-sw1(config-if)#switchport mode access

    cisco-sw1(config-if)#switchport access vlan 2

    • 进入交换机某一端口

    switch> enable

    switch#configure terminal

    switch(conf)# interface fastehernet 0/1

    switch(conf-if)#

    • show:查看命令,交换机的所有配置和其它相关信息都需要通过show命令查看。

    switch> enable

    switch# show version 察看系统中的所有版本信息

    switch#show  vlan id 1 查看交换机有关vlan配置信息

    switch#show running-configure 查看交换机当前起作用的配置信息

    switch#show interface fastethernet 0/1 察看交换机1 接口具体配置和统计信息

    switch#show mac-address-table 查看mac地址转发表

    • 交换机恢复出厂

    switch> enable

    switch# erase startup-configure

    switch# reload

    • telnet 远程登录设置:

    switch>en

    switch#configure terminal

    swich(conf)#enable password cisco 以cisco 为特权模式密码

    swich(conf)#interface vlan 1 以vlan 1端口作为远程登录的接口,其他端口亦可

    swich(conf-if)#ip address 192.168.1.1 255.255.255.0

    swich(conf-if)#no shut

    swich(conf-if)#exit

    swich(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆

    swich(conf-line)#password 123456

    swich(conf-line)#login

    • SSH远程登录设置:

    Switch#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    Switch(config)#hostname cisco-sw1   交换机重新命名

    cisco-sw1(config)#ip domain-name cisco.com 配置域名

    cisco-sw1(config)#line vty 0 4

    cisco-sw1(config-line)#transport input ssh 登录方式为SSH

    cisco-sw1(config-line)#exit

    cisco-sw1(config)#crypto key generate rsa 配置秘钥

    The name for the keys will be: cisco-sw1.cisco.com

    Choose the size of the key modulus in the range of 360 to 2048 for your

    General Purpose Keys. Choosing a key modulus greater than 512 may take

    a few minutes.

    How many bits in the modulus [512]: 1024 思科推荐使用1024

    % Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

    展开全文
  • Line的配置模式及cisco常用show命令

    千次阅读 2017-11-22 20:18:21
    全局配置模式下,执行line vty或line console命令,将进入Line配置模式。该模式主要用于对虚拟终端(vty)和控制台端口进行配置,其配置主要是设置虚拟终端和控制台的用户级登录密码。 Line配置模式的命令行...

    思科交换机  Line配置模式

    在全局配置模式下,执行line vtyline console命令,将进入Line配置模式。该模式主要用于对虚拟终端(vty)和控制台端口进行配置,其配置主要是设置虚拟终端和控制台的用户级登录密码。

    Line配置模式的命令行提示符为:student1(config-line)#

    交换机有一个控制端口(console),其编号为0,通常利用该端口进行本地登录,以实现对交换机的配置和管理。为安全起见,应为该端口的登录设置密码,设置方法为:

    student1#config terminal

    student1(config)#line console 0

    student1(config-line)#?

    exit         exit from line configuration mode

    login        Enable password checking

    password     Set a password

    从帮助信息可知,设置控制台登录密码的命令是password,若要启用密码检查,即让所设置的密码生效,则还应执行login命令。退出line配置模式,执行exit命令。

    下面设置控制台登录密码为654321,并启用该密码,则配置命令为:

    student1(config-line)#password  654321

    student1(config-line)#login

    student1(config-line)#end

    student1#write

    设置该密码后,以后利用控制台端口登录访问交换机时,就会首先询问并要求输入该登录密码,密码校验成功后,才能进入到交换机的用户EXEC模式。

    交换机支持多个虚拟终端,一般为16个(015)。设置了密码的虚拟终端,就允许登录,没有设置密码的,则不能登录。如果对04条虚拟终端线路设置了登录密码,则交换机就允许同时有5telnet登录连接,其配置命令为:

    student1(config)#line vty 0 4

    student1(config-line)#password  123456

    student1(config-line)#login

    student1(config-line)#end

    student1#write

    若要设置不允许telnet登录,则取消对终端密码的设置即可,为此可执行no passwordno login来实现。

    Cisco IOS命令中,若要实现某条命令的相反功能,只需在该条命令前面加no,并执行前缀有no的命令即可。

    为了防止空闲的连接长时间的存在,通常还应给通过console口的登录连接和通过vty线路的telnet登录连接,设置空闲超时的时间,默认空闲超时的时间是10分钟。

    设置空闲超时时间的配置命令为:exec-timeout 分钟数秒数

    例如,要将vty 0-4线路和Console的空闲超时时间设置为3分钟0秒,则配置命令为:

    student1#config t

    student1(config)#line vty 0 4

    student1(config-line)#exec-timeout 3 0

    student1(config-line)#line console 0

    student1(config-line)#exec-timeout 3 0

    student1(config-line)#end

    student1#

     

     

     

     

    交换机基本状态:

    switch: ;ROM状态, 路由器是rommon>

    hostname> ;用户模式

    hostname# ;特权模式

    hostname(config)# ;全局配置模式

    hostname(config-if)# ;接口状态

     

    交换机口令设置:

    switch>enable ;进入特权模式

    switch#config terminal ;进入全局配置模式

    switch(config)#hostname  ;设置交换机的主机名

    switch(config)#enable secret xxx ;设置特权加密口令

    switch(config)#enable password xxa ;设置特权非密口令

    switch(config)#line console 0 ;进入控制台口

    switch(config-line)#line vty 0 4 ;进入虚拟终端

    switch(config-line)#login ;允许登录

    switch(config-line)#password xx ;设置登录口令xx

    switch#exit ;返回命令

    交换机VLAN设置:

    switch#vlan database ;进入VLAN设置

    switch(vlan)#vlan 2 ;建VLAN 2

    switch(vlan)#no vlan 2 ;删vlan 2

    switch(config)#int f0/1 ;进入端口1

    switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

    switch(config-if)#switchport mode trunk ;设置为干线

    switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan

    switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

    switch(config)#vtp domain  ;设置发vtp域名

    switch(config)#vtp password  ;设置发vtp密码

    switch(config)#vtp mode server ;设置发vtp模式

    switch(config)#vtp mode client ;设置发vtp模式

    交换机设置IP地址

    switch(config)#interface vlan 1 ;进入vlan 1

    switch(config-if)#ip address   ;设置IP地址

    switch(config)#ip default-gateway  ;设置默认网关

    switch#dir flash: ;查看闪存

    交换机显示命令:

    switch#write ;保存配置信息

    switch#show vtp ;查看vtp配置信息

    switch#show run ;查看当前配置信息

    switch#show vlan ;查看vlan配置信息

    switch#show interface ;查看端口信息

    switch#show int f0/0 ;查看指定端口信息

    2. 路由器支持的命令:

    路由器显示命令:

    router#show run ;显示配置信息

    router#show interface ;显示接口信息

    router#show ip route ;显示路由信息

    router#show cdp nei ;显示邻居信息

    router#reload     ;重新起动

    路由器口令设置:

    router>enable ;进入特权模式

    router#config terminal ;进入全局配置模式

    router(config)#hostname  ;设置交换机的主机名

    router(config)#enable secret xxx ;设置特权加密口令

    router(config)#enable password xxb ;设置特权非密口令

    router(config)#line console 0 ;进入控制台口

    router(config-line)#line vty 0 4 ;进入虚拟终端

    router(config-line)#login ;要求口令验证

    router(config-line)#password xx ;设置登录口令xx

    router(config)#(Ctrl+z) ; 返回特权模式

    router#exit ;返回命令

    路由器配置:

    router(config)#int s0/0 ;进入Serail接口

    router(config-if)#no shutdown ;激活当前接口

    router(config-if)#clock rate 64000 ;设置同步时钟

    router(config-if)#ip address   ;设置IP地址

    router(config-if)#ip address  second ;设置第二个IP

    router(config-if)#int f0/0.1 ;进入子接口

    router(config-subif.1)#ip address  ;设置子接口IP

    router(config-subif.1)#encapsulation dot1q  ;绑定vlan中继协议

    router(config)#config-register 0x2142 ;跳过配置文件

    router(config)#config-register 0x2102 ;正常使用配置文件

    router#reload ;重新引导

    路由器文件操作:

    router#copy running-config startup-config ;保存配置

    router#copy running-config tftp ;保存配置到tftp

    router#copy startup-config tftp ;开机配置存到tftp

    router#copy tftp flash: ;下传文件到flash

    router#copy tftp startup-config;下载配置文件

    ROM状态:

    Ctrl+Break ;进入ROM监控状态

    rommon>confreg 0x2142 ;跳过配置文件

    rommon>confreg 0x2102 ;恢复配置文件

    rommon>reset  ;重新引导

    rommon>copy xmodem: flash: ;从console传输文件

    rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP

    rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码

    rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP

    rommon>TFTP_FILE=c2600.bin ;指定下载的文件

    rommon>tftpdnld ;从tftp下载

    rommon>dir flash: ;查看闪存内容

    rommon>boot ;引导IOS

    静态路由:

    ip route    ;命令格式

    router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例

    router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例

    动态路由:

    router(config)#ip routing ;启动路由转发

    router(config)#router rip ;启动RIP路由协议

    router(config-router)#network  ;设置发布路由

    router(config-router)#negihbor  ;点对点帧中继用。

    帧中继命令:

    router(config)#frame-relay switching ;使能帧中继交换

    router(config-s0)#encapsulation frame-relay ;使能帧中继

    router(config-s0)#fram-relay lmi-type cisco ;设置管理类型

    router(config-s0)#frame-relay intf-type DCE ;设置为DCE

    router(config-s0)#frame-relay dlci 16 ;

    router(config-s0)#frame-relay local-dlci 20 ;设置虚电路号

    router(config-s0)#frame-relay interface-dlci 16 ;

    router(config)#log-adjacency-changes ;记录邻接变化

    router(config)#int s0/0.1 point-to-point ;设置子接口点对点

    router#show frame pvc ;显示永久虚电路

    router#show frame map ;显示映射

    基本访问控制列表

    router(config)#access-list  permit|deny  

    router(config)#interface  ;default:deny any

    router(config-if)#ip access-group  in|out ;default:out

    例1:

    router(config)#access-list 4 permit 10.8.1.1

    router(config)#access-list 4 deny 10.8.1.0 0.0.0.255

    router(config)#access-list 4 permit 10.8.0.0 0.0.255.255

    router(config)#access-list 4 deny 10.0.0.0 0.255.255.255

    router(config)#access-list 4 permit any

    router(config)#int f0/0

    router(config-if)#ip access-group 4 in

    扩展访问控制列表:

    access-list  permit|deny icmp  <DESTINATIONIP

    wild>[type]

    access-list  permit|deny tcp  <DESTINATIONIP

    wild>[port]

    例3:

    router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo

    router(config)#access-list 101 permit ip any any

    router(config)#int s0/0

    router(config-if)#ip access-group 101 in

    例3:

    router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80

    router(config)#access-list 102 permit ip any any

    router(config)#interface s0/1

    router(config-if)#ip access-group 102 out

    删除访问控制例表:

    router(config)#no access-list 102

    router(config-if)#no ip access-group 101 in

    路由器的nat配置

    Router(config-if)#ip nat inside ;当前接口指定为内部接口

    Router(config-if)#ip nat outside ;当前接口指定为外部接口

    Router(config)#ip nat inside source static [p] <私有IP><公网IP> [port]

    Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1

    Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80

    Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0

    Router(config)#ip nat inside source list 1 pool p1

    Router(config)#ip nat inside destination list 2 pool p2

    Router(config)#ip nat inside source list 2 interface s0/0 overload

    Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary

    Router#show ip nat translation

    rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。

    overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。

    外部网关协议配置:

    routerA(config)#router bgp 100

    routerA(config-router)#network 19.0.0.0

    routerA(config-router)#neighbor 8.1.1.2 remote-as 200

    配置PPP验证:

    RouterA(config)#username  password 

    RouterA(config)#int s0

    RouterA(config-if)#ppp authentication {chap|pap}

    3.PIX防火墙命令

    Pix525(config)#nameif ethernet0 outside security0 ;命名接口和级别

    Pix525(config)#interface ethernet0 auto ;设置接口方式

    Pix525(config)#interface ethernet1 100full ;设置接口方式

    Pix525(config)#interface ethernet1 100full shutdown

    Pix525(config)#ip address inside 192.168.0.1 255.255.255.0

    Pix525(config)#ip address outside 133.0.0.1 255.255.255.252

    Pix525(config)#global (if_name) natid ip-ip ;定义公网IP区间

    Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 ;例句

    Pix525(config)#global (outside) 1 133.0.0.1 ;例句

    Pix525(config)#no global (outside) 1 133.0.0.1 ;去掉设置

    Pix525(config)#nat (if_name) nat_id local_ip [netmark]

    Pix525(config)#nat (inside) 1 0 0

    内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。

    Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0

    内网172.16.5.0/16网段的主机可以访问global 1指定的外网。

    Pix525(config)#route if_name 0 0 gateway_ip [metric] ;命令格式

    Pix525(config)#route outside 0 0 133.0.0.1 1 ;例句

    Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 ;例句

    Pix525(config)#static (inside, outside) 133.0.0.1 192.168.0.8

    表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。

    Pix525(config)#static (dmz, outside) 133.0.0.1 172.16.0.8

    中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。

     

    展开全文
  • 【实验内容】 (1) 选择一台C2811 路由器,并添加两台交换机...(3) 进入路由器f0/0 接口模式配置IP 地址为192.168.1.1/24。进入路由器f0/1 接口模式配置IP 地址为192.168.2.1/24。 (4) 在路由器全局模式下使用show

    【实验内容】
    (1) 选择一台C2811 路由器,并添加两台交换机和两台计算机。分别在2 台计算机上配置IP 地址和网关,配置的IP 地址和网关如图所示,并与Switch 连接。

    在这里插入图片描述

    (2) 在路由器C2811 上,使用帮助查找路由器常用配置命令,并对命令运行的结果进行观察。见实验1,常用交换机配置命令。
    在这里插入图片描述

    (3) 进入路由器f0/0 接口模式,配置IP 地址为192.168.1.1/24。进入路由器f0/1 接口模式,配置IP 地址为192.168.2.1/24。
    在这里插入图片描述

    (4) 在路由器全局模式下使用show ip route 查看路由表,并观察路由表内容。
    在这里插入图片描述

    (5) 192.168.1.100 与192.168.2.100 之间进行ping 通。
    在这里插入图片描述

    (6)用show interface f0/0来查看局域网接口f0/0的详细信息,用show interface f0/1来查看局域网接口f0/1的详细信息。
    在这里插入图片描述
    在这里插入图片描述

    【实验问题】
    1. 从主机192.168.1.1上ping主机192.168.2.1时,数据包是如何传递的?主机、交换机、路由器分别又是如何处理的?结合show mac-address-table和show ip route进行解释。路由器分别又是如何处理的?结合show mac-address-table和show ip route进行解释。**
    主机192.168.1.1先查看自己的mac地址如果没有目标主机mac地址就给交换机进行广播,如果广播没有回应的,就交给网关,网关在交给路由器,路由器在去查看自己的路由表,如果查到最长相似的就交给它,再有它转发给目标地址

    2. 在路由器上用show arp 时看到什么ARP 条目?

    数字是生存时间,就是这个条目在ARP表中存在了多久,ARP表有个老化时间,这个AGE的时间到达老化时间而又没有收到该条的更新就会删除这条.
    AGE是“—”这个代表这个地址是在路由器/交换机上的,所以不需要计算老化时间
    数字就具体表示存在了多长时间(分钟为单位),你隔一分钟去show 一下,这个是会变化的。

    3. show int f 0/0是在那个配置模式下使用?
    特权模式

    展开全文
  • 华为交换机基础配置命令参考

    万次阅读 多人点赞 2019-03-24 10:06:03
    用户模式下,输入system-view进入视图模式,可执行设备全局配置命令; 局部配置模式 视图模式下,输入局部配置命令,如interface GE 1/0/0,进入GE1/0/0端口配置模式, 此外局部配置模式有很多种,可根据...

    华为交换机基础配置命令参考

    基础配置

    用户模式

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令;

     

    视图模式

    用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令;

     

    局部配置模式

    视图模式下,输入局部配置命令,如interface GE 1/0/0,进入GE1/0/0端口配置模式,

     

    此外局部配置模式有很多种,可根据不同需求进入vlan配置模式、端口聚合配置模式等,可输入?,查看当前模式下,能执行哪些命令;

     

    输入quit返回上一层配置模式,输入commit提交已有配置,用户模式下输入save保存配置;

     

     

    查看设备信息

    <HUAWEI>display version

     

    其中关键信息有:

    软件版本:Version 8.130 (S6800 V800R013C00SPC560B560)

    设备型号:HUAWEI S6800

    运行时间:0 day, 0 hour, 15 minutes

     

    查看和修改系统时间

    <HUAWEI>display clock

    <HUAWEI>clock datetime 12:00:00 2018-01-01

     

     

    修改设备名称

    <HUAWEI>system-view

    [~HUAWEI]sysname CE6800

    如果没有commit,需退出一次系统视图模式后保存;

     

     

     配置设备说明信息

    添加登录设备说明内容,举例:Only the administrator can configure the equipment

    [*CE6800]header shell information "Only the administrator can configure the equipment!"

     

    退出视图模式后可见

     

     

    配置console登录认证方式及超时时间

    Console登录:默认console登录无密码,任何人通过串口线直连设备console接口,可直接修改配置,管理员可配置console密码,登录不需要用户名,初次配置时使用console;

     

    超时时间:指连接设备后,一段时间内无操作,系统自动退出,需重新登录,默认超时时间为10min;

     

    进入console配置模式

    [*CE6800]user-interface console 0

     

    Console认证方式为password

    [*CE6800-ui-console0]authentication-mode password

     

    设置console密码为密文形式huawei@123

    [*CE6800-ui-console0]set authentication password cipher huawei@123

     

    设置超时时间为20min

    [*CE6800-ui-console0]idle-timeout 20 0

     

    使用quit返回视图模式,保存后使用display this检查配置结果,乱码是加密后的密码;

     

     

    Telnet 配置

    配置密文登录验证

    进入vty配置模式,0 4表示允许5个并发telnet连接

    [~CE6800]user-interface vty 0 4

     

    指定认证方式为password,出现要求使用aaa认证提示信息,暂时忽略

    [~CE6800-ui-vty0-4]authentication-mode password

     

     

    配置telnet使用密文认证,密码Gauss_234

    [*CE6800-ui-vty0-4]set authentication password cipher Gauss_234

     

    配置用户等级3,缺省为级别1

    [*CE6800-ui-vty0-4]user privilege level 3

     

    退出保存后,使用display this查看配置

     

     

    用户等级说明

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。
    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

     

    注:某些型号设备用户等级有0-15级,区分更细,其中15级与LEVEL 3权限一致,配置时需依据具体情况而定。

     

    配置aaa登录认证

    aaa认证

    authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;

     

    进入vty配置模式

    [~CE6800]user-interface vty 0 4

     

    退出vty配置模式后,进入aaa配置模式

    [*CE6800]aaa

     

    配置本地用户huawei密码为密文Gauss_234

    [*CE6800-aaa]local-user huawei password cipher Gauss_234

     

    配置huawei用户服务类型为telnet

    [*CE6800-aaa]local-user huawei service-type telnet

     

    配置huawei用户特权等级15(模拟器不支持此配置,只有用户等级0-3)

    [*CE6800-aaa]local-user huawei privilege level 15

     

    配置完成后查看结果,其中aaa认证模式无特殊要求,均采用默认模式

     

     

    telnet登录时会要求输入username和password

    配置设备超级密码

    超级密码

    在用户权限较低时(例如Telnet登陆时,可以定义权限级别为0戒1),此时

    可以使用super命令迚行权限提升。为避免非法权限提升带来的危害,应该配置

    超级密码迚行防护。

     

    为CE6800设置超级密码,密码以simple(明文)方式存储(模拟器不支持)

    [*CE6800]super password simple huawei

     

    保存及查看配置

    保存所有配置信息,先提交后保存

    [~CE6800]commit

    <CE6800>save

     

     

    查看已保存的所有配置

    [*CE6800]display saved-configuration

     

    查看当前所有配置

    [*CE6800]display current-configuration

     

     

    IP及路由配置

    配置接口IP

    拓扑图如下:

     

    CE6800配置

    [*CE6800]undo portswitch batch GE 1/0/0                                                  GE 1/0/0开启三层转发

    [*CE6800]interface GE 1/0/0                                                                       进入接口配置模式

    [*CE6800-GE1/0/0]ip address 10.0.12.1 24                                                配置IP及netmask

    [*CE6800-GE1/0/0]description this port connect to CE12800 GE 1/0/0      添加端口说明(可选)

    [*CE6800-GE1/0/0]undo shutdown                                                             激活接口

    [*CE6800-GE1/0/0]quit                                                                               退出接口配置模式

    [*CE6800]commit                                                                                        提交配置

     

    保存后查看配置:

     

     

    CE12800配置

    配置GE 1/0/0地址为10.0.12.1 24

    其余配置与CE6800相同,查看配置结果如下

     

     

    从CE6800 ping 对端CE12800,测试连通性

     

     

    配置静态路由

    接上一个案例,拓扑图如下:

     

    目标:让CE6800能ping通CE6850上的8.0.10.2

     

    在CE12800上,配置GE 1/0/1接口IP为8.0.10.1/24

     

     

    在CE6850上,配置GE 1/0/0 接口IP为8.0.10.2/24

     

     

    网络连通后,尝试从CE6800 ping CE6850上的8.0.10.2,结果ping不通;

    查看CE6800路由表,没有去往8.0.10.0/24的路由

     

     

    在CE6800上添加去往8.0.10.0/24的静态路由,下一跳地址应为CE12800上的10.0.12.2

    [*CE6800]ip route-static 8.0.10.0 24 10.0.12.2

     

    再尝试从CE6800 ping CE6850上的8.0.10.2,结果仍然ping不通,

    原因是CE6850没有去往10.0.12.0/24网段的路由,导致ping数据包“有去无回”;

    在CE6850上添加去往10.0.12.0/24的静态路由,下一跳地址应为CE12800上的8.0.10.1

    [~CE6850]ip route-static 10.0.12.0 24 8.0.10.1

     

    提交保存后,CE6800可以ping通CE6850上的8.0.10.2;

     

    查看CE6800、CE12800及CE6850路由表,分别如下图

     

     

    注意到Proto字段,有两种类型:Direct直连和Static静态,

    其中CE12800路由均为直连,Pre字段为0,

    而CE6800和CE6850有两条静态路由,Pre字段为60,

    Pre表示路由优先级,越小越优,路由会优先匹配;

     

    华为路由器默认协议优先级如下表

     

    其余协议均为动态路由协议,包括:

    OSPF(开放式最短路径优先协议)

    RIP(路由信息协议)

    IS-IS(中间系统到中间系统协议)

    BGP(边界网关协议)

     

    配置默认路由

     

    该拓扑图中,在CE6800和CE6850上配置默认路由,也可以互相ping通,配置示例如下:

     

    CE6800配置:

    [~CE6800]ip route-static 0.0.0.0 0.0.0.0 10.0.12.2

     

    CE6850配置:

    [~HUAWEI]ip route-static 0.0.0.0 0.0.0.0 8.0.10.1

     

    分别查看路由表:

     

     

    利用默认路由,拓扑图中两端设备也可以互相ping通;

     

    配置端口聚合

    LACP协议

    LACP,基于IEEE802.3ax标准的LACP(Link Aggregation Control Protocol,链路汇聚控制协议)是一种实现链路动态汇聚的协议。LACP协议通过LACPDU(Link Aggregation Control Protocol Data Unit,链路汇聚控制协议数据单元)与对端交互信息

     

    静态LACP汇聚由用户手工配置,不允许系统自动添加或删除汇聚组中的端口。汇聚组中必须至少包含一个端口。当汇聚组只有一个端口时,只能通过删除汇聚组的方式将该端口从汇聚组中删除。静态汇聚端口的LACP 协议为使能状态,当一个静态汇聚组被删除时,其成员端口将形成一个或多个动态LACP 汇聚,并保持LACP 使能。禁止用户关闭静态汇聚端口的LACP 协议。

    动态LACP汇聚是一种系统自动创建或删除的汇聚,动态汇聚组内端口的添加和删除是协议自动完成的。只有速率和双工属性相同、连接到同一个设备、有相同基本配置的端口才能被动态汇聚在一起。即使只有一个端口也可以创建动态汇聚,此时为单端口汇聚。动态汇聚中,端口的LACP 协议处于使能状态。

     

    端口聚合配置示例

    拓扑图如下:

     

    CE6850的GE1/0/1~GE1/0/3分别直连对端CE12808的GE1/0/1~GE1/0/3,将三条链路做链路聚合(channel);

     

    CE6850配置如下:

    [~CE6850]interface Eth-Trunk 1                                                进入Eth-Trunk子配置模式,

    [*CE6850-Eth-Trunk1]mode lacp-dynamic                                 选择lacp动态模式

    [*CE6850-Eth-Trunk1]lacp max active-linknumber 1                                          

    [*CE6850-Eth-Trunk1]least active-linknumber 1                                              

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/0

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/1

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/2                                 将三个端口加入Eth-Trunk 1

    [*CE6850-Eth-Trunk1]commit                                                   提交配置

     

    CE12808配置与CE6850相同;

     

    查看Eth-Trunk 1配置

     

     

     

    两端设备的三根连线形成链路聚合,逻辑接口为Eth-Trunk 1

     

    展开全文
  • 锐捷交换机配置命令节选

    千次阅读 2019-05-20 15:10:18
    锐捷交换机配置命令节选 命令模式的切换 ...进入全局配置模式 enable configure 进入接口配置模式 eanble configure interface g0/1 进入线路配置模式 eanble configure line conso...
  • 要返回特权模式,请输入全局配置模式命令 exit。 有许多不同的子配置模式。例如,要进入线路子配置模式,您可以使用line命令后跟您要访问的管理线路类型和编号来实现。使用exit命令来退出子配置模式并返回全局配置...
  • 神州数码交换机配置基本命令

    千次阅读 2020-09-20 09:16:08
    神州数码交换机配置基本命令 交换机基本状态: hostname> ;用户模式 ...进入全局配置模式 switch(config)#hostname ;设置交换机的主机名 switch(config)#enable secret xxx ;设置特权加密口令
  • 思科交换机Line配置模式在全局配置模式下,执行line vty或line console命令,将进入Line配置模式。该模式主要用于对虚拟终端(vty)和控制台端口进行配置,其配置主要是设置虚拟终端和控制台的用户级登录密码。Line...
  • Cisco路由器配置命令

    2013-05-31 10:46:46
    (1)模式转换命令Enable 用户模式进入特权模式,conf t 特权模式进入全局配置模式interface+接口类型+接口号全局配置模式进入接口模式line+接口类型+接口号全局配置模式进入线控模式注:用户模式:查看初始化的信息....
  • 交换机用户模式、特权模式全局模式、端口模式

    万次阅读 多人点赞 2019-09-17 17:04:03
    1.用户模式  交换机启动完成后按下Enter键,首先进入的就是用户模式,在些用户模式下用户将受到极大的限制,只能用来查看一些统计信息。  Switch>...全局配置模式  在特权模式下输入con...
  • CISCO配置模式

    2009-01-15 23:55:37
    全局配置模式:在特权用户模式下输入configure terminal 命令即可进入全局配置模式, 在该模式下主要完成全局参数的配置。提示信息:switch(config)# 接口配置模式:在全局配置模式下输入interface interface-...
  • 输入命令config terminal进入全局配置模式 switch(config)# 输入命令int xxx可进入端口或者vlan的全局配置子模式 特权用户模式可输入show命令查看相关设置,命令后输入?可查询帮助 可用no 命令撤销已经设置的配置...
  • 交换机配置基本命令

    千次阅读 2012-01-08 20:19:43
    交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 ...hostname(config-if)# ;...进入全局配置模式 switch(config)#hostname ;设置交换机的主机名
  • cisco配置基础命令

    2017-10-13 19:29:24
    cisco配置模式实用命令行(交换机为模型): enable ——> 进入特权模式; Switch# disable ——> 返回到用户模式; Switch> configure terminal ——> 进入全局配置模...
  • cisco交换机配置命令

    2014-01-27 08:14:42
    Switch>enable 进入特权...Switch#configure terminal 进入全局配置模式 Switch (config)# vlan vlan-id 创建一个Vlan或者进入Vlan配置模式 Switch (config-vlan)# name vlan-name 给Vlan命名(取消设置:no name)
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname...进入全局配置模式switch(config)#hostn...
  • 思科交换机配置命令

    2012-07-10 12:12:41
    进入全局配置模式 switch(config)#hostname ;设置交换机的主机名 switch(config)#enable secret xxx ;设置特权加密口令 switch(config)#enable password xxa ;设置特权非密口令 switch(config)#line console ...
  • 锐捷交换机配置命令

    千次阅读 2019-09-24 16:41:37
    锐捷交换机配置命令 交换机基本操作 1.进入特权模式 Switch>...全局配置模式[主机名(config)#]:配置交换机的整体参数 子模式: 1.线路配置模式[主机名(config-line)#]:配置交换机的线路参数 2.接口配...
  • 交换机配置命令

    2012-07-01 22:08:00
    类别 命令格式 命令含义 基本配置 ...进入全局配置模式 S(config)# hostnamename 改变交换机名称 S(config)# enable password levellevel_# password 设置用户口令(level_#=1)...
  • 思科三层交换机配置命令

    千次阅读 2019-05-21 14:29:03
    1.交换机支持的命令 思科交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;...进入全局配置模式 switch(config)#hostnam...
  • 第6天:交换机的配置命令实验01:交换机的工作模式实验目的:验证交换机常用的几个命令实验环境:实验...在用户模式输入enable命令进入特权模式在特权模式输入configureterminal进入全局模式在全局模式输入interfa...
  • VLAN配置命令列表

    2011-09-23 22:50:25
    命令 命令功能 configure terminal 进入全局配置模式 vlan vlan-id 创建VLAN命令 name vlan-name 给创建的
  • 交换机基本操作 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch> 配置模式: 全局配置模式[主机名(config)#]:...1.进入全局配置模式下 ………………
  • 思科路由配置命令

    千次阅读 2018-07-01 18:08:08
    路由器基本配置命令enable #进入特权模式 configure terminal 进入全局配置命令show ip interface brief 简要查看接口状态命令interface fastethernet 0/1 进入f0/1接口ip address 10.0.0.1 255.255.255.0 为...
  • Cisco路由配置命令

    千次阅读 2011-09-23 22:08:57
    Cisco路由配置命令 交换机命令总结 交换机口令设置: switch>enable 进入特权模式  switch#config terminal 进入全局配置模式 switch(config)#hostname 设置交换机的主
  • 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname aptech2950 以aptech2950 为例 switch> enable switch#c onfigure terminal switch(conf...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 625
精华内容 250
关键字:

进入全局配置模式命令