精华内容
下载资源
问答
  • 华为交换机的三种视图: 用户视图, 系统视图, 接口视图 用户视图: 刚开始登入交换机时的视图,一般...system-view // 进入系统视图的命令 clock timezone BJ add|minus 8 // 设置时区 clock datetime 16:36:00 20...

    华为交换机的三种视图: 用户视图, 系统视图, 接口视图

    用户视图: 刚开始登入交换机时的视图,一般看到的是尖括号<> .

    save    // 配置完交换机后保存当前配置的命令
    system-view    // 进入系统视图的命令
    clock  timezone  BJ  add|minus 8   // 设置时区
    clock  datetime  16:36:00 2016-07-01    //设置交换机的时间
    
    • 1
    • 2
    • 3
    • 4
    • 5

    系统视图: 在用户视图下输入system-view后进入系统视图,一般为方括号[]

    display current-configuration  // 显示当前配置
    user-interface maximum-vty 15  //配置vty最大连接数
    user-interface vty 0 14     //进入vty用户界面视图
    user privilege level 2      //设置vty登入的用户等级为2(配置用户级别)
    authentication-mode aaa  //设置vty登入时的验证模式为用户名和密码验证
    
    aaa  //进入AAA视图
    local-user admin password cipher admin@123  //设置aaa登入的用户名和密码
    local-user admin service-type telnet  //设置admin用户远程登入时的协议
    
    user-interface console 0     //进入第0个console口的用户界面
    authentication-mode passwd   //配置从console口登入交换机的认证模式为密码认证
    set authentication password cipher admin@123  //配置从console口登入交换机的密码
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    vlan 10  //创建一个VLAN
    
    
    interface meth 0/0/1   //进入交换机的第一个管理网口
    ip address 192.168.1.110 24 //设置管理网口的ip地址和子网掩码
    
    interface gigabitethernet 0/0/1 //进入第一个业务网口
    port link-type access  //设置第1个网口位access模式
    port default vlan 10   //设置此网口的VLAN号为10
    
    interface gigabitethnet 0/0/2 //进入第2个业务网口
    port link-type trunk   //设置第二个网口位trunk模式
    port trunk allow-pass vlan 10 20 30  //设置此端口可以通过的VLAN号
                 // port trunk allow-pass vlan all  表示可以通过所有的带VLAN的帧
    
    Interface gigabitethnet 0/0/3  //进入第3个业务网口
    Port link-type hybrid     //设置此端口为hybrid模式,每个端口默认就是hybrid模式
    Port hybrid pvid vlan 10   //设置pvid为10
    Port hybrid tagged vlan 20 30 40 //设置tagged列表为20,30,40
    Port hybrid untagged vlan 50 60 //设置untagged列表为50,60
    
    Display port vlan  //显示当前各端口的VLAN情况
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    清除某个端口的配置
    Interface gigabitethernet 0/0/2
    Clear configuration this
    Undo shutdown
    
    Interface gigabitethernet 0/0/3
    Undo port default vlan  //access 模式的端口
    Undo port link-type 
    Undo port hybrid pvid vlan vlanid  //hybrid 模式的端口
    Undo port hybrid untagged vlan vlanid 
    Undo port hybrid tagged vlan vlanid 
    Undo port trunk pvid vlan  //trunk 模式的端口
    Undo port trunk allow-pass vlan vlanid 
    Undo port link-type
    
    恢复出厂设置s5700SI
    在用户视图下(按Ctrl+z组合键回到用户视图)输入如下命令操作
    reset saved-configuration
    Y
    Reboot
    N
    Y
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    设置交换机的mux-vlan模式
    假设主VLAN是10,从VLAN中group模式的有VLAN 20, separate模式的有VLAN 30,server连接1号端口,PC1和PC2连接23号端口,PC3和PC4连接45号端口
    Vlan batch 10 20 30
    Vlan 10
    Mux-vlan
    Subordinate group 20
    Subordinate separate 30
    把各连接的端口设为access模式,并且加入到各自的VLAN中,且同时开启mux-vlan功能,
    Interface gigabitethernet 0/0/1        
    Port link-type access
    Port default vlan 10
    Port mux-vlan enable
    Interface gigabitethernet 0/0/2       //3号端口设置方法类似
    Port link-type access
    Port default vlan 20
    Port mux-vlan enable
    Interface gigabitethernet 0/0/4      //5号端口设置方法类似
    Port link-type access
    Port default vlan 30
    Port mux-vlan enable
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    三层交换机接路由器LAN口
    Vlan 60 70
    Interface vlanif 60
    ip address 192.168.60.1 24
    interface vlanif 70
    ip address 192.168.1.238 24
    interface gigabitethernet 0/0/3
    port link-type access
    port default vlan 60
    interface gigabitethernet 0/0/4
    port link-type access
    port default vlan 70
    ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
    在与交换机相连的路由器上设置一条静态ip地址,目的地址为交换机相关的各个网段地址,网关为交换机与路由器相连的vlanif的ip地址
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    批量配置交换机端口
    vlan batch 10 20
    port-group 1
    group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10
    port link-type access
    port default vlan 10

    华为交换机的三种视图: 用户视图, 系统视图, 接口视图

    用户视图: 刚开始登入交换机时的视图,一般看到的是尖括号<> .

    save    // 配置完交换机后保存当前配置的命令
    system-view    // 进入系统视图的命令
    clock  timezone  BJ  add|minus 8   // 设置时区
    clock  datetime  16:36:00 2016-07-01    //设置交换机的时间
    
    • 1
    • 2
    • 3
    • 4
    • 5

    系统视图: 在用户视图下输入system-view后进入系统视图,一般为方括号[]

    display current-configuration  // 显示当前配置
    user-interface maximum-vty 15  //配置vty最大连接数
    user-interface vty 0 14     //进入vty用户界面视图
    user privilege level 2      //设置vty登入的用户等级为2(配置用户级别)
    authentication-mode aaa  //设置vty登入时的验证模式为用户名和密码验证
    
    aaa  //进入AAA视图
    local-user admin password cipher admin@123  //设置aaa登入的用户名和密码
    local-user admin service-type telnet  //设置admin用户远程登入时的协议
    
    user-interface console 0     //进入第0个console口的用户界面
    authentication-mode passwd   //配置从console口登入交换机的认证模式为密码认证
    set authentication password cipher admin@123  //配置从console口登入交换机的密码
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    vlan 10  //创建一个VLAN
    
    
    interface meth 0/0/1   //进入交换机的第一个管理网口
    ip address 192.168.1.110 24 //设置管理网口的ip地址和子网掩码
    
    interface gigabitethernet 0/0/1 //进入第一个业务网口
    port link-type access  //设置第1个网口位access模式
    port default vlan 10   //设置此网口的VLAN号为10
    
    interface gigabitethnet 0/0/2 //进入第2个业务网口
    port link-type trunk   //设置第二个网口位trunk模式
    port trunk allow-pass vlan 10 20 30  //设置此端口可以通过的VLAN号
                 // port trunk allow-pass vlan all  表示可以通过所有的带VLAN的帧
    
    Interface gigabitethnet 0/0/3  //进入第3个业务网口
    Port link-type hybrid     //设置此端口为hybrid模式,每个端口默认就是hybrid模式
    Port hybrid pvid vlan 10   //设置pvid为10
    Port hybrid tagged vlan 20 30 40 //设置tagged列表为20,30,40
    Port hybrid untagged vlan 50 60 //设置untagged列表为50,60
    
    Display port vlan  //显示当前各端口的VLAN情况
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    清除某个端口的配置
    Interface gigabitethernet 0/0/2
    Clear configuration this
    Undo shutdown
    
    Interface gigabitethernet 0/0/3
    Undo port default vlan  //access 模式的端口
    Undo port link-type 
    Undo port hybrid pvid vlan vlanid  //hybrid 模式的端口
    Undo port hybrid untagged vlan vlanid 
    Undo port hybrid tagged vlan vlanid 
    Undo port trunk pvid vlan  //trunk 模式的端口
    Undo port trunk allow-pass vlan vlanid 
    Undo port link-type
    
    恢复出厂设置s5700SI
    在用户视图下(按Ctrl+z组合键回到用户视图)输入如下命令操作
    reset saved-configuration
    Y
    Reboot
    N
    Y
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    设置交换机的mux-vlan模式
    假设主VLAN是10,从VLAN中group模式的有VLAN 20, separate模式的有VLAN 30,server连接1号端口,PC1和PC2连接23号端口,PC3和PC4连接45号端口
    Vlan batch 10 20 30
    Vlan 10
    Mux-vlan
    Subordinate group 20
    Subordinate separate 30
    把各连接的端口设为access模式,并且加入到各自的VLAN中,且同时开启mux-vlan功能,
    Interface gigabitethernet 0/0/1        
    Port link-type access
    Port default vlan 10
    Port mux-vlan enable
    Interface gigabitethernet 0/0/2       //3号端口设置方法类似
    Port link-type access
    Port default vlan 20
    Port mux-vlan enable
    Interface gigabitethernet 0/0/4      //5号端口设置方法类似
    Port link-type access
    Port default vlan 30
    Port mux-vlan enable
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    三层交换机接路由器LAN口
    Vlan 60 70
    Interface vlanif 60
    ip address 192.168.60.1 24
    interface vlanif 70
    ip address 192.168.1.238 24
    interface gigabitethernet 0/0/3
    port link-type access
    port default vlan 60
    interface gigabitethernet 0/0/4
    port link-type access
    port default vlan 70
    ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
    在与交换机相连的路由器上设置一条静态ip地址,目的地址为交换机相关的各个网段地址,网关为交换机与路由器相连的vlanif的ip地址
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    批量配置交换机端口
    vlan batch 10 20
    port-group 1
    group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10
    port link-type access
    port default vlan 10

    转载于:https://www.cnblogs.com/qzqdy/p/8962432.html

    展开全文
  • top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器top...

    top命令经常用来监控linux的系统状况,比如cpu、内存的使用,程序员基本都知道这个命令,但比较奇怪的是能用好它的人却很少,例如top监控视图中内存数值的含义就有不少的曲解。

    本文通过一个运行中的WEB服务器的top监控截图,讲述top视图中的各种数据的含义,还包括视图中各进程(任务)的字段的排序。

     

    top进入视图

    top视图 01

    top视图 01

    【top视图 01】是刚进入top的基本视图,我们来结合这个视图讲解各个数据的含义。

    第一行:
    10:01:23 — 当前系统时间
    126 days, 14:29 — 系统已经运行了126天14小时29分钟(在这期间没有重启过)
    2 users — 当前有2个用户登录系统
    load average: 1.15, 1.42, 1.44 — load average后面的三个数分别是1分钟、5分钟、15分钟的负载情况。

    load average数据是每隔5秒钟检查一次活跃的进程数,然后按特定算法计算出的数值。如果这个数除以逻辑CPU的数量,结果高于5的时候就表明系统在超负荷运转了。

    第二行:
    Tasks — 任务(进程),系统现在共有183个进程,其中处于运行中的有1个,182个在休眠(sleep),stoped状态的有0个,zombie状态(僵尸)的有0个。

    第三行:cpu状态
    6.7% us — 用户空间占用CPU的百分比。
    0.4% sy — 内核空间占用CPU的百分比。
    0.0% ni — 改变过优先级的进程占用CPU的百分比
    92.9% id — 空闲CPU百分比
    0.0% wa — IO等待占用CPU的百分比
    0.0% hi — 硬中断(Hardware IRQ)占用CPU的百分比
    0.0% si — 软中断(Software Interrupts)占用CPU的百分比

    在这里CPU的使用比率和windows概念不同,如果你不理解用户空间和内核空间,需要充充电了。

    第四行:内存状态
    8306544k total — 物理内存总量(8GB)
    7775876k used — 使用中的内存总量(7.7GB)
    530668k free — 空闲内存总量(530M)
    79236k buffers — 缓存的内存量 (79M)

    第五行:swap交换分区
    2031608k total — 交换区总量(2GB)
    2556k used — 使用的交换区总量(2.5M)
    2029052k free — 空闲交换区总量(2GB)
    4231276k cached — 缓冲的交换区总量(4GB)

    这里要说明的是不能用windows的内存概念理解这些数据,如果按windows的方式此台服务器“危矣”:8G的内存总量只剩下530M的可用内存。Linux的内存管理有其特殊性,复杂点需要一本书来说明,这里只是简单说点和我们传统概念(windows)的不同。

    第四行中使用中的内存总量(used)指的是现在系统内核控制的内存数,空闲内存总量(free)是内核还未纳入其管控范围的数量。纳入内核管理的内存不见得都在使用中,还包括过去使用过的现在可以被重复利用的内存,内核并不把这些可被重新使用的内存交还到free中去,因此在linux上free内存会越来越少,但不用为此担心。

    如果出于习惯去计算可用内存数,这里有个近似的计算公式:第四行的free + 第四行的buffers + 第五行的cached,按这个公式此台服务器的可用内存:530668+79236+4231276 = 4.7GB。

    对于内存监控,在top里我们要时刻监控第五行swap交换分区的used,如果这个数值在不断的变化,说明内核在不断进行内存和swap的数据交换,这是真正的内存不够用了。

    第六行是空行

    第七行以下:各进程(任务)的状态监控
    PID — 进程id
    USER — 进程所有者
    PR — 进程优先级
    NI — nice值。负值表示高优先级,正值表示低优先级
    VIRT — 进程使用的虚拟内存总量,单位kb。VIRT=SWAP+RES
    RES — 进程使用的、未被换出的物理内存大小,单位kb。RES=CODE+DATA
    SHR — 共享内存大小,单位kb
    S — 进程状态。D=不可中断的睡眠状态 R=运行 S=睡眠 T=跟踪/停止 Z=僵尸进程
    %CPU — 上次更新到现在的CPU时间占用百分比
    %MEM — 进程使用的物理内存百分比
    TIME+ — 进程使用的CPU时间总计,单位1/100秒
    COMMAND — 进程名称(命令名/命令行)

    多U多核CPU监控

    在top基本视图中,按键盘数字“1”,可监控每个逻辑CPU的状况:

    top视图 02

    top视图 02

    观察上图,服务器有16个逻辑CPU,实际上是4个物理CPU。

    进程字段排序

    默认进入top时,各进程是按照CPU的占用量来排序的,在【top视图 01】中进程ID为14210的java进程排在第一(cpu占用100%),进程ID为14183的java进程排在第二(cpu占用12%)。可通过键盘指令来改变排序字段,比如想监控哪个进程占用MEM最多,我一般的使用方法如下:

    1. 敲击键盘“b”(打开/关闭加亮效果),top的视图变化如下:

    top视图 03

    top视图 03

    我们发现进程id为10704的“top”进程被加亮了,top进程就是视图第二行显示的唯一的运行态(runing)的那个进程,可以通过敲击“y”键关闭或打开运行态进程的加亮效果。

    2. 敲击键盘“x”(打开/关闭排序列的加亮效果),top的视图变化如下:

    top视图 04

    top视图 04

    可以看到,top默认的排序列是“%CPU”。

    3. 通过”shift + >”或”shift + <”可以向右或左改变排序列,下图是按一次”shift + >”的效果图:

    top视图 05

    top视图 05

    视图现在已经按照%MEM来排序了。

    改变进程显示字段

    1. 敲击“f”键,top进入另一个视图,在这里可以编排基本视图中的显示字段:

    top视图 06

    top视图 06

    这里列出了所有可在top基本视图中显示的进程字段,有”*”并且标注为大写字母的字段是可显示的,没有”*”并且是小写字母的字段是不显示的。如果要在基本视图中显示“CODE”和“DATA”两个字段,可以通过敲击“r”和“s”键:

    top视图 07

    top视图 07

    2. “回车”返回基本视图,可以看到多了“CODE”和“DATA”两个字段:

    top视图 08

    top视图 08

    top命令的补充

    top命令是Linux上进行系统监控的首选命令,但有时候却达不到我们的要求,比如当前这台服务器,top监控有很大的局限性。这台服务器运行着websphere集群,有两个节点服务,就是【top视图 01】中的老大、老二两个java进程,top命令的监控最小单位是进程,所以看不到我关心的java线程数和客户连接数,而这两个指标是java的web服务非常重要的指标,通常我用ps和netstate两个命令来补充top的不足。

    监控java线程数:
    ps -eLf | grep java | wc -l

    监控网络客户连接数:
    netstat -n | grep tcp | grep 侦听端口 | wc -l

    上面两个命令,可改动grep的参数,来达到更细致的监控要求。

    在Linux系统“一切都是文件”的思想贯彻指导下,所有进程的运行状态都可以用文件来获取。系统根目录/proc中,每一个数字子目录的名字都是运行中的进程的PID,进入任一个进程目录,可通过其中文件或目录来观察进程的各项运行指标,例如task目录就是用来描述进程中线程的,因此也可以通过下面的方法获取某进程中运行中的线程数量(PID指的是进程ID):

    ls /proc/PID/task | wc -l

    在linux中还有一个命令pmap,来输出进程内存的状况,可以用来分析线程堆栈:

    pmap PID

    转载于:https://www.cnblogs.com/-colin/p/7526202.html

    展开全文
  • Linux监控系统状态命令Top使用

    千次阅读 2014-05-14 09:59:16
    top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器...
    top命令经常用来监控linux的系统状况,比如cpu、内存的使用,程序员基本都知道这个命令,但比较奇怪的是能用好它的人却很少,例如top监控视图中内存数值的含义就有不少的曲解。
    本文通过一个运行中的WEB服务器的top监控截图,讲述top视图中的各种数据的含义,还包括视图中各进程(任务)的字段的排序。
     
    top进入视图
    top视图 01
    top视图 01
    【top视图 01】是刚进入top的基本视图,我们来结合这个视图讲解各个数据的含义。

    第一行:
    10:01:23 当前系统时间
    126 days, 14:29 系统已经运行了126天14小时29分钟(在这期间没有重启过)
    2 users 当前有2个用户登录系统
    load average: 1.15, 1.42, 1.44 load average后面的三个数分别是1分钟、5分钟、15分钟的负载情况。
    load average数据是每隔5秒钟检查一次活跃的进程数,然后按特定算法计算出的数值。如果这个数除以逻辑CPU的数量,结果高于5的时候就表明系统在超负荷运转了。
     
    第二行:
    Tasks 任务(进程),系统现在共有183个进程,其中处于运行中的有1个,182个在休眠(sleep),stoped状态的有0个,zombie状态(僵尸)的有0个。
     
    第三行:cpu状态
    6.7% us 用户空间占用CPU的百分比。
    0.4% sy 内核空间占用CPU的百分比。
    0.0% ni 改变过优先级的进程占用CPU的百分比
    92.9% id 空闲CPU百分比
    0.0% wa IO等待占用CPU的百分比
    0.0% hi 硬中断(Hardware IRQ)占用CPU的百分比
    0.0% si 软中断(Software Interrupts)占用CPU的百分比
    在这里CPU的使用比率和windows概念不同,如果你不理解用户空间和内核空间,需要充充电了。
     
    第四行:内存状态
    8306544k total 物理内存总量(8GB)
    7775876k used 使用中的内存总量(7.7GB)
    530668k free 空闲内存总量(530M)
    79236k buffers 缓存的内存量 (79M)
     
    第五行:swap交换分区
    2031608k total 交换区总量(2GB)
    2556k used 使用的交换区总量(2.5M)
    2029052k free 空闲交换区总量(2GB)
    4231276k cached 缓冲的交换区总量(4GB)
     
    这里要说明的是不能用windows的内存概念理解这些数据,如果按windows的方式此台服务器危矣:8G的内存总量只剩下530M的可用内存。Linux的内存管理有其特殊性,复杂点需要一本书来说明,这里只是简单说点和我们传统概念(windows)的不同。
     
    第四行中使用中的内存总量(used)指的是现在系统内核控制的内存数,空闲内存总量(free)是内核还未纳入其管控范围的数量。纳入内核管理的内存不见得都在使用中,还包括过去使用过的现在可以被重复利用的内存,内核并不把这些可被重新使用的内存交还到free中去,因此在linux上free内存会越来越少,但不用为此担心。
    如果出于习惯去计算可用内存数,这里有个近似的计算公式:第四行的free + 第四行的buffers + 第五行的cached,按这个公式此台服务器的可用内存:530668+79236+4231276 = 4.7GB。
     
    对于内存监控,在top里我们要时刻监控第五行swap交换分区的used,如果这个数值在不断的变化,说明内核在不断进行内存和swap的数据交换,这是真正的内存不够用了。
     
    第六行是空行
    第七行以下:各进程(任务)的状态监控
    PID 进程id
    USER 进程所有者
    PR 进程优先级
    NI nice值。负值表示高优先级,正值表示低优先级
    VIRT 进程使用的虚拟内存总量,单位kb。VIRT=SWAP+RES
    RES 进程使用的、未被换出的物理内存大小,单位kb。RES=CODE+DATA
    SHR 共享内存大小,单位kb
    S 进程状态。D=不可中断的睡眠状态 R=运行 S=睡眠 T=跟踪/停止 Z=僵尸进程
    %CPU 上次更新到现在的CPU时间占用百分比

    %MEM 进程使用的物理内存百分比
    TIME+ 进程使用的CPU时间总计,单位1/100秒
    COMMAND 进程名称(命令名/命令行)
    多U多核CPU监控
    在top基本视图中,按键盘数字1,可监控每个逻辑CPU的状况:
     
    top视图 02
    top视图 02
    观察上图,服务器有16个逻辑CPU,实际上是4个物理CPU。
    进程字段排序
    默认进入top时,各进程是按照CPU的占用量来排序的,在【top视图 01】中进程ID为14210的java进程排在第一(cpu占用100%),进程ID为14183的java进程排在第二(cpu占用12%)。可通过键盘指令来改变排序字段,比如想监控哪个进程占用MEM最多,我一般的使用方法如下:
    1. 敲击键盘b(打开/关闭加亮效果),top的视图变化如下:
     
    top视图 03
    top视图 03
    我们发现进程id为10704的top进程被加亮了,top进程就是视图第二行显示的唯一的运行态(runing)的那个进程,可以通过敲击y键关闭或打开运行态进程的加亮效果。
    2. 敲击键盘x(打开/关闭排序列的加亮效果),top的视图变化如下:
     
    top视图 04
    top视图 04
    可以看到,top默认的排序列是%CPU。
    3. 通过shift + >或shift + <可以向右或左改变排序列,下图是按一次shift + >的效果图:
     
    top视图 05
    top视图 05
    视图现在已经按照%MEM来排序了。
    改变进程显示字段
    1. 敲击f键,top进入另一个视图,在这里可以编排基本视图中的显示字段:
     
    top视图 06
    top视图 06
    这里列出了所有可在top基本视图中显示的进程字段,有*并且标注为大写字母的字段是可显示的,没有*并且是小写字母的字段是不显示的。如果要在基本视图中显示CODE和DATA两个字段,可以通过敲击r和s键:
     
    top视图 07
    top视图 07
    2. 回车返回基本视图,可以看到多了CODE和DATA两个字段:
     
    top视图 08
    top视图 08
    top命令的补充
    top命令是Linux上进行系统监控的首选命令,但有时候却达不到我们的要求,比如当前这台服务器,top监控有很大的局限性。这台服务器运行着websphere集群,有两个节点服务,就是【top视图 01】中的老大、老二两个java进程,top命令的监控最小单位是进程,所以看不到我关心的java线程数和客户连接数,而这两个指标是java的web服务非常重要的指标,通常我用ps和netstate两个命令来补充top的不足。
     
    监控java线程数:
    ps -eLf | grep java | wc -l
    监控网络客户连接数:
    netstat -n | grep tcp | grep 侦听端口 | wc -l
    上面两个命令,可改动grep的参数,来达到更细致的监控要求。
     
    在Linux系统一切都是文件的思想贯彻指导下,所有进程的运行状态都可以用文件来获取。系统根目录/proc中,每一个数字子目录的名字都是运行中的进程的PID,进入任一个进程目录,可通过其中文件或目录来观察进程的各项运行指标,例如task目录就是用来描述进程中线程的,因此也可以通过下面的方法获取某进程中运行中的线程数量(PID指的是进程ID):
     
    ls /proc/PID/task | wc -l
    在linux中还有一个命令pmap,来输出进程内存的状况,可以用来分析线程堆栈:
    pmap PID

    展开全文
  • 进入系统视图 进入接口g0/0/1接口视图 返回系统视图、返回用户视图 重新进入接口g0/0/1接口视图,快速返回用户视图 练习TAB补全、命令简写、?帮助用法 0.2 方案 图-1 0.3 步骤 步骤一:进入配置终端及切换...

    0.1 问题
    本例要求掌握华为交换机的配置视图,打开交换机lsw1配置终端,完成下列操作:

    进入系统视图
    进入接口g0/0/1的接口视图
    返回系统视图、返回用户视图
    重新进入接口g0/0/1的接口视图,快速返回用户视图
    练习TAB补全、命令简写、?帮助的用法
    0.2 方案
    在这里插入图片描述
    图-1

    0.3 步骤
    步骤一:进入配置终端及切换视图

    The device is running!
    //用户模式
    system-view //切进系统视图
    Enter system view, return user view with Ctrl+Z.
    [Huawei] //系统视图
    [Huawei] interface GigabitEthernet 0/0/1 //切进接口视图
    [Huawei-GigabitEthernet0/0/1] //接口视图
    [Huawei-GigabitEthernet0/0/1] quit
    [Huawei] quit

    system-view
    Enter system view, return user view with Ctrl+Z.
    [Huawei]interface GigabitEthernet 0/0/1
    [Huawei-GigabitEthernet0/0/1] //按Ctrl+Z快捷键
    //已快速返回到用户模式
    步骤二:命令行编辑技巧

    sys //输入sys后按TAB键
    system-view //自动补全完整命令
    sys //进系统视图的简写
    Enter system view, return user view with Ctrl+Z.
    [Huawei]
    [Huawei]int g0/0/1 //进接口模式的简写
    [Huawei-GigabitEthernet0/0/1]
    [Huawei-GigabitEthernet0/0/1]display ver? //在命令后加 ?会提示用法
    version
    [Huawei-GigabitEthernet0/0/1]display versio
    [Huawei-GigabitEthernet0/0/1]display version ?
    slot Slot
    | Matching output

    展开全文
  • 一、进入系统视图: <H3C>到[H3C]:system-view [H3C]到<H3C>:quit 注:<H3C>:用户视图 [H3C]:系统视图 二、帮助特性使用“?”,补全命令使用【tab】 三、更改系统名称: ...
  • questioning Django开发问答网站 License: MIT 设置 跳转到 . 基本命令 项目运行 版本要求:Python3.6及以上版本、Django2.2.0以上版本 依赖说明:使用虚拟环境,使用如下命令安装依赖: ...访问/xadmin进入后台
  • 华为路由器常用VRP命令一、命令行基础1.命令行视图2.快捷键二、常用命令1.用户视图命令2.系统视图命令3.接口视图命令4....系统视图:配置设备系统参数,或者进入其他功能视图,如:接口视图和协议视图。 接口
  • Linux下top命令

    2015-08-04 11:40:53
    top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器top...
  • Top命令经常用来监控Linux的系统状况,比如cpu、内存使用。 退出top界面命令:q 查看多核CPU命令 mpstat -P ALL 和 sar -P ALL 说明:sar -P ALL > aaa.txt 重定向输出内容到文件 aaa.txt本文通过一个运行...
  • top命令的使用

    2019-06-03 13:49:01
    本文通过一个运行中WEB服务器top监控截图,讲述top视图各种数据含义,还包括...【top视图 01】是刚进入top基本视图,我们来结合这个视图讲解各个数据含义。 第一行: 10:01:23 — 当前系统时间 ...
  • 进入系统视图——sy 交换机命名——sysname huawei 返回上一级——quit(q) 直接返回视图——return(ret) 保存配置——save(sa) 重启设备——reboot 查看配置——display current-configuration(dis cur) ...
  • 交换机路由基本配置命令行配置

    千次阅读 2019-06-02 13:39:40
    命令行配置视图 1、视图模式 <Huawei>用户视图 //当前视图为用户视图 <Huawei>system-view //进入系统视图 [Huawei]系统视图 ...
  • 华为路由器配置命令 <Huaiwei>system-view 进入系统视图模式 [Huaiwei]display interfaces 显示接口信息 [Huaiwei]display ip route 显示路由 [Huaiwei]link-protocol hdlc 绑定HDLC [Huaiwe...
  • ensp基础命令

    2020-11-04 19:23:33
    system-view 命令用来使用户从用户视图进入系统视图。 quit 命令用来从当前视图退回到较低级别视图,如果是用户视图,则退出系统。 undo 在配置命令前面加undo可以取消这条配置命令。 undo info-center enable...
  • top命令的使用详解

    2014-03-04 13:19:41
    top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器...
  • 在使用linux系统中,我们最长用查看系统性能方式就是使用命令top;通知我们只关心总体cpu和内存使用情况,对其他参数基本无视,也看不懂。下面来介绍一下top详细参数意义。top视图进入top基本视图,...
  • top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器...
  • linux下top命令的使用

    2015-05-11 17:01:38
    top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器top...
  • top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器top...
  • ensp 常用命令

    2020-11-26 10:54:20
    system-view 进入系统视图模式(默认是用户视图< Huawei >,系统视图是 [ Huawei ]) sysname 修改名字 interface + 对应接口名字 (从而对该接口进行相应配置) ip address + ip地址 + 子网掩码 ...
  • top命令经常用来监控linux的系统状况,比如cpu、内存使用,程序员基本都知道这个命令,但比较奇怪是能用好它人却很少,例如top监控视图中内存数值含义就有不少曲解。 本文通过一个运行中WEB服务器top...
  • ensp常用命令

    万次阅读 多人点赞 2018-11-22 00:02:48
    进入系统视图,默认我们打开命令行前面提示是尖括号&lt;&gt;,此为用户视图,当我们输入sys时就可以进入系统视图来对路由进行操作了 interface + 接口名  用来设置接口,例如路由器上有FE...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 467
精华内容 186
热门标签
关键字:

进入系统视图的命令