精华内容
下载资源
问答
  • Cisco交换机Trunk配置命令是什么?
    千次阅读
    2020-12-28 20:22:40

    展开全部

    TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高带宽。

    Trunk是一种封装技术,它是一条点到点的链路,链路的两端可以都是交换机,也可以是交换机和路由器,还可以是主机和交换机或路由器。

    基于端口汇聚(Trunk)功能,允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量,大幅度提供整个网络能力。

    在语音级应用的线路中,trunk一般指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它为两端设备之间进行转接,作为信令和终端设备数据的传输链路。

    扩展资料

    TRUNK功能具体应用

    1、TRUNK功能用于与服务器相联,给服务器提供独享的高带宽。

    2、TRUNK功能用于交换机之间的级联,通过牺牲端口数来给交换机之间的数据交换提供捆绑的高带宽,提高网络速度,突破网络瓶颈,进而大幅提高网络性能。

    3、Trunk可以提供负载均衡能力以及系统容错。由于Trunk实时平衡各个交换机端口和服务器接口的流量,一旦某个端口出现故障,它会自动把故障端口从Trunk组中撤消,进而重新分配各个Trunk端口的流量,从而实现系统容错。

    更多相关内容
  • Trunk端口配置

    万次阅读 2019-03-27 09:37:51
    以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机与交换机之间、交换机与路由器之间)承载多个不同VLAN...

    原理简述:

    在以太网中,通过划分VLAN来隔离广播域和增强网络通信的安全性。以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机与交换机之间、交换机与路由器之间)承载多个不同VLAN数据的,它不属于任何一个具体的VLAN ,可以承载所有的VLAN数据,也可以配置为只能传输指定VLAN的数据。

    Trunk端口一般用于交换机之间连接的端口,可以接收和发送多个VLAN的报文。

    当Trunk端口收到数据帧时,如果该帧不包含802.1Q的VLAN标签,将打上Trunk端口的PVID;如包含,则不改变。

    当Trunk端口发送数据帧时,当发送的数据帧的VLAN ID与端口的PVID不同时,检查其是否允许该VLAN通过,若允许的情况下,将其直接透传;不允许的情况下,直接丢弃。当该帧的VLAN ID与端口的PVID相同时,则剥离VLAN标签再转发。

    实验内容:

    保证在不同交换机下相同的部门之间能互相通信,需要配置交换机之间的链路为干道模式,实现相同VLAN跨交换机通信。

    实验目的:

    1.理解干道模式的应用场景;

    2.掌握Trunk端口的配置;

    3.掌握Trunk端口允许所有VLAN通过的配置;

    4.掌握Trunk端口允许特定VLAN通过的配置。

    实验拓扑:

    配置过程:

    1.根据实验要求,完成基础配置,实现在VLAN未划分前,各PC间可以互相通信。

    2.创建VLAN,配置Access接口:

    在S2和S3上,需要通过VLAN的划分隔离不同的部门。

    [S2]vlan batch 10 20
    [S2]vlan 10
    [S2-vlan10]description yanfa
    [S2-vlan10]vlan 20
    [S2-vlan20]description shichang
    .....

    配置完成后,可使用display vlan命令查看VLAN的信息。

    [S2]dis vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    10   common  
    20   common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    yanfa       //以配置好相关的VLAN                  
    20   enable  default       enable  disable    shichang    

    或使用display vlan summary命令查看所配置的VLAN的简要信息。

    [S2]dis vlan summary 
    static vlan:
    Total 3 static vlan.  //配置完好
      1 10 20      
    
    dynamic vlan:
    Total 0 dynamic vlan.
    
    reserved vlan:
    Total 0 reserved vlan.
    

    在交换机上划分接口到相应的VLAN内。

    [S2-Ethernet0/0/2]port link-type access 
    [S2-Ethernet0/0/2]port default vlan 10
    
    [S2-Ethernet0/0/3]port link-type access 
    [S2-Ethernet0/0/3]port default vlan 20
    。。。。。。
    S3交换机配置方法相同。
    

    划分后使用display port vlan命令检查VLAN和接口的配置情况。

    [S2]dis po v
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    Ethernet0/0/1           hybrid       1     -                                   
    Ethernet0/0/2           access       10    -          //已划分到相应的VLAN 内                         
    Ethernet0/0/3           access       20    -                                   
    Ethernet0/0/4           hybrid       1     -                                   
    Ethernet0/0/5           hybrid       1     -                                   
    Ethernet0/0/6           hybrid       1     -                                   
    Ethernet0/0/7           hybrid       1     -                                   
    Ethernet0/0/8           hybrid       1     -  
    ......

    在成功划分到相应VLAN后,测试相同部门中的PC的通信状态。

    PC>ping 10.1.1.3      //不能互通
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    3.配置Trunk接口:

    以上的操作是该跨交换机实现相同VLAN通信的二层组网拓扑中,虽然与PC端相连的交换机接口都划分到了相应的VLAN,但是在交换机与交换机之间相连的接口上并没有相应的VLAN信息,不能识别和发送跨越交换机的VLAN报文。此时的VLAN在每台交换机上只具有本地意义,而无法实现相同VLAN的跨交换机通信。

    现需要在交换机之间相连的接口配置为Trunk接口,而且配置的时候需要明确的指出被允许通过的VLAN,实现对VLAN流量传输的控制。

    [S1]int g0/0/1
    [S1-GigabitEthernet0/0/1]port link-type trunk    //配置Trunk模式
    [S1-GigabitEthernet0/0/1]port trunk allow-pass  vlan all   //允许所有VLAN通过
    。。。。。。。
    
    
    [S2]int e0/0/1	
    [S2-Ethernet0/0/1]port link-type trunk 	
    [S2-Ethernet0/0/1]port trunk allow-pass vlan 10 20   //允许VLAN 10、VLAN 20通过

    在交换机之间其他的接口上配置相同。

    可使用display port vlan命令检查Trunk的配置情况。

    [S1]dis port vlan
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/1    trunk        1     1-4094   //配置完善
    GigabitEthernet0/0/2    trunk        1     1-4094
    GigabitEthernet0/0/3    hybrid       1     -                                   
    GigabitEthernet0/0/4    hybrid       1     -                                   
    GigabitEthernet0/0/5    hybrid       1     -                                   
    GigabitEthernet0/0/6    hybrid       1     -                                   
    GigabitEthernet0/0/7    hybrid       1     -           
    ......

    完成所有的配置后再次测试PC间的连通性。

    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.3: bytes=32 seq=1 ttl=128 time=94 ms
    From 10.1.1.3: bytes=32 seq=2 ttl=128 time=63 ms
    From 10.1.1.3: bytes=32 seq=3 ttl=128 time=109 ms
    From 10.1.1.3: bytes=32 seq=4 ttl=128 time=78 ms
    From 10.1.1.3: bytes=32 seq=5 ttl=128 time=63 ms
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 63/81/109 ms
    //可以实现相同部门之间的通信

    注:在华为S系列交换机上,当Trunk端口收到带有vlan Tag的数据帧,但本机没有创建与该vlan tag数据帧中所携带的vlan id一致的vlan时,会对数据帧做丢弃处理。

     

    展开全文
  • 配置Trunk接口

    2022-03-23 20:14:15
    命令 1.创建VLAN S1: sys sysname S1 vlan 10 description RD vlan 20 description Market int e0/0/2 port link-type access port default vlan 10 int e0/0/3 port link-type access port default vlan 20 q ...

    拓扑图

     命令

    1.创建VLAN
    S1:
    sys
    sysname S1
    vlan 10
    description RD
    vlan 20
    description Market
    int e0/0/2
    port link-type access
    port default vlan 10
    int e0/0/3
    port link-type access
    port default vlan 20
    q
    
    S2:
    sys
    sysname S2
    vlan 10
    description RD
    vlan 20
    description Market
    int e0/0/3
    port link-type access
    port default vlan 10
    int e0/0/4
    port link-type access
    port default vlan 20
    q
    
    S3:
    sys
    sysname S3
    vlan 10
    description RD
    vlan 20
    description Market
    q
    
    display vlan
    S3:
    display vlan summary
    S1 S2:
    display port vlan
    
    2.测试PC1和PC3的连通性
    
    3.配置Trunk端口
    S1:
    int e0/0/1
    port link-type trunk
    port trunk allow-pass vlan 10 20
    q
    
    S2:
    int e0/0/2
    port link-type trunk
    port trunk allow-pass vlan 10 20
    q
    
    display port vlan
    
    S3:
    int g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int g0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    q
    
    

    展开全文
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • 配置vlan & 配置trunk

    2022-03-21 22:14:15
    配置VLAN 实验8的拓扑图如下: 正在上传…重新上传取消 正在上传…重新上传取消 第一步:对交换机SW1进行基本通用配置: 正在上传…重新上传取消 第二步:在交换机上分配局域网vlan的接口: 先检查当前...

    实验8:配置VLAN

    实验8的拓扑图如下:

     

    第一步:对交换机SW1进行基本通用配置:

    第二步:在交换机上分配局域网vlan的接口:

    • 先检查当前配置状态,以便于后续操作

    • 创建并命名局域网vlan

    Vlan2、Vlan3:

    • 配置Vlan2、Vlan3后,确定配置成功

     

     

    第三步:对pc进行命名与设置IP:

    • 进入pc,对其命名,此处以pc0为例,其余pc同理

    • 配置pc的ip地址

    以Pc0为例

    • 检测配置是否能够支持同局域网能通信,不同局域网之前是否被隔离:

    Vlan2下的通信:

     如下图,Pc0与Pc1通信成功

    Vlan3下的通信:

    利用命令提示符窗口来进行通信测试

     

    如下图,192.1688.3.2时pc3的地址,此时可以发现pc2和pc3通信成功

    Vlan2与Vlan3之间的通信:(不同局域网照理来说是不相的)

    测试例子如下:

    所以验证完毕,符合实验原理,实验8完成。

    实验8小结

    同一个局域网地址网段相同,即可完成信息共享,不同则无法实现信息共享;

    不同的局域网地址网段即使相同,也不能够完成信息共享。

    以下是思科模拟器上的测试图:

    如将pc2地址改为192.168.2.3

     

    如下图,pc2不能和同在vlan3的其他设备通信

    也不能与地址网段相同的设备通信。

    实验9:配置trunk

    实验9的拓扑图如下:

     

    第一步:交换机sw1、sw2创建命名vlan

    • 对交换机的基本配置,sw1为例,sw2同理

    • 先检查当前配置状态,以便于后续操作

    此处依旧以sw1为例,sw2同理

    • 创建并命名局域网vlan

    Vlan2、Vlan3:

    sw1为例,sw2同理

    • 配置Vlan2、Vlan3后,确定配置成功

    Sw1:

     

    Sw2同理。

    • 配置pc的ip地址:

    下面是sw1的连接的pc:

    其余pc和sw2以下的pc同法。

    第二步:配置sw1和sw2之间的trunk

    Sw1:

    Sw2:

     此时可以查看trunk状态

    最后发现不同交换机之间同局域网的pc能够通信

    如pc1和pc5,pc3和pc6都通讯成功

    第三步:移除vlan3在trunk上的流量,使得sw1和sw2上的vlan3不能通信

    Sw1

    Sw2

    然后sw1和sw2上的vlan3不能通信

    如pc2和pc6

    第四步:允许vlan3的流量,使得sw1与sw2的vlan3能通信

    Sw1

    Sw2

     测试了此时的pc2和pc6能通信

     

    第五步:修改native vlan为valn90

    Sw1

    Sw2

    经测试能通信

     修改vlan成功。

    实验8、9的pkt

    csdn链接https://download.csdn.net/download/qq_52373338/85014902

    百度网盘链接:https://pan.baidu.com/s/1Atmj3yUf7YF1mEAnRsBBjg?pwd=0000 
    提取码:0000

    展开全文
  • Trunk配置实验

    千次阅读 2020-04-12 20:32:57
    最近在初学网格配置,采用华为的ENSP平台来进行网络搭建仿真实验。第一个实验就是搭建一个简单的网络来进行实现同一局域网下不同VLAN间的通信,如图蓝色表示VLAN:5,绿色VLAN:9,他们旗下的主机是不能互相ping通的...
  • 两台交换机创建相同的vlan,这里是vlan10,然后将两台主机连接端口划分到创建的vlan中,将两台交换机连接的端口设置trunk模式,设置完成后,连接在两台交换机上的两台pc就可以ping通了。 SW1: enable conf t ...
  • 思科(CISCO)TRUNK简单配置

    万次阅读 2019-05-12 10:28:35
    思科TRUNK配置 ...TRUNK端口默认为所有 VLAN 的成员;因此,它传输所有 VLAN 的流量。本练习主要介绍创建 TRUNK 端口并将它们分配给本征 VLAN(而不是默认 VLAN)。 地址分配表 设备 接...
  • 因为在工作中遇到了一些问题,对trunk和三层交换有自己的理解,所以有感 一、trunk概述和作业 1.trunk概述 干道 主干链路 通常用于交换机和交换机之间,通过一个接口传输多个vlan 的数据包 ...
  • 3.2配置trunk接口

    2021-03-19 16:05:43
    配置trunk接口原理概述一、实验目的及编址二、实验拓扑二、实验内容配置双工模式1.配置ip地址做ping通测试总结与思考 原理概述 在以太网中通过划分vlan来隔离广播域和增强网络通信安全性。 为了使交换机的vlan帧能...
  • 配置思路:1.创建vlansw1#vlan database 进入vlan数据库sw1(vlan)#vlan 2 name jishu 创建名为:技术的vlanVLAN 40 modified:Name: jishusw1(vlan)#vlan 3 name caiwu 创建名为:财务的vlanVLAN 41 modified:Name: ...
  • #配置 trunk 链路的封装类型,同一链路的两端封装要相同。有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。 Switch(config)#interface f0/2 Switch(config-if)#switchport trunk encapsulation dot1q...
  • 6. 交换机端口链路类型介绍6.1 交换机端口链路类型介绍交换机以太网端口共有三种链路类型:Access、Trunk 和 Hybrid。1.Access 类型的端口只能属于 1 个 VLAN,一般用于连接计算机的端口;2.Trunk 类型的端口可以...
  • 思科交换机配置trunk模式及vtp

    千次阅读 2022-03-21 09:12:25
    一、 TRUNK 的背景 : 如果交换机与交换机之间存在多条链路,交换机每增加一个vlan,交换机与交换机就会增加一条链路。这样会存在链路浪费,就产生了 DTP ( dynamic trunk protocols)采用trunk后,所有的vlan都走...
  • 一直在想要不要把锐捷的命令整理出来,其实锐捷的命令和思科的基础命令是一样的,只要熟悉 思科命令,那么锐捷的命令基本上是没有问题的。但是有好多的粉丝私信我想要一份,我就...一、基础配置命令1、准备命令 wri...
  • 思科交换机如何配置trunk

    千次阅读 2021-04-02 14:43:43
    2、掌握Trunk配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20; 4...
  • 如图:(R1)------(SW1)------(PC1)//PC1属于vlan2,属于192.168.2.0网段||(SW2)------(PC2) //PC2属于vlan3,属于192.168.3.0网段sw1和sw2都用自身的fa0/3连接,把他们配置trunk模式,在设置sw1和sw2之间连接端口...
  • 华为:Eth-Trunk相关命令
  • VLAN与Trunk命令

    2022-03-16 15:52:31
    将交换机的端口加入到相应的vlan中,验证vlan的配置 3、交换机vlan接口类型 1.access 接口类型 接入模式:一般用于连接计算机 或者路由的端口 作用:数据进交换机时打上vlan标签,出交换机 脱掉vlan标签 2.trunk 终极...
  • H3C交换机配置trunk

    千次阅读 2021-12-21 00:11:49
    H3C交换机配置trunk 建vlan vlan 520 给当前端口添加vlan 520 port ethernet 1/0/1 to ethernet 1/0/10 进入vlan的地址配置 interface vlan-interface 520 为当前vlan配ip地址 ip address 224.220.3.2 255.255.255.0...
  • 有的交换机在将端口设置trunk的时候会报这个错误, Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. 出现这个错误的时候,先给端口封装dot1Q协议...
  • 有的思科交换机用户不知道怎么配置,这次我们来介绍一下思科交换机虚拟串口配置VLAN Trunk的步骤。交换机串口(Trunk)的作用:在以太网上通过交换机的串口实现中继可以使用如下两种封装类型:—IEEE 802.1Q—ISL...
  • 配置VLAN的相关命令作用以及Trunk命令作用1.静态路由结合vlan及trunk2.配置操作 1.静态路由结合vlan及trunk 2.配置操作 首先进入系统模式 system 然后敲更改名字命令sys R1 关闭提示信息 undo info-center enable...
  • 华为交换机VLAN配置TRUNK

    千次阅读 2022-01-17 16:29:55
    Lsw1配置(Lsw2同样): <Huawei>u t m Info: Current terminal monitor is off. <Huawei>SYS Enter system view, return user view with Ctrl+Z. [Huawei]sysname lsw1 //更改交换机名称lsw1 [lsw1...
  • 思科交换机配置TRUNK的主要步骤

    千次阅读 2020-12-18 22:39:12
    思科交换机配置TRUNK的主要步骤到底什么是TRUNK呢?使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的交换机产品中怎样来进行交换机配置TRUNK,下面我们来了解一下这些方面的知识。在二层交换机的性能...
  • HUAWEI设备如何配置Trunk ①进入对应接口配置接口类型 [SW1]interface e0/0/1 [SW1-Ethernet0/0/1]port link-type trunk 注意:如果这一步错了,需要一层一层的来删除配置,直到恢复到默认的配置,参考代码如下 ...
  • Trunk端口汇聚)的概念与设置

    万次阅读 2016-07-31 13:19:31
    在二层交换机的性能参数中,常常提到一个重要的指标:TRUNK,许多的二层交换机产品在...还有在具体的交换机产品中怎样来配置TRUNK.下面我们来了解一下这些方面的知识。 一、什么是TRUNK?   TRUNK端口汇聚
  • VLAN与Trunk配置

    2022-03-20 17:31:22
    四、Trunk配置 五、总结 一、VLAN的概述与优势 VLAN(Virtual Local Area Network)全称为虚拟局域网。 在传统的交换式以太网中,所有的用户在同一个广播域中,当网络规模较大时,广播..

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,224
精华内容 6,089
关键字:

配置trunk端口命令

友情链接: 3165964.rar