精华内容
下载资源
问答
  • 在网上找了很多资料,发现是window平台本身不带编译系统,而安装mysql-python需要进行编译。网上给出的办法是,安装vs2008或者MinGW,很是麻烦。后来总算找到另外一种超级简单的办法。 原来国外一个大学-加...

    最近要使用django进行项目开发,需要使用mysql-python模块。

    在本地搭建环境安装的时候却出现报错,Unable to find vcvarsall.bat 

    在网上找了很多资料,发现是window平台本身不带编译系统,而安装mysql-python需要进行编译。网上给出的办法是,安装vs2008或者MinGW,很是麻烦。后来总算找到另外一种超级简单的办法。

    原来国外一个大学-加州大学欧文分校的Christoph Gohlke提供了大量python非官方插件模块安装包:直接下载用pip安装就可以了。

    这里给出链接地址,真诚感谢老外。

    www.lfd.uci.edu/~gohlke/pythonlibs/

    打开网站找到mysql-python模块

    选择第四个whl文件。由于下载网速比较慢,这里给出我的链接

    在文件位置打开cmd,运行pip install MySQL_python‑1.2.5‑cp27‑none‑win_amd64.whl

    不出意外的话就会提示安装成功。

     

    转载于:https://www.cnblogs.com/ExMan/p/9365892.html

    展开全文
  • window10下python2.7安装pip报错

    千次阅读 2019-04-15 00:19:18
    get-pip.py 文件内容来源于(将网页内容保存) ...报错信息 D:\softs\python\Python27>python get-pip.py DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please ...

    get-pip.py 文件内容来源于(将网页内容保存)

    https://bootstrap.pypa.io/get-pip.py

    报错信息

    D:\softs\python\Python27>python get-pip.py
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
    Collecting pip
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:354: SNIMissingWarning: An HTTPS request has been made, but the SNI (Server Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
      Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
      Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
      Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
      Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
      Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
    c:\users\zhenhua\appdata\local\temp\tmpcjyvwz\pip.zip\pip\_vendor\urllib3\util\ssl_.py:150: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
      Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)) - skipping
      Could not find a version that satisfies the requirement pip (from versions: )
    No matching distribution found for pip
    

    解决方案:

    D:\softs\python\Python27>python get-pip.py -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
    Looking in indexes: http://pypi.douban.com/simple/
    Collecting pip
      Downloading http://pypi.doubanio.com/packages/d8/f3/413bab4ff08e1fc4828dfc59996d721917df8e8583ea85385d51125dceff/pip-19.0.3-py2.py3-none-any.whl (1.4MB)
        100% |████████████████████████████████| 1.4MB 5.1MB/s
    Collecting setuptools
      Downloading http://pypi.doubanio.com/packages/c8/b0/cc6b7ba28d5fb790cf0d5946df849233e32b8872b6baca10c9e002ff5b41/setuptools-41.0.0-py2.py3-none-any.whl (575kB)
        100% |████████████████████████████████| 583kB 5.4MB/s
    Collecting wheel
      Downloading http://pypi.doubanio.com/packages/96/ba/a4702cbb6a3a485239fbe9525443446203f00771af9ac000fa3ef2788201/wheel-0.33.1-py2.py3-none-any.whl
    Installing collected packages: pip, setuptools, wheel
      The script wheel.exe is installed in 'D:\softs\python\Python27\Scripts' which is not on PATH.
      Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
    Successfully installed pip-19.0.3 setuptools-41.0.0 wheel-0.33.1
    
    展开全文
  • 报错如下: 原因: 是由于 python3.8 asyncio 在 windows 上默认使用 ...jupyter 依赖 tornado,而 tornado 在 window 上需要使用 SelectorEventLoop,所以产生这个报错。 On Windows, Tornado requi...

    报错如下:

     

    原因:

    是由于 python3.8 asyncio 在 windows 上默认使用 ProactorEventLoop 造成的,而不是之前的 SelectorEventLoop。jupyter 依赖 tornado,而 tornado 在 window 上需要使用 SelectorEventLoop,所以产生这个报错。

    On Windows, Tornado requires the ``WindowsSelectorEventLoop``. This is
    the default in Python 3.7 and older, but Python 3.8 defaults to an
    event loop that is not compatible with Tornado. Applications that use
    Tornado on Windows with Python 3.8 must call
    ``asyncio.set_event_loop_policy(asyncio.WindowsSelectorEventLoopPolicy())``
    at the beginning of their ``main`` file/function.
     

    而对于像 jupyter 这种依赖于 tornado 的库,则无法用这种方式。目前这个问题已由 python 官方跟踪:https://bugs.python.org/issue37373

    临时解决办法:

    修改 python安装目录\Lib\site-packages\tornado\platform\asyncio.py

    import asyncio
    asyncio.set_event_loop_policy(asyncio.WindowsSelectorEventLoopPolicy())
    

    也就是在 import asyncio 之后,手动让 tornado 选择 SelectorEventLoop,这样 jupyter 就可以正常使用了。

    所以现在其实不太建议升级到 python3.8

    Python目前最新版本是3.8.0,2019年10月14日发布的,从学习者与开发者角度,都不应该选择最新版本,建议选择第一版是至少一年前发布的,这样很多第三方库也跟进变化了。

    2019年12月10日,推荐选择:

    3.7.x版本,因为3.7.0版本是2018年6月发布的

     

    展开全文
  • 1.首先下载whl文件   http://www.lfd.uci.edu/~gohlke/pythonlibs/#wordcloud 如果不知道下载哪个版本,先到dos命令下看一下 ...然后到下载的目录下进行安装 pip install wordcloud-1.3.3-


    1.首先下载whl文件 

     http://www.lfd.uci.edu/~gohlke/pythonlibs/#wordcloud


    如果不知道下载哪个版本,先到dos命令下看一下


    import pip
    print(pip.pep425tags.get_supported())
    
    
    然后到下载的目录下进行安装 
    
    
    
    
    
    pip install wordcloud-1.3.3-cp35-cp35m-win_amd64.whl

    展开全文
  • 点击Install package scrapy安装scrapy包,报错: 在cmd中输入命令:pip install scrapy 报错;提示pip版本过低: 复制命令'python -m pip install --upgrade pip',运行升级,提示successful成功: ...
  • pip安装Locust报错,提示如下图:(安装pymssql时也出现过类似问题) Error:Microsoft Visual C++ 14.0 is required. Get it with “Build Tools for Visual Studio”: ...
  • 现在总结一下,刚使用Python做图像处理,需要用到scipy 我们都知道scipy依赖numpy,其实不仅仅依赖numpy,当你用pip install numpy后,再pip install scipy时发现少很多包最常见的是 no lapack/blas resources ...
  • python 安装 aliyunsdkiotclient 模块报错问题决方案 工作场景 使用pycharm下启动项目 报错提示 没有安装 aliyunsdkiotclient模块 本人电脑系统 window10 python3.8.6 使用常规方法在python中pip install 安装 输入...
  • window安装dlib以及报错解决方案

    千次阅读 2020-12-31 09:49:45
    !!!!!!!!!!!!... You must use Visual Studio to build a python extension on windows. If you are getting this error it means you have not installed Visual C++. Note that there are many
  • window7 sp1安装python3.8.5

    2021-05-26 10:27:14
    安装问题:安装python报错 One or more issues caused the setup to fail.Please fix the issues and then retry setup.For more information see the log file 二、window7 sp1打补丁 百度之后发现是安装python...
  • Python安装MySQLdb模块报错解决方法

    千次阅读 2019-04-09 10:53:19
    MySQLdb安装报错解决方法 问题: 1.没有找到与Python版本匹配的 MySQLdb模块 2.提示需要安装VC++ XX库,因为pip3安装编译调用到window底层的东西。 解决以上问题方案: 1.下载自己安装Python对应的whl版本: ...
  • 真正可以解决pycrypto且最简单的方法【已经尝试成功】...pycrypto各大版本的下载安装:http://www.voidspace.org.uk/python/pycrypto-2.6.1/ 但是在window有一个问题务必要注意,我下载 pycrypto-2.6.1-cp34-non...
  • 安装jpype时发生报错: ...按照提示去装了Microsoft visual C++,结果重新安装还是报错,根据https://blog.csdn.net/qq_38934189/article/details/79460085这篇...1.从Python Extension Packages for Window...
  • window安装python_opencv

    2020-01-14 16:55:19
    打开cmd 1.安装依赖 pip install --upgrade setuptools pip install numpy Matplotlib 报错: 根据提示可以解决 ...2.安装python-opencv pip install opencv-python 3.验证opencv是否安装成功 python import ...
  • 系统是WIN10 64位Python是3.5.2今天安装pip install Scrapy来安装发现报错Microsoft Visual C++ 14.0 is required 检查发现电脑中其实是有Microsoft Visual C++ 14.0的,但是无论怎么都无法安装成功 后来解决办法...
  • window10 python 2.7.2 电脑重装后python第三方库没有了。重新下载就发现好多错误。 pip install requests报错 显示:Fatal error in launcher: Unable to create process using '"f:\python.exe" "F:\python\...
  • window,sts安装python

    2019-10-04 23:01:33
    window,sts安装python 1.先在python官网下载最新的python安装,安装的时候勾上所有选项 官网:https://www.python.org/downloads/ 2.在sts里安装pyDev插件,我当时直接search报错退出,之后选择...
  • 但是在window操作系统下,pycharm的pythonIDE中安装wordcloud包安装报错,但没安装成功。========================================问题分析:在通过pip install wordcloud命令行安装时报错如下:正如错误提示所说...
  • Cannot fetch index base URL https://pypi.python.org/simple/ Could not find any downloads that satisfy the requirement pefile>=2017.8.1 (from pyinstaller) 因为翻墙的原因 使用国内镜像 通过这个方式...
  • window系统下载python:https://www.python.org/downloads/windows/ 在此网页找到我们需要的版本,下载即可(这里我们选择下载后双击安装即可), 点击:Download Windows x86 executale installer(64位,上面...
  • ubuntu16.04安装pyaudio报错

    千次阅读 2018-10-14 17:05:55
    window上用pip安装 在ubuntu等linux上安装用apt安装 但我都尝试了,都不能正确安装,报出错误,安装失败。 显示类似如下错误: fatal error: portaudio.h: No such file or directory 尝试很多,说用 ...
  • python环境安装目录下的script目录下,cmd使用pip install lxmlm(前提是有pip模块)命令基本是安装不了lxml模块的,会报错。 因此就需要是官网下载whl文件,链接如下: https://www.lfd.uci.edu/~gohlke/python...
  • 直接用pip install命令安装pymssql报错,参照网上教程无果,最后在官网找到相对比较简便的教程 1、下载pymssql模块(选择正确的文件,例如64位Python 2.7选择pymssql‑2.1.1‑cp27‑none‑win_amd64.whl)下载地址 ...
  • cmd启动报错: 环境: python 3.6.5 window 7 问题原因 缺失相关的库文件 api-ms-win-crt-runtime就是MFC的运行时环境的库,python在windows上编译也是用微软的visual studio C++编译的,底层也会用到微软...

空空如也

空空如也

1 2 3 4 5 ... 12
收藏数 232
精华内容 92
关键字:

window安装python报错

python 订阅