精华内容
下载资源
问答
  • 配置静态链路聚合和动态LACP

    千次阅读 2020-05-04 12:54:54
    配置静态链路聚合 [lsw2]interface Eth-Trunk 1 [lsw2-Eth-Trunk1]mode manual load-balance 选择手工配置trunk链路聚合 [lsw2-Eth-Trunk1]trunkport g0/0/4 [lsw2-Eth-Trunk1]trunkport g0/0/5 [lsw2-Eth-Trunk1]...

    在这里插入图片描述
    配置静态链路聚合

    [lsw2]interface Eth-Trunk 1
    [lsw2-Eth-Trunk1]mode manual load-balance  选择手工配置trunk链路聚合
    [lsw2-Eth-Trunk1]trunkport g0/0/4 
    [lsw2-Eth-Trunk1]trunkport g0/0/5
    [lsw2-Eth-Trunk1]trunkport g0/0/6
    [lsw3]interface Eth-Trunk 1
    [lsw3-Eth-Trunk1]mode manual load-balance  选择手工配置trunk链路聚合
    [lsw3-Eth-Trunk1]trunkport g0/0/4 
    [lsw3-Eth-Trunk1]trunkport g0/0/5
    [lsw3-Eth-Trunk1]trunkport g0/0/6
    

    配置动态链路聚合(LACP)

    [lsw1]interface Eth-Trunk 2	
    [lsw1-Eth-Trunk2]mode lacp-static 	
    [lsw1-Eth-Trunk2]trunkport g0/0/1
    [lsw1-Eth-Trunk2]trunkport g0/0/2
    [lsw1-Eth-Trunk2]trunkport g0/0/3
    [lsw2]interface Eth-Trunk 2	
    [lsw2-Eth-Trunk2]mode lacp-static 选择动态配置链路聚合	
    [lsw2-Eth-Trunk2]trunkport g0/0/1
    [lsw2-Eth-Trunk2]trunkport g0/0/2
    [lsw2-Eth-Trunk2]trunkport g0/0/3
    [lsw2-Eth-Trunk2]max active-linknumber 2  主动端选择接口的阀值(数量)
    

    其他设置参数:

    [lsw2-Eth-Trunk2]display eth-trunk 查看eth-trunk的状态 	
    [lsw2-Eth-Trunk2]lacp preempt enable 开启抢占功能	
    [lsw2-Eth-Trunk2]lacp preempt delay 10 设置抢占延迟时间
    [lsw2]lacp priority 1000	更改系统优先级
    [lsw2]interface g0/0/3	
    [lsw2-GigabitEthernet0/0/3]lacp priority 100	更改端口的优先级
    
    展开全文
  • 链路聚合分为:静态链路聚合动态链路聚合 链路聚合的负载分担模式:对于二层数据流,系统会根据MAC地址(源 mac地址目的mac地址来计算),而对于三层数据流则会根据ip地址 来进行负载分担计算。 静态...
    链路聚合分为:静态链路聚合、动态链路聚合
    链路聚合的负载分担模式:对于二层数据流,系统会根据MAC地址(源
    mac地址和目的mac地址来计算),而对于三层数据流则会根据ip地址
    来进行负载分担计算。


    静态链路聚合实验:实验环境:H3C ENSP
    配置要点:
    第一步:创建链路聚合端口
    :(系统模式)interface eth-trunk 2(端口号)
    第二步:指定聚合端口的链路类型
    :(聚合端口模式)port link-type trunk
    第三步:如果聚合链路端口是trunk类型,则需要进一步指定允许相应
    数据通过的vlan编号
    :(聚合端口模式)port trunk allow-pass vlan 10(vlan号)
    第四步:把接口加入到链路聚合端口中

    :(接口模式)eth-trunk 2


    交换机1配置:

    [Huawei]display current-configuration 
    #
    sysname Huawei
    #
    vlan batch 10
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface Ethernet0/0/1
     eth-trunk 2
    #
    interface Ethernet0/0/2
     eth-trunk 2
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return

    交换机2配置:

    [Huawei]display current-configuration 
    #
    sysname Huawei
    #
    vlan batch 10
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface Ethernet0/0/1
     eth-trunk 2
    #
    interface Ethernet0/0/2
     eth-trunk 2
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return
    [Huawei] 

    测试图:


    展开全文
  • 作者:陆斌文章来自微信公众号:平台人生 内容简介:ESXi与物理交换机之间配置静态链路聚合时,因为静态链路聚合的特点,在进行down网卡和从虚拟...在日常应用中,链路聚合的配置模式有两种:静态模式和动态模...

    作者:陆斌
    文章来自微信公众号:平台人生

    内容简介:ESXi与物理交换机之间配置静态链路聚合时,因为静态链路聚合的特点,在进行down网卡和从虚拟交换机移除网卡的操作时,可能会无法完成故障流量切换,影响到虚拟机的运行。本文对其中的原理进行了分析。

    链路聚合(link aggregation)是将多个物理端口绑定为单一逻辑组的行为。在日常应用中,链路聚合的配置模式有两种:静态模式和动态模式。动态聚合的链路聚合,即大名鼎鼎的LACP,不再多做介绍,这里我们主要聊聊静态模式的链路聚合。静态模式,顾名思义,配置即生效,没有协商,聚合组创建之后立刻显示为“启动”状态,即使线路另一端的对应端口没有正确配置,也依然为“启动状态”,就是这么任性。
    当我们配置vSphere ESXi主机虚拟标准交换机(VSS)时,如果采用了双网卡绑定,并想使用“基于IP HASH 哈希的路由”这一负载平衡策略,必要条件是——与ESXi主机上行链路相连的物理交换机必须配置静态模式的链路聚合。只有物理交换机配置了链路聚合,ESXi主机VSS网卡绑定使用的“基于IP HASH哈希的路由”负载平衡策略才能够将网络流量均衡的分配到两块物理网卡,实现上行链路网络流量均衡和上行物理链路冗余。如果要问为什么不配置动态模式的链路聚合,原因很简单,虚拟标准交换机(VSS)不支持LACP协商,我们的选择只有一个——静态模式的链路聚合。


    图1.基于IP哈希的路由负载均衡策略

    图2. ESXi与物理交换机静态链路聚合配置示例

    一切配置就绪,总得测试一把,按照正常情况,链路聚合组中的一个端口失效后,网络流量应该会发生故障切换,那么从ESXi这边看,怎样才能使链路聚合组中的一个端口失效呢,我们很快会想到如下办法:down网卡(使用命令esxcli network nic down –n vmnicX)、从虚拟交换机移除网卡。当我们进行上述两个操作时,会发现物理交换机上与被down掉或被移除网卡对应的端口并没有失效,端口状态依然为UP,流量也没有发生故障切换,这是怎么回事?


    图3.从虚拟交换机移除网卡

    原来,一切就源于“静态模式”链路聚合。在配置静态模式链路聚合后,物理交换机端检测聚合端口是否生效,是通过链路的物理状态,即电信号,只要链路的电信号存在,端口即被认为是UP状态,而不管对端有没有正确配置。由此,我们可以得出如下分析:
    (1)当down掉ESXi上的一块网卡时,如果网卡的驱动程序不能切断网卡的电信号,那么上联物理交换机并不会感知到相连对端虚拟交换机聚合组中有成员被down掉,还是继续从被down掉网卡对应的端口发送数据,不会发生故障流量切换。
    (2)当从虚拟交换机移除网卡时,该网卡只是不再被ESXi使用,但是其电信号依然存在,上联物理交换机并不会感知相连对端虚拟交换机聚合组中有成员被移除,还是继续从被移除网卡对应的端口发送数据,也不会发生故障流量切换。

    通过以上的分析可以看出,在配置静态链路聚合后,如果要使聚合组中的成员失效,必须要切断其对应物理链路的电信号,否则物理交换机就会认为相应端口在聚合组中的状态为UP,不会发生故障流量切换。这就是我们发现的ESXi与物理交换机静态链路聚合配置过程中的小陷阱。
    在发现以上“小陷阱”后,我们又在多种型号服务器和物理交换机组合上对拔网线、down网卡、从虚拟交换机移除网卡这三种操作进行了测试,得出了以下结论:
    (1)拔网线,能够保证使物理交换机静态链路聚合组中的成员状态为Down,发生故障流量切换。
    (2)down网卡,与服务器使用的网卡型号和驱动程序相关,如果网卡的驱动程序在执行down网卡操作时能够切断网卡的电信号,那么就可以使物理交换机静态链路聚合组中的成员状态为Down,发生故障流量切换;否则无法发生故障流量切换。
    (3)从虚拟交换机移除网卡,物理交换机始终会认为相应的物理链路电信号正常,不会发生故障流量切换。

    知道了以上小陷阱后,如果我们的环境中配置了静态链路聚合,在进行down网卡和从虚拟交换机移除网卡的操作时,就要小心了。如果有重要的虚拟机在运行,且上行链路配置了静态链路聚合,强烈建议您不要轻易进行down网卡和从虚拟交换机移除网卡的操作,以防发生不测。

    转载于:https://www.cnblogs.com/inos/p/11381872.html

    展开全文
  • 链路聚合与权重

    2019-09-26 17:38:36
    链路聚合通过聚合多条并行的物理链路,对上层协议表现为一条逻辑链路...链路聚合分为动态和静态两种,静态的通过手工配置,动态的通过协议协商。IEEE 规定的链路聚合标准 LACP(Link Aggregation Control Protocol)使...

    链路聚合通过聚合多条并行的物理链路,对上层协议表现为一条逻辑链路,来提高吞吐量和冗余性。常见的链路聚合技术有Cisco的Etherchannel
    ,华为的Eth-trunk 以及 linux bonding 等。链路聚合分为动态和静态两种,静态的通过手工配置,动态的通过协议协商。IEEE 规定的链路聚合标准
    LACP(Link Aggregation Control Protocol)使用的最为广泛1。

    以太网的链路带宽是以10Mbps、100Mbps、1000Mpbs、10Gbps等,速率增长是离散的,链路聚合可以线性的增加链路带宽,例如两交换机之间的流量大于1Gbps小于2Gbps,利用链路聚合绑定两个千兆链路可以很好的解决问题;另一种情况,两交换机之间的流量大约11Gbps,可以利用链路绑定一条千兆一条万兆链路吗?下面的文章就来讨论这个问题。

    静态与动态

    静态链路聚合:
    不需要使用控制协议(i.e 不使用基于网络的协议),通过手工配置生效,当聚合口组成员端口启动后,立即生效(成为活动的成员端口)。

    动态链路聚合:
    需要使用链路聚合控制协议(LACP),端口通过配置加链路聚合组,但是否生效(被选中成为活动的成员端口)取决于LACP的协商结果。

    初见链路聚合——一个拓扑实践


    在详细介绍链路聚合之前,先来讨论图1拓扑,初步挖掘一下链路聚合技术,这个神奇的拓扑在《MSTP 解决链路负载均衡与链路检测》一文中用于讨论MSTP 在该拓扑上的适用性,这里面用来讨论链路聚合依然很合适(它依然能引出很多问题)。

    情景:如图1 所示,link1 是裸光纤链路,link2 中间加了百兆收发器。
    问:这样的拓扑能否使用链路聚合技术?
    答案:是不行的,链路聚合技术有很多限制,不同厂商的实现虽然不同,但是仍需要遵循这些限制,如图1 jieru 的E0/0/2 是一个百兆端口,G0/0/1 是一个千兆端口,二者的物理层实现不一样,无法聚合,图1 jieru 上配置e0/0/2与g0/0/1链路聚合会报错。

    假设1:将jieru e0/0/2 换成千兆端口(G0/0/2)。
    问:图1 拓扑可否使用链路聚合呢?
    答案:可以配置成静态的端口聚合,但是静态端口聚合可能会导致转发黑洞。

    先来看看link1与link2 有何不同。第一 对应两台交换机来说,g0/0/1 和g0/0/2 一个是光口,一个是电口,介质不同;第二 link1 实际速率(或者说 工作速率 speed)为1000Mbps,link2 实际速率为100Mbps。

    第一,介质不同的两个端口可以做链路聚合吗?原则上是不行的,但是事实上很多厂商已经实现这一功能2,只要两条链路都是全双工点对点链路就行。
    第二,工作速率不同的两个端口可以做链路聚合吗?动态链路聚合(基于LACP)不支持非等速率链路聚合,LACP 要求参与聚合的N条平行的链路 必须是全双工点对点端口,并且实际速率相同3;静态链路聚合并没有找到明确的规范,实际测试是可以聚合工作速率不同的两端口的。

    根据华为的实现,huiju上将G0/0/1 - 2 配置到一个Eth-trunk 中,在huiju上显示
    Eth-trunk 的带宽为1.1Gbps,实际上链路带宽不一定能到这么大(见下文 负载均衡章节分析)。

    而就算静态链路聚合可以很好的解决负载问题,但是依然解决不了图1 拓扑中潜在的风险,在《MSTP 解决链路负载均衡与链路检测》中谈到,应用在图1 中的冗余协议必须要解决对Link2的链路检测问题,才能避免转发黑洞。静态配置的链路聚合无法感知link2 光纤链路故障(不依赖hello消息),故障发生后相当一部分数据帧会被送入无休止的黑洞。

    假设2:目前的光纤传输技术发展的很快,利用DWDM技术,在单个波长上甚至都能传输40Gbps的流量,单条裸光纤使用百兆收发器实在浪费,将图1 中的百兆收发器改成高端些的光端机,为Link2 提供1Gbps的链路带宽。可以满足LACP的要求使用动态链路聚合技术了。
    问1:图1 使用LACP聚合的link2 还会产生流量转发黑洞吗?
    答:是不会的,使用LACP聚合的链路,会周期性的交换LACPDU,Link2 光纤链路故障发生后,LACP 可以感知到,从而将G0/0/2 端口置为非活动状态,分配给其的会话流量重新分配给G0/0/1 ,因而只会短暂的出现网络中断。
    **问2:**link2 光纤链路故障后,LACP多久才能感知到?
    **答:**LACP双方在协商阶段会较频繁的发送LACPDU,当协商完成确定要聚合的链路后,LACP双方默认Slow Periodic Time模式下,30s发送一次LACPDU,Long Timeout Time 90s;因此LACP 大约需要90s 才能感知到link2 光纤故障。对于有些业务来说90s的时间太长了,可以调整LACP 工作在Fast Periodic Time 模式下(仅当确认业务不繁忙,且端到端延时较小的情况下,不然造成LACP 震荡),1s 交互一次LACPDU ,Short Timeout Time 3s,从而实现故障快速感知切换。
    链路聚合原理分析

    上文已经谈到,链路聚合分为动态与静态两种,静态模式的链路聚合会造成不可预料的问题,在多数情况下建议使用动态模式下的链路聚合,使用链路聚合控制协议自动去协商、评估、聚合链路。这节从最常见的链路聚合控制协议(LACP)入手,分析链路聚合的原理。

    分层模型

    在OSI分层参考模型中,链路聚合工作数据链路层的链路聚合子层,MAC子层之上,MAC Client之下。链路聚合子层可以聚合多个独立的链路,向MAC Client 提供单一的MAC 接口,见下图2

    Aggregator (聚合器)为链路聚合组提供数据传输和接收的方法,并向MAC Client 提供单一的MAC 接口,Aggregator包含Frame Collector 和 Frame Distributor,Frame Collector负责从聚合链路组中接收数据帧,传递给MAC Client,Frame Distributor将从MAC Client 收取的数据帧通过聚合链路组传输出去,无论是接收还是传输数据帧,都必须要避免数据帧乱序或者重复;Aggregator Control 中,LACP 负责与对端系统通过Control Frame 交换信息,协商决定聚合哪些链路,以及使能或关闭聚合组,Aggregator Control 通过共享变量实现对Aggregator 的控制。图示见上图3 5.
    LACPDU

    链路聚合控制协议(LACP)通过交互LACPDU,为配对双方协商聚合哪几条条链路、以及协商如何在聚合链路上正确的发送与接收数据。LACPDU的格式

    LACPDU 通过二层组播发送。LACPDU结构中字段很多,这里先介绍一下什么是“Actor”与“Partner”。
    链路两端的LACP参与者,通过组播向链路上发送LACPDU,参与者发送LACPDU时,本地系统就称为“Actor”,远端系统就称为“Partner”(换句话说,每个参与者都认为自己是“Actor”,对方是“Partner”)。
    LACP状态机

    Receive machine:接收并维护与Partner的状态;
    Periodic Transmission machine:负责周期性的传送LACPDU,保持聚合状;
    Selection Logic :负责为端口选择合适的Aggregator,称:“端口选择了Aggregator” 为”selected”;
    Mux machine:负责将端口附着到对应的Aggregator(或分离) ,并且负责使能端口接收或转发数据(或关闭);
    Transmit machine:负责周期性的或按其他状态机的要求传输LACPDU。

    当LACP协商开始时,Receive machine 负责与Partner 交换配置信息,当Actor和Partner信息交换完毕后(双方完全知晓了对方的信息),Selection Logic 依据对应的算法为端口选择Aggregator,选择完毕后,Mux machine将处于”selected”状态的端口附着在其对应的Aggregator上,并使能数据转发;此后Aggregator便可收取MAC Client 的数据帧,向端口组分发,并且收集端口组转发来的数据帧,传递给 MAC Client;链路聚合完成后,Periodic Transmission machine 周期性的传送LACPDU,Receive machine 接收LACPDU,共同负责保持、维护LACP链路聚合组的状态;Transmit machine 在整个过程中,负责LACPDU的传输。

    LACPDU的Actor/Partner State

    LACP 使用LACPDU 向对端系统传达自身目前的状态(Actor State)、自己已知的对端系统的状态(Patner State),完成协商过程。

    1、协商开始之前,参与者双方都未收到对方的LACPDU,因此端口状态为

    Active, Aggeration, defaulted
    1
    Active:表示系统在该链路使能了LACP;
    Aggeration:表示系统认为该链路是“有聚合能力的”;
    defaulted:表示系统Receive machine 未获得”Partner”的LACPDU,因此将Partner的信息置于默认值。

    2、协商开始后,参与者双方收到了对方的LACPDU,获知了对方的信息,LACP为端口选择了合适的Aggregator,端口会置于以下状态通知对方:

    Active, Aggeration, Synchronization
    1
    Synchronization:表示系统认为该链路已经加入了聚合组,选择了合适的aggregator。

    3、当参与者双方的端口都处于2状态时,说明协商成功,该链路可以加入链路聚合组,参与者端口会置于以下状态通知对方:

    Activity, Aggregation, Synchronization, Collecting, Distributing
    1
    Collecting:表示Frame Collector 已经使能,准备接收数据帧;
    Distributing:表示Frame Distributor 已经使能,准备分发数据帧。

    4、最终参与者双方都处于3状态,链路聚合完成,开始准备转发数据帧。

    Selection 算法

    简介

    Selection 算法或者叫Selection逻辑,是LACP协议中最核心的部分。Selection为端口选择Aggregator,实际上就是决定哪些端口可以聚合,并形成链路聚合组。开始介绍前先了解一下几个概念:
    KEY:每个端口、aggregator 都对应一个key,拥有相同key的一组端口,具有聚合的潜力。端口的key 由端口的速率、双工状态、点对点状态以及管理配置信息等决定,具有相同key的端口才有可能聚合在一起。在推荐的实现中,每个端口对应一个aggregator,该aggregator的key与对应的端口的key相同。
    System Identifier:由LACP参与者的MAC地址(one of the ports of the System)和优先级(priority)组成。System Identifier用来决定Master与Salve,优先级值小的系统成为Master,优先级相同,则mac地址值小的成为Master。
    LAG ID:译为,链路聚合组标识符。同一链路聚合组内的端口的LAG ID 相同。LAG ID由 Actor System Identifier、Actor port key、Partner System Identifier、Partner port key组成。
    SElELCTED:当一个端口处于SElELCTED状态,说明该端口已经选择了合适的Aggregator,准备下一步准备attach到Aggregator,完成链路聚合。
    很多LACP的实现中,都需要管理员手动的在每个系统配置待聚合的端口组(如思科的EtherChannel),再由LACP协商决定哪些端口可以聚合。

    算法6

    每一个待聚合端口组只能产生一个链路聚合组,链路聚合组中端口的LAG ID 相同,其他端口处于”UNSELECTED(不选择任何Aggregator)”状态 ;
    Master系统,从待聚合端口组中优先级最高的端口开始选择,端口选择KEY与其相同的Aggregator(SELECTED),次优先级的端口如果LAG ID与最高优先级端口相同,则选择同一个Aggregator,若不同,则置于“UNSELECTED”状态,执行下一个端口,直到选择完毕。
    Slave系统根据Master的选择,决定聚合哪些端口。

    Master P1-3 属于待聚合端口组5,且端口的速率等信息相同,因此Key都为401(系统计算),
    Slave P1 P3属于待聚合端口组10,P2 属于带聚合端口组5,因此Key不相同。Master上P1-3的priority都为默认值,因此Port id 最小的P1 是最高优先级的端口,P1首先选择自己对应的aggregator;从图上可以看到P2的LAG ID (401,401,401,401)与P1 的LAG ID(401,401,12945,12945)不同,因此P2 置于”UNSELECTED”状态;P3的LAG ID与P1相同,因此P3 选择与P1 同一个aggregator ;Slave 根据Master 的聚合结果聚合自己的端口。

    如图6,将P2 的Priority改为0,因此P2成为了待聚合端口组中最高优先级端口,P2选择了自己对应的aggregator,由于P1、P3的LAG ID与P2不同,因此P1、P3置于“UNSELECTED”状态。
    负载均衡与权重

    这节讨论aggregator如何分发(从链路聚合组中选择一条成员链路并转发)上层协议(MAC Client)的数据帧,如图3 aggregator 中的Frame Distributor负责分发数据帧,分发需有一定的负载均衡算法, 使数据帧相对均匀的分布在不同的成员链路上,达到扩展带宽的作用。不同的链路聚合实现有多种分发负载算法,但每种分发算法最好都不要产生:

    给定的会话7 数据帧乱序
    数据帧重复
    数据帧乱序或者重复都会对接收者造成不良影响,为避免产生着两种情况,有一个约定俗成的规则,即:所有属于给定会话的数据帧 必须保证从同一链路转发。 这就要求给定会话无论何时到达Frame Distributor,Frame Distributor需要为其选择固定的一条链路,也就是说选择算法是”history Independent”,可以为每个会话维护一张转发端口的对应表,当第一个数据帧选择链路转发后,后续的数据帧依照转发表转发,如此减轻设备的计算负担。

    几种负载均衡算法

    满足上述规则的负载方式有很多,链路聚合可以使用 MAC 、IP、Layer4 port numbers 逐流负载,可以是基于源地址(端口)、目的地址(端口)或者两种都有8。可以根据不同的拓扑类型选择不同的负载方法。 

    Example A 是典型的“多对多”传输的场景,SW1 和 SW2 之间的聚合链路基于源MAC或目的MAC(src-mac or dst-mac)分发,即可将流量负载在各个成员链路;
    Example B 多台PC同一台路由器通信,路由器的IP、MAC都只有一个,因此源自PC的流量需使用源MAC 负载,源自路由器的流量需使用目的MAC负载。(SW1 src-mac,SW2 dst-mac);
    Example C 假设两台服务器所有的通信都使用相同的MAC地址,若实现负载,基于IP或MAC的负载方式都不行,可利用高层协议的信息负载,比如Layer4 port numbers。
    非等价链路聚合?

    回到图1 的问题,LACP为什么不能聚合速率不同的链路?端口的Key会依据速率(speed)等信息计算,如果速率不同,端口的Key就会不同,LACP无法聚合。上文说过可以通过静态的链路聚合将速率不同的链路聚合起来,但丧失了LACP的特性。目前LACP标准中还不能支持非等价链路聚合。

    非等价链路聚合设想

    假设需要带宽为12Gbps的链路,如何适配LACP才能实现呢,这里有个设想:
    首先LACP key的计算将端口速率排除在外,这样不同速率的端口key 的计算值相同,可以聚合在一起。只有这样是不行的,12Gbps的链路需要聚合三条链路带宽分别是10Gbps、1Gbps、1Gbps,以现有的分发负载方式是无法应对不同速率的端口的。可为每个端口维护一个Weight(权重)值,比如10Gpbs端口的weight是10,1Gbps的weight 是 1,Frame Distributor 依据不同的权重将10/12的会话分发到10Gbps的端口,将1/12的会话分发到1Gbps的端口。

    这里有个两个问题,第一 Frame Distributor 不可能预知链路的会话数量,该怎样依据比例分发会话呢?第二 每个会话的流量不同,以会话为粒度负载有可能会造成流量负载不均,甚至拥塞。
    为解决这两个问题,使用基于端口负载的动态的权重也许行得通。下面设想一下方案:

    为了获得更好的负载效果,将权重的基数设为100Mbps,因此10Gbps的原始权重是10000Mpbs/100Mbps=100,1Gbps的原始权重是10;
    当一个数据帧到达,获取当前3个端口的负载量(以Mbps为单位),X=负载量整除100,原始权重减去X等于当前端口权重,数据帧从当前权重最大的端口转发。
    维护一张转发表,转发表中是会话的信息与转发端口的对应表,当一个数据帧到达时,先搜索转发表,有对应的转发条目直接转发,没有对应的转发条目则执行上述2转发规则,计算出端口后,转发条目维护进转发表。
    这里面端口负载量的计算很有讲究,由于会话的流量是动态的,时大时小,因此负载量须是一段时间的平均负载量,时间跨度取大了或取小了都会对实际负载效果造成影响。

    实际实现中,转发表的最大可维持的条目数也有讲究。条目数太多,会过度占用设备的内存,并且寻址时间会增加;条目数太少,会影响选择算法的”history Independent”,同一会话的数据有可能从不同链路转发,造成乱序或帧重复。

     

    转载于:https://www.cnblogs.com/niezhongle/p/11077067.html

    展开全文
  • eNSP之链路聚合

    2020-11-02 21:24:21
    静态聚合和动态LACP模式的区别: 1、静态聚合模式 ,所有的物理接口成员都参与数据转发。 2、动态LACP模式 , 可以灵活的选取活动接口链路,又称为是M:N模式,M指得是活动链路(即转发数据的链路),N指的是备份链路。 ...
  • 以太网链路聚合通过将多条以太网物理链路捆绑在一起形成一条以太网逻辑链路,实现增加链路带宽的目的,同时这些捆绑在一起的链路通过相互动态备份,可以有效地提高链路的可靠性。在这里简单介绍一下华三交换机最常用...
  • 链路聚合(Link Aggregation)与权重

    千次阅读 2018-01-31 15:29:44
    链路聚合(Link Aggregation)与权重 介绍 链路聚合通过聚合多条并行的物理链路,对上层协议表现为一...链路聚合分为动态和静态两种,静态的通过手工配置,动态的通过协议协商。IEEE 规定的链路聚合标准  LACP(L
  • 通过在两台设备之间建立链路聚合组,可以提供更高的通讯带宽更高的可靠性。链路聚合不仅为设备间通信提供了冗余保护,而且不需要对硬件进行升级。 静态聚合 双方系统间不使用聚合协议来协商链路信息 动态聚合 ...
  • 我们知道端口聚合能够提高链路的带宽增加冗余性,目前华为设备负载分担有三种模式,分别是手工负载分担链路聚合和 LACP模式链路聚合以及动态LACP聚合。 手工负载分担模式链路聚合 手工负载分担模式下,Eth-Trunk...
  • 链路聚合 定义 把连接到同一台交换机上的多个物理端口捆绑为一个逻辑端口 功能 提高链路可靠性 聚合组内只要还有物理端口存活,链路就不会中断 增加链路传输带宽 避免了STP计算,聚合组内物理端口不会被闭塞 交换机...
  • 文章目录链路聚合一、手工负载分担模式二、LACP模式2.1静态LACP模式2.2动态LACP模式总结 链路聚合 一、手工负载分担模式 二、LACP模式 2.1静态LACP模式 2.2动态LACP模式 总结 提示:这里对文章进行总结: 例如:以上...
  • h3c v5 与 v3 链路聚合

    2013-01-29 15:10:24
    答:SMB交换机支持的聚合模式分别为手工聚合和静态LACP聚合,参照主网络V3平台的聚合模式,但在V5平台中,手工聚合对应的是静态聚合,静态LACP聚合对应的是动态聚合。 Q:H3C S12500/9500E交换机与S9500链路聚合如何...
  • 2、链路聚合 百科链路聚合:https://baike.baidu.com/item/%E9%93%BE%E8%B7%AF%E8%81%9A%E5%90%88/8626060?fr=aladdin ... 静态聚合和动态聚合模式 # 创建二层聚合端口1。 <Device...
  • 配置静态动态LACP,使多个接口起到Load balance的作用,本例中实现从PC-101发包,经过208与207的中间链路(配置链路聚合,每个聚合口最多支持8个聚合成员),最终报文到达PC-91,且查看中间链路各接口收发包计数。...
  • H3C Comware V3 端口聚合

    2019-03-20 23:15:00
    通常链路聚合有三种模式:手工汇聚、静态LACP汇聚和动态LACP汇聚。 但是V3版本下只提供了 手工聚合模式 manual 和 静态LACP聚合模式 static 两种 V3版本配置链路聚合 1,创建聚合组并指定聚合模式(系统视图) link-...
  • ESXI6.7虚拟机配置LACP静态汇聚端口网络负载均衡分流-虚拟机设置...按照LACP聚合方式的不同,链路聚合可以分为两种模式:静态聚合模式和动态聚合模式,本次我们先用静态汇聚模式。 静态汇聚。 静态LACP汇聚由用户手工
  • 动态路由

    2021-04-05 13:50:58
    静态路由与动态路由的比较 动态路由协议分类 距离矢量路由协议 链路状态路由协议 距离矢量路由协议 链路状态路由协议 RIP路由协议 RIP的基本概念 路由表的形成 RIP工作原理 水平分割毒性逆转 RIP 的两个...
  • 6.5 显示静态链路聚合配置统计信息 22 7 配置动态链路聚合 23 7.1 创建动态聚合 23 7.2 删除动态链路聚合组 24 7.3 添加/删除动态链路聚合中的端口 24 7.4 激活/关闭动态链路聚合状态 25 7.5 显示动态链路聚合配置...
  • Eth-trunk原理配置

    2020-03-19 19:22:21
    静态和动态区别:静态的 捆绑链路的数量都参与数据转发 动态聚合可以从捆绑的链路数中选择活跃的接口(数据转发的接口) 动态 聚合称为M:N模式 ,M指的是转发数据的接口 ,N指的是备份的接口 动态LACP 模式:----...
  • 链路聚合 路由器可以传递不同网段的数据 路由器依靠路由表传递数据 路由表获取方式 1,直连路由 2,静态路由 3,默认路由 0.0.0.0 0 4,动态路由 三层交换机使用过程: 1, 添加vlan 2, 对应的接口加入相应vlan 3, 进入...
  • 6.5 显示静态链路聚合配置统计信息 22 7 配置动态链路聚合 23 7.1 创建动态聚合 23 7.2 删除动态链路聚合组 24 7.3 添加/删除动态链路聚合中的端口 24 7.4 激活/关闭动态链路聚合状态 25 7.5 显示动态链路聚合配置...
  • ALCATEL交换机配置手册

    2013-07-02 16:32:52
    6.5 显示静态链路聚合配置统计信息 22 7 配置动态链路聚合 23 7.1 创建动态聚合 23 7.2 删除动态链路聚合组 24 7.3 添加/删除动态链路聚合中的端口 24 7.4 激活/关闭动态链路聚合状态 25 7.5 显示动态链路聚合配置...
  • 链路聚合分为动态聚合和静态聚合     2、什么是二层交换 自动建立终端MAC地址与端口的对应关系表,通过解析以太网包获取目的MAC地址,然后把包从对应的端口发送出去,如果在对应表中没有找到对应...
  • LACP简介

    2021-01-02 15:18:48
    静态LACP和动态LACP的区别 一、LACP LACP(Link Aggregation Control Protocol,链路聚合控制协议)是一种基于IEEE802.3ad标准的协议。LACP协议通过LACPDU(Link Aggregation Control Protocol Data Unit,链路聚合...
  • 静态LACP模式是一种利用LACP协议进行聚合参数协商、确定活动接口非活动接口的链路聚合方式。该模式下,需手工创建Eth-Trunk,手工加入Eth-Trunk成员接口,由LACP协议协商确定活动接口非活动接口。
  • GIGE设备物理连接配置

    2020-03-09 23:28:41
    在进行IP配置之间,必须在设备应用程序之间建立物理连接。GIGE设备可以使用多个物理连接来增加数据传输的总...3.静态链路聚合组配置(静态滞后配置,sLAG) 4. 动态链接聚合组配置(动态滞后配置,dLAG) SL配置...

空空如也

空空如也

1 2 3
收藏数 51
精华内容 20
关键字:

链路聚合静态和动态