精华内容
下载资源
问答
  • 之前我一直困扰于有关华为NAT技术的区别,因为无论在配置命令,还是我所得到的结果来说,我一直...静态NAT和NAT服务器都可以在接口视图下配置 静态NAT比NAT服务器多一个Netmask选项 少一个acl选项 但我感觉这些貌...

    之前我一直困扰于有关华为NAT技术的区别,因为无论在配置命令,还是我所得到的结果来说,我一直认为华为静态NAT和NAT

    服务器基本完全一样。

    先说一下我之前的观点:

    对比静态和NAT服务器在配置上的的区别

    静态NAT可以在系统视图下配置 NAT服务器不行

    静态NAT和NAT服务器都可以在接口视图下配置

    静态NAT比NAT服务器多一个Netmask选项 少一个acl选项

    但我感觉这些貌似对本质区别不大。

    然后翻阅网络上的资料,大部分答非所问。

    然而事实上这两个的区别在于:

    配置NAT Server和NAT Static的区别就是:NAT Server对于内网主动访问外网的情况不做端口替换,仅作地址替换;NAT Static对于内网主动访问外网的情况会同时替换地址和端口号。

    其实要说起来,NAT技术甭管怎么分类都是殊归同途,但是不知道为什么,我就是陷入了牛角尖中。

    展开全文
  • 华为eNSP:华为静态NAT,动态NAT配置实列

    千次阅读 多人点赞 2020-06-29 16:13:29
    华为eNSP:华为静态NAT,动态NAT配置实列拓扑图实验拓扑以及IP地址分配如下静态NAT服务器地址转换)动态NAT代码展示交换机的代码路由器R1的代码路由器R2的代码配置展示交换机配置路由器R1配置路由器R2配置 ...

    拓扑图实验拓扑以及IP地址分配如下

    在这里插入图片描述

    静态NAT(服务器地址转换)

    • 静态NAT实现了私有地址和公有地址的一对一转换,一个公网地址对应一个私网地址

    动态NAT

    • 动态NAT基于地址池来实现私有地址和公有地址的转换,转换是随机的

    代码展示

    交换机的代码

    <Huawei>system-view 
    [Huawei]sysname SW1
    [SW1]vlan batch  10 20 30 40                                       ##创建VLAN
    [SW1]interface  GigabitEthernet 0/0/1                              ##进入线路
    [SW1-GigabitEthernet0/0/1]port link-type access                    ##定义他为access端口
    [SW1-GigabitEthernet0/0/1]port default vlan 10                     ##打标签
    [SW1]interface  GigabitEthernet 0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type access
    [SW1-GigabitEthernet0/0/2]port default vlan 20
    [SW1]interface  GigabitEthernet 0/0/3
    [SW1-GigabitEthernet0/0/3]port link-type access
    [SW1-GigabitEthernet0/0/3]port default vlan 30
    [SW1]interface  GigabitEthernet 0/0/4
    [SW1-GigabitEthernet0/0/4]port link-type access
    [SW1-GigabitEthernet0/0/4]port default vlan 20
    [SW1]interface  GigabitEthernet 0/0/5
    [SW1-GigabitEthernet0/0/5]port link-type access
    [SW1-GigabitEthernet0/0/5]port default vlan 40
    [SW1]interface  GigabitEthernet 0/0/6
    [SW1-GigabitEthernet0/0/6]port link-type access
    [SW1-GigabitEthernet0/0/6]port default vlan 10
    [SW1]interface  Vlanif 10                                          ##进入VLAN
    [SW1-Vlanif10]ip address 192.168.10.1 24                           ##设置ip地址
    [SW1]interface  Vlanif 20
    [SW1-Vlanif10]ip address 192.168.20.1 24
    [SW1]interface  Vlanif 30
    [SW1-Vlanif10]ip address 192.168.30.1 24
    [SW1]interface  Vlanif 40
    [SW1-Vlanif10]ip address 11.0.0.2 24
    [SW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1                      ##设置静态路由
    

    路由器R1的代码

    <Huawei>system-view 
    [Huawei]sysname R1
    [R1]]interface GigabitEthernet 0/0/0                               ##进入线路
    [R1-GigabitEthernet0/0/0]ip add 11.0.0.1 24                        ##设置ip地址
    [R1]]interface GigabitEthernet 0/0/0 
    [R1-GigabitEthernet0/0/1]ip add 12.0.0.1 24
    [R1]ip route-static 192.168.10.0 24 11.0.0.2                       ##设置静态路由
    [R1]ip route-static 192.168.20.0 24 11.0.0.2 
    [R1]ip route-static 192.168.30.0 24 11.0.0.2 
    [R1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    [R1]nat static global 8.8.8.8 inside 192.168.10.10                 ##静态nat设置
    [R1]]interface g 0/0/1                                       
    [R1-GigabitEthernet0/0/1]nat static enable                         ##开通nat服务
    [R1]nat address-group 1 212.0.0.100 212.0.0.200                    ##设置外网ip群
    [R1]acl 2000                                                       ##设置内网ip池名为2000
    [R1-acl-basic-2000]rule permit  source  192.168.20.0 0.0.0.255     ##设置地址池范围
    [R1-acl-basic-2000]rule permit source  11.0.0.0 0.0.0.255
    [R1-acl-basic-2000]int g 0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound 2000 address-group 1 no-pat  ##将内网地址池2000里面的ip转换成外网地址群里面address-group 1
    [R1-acl-adv-3000]rule permit ip source 192.168.30.0 0.0.0.255
    [R1]int g 0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound  3000
    [R1]int g 0/0/1
    [R1-GigabitEthernet0/0/1]nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www
    

    路由器R2的代码

    <Huawei>system-view 
    [Huawei]sysname R2
    [R2]interface GigabitEthernet 0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2]interface loo 0
    [R2-LoopBack0]ip add 114.114.114.114 32
    [R2]ip route-static 8.8.8.8 32 12.0.0.1
    [R2]ip route-static 212.0.0.0 24 12.0.0.1
    [R2]interface g 0/0/1
    [R2-GigabitEthernet0/0/1]ip add 13.0.0.1 24
    [R2]ip route-static 9.9.9.9 24 12.0.0.1
    

    配置展示

    交换机配置

    SW1交换机一配置
    vlan batch 10 20 30 40
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
    interface Vlanif20
     ip address 192.168.20.1 255.255.255.0
    interface Vlanif30
     ip address 192.168.30.1 255.255.255.0
    interface Vlanif40
     ip address 11.0.0.2 255.255.255.0
    interface MEth0/0/1
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 20
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 20
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 40
    interface GigabitEthernet0/0/6
     port link-type access
     port default vlan 10
    ip route-static 0.0.0.0 0.0.0.0 11.0.0.1
    

    路由器R1配置

    acl number 2000  
     rule 5 permit source 192.168.20.0 0.0.0.255 
     rule 10 permit source 11.0.0.0 0.0.0.255 
    acl number 3000  
     rule 5 permit ip source 192.168.30.0 0.0.0.255 
     nat address-group 1 212.0.0.100 212.0.0.200
     nat static global 8.8.8.8 inside 192.168.10.10 netmask 255.255.255.255
    interface GigabitEthernet0/0/0
     ip address 11.0.0.1 255.255.255.0 
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.0 
     nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www
     nat outbound 2000 address-group 1 no-pat
     nat outbound 3000
     nat static enable
    ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    ip route-static 192.168.10.0 255.255.255.0 11.0.0.2
    ip route-static 192.168.20.0 255.255.255.0 11.0.0.2
    ip route-static 192.168.30.0 255.255.255.0 11.0.0.2
    
    

    路由器R2配置

    interface GigabitEthernet0/0/0
     ip address 12.0.0.2 255.255.255.0 
    interface GigabitEthernet0/0/1
     ip address 13.0.0.1 255.255.255.0 
    ip address 114.114.114.114 255.255.255.255 
    ip route-static 8.8.8.8 255.255.255.255 12.0.0.1
    ip route-static 9.9.9.9 255.255.255.255 12.0.0.1
    ip route-static 212.0.0.0 255.255.255.0 12.0.0.1
    
    展开全文
  • 演示目标: 配置一对一关系的静态NAT 配置一对多关系的静态NAT 演示环境:使用上面9.3.1 ...演示背景:在这个演示环境中,私有专用网络上的Web服务器192.168.2.100FTP服务器192.168.2.200需要提供给公共网络上...

    演示目标:

    配置一对一关系的静态NAT

    配置一对多关系的静态NAT

    演示环境:使用上面9.3.1 理解并取证:网络地址翻译(NAT)-静态NAT的工作原理部分关于一对一关系的静态NAT图 9.52的网络环境。

    203440335.png


    演示背景:在这个演示环境中,私有专用网络上的Web服务器192.168.2.100和FTP服务器192.168.2.200需要提供给公共网络上的主机访问,并要求公共网络上的主机202.202.2.100访问202.202.1.100时就是访问192.168.2.100的Web服务器;访问202.202.1.200时就是访问192.168.2.200的FTP服务器,使用静态NAT来完成上述要求。

    演示步骤:


    第一步:保持前面演示环境中的网络基础配置,如接IP地址、启动路由协议等,然后在NAT路由器R1上完成静态NAT的配置,具体配置如下:


    关于静态NAT的配置:

    R1(config)#ip nat inside source static 192.168.2.100202.202.1.100

    配置静态NAT将内部源地址192.168.2.100转换成202.202.1.100的公共地址。

    R1(config)#ip nat inside source static 192.168.2.200202.202.1.200

    配置静态NAT将内部源地址192.168.2.200转换成202.202.1.200的公共地址。

    R1(config)#interface e1/1

    R1(config-if)#ip nat outside * 配置NAT的外部接口。

    R1(config-if)#exit

    R1(config)#interface e1/0

    R1(config-if)#ip nat inside * 配置NAT的内部接口。

    R1(config-if)#exit


    第二步完成上述配置后,在公共网络上的主机202.202.2.100上使用http://202.202.1.100和ftp://202.202.1.200来访问私有网络中的Web和FTP服务器,访问的结果如下图9.66所示,显示成功访问,如果我们在访问服务器之前,在NAT路由器R1上执行了debug ip nat detailed调试NAT的翻译过程,会得到如下图9.67所示的结果,然后可以通过show ip nat translations来查看NAT的翻译表,如下图9.68所示,可看出一个公共IP地址对一个私有网络专用地址,然后以结合9. 3. 4理解NAT的地址类型的案例二来进一步理解NAT的四种地址类型。


    203645567.png

    203646530.png

    203646270.png


    第三步:现在出于某种原因,可能是为了节省可用的公共IP地址,要求公共网络上的主机202.202.2.100仅使用一个公共IP地址202.202.1.100就可以访问到私有网络上的Web和FTP服务器,关于它的原理与演示环境如前面9.3.2 理解并取证:网络地址翻译(NAT)-动态NAT工作原理部分关于静态NAT一对多关系的图 9.53所示,配置一对多关系的静态NAT如下所示:


    R1(config)#ip nat inside source statictcp 192.168.2.100 80 202.202.1.100 8000

    静态NAT将内部源地址192.168.2.100和TCP端口80翻译成公共IP地址202.202.1.100和端口号8000。

    R1(config)#ip nat inside source statictcp 192.168.2.200 21 202.202.1.100 2001

    静态NAT将内部源地址192.168.2.200和TCP端口21翻译成公共IP地址202.202.1.100和端口号2001。



    注意:上面的静态NAT翻译,虽然将两个不同的内部本地IP(私有专用网络IP)翻译成同一个内部全局IP(公共IP),但是由于翻译了端口号,使用了TCP套接字的方式,所以可以识别出不同的会话。

    第四步在完成上述配置后,可以在公共主机202.202.2.100上使用http://202.202.1.100:8000和ftp://202.202.1.100:2001去访问私有网络上的Web和FTP服务器,这里必须申明使用的端口号,否则无法完成访问,如下图9.69所示,表示成功访问,同时可以在NAT路由器上使用debug ip nat detailed得到如下图 9.70所示的结果,执行showip nat translations来查看NAT翻译表如下图9.71所示的结果。

    203844228.png

    203845736.png




    本文转自 kingsir827 51CTO博客,原文链接:http://blog.51cto.com/7658423/1320184,如需转载请自行联系原作者
    展开全文
  • 1,静态NAT服务器地址转换) 静态NAT实现了私有地址公有地址的一对一转换,一个公网地址对应一个私网地址 2,动态NAT 动态NAT基于地址池来实现私有地址公有地址的转换,转换是随机的 3,NAPT(网络地址...

    一、NAT的四种类型

    1,静态NAT(服务器地址转换)

        静态NAT实现了私有地址和公有地址的一对一转换,一个公网地址对应一个私网地址

    2,动态NAT

        动态NAT基于地址池来实现私有地址和公有地址的转换,转换是随机的

    3,NAPT(网络地址端口转换)

        NAPT允许多个私网地址转换到同一个公有地址的不同端口,私网利用端口号来区分。

    4,Easy IP:转换成出接口地址

        利用端口号来识别不用的私网地址,NAPT的特例。直接将内网私有地址转换为出接口的公网IP地址。

    二、NAT配置

    1,实验拓扑以及IP地址分配如下:

     

    2,静态NAT配置步骤:


        1,进入“出接口”:interface s4/0/0
        2,地址转换:nat static(静态) global(公网IP:未分配的IP地址)172.16.2.3 inside (内网需要转换的PC的私有IP地址)192.168.1.1

    3,动态NAT配置:

        1.设置公网地址池:nat address-group 1 172.16.2.3 172.16.2.254
        2.创建ACL:acl 2000
        3.允许网段1.0的数据进行转换:rule 5 permit source 192.168.1.0 0.0.0.255

                                                        :rule 10 deny                               //华为acl最后有一条默认的隐藏命令:permit any 与思科相反
        4.进入接口(出方向):interface serial4/0/0
        5.匹配ACL:nat outbound 2000 address-group 1 no-pat                          //no-pat的作用:(不进行端口转换)

    4,NAPT的配置:

        1,公网地址池被缩减为只包含一个IP地址: nat address-group 1 172.16.2.254   172.16.2.254

        2,在动态NAT的第五步进行接口转换,nat outbound 2000 address-group 1

    5,Easy IP的配置:

        1.创建ACL:acl 2000
        2.允许1.0的数据进行转换:rule 5 permit source 192.168.1.0 0 .0.0.255

                                                :rule 10 deny
        3.进入接口(出方向):interface serial4/0/0
        4.匹配ACL:nat outbound 2000

    三、验证Easy IP:

    用PC1 ping AR2,分别在接口g0/0/1和接口s4/0/0抓包查看源IP地址:

    接口G0/0/1

    接口S4/0/0

     

    展开全文
  • 静态路由,NAT和代理服务器/ALG

    千次阅读 2014-12-26 08:48:12
    默认情况下,操作系统并不允许在两个网卡间直接转发IP数据包,因为这台 计算机可能是接入到多个业务层面的服务器。在这里,我们的目的就是配置最简单的路由,因此启动IP转发功能。 有几种配置方法: (1)
  • 配置静态NAT

    2010-12-24 20:39:37
    掌握静态NAT,内部网络有e-mail服务器和FTP服务器等需要为外部用户提供服务,这些服务器的IP地址可以采用静态地址转换 【实验功能】 允许内部主机访问互联网 【实验拓扑】 【实验步骤】 路由器左边...
  • 实验环境:思科模拟器Cisco Packet Tracer IP地址划分: WEB:192.168.1.1 DNS:192.168.1.2 ...内网能正常访问外网,外网只能访问内网的DNS服务器和WEB服务器 实验拓扑图: 在路由器上的配置: 1、添加标准A...
  • 默认情况下,操作系统并不允许在两个网卡间直接转发IP数据包,因为这台计算机可能是接入到多个业务层面的服务器。在这里,我们的目的就是配置最简单的路由,因此启动IP转发功能。 有几种配...
  • 我们通过一个例子来说说它们的作用: A公司的内网有100台电脑,网段为192.168.1.0/24,某些...静态NAT: 最重要的特点是一对一,而且是静态指定的(一个内网ip对应一个外网ip是固定好的),常用于将内网服务器的ip地.
  • 目录一、前言二、学习目标三、NAT应用场景四、静态NAT五、动态NAT六、Easy IP七、NAT服务器八、实验配置8.1 实验要求8.2 配置操作8.2 验证 一、前言 随着Internet的发展网络应用的增多, IPv4地址枯竭已经成为制约...
  • 静态NAT转换

    2009-05-08 11:14:30
    最近有人问我,如何配置NAT (网络地址转换),从而使得互联网上的计算机通过其思科路由器访问其内部的Web电子邮件服务器。这需要在专门公用的IP地址专门私用的IP地址之间配置一个静态NAT转换。下面笔者谈一下...
  • 配置静态 NAT 【实验目的】 配置网络地址变换,提供到公司共享服务器的可靠外部访问。 【背景描述】 某 IT 企业因业务扩展,需要升级网络,他们选择 172.16.1.0/24 作为私有地址,并用NAT 来处理外部网络的连接。 ...
  • NAT的实现方式有三种,即静态转换Static Nat、动态转换Dynamic Nat 端口多路复用OverLoad。 静态转换 (Static Nat) 是指将内部网络的私有IP地址转换为公有IP地址,IP地址对是一对一的,是一成不变的,某个私有...
  • nat和静态映射

    2012-06-08 13:35:57
    要求:内部通过NAT上网、设为222.222... R3模仿内部服务器静态映射为222.222.222.100 r2 en conf t int f0/0 ip add 192.168.0.100 255.255.255.0 no sh exit ip route 0.0.0.0 0.0.0.0 f0/0 r3 en ...
  • NAT技术代理服务器

    2017-06-25 23:37:19
    NAT技术是1994年提出的。...NAT的实现方式有三种,即静态转换Static Nat、动态转换Dynamic Nat和端口多路复用OverLoad。静态转换是指将内部网络的私有IP地址转换为公有IP地址,IP地址对是一对一的,是一成不变的,某
  • 客户端Server端不能直接通讯,都作了一对一的静态NAT 当客户端采用被动模式的FTP连接FTP服务器端时,FTP的控制通讯数据通讯,发起端都在客户端: ----对于客户端侧防火墙来说,都是从高安全区到低安全区的访问...
  • 最近有人问我,如何配置NAT (网络地址转换),从而使得互联网上的计算机通过其思科路由器访问其内部的Web电子邮件服务器。这需要在专门公用的IP地址专门私用的IP地址之间配置一个静态NAT转换。下面笔者谈一下...
  • DHCP,NAT和静态路由综合实验 目标 1、PC0自动从DHCP服务器获得192.168.10.100的地址,PC1自动从DHCP服务器获得1.1.1.100的地址(需要在Router0上配置中继代理),PC2自动从soho路由器上获得192.168.1.100的地址,...
  • 1.在vmware虚拟网络编辑器中,取消NAT模式下的:“使用本地DHCP服务将IP地址分配给虚拟机”选项。 2.编辑宿主机VMnet8适配器的IPV4属性。设置IP地址子网掩码,使其与vmware子网处于同一网段。 3.编辑虚拟操作...
  • NAT静态端口映射

    2018-05-11 00:05:14
    端口映射是将一台主机的内网IP地址映射成一个公网...端口映射分为动态和静态,此处以静态端口映射为例,针对如下拓扑完成实验模拟:实验要求:将内网一台提供网络服务的pc机IP通过路由器端口映射成一个外网IP12.0.0...
  • NAT

    2019-07-21 15:57:50
    静态NAT实现了私有地址公有地址的一对一映射 一个公网ip只会分配给唯一且固定的内网主机 动态NAT 动态NAT基于地址池来实现私有地址公有地址的转换 NAPT 同网络地址端口转换NAPT允许多个内部地址映射到同一个...
  • NAT静态网络地址转换

    2018-05-10 19:55:09
    NAT静态网络地址转换第一个实验,静态网络地址转换。原理:将内部网络的私有IP地址转换为公用合法的IP地址,IP地址的对应关系是一对一的,而且是不变的,即某个私有IP地址只转换为某个固定的合法的外部IP地址。借助...
  • 路由器配置静态NAT地址转换

    千次阅读 2008-12-21 23:30:00
    如何配置NAT (网络地址转换),从而使得互联网上的计算机通过其思科路由器访问其内部的Web电子邮件服务器。这需要在专门公用的IP地址专门私用的IP地址之间配置一个静态NAT转换。下面笔者谈一下解决这个问题的...
  • ACL、NAT和PAT

    2021-03-19 14:07:06
    ACL、NAT和PATACL(访问控制列表)访问控制列表访问控制列表在接口应用的方向作用ACL工作原理ACL种类ACL(访问控制列表)的应用原则:应用规则NAT网络地址转换工作原理NAT功能静态NAT动态NATPAT端口多路复用原理PAT...
  • 文章目录22NAT应用场景NAT的好处NAT类型静态NAT配置动态NATNAPT动态NAT和PAT配置Easy IPNAT服务器配置前言 应用场景 01NAT应用场景 02NAT应用实例 不学私网路由 03NAT地址转换信息表 NAT的好处 有效避免来自外网...
  • 为了在公司家中不改变ip,所以采用vm的NAT模式来设置静态ip 1、vm采用NAT模式联网 2、编辑vm虚拟机设置 3、查看该网段的网关 可以看出网关为192.168.101.2,然后开始设置静态ip 然后查看win本机...

空空如也

空空如也

1 2 3 4 5 ... 16
收藏数 306
精华内容 122
关键字:

静态nat和服务器nat