精华内容
下载资源
问答
  • 华为交换机配置DHCP

    2020-10-08 23:45:55
    DHCP Server配置 <Huawei>u t m <Huawei>system-view [Huawei]sysname DHCP Server [DHCP Server]vlan batch 10 20 [DHCP Server]dhcp enable [DHCP Server]ip pool vlan10 [DHCP Server-ip-pool-vlan...

    DHCP Server

    DHCP有区分全局地址池与基于接口的地址池,本篇主要介绍基于接口的DHCP配置

    网络拓扑

    在这里插入图片描述

    DHCP Server配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]sysname DHCP Server
    [DHCP Server]vlan batch 10 20
    [DHCP Server]dhcp enable
    [DHCP Server]ip pool vlan10
    [DHCP Server-ip-pool-vlan10]gateway-list 10.0.0.254
    [DHCP Server-ip-pool-vlan10]network 10.0.0.0 mask 24
    [DHCP Server-ip-pool-vlan10]excluded-ip-address 10.0.0.240 10.0.0.253  #限制IP范围
    [DHCP Server-ip-pool-vlan10]lease day 2  #有效期
    [DHCP Server-ip-pool-vlan10]dns-list 114.114.114.114
    [DHCP Server-ip-pool-vlan10]quit
    [DHCP Server]ip pool vlan20
    [DHCP Server-ip-pool-vlan20]gateway-list 10.1.1.254 
    [DHCP Server-ip-pool-vlan20]network 10.1.1.0 mask 24
    [DHCP Server-ip-pool-vlan20]excluded-ip-address 10.1.1.240 10.1.1.253
    [DHCP Server-ip-pool-vlan20]lease day 2
    [DHCP Server-ip-pool-vlan20]dns-list 114.114.114.114
    [DHCP Server-ip-pool-vlan20]quit
    [DHCP Server]interface vlanif 10
    [DHCP Server-Vlanif10]ip address 10.0.0.254 24
    [DHCP Server-Vlanif10]dhcp select global 
    [DHCP Server-Vlanif10]quit
    [DHCP Server]interface vlanif 20
    [DHCP Server-Vlanif20]ip address 10.1.1.254 24
    [DHCP Server-Vlanif20]dhcp select global 
    [DHCP Server-Vlanif20]quit
    [DHCP Server]interface g0/0/1
    [DHCP Server-GigabitEthernet0/0/1]port link-type trunk
    [DHCP Server-GigabitEthernet0/0/1]port trunk allow-pass vlan 10
    [DHCP Server-GigabitEthernet0/0/1]quit
    [DHCP Server]inter g0/0/2
    [DHCP Server-GigabitEthernet0/0/2]port link-type trunk
    [DHCP Server-GigabitEthernet0/0/2]port trunk allow-pass vlan 20
    

    sw1配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]vlan batch 10 20
    [Huawei]dhcp enable
    [Huawei]inter e0/0/1
    [Huawei-Ethernet0/0/1]port link-type trunk 
    [Huawei-Ethernet0/0/1]port trunk allow-pass vlan 10
    [Huawei-Ethernet0/0/1]quit
    [Huawei]inter e0/0/2
    [Huawei-Ethernet0/0/2]port link-type access 
    [Huawei-Ethernet0/0/2]port default vlan 10
    [Huawei-Ethernet0/0/2]quit
    

    sw2配置

    <Huawei>u t m
    <Huawei>system-view 
    [Huawei]dhcp enable
    [Huawei]sysname sw2
    [sw2]vlan 20
    [sw2-GigabitEthernet0/0/1]inter e0/0/1
    [sw2-Ethernet0/0/1]port link-type trunk 
    [sw2-Ethernet0/0/1]port trunk allow-pass vlan 20
    [sw2-Ethernet0/0/1]inter e0/0/2
    [sw2-Ethernet0/0/2]port link-type access 
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]quit
    [sw2]inter e0/0/2
    [sw2-Ethernet0/0/2]port default vlan 20
    [sw2-Ethernet0/0/2]quit
    

    查看客户端地址

    PC2的IP
    在这里插入图片描述
    PC3的IP

    在这里插入图片描述
    从PC2 (10.0.0.239)ping PC3(10.1.1.239)
    在这里插入图片描述
    查看地址池
    在这里插入图片描述

    展开全文
  • 华为交换机配置DHCP, NAT, 互联vlan Ⅰ: 网络拓扑图 Ⅱ:配置部分 PC1-2-3-4: 地址获取选择DHCP SW2: sysname Huawei undo info-center enable vlan batch 10 20 interface Eth-Trunk0 port link-type trunk ...

    eNSP 华为交换机配置DHCP, NAT, 互联vlan

    Ⅰ: 网络拓扑图
    在这里插入图片描述
    Ⅱ:配置部分
    PC1-2-3-4: 地址获取选择DHCP
    SW2:

    sysname Huawei
    undo info-center enable
    vlan batch 10 20
    #
    interface Eth-Trunk0
     port link-type trunk
     port trunk allow-pass vlan 10 20
     #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/1
     eth-trunk 0
    interface GigabitEthernet0/0/2
     eth-trunk 0
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 20
     #
    interface GigabitEthernet0/0/5
     eth-trunk 1
     #
    interface GigabitEthernet0/0/6
     eth-trunk 1
    

    SW3:

    sysname Huawei
    undo info-center enable
    vlan batch 10 20
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/3
     eth-trunk 2
    #
    interface GigabitEthernet0/0/4
     eth-trunk 2
    #
    interface GigabitEthernet0/0/5
     eth-trunk 1
    #
    interface GigabitEthernet0/0/6
     eth-trunk 1
    

    SW1:

    #
    sysname Huawei
    #
    undo info-center enable
    #
    vlan batch 10 20 195
    #
    dhcp enable
    #
    ip pool 1
     gateway-list 192.168.1.1
     network 192.168.1.0 mask 255.255.255.0
     excluded-ip-address 192.168.1.200 192.168.1.254
     dns-list 8.8.8.8
    #
    ip pool 2
     gateway-list 192.168.2.1
     network 192.168.2.0 mask 255.255.255.0
     excluded-ip-address 192.168.2.200 192.168.2.254
     dns-list 8.8.8.8
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     dhcp select global
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     dhcp select global
    #
    interface Vlanif195
     ip address 195.1.1.1 255.255.255.0
    #
    interface Eth-Trunk0
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface Eth-Trunk2
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/1
     eth-trunk 0
    #
    interface GigabitEthernet0/0/2
     eth-trunk 0
    #
    interface GigabitEthernet0/0/3
     eth-trunk 2
    #
    interface GigabitEthernet0/0/4
     eth-trunk 2
    #
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 195
    
    

    AR3:

    #
     undo info-center enable
    #
    acl number 2000  
     rule 5 permit source 192.168.1.0 0.0.0.255 
     rule 10 permit source 192.168.2.0 0.0.0.255 
    #
     nat address-group 1 60.1.1.2 60.1.1.10
    #
    interface GigabitEthernet0/0/0
     ip address 195.1.1.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 60.1.1.1 255.255.255.0 
     nat outbound 2000 address-group 1 
     / nat outbound 2000 , 表示从该端口出,共用端口IP 地址//
     / nat static global 192.168.1.0 inside 60.1.1.1 , 静态端口配置///
    #
    interface NULL0
    #
    ip route-static 192.168.1.0 255.255.255.0 195.1.1.1
    ip route-static 192.168.2.0 255.255.255.0 195.1.1.1
    #
    

    R3:

    #
    sysname Huawei
    #
    undo info-center enable
    #
    interface Ethernet0/0/0
     ip address 60.1.1.100 255.255.255.0
    #
    ip route-static 0.0.0.0 0.0.0.0 60.1.1.1
    #
    

    Ⅲ 验证部分:
    PC1:

    ping 60.1.1.100
    Ping 60.1.1.100: 32 data bytes, Press Ctrl_C to break
    From 60.1.1.100: bytes=32 seq=1 ttl=253 time=203 ms
    From 60.1.1.100: bytes=32 seq=2 ttl=253 time=62 ms
    From 60.1.1.100: bytes=32 seq=3 ttl=253 time=94 ms
    From 60.1.1.100: bytes=32 seq=4 ttl=253 time=94 ms
    From 60.1.1.100: bytes=32 seq=5 ttl=253 time=93 ms
    --- 60.1.1.100 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/109/203 ms
    

    R3:

    [Huawei]ping 192.168.2.199
      PING 192.168.2.199: 56  data bytes, press CTRL_C to break
        Reply from 192.168.2.199: bytes=56 Sequence=1 ttl=126 time=130 ms
        Reply from 192.168.2.199: bytes=56 Sequence=2 ttl=126 time=90 ms
        Reply from 192.168.2.199: bytes=56 Sequence=3 ttl=126 time=110 ms
        Reply from 192.168.2.199: bytes=56 Sequence=4 ttl=126 time=90 ms
        Reply from 192.168.2.199: bytes=56 Sequence=5 ttl=126 time=90 ms
    展开全文
  • 华为交换机配置DHCP服务器

    万次阅读 2018-04-28 19:42:01
    1.开启交换机DHCP服务。[huawei]dhcp enable2.配置地址池。[huawei]ip pool 8 [huawei-ip-pool-8]network 192.168.8.0 mask 255.255.255.0 [huawei-ip-pool-8]dns-list 223.5.5.5 223.6.6.6 [huawei-ip-pool-8]...
    1.开启交换机的DHCP服务。
    [huawei]dhcp enable
    2.配置地址池。
    [huawei]ip pool 8
    [huawei-ip-pool-8]network 192.168.8.0 mask 255.255.255.0
    [huawei-ip-pool-8]dns-list 223.5.5.5 223.6.6.6
    [huawei-ip-pool-8]gateway-list 192.168.8.1
    3.进入vlan接口开启该vlan dhcp功能
    [huawei]interface vlanif 10
    [huawei]dhcp select global
    4.查看配置信息。
    [huawei]display ip pool name 8


    展开全文
  • DHCP Relay即DHCP中继,它是为解决服务器和...华为5700交换机dhcp配置方法请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上应用场景:用户侧网段与DHCP服务器处于不同网段SwitchA为DHCP中继的配置思路在Sw...

    DHCP Relay即DHCP中继,它是为解决服务器和客户端不在同一个网段而提出来的,它提供了对DHCP广播报文的透明传输功能,下面是学习啦小编给大家整理的一些有关华为5700交换机dhcp配置方法,希望对大家有帮助!

    华为5700交换机dhcp配置方法

    请自行准备好华为交换机和电脑

    并且让你的电脑和交换机连接上

    应用场景:

    用户侧网段与DHCP服务器处于不同网段

    SwitchA为DHCP中继的配置思路

    在SwitchA上创建DHCP服务器组并为服务器组添加DHCP服务器SwitchB,使SwitchB成为公司分配IP地址给其它主机的服务器。

    在接口VLANIF100下使能DHCP中继功能,使之成为DHCP中继服务器。

    为接口VLANIF100绑定创建的DHCP服务器组,指定中继指向的公司的主服务器。

    SwitchB为DHCP服务器的配置思路如下:

    配置DHCP服务器到中继的接口Eth 0/0/1的路由,使公司服务器到中继的路由可达。

    使能公司服务器的DHCP功能,配置DHCP服务器的接口Eth 0/0/1下的各楼宇内的主机从服务器全局地址池中获取IP地址。

    在公司DHCP服务器上创建全局地址池,为公司内的主机分配IP地址。

    创建DHCP服务器组并为服务器组添加DHCP服务器。

    # 创建DHCP服务器组。

    system-view

    [Quidway] dhcp server group dhcpgroup1

    # 为DHCP服务器组添加DHCP服务器。

    [Quidway-dhcp-server-group-dhcpgroup1] dhcp-server 100.10.10.1

    [Quidway-dhcp-server-group-dhcpgroup1] quit

    在VLANIF接口下使能DHCP中继功能。

    # 创建VLAN并将Eth 0/0/1接口加入到VLAN中。

    [Quidway] vlan 100

    [Quidway-Vlan100] quit

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port link-type trunk

    [Quidway-Ethernet0/0/1] port trunk allow-pass vlan 100

    [Quidway-Ethernet0/0/1] quit

    # 使能全局DHCP功能,并使能VLANIF接口下DHCP中继功能。

    [Quidway] dhcp enable

    [Quidway] interface vlanif 100

    [Quidway-Vlanif100] dhcp select relay

    [Quidway-Vlanif100] quit

    为VLANIF接口绑定指定的DHCP服务器组。

    # 为VLANIF接口配置IP地址。

    [Quidway] interface vlanif 100

    [Quidway-Vlanif100] ip address 20.20.20.1 24

    # 为VLANIF接口指定DHCP服务器。

    [Quidway-Vlanif100] dhcp relay server-select dhcpgroup1

    [Quidway-Vlanif100] quit

    配置DHCP服务器。

    # 创建VLAN并将Eth 0/0/1接口加入到VLAN中。

    [Quidway] vlan 20

    [Quidway-Vlan20] quit

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port link-type trunk

    [Quidway-Ethernet0/0/1] port trunk allow-pass vlan 20

    [Quidway-Ethernet0/0/1] quit

    # 启动DHCP服务,配置接口VLANIF20下的客户端从全局地址池中获取IP地址。

    system-view

    [Quidway] dhcp enable

    [Quidway] interface vlanif 20

    [Quidway-Vlanif20] ip address 100.10.10.1 24

    [Quidway-Vlanif20] dhcp select global

    [Quidway-Vlanif20] quit

    在DHCP服务器上配置一个20.20.20.0/24网段的IP地址池,并且添加到SwitchA的静态路由,保证DHCP服务器到20.20.20.0/24网段路由可达。

    [Quidway] ip pool 1

    [Quidway-ip-pool-1] network 20.20.20.0 mask 24

    [Quidway-ip-pool-1] quit

    # 将IP地址池网段添加到DHCP中继的静态路由,保证DHCP服务器到20.20.20.0/24网段路由可达。(略)

    验证配置结果。

    # 在SwitchA上使用display dhcp relay命令用来查看接口的DHCP中继配置情况。

    [Quidway] display dhcp relay interface vlanif100

    DHCP relay agent running information of interface Vlanif100 :

    Server group name : dhcpgroup1

    Gateway address in use : 100.10.10.1

    # 在SwitchB上使用display ip pool命令用来查看IP地址池配置情况。

    [Quidway] display ip pool

    -----------------------------------------------------------------------

    Pool-Name : 1

    Pool-No : 0

    Position : Local Status : Unlocked

    Gateway-0 : -

    Mask : 255.255.255.0

    Vpn instance : --

    IP address Statistic

    Total :250

    Used :0 Idle :248

    Expired :0 Conflict :0 Disable :2

    查看配置文件

    SwitchA的配置文件

    #

    sysname Quidway

    #

    vlan 100

    #

    dhcp enable

    #

    dhcp server group dhcpgroup1

    dhcp-server 100.10.10.1

    #

    interface Vlanif100

    ip address 20.20.20.1 255.255.255.0

    dhcp select relay

    dhcp relay server-select dhcpgroup1

    #

    interface Ethernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 100

    #

    return

    SwitchB的配置文件

    #

    sysname Quidway

    #

    vlan batch 20

    #

    dhcp enable

    #

    ip pool 1

    network 20.20.20.0 mask 255.255.255.0

    #

    interface Vlanif20

    ip address 100.10.10.1 255.255.255.0

    dhcp select global

    #

    interface Ethernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 20

    #

    return

    华为设置连接两个无线路由器的方法

    1、网口2的位置添加一个家用交换机,有4个口,你刚好可以使用3个口,相当于自来水的4通(一个口空闲)

    这个必须要求2个路由器都有不同的上网帐号 密码,都可以自己拨号,基本上不现实//大学宿舍基本上是这样做的

    2、路由器2接路由器1

    A 路由器1负责拨号上网,路由器2要么接路由器lan口到路由器2wav口(设置动态ip,lan口ip调整)

    假设路由器1lanip 未192.168.a.1 路由器2必须设置lan ip未192.168.b.1

    B路由器1负责拨号,开启dhcp,填写你网络服务商的dns,路由器1lan口出线到路由器2lan口,,路由器2lan口ip设置再前方路由器ip段里面,关闭路由器2dhcp,相当于前方路由器的交换机,2个路由器均可设置无线功能

    假设路由器1lanip 未192.168.a.1 路由器2必须设置lan ip未192.168.a.c(c可以在2~253之间,推荐150)

    看了“华为5700交换机dhcp怎么配置”的人还看了

    展开全文
  • 华为交换机基础DHCP配置

    万次阅读 2018-05-06 13:48:57
    配置两个地址池:192.168.1.0/24和192.168.2.0/24配置两个VLAN:10和20将...步骤:[DHCP]DHCP enable打开DHCP功能 [DHCP]vlan batch 10 20[DHCP]ip pool vlan10[DHCP]gateway-list 192.168.1.254[DHCP]network 192...
  • 华为S2700/S3700/S5700/S9300二三层交换机配置DHCP中继DHCP中继DHCP Relay即DHCP中继,它是为解决服务器和客户端不在同一个网段而提出来的,它提供了对DHCP广播报文的透明传输功能,能够把DHCP客户端的广播报文透明...
  • 今天给大家带来日常工作中经常用到的一个技术,那就是DHCP技术,细节类型请转战其他地方即可,理论一大把,不具体细说了...第一种环境DHCP方式:本地DHCP配置方式:接口下启用业务VLAN ID:2网段:10.0.0.0/24网关:...
  • 华为三层交换机配置DHCP配置

    万次阅读 2015-01-27 10:42:05
    华为三层交换机配置DHCP配置 1,交换机作DHCP Server 『配置环境参数』 1.PC1、PC2的网卡均采用动态获取IP地址的方式 2.PC1连接到交换机的以太网端口0/1,属于VLAN10;PC2连接到交换机的以太网端口0/2,属于VLAN...
  • 华为交换机DHCP配置

    2021-04-08 15:57:28
    华为交换机DHCP配置 设备型号:华为交换机–S3700 时间:2021.3.19 环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动...
  • 华为交换机配置DHCP 一、实验环境 二、给交换机起个名称 [Huawei]sysname switch [switch] 三、全局开启dhcp [switch]dhcp ena [switch]dhcp enable Info: The operation may take a few seconds. Please wait...
  • 华为核心交换机:S5720S-36C-EI-AC 管理IP:172.30.5.1华为桌面交换机:S5700S...如下图所示:核心交换机配置:(华为交换机dhcp server配置:DHCP配置)接入层交换机配置:[SW_ACC_5.10]dhcp enable[SW_ACC_5.10]dhcp ...
  • 当然这只是实验中这么来做,现实中考虑...DHCP服务配置 LSW1三层交换机 undo t m sys vlan 10 vlan 20 int g0/0/1 port link-type ac port default vlan 10 int g0/0/2 port link-type ac port default vlan 20 q dhcp
  • system-view[Quidway] dhcp server group dhcpgroup1# 为DHCP服务器组添加DHCP服务器。[Quidway-dhcp-server-group-dhcpgroup1] dhcp-server 100.10.10.1[Quidway-dhcp-server-group-dhcpgroup1] quit在VLANIF接口下...
  • 关于华为交换机常用的配置方法,今天汇总一下,大家可以参考。1、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,比如vlan 2就是编号为2的vlan,只是一个...
  • f99b4cbdf76d478393de658f5c53f6ca-300x220.jpg (8.78 KB, 下载次数: 22)华为S7706交换机DHCP Server 配置不成功问题2016-6-10 14:22 上传问题描述如下图所示:S7706交换机作为DHCP服务器,S5700作为接入交换机连接...
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有其他问题,请私信给我在上一篇我们讲到了华为交换机的vlan划分和IP地址的分配,有一个问题就是当你不知道这个口属于哪个vlan,也没有console线,怎么办?...
  • 下面看看在交换机设备上是如何实现IPv6的DHCP的。第一步:先开启设备的DHCP功能开启DHCP功能第二步:配置连接电脑的端口,将电脑网卡放入到vlan 3501电脑网卡使用vlan 3501电脑网卡用3501是在虚拟机上...
  • 配置命令:<Huawei>sysEnter system view, return user view withCtrl+Z.[Huawei]sysna[Huawei]sysname dhcp[dhcp]vlan 11[dhcp-vlan11]vlan 22[dhcp-vlan22]qu[dhcp]interface vlan11[dhcp-Vl...

空空如也

空空如也

1 2 3 4 5 ... 19
收藏数 380
精华内容 152
关键字:

华为交换机配置dhcp