精华内容
下载资源
问答
  • 1.思科交换机 查看是否支持ssh show ip ssh 更改ssh密码 enable configure terminal username 用户名 password 密码 更改console密码 enable configure terminal enable secret 密码 login(老版本不用设置cisco 2950...

    1.思科交换机
    查看是否支持ssh show ip ssh
    更改ssh密码
    enable
    configure terminal
    username 用户名 password 密码

    更改console密码
    enable
    configure terminal
    enable secret 密码
    login(老版本不用设置cisco 2950)
    write(在中括号模式下)

    设置consloe密码
    line console 0
    password 密码

    2.华为交换机
    更改用户名密码
    aaa
    local-user “用户名” password irreversible-cipher(不可逆密码) 密码

    console密码更改
    user-interface console 0
    authentication-mode password
    set authentication password cipher 密码
    return(commit)
    save(在尖括号模式下)

    提交后,cisco千万得记得write(在中括号模式下),华为千万记得save(在尖括号模式下)

    展开全文
  • 思科3560交换机console线灌IOS

    千次阅读 2014-08-24 13:19:24
    0用console线将交换机与电脑相连接 1拔掉交换机的电源 2按着交换机的mode键,一般交换机就一个键可以按,3560的mode键在那一列指示灯的最下面。插上电源。 3在CRT上可以看到以下的画面: 4输入...

    如果不小心把Flash中的bin文件删掉那就中了大奖了,如果不小心把Flash的bin文件删掉之后还重启了一下交换机那就是中了头等奖。因此说一下怎么使用console线灌IOS文件.

    首先第一步当然是要保证你手头上有IOS文件(要不然拿什么东西灌进去?)

    第一步本地pc应该有相应的IOS文件,第二步本地pc应该有一个超级终端(我用的是secrt)支持xmode传输

    0用console线将交换机与电脑相连接

    1拔掉交换机的电源

    2按着交换机的mode键,一般交换机就一个键可以按,3560的mode键在那一列指示灯的最下面。插上电源。

    3在CRT上可以看到以下的画面:


    4输入flash_init(这种模式下不支持tab键补全,自己慢慢敲吧)

    然后进入以下画面:

    结束之后为了快速的传输默认情况下console口的速率是9600的,我们可以

    swich:set BAUD 115200 //设置速率为115200

    设置成功之后此时CRT会出现乱码,我们先到本机“计算机”--》“管理”--》对应的端口。如下图更改速率为115200


    然后关闭CRT,新建一个CRT会话将端口速率更改为115200.此时就不会乱码了。


    5输入switch:copy xmodem: flash:c3560-advipservicesk9-mz.122-25.SEE2.bin

    画面出现“C”字符的时候表示可以传输了,如下图:

    6赶紧设置你的CRT,设置传输的文件目录,然后就可以传输了

    7设置从这个ios启动


    8传输完毕之后记得更改交换机的传输速率为默认的9600~~~

    Switch(config)#line console 0 //这两步设置互换机的console口传输速度是9600

    Switch(config-line)#speed 9600



    大家可以参考:http://www.2cto.com/net/201107/97504.html


    展开全文
  • 通过配置线连接交换机,又发现又设置了enable密码,于是笔者只能想到恢复初始配置,遂将实现过程整理如下: 1、按住前面板的mode键不放,插上电源,等3-5秒后松开mode键,我们将会看到如下提示: The system has ...

    通过配置线连接交换机,又发现又设置了enable密码,于是笔者只能想到恢复初始配置,遂将实现过程整理如下:
    1、按住前面板的mode键不放,插上电源,等3-5秒后松开mode键,我们将会看到如下提示:

    The system has been interrupted prior to initializing the
    flash filesystem. The following commands will initialize
    the flash filesystem, and finish loading the operating
    system software:

    flash_init
    load_helper
    boot
    

    switch:
    2、到这里我们输入flash_init命令,开始初始化flash,完了后,我们再输入ren flash:config.text flash:config.old

     命令对已存丰的config.text重新命名成config.old,不删除、方便以后还可以恢复,最后我们在使用boot命令进行启动。
    

    switch: flash_init
    Initializing Flash…
    flashfs[0]: 18 files, 2 directories
    flashfs[0]: 0 orphaned files, 0 orphaned directories
    flashfs[0]: Total bytes: 7741440
    flashfs[0]: Bytes used: 3966464
    flashfs[0]: Bytes available: 3774976
    flashfs[0]: flashfs fsck took 6 seconds.
    …done initializing flash.
    Boot Sector Filesystem (bs:) installed, fsid: 3
    Parameter Block Filesystem (pb:) installed, fsid: 4
    switch: dir

    List of filesystems currently registered:

               flash[0]: (read-write)
              xmodem[1]: (read-only)
                null[2]: (read-write)
                  bs[3]: (read-only)
    

    switch:
    在这里插入图片描述
    3、这样我们等启动好了,再次使用enable命令进入特权模式就没有密码了,还可以使用dir命令查看到我们重命名的文件,如下所示:

    Switch>en
    Switch#dir
    Directory of flash:/

    2  -rwx     2664051   Mar 01 1993 00:03:22  c2950-i6q4l2-mz.121-11.EA1.bin
    4  -rwx        1216   Apr 15 1994 21:28:58  vlan.dat
    5  -rwx        4413   Jan 31 1994 21:45:53  config.old
    6  -rwx           5   Jan 31 1994 21:45:53  private-config.text
    7  drwx         704   Mar 01 1993 00:04:00  html
    

    19 -rwx 109 Mar 01 1993 00:04:01 info
    20 -rwx 109 Mar 01 1993 00:04:01 info.ver
    21 -rwx 269 Jan 01 1970 00:01:46 env_vars

    7741440 bytes total (3774976 bytes free)
    Switch#

    如果上述的操作进行要输入dir的时候到敲任何键都不动了的话,就要修改波特率为交换机本身的波特率115200。
    在这里插入图片描述

    switch: flash_init
    Initializing Flash…
    flashfs[0]: 18 files, 2 directories
    flashfs[0]: 0 orphaned files, 0 orphaned directories
    flashfs[0]: Total bytes: 7741440
    flashfs[0]: Bytes used: 3966464
    flashfs[0]: Bytes available: 3774976
    flashfs[0]: flashfs fsck took 6 seconds.
    …done initializing flash.
    Boot Sector Filesystem (bs:) installed, fsid: 3
    Parameter Block Filesystem (pb:) installed, fsid: 4
    修改完波特率后,就可以正常输入dir了
    switch: dir

    那么如何修改交换机的波特率为默认波特率呢?

    cisco 交换机恢复IOS与更改波特率
    https://blog.csdn.net/weixin_33724659/article/details/92696183
    第一步:执行flash_init

    switch: flash_init

    第二步:修改波特率
    为了提高文件传输速率,需要修改console口的波特率,先使用如下指令修改设备的波特率
    switch: set BAUD 115200

    第三步:是用xmodem传输IOS文件
    在设备上输入如下指令:
    switch: copy xmodem: flash:c2950.bin
    flash:后面的“c3560-ipservicesk9-mz.122-53.SE.bin”(上面的c2950.bin)为IOS文件名,需要在本地PC上事先准备好。
    然后点击超级终端“发送”菜单,选择发送文件,使用xmodem方式。
    文件开始通过console发送到交换机上,传输时间是根据文件大小决定的,10M的文件大约需要50分钟。

    第四步:设置启动文件
    当IOS文件正确传输到交换机上面,执行以下指令设置启动文件。
    switch: set BOOT flash:c2950.bin

    第五步:重置波特率

    交换机上执行如下指令重置波特率:

    switch: unset BAUD

    PC上将超级终端的波特率改回9600,生效后,
    光标在switch: unset BAUD 位置不动了,那么还是波特率没改回来,修改回9600就可以继续往下走了
    在这里插入图片描述
    第六步:启动IOS

    在交换机上执行以下指令,启动IOS。
    switch: boot

    展开全文
  • 思科交换机常用指令

    2020-11-23 12:19:39
    title: 思科交换机常用指令(持续更新) tags: 教程 author: caijinbo date: 2019-11-19 思科交换机常用指令 vlan设置 console>enable //进入特权模式 console#configure //进入配置视图 console(config)#vlan ...

    title: 思科交换机常用指令(持续更新)
    tags: 教程
    author: caijinbo
    date: 2019-11-19

    思科交换机常用指令

    vlan设置

    console>enable    //进入特权模式
    console#configure      //进入配置视图
    console(config)#vlan database     //进入vlan配置
    console(config-vlan)#vlan 2   //创建vlan2
    console(config-vlan)#no vlan 2      //删除vlan 2
    console(config-vlan)#exit    //退回到特权模式下
    console(config)#interface vlan 2      //进入vlan2的配置视图
    console(config-if-vlan2)#name xxx    //为vlan2修改名字
    

    端口配置

     console(config)#interface ethernet 1/g1    //进入网口1,/1/g1指的是第一个插槽上的第一个千兆网口
    console(config-if-1/g1)#     //接口视图模式
    console(config-if-1/g1)# speed 10/100/1000      //定义端口的带宽,只能从这三种模式中做选择。
    console(config-if-1/g1)# duplex full/half     //定义双工模式
    console(config-if-1/g1)# negotiation    //启用自动协商速度和双工参数
    console(config-if-1/g1)# no negotiation  //禁用自动协商速度和双工参数
    console(config-if-1/g1)# switchport mode access/trunk/general       //定义端口类型,总共有三种类型
    console(config-if-1/g1)# switchport access vlan 2     //将端口以access模式加入到vlan 2 中
    console(config-if-1/g1)# shutdown     //关闭当前端口
    console(config-if-1/g1)# no shutdown       //打开当前端口
    console(config)#interface   ethernet 1/g24        //进入汇聚千兆口24,共有四个千兆combo口21-24
    console(config-if-1/g24)#      //接口视图模式
    console(config-if-1/g24)#duplex  auto/full/half      //设置端口工作模式为 自适应/全双通/半双通
    console(config-if-1/g24)#switchport mode trunk      //设置当前端口模式为汇聚口
    console(config-if-1/g24)#switchport mode access    //设置当前端口模式为接入模式
    console(config-if-1/g24)#switchport trunk allowed vlan add/remove 1,2     //将当前汇聚端口加入或移除从vlan 1 ,2通过,vlan修剪,默认为all,全部允许
    console(config-if-1/g24)#switchport access vlan 2    //将当前端口以access模式加入到vlan2 中
    
    若21-24号口用作光口的话,配置接口就对应1/xg1-1/xg4代表使用光纤做10G上联口用:
    console(config)#interface ethernet 1/xg1       //进入汇聚万兆口1,共有4个千兆combo口21-24对应四个1/xg1-1/xg4万兆光口
    console(config-if-1/xg1)#
    console(config-if-1/xg1)#duplex auto/full/half      //设置端口工作模式为  自适应/全双通/半双通
    console(config-if-1/xg1)#switchport mode trunk   //设置当前端口模式为汇聚口
    console(config-if-1/xg1)#switchport mode access  //设置当前端口模式为接入模式
    console(config-if-1/xg1)#switchport trunk allowed vlan add/remove  1,2    //将当前汇聚端口加入或移除从vlan1,2通过,vlan修剪,默认为all,全部允许
    console(config-if-1/xg1)#switchport access vlan 2  //将当前端口以access模式加入vlan2中
    

    将单个端口加入vlan

    console(config)#interface ethernet 1/g1
    console(config-if-1/g1)#switchport mode access 
    console(config-if-1/g1)#switchport access vlan 2
    

    将多个端口加入到vlan中

    console(config)#interface range ethernet 1/g1-1/g12     //进入1-12这个接口组里配置
    console(config-if)#switchport mode access
    console(config-if)#switchport access vlan 2
    
    console#show vlan    //用于查看配置后结果
    

    设置VTP
    cisco专有的vlan终级协议也成为局域网干道协议,作用是十几台交换机在企业网中,配置vlan工作量大,可以使用VTP协议,把一台交换机配置成VTP server,其余交换机配置成VTP client,这样他们可以自动学习到server上的vlan信息

    交换机配置IP地址

    console(config)#interface vlan 1       //进入vlan1
    console(config-if-vlan1)#ip address 119.167.223.221 255.255.255.128  //设置交换机的管理ip地址
    console(config)#ip default-gateway 119.167.223.254    //设置交换机的默认网关
    console(config)#end     //退出当前模式
    

    交换机保存设置命令

    console#copy running-config startup-config    //将当前正在使用中的配置保存到交换机开机需要加载的配置文件里去。
    console#copy running-config backup-config      //将当前的配置保存到备份配置文件里
    

    交换机显示命令
    特权模式下:

    console#show running-config    //显示当前正在使用的配置信息
    console#show startup-config    //显示交换机开机时自动加载的配置文件
    console#show vlan    //显示vlan的配置信息
    console#show interfaces configuration ethernet 1/g1       //显示二层端口状态,可以用来决定此口是否为二层或三层口
    console#show ip interface vlan 100    //查看交换机vlan100的IP配置信息
    console#show version    //查看交换机固件版本信息
    

    基于端口的mac地址绑定

    console#config  //进入配置视图模式
    console(config)#interface ethernet 1/g1     //进入具体端口视图模式下
    console(config-if-1/g1)#switch port-secruity     //配置端口安全模式
    console(config-if-1/g1)#switchport port-seruity mac-address MAC(主机的mac地址)     //配置该端口要绑定的主机mac地址
    console(config-if-1/g1)# no switchport port-seruity mac-address MAC(主机的mac地址)  //删除绑定主机的mac地址
    

    配置交换机的snmp功能

    console(config)#snmp-server community xxx ro     //xxx为自定义的共同体名称,并且团体的权限为只读
    console(config)#snmp-server host x.x.x.x(ip地址)xxx(团体名)    //设置管理机x.x.x.x同时允许该管理机以团体名xxx访问。
    console(config)#snmp-server enable traps     //启用snmp服务
    

    交换机禁ping配置

    console(config)#access-list 110 deny icmp any any      //配置访问控制列表(Access Control List,ACL)110指的是ICMP对应ping。
    console(config)#access-list 110 permit ip any any   //运行所有的ip协议的应用
    console(config)#int vlan 1
    console(config-if-vlan1)#ip access-group 110 in 
    console(config)#int vlan 2
    console(config-if-vlan2)#ip access-group 110 in
    console(config)#int vlan 3
    console(config-if-vlan3)#ip access-group 110 in
    console(config)#interface ethernet 1/g1     //端口禁ping
    console(config-if-1/g1)#ip access-group 110 in
    

    恢复交换机出厂设置

    console#clear config    //恢复交换机出厂设置
    console#reload     //重新启动交换机
    
      交换机工作于OSI参考模型的第二层,即数据链路层。交换机内部的cpu会在每个端口成功连接时,通过将mac地址和端口对应,形成一张mac表。在今后的通讯中,发往该mac地址的数据包将仅送往其对应的端口,而不是所有的端口。因此,交换机可用于划分链路层广播,即冲突域,但它不能划分网络层广播,即广播域。
     交换机拥有一条很高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上,控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的mac(网卡的硬件地址)的NIC(网卡)挂接在哪个端口上,通过内部交换矩阵迅速将数据包传送到目的端口,目的mac若不存在,广播到所有的端口,接收端口回应后,交换机会“学习”新的mac地址,并把它添加到内部mac地址表中。使用交换机也可以把网络“分段”,通过对照IP地址表,交换机只允许必要的网络流量通过交换机。通过交换机的过滤和转发,可以有效的减少冲突域,但它不能划分网络层广播,即广播域。
    
    展开全文
  • 思科交换机领命

    2019-06-28 14:09:51
    CISCO交换机基本配置:Console端口连接 用户模式hostname# ; 特权模式hostname(config)# ; 全局配置模式hostname(config-if)# ; 交换机口令设置: switch>enable ;进入特权模式 switch#config termin...
  • 因为目前很多笔记本电脑没有配置串口,所以目前console线都同时接了一个串口转USB口的线,然后通过USB连接笔记本电脑的USB口。 我的电脑也是这样。 寻找端口号 右键计算机-->管理-->设备管理,在...
  • 熟悉思科交换机配置

    2020-08-09 20:41:20
    一、熟悉思科交换机配置 二、配置console口用户名mtlk和用户名,并要求口令加密 三、配置ssh远程登录管理方式,创建用户名mtlk1和口令,口令加密存储 四、通过show查看配置是否存在 五、验证配置是否生效 六、把...
  • 思科交换机配置

    2011-12-04 20:39:00
    Cisco交换机配置命令 首先通过配置线连接电脑与交换机的console口,在电脑上按以下步骤打开超级终端连接交换机: 开始--程序--附件--通讯--超级终端
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...
  • 思科交换机配置命令

    2012-07-10 12:12:41
    思科交换机配置命令 交换机基本状态: switch: ;ROM状态, 路由器是rommon> hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置...
  • 对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;其二,通过telnet方式远程访问、配置交换机,...
  • 思科交换机IOS升级

    千次阅读 2016-03-27 13:33:26
    思科交换机IOS升级 一、先将自己的电脑设置到同一网段 二、电脑使用tftp服务器(如3CD )将要升级的IOS导入改服务器下。设置tftp,将路径选择到有IOS的路径下,路径全用英文 三、交换机和自己电脑用网线相连。 ...
  • 思科交换机密码配置和清除思科交换机密码配置一.设置console密码>enable#configure trminal(confing)#line console 0←console口①(config-line)#password (cisco)←密码(config-line)#login ← 一定不能少的....
  • 一.设置console密码 ...(confing)#line console 0←console口 ①(config-line)#password (cisco)←密码 (config-line)#login ← 一定不能少的. console密码设置完成 exit 二:设置全局密码 ena
  • 思科交换机路由器 连接配置步骤

    千次阅读 2017-11-21 12:08:00
    我讲CCNA大多使用模拟软件Packet Tracer和GNS3。大家学会了如何在模拟软件下配置思科路由器和交换机,但是在工作中如何使用计算机连接路由器和交换机进行配置,依然是没有概念,当我们...思科交换机连接配置步骤 硬...
  • 思科交换机备份与还原思路: 一台电脑通过console端口连接到cisco 2960交换机,配置一个VLAN 10并分配IP地址和网关,电脑设置固定IP地址连接到cisco 2960交换机,确认交换机ping通这台电脑的IP...
  • ⒉首先得拔掉电源,因为思科交换机上没有开关 所以我们只能拔掉电源 接下来我们要做的就是按住MODE按钮 接着插上电源 等端口指示灯灭掉松开⒊初始化flash。>flash_init⒋更名含有password的配置文件。>rename ...
  • 思科交换机密码配置

    2010-06-09 17:03:23
    思科交换机密码设置 (引用地址:http://hi.baidu.com/%B5%E7%C4%D4%B4%EF%D7%D0/blog/item/5ba484c7c961a5109d163d83.html) 思科交换机密码配置一.设置console密码>enable#configure trminal(confing)#line...
  • 思科交换机的配置与管理-基础命令 交换机的管理方式基本分为两种:带内管理和带外管理 A 通过交换机的Console端口管理交换机属于带外管理:这种管理方式不占用交换机的网络端口,第一次配置交换机必须利用Console...
  • 思科交换机密码设置

    2012-06-23 23:33:49
    思科交换机密码配置 一.设置console密码 >enable #configure trminal (confing)#line console 0←console口 ①(config-line)#password (cisco)←密码 (config-line)#login ← 一定不能少的. console密码...
  • 交换机2960S突然不启动了,风扇也不转,判断电源坏,taobao了个,回来换上直接启动,连上console却发现总提示错误: %Error opening tftp://255.255.255.255/xxxxxx.cfg (Timed out) %Error opening tftp://255....
  • 思科交换机安全

    2018-10-28 13:17:00
    CCNA> CCNA>...CCNA(config)#line console 0 CCNA(config-line)#password ccna CCNA(config-line)#login !使password生效 CCNA(config-line)#end CCNA#logout !注销当前用户...

空空如也

空空如也

1 2 3 4 5 ... 9
收藏数 164
精华内容 65
关键字:

思科交换机console