精华内容
下载资源
问答
  • 思科交换机 Trunk

    2013-07-10 11:05:30
    中继接口封装的类型Cisco支持多种Trunk方式(即对VLAN帧标识):ISL――Cisco专有封装协议,也是默认的。前面加26字节,后面加4字节FCS。 帧长度1518/1548。可支持的VLAN数为1-1046。IEEE 802.1Q――IEEE标准方法,在...

    中继接口:中继链接(Trunk Link)指的是能够转发多个不同VLAN的通信的端口。

    中继接口封装的类型


    Cisco支持多种Trunk方式(即对VLAN帧标识):

    1. ISL――Cisco专有封装协议,也是默认的。前面加26字节,后面加4字节FCS。 帧长度1518/1548。可支持的VLAN数为1-1046。

    2. IEEE 802.1Q――IEEE标准方法,在帧头写入VLAN信息,后面只增加4字节FCS。帧 长度为1518/1522。有12位的vlan标识,它可以支持到4096个VLAN。802.1Q-trunk为转发未被标记的frame而定义了 native  VLAN(本地VLAN)。交换机能够从未被标记的trunk上的nativeVLAN转发2层frame,接受方将把所有的未标记frame转发到 native VLAN中  。VLAN1是默认的本地VLAN,也可以把其他的VLAN更改为本地VLAN。如果是ISL,则没被封装的frame将会丢弃,包括 nativeVLAN,所有的数据将被封装

    3. 802.10――FDDI上传输VLAN信息的Cisco专有协议,把VLAN信息写入SAID安全关联标识符部分

    4. LANE――基于ATM上传输VLAN信息的一种IEEE标准方法。

    配置中继接口模式

    1.交叉线连接两台交换机
    2.进入接口
    sw2(config)#interface f0/24
    3.配置接口模式:

    • switchport mode access:强制接口成为access接口,并且可以与对方主动进行协商,诱使对方成为access模式。

    • switchport mode dynamic auto:有邻居交换机主动与自己协商时才会变成Trunk接口,所以它是一种被动模式,当邻居接口为Trunk/desirable之一时,才会成为Trunk。如果不能形成trunk模式,则工作在access模式。

    • switchport mode dynamic desirable:主动与邻居协商是不是成为Trunk接口,如果邻居接口模式为Trunk/desirable/auto之一,则接口将变成trunk接口工作。如果不能形成trunk模式,则工作在access模式。这种模式是现在交换机的默认模式。

    • switchport mode trunk:强制接口成为Trunk接口,并且主动诱使对方成为Trunk模式,所以当邻居交换机接口为trunk/desirable/auto时会成为Trunk接口。

    • switchport nonegotiate:严格的说,这不算是种接口模式,它的作用只是阻止交换机接口发出DTP数据包,它必须与switchport mode trunk或者switchport mode access一起使用。必须手工去配置相邻接口的模式。

    • switchport mode dot1q-tunnel:设置接口为Q-in-Q隧道 。

    封装配置

    1.进入中继接口配置模式
    interface f0/24
    2.设置中继接口的封装类型

    • switchport trunk encapsulation isl:中继接口的类型为cisco专有的isl(3550)

    • switchport trunk encapsulation dot1q:中继接口的类型为 IEEE 802.1Q (2950)

    • switchport trunk encapsulation negotiate:根据相邻接口的类型来协商封装类型

    允许中继访问的VLAN

    在默认情况下,交换机的中继接口发送和接收来自所有VLAN(1-4094)数据流量。我们可以使用命令将一些VLAN从允许访问的VLAN列表中删除,使得这些VLAN在中继链路上不装载。
    配置步骤:
    1. 进入接口模式 interface f0/24
    2. 将接口配置为中继模式(如果已经是中继接口就不需要)
    switchport mode trunk
    3. 配置允许VLAN列表
    switchport trunk allowed vlan {add | all | except | remove} vlan-list

    • add:将VLAN添加到允许中继运载的VLAN列表

    • all:允许中继链路晕在所有的VLAN,这是一个默认值

    • except:除了VLAN-list指定的VLAN外,其他的VLAN都允许

    • remove:将vlan-list指定的VLAN从允许列表中移除

    • vlan-list:可以使用单个(1-4094)或者一个范围(不能出现空格)

    4. 查看配置结果
       show running interface f0/24    //查看中继接口配置
       show interface f0/24 switchport //查看中继接口的状态
    如:
        interface f0/24
    switchport trunk allowed vlan remove 3,5,6-10
        !
    show interface f0/24 switchport
    Name: Fa0/24
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1,2,4,11-4094
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Appliance trust: none


    考试题目:
               YY版本:SW1和SW2上做trunk,封装类型为isl,使所有的odd的vlan承载在fa0/23上,而even的vlan承载在fa0/24上,并且只承载题目中存在的vlan
               配置:
               SW1和SW2
               Interface f0/23
               Switchport mode trunk
               Switchport trunk encapsulation isl
               Switchport trunk allowed vlan 11,13,15,17
               Interface f0/24
                   Switchport trunk encapsulation isl
                   Switchport mode trunk
                   Switchport trunk allowed vlan 12,14,16
               验证:
               show interface trunk

    设置中继修剪列表

    Prunning-eligible合适修剪列表只能应用在中继链路上,VTP的修剪功能必须打开。
    配置过程:
    1.打开vtp的修剪功能
    特权模式下:
    vlan database
    vtp pruning
    2.进入中继接口模式
    interface f0/24
    switch trunk pruning vlan {add |except | none | remove} vlan-list [,vlan[,vlan[,,,]]

    • add:将vlan加入到适宜修剪的列表中

    • except:除了指定的vlan之外都修剪

    • none:不做任何的修剪

    • remove:将指定的vlan移除需要修剪的列表

    • vlan-list:可以是用逗号分隔的单个vlan(2-1001,其他不能被修剪掉),短线表示为一个范围,不能出现空格

    3.查看配置结果
       show interface f0/24 switchport
       show running interface f0/24
       show interface trunk
    如:
       interface f0/24
    switchport trunk pruning vlan add 3,5,6-10
    show running inter f0/24
    show interface f0/24 switchport
    Name: Fa0/24
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: 1,2,4-4094
    Pruning VLANs Enabled: 2,4,11-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Appliance trust: none

    配置802.1Q的本地vlan(native vlan)

    • 封装类型为802.1q的trunk中继接口,可以接收“带标记(tagged)”和“未加标记(untagged)”的数据。缺省时,交换机会用该端口的本地vlan(native vlan)来转发未加标记的数据。

    • 封装类型为isl的trunk中继接口,对未加标记“未加标记(untagged)”的数据将会丢弃。

    • 缺省的本地vlan(native )为VLAN 1。

    • 本地vlan可以被指定为任意的vlan号,它不依赖于管理vlan。

    配置过程:
    1.进入接口模式,中继的封装类型为802.1q
    interface f0/24
    switchport mode trunk
    switchport trunk encap dot1q
    2.设置哪个vlan作为本地vlan
       switchport trunk native vlan vlan-id
       vlan-id:1-4094
    3.查看配置结果
       show interface f0/24 switchport
    如果某个数据帧的vlan id与出端口的本地vlan号相同,该数据包就按照未标记传送;否则,交换机会使用带标记来传输数据包

    如:
    interface f0/24
       switchport mode trunk
       switchport trunk encap dot1q
       switchport trunk native vlan 3
    show interf f0/24 switchport


    Name: Fa0/24
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 3 (VLAN_B)
    Voice VLAN: none
    Operational private-vlan: none
    Trunking VLANs Enabled: 1,2,4-4094
    Pruning VLANs Enabled: 2-9,11-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Appliance trust: none

    show interface trunk
    Port              Mode            Encapsulation      Status       Native vlan
    Fa0/24        desirable       802.1q                 trunking       3

    Port              Vlans allowed on trunk
    Fa0/24        1-2,4-4094

    Port            Vlans allowed and active in management domain
    Fa0/24       1-2,10

    Port              Vlans in spanning tree forwarding state and not pruned
    Fa0/24         1-2,10


    转载于:https://blog.51cto.com/1841cisco/1244081

    展开全文
  • switchport trunk encapsulation dot1q //c2960交换机不需要此条命令 switchport mode trunk switchport trunk allowed vlan 57 switchport trunk allowed vlan add 192 数字机房C3750 vlan 3 name movie ...

    背景:如图,东湖机房-钻探机房-数字机房之间只有一根光纤(2芯),而这三个地方都要使用到两个不同的网络即10.63.57.0和192.168.192.0

    东湖机房有一台C3550,钻探机房C3750,数字机房C3750

    要求:在现有条件下,实现三地相同网段的网络互联。

    配置:

    东湖机房C3550
    vlan 57
    name lan
    vlan 192
    name wan
    exit
    interface range fastEthernet 0/2 - 12
    switchport mode access
    spanning-tree portfast
    switchport access vlan 57
    exit
    interface range fastEthernet 0/13 - 24
    switchport mode access
    spanning-tree portfast
    switchport access vlan 192
    exit
    int fa0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlan 57
    switchport trunk allowed vlan add 192

    钻探机房C2960
    vlan 57
    name lan
    vlan 192
    name wan
    exit
    interface range  gig1/0/2 - 12
    switchport mode access
    spanning-tree portfast
    switchport access vlan 57
    exit
    interface range  gig1/0/13 - 24
    switchport mode access
    spanning-tree portfast
    switchport access vlan 192
    exit
    int fa0/1
    switchport trunk encapsulation dot1q    //c2960交换机不需要此条命令
    switchport mode trunk
    switchport trunk allowed vlan 57
    switchport trunk allowed vlan add 192

    数字机房C3750
    vlan 3
    name movie
    vlan 987
    name meeting
    vlan 57
    name lan
    vlan 192
    name wan
    exit
    interface range gig1/0/2 - 8
    switchport mode access
    spanning-tree portfast
    switchport access vlan 2
    exit
    interface range gig1/0/9 - 16
    switchport mode access
    spanning-tree portfast
    switchport access vlan 57
    exit
    interface range gig1/0/17 - 22
    switchport mode access
    spanning-tree portfast
    switchport access vlan 192
    exit
    interface range gig1/0/22 - 24
    switchport mode access
    spanning-tree portfast
    switchport access vlan 987
    exit

    int gig1/0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlan 57
    switchport trunk allowed vlan add 192
    switchport trunk allowed vlan add 987

     详细配置清单:

    东湖机房C3550

    c3550#sh run
    Building configuration...

    01:41:44: %SYS-5-CONFIG_I: Configured from console by console
    Current configuration : 5040 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c3550
    !
    enable secret 5 $1$12.H$ImTHhROtL/FF9MG7O.kyL0
    enable password ytv2003
    !
    ip subnet-zero
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    !
    !
    !        
    interface FastEthernet0/1
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 57,192
     switchport mode trunk
     rmon collection stats 1 owner "root@ciscoworks [1066772640421]"
    !
    interface FastEthernet0/2
     switchport access vlan 57
     switchport mode access
     rmon collection stats 2 owner "root@ciscoworks [1066772640390]"
     spanning-tree portfast
    !
    interface FastEthernet0/3
     switchport access vlan 57
     switchport mode access
     rmon collection stats 3 owner "root@ciscoworks [1066772640359]"
     spanning-tree portfast
    !
    interface FastEthernet0/4
     switchport access vlan 57
     switchport mode access
     rmon collection stats 4 owner "root@ciscoworks [1066772640328]"
     spanning-tree portfast
    !
    interface FastEthernet0/5
     switchport access vlan 57
     switchport mode access
     rmon collection stats 5 owner "root@ciscoworks [1066772640296]"
     spanning-tree portfast
    !
    interface FastEthernet0/6
     switchport access vlan 57
     switchport mode access
     rmon collection stats 6 owner "root@ciscoworks [1066772640265]"
     spanning-tree portfast
    !
    interface FastEthernet0/7
     switchport access vlan 57
     switchport mode access
     rmon collection stats 7 owner "root@ciscoworks [1066772640218]"
     spanning-tree portfast
    !
    interface FastEthernet0/8
     switchport access vlan 57
     switchport mode access
     rmon collection stats 8 owner "root@ciscoworks [1066772640171]"
     spanning-tree portfast
    !
    interface FastEthernet0/9
     switchport access vlan 57
     switchport mode access
     rmon collection stats 9 owner "root@ciscoworks [1066772640125]"
     spanning-tree portfast
    !
    interface FastEthernet0/10
     switchport access vlan 57
     switchport mode access
     rmon collection stats 10 owner "root@ciscoworks [1066772640093]"
     spanning-tree portfast
    !
    interface FastEthernet0/11
     switchport access vlan 57
     switchport mode access
     rmon collection stats 11 owner "root@ciscoworks [1066772640062]"
     spanning-tree portfast
    !
    interface FastEthernet0/12
     switchport access vlan 57
     switchport mode access
     rmon collection stats 12 owner "root@ciscoworks [1066772640031]"
     spanning-tree portfast
    !
    interface FastEthernet0/13
     switchport access vlan 192
     switchport mode access
     rmon collection stats 13 owner "root@ciscoworks [1066772640000]"
     spanning-tree portfast
    !
    interface FastEthernet0/14
     switchport access vlan 192
     switchport mode access
     rmon collection stats 14 owner "root@ciscoworks [1066772639968]"
     spanning-tree portfast
    !
    interface FastEthernet0/15
     switchport access vlan 192
     switchport mode access
     rmon collection stats 15 owner "root@ciscoworks [1066772639937]"
     spanning-tree portfast
    !
    interface FastEthernet0/16
     switchport access vlan 192
     switchport mode access
     rmon collection stats 16 owner "root@ciscoworks [1066772639890]"
     spanning-tree portfast
    !
    interface FastEthernet0/17
     switchport access vlan 192
     switchport mode access
     rmon collection stats 17 owner "root@ciscoworks [1066772639859]"
     spanning-tree portfast
    !
    interface FastEthernet0/18
     switchport access vlan 192
     switchport mode access
     rmon collection stats 18 owner "root@ciscoworks [1066772639828]"
     spanning-tree portfast
    !
    interface FastEthernet0/19
     switchport access vlan 192
     switchport mode access
     rmon collection stats 19 owner "root@ciscoworks [1066772639796]"
     spanning-tree portfast
    !
    interface FastEthernet0/20
     switchport access vlan 192
     switchport mode access
     rmon collection stats 20 owner "root@ciscoworks [1066772639750]"
     spanning-tree portfast
    !
    interface FastEthernet0/21
     switchport access vlan 192
     switchport mode access
     rmon collection stats 21 owner "root@ciscoworks [1066772639718]"
     spanning-tree portfast
    !
    interface FastEthernet0/22
     switchport access vlan 192
     switchport mode access
     rmon collection stats 22 owner "root@ciscoworks [1066772639687]"
     spanning-tree portfast
    !
    interface FastEthernet0/23
     switchport access vlan 192
     switchport mode access
     rmon collection stats 23 owner "root@ciscoworks [1066772639656]"
     spanning-tree portfast
    !        
    interface FastEthernet0/24
     switchport access vlan 192
     switchport mode access
     rmon collection stats 24 owner "root@ciscoworks [1066772639625]"
     spanning-tree portfast
    !
    interface GigabitEthernet0/1
     switchport mode dynamic desirable
     rmon collection stats 25 owner "root@ciscoworks [1066772639578]"
    !
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     rmon collection stats 26 owner "root@ciscoworks [1066772639453]"
    !
    interface Vlan1
     no ip address
     no ip route-cache
     no ip mroute-cache
    !
    interface Vlan57
     ip address 10.63.57.11 255.255.255.0
    !
    ip classless
    ip http server
    !
    snmp-server community public RW
    snmp-server location public
    snmp-server host 10.65.160.5 rw
    !
    line con 0
     password datapart
     login
    line vty 0 4
     password datapart
     login
    line vty 5 15
     password datapart
     login
    !
    !
    end

    钻探机房C2950

    wlgs#sh run
    Building configuration...

    Current configuration : 3233 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname wlgs
    !
    enable secret 5 $1$t37f$JjNloQpCT20yvt.lf8VmD.
    enable password datapart
    !
    no aaa new-model
    system mtu routing 1500
    ip subnet-zero
    !
    cluster enable datapart 0
    !
    !
    !
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface FastEthernet0/1
     switchport trunk allowed vlan 57,192
     switchport mode trunk
    !
    interface FastEthernet0/2
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/3
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/4
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !        
    interface FastEthernet0/5
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/6
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/7
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/8
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/9
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/10
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/11
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/12
     switchport access vlan 57
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/13
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/14
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/15
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/16
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/17
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/18
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/19
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/20
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/21
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/22
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/23
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface FastEthernet0/24
     switchport access vlan 192
     switchport mode access
     spanning-tree portfast
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface Vlan1
     no ip address
     no ip route-cache
    !
    interface Vlan57
     ip address 10.63.57.10 255.255.255.0
     no ip route-cache
    !
    ip http server
    !
    control-plane
    !
    !
    line con 0
    line vty 0 4
     password catv2006
     login
    line vty 5 15
     password catv2006
     login
    !
    end
     

    转载于:https://blog.51cto.com/sunrc/407120

    展开全文
  • 1、理解Trunk的运行原理 2、掌握Trunk的配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应...

    实验目的

     

    1、理解Trunk的运行原理

    2、掌握Trunk的配置方法

     

    实验拓扑

     

    图片

     

    实验需求

     

     

    1、根据实验拓扑图,完成设备的基本配置;

    2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR;

    3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20;

    4、把SW1和SW2互连的链路配置成Trunk,采用Dot1q封装;

    5、测试PC之间的网络连通性。

     

    实验步骤

     

    步骤1:设备的基本配置

    配置PC1

    •  
    •  
    VPCS> set pcname PC1   //设置主机名PC1> ip 10.1.1.1/24      //设置IP地址

    配置PC2

    •  
    •  
    VPCS> set pcname PC2PC2> ip 10.1.2.1/24

    配置PC3

    •  
    •  
    VPCS> set pcname PC3PC3> ip 10.1.1.2/24

     

    配置PC4

    •  
    •  
    VPCS> set pcname PC4PC4> ip 10.1.2.2/24

     

    配置SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    Switch>enableSwitch#configure terminalSwitch(config)#hostname SW1SW1(config)#no ip domain-lookupSW1(config)#line console 0SW1(config-line)#exec-timeout 0 0SW1(config-line)#logging synchronousSW1(config-line)#endSW1#

    配置SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    Switch>enableSwitch#configure terminalSwitch(config)#hostname SW2SW2(config)#no ip domain-lookupSW2(config)#line console 0SW2(config-line)#exec-timeout 0 0SW2(config-line)#logging synchronousSW2(config-line)#endSW2#

    步骤2:VLAN的配置

    配置SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1(config)#vlan 10SW1(config-vlan)#name ITSW1(config-vlan)#exitSW1(config)#vlan 20SW1(config-vlan)#name HRSW1(config-vlan)#exitSW1(config)#interface Eth0/1SW1(config-if)#switchport mode accessSW1(config-if)#switchport access vlan 10SW1(config-if)#exitSW1(config)#interface Eth0/2SW1(config-if)#switchport mode access   SW1(config-if)#switchport access vlan 20SW1(config-if)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2(config)#vlan 10SW2(config-vlan)#name ITSW2(config-vlan)#exitSW2(config)#vlan 20SW2(config-vlan)#name HRSW2(config-vlan)#exitSW2(config)#interface Eth0/1SW2(config-if)#switchport mode accessSW2(config-if)#switchport access vlan 10SW2(config-if)#exitSW2(config)#interface Eth0/2SW2(config-if)#switchport mode access   SW2(config-if)#switchport access vlan 20SW2(config-if)#endSW2#

     

    步骤3:Trunk的配置

    配置SW1

    •  
    •  
    •  
    •  
    •  
    SW1(config)#interface Eth0/0SW1(config-if)#switchport trunk encapsulation dot1qSW1(config-if)#switchport mode trunkSW1(config-if)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    SW2(config)#interface Eth0/0SW2(config-if)#switchport trunk encapsulation dot1qSW2(config-if)#switchport mode trunkSW2(config-if)#endSW2#

     

    实验检查

    步骤1:检查VLAN

    检查SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1#show vlan brief
    
    VLAN Name                             Status    Ports---- -------------------------------- --------- -------------------------------1    default                             active     Et0/310   IT                                 active     Et0/120   HR                                active     Et0/21002 fddi-default                     act/unsup1003 token-ring-default               act/unsup1004 fddinet-default                  act/unsup1005 trnet-default                    act/unsupSW1已经创建好VLAN10和VLAN20,并已将对应接口划入。

     

    检查SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2#show vlan brief
    
    VLAN Name                             Status    Ports---- -------------------------------- --------- -------------------------------1    default                             active    Et0/310   IT                                 active    Et0/120   HR                                active    Et0/21002 fddi-default                     act/unsup1003 token-ring-default               act/unsup1004 fddinet-default                  act/unsup1005 trnet-default                    act/unsupSW2已经创建好VLAN10和VLAN20,并已将对应接口划入。

     

    步骤2:检查Trunk

    检查SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1#show interfaces Eth0/0 switchportName: Et0/0Switchport: EnabledAdministrative Mode: trunkOperational Mode: trunkAdministrative Trunking Encapsulation: dot1qOperational Trunking Encapsulation: dot1qNegotiation of Trunking: OnAccess Mode VLAN: 1 (default)Trunking Native Mode VLAN: 1 (default)Administrative Native VLAN tagging: enabledVoice VLAN: noneAdministrative private-vlan host-association: noneAdministrative private-vlan mapping: noneAdministrative private-vlan trunk native VLAN: noneAdministrative private-vlan trunk Native VLAN tagging: enabledAdministrative private-vlan trunk encapsulation: dot1qAdministrative private-vlan trunk normal VLANs: noneAdministrative private-vlan trunk associations: noneAdministrative private-vlan trunk mappings: noneOperational private-vlan: noneTrunking VLANs Enabled: ALLPruning VLANs Enabled: 2-1001Capture Mode DisabledCapture VLANs Allowed: ALLProtected: falseAppliance trust: noneE0/0接口当前是Trunk,封装的协议是dot1q。SW1#show interfaces trunkPort        Mode            Encapsulation   Status        Native vlanEt0/0       on               802.1q         trunking      1
    
    Port        Vlans allowed on trunkEt0/0       1-4094Port        Vlans allowed and active in management domainEt0/0       1,10,20Port        Vlans in spanning tree forwarding state and not prunedEt0/0       1,10,20E0/0封装的Trunk协议是dot1q,当前的状态是trunking。SW1#sh run int Eth0/0Building configuration...Current configuration : 90 bytes!interface Ethernet0/0 switchport trunk encapsulation dot1q switchport mode trunkendE0/0接口的Trunk封装协议是dot1q,模式是trunk。

     

    检查SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2#show interfaces trunkPort        Mode             Encapsulation  Status        Native vlanEt0/0       on                802.1q        trunking      1
    
    Port        Vlans allowed on trunkEt0/0       1-4094Port        Vlans allowed and active in management domainEt0/0       1,10,20Port        Vlans in spanning tree forwarding state and not prunedEt0/0       1,10,20E0/0封装的Trunk协议是dot1q,当前的状态是trunking。

     

    步骤4:网络连通性测试

    测试PC1和PC3的连通性:

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    PC1> ping 10.1.1.284 bytes from 10.1.1.2 icmp_seq=1 ttl=64 time=1.603 ms84 bytes from 10.1.1.2 icmp_seq=2 ttl=64 time=1.234 ms84 bytes from 10.1.1.2 icmp_seq=3 ttl=64 time=1.027 ms84 bytes from 10.1.1.2 icmp_seq=4 ttl=64 time=2.372 ms84 bytes from 10.1.1.2 icmp_seq=5 ttl=64 time=1.200 msPC1和PC3的网络连通性正常。

    测试PC2和PC4的连通性:

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    PC2> ping 10.1.2.284 bytes from 10.1.2.2 icmp_seq=1 ttl=64 time=0.887 ms84 bytes from 10.1.2.2 icmp_seq=2 ttl=64 time=0.932 ms84 bytes from 10.1.2.2 icmp_seq=3 ttl=64 time=1.295 ms84 bytes from 10.1.2.2 icmp_seq=4 ttl=64 time=0.926 ms84 bytes from 10.1.2.2 icmp_seq=5 ttl=64 time=1.011 msPC2和PC4的网络连通性正常。
    展开全文
  • 1、理解Trunk的运行原理 2、掌握Trunk的配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的...

    实验目的

     

    1、理解Trunk的运行原理

    2、掌握Trunk的配置方法

     

    实验拓扑

     

    图片

    实验需求

     

    1、根据实验拓扑图,完成设备的基本配置;

    2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR;

    3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20;

    4、把SW1和SW2互连的链路配置成Trunk,采用Dot1q封装;

    5、测试PC之间的网络连通性。

     

    实验步骤

     

     

     

    步骤1:设备的基本配置

    配置PC1

    •  
    •  
    VPCS> set pcname PC1   //设置主机名PC1> ip 10.1.1.1/24      //设置IP地址

     

    配置PC2

    •  
    •  
    VPCS> set pcname PC2PC2> ip 10.1.2.1/24

     

    配置PC3

    •  
    •  
    VPCS> set pcname PC3PC3> ip 10.1.1.2/24

     

    配置PC4

    •  
    •  
    VPCS> set pcname PC4PC4> ip 10.1.2.2/24

     

    配置SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    Switch>enableSwitch#configure terminalSwitch(config)#hostname SW1SW1(config)#no ip domain-lookupSW1(config)#line console 0SW1(config-line)#exec-timeout 0 0SW1(config-line)#logging synchronousSW1(config-line)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    Switch>enableSwitch#configure terminalSwitch(config)#hostname SW2SW2(config)#no ip domain-lookupSW2(config)#line console 0SW2(config-line)#exec-timeout 0 0SW2(config-line)#logging synchronousSW2(config-line)#endSW2#

     

    步骤2:VLAN的配置

    配置SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1(config)#vlan 10SW1(config-vlan)#name ITSW1(config-vlan)#exitSW1(config)#vlan 20SW1(config-vlan)#name HRSW1(config-vlan)#exitSW1(config)#interface Eth0/1SW1(config-if)#switchport mode accessSW1(config-if)#switchport access vlan 10SW1(config-if)#exitSW1(config)#interface Eth0/2SW1(config-if)#switchport mode access   SW1(config-if)#switchport access vlan 20SW1(config-if)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2(config)#vlan 10SW2(config-vlan)#name ITSW2(config-vlan)#exitSW2(config)#vlan 20SW2(config-vlan)#name HRSW2(config-vlan)#exitSW2(config)#interface Eth0/1SW2(config-if)#switchport mode accessSW2(config-if)#switchport access vlan 10SW2(config-if)#exitSW2(config)#interface Eth0/2SW2(config-if)#switchport mode access   SW2(config-if)#switchport access vlan 20SW2(config-if)#endSW2#

     

    步骤3:Trunk的配置

    配置SW1

    •  
    •  
    •  
    •  
    •  
    SW1(config)#interface Eth0/0SW1(config-if)#switchport trunk encapsulation dot1qSW1(config-if)#switchport mode trunkSW1(config-if)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    SW2(config)#interface Eth0/0SW2(config-if)#switchport trunk encapsulation dot1qSW2(config-if)#switchport mode trunkSW2(config-if)#endSW2#

     

    实验检查

     

     

    步骤1:检查VLAN

    检查SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1#show vlan brief
    
    VLAN Name                             Status    Ports---- -------------------------------- --------- -------------------------------1    default                             active     Et0/310   IT                                 active     Et0/120   HR                                active     Et0/21002 fddi-default                     act/unsup1003 token-ring-default               act/unsup1004 fddinet-default                  act/unsup1005 trnet-default                    act/unsupSW1已经创建好VLAN10和VLAN20,并已将对应接口划入。

     

    检查SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2#show vlan brief
    
    VLAN Name                             Status    Ports---- -------------------------------- --------- -------------------------------1    default                             active    Et0/310   IT                                 active    Et0/120   HR                                active    Et0/21002 fddi-default                     act/unsup1003 token-ring-default               act/unsup1004 fddinet-default                  act/unsup1005 trnet-default                    act/unsupSW2已经创建好VLAN10和VLAN20,并已将对应接口划入。

     

    步骤2:检查Trunk

    检查SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1#show interfaces Eth0/0 switchportName: Et0/0Switchport: EnabledAdministrative Mode: trunkOperational Mode: trunkAdministrative Trunking Encapsulation: dot1qOperational Trunking Encapsulation: dot1qNegotiation of Trunking: OnAccess Mode VLAN: 1 (default)Trunking Native Mode VLAN: 1 (default)Administrative Native VLAN tagging: enabledVoice VLAN: noneAdministrative private-vlan host-association: noneAdministrative private-vlan mapping: noneAdministrative private-vlan trunk native VLAN: noneAdministrative private-vlan trunk Native VLAN tagging: enabledAdministrative private-vlan trunk encapsulation: dot1qAdministrative private-vlan trunk normal VLANs: noneAdministrative private-vlan trunk associations: noneAdministrative private-vlan trunk mappings: noneOperational private-vlan: noneTrunking VLANs Enabled: ALLPruning VLANs Enabled: 2-1001Capture Mode DisabledCapture VLANs Allowed: ALLProtected: falseAppliance trust: noneE0/0接口当前是Trunk,封装的协议是dot1q。SW1#show interfaces trunkPort        Mode            Encapsulation   Status        Native vlanEt0/0       on               802.1q         trunking      1
    
    Port        Vlans allowed on trunkEt0/0       1-4094Port        Vlans allowed and active in management domainEt0/0       1,10,20Port        Vlans in spanning tree forwarding state and not prunedEt0/0       1,10,20E0/0封装的Trunk协议是dot1q,当前的状态是trunking。SW1#sh run int Eth0/0Building configuration...Current configuration : 90 bytes!interface Ethernet0/0 switchport trunk encapsulation dot1q switchport mode trunkendE0/0接口的Trunk封装协议是dot1q,模式是trunk。

     

    检查SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2#show interfaces trunkPort        Mode             Encapsulation  Status        Native vlanEt0/0       on                802.1q        trunking      1
    
    Port        Vlans allowed on trunkEt0/0       1-4094Port        Vlans allowed and active in management domainEt0/0       1,10,20Port        Vlans in spanning tree forwarding state and not prunedEt0/0       1,10,20E0/0封装的Trunk协议是dot1q,当前的状态是trunking。

     

    步骤4:网络连通性测试

    测试PC1和PC3的连通性:

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    PC1> ping 10.1.1.284 bytes from 10.1.1.2 icmp_seq=1 ttl=64 time=1.603 ms84 bytes from 10.1.1.2 icmp_seq=2 ttl=64 time=1.234 ms84 bytes from 10.1.1.2 icmp_seq=3 ttl=64 time=1.027 ms84 bytes from 10.1.1.2 icmp_seq=4 ttl=64 time=2.372 ms84 bytes from 10.1.1.2 icmp_seq=5 ttl=64 time=1.200 msPC1和PC3的网络连通性正常。

     

    测试PC2和PC4的连通性:

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    PC2> ping 10.1.2.284 bytes from 10.1.2.2 icmp_seq=1 ttl=64 time=0.887 ms84 bytes from 10.1.2.2 icmp_seq=2 ttl=64 time=0.932 ms84 bytes from 10.1.2.2 icmp_seq=3 ttl=64 time=1.295 ms84 bytes from 10.1.2.2 icmp_seq=4 ttl=64 time=0.926 ms84 bytes from 10.1.2.2 icmp_seq=5 ttl=64 time=1.011 msPC2和PC4的网络连通性正常。

     

    展开全文
  • 1) 报文入端口时:对于没有vlan的报文,trunk端口把这些报文标记为带native vlan的报文 3) 报文出端口时,对于没有vlan的报文,trunk端口将这些报文标记为带native vlan的报文 4) 报文出端口时,对于有vlan的...
  • 思科交换机设置端口 trunk 模式报错

    千次阅读 2019-11-20 21:02:26
    Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. 意思是:拒绝命令:主干封装为“Auto”的接口不能配置为“trunk”模式。 原因分析:因为端口没有还...
  • Mellanox交换机trunk配置

    2015-07-09 20:46:19
    centec交换机个人感觉cli跟思科没什么大区别,主要是mellanox交换机配置trunk的时候没有native vlan支持,不过port支持hybrid。交换机port类型介绍看这里:http://blog.csdn.net/JesseYoung/article/detail...
  • 思科交换机命令

    2018-08-06 15:44:00
    show running-conf #查看配置configure terminal #进入全局配置no tftp-server system:default-running-config #关掉默认... trunk模式的端口用于交换机交换机交换机与路由器,大多用于级联网络设备。 Access...
  • 思科交换机vlan

    2020-06-18 10:16:37
    VLAN VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网设备从逻辑上划分成一个...有了VLAN,交换机之间的级联链路就需要Trunk 技术来保证该链路可以同时传输多个VLAN 的数据。同时为...
  • cisco思科交换机无线常用配置 1、 交换机telnet功能开启: <Sysname>enable [Sysname]conf t line vty 0 4 password XXXX login 配置说明:默认情况下所有端口都可以通过telnet进行连接。 2、 建立VLAN: 思科采用...
  • 思科交换机作为DHCP

    2017-11-02 13:59:00
    实验名称:交换机作为DHCP 实验目的:PC1与PC2不同网段互通 ...2.在二层交换机设置DHCP配置,设置vlan 1 的ip与三层交换机为同一网段互通,并设置三层交换机对应端口的ip为网关,与三层交换机的对应端口为trunk ...
  • 思科交换机的接口分为access和trunk两种类型 access口端口的收发规则是: 收:不带tag打上tag,带tag丢弃 发:去掉tag直接发送 trunk口端口收发规则: 收:不带tag打上tag,带tag如果允许通过就直接转发 发:...
  • 思科交换机:vtp协议

    2020-10-30 20:30:14
    作用十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样他们可以自动学习到server 上的VLAN 信息,若考虑安全因素可将接入层交换机配为...
  • 思科 交换机的vtp模式

    千次阅读 2020-01-23 21:37:17
    第一步:把两两相连的交换机分别trunk SW0: SW1: SW2: SW3: 第二步:配置交换机vtp三种模式 SW0: 设置成域名为A,服务器模式(server) SW1:设置成域名为A,客户机(client) SW2:设置成域名为A,透...
  • 思科交换机基本配置 交换机是局域网中最重要的设备,交换机是基于 MAC 来进行工作的。和路由器类似,交换 机也有 IOS,IOS 的基本使用方法是一样的。本章将简单介绍交换机的一些基本配置,以及交换 机独特的密码恢复...
  • 统计了思科的路由器及交换机的命令,包括划分vlan trunk 及单臂路由等命令大全!
  • Switch(config-if-range)# Switchport mode trunk Switch>Enable Switch#configure t Switch(config)#inter vlan 1 Switch(config-if)#ip address 192.168.1.1 255.255.255.0 Switch(config-if)#no shu
  • 真实网络中实际是采用交换机作为DHCP服务器。 配置二层交换机将端口fa0/1...配置连接三层设备的fa0/24口设置为trunk口 给vlan10配置dhcp功能 功能验证 验证成功,保留ip没有获取到 问题沟通+vx16630121348 ...
  • 思科VLAN Trunk

    2020-06-18 10:18:57
    如果交换机 1 的VLAN1 中的机器要访问交换机 2 的VLAN1中的,我们可以把两台交换机的级联端口设置为Trunk端口,这样,当交换机把数据包从级联口发出去的时候,会在数据包中做一个标记(TAG),以使其它交换机识别该...
  • 思科的CatOS交换机 上, 有一条命令 – set port host对连接 到 终端的端口进行优化配置 。这 条命令 会将端口的 channel模式关闭;在端口上激活生成树(spanning tree)的快速启动(portfast)特性 – ...
  • 1、基本概念介绍 IOS: 互联网操作系统,也就是交换机和路由器中用的操作系统 VLAN: 虚拟lan VTP: VLAN TRUNK PROTOCOL DHCP: 动态主机配置协议 ACL: 访问控制列表 三层交换机:具有三层路由转发能力的交换机本教程...
  • interface GigabitEthernet0/1switchport trunk native vlan 100 (vlan100作为access模式的)switchport trunk allowed vlan 11,100switchport mode trunk 转载于:https://blog.51cto.com/zhanguo1110/1...
  • 为什么 提示:VLAN有三大优点 1.控制广播,防止网络通信量过大而瘫痪 2.增强网络安全性 3.简化网络管理 VLAN分类 提示:根据使用和管理方式的不同划分 1、 静态VLAN 基于端口的,需要网络管理员手工...VLAN Trunk
  • 思科交换机基本配置实例讲解(123)

    千次阅读 2017-12-26 10:32:00
    1、基本概念介绍 IOS: 互联网操作系统,也就是交换机和路由器中用的操作... VTP: VLAN TRUNK PROTOCOL DHCP: 动态主机配置协议 ACL: 访问控制列表 三层交换机:具有三层路由转发能力的交换机 本教程中“...
  • 【CCNA】实验之思科交换机配置vlan

    千次阅读 2018-08-14 10:51:02
    1、实验需求: 2、实验步骤 1&gt;配置sw1主机名 ...要求不使用trunk。...sw2交换机配置方式相同。 配置完成后测试PC1可以ping通PC3: 同时PC1无法ping通PC4: PC2可以访问PC4: 但是PC2不可以...
  • 需要TRUNK 才能在交换机之间传递 VLAN 信息。交换机上的端口可以是接入端口,或者是 TRUNK 端口。接入端口传输来自分配给该端口的特定 VLAN 的流量。TRUNK端口默认为所有 VLAN 的成员;因此,它传输所有 VLAN 的流量...
  • 有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。 Switch(config)#interface f0/2 Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport mode trunk Switch...

空空如也

空空如也

1 2 3 4 5 ... 11
收藏数 207
精华内容 82
关键字:

思科交换机trunk