精华内容
下载资源
问答
  • DHCP租约过期与更新

    千次阅读 2020-12-13 20:37:40
    如果电脑在租约到期之后重新开机,会得到一个新IP地址,过程是自动,不需要用户干涉。 再次申请话,IP地址有可能或获取到上次使用IP ,因为DHCP虽然 看上去是随机分配IP地址,但是如果客户端第一次有向DHCP...

                 DHCP的租约到期之前,如果设备(电脑、路由器)正在工作的话,是会自动续约的,不会造成网络中断。如果电脑在租约到期之后重新开机,会得到一个新的IP地址,过程是自动的,不需要用户干涉。

                 再次申请的话,IP地址有可能或获取到上次使用的IP ,因为DHCP虽然 看上去是随机分配IP地址,但是如果客户端第一次有向DHCP服务器获取IP地址话,这个时候DHCP服务器会把这台客户端的 mac和IP 记录下路,如果下次再申请,而这个IP 地址又没有被分出去的话,那么会优先使用这条记录。

                  当客户端重新启动(拔插网线)或租约到达50%时,客户端直接向提供租约的DHCP服务器发送Request包,要求更新现有地址租约。

                  一旦 DHCP 客户端成功地从服务器那里取得 DHCP 租约之后,除非其租约已经失效并且 IP 地址也重新设定回 0.0.0.0 ,否则就无需再发送 DHCP discover 信息了,而会直接使用已经租用到的 IP 地址向之前的 DHCP服务器发出 DHCP request 信息,DHCP 服务器会尽量让客户端使用原来的 IP 地址,如果没问题的话,直接响应 DHCP ACK来确认则可。如果该地址已经失效或已经被其它机器使用了,服务器则会响应一个DHCP NACK 封包给客户端,要求其重新执行 DHCP discover。

    展开全文
  • DHCP

    2020-11-04 17:19:38
    DHCP原理与配置了解DHCP服务DHCP的租约过程客户机请求IP地址服务器响应客户机请求IP地址服务器确定租约重新登录更新租约使用DHCP动态配置主机地址安装DHCP服务器DHCP小实验 了解DHCP服务 DHCP(动态主机配置协议) ...

    了解DHCP服务

    DHCP(动态主机配置协议)
    采用的是UDP协议:67(客户端)68(服务器)
    由internet工作任务小组设计开发
    专门用于为TCP/IP网络中的计算机自动分配TCP/IP参数的协议

    使用DHCP的好处
    1、减少管理员的工作量
    2、避免输入错误的可能
    3、避免IP地址冲突
    4、当更改IP地址段时,不需要重新配置每个用户的IP地址
    5、提高了IP地址的利用率
    6、方便客户端的配置

    DHCP的分配方式
    自动分配:分配到一个IP地址后永久使用
    手动分配:由DHCP服务器管理员专门指定IP地址
    动态分配:使用完后释放该IP,供其它客户机使用

    DHCP的租约过程

    客户机从DHCP服务器获得IP地址的过程成为DHCP的租约过程

    客户机请求IP地址

    1、当一个DHCP客户机启动时,客户机还没有IP地址,所有客户机要通过DHCP获取一个合法的地址
    2、此时DHCP客户机以广播方式发送DHCP Discover发现信息来寻找DHCP服务器
    3、DHCP客户端广播请求IP地址
    源IP地址:0.0.0.0
    目标地址:255.255.255.255

    服务器响应

    1、DHCP服务器接收到来自客户机请求IP地址的信息时,在自己的IP地址池中查找是否有合法的IP地址提供给客户机
    2、如果有,DHCP服务器将此IP地址做上标记,加入到DHCP Offer的消息中,然后广播一则DHCP OFFER消息
    3、DHCP服务器响应
    源IP地址:192.168.10.10
    目标IP地址:255.255.255.255
    提供的IP地址:192.168.10.101

    客户机请求IP地址

    1、DHCP客户机从接收到的第一个DHCP OFFER消息中提取IP地址,发出IP地址的DHCP服务器将该地址保留,这样该地址就不能再分配给另一个DHCP客户机
    客户端广播
    2、选择DHCP服务器(192.168.10.10)
    源地址:0.0.0.0
    目标地址:255.255.255.255
    租约期限:8天

    服务器确定租约

    1、DHCP服务器接收到DHCP request消息后,以DHCP ACK消息的形式向客户机广播成功确认,该消息包含有IP地址的有效租约和其它可配置的信息
    2、当客户机收到DHCP ACK消息时,配置IP地址,完成TCP/IP的初始化
    3、DHCP服务器确认
    源IP地址:192.168.10.10
    目标IP地址:255.255.255.255

    重新登录

    DHCP客户机每次重新登录网络时,不需要再发送DHCP Discover信息,而是直接发送包含前一次所分配的IP地址的DHCP Request请求信息

    更新租约

    1、当DHCP服务器向客户机出租的IP地址租期达到50%时,就需要更新租约
    2、客户机直接向提供租约的服务器发送DHCP Request包,要求更新现有的地址租约

    使用DHCP动态配置主机地址

    DHCP服务
    1、为大量客户机自动分配地址,提供集中管理
    2、减轻管理和维护成本,提高网络配置效率
    可分配的地址信息主要包括
    1、网卡的IP地址、子网掩码
    2、对应的网络地址、广播地址
    3、默认网关地址
    4、DNS服务器地址
    5、租期

    安装DHCP服务器

    DHCP服务器软件
    1、CentOS光盘中的dhcp-4.2.5-47.el7.centos.x86_64.rpm
    2、DHCP软件包的主要文件
    主配置文件:/etc/dhcpd.conf
    执行程序:/usr/sbin/dhcpd、/usr/sbin/dhcrelay

    DHCP小实验

    1.安装dhcp服务
    rpm -ivh /mnt/Packages/dhcp-4.2.5-47.el7.centos.x86_64.rpm
    2.复制样例为dhcp配置文件
    cp /usr/share/doc/dhcp-4.2.5/dhcpd.conf.example /etc/dhcp/dhcpd.conf
    3.配置dhcp的配置文件
    vi /etc/dhcp/dhcpd.conf
    ddns-update-style none; //禁用 DNS 动态更新
    default-lease-time 21600; //默认租约为 6 小时
    max-lease-time 43200; //最大租约为 12 小时
    option domain-name "bdqn.com"; //指定默认搜索域
    option domain-name-servers 202.106.0.20, 202.106.148.1; //指定 DNS 服务器地址
    ******下发地址段的配置选项***********
    subnet 192.168.4.0 netmask 255.255.255.0 { //声明网段地址
    range 192.168.4.128 192.168.4.254; //设置地址池,可以有多个
    option routers 192.168.4.1; //指定默认网关地址
    }
    ******设置保留地址*******************
    host prtsvr {
    hardware ethernet 00:c0:c3:22:46:81;  【微软默认网卡MAC地址分隔符是-,需要手动改为:】
    fixed-address 192.168.4.100;
    }
    4.启动dhcp服务
    systemctl start dhcpd
    netstat -anpu | grep dhcpd
    5.客户端设置为dhcp启动
    vi /etc/sysconfig/network-scripts/ifcfg-ens33
    DEVICE=ens33
    ONBOOT=yes
    BOOTPROTO=dhcp
    6.客户机设置ens33网卡dhcp获取地址
    dhclient -d ens33
    7.服务器查看客户机获取地址的情况
    less /var/lib/dhcpd/dhcpd.leases
    8.客户机设置ens33网卡释放获取到的地址
    dhclient -r ens33
    展开全文
  • 广播第四个过程:ack 服务端确认IP可用 服务端——》客户端 广播更新租约DHCP服务器配置安装DHCP服务器dhcpd.conf内容构成全局设置,作用于整个DHCP服务器subnet网段声明,作用于整个子网段

    了解DHCP服务

    动态主机配置协议是一个局域网的网络协议。指的是由服务器控制一段IP地址范围,客户机登录服务器时就可以自动获得服务器分配的IP地址和子网掩码。担任DHCP服务器的计算机需要安装TCP/IP协议,并为其设置静态IP地址、子网掩码、默认网关等内容。
    DHCP (Dynamic HostConfiguration Protocol, 动态主机配置协议)
    由Internet工作任务小组设计开发专门用于为TCP/IP网络中的计算机自动分配TCP/IP参数的协议

    使用DHCP的好处

    减少管理员的工作量
    避免输入错误的可能
    避免IP地址冲突
    当更改IP地址段时,不需要重新配置每个用户的IP地址
    提高了IP地址的利用率
    方便客户端的配置

    DHCP的分配方式

    在DHCP的工作原理中,DHCP服务器提供了三种IP分配方式:自动分配(Automatic allocation)、手动分配和动态分配(Dynamic Allocation)。

    • 自动分配是当DHCP客户端第一次成功的从DHCP服务器获取一个IP地址后,就永久的使用这个IP地址。
    • 手动分配是由DHCP服务器管理员专门指定的IP地址
    • 动态分配是当客户端第一次从DHCP服务器获取到IP地址后,并非永久使用该地址,每次使用完后,DHCP客户端就需要释放这个IP,供其他客户端使用。

    工作原理

    客户机从DHCP服务器获得IP地址的过程称为DHCP的租约过程
    分为四个步骤
    在这里插入图片描述

    租约过程

    第一个过程:discover 请求IP地址 客户——》服务端 广播

    • 当一个DHCP客户机启动时,客户机还没有IP地址,所以客户机要通过DHCP获取一个合法的地址
    • 此时DHCP客户机以广播方式发送DHCP discover发现信息来寻找DHCP服务器
    • 因为自己没有IP地址,所以源IP地址为:0.0.0.0
    • 同时也不知道DHCP服务器地址,所以发送广播255.255.255.255
      在这里插入图片描述

    第二个过程:offer 服务器回应可用IP信息 服务器——》客户端 广播

    • 当DHCP服务器接收到来自客户机请求IP地址的信息时,他就在自己的IP地址池中查找是否有合法的IP地址(可用IP、子网掩码、网关、DNS、租约期限)提供给客户机,如果有,DHCP服务器就将此IP地址做上标记,加入到DHCPoffer的消息中,然后DHCP服务器就广播一则DHCP offer消息
    • 客户机仍没有IP地址,所以发送广播
      • 如果有多台DHCP服务器 discover请求后收到 offer先到先得

    第三个过程:request 客户端请求确认可用IP 客户端——》服务端 广播

    • 客户机选择IP地址:发送DHCP request广播
    • 客户机从接收到的第一个DHCPoffer消息中提取IP地址,发出IP地址的DHCP服务器将该地址保留,这样该地址就不能再分配给另一个DHCP客户机
    • 第一个DHCP offer表示:若局域网中同时存在两个DHCP,那么客户机根据收到DHCPoffer的顺序来确定使用哪个DHCP服务器的地址
    • 客户机发送DHCP request 广播,选择IP地址,并附上租约期限信息(默认8天)
      在这里插入图片描述

    第四个过程:ack 服务端确认IP可用 服务端——》客户端 广播

    • 服务器确定租约:发送DHCP ACK广播
    • DHCP服务器接收到DHCP request消息后,以DHCP ACK消息的形式向客户机广播成功确认,该消息包含有IP地址的有效租约和其他可配置的消息
    • 当客户机收到DHCP ACK消息时,他就配置了IP地址,完成TCP/IP的初始化
    • 此时服务器发出的仍旧是广播,因为客户机还没有IP地址
      • 特殊情况:如果offer中的地址被使用直接回应noack 则继续循环第一个过程
        在这里插入图片描述

    更新租约

    续约的时候发的是request单播
    租约期限过半 要找DHCP续约
    整个局域网都没有DHCP服务器 客户机租约到期后,会自动释放地址,然后使用169.254.0.0–169.254.255.255网段的地址

    DHCP服务器的配置

    • DHCP服务
      为大量客户机自动分配地址,提供集中管理
      减轻管理和维护成本、提高网络配置效率

    • 可分配的地址信息主要包括
      网卡的IP地址、子网掩码
      对应的网络地址、广播地址
      默认网关地址
      DNS服务器地址

    安装DHCP服务器

    • DHCP服务器软件
      centos镜像中的dhcp…rpm
    • dhcp软件包的主要文件
      主配置文件:/etc/dhcpd.conf
      执行程序:/usr/sbin/dhcpd,/usr/sbin/dhcrelay
      执行参数配置:/etc/sysconfig/dhcpd

    dhcpd.conf的内容构成

    ddns-update-style interim;  						全局配置参数,针对所有子网段
    ...
    subnet 10.152.187.0 netmask 255.255.255.0 {			网段声明
      option routers 10.5.5.1;							配置选项,网关
      ...
      default-lease-time 600;							配置参数,租约
       ...
      host ns{
            ...
            fixed-address 207.175.42.254; 				主机声明,固定的主机地址
        }
    }
    

    全局设置,作用于整个DHCP服务器

    ddns-update-style none;						禁止dns动态更新
    default-lease-time 21600;					默认租约期限
    max-lease-time 43200;						最大租约期限
    option domain-name"domain.org";				指定域名
    option domain-name-servers 202.106.0.20;	指定分配dns地址
    

    subnet网段声明,作用于整个子网段

    range参数:设置用于分配的IP地址池
    option subnet-mask 参数: 设置客户机的子网掩码
    option routers 参数: 设置客户机的默认网关地址
    

    host主机声明,作用于单个主机

    hardware ethernet 参数:指定对应主机的MAC地址
    fixed-address参数:指定为该主机保留的IP地址
    

    DHCP实验

    • 实验环境
      VM虚拟机里一台win7客户机 一台linux里配置DHCP服务器
    • 实验步骤
      dhcp固定IP地址
      安装dhcp包
      修改配置文件(根据模板复制)
      设置subnet {地址池, 子网掩码,网关,dns地址}
      启动服务
    [root@pan ~]# yum install dhcp* -y				下载dhcp所有包
    下载完后把win10 和linux 绑在一个网卡上  (我这里用仅主机模式)
    [root@pan ~]# rpm -cq dhcp
    /etc/dhcp/dhcpd.conf						DHCP配置文件
    /etc/dhcp/dhcpd6.conf
    /etc/openldap/schema/dhcp.schema
    /etc/sysconfig/dhcpd
    /var/lib/dhcpd/dhcpd.leases
    /var/lib/dhcpd/dhcpd6.leases
    [root@pan ~]# cd /etc/dhcp/
    [root@pan dhcp]# ls
    dhclient.d  dhclient-exit-hooks.d  dhcpd6.conf  dhcpd.conf  scripts
    [root@pan dhcp]# vim dhcpd.conf 	 进去看一下配置文件	 		里面是空的
    # DHCP Server Configuration file.
    #   see /usr/share/doc/dhcp*/dhcpd.conf.example					DHCP配置文件模板 进去看看
    #   see dhcpd.conf(5) man page
    #
    ~                                                                                      
    ......                                       
    [root@pan dhcp]# cp /usr/share/doc/dhcp-
    dhcp-4.2.5/        dhcp-common-4.2.5/ dhcp-devel-4.2.5/  
    [root@pan dhcp]# cp /usr/share/doc/dhcp-4.2.5/dhcpd.conf.example  /etc/dhcp/dhcpd.conf  把配置模板里的信息复制到刚刚的空配置文件里
    [root@pan dhcp]# vim /etc/sysconfig/network-scripts/ifcfg-ens33 				配置DHCP固定ip地址
    TYPE=Ethernet
    PROXY_METHOD=none
    BROWSER_ONLY=no
    BOOTPROTO=static								DHCP改成static
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=no
    IPV6INIT=yes
    IPV6_AUTOCONF=yes
    IPV6_DEFROUTE=yes
    IPV6_FAILURE_FATAL=no
    IPV6_ADDR_GEN_MODE=stable-privacy
    NAME=ens33
    UUID=96401a89-2a9e-4214-b827-df367567dc24
    DEVICE=ens33
    ONBOOT=yes
    IPADDR=192.168.100.120						加上ip地址
    NETMAKS=255.255.255.0						子网掩码
    GATEWAY=192.168.100.2						网关
    [root@pan dhcp]# service network restart 			重启网络服务
    [root@pan dhcp]# vim dhcpd.conf 					
      1 # dhcpd.conf
      2 #
      3 # Sample configuration file for ISC dhcpd
      4 #
      5 
      6 # option definitions common to all supported networks...
      7 option domain-name "example.org";						
      8 option domain-name-servers 8.8.8.8;					DNS地址(分号不能少;)
      9 
     10 default-lease-time 600;					默认租约
     11 max-lease-time 7200;					最大租约
     12 
     13 # Use this to enble / disable dynamic dns updates globally.
     14 #ddns-update-style none;						
    ......
     26 
     27 subnet 192.168.100.0 netmask 255.255.255.0 {					修改网段
     28   range 192.168.100.130 192.168.100.200;						分配ip的地址池(空两格表示层级关系)
     29   option routers 192.168.100.2;								分配给下面客户端的网关
     30 }
     31 
    
    wq保存退出
    
    [root@pan dhcp]# systemctl start dhcpd										启动dhcp服务
    [root@pan dhcp]# netstat -nuap													查看
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
    udp        0      0 0.0.0.0:5353            0.0.0.0:*                           8628/avahi-daemon:  
    udp        0      0 192.168.100.120:52994   185.209.85.222:123      ESTABLISHED 8682/chronyd        
    udp        0      0 192.168.122.1:53        0.0.0.0:*                           9773/dnsmasq        
    udp        0      0 0.0.0.0:67              0.0.0.0:*                           15992/dhcpd         					已启动
    udp        0      0 0.0.0.0:67              0.0.0.0:*                           9773/dnsmasq        
    udp        0      0 0.0.0.0:111             0.0.0.0:*                           1/systemd           
    udp        0      0 127.0.0.1:323           0.0.0.0:*                           8682/chronyd        
    udp        0      0 0.0.0.0:738             0.0.0.0:*                           8619/rpcbind        
    udp        0      0 0.0.0.0:41760           0.0.0.0:*                           8628/avahi-daemon:  
    udp6       0      0 :::111                  :::*                                1/systemd           
    udp6       0      0 ::1:323                 :::*                                8682/chronyd        
    udp6       0      0 :::738                  :::*                                8619/rpcbind      
    

    切换到win7设置自动获取ip地址
    在这里插入图片描述
    cmd进去看一下
    在这里插入图片描述

    DNS子网段里的优先生效
    在这里插入图片描述
    在这里插入图片描述
    改完后保存要重新启动
    再去win7查看
    在这里插入图片描述
    固定分配IP地址
    查看客户机的mac地址 我的是00-0C- 29-1A-49-A0
    进配置文件搜索/fix
    在这里插入图片描述
    重启服务进客户机查看
    在这里插入图片描述

    实验总结

    • 修改完后要重启服务
    • 配置文件修改完要加分号
    • systemctl start dhcpd 启动
    • systemctl restart dhcpd 重启
    • 客户端: ipconfig /release 释放IP地址
      • ipconfig /renew 获取ip地址
      • ipconfig /all 查看IP的主机信息,DNS信息,物理地址信息,DHCP服务器信息等,

    DHCP中继实验

    eNSP拓扑图
    在这里插入图片描述

    二层交换机LSW2配置信息
    <Huawei>dis cu
    #
    sysname Huawei
    #
    vlan batch 10 20 100
    #
    interface Ethernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 20
    #
    interface Ethernet0/0/4
     port link-type access
     port default vlan 100
    
    三层交换机LSW1配置信息
    sysname Huawei
    #
    vlan batch 10 20 100
    #
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.100.100
    #
    interface Vlanif20
     ip address 192.168.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.100.100
    #
    interface Vlanif100
     ip address 192.168.100.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.100.100
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    
    linux设置
    [root@localhost ~]# yum install dhcp* -y			联网下载dhcp所有包
    [root@localhost ~]# rpm -cq dhcp
    /etc/dhcp/dhcpd.conf										
    /etc/dhcp/dhcpd6.conf
    /etc/openldap/schema/dhcp.schema
    /etc/sysconfig/dhcpd
    /var/lib/dhcpd/dhcpd.leases
    /var/lib/dhcpd/dhcpd6.leases
    [root@localhost ~]# cp /usr/share/doc/dhcp-4.2.5/dhcpd.conf.example /etc/dhcp/dhcpd.conf			复制dhcp配置文件模板覆盖到空的配置文件上
    [root@localhost ~]# vim /etc/dhcp/dhcpd.conf						编辑配置文件
    

    在这里插入图片描述
    把拓扑图里的云和linux都绑在一个网卡上
    在这里插入图片描述
    在这里插入图片描述

    [root@localhost ~]# vim /etc/sysconfig/network-scripts/ifcfg-ens33 					配置网络
    TYPE=Ethernet
    PROXY_METHOD=none
    BROWSER_ONLY=no
    BOOTPROTO=static			改成静态
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=no
    IPV6INIT=yes
    IPV6_AUTOCONF=yes
    IPV6_DEFROUTE=yes
    IPV6_FAILURE_FATAL=no
    IPV6_ADDR_GEN_MODE=stable-privacy
    NAME=ens33
    UUID=96401a89-2a9e-4214-b827-df367567dc24
    DEVICE=ens33
    ONBOOT=yes
    IPADDR=192.168.100.100					配置ip
    NETMASK=255.255.255.0
    GATEWAY=192.168.100.1
    DNS1=8.8.8.8
    ~                              
    [root@localhost ~]# systemctl restart network					重启后查看ip
    [root@localhost ~]# ifconfig 
    ens33: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.100.100  netmask 255.255.255.0  broadcast 192.168.100.255
            inet6 fe80::649:df95:3c83:ded1  prefixlen 64  scopeid 0x20<link>
            ether 00:0c:29:b5:32:3f  txqueuelen 1000  (Ethernet)
            RX packets 8783  bytes 12721541 (12.1 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 2477  bytes 188412 (183.9 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    [root@localhost ~]# ping 192.168.10.1 				ping下其他网段  (不成功检查网卡、云绑定问题)
    PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
    64 bytes from 192.168.10.1: icmp_seq=1 ttl=255 time=42.4 ms
    64 bytes from 192.168.10.1: icmp_seq=2 ttl=255 time=31.1 ms
    64 bytes from 192.168.10.1: icmp_seq=3 ttl=255 time=38.2 ms
    [root@localhost ~]# setenforce 0			关闭防火墙
    [root@localhost ~]# iptables--F				清楚规则链路
    [root@localhost ~]# systemctl start dhcpd				启动dhcp服务
    
    Job for dhcpd.service failed because the control process exited with error code. See "systemctl status dhcpd.service" and "journalctl -xe" for details.
    如果出现这种情况检查配置文件 重新覆盖修改或者重启电脑重新做
    

    在这里插入图片描述
    2台PC获取ip成功

    实验总结

    ping PC不通一般都是在三层交换机设置和绑云上
    配置文件不能乱改 每段结尾分号很重要

    展开全文
  • Page */38 配置DHCP服务 第6章 本章目标 利用DHCP服务器给所有客户机动态分配IP地址 理解DHCP服务作用 理解DHCP...Page */38 本章结构 配置DHCP服务器 DHCP概述 什么是DHCP 使用DHCP理由 DHCP租约过程 IP租约更新 I
  • 分配方式二、DHCP的工作过程1.客户端在网络中搜索服务器2.服务器向客户端响应服务3.客户机选择IP地址4.服务器确定租约5.重新登录6.更新租约三、使用DHCP动态配置主机地址1.DHCP服务2.可分配地址信息主要包括四、...


    一、了解 DHCP 服务

    1.概述

    • DHCP(Dynamic Host Configuration Protocol,动态主机配置协议),是由 Internet 工作任务小组设计开发的,专门用于为 TCP/IP 网络中的计算机自动分配 TCP/IP 参数的协议
    • DHCP 服务避免了因手动设置IP地址所产生的错误,同时也避免了把一个 IP 地址分配给多台工作站所造成过的地址冲突
    • DHCP 提供了安全、可靠且安全的 TCP/IP 网络设置,降低了配置 IP 地址的负担

    2.使用 DHCP 的好处

    Internet是目前世界上用户最多的服务之一,有几亿人在使用Internet,由于上网时间的不确定性以及使用人员的技术水平不同,为每位用户分配一个固定的IP地址,不仅造成了IP地址的浪费,也会为ISP服务商带来高额的维护成本,而使用DHCP服务则有以下好处:

    • 减少管理员的工作量
    • 避免输入错误的可能
    • 避免IP地址冲突
    • 网络更改IP地址段时,不需要再重新配置每个用户的IP地址
    • 提高了IP地址的利用率
    • 方便客户端的配置

    3.DHCP 的分配方式

    • DHCP的典型应用模式如下
      • 在网络中假设一台专用的DHCP服务器,负责集中分配各种网络地址参数(主要包括IP地址,子网掩码,广播地址,默认网关地址,DNS服务器地址)
      • 其他主机作为DHCP客户机,将网卡配置为自动获取地址,即可与DHCP服务器进行通信,完成自动配置过程
    • 在DHCP的工作原理中,DHCP服务器提供了三种分配方式:自动分配,手动分配,动态分配
    • 自动分配:
      当DHCP客户机第一次成功地从DHCP服务器获取到一个IP地址后,就永久的使用这个IP地址
    • 手动分配:
      由DHCP服务器管理员专门指定IP地址
    • 动态分配:
      当DHCP客户机第一次从DHCP服务器获得IP地址后,并非永久的使用该地址,而是在每次使用完后,DHCP客户机就会释放这个IP地址,供其他客户机使用

    二、DHCP 的工作过程

    • 客户机从DHCP服务器获得IP地址的过程称为DHCP 的租约过程
    • 分为以下四个步骤

    1.客户端在网络中搜索服务器

    • 当一个DHCP客户机启动时,客户机还没有IP地址,所以客户机要通过DHCP获取一个合法的地址
    • 此时DHCP客户机以广播方式发送DHCP Discover发现信息来寻找DHCP服务器

    2.服务器向客户端响应服务

    • DHCP服务器接收到来自客户机请求IP地址的信息时,在自己的IP地址池中查找是否有合法的IP地址提供给客户机
    • 如果有,DHCP服务器将此IP地址做上标记,加入到DHCP Offer的消息中,然后广播一则DHCP Offer 消息

    3.客户机选择 IP 地址

    • DHCP客户机从接收到的第一个DHCP Offer消息中提取 IP 地址
    • 发出IP地址的DHCP服务器将该地址保留,这样该地址就不能再分配给另一个DHCP客户机了

    4.服务器确定租约

    • DHCP服务器接收到 DHCP Request 消息后,以DHCP ACK 消息的形式向客户机广播成功确认
    • 该消息包含有IP地址的有效租约和其他可配置的信息
    • 当客户机收到 DHCP ACK 消息时,配置IP地址,完成TCP/IP的初始化

    5.重新登录

    • DHCP客户机每次重新登录网络时,不需要再发送DHCP Discover信息
    • 而是直接发送包含前一次所分配的IP地址的DHCP Request请求信息

    6.更新租约

    • 当DHCP服务器向客户机出租的IP地址租期达至50%时就需要更新租约
    • 客户机直接向提供租约的服务器发送DHCP Request包,要求更新现有的地址租约

    三、使用 DHCP 动态配置主机地址

    1.概述

    • 为大量客户机自动分配地址,提供集中管理
    • 减轻管理和维护成本、提高网络配置效率

    2.可分配的地址信息

    • 网卡的 IP 地址、 子网掩码
    • 对应的网络地址、广播地址
    • 默认网关地址
    • DNS服务器地址

    四、安装 DHCP 服务器

    1.DHCP 服务软件

    • CentOS光盘中的 dhcp-4.2.5-47.el7.centos.x86_64.rpm
    • 一般都有,没有的话 RPM 去安装一下
      mark
    • DHCP 软件包的主要文件
      • 主配置文件:/etc/dhcpd.conf
      • 执行程序:/usr/sbin/dhcpd、usr/sbin/dhcrelay

    2.主配置文件

    • dhcpd.conf 的内容构成
    ddns-update-style  interim;     #全局配置参数
    ......
    subnet  192.168.0.0  netmask  255.255.255.0 {       #subnet以上的都是全局配置参数;网段声明(网段、子网掩码、默认网关地址)
       option routers 192.168.0.1;       #配置选项
       ......
       default-lease-time 21600;   #配置参数
       host ns {
          ......    
          fixed-address 207.175.42.254;    #主机声明(固定一个IP给主机用的)
       }
    }        
    
    • 全局配置,作用于整个DHCP服务器
      • ddns-update-style none;
      • default-lease time 21600;
      • max-lease-time 43200;
      • option domain-name “domain.org”;
      • option domain-name servers 202.106.0.20;
    • Subnet网段声明,作用于整个子网段
      • range参数:设置用于分配的IP地址池
      • option subnet-mask参数:设置客户机的子网掩码
      • option routers参数:设置客户机的默认网关地址
    [root@xcf1 ~]# vim /etc/httpd.conf
    

    五、配置步骤

    1.使用 DHCP 动态的给 PC 机分配 IP 地址

    1.1 eNSP

    • 实验拓扑图如下
    • 注:配置完“Cloud”之后才能用串口线连接
      mark
    • 配置Cloud
      mark
      (注:第一个选择UDP,第二个选择仅主机模式VMnet1,别选8,它自带dhcp功能,与本实验有冲突)
    • SW1基本配置
    <Huawei>sys
    [Huawei]sys SW1
    [SW1]un in en
    Info: Information center is disabled.
    [SW1]vlan batch 10 20 100
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [SW1]int e0/0/1
    [SW1-Ethernet0/0/1]p l a
    [SW1-Ethernet0/0/1]p d v 10
    [SW1-Ethernet0/0/1]int e0/0/2
    [SW1-Ethernet0/0/2]p l a
    [SW1-Ethernet0/0/2]p d v 20
    [SW1-Ethernet0/0/2]int e0/0/4
    [SW1-Ethernet0/0/4]p l a
    [SW1-Ethernet0/0/4]p d v 100
    [SW1-Ethernet0/0/4]int e0/0/3
    [SW1-Ethernet0/0/3]p l t
    [SW1-Ethernet0/0/3]p t a v a
    
    • SW2基本配置
    <Huawei>sys
    [Huawei]sys SW2
    [SW2]un in en
    Info: Information center is disabled.
    [SW2]vlan batch 10 20 100
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [SW2]int Vlanif 10
    [SW2-Vlanif10]ip add 192.168.10.1 24
    [SW2-Vlanif10]un sh
    Info: Interface Vlanif10 is not shutdown.
    [SW2-Vlanif10]q
    [SW2]int Vlanif 20
    [SW2-Vlanif20]ip add 192.168.20.1 24
    [SW2-Vlanif20]un sh
    Info: Interface Vlanif20 is not shutdown.
    [SW2-Vlanif20]q
    [SW2]int Vlanif 100
    [SW2-Vlanif100]ip add 192.168.100.1 24
    [SW2-Vlanif100]un sh
    Info: Interface Vlanif100 is not shutdown.
    [SW2-Vlanif100]int g0/0/1
    [SW2-GigabitEthernet0/0/1]port link-type trunk 
    [SW2-GigabitEthernet0/0/1]port trunk allow-pass vlan all 
    
    • 配置DHCP中继(三层交换机)
    [SW2]dhcp enable        ##开启DHCP功能
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [SW2]int Vlanif 10        ##配置虚接口ip,选择dhcp中继模式,请求指向dhcp服务器ip
    [SW2-Vlanif10]dhcp select relay 
    [SW2-Vlanif10]dhcp relay server-ip 192.168.100.100
    [SW2-Vlanif10]q
    [SW2]int Vlanif 20
    [SW2-Vlanif20]dhcp select relay 
    [SW2-Vlanif20]dhcp relay server-ip 192.168.100.100
    [SW2-Vlanif20]int Vlanif 100
    [SW2-Vlanif100]dhcp select relay 
    [SW2-Vlanif100]dhcp relay server-ip 192.168.100.100
    

    1.2 虚拟机

    • 选择虚拟机网络类型
      mark
    • 配置网卡IP
      mark
    • 安装dhcp软件包,并查看和找到配置文件
    [root@xcf1 ~]# yum -y install dhcp
    已加载插件:fastestmirror, langpacks
    Loading mirror speeds from cached hostfile
    软件包 12:dhcp-4.2.5-58.el7.centos.x86_64 已安装并且是最新版本
    无须任何处理
    
    [root@xcf1 ~]# cd /etc/dhcp/        ##dhcp的配置文件是/etc/dhcp/dhcpd.conf
    [root@xcf1 dhcp]# ls
    dhclient.d  dhclient-exit-hooks.d  dhcpd6.conf  dhcpd.conf  scripts
    [root@xcf1 dhcp]# less dhcpd.conf        ##查看一下内容
    ...
    
    [root@xcf1 ~]# cd /usr/share/doc/dhcp-4.2.5/        到该目录下去寻找dhcp配置模板
    [root@xcf1 dhcp-4.2.5]# ls        ##“dhcpd.conf.example”
    dhcpd6.conf.example  dhcpd.conf.example  ldap
    [root@xcf1 dhcp-4.2.5]# cp dhcpd.conf.example /etc/dhcp/dhcpd.conf        ##将模板覆盖到/etc/dhcp/dhcpd.conf中
    cp:是否覆盖"/etc/dhcp/dhcpd.conf" y
    
    [root@xcf1 ~]# cd /etc/dhcp/        ##回到/etc/dhcp目录下
    [root@xcf1 dhcp]# ls
    dhclient.d  dhclient-exit-hooks.d  dhcpd6.conf  dhcpd.conf  scripts
    [root@xcf1 dhcp]# less dhcpd.conf        ##查看配置文件并进行下一步编辑
    
    • 编辑dhcp配置文件
      • [root@xcf1 dhcp]# vim dhcpd.conf
        mark
    • 关闭防火墙,重启网卡,再去“ping”进行验证网络
    [root@xcf1 dhcp]# systemctl stop firewalld
    se[root@xcf1 dhcp]# setenforce 0
    ##记得重启一下网卡!
    [root@xcf1 dhcp]# systemctl restart dhcpd
    
    
    [root@xcf1 dhcp]# ping 192.168.100.1
    ...
    [root@xcf1 dhcp]# ping 192.168.10.1
    ...
    [root@xcf1 dhcp]# ping 192.168.20.1
    ...
    

    1.3 验证

    • 到eNSP中验证一下
    • 首先开启两台PC的DHCP来自动获取一下IP地址
      mark
      mark
    • 进入命令行“ipconfig”
      • pc1
        mark
      • pc2
        mark

    2.给 PC 机分配固定的 IP 地址

    • 首先将虚拟机Win10的网络适配器改成VMnet1仅主机模式
      mark

    2.1 修改宿主机网络适配器(注意,不是虚拟机的!)

    mark
    mark

    • 设置VMnet1
      mark
      mark

    2.2 在 Win10 虚拟机中查找该主机 MAC 地址

    mark

    • 输入“ipconfig/renew”或“ipconfig/release”刷新网络信息(按回车以显示)
    • 查看MAC地址
      mark

    2.3 虚拟机 CentOS7 中编辑 dhcp 配置文件

    [root@xcf1 ~]# cd /etc/dhcp/
    [root@xcf1 dhcp]# ls
    dhclient.d  dhclient-exit-hooks.d  dhcpd6.conf  dhcpd.conf  scripts
    [root@xcf1 dhcp]# vim dhcpd.conf 
    

    mark

    • 记得按wq保存退出
    • 修改完成,重启dhcp服务
    [root@xcf1 dhcp]# systemctl stop dhcpd        ##重启DHCP服务
    [root@xcf1 dhcp]# systemctl start dhcpd
    

    2.4 回到 win10 中刷新网络配置再查看就有绑定的 IP 了

    mark

    展开全文
  • DHCP配置

    2020-06-04 11:38:08
    当客户端重新启动或租约到达50%是,客户端直接像提供租约的DHCP服务器发送DHCPRequest包,要求更新现有地址租约。如果客户端无法与服务器通信,则客户端会再次等到租约导到87.5%时,重新进行租约更新,这是客户端向...
  • 客户机重新登录情况1.4.6租约过程更新租约二、使用DHCP动态配置主机地址2.1DHCP服务2.2可分配地址信息主要包括2.3DHCP主要配置文件2.4DHCP配置流程 一、DHCP概述 1.1了解DHCP服务 DHCP(动态主机配置协议)是一...
  • DHCP和域概念知识

    千次阅读 2019-01-17 11:50:38
    dhcp租约过程 客户机请求ip 服务器响应 客户机选择ip 服务器确定租约   客户端重启 更新租约     域名空间结构 根域 顶级域 而基于 fqdn=主机名.dns后缀   cache-only名称服务器 访问网站过程...
  • DHCP的原理与配置DHCP工作原理DHCP的租约过程客户机选择IP地址服务器确定租约重新登录更新租约DHCP服务器配置使用DHCP动态配置主机地址安装DHCP服务器主配置文件dhcpd.conf内容构成全局设置,作用于整个DHCP...
  • 文章目录一、了解DHCP服务使用DHCP的好处DHCP的分配方式二、DHCP的租约过程客户机请求P地址服务器响应客户机选择IP地址服务器确定租约重新登录更新租约三、DHCP的配置方式DHCP服务可分配地址信息主要包括 ...
  • DHCP服务器配置

    2009-08-25 09:17:56
    二、DHCP的租约过程DHCPdiscover、dhcpoffer、dhcprequest、dhcpack四个广播包。 三、ipconfig/release:释放租约 ipconfig/renew:更新租约 四、实验背景: 某公司办公区域分两个部分,OfficeA有200台主机...
  • DHCP服务

    2020-11-01 15:09:20
    DHCP服务DHCP简介DHCP的好处DHCP的分配方式DHCP的租约过程四个报文交互过程客户机重新登陆更新租约 DHCP简介 DHCP全称Dynamic Host Configuration Protocol,专门用于为TCP/IP网络中计算机自动分配TCP/IP参数...
  • 理论+实验:Linux的DHCP原理与配置

    千次阅读 2020-10-20 18:21:19
    目录一、DHCP工作原理1.1、了解DHCP服务1.2、使用DHCP好处1.3、DHCP分配方式1.4、DHCP租约过程1.4.1、客户机请求IP地址1.4.2、服务器响应1.4.3、客户机选择IP地址1.4.4、服务器确定租约1.4.5、重新登陆1.4.6、...
  • Linux下DHCP服务器部署

    2016-05-25 12:11:27
    DHCP租约产生的过程 租约更新 中继代理 DHCP安装和配置 DHCP安装和相关文件说明 DHCP配置 语法格式 配置选项和参数 配置示例 启动服务并设置开机自动启动 DHCP Relay配置 DHCP Load Balance Primary Server...
  • DHCP、FTP原理和配置方法DHCP服务了解DHCP服务使用DHCP的好处DHCP的分配方式DHCP的租约过程分为四个步骤客户机请求IP地址服务器响应客户机选择IP地址服务器确定租约重新登录更新租约可分配地址信息主要包括安装...
  • 1、DHCP作用 ...也成为DHCP租约过程,分为4个步骤: 1)客户机发送DHCP Discovery广播包 客户机广播请求IP地址(包含客户机MAC地址) 2)服务器响应DHCP Offer广播包 服务器响应提供IP地址(但无子网
  • 目录前言一、什么是DHCP1.1 DHCP概述1.2 DHCP的好处1.3 DHCP的分配方式1.3.1 自动分配1.3.2 手动分配1.3.3 动态分配二、DHCP工作原理(租约过程)2.1 租约过程分为以下四个步骤:2.2 租约过程详解2.2.1 客户端广播...
  • 原理与配置DHCP

    2021-04-26 16:18:01
    客户机从DHCP服务器获得IP地址的过程称为DHCP的租约过程■分为四个步骤■客户机请求IP地址■服务器确定租约■重新登录■更新租约使用DHCP动态配置主机地址■DHCP服务■可分配地址信息主要包括■配置■
  • 手把手教你搭建DHCP服务器

    万次阅读 多人点赞 2018-04-13 19:56:18
    更新租约 搭建DHCP服务器 实验目的 实验环境 实验步骤 实验结果 DHCP实现原理 DHCP定义 DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)是一个局域网网络协议,使用UDP协议工作...
  • DHCP服务安全配置

    2019-11-28 23:15:13
    DHCP概述 DHCP全称为动态主机配置协议,负责为客户机动态分配TCP/IP信息 ...DHCP租约过程 客户机请求IP地址 服务器响应请求 客户机选择IP地址 服务器确认租约 DHCP工作原理: IP租约更新 当DHCP客户...
  • (4)DHCP的租约过程步骤详细解读更新租约2,dhcp服务器配置(1) DHCP服务(2) 可分配地址信息主要包括(3) DHCP在Centos7配置过程:3,dhcp在华为模拟器(ensp)配置过程4,dhcp中继原理与配置 1,dhcp工作...
  • DHCP原理与配置

    2020-11-03 16:10:40
    DHCP原理与配置DHCP工作原理什么是DHCPDHCP使用DHCP的好处DHCP的分配方式DHCP的租约过程客户机请求IP地址服务器响应客户机选择IP地址服务器确定租约重新登录更新租约使用DHCP动态配置主机地址DHCP服务可分配地址...
  • DHCP原理和配置

    2019-12-07 14:23:46
    文章目录一、DHCP原理与设置1.1 什么是DHCP1.2 DHCP的作用场景1.3 使用DHCP的好处1.4 DHCP的分配方式1.5 DHCP的租约过程(给客户机分配IP)1.6 更新租约二、DHCP服务器配置实例2.1 实验环境2.2 实验目的2.3 实验过程...
  • 动态主机配置协议)由Internet工作任务小组设计开发专门用于为TCP/IP网络中计算机自动分配TCP/IP参数协议使用DHCP的好处DHCP的分配方式DHCP的租约过程客户机从DHCP服务器获得IP地址的过程称为DHCP的租约过程分为...
  • 带你了解DHCP

    2020-11-04 14:28:06
    DHCP原理与配置了解DHCP服务DHCP的租约过程客户机请求IP地址服务器响应客户机请求IP地址服务器确定租约重新登录更新租约使用DHCP动态配置主机地址安装DHCP服务器DHCP小实验 了解DHCP服务 DHCP(动态主机配置协议) ...
  • 动态主机配置协议)2、使用DHCP的好处3、DHCP的分配方式(1)使用DHCP服务分配地址(2)可分配地址信息主要包括(3)三种分配方式4、DHCP 的租约过程(1)客户端在网络中搜索服务器(2)服务器向客户端响应服务(3...
  • DHCP(理论)

    2020-11-04 16:14:18
    文章目录一、使用DHCP的好处二、DHCP的分配方式三、DHCP的租约过程(四个步骤)1、客户机请求IP地址2、服务器响应3、客户机选择IP地址4、服务器确认租约四、重新登录过程五、更新租约六、使用DHCP动态配置主机地址 ...

空空如也

空空如也

1 2 3
收藏数 52
精华内容 20
关键字:

dhcp租约的更新过程