精华内容
下载资源
问答
  • DR和BDR的选举问题

    万次阅读 2012-11-02 10:49:31
    DR和BDR的选举问题 1、 DR---Designated Router(指定路由器) DR的任务:  该图中,当R3所直连的某一网络发生中断,则R3将把该信息只交给R1(DR),DR收到该信息后,再向R2和R4发送该网络中断的信息。...

    DR和BDR的选举问题

    1、 DR---Designated Router(指定路由器)

    DR的任务:   


    该图中,当R3所直连的某一网络发生中断,则R3将把该信息只交给R1(DR),DR收到该信息后,再向R2和R4发送该网络中断的信息。换句话说,R1(即DR)是整个OSPF网络中的领导者,网络中出现任何变化,都需要向DR汇报,再由DR向其他路由器发送该消息。

    2、 BDR---Backup Designated Router(备份指定路由器)

    BDR的任务:在上图中,如果充当整个OSPF网络管理者的DR路由器发生意外情况,down了,则整个网络会因为失去了核心而变得混乱。BDR的作用就是在DR实效后顶替DR的位置,变成新的DR。

    3、 为什么要选择DR、BDR? 先来考虑一下没有DR/BDR网络的更新将是什么样子的: 如图,当R2路由器有路由更新信息需要告诉给其他路由器,那么它会把信息copy三份分别发给R1,R3,R4 



    当R1、R3、R4收到来自R2的更新报文后,也会做同样的事---因为它们不确定别的路由器是否已经知道了这条更新,所以他们会尽力的把自己知道的所有消息通过所有的ospf interface转发出去。 



    这样会导致一个问题:网络中的重复更新信息被复制了很多份,占用了宝贵的网络资源。如果仅仅只有一台领导者DR和一台BDR那么问题就会解决:所有的非DR、BDR路由器有任何的路由更新信息都只告诉DR和BDR,再由DR负责向其他的路由器转发该更新信息。


    4、 怎么选择DR、BDR 如下图,四台OSPF路由器的Router ID都已标识出来.它们使用HELLO报文来互相交换信息,从而选择出DR、BDR。在整个OSPF网络中,Router ID最高者则成为DR,次高者成为BDR,其余的路由器统称为DRother。下图中,因为R1路由器的Router ID最高,则成为DR;而R2路由器的Router ID次高,成为BDR;R3、R4两台路由器被称为DRother. 


    5、 手工配置DR、BDR DR需要处理整个网络中的实时的变动信息,承担着整个OSPF网络中领导者的责任,因此做为DR路由器需要较强的性能。不排除一种可能性:网络中的一台较低端的路由器因为其上IP数值较大,那么很可能在DR选举时会成为DR,那么它将成为整个网络性能的瓶颈。我们可以通过手工控制选举的方式来指定谁将成为DR,谁将成为BDR。 可以有两种方式:

    1)、 通过控制每台路由器的Router ID来指定DR、BDR 每台OSPF路由器选举DR、BDR,是通过比较各自的Router ID来决定,谁的Router ID最高,谁将成为DR。那么我们可以通过手工指定各台路由器的Router ID,来控制选举。例如在上图中,我们现在修改DR、BDR分别为R4、R3,而R1、R2均成为DRother.

    Router1(config)#int lo 0

    Router1(config-if)#ip add 1.1.1.1 255.255.255.0

    Router1(config-if)#router ospf 100

    Router1(config-router)#router-id 1.1.1.1


    Router2(config)#int lo 0

    Router2(config-if)#ip add 2.2.2.2 255.255.255.0

    Router2(config)#router ospf 200

    Router2(config-router)#router-id 2.2.2.2


    Router3(config)#int lo 0

    Router3(config-if)#ip add 3.3.3.3 255.255.255.0

    Router3(config)#router ospf 300

    Router3(config-routre)#router-id 3.3.3.3


    Router4(config)#int lo 0

    Router4(config-if)#ip add 4.4.4.4 255.255.255.0

    Router4(config)#router ospf 400

    Router4(config-routre)#router-id 4.4.4.4

    因为在上图中网络已经收敛,DR、BDR已经选出,如果此时我们重新修改各路由器的Router ID,它们也不会重新选举,那样会造成网络的动荡。因此,我们在修改配置后,需要手动的重启ospf进程: Clear ip ospf pro Y 然后可以通过命令:show ip ospf neighbor 来查看配置是否生效。

    2)、 通过修改路由器优先级来控制DR、BDR的选举 路由器在选举的过程中,需要比较Router ID和优先级别,优先级默认是相同的,均为1。所以在默认情况下,只比较Router ID即可。但是可以通过手工的修改优先级来控制选举。方法如下: 例如在上图中,我们需要更改R3为DR,R1为BDR,其余则为DRother

    R3(config-if)#ip ospf priority 100

    R1(config-if)#ip ospf priority 80

    Priority范围是0~255,当一台路由器的priority为0时,该路由器将不会参加选举。


    需要注意的是:

    只有在广播或NBMA类型接口才会选举DR,在点到点或点到多点类型的接口上不需要选举DR。 DR是某个网段中的概念,是针对路由器的接口而言的。某台路由器在一个接口上可能是DR,在另一个接口上有可能是BDR,或者是DR Other。 路由器的优先级可以影响一个选取过程,但是当DR/BDR已经选取完毕,就算一台具有更高优先级的路由器变为有效,也不会替换该网段中已经选取的DR/BDR成为新的DR/BDR。 DR并不一定就是路由器优先级最高的路由器接口;同理,BDR也并不一定就是路由器优先级次高的路由器接口

     

    出处:http://wenku.baidu.com/view/e504ecf67c1cfad6195fa7e8.html





    展开全文
  • OSPF中DR/BDR的选举问题

    2009-11-16 17:30:54
    王导导首先我要确定ospf的确先选的bdr然后在来的dr,...宣称是说在hello包里的DR/BDR域里有自己接口的地址,表示参与DRBDR的选举;宣告是表示某路由器已经被选举为了DR或BDR。2,已经选举为了DR(也就是被宣告为了D...
    王导导首先我要确定ospf的确先选的bdr然后在来的dr,很多人有疑问是应为首先tcp/ip 一书中关于dr和dbr的选举少写的一段:如下

    1,首先得弄明白卷一上说的“宣称”,“宣告”是两个截然不同的意思。宣称是说在hello包里的DR/BDR域里有自己接口的地址,表示参与DR或BDR的选举;宣告是表示某路由器已经被选举为了DR或BDR。

    2,已经选举为了DR(也就是被宣告为了DR),不能参与BDR的选举,,但是但是但是已经选举为了BDR的路由器可以参与DR的选举。

    3,DR/BDR的选举是一个循环的过程。

    所以如下总结

    1,首先当然是先列表出符合选举条件的路由器了(也就是优先级大于0且已已经是2-way状态的路由器),,然后所有的路由器既宣称自己为DR,也宣称自己为BDR,当然在hello包里的DR/BDR域里都记上自己接口的IP地址。

    2,然后开始选举BDR,(当然这个是个循环过程了,如果这个时候已经有DR了,那么就排出这个DR,因为已经选举为了DR的不参与BDR的选举),所以划分一个排开DR的子集,这里就都是宣称自己为BDR的路由器,,然后优先级取胜出BDR(当然优先级相等,就RID了),如果没有宣称BDR的路由器(因为可能在hello字段BDR域里没有自己的接口地址,关于这点我也感觉和之前矛盾),那么就从中选举出优先级最大的路由器为BDR。

    3,然后开始选举DR,还是划分宣称自己为DR的子集,当然这个时候之前选出来的BDR也参与到DR的选举中,再次通过优先级选举出DR,如果之前选举的BDR优先级最大,那么就在这次选举被覆盖掉,被选举为了DR(从而也保证优先级最大的为DR),如果没有宣称自己为DR的路由器,那么直接把这个BDR升级为DR。,然后再选举BDR。

    in a word,如果段中有DR了,那么选举BDR,如果没有DR,那么之前选举的BDR升级为DR,再次选举BDR,,但是同样是按照之前的选举步骤来。


    如上 所说是少了这么一段.其实加上这么一段后发现就对了吧~~哈哈~~~


          还有个误到人的地方就是在ospf邻居在exstart状态时,开始选dr和bdr,这个时候出现了一个m/s(主从)位,很多人说优先级等同的情况下看router-id,大的是m就是主,也是dr,也是决定谁控制数据同步.其实我要说并不是的,ms就是简单的决定谁去控制数据同步,这个在我下的ospf 邻居关系里就有,而且那上面有个经典的话,dr也是可能成为salve的,也正好驳倒了router-id大的就是m,就是dr.前面其实有人把这个贴出来讲对了

        (向以前我班里的学生道歉,当时我也是这么说的,不好意思,现在做个纠正)

    转载于:https://blog.51cto.com/laobai/228144

    展开全文
  • 思科华为ccie认证-OSPF在广播类型的网络拓扑中DR和BDR的选举 指定路由器(DR): 一个网段上的其他路由器都和指定路由器(DR)构成邻接关系,而不是它们互相之间构成邻接关系。 备份指定路由器(BDR): 当DR...

    思科华为ccie认证-OSPF在广播类型的网络拓扑中DR和BDR的选举

     

    指定路由器(DR):

    一个网段上的其他路由器都和指定路由器(DR)构成邻接关系,而不是它们互相之间构成邻接关系。

    备份指定路由器(BDR):

    当DR出现问题,由BDR接手DR的工作,同时会在选举出一个BDR。

    其他路由器我们叫做DR Other。

     

    BDR首先会和DR形成邻接关系;

    其它的路由器(DR Other)也要和BDR形成邻接关系。

    这样做是有原因的,当DR出故障以后,BDR会成为新的DR。如果DR other不和BDR形成邻接关系,网络的流量就会中断时间很长,因为建立邻居关系是要花一定时间的,在这段时间内,网络的流量是不通的!

    DR other和BDR形成邻接关系,当BDR切换为DR时,只需要发送LSA,向DR other告知新的DR即可,LSDB的内容基本上不变!所以能够节省时间,让BDR真正的起到备份的作用!

     

    DR和BDR的选举规则:

    具有最高OSPF优先级的路由器会被选为DR,优先级默认为1。

    如果OSPF优先级相同,则具有最高Router ID的路由器会被选为DR。

     

    Route-id选举规则:

    [if !supportLists]1. [endif]手工配置最优先

    [if !supportLists]2. [endif]当设备有loopback口时,路由器选取它所有loopback接口上数值最高的IP地址

    [if !supportLists]3. [endif]如果没有loopback接口,就在所有物理端口中选取一个数值最高的IP地址

     

    需求:(描述实验的要求)

    [if !supportLists]1. [endif]R1 R2 R3属于OSPF 的骨干区域,R1 R2 R3位于10.1.1.0/24 网段.

    [if !supportLists]2. [endif]R2 R3 R4 位于OSPF 的40.1.1.0/24 网段.

    [if !supportLists]3. [endif]希望R2 作为 10.1.1.0 网段的DR, R3作为BDR;R3 作为40.1.1.0 网段的DR,R2 作为BDR.

     

    拓扑:

     

    分析难点以及完成的思路

    按照要求配置,首先正常配置OSPF的基础命令,保证在修改DR和 BDR之前全网互通,配置完成之后再去测试连通性,全部测试完毕之后,修改我们的DR和BDR,查看我们修改之后的DR和BDR设备是否成功达到我们的要求

     

    配置命令

    R1 配置:

    R1(config)#line console 0

    R1(config-line)#exec-timeout 0 0

    R1(config-line)#logging synchronous

    R1(config-line)#exit

    R1(config)#no ip do lo

     

    R1(config)#interface loopback 0

    R1(config-if)#ip address 1.1.1.1 255.255.255.255

    R1(config-if)#no shutdown

    R1(config-if)#exit

     

    R1(config)#interface f0/0

    R1(config-if)#ip address 10.1.1.1 255.255.255.0

    R1(config-if)#no shutdown

    R1(config-if)#exit

     

    R2配置:

    R2(config)#line console 0

    R2(config-line)#exec-timeout 0 0

    R2(config-line)#logging synchronous

    R2(config-line)#exit

    R2(config)#no ip do lo

    R2(config)#ho R2

    R2(config)#interface loopback 0

    R2(config-if)#ip address 2.2.2.2 255.255.255.255

    R2(config-if)#no shutdown

    R2(config-if)#exit

     

    R2(config)#interface f0/0

    R2(config-if)#ip address 10.1.1.2 255.255.255.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

     

    R2(config)#interface f0/1

    R2(config-if)#ip address 40.1.1.2 255.255.255.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

     

    R3配置:

    R3(config)#line console 0

    R3(config-line)#exec-timeout 0 0

    R3(config-line)#logging synchronous

    R3(config-line)#exit

    R3(config)#no ip do lo

    R3(config)#ho R3

     

    R3(config)#interface loopback 0

    R3(config-if)#ip address 3.3.3.3 255.255.255.255

    R3(config-if)#no shutdown

    R3(config-if)#exit

     

    R3(config)#interface f0/0

    R3(config-if)#ip address 10.1.1.3 255.255.255.0

    R3(config-if)#no shutdown

    R3(config-if)#exit

     

    R3(config)#interface f0/1

    R3(config-if)#ip address 40.1.1.3 255.255.255.0

    R3(config-if)#no shutdown

    R3(config-if)#exit

     

    R4配置:

    R4(config)#line console 0

    R4(config-line)#exec-timeout 0 0

    R4(config-line)#logging synchronous

    R4(config-line)#exit

    R4(config)#no ip do lo

    R4(config)#ho R4

     

    R4(config)#interface loopback 0

    R4(config-if)#ip address 4.4.4.4 255.255.255.255

    R4(config-if)#no shutdown

    R4(config-if)#exit

     

    R4(config)#interface f0/1

    R4(config-if)#ip address 40.1.1.4 255.255.255.0

    R4(config-if)#no shutdown

    R4(config-if)#exit

     

     

     

    启用OSPF,默认情况下,OSPF进行DR选举时的优先级默认为1,比较规则是优先级越大越优先,优先级相同,router-id越大越优先。因此干预选举可以通过设置router-id和修改接口的优先级进行。在10.1.1.0 网段上,由于R1 R2 R3的优先级为默认的1 ,因此优先级大的R3(3.3.3.3),就成为DR,R2(2.2.2.2)成为BDR.但是要考虑,如果R1 R2率先接入网络,当DR BDR选举完成之后再接入R3的话,R3错过选举之后,就不能抢占DR BDR了。

    R2 R3 R4也一样,因此正常情况下R4为DR,R3为BDR

     

    R1配置:

    R1(config)#router ospf 1

    R1(config-router)#router-id 1.1.1.1//手工指定router-id

    R1(config-router)#network 1.1.1.1 0.0.0.0 area 0--------采取反子网掩码的方式进行通告,类似于通告了一个1.1.1.1 255.255.255.255 的路由信息,采用反子网掩码,是为了区别配置IP地址是的子网掩码

     

    R1(config-router)#network 10.1.1.0 0.0.0.255 area 0

    R1(config-router)#exit

    R1(config)#end

     

    R2配置:

    R2(config)#router ospf 1

    R2(config-router)#router-id 2.2.2.2

    R2(config-router)#network 2.2.2.2 0.0.0.0 area 0

    R2(config-router)#network 10.1.1.0 0.0.0.255 area 0

    R2(config-router)#network 40.1.1.0 0.0.0.255 area 0

    R2(config-router)#end

     

    R3配置:

    R3(config)#router ospf 1

    R3(config-router)#router-id 3.3.3.3

    R3(config-router)#network 3.3.3.3 0.0.0.0 area 0

    R3(config-router)#network 10.1.1.0 0.0.0.255 area 0

    R3(config-router)#network 40.1.1.0 0.0.0.255 area 0

    R3(config-router)#exit

     

    R4 配置:

    R4(config)#router ospf 1

    R4(config-router)#router-id 4.4.4.4

    R4(config-router)#network 4.4.4.4 0.0.0.0 area 0

    R4(config-router)#network 40.1.1.0 0.0.0.255 area 0

    R4(config-router)#end

     

    这时,为了满足要求,让R2成为10.1.1.0 网段的DR,可以修改R2的router-id,改为22.22.22.22

    ,只要比R3的3.3.3.3 大就可以;为了是R3成为40.1.1.0 网段的DR,可以修改R3的f0/1

    的接口优先级。

    R2配置:

    R2(config)#router ospf 1

    R2(config-router)#ro

    R2(config-router)#router-id 22.22.22.22

    Reload or use "clear ip ospf process" command, for this to take effect//系统提示,要想新的router-id生效,要重启OSPF进程

    R2(config-router)#end

     

    R3 配置:

    R3(config)#interface f0/1

    R3(config-if)#ip ospf priority 5

    R3(config-if)#end

     

    这个时候,将R1 R2 R3 R4的OSPF进程重启,然后再观察。

    R1配置:

    R1#clear ip ospf process

    Reset ALL OSPF processes? [no]: y//重启OSPF进程,这个要在四个路由器上同时敲下去

     

    这时可以看到10.1.1.0网段,R2的router-id最大成为DR,R3的router-id次之,成为BDR;

    40.1.1.0 网段,R3的优先级最大成为DR,R2的router-id最大,成为BDR.

     

    按照正常配置完成之后,全网互通,在修改DR和BDR之后需要清一下OSPF的进程,让他们重新选举DR和BDR,如果不重启进程会发现DR和 BDR没有变化

     

    当DR优先级为0时,通过这个配置,也可以控制DR、BDR的选取!如果想让某台路由器永远都是一个LAN上的DR,则可以将其它的路由器的DR优先级都配置为0。

     

    DR、BDR是终身制,不能被抢占的,这一知识点也是比较奇怪的,我们上面说了DR/BDR是选取出来的,理论上在一个LAN上,应该是优先级最大的路由器被选取为DR的。

     

    但在很多场景中,小伙伴看到的并不是优先级最大的路由器作为DR!因为DR/BDR的选取是不能被抢占的!

     

    只要某台路由器在一个LAN上,已经被选取为DR,则它会一直是DR!只有等它重启或者关机了,才会重新选取,也就是说DR/BDR是终身制的!

     

    这样做主要是为了网络的稳定,在真实网络中,稳定是压倒一切的!即使某种技术最新,某个设备性能最强,但是如果影响到稳定,就不会被优先选择!

     

    所以想要让某个路由器永远作为DR,则只能其它路由器的优先级修改为0!

    展开全文
  • DR和BDR在广播网和NBMA网络中,任意两台路由器之间都要传递路由信息。如果网络中有n台路由器,则需要建立n(n-1)/2个邻接关系。这使得任何一台路由器路由变化都会导致多次传递,浪费了带宽资源。为解决这一问题,...

    .DR和BDR

    在广播网和NBMA网络中,任意两台路由器之间都要传递路由信息。如果网络中有n台路由器,则需要建立n(n-1)/2个邻接关系。这使得任何一台路由器的路由变化都会导致多次传递,浪费了带宽资源。为解决这一问题,OSPF协议定义了DR(Designated Router,指定路由器),所有路由器都只将信息发送给DR,由DR将网络链路状态发送出去。

    如果DR由于某种故障而失效,则网络中的路由器必须重新选举DR,再与新的DR同步。这需要较长的时间,在这段时间内,路由的计算是不正确的。为了能够缩短这个过程,OSPF提出了BDR(Backup Designated Router)的概念。

    BDR实际上是对DR的一个备份,在选举DR的同时也选举出BDR,BDR也和本网段内的所有路由器建立邻接关系并交换路由信息。当DR失效后,BDR会立即成为DR。由于不需要重新选举,并且邻接关系事先已建立,所以这个过程是非常短暂的。当然这时还需要再重新选举出一个新的BDR,虽然一样需要较长的时间,但并不会影响路由的计算。

    除DR和BDR之外的路由器(称为DR Other)之间将不再建立邻接关系,也不再交换任何路由信息。这样就减少了广播网和NBMA网络上各路由器之间邻接关系的数量。

    如图9-20所示,用实线代表以太网物理连接,虚线代表建立的邻接关系。可以看到,采用DR/BDR机制后,5台路由器之间只需要建立7个邻接关系就可以了。

    DR和BDR不是人为指定的,而是由本网段中所有的路由器共同选举出来的。路由器接口的DR优先级决定了该接口在选举DR、BDR时所具有的资格。本网段内DR优先级大于0的路由器都可作为"候选人"。

    选举中使用的"选票"就是Hello报文。每台路由器将自己选出的DR写入Hello报文中,发给网段上的每台运行OSPF协议的路由器。当处于同一网段的两台路由器同时宣布自己是DR时,DR优先级高者胜出。如果优先级相等,则Router ID大者胜出。如果一台路由器的优先级为0,则它不会被选举为DR或BDR。

    另外,在使用DR和BDR时需要注意以下几点:

    (1)只有在广播或NBMA类型接口才会选举DR,在点到点或点到多点类型的接口上不需要选举DR;

         所以,为什么两台路由器之间用Serial口相连时,不会选举DR/BDR。

    (2)DR是指某个网段中概念,是针对路由器的接口而言的。某台路由器在一个接口上可能是DR,在另一个接口上有可能是BDR,或者是DR Other。

    (3)若DR、BDR已经选择完毕,当一台新路由器加入后,即使它的DR优先级值最大,也不会立即成为该网段中的DR。

    (4)DR并不一定就是DR优先级最大的路由器;同理,BDR也并不一定就是DR优先级第二大的路由器。

    2.OSPF报文类型

    OSPF有以下5种报文类型:

    (1)HELLO报文(Hello Packet):最常用的一种报文,周期性地发送给本路由器的邻居。内容包括一些定时器的数值、DR、BDR(Backup Designated Router)以及自己已知的邻居。

    (2)DD报文(Database Description Packet):两台路由器进行数据库同步时,用DD报文来描述自己的LSDB,内容包括LSDB中每一条LSA的摘要(摘要是指LSA的HEAD,通过该HEAD可以唯一标识一条LSA)。这样做是为了减少路由器之间传递信息的量,因为LSA的HEAD只占一条LSA的整个数据量的一小部分,根据HEAD,对端路由器就可以判断出是否已有这条LSA。

    (3)LSR报文(Link State Request Packet):两台路由器互相交换过DD报文之后,知道对端的路由器有哪些LSA是本地的LSDB所缺少的,这时需要发送LSR报文向对方请求所需的LSA。内容包括所需要的LSA的摘要。

    (4)LSU报文(Link State Update Packet):用来向对端路由器发送所需要的LSA,内容是多条LSA(全部内容)的集合。

    (5)LSAck报文(Link State Acknowledgment Packet):用来对接收到的LSU报文进行确认。内容是需要确认的LSA的HEAD(一个报文可对多个LSA进行确认)。

     

    3.DR/BDR具体的选举过程


    (1)当路由器与邻居建立双向通信(2-way)后,默认情况下路由器要等待wait time时间(默认40与dead time相同)以接收邻居路由器发过来的hello报文通告DR/BDR,如果在此期间收到BDR的hello报文,或DR的hello报文(无指定BDR),则认为网络中已有DR,无需选举DR,直接使用原有的DR,此时不需要等待wait time时间,可以快速选举BDR(如果没有的话).
     (2)如果路由器没有收到(1)中描述的报文,则等待wait time时间后,宣告自己是DR及BDR(优先级要>0)。
     (3)从所有宣告自己是BDR的路由器列表中,根据优先级和Router ID选举出BDR。如果没有路由器宣告自己是BDR,则优先级最高的为BDR(优先级要>0),否则Router ID最大的为BDR。
     (4)除去(3)中的路由器,如果剩下的路由器中有宣告自己是DR的,则根据优先级与Router ID选举新的DR。(此情况通常出现在两个网络合并的情况下,因为两个网络中原来都有DR,现在要重新选举)。
     (5)如果(4)的情况不存在,则(3)中选举出来的BDR称为DR,重新选举BDR。


    转载于:https://blog.51cto.com/fengye0660/1786529

    展开全文
  • 思科ccie工程师必看——OSPF在广播类型的网络拓扑中DR和BDR的选举。指定路由器(DR): 一个网段上的其他路由器都和指定路由器(DR)构成邻接关系,而不是它们互相之间构成邻接关系。 备份指定路由器(BDR): 当...
  • OSPF-DRBDR的选举及作用 IERS-DRBDR的选举及作用 一、问题引出 在运行OSPF的MA网络中包括广播型NBMA网络会存在两个问题: 1)、在一个有n个路由器的网络中,会形成(n*(n-1))/2邻居关系。 2)、邻居间LSA的泛...
  • OSPF DR/BDR选举的问题

    2008-11-27 16:39:59
    这个状态下,这台路由器都检查每个邻居路由器发送过来HELLO数据包优先级(优先级不参与选举)、DR和BDR字段。如果邻居路由器没有相关DR和BDR字段,那么就等待40S时间,才开始选举DR/BDR,这也是保证选举的...
  • DR/BDR详细选举过程

    千次阅读 2019-03-22 21:45:34
    DR/BDR 1.DR/BDR简介 在广播网NBMA网络中,任意两台路由器之间...为解决这一问题,OSPF协议定义了指定路由器DR(Designated Router),所有路由器都只将信息发送给DR,由DR将网络链路状态发送出去. 如果DR由于某种故障而...
  • OSPF-复习-DRBDR的选举及作用

    千次阅读 2019-01-19 15:25:14
    一、问题引出 在运行OSPF的MA网络中包括广播型NBMA网络会存在两个问题: 1)、在一个有n个路由器的网络中,会形成(n*(n-1))...二、DRBDR的作用 1)、DR(designated router)即指定路由,其负责在MA网络建立...
  • 5. DRBDR选举

    2021-01-26 18:31:11
    2.DRBDR的作用 (1)减少邻接关系。 (2)降低OSPF协议流量。 3.DR简介 DR(Designated Router)即指定路由器,其负责在MA网络建立维护邻接关系并负责LSA的同步。 DR与其他所有路由器形成邻接关系并交换链路...
  • 首先我绘制如下拓扑图,各路由器基本配置图中已经标明。三个路由器都分别加上loopback口,并分别配上...(为了方便ospf区域规划和问题排查,一般将某一个loopback口地址配置为路由router id,ospf启动生效后,...
  • 1.1.8 DR和BDR

    2021-04-24 14:53:56
    在OSPF章节中最后一块就是关于DR和BDR的选举和作用,我们在之前已经说过了,在OSPF中会有一个MA网络,可能是NBMA,或者是BMA,也就是广播多路访问网络,对于MA网络中会存在一些问题,我们来看看存在的问题。...
  • OSPF(二)DRBDR选举

    2020-03-13 15:55:51
    DBRDR与BDR的选举 MA网络中的问题 在运行OSPF的MA网络包括广播型网络NBMA网络,都会存在两个问题 在一个有n个路由器的网络,会形成(n×(n−1))/2个邻接关系。 邻居间LSA的泛洪扩散混乱,相同的LSA会被复制多份,...
  • 指定路由器备份指定路由器(DR/BDR) OSPF协议中在多址网络上有关LSA泛洪扩散存在问题: 1.在构建路由器间邻接关系时,会创建很多不必要LSA。 在多址网络上存在n台路由器,便会构建n(n-1)/2个邻接关系,每台...
  • LSA头部及DRBDR

    2020-08-18 21:50:10
    DRBDR的选举及作用 MA网络中的问题 nx(n-1)/2个邻接关系,管理复杂 重复的LAS泛洪,造成资源浪费 怎样节俭资源 可以选举一个DR(相当于一个组长) 其他路由器之和DR建立邻接关系,降低OSPF协议流量 思考?DR的单...
  • OSPF DR选举的先后

    2011-08-04 23:18:44
    问题的提出:DR和BDR选举的触发事件是什么?一个路由器,在什么情况下会认定DR/BDR选举完成,而DR/BDR选举完成则意味着这个多路访问网络已经稳定,那么换而言之,在什么情况下,一个路由器会认定这个网络已经稳定? ...
  • eNSP-BUG之OSPF中Router ID选举

    千次阅读 2020-04-02 15:21:42
    前言: 本内容主要是华为模拟器Ensp相应BUG进行描述,避免学习者碰到问题对理论...DR和BDR是由OSPFHello报文进行选举的选举是根据端口路由优先级(Router Priority)进行。 如果Router Priority被设置为...
  • 请问,在ospf中,如果选举dr和bdr,那么DRouter只和dr和bdr互换lsa吗?
  • OSPF–开放式最短路径优先协议 无类链路状态协议,带掩码,根据top图自动生成最短路径 组播更新,更新地址224.0.0.5/6...其中ma网路选举DR和BDR,非DR和BDR不能进入下一状态 点到点网络自动形成邻接关系,进入下一状...
  • --------------------我是分割线----------------------OSPF中DR与BDR选举触发事件研究 研究者:付泽群(月光) 指导老师:廖心建(已获得路由交换方向和服务提供商方向双CCIE认证)问题的提出:DR和BDR选举的...
  • 百度系统工程师面试

    2016-07-27 15:14:30
    DR和BDR的选举 放环的原则,SPF算法 对OSPF的宏观理解 BGP相关面试题目 什么时候使用BGP 什么时候BGP同步 BGP同步引起的问题 你对BGP的宏观理解 BGP路由阻尼 常规问题 1.TCP三次握手 2.TCP相关...
  • 帧中继 -使用虚电路进行连接;... Frame Relay NBMA连接引起的路由协议问题: -水平分割(EIGRP) -邻居发现、DR和BDR的选举(OSPF) -广播重叠    配置子接口是一种解决NBMA网络中路由问题的方法:...
  • OSPF路由协议

    2021-03-23 14:09:56
    DR和BDR的选举方法6. OSPF的数据包5个包类型7. OSPF的启动阶段(2个阶段,7步)8. OSPF和RIP比较三. OSPF命令 一. OSPF协议 1. OSPF OSPF–开放的最短路径优先协议 AS是指由同一个路由协议、使用统一路由策略的集合...
  • 网络规划-OSPF

    2021-06-01 21:13:28
    来自多路访问的挑战6.ospf指定路由器DR7.DR和BDR的选举过程8.更改ospf优先级9.传播默认静态路由10.总结二.多区域OSPF1.单区域OSPF遇到的问题2.多区域分的层次3.ospf路由器的类型4.ospf收敛过程5.配置多区域ospf6....
  • OSPF协议

    2021-03-24 14:09:02
    5.DR和BDR的选举方法 6.OSPF度量值和组播地址 7.OSPF与RIP的比较 一、AS路由协议 1.AS概述:是由同一个技术管理机构管理、使用统一选路 策略的一些路由器的集合。 2.按自治系统分类 IGP:内部网关路由协议,运行在AS...

空空如也

空空如也

1 2 3
收藏数 43
精华内容 17
关键字:

dr和bdr的选举问题