精华内容
下载资源
问答
  • 三层交换机实现不同vlan网络互通,192.168.1.0网段,192.168.2.0网段......
  • 实验要求: 拓扑结构如图,要求PC0与PC1能相互ping通,PC2与PC3能相互ping通。 实验提示: 三层交换机SW1要启用路由功能,对应端口要启用三层功能。... SW1交换机连接PC的端口要... SW2交换机划分VLAN,给虚拟V...

    实验要求:

    拓扑结构如图,要求PC0与PC1能相互ping通,PC2与PC3能相互ping通。

    实验提示:

    1. 三层交换机SW1要启用路由功能,对应端口要启用三层功能。
    2. SW1交换机连接PC的端口要设置IP地址,与所连接的PC在同一网段。查看交换机路由表确认路由信息。
    3. PC的网关要设置为SW1对应交换机端口的IP。
    4. 三层交换机SW2要启用路由功能。
    5. SW2交换机划分VLAN,给虚拟VLAN端口设置IP地址,与所连接的PC在同一网段。查看交换机路由表确认路由信息。
    6. PC的网关要设置为SW2对应虚拟VLAN端口的IP。

     

    交换机1配置命令:

    Switch>en

    Switch#conf t

    Switch(config)#ip routing

    Switch(config)#hostname sw1

    sw1(config)#int fa0/1

    sw1(config-if)#no switchport

    sw1(config-if)#ip add 10.0.0.1 255.255.255.0       //此处设置的IP 即为PC0的网关

    sw1(config-if)#exit

    sw1(config)#int fa0/2    

    sw1(config-if)#no switchport

    sw1(config-if)#ip add 10.0.1.1 255.255.255.0      //此处设置的IP 即为PC1的网关

    sw1(config-if)#exit

    sw1(config)#exit

    sw1#show ip route

     

    PC0

    IP Address       10.0.0.5

    Subnet Mask     255.255.255.0

    Default Gateway  10.0.0.1

     

    PC1

    IP Address       10.0.1.5

    Subnet Mask     255.255.255.0

    Default Gateway  10.0.1.1

     

    Ping 测试:

    柠檬汽水橘子汁

     

     

    交换机2配置命令:

    Switch>en

    Switch#conf t

    Switch(config)#hostname sw2

    sw2(config)#ip routing

    sw2(config)#vlan 10

    sw2(config-vlan)#exit

    sw2(config)#vlan 20

    sw2(config-vlan)#exit

    sw2(config)#int fa0/1

    sw2(config-if)#switchport mode access

    sw2(config-if)#switchport access vlan 10

    sw2(config-if)#exit

    sw2(config)#int fa0/2

    sw2(config-if)#switchport mode access      

    sw2(config-if)#switchport access vlan 20

    sw2(config-if)#exit

    sw2(config)#int vlan 10

    sw2(config-if)#ip add 10.0.0.1 255.255.255.0

    sw2(config-if)#no shut

    sw2(config-if)#exit

    sw2(config)#int vlan 20

    sw2(config-if)#

    sw2(config-if)#ip add 10.0.1.1 255.255.255.0

    sw2(config-if)#no shut

    sw2(config-if)#exit

    sw2(config)#exit

    sw2#show ip route

     

    PC2

    IP Address       10.0.0.2

    Subnet Mask     255.255.255.0

    Default Gateway  10.0.0.1

     

    PC3

    IP Address       10.0.1.2

    Subnet Mask     255.255.255.0

    Default Gateway  10.0.1.1

     

     

    ping验证:

    柠檬汽水橘子汁

     

    补充:

    二层交换机和三层交换机有什么区别?

    1.工作层级不同:二层交换机工作在数据链路层,三层交换机工作在网络层,三层交换机不仅实现了数据包的高速转发,还可以根据不同网络状况达到最优网络性能。

    2.原理不同:二层交换机的原理是当交换机从某个端口收到一个数据包,它会先读取包中的源MAC地址,再去读取包中的目的MAC地址,并在地址表中查找对应的端口,如表中有和目的MAC地址对应的端口,就把数据包直接复制到这个端口上。三层交换机的原理比较简单,就是一次路由多次交换,通俗来说就是第一次进行源到目的的路由,三层交换机会将此数据转到二层,那么下次无论是目的到源还是源到目的都可以进行快速交换。

    3.功能不同:二层交换机基于MAC地址访问,只做数据的转发,并且不能配置IP地址,而三层交换机将二层交换技术和三层转发功能结合在一起,也就是说三层交换机在二层交换机的基础上增加了路由功能,可配置不同vlan的IP地址,vlan之间可通过三层路由实现不同vlan之间通讯。

    4.应用不同:二层交换机主要用于网络接入层和汇聚层,而三层交换机主要用于网络核心层,但是也存在少部分三层交换机用于汇聚层的现象。

    (参考:https://baijiahao.baidu.com/s?id=1608045765713172108&wfr=spider&for=pc

    展开全文
  • 实验任务: 不同vlan,不同网段实现互通; 路由AR11用默认路由配置; ...LSW8实现三层交换机功能;...配置思路:1.将LSW8看成一个路由器,LSW8下面连接(LSW7和LSW6)的设备都看一个pc...2.LSW8是三层交换机,先不看...

    实验任务:

    1. 不同vlan,不同网段实现互通;

    2. 路由AR11用默认路由配置;

    3. LSW8实现三层交换机功能;

    如下华为拓扑图:

    图片1.png

    配置思路:1.将LSW8看成一个路由器,LSW8下面连接(LSW7和LSW6)的设备都看一个pc,这样就成两个路由互联,下面各接一个pc这样只需让左边的PC7和右边的PC8互通即可搞定:如下图:

    图片2.png

    2.LSW8是三层交换机,先不看192.168.6.0网段和192.168.7.0网段;只搞定vlan2到vlan6,如

    图片3.png

    1. 验证和测试vlan2到vlan6互通;:

    Ping 通pc9到pc14的互通

    Display ip interface brief 查看个端口的ip和vlan的配置详情

    1. 按照思路一,将vlan2到vlan6的网段ping通192.168.7.0网段

    配置步骤:

    1. 进交换机,创建vlan2到vlan6;进入各自接口,配置端口模式,并加入vlan ;LSW7改名为SW1 ,LSW6改名为SW2 LSW8改名为R1

    LSW7配置 并改名SW1 如下图:

    正在上传…image.png

    Sw6配置并改名为SW2

    image.png

    image.png

    2.配置AR11,实现双路由之间网段的互通 如图:

    正在上传…

    image.png

    3.配置sw8 上的路由下一跳:如图:

    image.png

    1. 配置各pc的ip地址,子网掩码,网关

    2. 验证与测试连通性

      6.保存华为设备的配置(在用户视图输入命令:save ~ y 即可

    结果验证:

    1.验证R1路由吓一跳路径:用display iproute-table 命令 【默认路由配置】如图:

    image.png

    2.验证R2 吓一跳 如图

    image.png

    1. 验证各个设备的配置(在用户视图模式:用命令:display ip interface brief【查看各设备接口详细信息;(主要用来查看自己配置的端口是否正确)

    2. 验证trunk模式和开启状态 命令:display port vlan 如图

    image.png

    1. 测试连通性:1)直接在pc上ping不同网段的ip ;验证不同网段的连通性

    2)直接在pc上ping本地网关;验证本地路由口是否通

    Ping自己ip 验证自己网卡和驱动是否正常

    实验总结:

    1. 华为所有交换机设备不能直接配ip,需要用虚拟端口vlan

    2. 多网段时,为节省接口,共用一接口时 ,两段都必须配成trunk模式并要允许所有vlan 通过

    和路由相连的那个三层交换机必须陪vlan 来实现多网段的互通,路由上的vlan不能直接给陪ip,要直接给路由那个相连的断楼直接陪ip即可,如果将ip直接陪在路由vlan上,会出现 192.168.7.0网段到别的网断不通!

    展开全文
  • 三层交换机的路由功能。 网关的设置。 交换机1 Switch>en Switch#conf t Switch(config)#hostname sw1 sw1(config)#vlan 10 sw1(config-vlan)#exit sw1(config)#vlan 20 sw...

    实验要求:所有PC之间都能相互ping通。

     

    实验提示:

    1. 交换机之间的中继功能。
    2. 三层交换机的路由功能。
    3. 网关的设置。

    交换机1

    Switch>en

    Switch#conf t

    Switch(config)#hostname sw1

    sw1(config)#vlan 10

    sw1(config-vlan)#exit

    sw1(config)#vlan 20

    sw1(config-vlan)#exit

     

    sw1(config)#int fa0/1

    sw1(config-if)#switchport mode access

    sw1(config-if)#switchport access vlan 10

    sw1(config-if)#exit

     

    sw1(config)#int fa0/2

    sw1(config-if)#switchport mode access

    sw1(config-if)#switchport access vlan 20

    sw1(config-if)#exit

     

    sw1(config)#int fa0/3

    sw1(config-if)#switchport trunk encapsulation dot1q

    sw1(config-if)#switchport mode trunk

    sw1(config-if)#exit

     

    sw1(config)#ip routing                  //开启三层路由

     

    sw1(config)#int vlan 10

    sw1(config-if)#ip add 10.0.0.1 255.255.255.0

    sw1(config-if)#exit

     

    sw1(config)#int vlan 20

    sw1(config-if)#ip add 20.0.0.1 255.255.255.0

    sw1(config-if)#exit

    交换机2

    Switch>en

    Switch#conf t

    Switch(config)#hostname sw2

    sw2(config)#vlan 10

    sw2(config-vlan)#exit

    sw2(config)#vlan 20

    sw2(config-vlan)#exit

     

    sw2(config)#int fa0/1

    sw2(config-if)#switchport mode access

    sw2(config-if)#switchport access vlan 10

    sw2(config-if)#exit

     

    sw2(config)#int fa0/2

    sw2(config-if)#switchport mode access

    sw2(config-if)#switchport access vlan 20

    sw2(config-if)#exit

     

    sw2(config)#int fa0/3

    sw2(config-if)#switchport trunk encapsulation dot1q

    sw2(config-if)#switchport mode trunk

    sw2(config-if)#exit

     

    sw2(config)#ip routing         //开启三层路由

     

    sw2(config)#int vlan 10

    sw2(config-if)#ip add 10.0.0.1 255.255.255.0

    sw2(config-if)#exit

     

    sw2(config)#int vlan 20

    sw2(config-if)#ip add 20.0.0.1 255.255.255.0

    sw2(config-if)#exit

     

    PC0

    IP Address          10.0.0.2

    Subnet Mask        255.255.255.0

    Default Gateway     10.0.0.1

    PC1

    IP Address          10.0.0.3

    Subnet Mask        255.255.255.0

    Default Gateway     10.0.0.1

     PC2

    IP Address          20.0.0.2

    Subnet Mask        255.255.255.0

    Default Gateway     20.0.0.1

     PC3

    IP Address          20.0.0.3

    Subnet Mask        255.255.255.0

    Default Gateway     20.0.0.1

     

    验证:

     

     

    展开全文
  • 很久很久之前搞Linux端口转发时,借了一台三层交换机,我拿到手还没拆包装箱。不知道是不是因为工作上的这个原因而买的。不过后来实现的端口转发和三层交换机完全不搭边,就...这次要做的是将三层交换机划分3个v...

    很久很久之前搞Linux端口转发时,借了一台三层交换机,我拿到手还没拆包装箱。不知道是不是因为工作上的这个原因而买的。不过后来实现的端口转发和三层交换机完全不搭边,就不了了之了。现在领导安排我查查广播风暴的事情,在同一网段里测试过了,就想在不同网段里试试,于是又借了这一台。这次是认真学习了一些配置命令,不过网上大把这类的资料,这里根据资料结合自己的实践,记录一下。
    这次要做的是将三层交换机划分3个vlan,分别是192.168.1、2、3段。

    <H3C>sys
    vlan 10:创建vlan并进入,加入1~8
    [H3C]vlan 10  
    [H3C-vlan10]port e1/0/1 to e1/0/8
    [H3C-vlan10]q

    创建vlan 20,加入9~16
    [H3C]vlan 20
    [H3C-vlan20]port e1/0/9 to e1/0/16
    [H3C-vlan20]q

    创建vlan 30,加入17~24
    [H3C]vlan 30
    [H3C-vlan30]port e1/0/17 to e1/0/24
    [H3C-vlan30]q

    显示有哪些vlan
    [H3C]dis vlan
    Total 4 VLAN exist(s).
    The following VLANs exist:
      1(default), 10, 20, 30,


    每个VLAN分别添加IP、子网掩码:
    [H3C]int vlan 10
    [H3C-Vlan-interface10]ip addr 192.168.1.254 255.255.255.0
    [H3C-Vlan-interface10]quit

    [H3C]int vlan 20
    [H3C-Vlan-interface20]ip addr 192.168.2.254 255.255.255.0
    [H3C-Vlan-interface20]quit

    [H3C]int vlan 30                       
    [H3C-Vlan-interface30]ip addr 192.168.3.254 255.255.255.0
    [H3C-Vlan-interface30]quit                              
    [H3C]

    这里添加的vlan的IP,结合后面的验证,是接入设备的网关地址。

    在接入vlan的设备上设置好IP和网关,信息如下:
    root@localhost:~# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         192.168.1.254   0.0.0.0         UG    0      0        0 eth0
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    root@localhost:~# ifconfig eth0
    eth0      Link encap:Ethernet  HWaddr 88:55:33:44:11:88 
              inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: ff90::3411:89ff:fe0d:f987/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:939 errors:0 dropped:0 overruns:0 frame:0
              TX packets:277 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:86165 (86.1 KB)  TX bytes:47595 (47.5 KB)
              Memory:90400000-9041ffff

    在该设备上ping vlan20中的设备,是ping得通的,抓包信息如下:
    root@localhost:~# tcpdump net 192.168.2.101
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
    11:28:55.413927 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 699346371:699346567, ack 3447371143, win 255, length 196
    11:28:55.413972 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 196:248, ack 1, win 255, length 52
    11:29:04.427973 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 3648:3908, ack 1, win 255, length 260
    11:29:06.430510 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 4168:4428, ack 1, win 255, length 260
    11:29:06.501987 IP 192.168.2.101 > 192.168.1.100: ICMP echo request, id 1, seq 108, length 40
    11:29:06.502120 IP 192.168.1.100 > 192.168.2.101: ICMP echo reply, id 1, seq 108, length 40
    11:29:06.630739 IP 192.168.2.101.59431 > 192.168.1.100.ssh: Flags [.], ack 4428, win 251, length 0
    11:29:07.431587 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 4428:4592, ack 1, win 255, length 164
    11:29:07.431637 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 4592:4740, ack 1, win 255, length 148
    11:29:07.432016 IP 192.168.1.100.ssh > 192.168.2.101.59431: Flags [P.], seq 4740:5020, ack 1, win 255, length 280
    11:29:07.504812 IP 192.168.2.101 > 192.168.1.100: ICMP echo request, id 1, seq 109, length 40
    11:29:07.504935 IP 192.168.1.100 > 192.168.2.101: ICMP echo reply, id 1, seq 109, length 40

    在该交换机上搞个环路,能检测到有冲突:
    %Jan  1 07:12:31:498 2010 H3C ARP/5/ARP_DUPLICATE_IPADDR_DETECT: Detected an IP address conflict. The device with MAC address f0fe-f1fa-5cfe1 connected to Ethernet1/0/5 in VLAN 10 and the device with MAC address ffde-f11c-3414 connected to Ethernet1/0/3 in VLAN 10 are using the same IP address 192.168.1.101.
    %Jan  1 07:12:31:888 2010 H3C ARP/5/ARP_DUPLICATE_IPADDR_DETECT: Detected an IP address conflict. The device with MAC address f0de-f1eb-5e31 connected to Ethernet1/0/3 in VLAN 10 and the device with MAC address ffde-f1eb-1378 connected to Ethernet1/0/5 in VLAN 10 are using the same IP address 192.168.1.101.
    %Jan  1 07:12:32:269 2010 H3C ARP/5/ARP_DUPLICATE_IPADDR_DETECT: Detected an IP address conflict. The device with MAC address f0ee-f1eb-5e31 connected to Ethernet1/0/5 in VLAN 10 and the de
    ---------------------
    作者:李迟
    来源:CSDN
    原文:https://blog.csdn.net/subfate/article/details/44901337
    版权声明:本文为博主原创文章,转载请附上博文链接!

    转载于:https://www.cnblogs.com/hujinbing/p/10425014.html

    展开全文
  • 三层交换机不同vlan之间默认是互通的,两次交换机不同vlan是隔离的。 vlan IP:就是定义一个vlan下所有机器的网关地址,该vlan下的机器网关必须是这个IP。 接口:就是交换机后面可以插网线的端口,可以设置为...
  • 这是我的网络拓扑图,利用三层交换机划分vlan,Switch2对应vlan2,Switch3对应vlan3,Switch4对应vlan4,无线路由器对应vlan5,然后用路由器实现vlan之间路由,但是我在二层交换机上未作配置,所以pc1和pc2能相互...
  • 创建vlan vlan batch 10 20 30 给vlan配置IP interface Vlanif10 ip address 192.168.10.254 255.255.255.0 interface Vlanif20 ip address 192.168.20.254 255.255.255.0 interface Vlanif30 ip address 192....
  • 思科设备三层交换机实践不同vlan之间的通信先准备四台PC机、四台二层交换机、一台三层交换机、一台路由器、一台服务器PC1 PC2 PC3 PC4 计算机SWI SW2 SW3 SW4 交换机MSW1 多层交换机第一步:先配置四台PC机iP 给PC机...
  • 【实训任务】1.将拓扑中PC1、PC5、PC3...2.通过配置三层交换机实现跨VLAN的互访。【相关知识】三层交换有时又称为路由交换、多层交换。三层交换具有路由功能,能够识别网络层的信息,将IP地址信息用于网络路径选...
  • 前面一篇已经和大家分享了交换机为什么要划分VLAN了,总的来说VLAN最大的好处就是可以隔离冲突域和广播域,试想,如果一个局域网内有上百台主机,如果一旦产生广播风暴,那么这个网络就会彻底瘫痪。可以通过VLAN划分...
  • 路由在三层上运行,其中根据目标 IP 地址将数据包发送到特定的下一跳 IP 地址。相同二层网络中的设备不需要路由即可到达本地对等点。所需要的是可以通过地址解析协议 (ARP) 解析的目标 MAC 地址,如下图所示:在此例...
  • 三层交换机VLAN划分

    2019-07-18 10:44:00
    SW1(config - vlan)#vlan 20 Sw2(config - vlan)#vlan 20 SW3(config - vlan)#vlan 30 SW1(config - vlan)#name shicahng SW2(config - vlan)#name shicahng SW3(config - vlan)#exit SW1(config - vlan)#vlan ...
  • 交换机划分VLAN

    2016-12-31 16:44:05
    交换机划分VLAN配置 在交换机1上 在交换机2上 在pc1上测试 利用三层交换机实现VLAN间路由 在二层交换机上 在三层交换机上 在pc3上进行测试 ping 192.168.1.2 ping 192.168....
  • 案例6:三层交换机基本配置 1 案例1:划分VLAN 1.1 问题 在交换机上创建以下VLAN,按照拓扑图-1将端口加入到指定的VLAN并配置服务器IP地址,实现同VLAN主机的通信 图-1 1.2 步骤 实现此案例需要按照如下...
  • 【实验名称】利用三层交换机实现VLAN间路由【实验目的】掌握如何在三层...【实验设备】三层交换机一台二层交换机一台【实验步骤】给三层交换机和二层交换机划分VLAN添加端口并设置trunk在三层交换机上配置SVI端口...
  • 1.三层交换机创建vlan,开启svi接口 2、交换机做vlan划分,pc0,pc1,pc2分别属于vlan2,vlan3,vlan4 …在接口f0/4做trunk口 3、将pc配置IP 4、最终结果达到三台pc通信 二层交换机配置: 三层交换机配置: 5、最终...
  • 【实验名称】利用三层交换机实现VLAN间路由【实验目的】掌握如何在三层交换机...【实验设备】三层交换机一台【实验步骤】步骤1 在三层交换机划分VLAN添加端口,并设置Trunk。步骤2 在三层交换机上配置svi端口。验...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 941
精华内容 376
关键字:

三层交换机划分vlan