精华内容
下载资源
问答
  • CISCO路由器配置命令详解及实例,非常实用的文档
  • 一般来说,可以用5种方式来设置路由器: 1.Console口接终端或运行终端仿真软件的微机; 2.AUX口接MODEM,通过电话线与远方的终端或运行终端仿真软件的微机相连; 3.通过Ethernet上的TFTP服务器; 4.通过Ethernet...
  • cisco路由器常用的命令,还有几个实验供学习之用!
  • 思科路由器配置命令(一)

    千次阅读 2020-09-29 16:01:46
    一、路由器基本配置命令 R1>enable 进入特权模式 R1#disable 退出特权模式 R1> R1#configure terminal 进入全局配置命令 R1(config)#no ip domain-lookup 关闭域名解析 R1(config)#hostname SW1 ...

    一、路由器基本配置命令

    R1>enable 进入特权模式
    R1#disable 退出特权模式
    R1>
    R1#configure terminal 进入全局配置命令
    R1(config)#no ip domain-lookup 关闭域名解析
    R1(config)#hostname SW1 更改主机名为SW1
    R1(config)#enable password CISCO 配置进入特权模式的密码
    R1(config)#interface Ethernet0/1 进入e0/1接口
    R1(config-if)#no shutdown 开启接口及协议
    R1(config-if)#shutdown 关闭接口
    R1(config)#end 返回用户模式
    R1#show ip interface brief 简要查看接口状态
    R1#show running-config 查看已配置信息
    R1#write 保存配置

    二、地址配置

    2.1、静态地址配置
    R1(config)#interface Ethernet0/1
    R1(config-if)#ip address 172.1.0.129 255.255.255.192 为接口配置ip地址
    R1(config-if)#ipv6 address 2012::1/64 在接口上配置ipv6地址
    2.2、动态地址配置
    DHCPv4配置
    R1:
    Router(config)#hostname dhcp 主机名dhcp
    dhcp(config)#no ip dhcp conflict logging 关闭dhcp冲突日志
    dhcp(config) ip dhcp pool dhcp-pool 定义一个dhcp地址池dhcp-pool
    dhcp(dhcp-config)# network 202.112.12.0 255.255.255.0
    DHCP服务器要分配的网络和掩码
    dhcp(dhcp-config)# default-router 202.112.12.1
    默认网关,这个要和对于与相应网络相连接口的ip地址相同
    dhcp(dhcp-config)# dns-server 202.112.12.1 DNS服务器
    dhcp(dhcp-config)#exit
    dhcp(config)#ip dhcp excluded-address 202.112.12.1 202.112.12.10
    排除地址段,不加入分配
    dhcp(config)#interface Ethernet0/0 对应上面的网关接口,下联需要地址的设备
    dhcp(config-if)#ip address 202.112.12.1 255.255.255.0
    dhcp(config-if)#no showdown

    vpc:
    VPCS>ip dhcp 开启dhcp配置
    VPCS>show 查看vps IP地址
    Show ip dhcp pool R1上查看dhcp的地址池信息
    Show ip dhcp binding 查看dhcp地址的绑定情况

    DHCPv6配置

    1. DHCPv6无状态自动配置
      R1:
      Router(config)#hostname dhcp 主机名dhcp
      dhcp(config)#ipv6 unicast-routing
      dhcp(config) ipv6 dhcp pool dhcpv6 定义一个dhcp地址池,名字叫做dhcpv6
      dhcp(dhcp-config)#dns-server 2001::2 定义ipv6的dns服务器
      dhcp(dhcp-config)#exit
      dhcp(config)#interface Ethernet0/0 进入需要分配dhcp地址的接口
      dhcp(config-if)# ipv6 address 2023::2/64
      dhcp(config-if)# ipv6 dhcp server dhcpv6 选择dhcp的服务端
      dhcp(config-if)# ipv6 nd other-config-flag —O置位
      dhcp(config-if)#no showdown

    vpc
    VPCS>ip auto 开启dhcpv6配置
    VPCS>show 查看vps IP地址

    1. DHCPv6有状态自动配置
      R1:
      Router(config)#hostname dhcp 主机名dhcp
      dhcp(config)#ipv6 unicast-routing 开启ipv6单播
      dhcp(config) ipv6 dhcp pool dhcpv6 定义一个dhcp地址池,名字叫做dhcpv6
      dhcp(dhcp-config)#dns-server 2001::2 定义ipv6的dns服务器
      dhcp(dhcp-config)# address prefix 2023:2323::/64 定义地址前缀
      dhcp(dhcp-config)#exit
      dhcp(config)#interface Ethernet0/0 进入需要分配dhcp地址的接口
      dhcp(config-if)# ipv6 address 2023::2323::1/64
      dhcp(config-if)# ipv6 dhcp server dhcpv6 选择dhcp的服务端
      dhcp(config-if)#ipv6 nd other-config-flag —O置位
      dhcp(config-if)# ipv6 nd managed-config-flag —M置位
      dhcp(config-if)#no showdown

    vpc
    VPCS>ip auto 开启dhcpv6配置
    VPCS>show 查看vps的 IP地址

    Ipv6无状态地址获取

    R1(config)#ipv6 unicast-routing 开启ipv6单播路由
    R1(config)#interface e0/0
    R1(config-if)#ipv6 enable 启用ipv6
    R1(config-if)#ipv6 address 2012::1/64 配置接口地址
    R1(config-if)#no shutdown 打开接口

    Router#conf t
    Router(config)#int e0/0
    Router(config-if)#ipv6 address autoconfig 接口自动获取ipv6地址
    Router(config-if)#no shutdown
    Router(config-if)#end
    Router# show ipv6 interface ethernet 0/0
    IPv6 is enabled, link-local address is FE80::A8BB:CCFF:FE00:A100
    No Virtual link-local address(es):
    Stateless address autoconfig enabled
    Global unicast address(es):
    2020::A8BB:CCFF:FE00:A100, subnet is 2020::/64 [EUI/CAL/PRE] //红标为无状态获取的地址
    valid lifetime 2591894 preferred lifetime 604694
    Joined group address(es):
    FF02::1
    FF02::1:FF00:A100
    MTU is 1500 bytes
    ICMP error messages limited to one every 100 milliseconds
    ICMP redirects are enabled
    ICMP unreachables are sent
    ND DAD is enabled, number of DAD attempts: 1
    ND reachable time is 30000 milliseconds (using 30000)
    ND NS retransmit interval is 1000 milliseconds
    Default router is FE80::A8BB:CCFF:FE00:9100 on Ethernet0/0
    Router#

    三、静态路由配置

    Ipv4:
    R1(config)# ip route 10.10.10.0 255.255.255.128 192.168.1.1(目标网段IP地址 目标子网掩码 下一路由器接口ip地址)
    R1(config)# ip route 10.10.10.0 255.255.255.128 e0/0 (目标网段IP地址 出接口)

    Ipv6:
    R1(config)#ipv6 route 2012::/64 2021:2a2a::2 (2012::/64表示目标网段IPv6网段 2021:2a2a::2表示下一条接口ipv6地址)
    R1(config)#ipv6 route 2012::/64 e0/0 (目标网段IPv6地址 出接口)

    四、telnet配置

    4.1、路由器添加用户
    配置CISCO路由器上登录账号、口令、账号级别,如下所示,账号名abc、口令为abc123、账号级别为15(最高级别)
    R1#configure terminal
    R1(config)#username abc privilege 15 secret abc123 建立一个用户用于登录
    4.2、远程登录
    1)配置CISCO路由器远程登录认证机制,如下所示,配置路由器本地用户登录
    R1(config)#line vty 0 4 创建5个线程用于登录管理
    R1(config-line)#login local 使用本地验证
    R1(config-line)#transport input telnet 启用telnet协议登录
    R1(config-line)#end

    2)不添加用户且使用telnet登录配置
    R1(config)#enable password abc
    R1(config)#line vty 0 4
    R1(config-line)#password abc 设置登录密码
    R1(config-line)#login 开启验证
    R1(config-line)#transport input telnet 启用telnet协议登录
    R1(config-line)#end

    展开全文
  • 特权模式:enable Router1 # show running-config Router1 # show ip route Router # show ip interface brief Switch # show vlan Switch # show ip ...配置模式:configure terminal console密码...

    特权模式:enable

    Router1 # show running-config

    Router1 # show ip route

    Router # show ip interface brief

     

    Switch # show vlan

    Switch # show ip interface

     

    配置模式:configure terminal

    console密码、enable密码、vty登录密码

    1)  console密码

    SW2(config)#line console 0
    SW2(config-line)#password cisco
    SW2(config-line)#login //启用密码认证,默认没有,需要加上去
    SW2(config-line)#login local //本地开启用户认证
    SW2(config)username xiao password fan //创建本地用户
    SW2(config)username xiao privilege 15 password fan //以该用户登入设备后直接进入特权模式
    说明---对用户的权限定义0-15级,最高为15,任何命令都可操作
    SW2(config)service password-encryption //明文密码加密

    2)  特权模式密码(设置全局密码)
    SW2>enadle
    SW2(config)#configure terminal

    1.(config)#enable password en cisco←密码encisco 
    2.(config)#enable secret jmcisco←密码jmcisco  #2个同时设,只有secret 有效,因为其优先极高
    (config)#login  <--一定要加,表示启用
    全局密码设置完成 
    exitenable password xiaofan 优先级低
    enable secret cisco  优先级高

    思科加密方式:
    0 显示的是密码本身
    7 密文加密,容易破解  
    5 复杂密文加密

    3)  虚拟通道密码

    SW2>enadle
    SW2(config)#configure terminal
    SW2(config)#line vty 0 4
    SW2(config-line)#password telnetcisco
    SW2(config-line)#login //默认就有
    SW2(config-line)#login local //开启本地用户认证,使用本地用户数据库
    SW2(config-line)no login //不需要密码就可登陆

    路由类(静态路由和动态路由)

    静态路由:ip route address subnet-mask address
    默认路由ip route 0.0.0.0 0.0.0.0 address
    动态路由:rip v2

    * Router1配置RIP协议

    Router(config)# router rip !开启RIP协议进程

    Router(config-router)# network 172.16.1.0  !申明本设备的直连网段

    Router(config-router)# network 172.16.2.0

    Router(config-router)# version 2

    Router(config-router)# no auto-summary !关闭路由信息的自动汇总功能

     

    * 三层交换机配置RIP协议

    Switch (config)# router rip !开启RIP协议进程

    Switch (config-router)# network 172.16.1.0  !申明本设备的直连网段

    Switch (config-router)# network 172.16.5.0

    Switch (config-router)# version 2

    vlan和trunk

        *三层交换机基本配置

    Switch# configure terminal

    Switch (config)# vlan 10

    Switch (config-vlan)# exit

    Switch (config)# vlan 50

    Switch (config-vlan)# exit

    Switch (config)# interface f0/1

    Switch (config-if)# switchport access vlan 10

    Switch (config-if)# exit

    Switch (config)# interface f0/5

    Switch (config-if)# switchport access vlan 50

    Switch (config-if)# exit

    Switch (config)# interface vlan 10 !创建VLAN虚接口,并配置IP

    Switch (config-if)# ip address 172.16.1.2255.255.255.0

    Switch (config-if)# no shutdown

    Switch (config-if)# exit

    Switch (config)# interface vlan 50 !创建VLAN虚接口,并配置IP

    Switch (config-if)# no shutdown

    Switch (config-if)# exit

    trunk在sw1、sw2之间使用

    sw1(config)#interface f0/0                        进入要设置的端口(f0/0)
    sw1(config-if)#switchport mode trunk                将端口进行trunk设置
    sw1(config-if)#no shutdown                         激活此端口

     

    访问控制(ACL)

    标准访问列表配置实例:
        
        R1(config)#access-list 10 deny 192.168.2.0 0.0.0.255
        
        R1(config)#access-list 10 permit any
        
        R1(config)#int fa0/0.1
        
        R1(config-subif)#ip access-group 10 out
      

     扩展访问控制列表配置实例:
        
        R2(config)#access-list 110 deny tcp any host 192.168.1.12 eq www
        
        R2(config)#access-list 110 deny tcp any host 192.168.1.12 eq ftp
        
        R2(config)#int fa0/0
        
        R2(config-if)#ip access-group 110 out
     上面配置的含义是拒绝访问192.168.1.12的www和ftp服务


    access-list 101 permit tcp any 172.16.4.13 0.0.0.0 eq www  //设置ACL101,容许源地址为任意IP,目的地址为172.16.4.13主机的80端口即WWW服务。由于CISCO默认添加DENY ANY的命令,所以ACL只写此一句即可。
        

     NAT

    R1配置:

    R1(config)#inter f0/0

    R1(config-if)#ip nat inside     //指定内部接口

    R1(config-if)#inter f0/1

    R1(config-if)#ip nat outside   //指定外部接口

    R1(config-if)#exit

    R1(config)#ip nat inside source static 192.168.1.10202.106.1.1  //配置静态NAT使192.168.1.10访问外网转换为202.106.1.1这个公网地址

    在R2上做一条回程路由

    R2(config)#ip route 202.106.1.1 255.255.255.255 12.0.0.1

     

    转载于:https://www.cnblogs.com/zyh0430/p/11407435.html

    展开全文
  • Cisco路由器配置命令全集,很全,比较实用的Cisco路由器配置手册。
  • R1(config-router)# router-id 1.1.1.1 指定路由器id号,区分路由器用,id唯一 R1(config-router)#network 12.1.1.0 255.255.255.0 area 0 将网段宣告进ospf骨干区域0中,在此区域中的所有建立起邻居的都能学到此条...

    一、 OSPF路由配置
    1、 实验拓扑

    2、基本配置
    R1(config)#router ospf 100 进入ospf配置,100为进程号,本地有效
    1~65535中
    R1(config-router)# router-id 1.1.1.1 指定路由器id号,区分路由器用,id唯一
    R1(config-router)#network 12.1.1.0 255.255.255.0 area 0
    将网段宣告进ospf骨干区域0中,在此区域中的所有建立起邻居的都能学到此条路由条目
    R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
    网段宣告可以选网络掩码,也可以使用反码,高版本有效,任选其一
    R1(config)# interface e0/0
    R1(config-if)# ip ospf priority 0 当前接口不参与到dr选举
    R1# sh ip protocols 查看当前ip路由协议信息
    R1#show ip route 查看路由表
    R1#show ip ospf neighbor 查看ospf的邻居关系
    R1#sh ip ospf database 查看ospf的数据信息
    R1#sh ip ospf interface e0/0 查看接口下的ospf信息

    R2(config)#router ospf 100
    R2(config-router)# router-id 2.2.2.2
    R2(config-router)#network 12.1.1.0 0.0.0.255 area 0
    R2(config-router)#network 23.1.1.0 0.0.0.255 area 0
    R2(config-router)#network 2.2.2.0 0.0.0.255 area 0
    R2(config-router)# default-information originate
    向OSPF区域中注入一条默认路由,路由器上需要存在一条默认路由,否则命令不生效。最后可以选参数‘always’。

    R3(config)#router ospf 100
    R3(config-router)# router-id 3.3.3.3
    R3(config-router)#network 23.1.1.0 0.0.0.255 area 0
    R3(config-router)#network 34.1.1.0 0.0.0.255 area 0
    R3(config-router)#network 3.3.3.0 0.0.0.255 area 0
    R3(config)# interface e0/0
    R3(config-if)# ip ospf priority 0 当前接口不参与到dr选举

    3、 ospf的路由引入bgp
    R1(config)#router ospf 100
    R1(config-router)#redistribute bgp 65511 subnets 65511表示bgp的as号

    二、BGP路由配置
    1、IBGP基本配置

    R1(config)# router bgp 64511						bgp的as号
    R1(config-router)#no auto-summary					关闭自动汇总
    R1(config-router)#bgp router-id 1.1.1.1				配置bgp路由器id
    R1(config-router)#neighbor 12.1.1.2 remote-as 64512	指定邻居路由器所在as
    R1(config-router)#network 1.1.1.0 mask 255.255.255.0  宣告网络进bgp
    
    R2(config)# router bgp 64511
    R2(config-router)#no auto-summary					关闭自动汇总
    R2(config-router)#bgp router-id 2.2.2.2				配置bgp路由器id
    R2(config-router)#neighbor 12.1.1.1 remote-as 64512
    R2(config-router)#neighbor 23.1.1.2 remote-as 64512
    
    R3(config)# router bgp 64511
    R3(config-router)#no auto-summary					关闭自动汇总
    R3(config-router)#bgp route-id 3.3.3.3				配置bgp路由器id
    R3(config-router)#neighbor 23.1.1.1 remote-as 64512
    R3(config-router)#network 3.3.3.0 mask 255.255.255.0  宣告网络进bgp
    

    2、 EBGP基本配置

    R3和R4之间运行EBGP
    R3(config)# router bgp 64511
    R3(config-router)#no auto-summary 关闭自动汇总
    R3(config-router)#bgp router-id 3.3.3.3 配置bgp路由器id
    R3(config-router)#neighbor 23.1.1.1 remote-as 64511 指定IBGP邻居
    R3(config-router)#neighbor 34.1.1.1 remote-as 64512 指定R4所在as号
    R3(config-router)#neighbor 23.1.1.2 next-hop-self 配置下一跳为自己,对从EBGP邻居传入的路由,在通告给IBGP邻居同时,强迫路由器通告自己是发送BGP更新的下一跳。

    R4(config)# router bgp 64512
    R4(config-router)#bgp route-id 4.4.4.4
    R4(config-router)#redistribute connected 宣告直连路由进bgp
    R4(config-router)#neighbor 34.1.1.1 remote-as 64511 指定R3建立邻居关系
    R4(config-router)# network 4.4.4.0 mask 255.255.255.0

    3、 BGP引入路由并过滤

    R1(config)# router bgp 64511 bgp的as号
    R1(config-router)#no auto-summary 关闭自动汇总
    R1(config-router)#bgp router-id 1.1.1.1 配置bgp路由器id
    R1(config-router)#neighbor 12.1.1.2 remote-as 64512 指定邻居路由器所在as
    R1(config-router)#network 1.1.1.0 mask 255.255.255.0 宣告网络进bgp

    R2(config)#router ospf 1 
    R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
    R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
    

    R2(config-router)#network 192.168.3.0 0.0.0.255 area 0
    R2(config)#access-list 1 permit 192.168.1.0 0.0.0.255 定义需要匹配的路由条目
    R2(config)#access-list 1 permit 192.168.2.0 0.0.0.255
    R2(config)#route-map os permit 10 建立一个名叫os(随意命名)的策略路由表,编号为10(可以从0~65535)
    R2(config-route-map)#match ip address 1 匹配访问控制列表1
    R2(config)# router bgp 64511
    R2(config-router)#redistribute ospf 1 route-map os 将ospf1中的路由表重发布进bgp,并应用策略路由表,匹配的才允许发布
    R2(config-router)#no auto-summary 关闭自动汇总
    R2(config-router)#bgp route-id 2.2.2.2 配置bgp路由器id
    R2(config-router)#neighbor 12.1.1.1 remote-as 64512
    R2(config-router)#neighbor 23.1.1.2 remote-as 64512

    R3(config)# router bgp 64511
    R3(config-router)#no auto-summary					关闭自动汇总
    R3(config-router)#bgp router-id 3.3.3.3				配置bgp路由器id
    R3(config-router)#neighbor 23.1.1.1 remote-as 64512
    R3(config-router)#network 3.3.3.0 mask 255.255.255.0  宣告网络进bgp
    R3#show ip bgp all								 查看bgp路由表信息
    R3#show ip bgp summary							 查看bgp连接信息
    

    R3#show tcp brief 查看tcp连接信息
    R3#show ip bgp neighbors 查看bgp的邻居的详细信息
    R3#show ip route 查看路由表
    R3#traceroute 1.1.1.1 source 2.2.2.2 查看从1网段到2网段所进过的路由器信息,vpc上为trace
    R3#clear ip bgp * 重置BGP连接

    三、路由策略控制

    1、 方式1
    R5访问R1的不同接口走不同线路控制(建立好BGP邻居的关系下)
    R3(config)#access-list 1 permit 192.168.1.0 0.0.0.255 (R1的0/0口网段)
    R3(config)# access-list 2 permit 192.168.2.0 0.0.0.255 (R1的0/1口网段)
    R3(config)#route-map a permit 10 定义一个名为a的策略,编号为10
    R3(config-route-map)#match ip address 1 匹配控制列表1所匹配的地址段
    R3(config-route-map)#set local-preference 200 设置本地优先级,越高越优,默认100
    R3(config)#route-map a permit 20 同时创建一个编号20的策略路由
    R3(config-route-map)#match ip address 2 匹配控制列表2所匹配的地址段
    R3(config-route-map)#set local-preference 50 设备本地优先级,
    R3(config)#router bgp 64511
    R3(config-router)#neighbor 35.1.1.1 route-map a out 告诉R5策略列表a的路由优先级,比如访问192.168.1.0网段从R3走

    R4(config)#access-list 1 permit 192.168.2.0 0.0.0.255 (R1的0/0口网段)
    R4config)# access-list 2 permit 192.168.1.0 0.0.0.255 (R1的0/1口网段)
    R4(config)#route-map a permit 10 定义一个名为a的策略,编号为10
    R4(config-route-map)#match ip address 1 匹配控制列表1所匹配的地址段
    R4(config-route-map)#set local-preference 200 设置本地优先级,越高越优,默认100
    R4(config)#route-map a permit 20 同时创建一个编号20的策略路由
    R4 (config-route-map)#match ip address 2 匹配控制列表2所匹配的地址段
    R4 (config-route-map)#set local-preference 50 设备本地优先级,
    R4 (config)#router bgp 64511
    R4 (config-router)#neighbor 45.1.1.1 route-map a out 告诉R5策略列表a的路由优先级,比如访问192.168.2.0网段优先从R4走

    2、方式2,控制MED属性,向EBGP邻居发送路由,影响其路由优先级

    R1访问R5的两个环回口设置
    R3(config)#access-list 3 permit 1.1.1.1 (R5的lo0口)
    R3(config)# access-list 4 permit 2.2.2.2 (R5的lo1口)
    R3(config)#route-map b permit 10 定义一个名为a的策略,编号为10
    R3(config-route-map)#match ip address 3 匹配控制列表1所匹配的地址段
    R3(config-route-map)#set metric 1000 设置路由MED值,越低越优
    R3(config)#route-map b permit 20 同时创建一个编号20的策略路由
    R3(config-route-map)#match ip address 4 匹配控制列表2所匹配的地址段
    R3(config-route-map)#set metric 2000 设置路由度量值,越低越优
    R3(config)#router bgp 64511
    R3(config-router)#neighbor 13.1.1.1 route-map b out 告诉R1策略列表a的路由优先级,比如访问1.1.1.1网段从R3走

    R4(config)#access-list 3 permit 1.1.1.1 (R5的lo0口)
    R4config)# access-list 4 permit 2.2.2.2 (R5的lo1口)
    R4(config)#route-map b permit 10 定义一个名为b的策略,编号为10
    R4(config-route-map)#match ip address 3 匹配控制列表1所匹配的地址段
    R4(config-route-map)#set metric 2000 设置MED,越低越优。
    R4(config)#route-map b permit 20 同时创建一个编号20的策略路由
    R4 (config-route-map)#match ip address 4 匹配控制列表2所匹配的地址段
    R4 (config-route-map)#set metric 1000 设置MED值,
    R4 (config)#router bgp 64511
    R4 (config-router)#neighbor 14.1.1.1 route-map b out 告诉R1策略列表b的路由优先级,比如访问2.2.2.2网段优先从R4走
    方式一和方式二可以共存

    四、策略路由

    控制R1、R2的环回口1.1.1.1和2.2.2.2互相访问走R3走,不走直连。
    R1(config)# access-list 100 permit ip 1.1.1.0 0.0.0.255 2.2.2.0 0.0.0.255 配路由列表
    R1(config)#route-map out permit 10 创建策略路由表
    R1(config-route-map)#match ip address 100 应用控制策策略
    R1(config-route-map)#set ip next-hop 13.1.1.2 设置下一跳地址为R3
    R1(config)#ip local policy route-map out 全局应用策略路由表

    R2(config)# access-list 100 permit ip 2.2.2.0 0.0.0.255 1.1.1.0 0.0.0.255
    R2(config)#route-map out permit 10
    R2(config-route-map)#match ip address 100
    R2(config-route-map)#set ip next-hop 23.1.1.2
    R2(config)#ip local policy route-map out

    展开全文
  • 思科路由器配置命令.docx
  • 思科路由器配置命令教程.docx
  • 如何正确的进行路由器设置,是用户最为关心的问题,可能好多人还不了解如何在家庭使用中将路由器设置到最佳,没有关系,看完本文你肯定有不少收获,希望本文能教会你更多东西。
  • 一、交换机基础配置命令 Switch>enable Switch# configure terminal Switch(config)# vlan 10 创建vlan,编号为10 Switch(config-vlan)# name nanjin 命名vlan,名称为nanjin Switch(config)#...

    一、交换机基础配置命令

    Switch>enable
    Switch# configure terminal
    Switch(config)# vlan 10 创建vlan,编号为10
    Switch(config-vlan)# name nanjin 命名vlan,名称为nanjin
    Switch(config)#interface vlan 10 进入vlan
    Switch (config-if)#description link-to dianx 给vlan添加备注信息
    Switch(config-if)# ip address 172.16.1.1 255.255.255.0 给vlan配ip地址。
    Switch(config-if)# no shutdown 打开vlan
    Switch#show vlan brief 查看vlan及接口详情
    Switch#show interfaces vlan 10 查看具体vlan的情况

    二、交换技术配置

    1、trunk端口配置
    Switch(config)# int e0/1
    Switch(config-if)#switchport trunk encapsulation dot1q
    接口的trunk封装802.1Q协议,用于启用trunk
    Switch(config-if)# switchport mode trunk 接口模式为trunk模式
    2、access端口配置
    Switch(config)# int e0/0
    Switch(config-if)# switchport mode access 接口模式为access模式
    Switch(config-if)# switchport access vlan 10 将接口划分到vlan10下
    3、VLAN许可
    Switch(config-if)# switchport trunk allowed vlan 10 trunk链路放行vlan10的流量
    Switch(config-if)# switchport trunk native vlan 20 trunk链路禁止vlan20流量通过
    Switch #show interfaces trunk 查看trunk链路详情

    三、链路聚合

    SW1(config)# interface port-channel 1 创建一个通道,通道号为1
    SW1(config)#int e0/0
    SW1(config-if)# switchport trunk encapsulation dot1q 启用trunk链路
    SW1(config-if)# switchport mode trunk
    SW1(config-if)#channel-group 1 mode active 将接口加入到1号通道中,封装协议为LACP
    SW1(config)# int e0/1 同上
    SW1(config-if)# switchport trunk encapsulation dot1q
    SW1(config-if)# switchport mode trunk
    SW1(config-if)#channel-group 1 mode active

    SW2(config)# interface port-channel 1 创建一个通道,通道号为1,要和SW1相同
    SW2(config)#int e0/0
    SW2(config-if)# switchport trunk encapsulation dot1q
    SW2(config-if)# switchport mode trunk
    SW2(config-if)#channel-group 1 mode active
    SW2(config)# int e0/1
    SW2(config-if)# switchport trunk encapsulation dot1q
    SW2(config-if)# switchport mode trunk
    SW2(config-if)#channel-group 1 mode active
    SW2#show etherchannel summary 查看链路状态

    四、MSTP生成树

    Switch(config)#spanning-tree mode mst 生成树模式改为mst
    Switch(config)#spanning-tree mst configuration 进入mst配置模式
    Switch(config-mst)#revision 1 设置配置修订号,只有revision号相同的交换机才是在同一个mst域
    Switch(config-mst)#instance 1 vlan 1,2,3,4,5 将vlan映射到实例1中
    Switch(config-mst)#instance 2 vlan 10,20,30,40,50 将vlan映射到实例2中
    Switch(config-mst)#exit 退出配置生效
    Switch(config)#spanning-tree mst 1 priority 0
    Switch(config)#spanning-tree mst 2 priority 4096
    设置此交换机为MST1的根桥,MST2的备份根桥

    Switch2(config)#spanning-tree mode mst 生成树模式改为mst
    Switch2(config)#spanning-tree mst configuration 进入mst配置模式
    Switch2(config-mst)#revision 1 设置配置修订号,只有revision号相同的交换机才是在同一个mst域
    Switch2(config-mst)#instance 1 vlan 1,2,3,4,5 将vlan映射到实例1中
    Switch2(config-mst)#instance 2 vlan 10,20,30,40,50 将vlan映射到实例2中
    Switch2(config-mst)#exit 退出配置生效
    Switch2(config)#spanning-tree mst 1 priority 4096
    Switch2(config)#spanning-tree mst 2 priority 0
    设置此交换机为MST2的根桥,MST1的备份根桥
    Switch#show spanning-tree 查看stp状态

    五、MAC地址绑定

    Switch(config)# interface e0/0
    Switch(config-if)#switchport port-security mac-address 00:50:79:66:68:04 配置需要绑定低MAC地址
    Switch(config-if)#switchport port-security maximum 1 限制次端口运行的MAC地址数为1
    Switch(config-if)#switchport port-security violation shutdown 当发现与上述配置不符合时,吧端口down掉

    六、单臂路由

    R1(config)# interface e0/0
    R1(config-if)#no shutdown 打开和交换机互联的接口
    R1(config)#int e0/0.1 进入该接口的子接口
    R1(config-subif)#encapsulation dot1Q 10 用于承载vlan10的流量
    R1(config-subif)#ip address 192.168.10.1 255.255.255.0 给接口配置地址,为vlan的网关
    R1(config-subif)# no shutdown 打开接口
    R1(config)#int e0/0.2 进入该接口的子接口
    R1(config-subif)#encapsulation dot1Q 20 用于承载vlan20的流量
    R1(config-subif)#ip address 192.168.20.1 255.255.255.0 给接口配置地址,为vlan的网关
    R1(config-subif)# no shutdown 打开接口

    互联的交换机接口启用trunk
    Switch(config)# int e0/0
    Switch(config-if)#switchport trunk encapsulation dot1q
    Switch(config-if)#switchport mode trunk

    展开全文
  • Cisco路由器配置命令之模式转换命令.pdf
  • 在写路由过程中不用再记那烦索的命令了,希望对大家有用。 用户模式: 用户模式: Router> Router> 特权模式: 特权模式: Router>en Router>enable Router# Router# 全局配置模式 全局配置模式 Router#conf t Router...
  • 找了很久的 思科路由器配置命令及方法 学习基础,志在千里!
  • 思科网络路由器配置命令(详细命令总结归纳)

    千次阅读 多人点赞 2021-10-04 19:22:29
    二、路由器配置 1、常用命令 2、配置永不超时(防止长时间无操作返回初始界面) 3、防止配置命令被打断(启用显示同步) 4、禁用DNS查找 5、配置arp 6、静态路由,默认路由 7、telenet远程登录设置 8、配置...
  • 思科(Cisco)路由器常用命令总结

    千次阅读 多人点赞 2019-04-24 16:55:03
    思科路由器常用命令总结: 1,路由器口令设置: router>enable 进入特权模式 router#config terminal 进入全局配置模式 router(config)#hostname 设置交换机的主机名 router(config)#enable secret xxx 设置特权...
  • 思科路由器配置命令详解及实例 一般来说,可以用5种方式来设置路由器: 1.Console口接终端或运行终端仿真软件的微机; 2.AUX口接MODEM,通过电话线与远方的终端或运行终端仿真软件的微机相连; 3.通过Ethernet上...
  • CISCO 路由器产品配置手册
  • Cisco路由器配置命令

    2021-10-15 15:43:48
    特权模式:这一级别用户可以使用show命令进行配置查看,但是还是无法进行配置。在用户模式下输入enable进入。 一般是Router# 全局模式:这一级别下用户可以对路由器进行配置。特权模式下输入config terminal可以...
  • Cisco路由器配置命令手册收藏.pdf适用于初学者学习
  • cisco 路由器配置手册,非常详细: 1、路由器配置基础。 2、广域网协议设置。 3、 路由协议设置。 4、服务质量及访问控制。 5、虚拟局域网(VLAN)路由。
  • 长期笔记的最实用 思科cisco 路由器配置命令大全 你值得拥有一份

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 22,846
精华内容 9,138
关键字:

cisco路由器配置命令