1.单臂路由(图)

环境:一台路由器,一台二层交换机,两台pc机


213033510.jpg

二层交换机的配置

//创建vlan 10 和 vlan 20:

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)# exit


//进入接口配置模式,把0/1变成trunk口(默认是access口)

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#exit

//进入接口配置模式分别把对应的接口,加入对应的vlan:

Switch(config)#interface fastEthernet 1/1

Switch(config-if)#switchport mode access 

Switch(config-if)#switchport access vlan 10

Switch(config-if)#interface fastEthernet 2/1

Switch(config-if)#switchport mode access 

Switch(config-if)#switchport access vlan 20


路由器的配置:

Router(config)#inter fas 0/0

Router(config-if)#no ip address 

Router(config-if)#no shutdown    //注意:单臂路由的配置父接口一定要no shutdown

Router(config-if)#exit


Router(config)#int fas 0/0.10

Router(config-subif)#encapsulation dot1Q 10  //注意:在配置ip时一定要先封装802.1q协议

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config-subif)#no shutdown 

Router(config-subif)#int fas 0/0.20

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Router(config-subif)#no shutdown


PC0的配置:

1、 ip 192.168.10.102 
2、 netmask 255.255.255.03 
3、 gateway 192.168.10.1


PC1的配置:

1、 ip 192.168.20.202
2、 netmask 255.255.255.03 
3、 gateway 192.168.20.1


2.使用SVI实现VLAN间的通信

环境:一台三层交换机,两台pc机

214108558.jpg

三层交换机的配置: 

首先需要启用三层交换机上的路由功能:ip routing

 

 1//创建vlan 10  20

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#exit


//配置SVI接口ip

Switch(config)#interface vlan 10

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#no shutdown 

Switch(config-if)#interface vlan 20

Switch(config-if)#ip address 192.168.20.1 255.255.255.0

Switch(config-if)#no shutdown 

Switch(config-if)#exit


//改变接口模式并加入vlan

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access 

Switch(config-if)#switchport access vlan 10

Switch(config-if)#interface fastEthernet 0/2

Switch(config-if)#switchport mode access 

Switch(config-if)#switchport access vlan 20


两主机的配置与单臂路由中两主机的配置一样。


3.跨交换机实现VLAN间的通信(图)

环境:一台三层交换机,两台二层交换机,两台pc机


214802748.jpg

三层交换机的配置(SW3)

//创建vlan 10 、 20 并设置ip

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#exit

Switch(config)#interface vlan 10

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#no shutdown 

Switch(config-if)#interface vlan 20

Switch(config-if)#ip address 192.168.20.1 255.255.255.0

Switch(config-if)#no shutdown 

Switch(config-if)#exit


//设置接口模式并加入相应的vlan(注意trunk口的设置)

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#interface fastEthernet 0/1

Switch(config-if)#switchport access vlan 10

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config)#interface fastEthernet 0/2

Switch(config-if)#switchport mode trunk 

Switch(config-if)#interface fastEthernet 0/2

Switch(config-if)#switchport access vlan 20


SW21的配置:

Switch(config)#vlan 10

Switch(config-vlan)#exit


Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk


Switch(config-if)#interface fastEthernet 1/1

Switch(config-if)#switchport mode access 

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit


SW22的配置:

Switch(config)#inter fa  1/1

Switch(config-if)#switchport mode access  


Switch(config-if)#inter fa 2/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#exit


Switch(config)#vlan 20

Switch(config-vlan)#inter fa  1/1

Switch(config-if)#switchport access vlan 20


注意:两交换机之间的链接是trunk链路