精华内容
下载资源
问答
  • 思科模拟器三层交换机
    2022-09-08 09:38:19

    三层交换机即是内置了路由功能的交换机,在转发数据帧的同时,还可以在不同网段之间路由数据包。在交换式局域网中,三层交换机可以配置多个虚拟vlan接口(SVI)作为vlan内PC设备的网关,同时转发数据包,实现不同vlan之间的通信。

    情境分析

    不同业务部门划分到不同VLAN,管理更为合理、安全,但有时又需要部门间间通信,这可通过三层交换机设备来实现。

    所需设备:

    (1)Cisco Catalyst 3560交换机1台。

    (2)PC机2台。

    (3)Console配置线1条。

    (4)直通线2根。

    任务拓扑,如图2-2-9所示。

    设备

    端口

    IP地址

    Mask

    网关

    VLAN10

    1

    192.168.10.1

    255.255.255.0

    VLAN20

    2

    192.168.20.1

    255.255.255.0

    PC1

    1

    192.168.10.10

    255.255.255.0

    192.168.10.1

    PC2

    3

    192.168.20.10

    255.255.255.0

    192.168.20.1

    步骤实现

    步骤1:按照如图2-2-9所示,连接网线拓扑结构图。

    步骤2:按照如表2-2-4所示,配置计算机的IP地址和子网掩码。

    步骤3:在三层交换机上设置主机名称,并创建vlan和添加端口。

    前两步省略

    1.

    Switch(config)#ho SW1  给三层交换机命名为SW1
    SW1(config-if)#vlan 10    创建vlan10 20
    SW1(config-vlan)#vlan 20
    SW1(config-vlan)#
    SW1(config-vlan)#
    SW1(config-vlan)#in f0/1 进入f0/1端口
    SW1(config-if)#sw mo a   配置端口模式
    SW1(config-if)#sw a vlan 10  把vlan10划分到端口中
    SW1(config-if)#in f0/2  进入f0/2端口
    SW1(config-if)#sw m a  配置端口模式
    SW1(config-if)#sw a vlan 20  把vlan20 加入到端口中
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#in vlan 10   进入vlan10  
    SW1(config-if)#
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    
    SW1(config-if)#ip add 192.168.10.1 255.255.255.0 
     配置ip和add,作为三层交换机的SVI(管理地址)也是PC机的网关
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#in vlan 20  进入vlan20
    SW1(config-if)#
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    	
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#ip add 192.168.20.1 255.255.255.0   配置ip add
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#ip routing  开启路由功能
    SW1(config)#

    2.在终端进行验证 看是否通信

    
    Packet Tracer PC Command Line 1.0
    C:\>ping 192.168.20.1
    
    Pinging 192.168.20.1 with 32 bytes of data:
    
    Reply from 192.168.20.1: bytes=32 time<1ms TTL=255
    Reply from 192.168.20.1: bytes=32 time=1ms TTL=255   网络畅通
    Reply from 192.168.20.1: bytes=32 time<1ms TTL=255
    Reply from 192.168.20.1: bytes=32 time<1ms TTL=255
    
    Ping statistics for 192.168.20.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 1ms, Average = 0ms
    

     小结:三层交换机与二层交换机区别指出在于可以互相通信, 切记管理地址是在vlan里面配置的 ,配置之后记得开启路由功能:ip routing ,没有这条命令网络无法互通。

    每日一言:

    只有分离后才能懂的事,却没有了感慨的时间。 --宝石之国

    更多相关内容
  • 思科模拟器配置文件及其说明,包含三层交换机配置、nat的转换、静态路由的配置和acl的相关知识与配置
  • 请问在思科模拟器上做三层交换机静态路由实验时划分完vlan,配置好主机ip地址后,pc0和pc1不能ping通,但是过了一会儿又能ping通了,这是什么原理呀,有时ping通有时ping不通
  • 使用Cisco思科模拟器进行三层交换机配置

    万次阅读 多人点赞 2019-06-06 15:51:40
    使用Cisco图形化配置,通过三层交换路由功能实现不同VLAN之间的通信。

    运行环境: win10 + Cisco模拟器Packet Tracer 5.2
    网络拓扑图:
    在这里插入图片描述

    实验步骤:

    1. 图标放置

    如图所示
    在这里插入图片描述

    2. 接线

    接线比较重要,需要记住接的线接在哪个端口处,通常每个Switch交换机有24个端口。在该实验中为了方便管理配置,我们可以将pc统一接到switch的1号端口,Switch与Switch相连用2号端口,Multilayer Switch接到Switch的3号端口。
    以Switch0为例:
    Switch0与PC0相连,用直线,选择Switch0的1号端口FastEthernet0/1与pc的端口FastEthernet连接。
    在这里插入图片描述
    在这里插入图片描述
    Switch0与Switch1相连,用虚线,选择Switch0的2号端口FastEthernet0/2与switch1的2号端口FastEthernet0/2相连。
    在这里插入图片描述
    在这里插入图片描述
    Switch0与Multilayer Switch0相连,用虚线,选择Switch0的3号端口FastEthernet0/3与 Multilayer Switch的1号端口FastEthernet0/1相连。
    在这里插入图片描述
    在这里插入图片描述
    最终网络拓扑图如下(鼠标移至绿色光标处可显示为几号端口):
    在这里插入图片描述

    3. PC的IP设置

    PC机的配置如下:

    PC0:IP Address 36.4.1.1
    Subnet Mask 255.0.0.0
    Default Gateway 36.4.1.254

    PC1:IP Address 36.4.2.2
    Subnet Mask 255.0.0.0
    Default Gateway 36.4.2.254

    PC2:IP Address 36.4.3.3
    Subnet Mask 255.0.0.0
    Default Gateway 36.4.3.254

    PC3:IP Address 36.4.4.4
    Subnet Mask 255.0.0.0
    Default Gateway 36.4.4.254

    选取PC0为例进行配置:
    点击PC0,进入Desktop,点击IP Configuration进行配置
    在这里插入图片描述
    按实验要求输入前三个即可
    在这里插入图片描述

    4. Multilayer Switch配置

    以太网端口有 3种链路类型:access、trunk、hybird

    Access类型端口:只能属于1个VLAN,一般用于连接计算机端口;

    Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    一般用于交换机与交换机相关的接口。

    Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    可以用于交换机的间连接也可以用于连接用户计算机

    我们使用了多层交换机的端口1和端口2,将其设置为trunk类型。
    端口1:
    在这里插入图片描述
    端口2同理,点击FastEthernet0/2,将其选择为trunk
    在这里插入图片描述
    实验中要求PC0,PC1,PC2,PC3分别使用vlan1,vlan2,vlan3,vlan4,因此我们需要在多层交换机中配置这四个vlan。
    进入CLI
    在这里插入图片描述
    输入如下指令
    在这里插入图片描述
    在config中添加vlan
    在这里插入图片描述
    由于vlan1为系统默认的,所以还需要在CLI中打开
    在这里插入图片描述
    将鼠标置于多层交换机上可查看当前配置是否正确。
    在这里插入图片描述

    5. Switch交换机配置

    分别对四个Switch进行配置。
    Switch0:
    与PC端相连的端口(端口F1)设置为access,接vlan 1,与switch相连的端口(F2和F3)设置为trunk。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    Switch1:
    与PC端相连的端口(端口F1)设置为access,接vlan 2,与switch相连的端口(F2)设置为trunk。
    在这里插入图片描述
    在这里插入图片描述
    Switch2:
    与PC端相连的端口(端口F1)设置为access,接vlan 3,与switch相连的端口(F2)设置为trunk。
    在这里插入图片描述
    在这里插入图片描述
    Switch3:
    与PC端相连的端口(端口F1)设置为access,接vlan 4,与switch相连的端口(F2和F3)设置为trunk。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    6. PC0的ping测试

    确认该三层交换机是否能够实现不同vlan之间的通信。
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 三层交换机分配vlan端口,实现主机在不同vlan通讯 实现内容预览: 结论: 设置网关后的主机可以在不同vlan下通讯 实验知识储备: 创建vlan: 例如创建vlan 100和vlan 200 Switch(config)#vlan 100 Switch...

    三层交换机分配vlan端口,实现主机在不同vlan通讯

    实现内容预览:

    在这里插入图片描述

    结论:

    	设置网关后的主机可以在不同vlan下通讯
    

    实验知识储备:

    创建vlan:
    	例如创建vlan 100和vlan 200
    	Switch(config)#vlan 100
    	Switch(config-vlan)#exit
    	Switch(config)#vlan 200
    	Switch(config-vlan)#exit
    
    划分端口:
    	例如把1-5端口划分vlan 100
    	Switch(config)#inter range fa 0/1-5
    	Switch(config-if)#switchport access vlan 100
    
    设置trunk口:
    例如将22端口设置为trunk口
    Switch(config-vlan)#vlan 100
    Switch(config-if)#int f0/22
    Switch(config-if)#switchport mode trunk 
    
    查看vlan端口:
    	Switch#show vlan
    
    给划分的vlan设置IP地址:
    	Switch#configure terminal
    	Switch(config)#interface vlan 100
    	Switch(config-if)#ip address 192.168.100.1 255.255.255.0
    	Switch(config-if)#no shutdown
    	Switch(config-if)#exit
    
    设置主机IP、掩码、网关:
    	网关为主机所连接vlan的IP地址
    

    在这里插入图片描述

    测试:
    	在命令行测试
    	ping + IP
    
    展开全文
  • 思科模拟器实现三层交换机下不同VLAN之间的通信 实验目标:在三层交换机下实现不同VLAN的PC机之间的通信 工具: CisicoPacketTracer6 实验设备: 六台PC机,四台接入层交换机和两台汇聚层交换机(二层交换机)以及...

    用思科模拟器实现三层交换机下不同VLAN之间的通信

    实验目标:在三层交换机下实现不同VLAN的PC机之间的通信
    工具: CisicoPacketTracer6
    实验设备: 六台PC机,四台接入层交换机和两台汇聚层交换机(二层交换机)以及一台核心交换机(三层交换机)

    实验步骤:
    1.用思科模拟器选择实验设备并实现下面的连接
    在这里插入图片描述
    2.设置相关的数据,
    2.1 PC机的IP地址(建议使用C类地址)
    1.点击PC机,进行如图所以的IP配置。按此方法设置其他PC机的IP地址
    在这里插入图片描述在这里插入图片描述

    2.2 PC机的默认网关(GateWay的前三位与IP地址一致):
    在这里插入图片描述

    2.3 在交换机中划分虚拟局域网:
    在这里插入图片描述
    2.4将汇聚层交换机以及与汇聚层交换机相连的两个交换机接口**(与汇聚层相连接的核心层交换机接口和与接入层交换机相连的接口。与PC机相连的接入层接口不必设为TRUNK,不然就相当于了在相同VLAN下的情况了)**将Access接口改为Trunk接口
    在这里插入图片描述
    2.5 核心交换机的配置:
    在这里插入图片描述
    代码如下:
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line. End with CNTL/Z. //这个地方是输入了conf t 自动出现的,并非手动写的
    Switch(config)#int VLAN11 //这里是VLAN的序号,并非名称
    Switch(config-if)#ip address 192.79.11.254 255.255.255.0 //ip address + 网关+子网掩码
    Switch(config-if)#no shutdown //也可以写成no shut
    Switch(config-if)#exit
    Switch(config)#int VLAN12
    Switch(config-if)#ip address 192.79.12.254 255.255.255.0
    Switch(config-if)#no shutdown
    Switch(config-if)#exit
    Switch(config)#ip routing//启动路由

    3.测试网络连通性的方法
    3.1 点击界面中右端的图标
    在这里插入图片描述
    再点击要测试的两台PC机(主要是不同VLAN下的PC机)。

    出现以下结果:
    在这里插入图片描述
    则说明配置成功。
    3.2点击下图的Commad Promt
    在这里插入图片描述

    输入ping命令(ping +PC机IP)
    出现以下结果
    在这里插入图片描述
    则说明不同VLAN下的PC机连接成功,实现通信。

    展开全文
  • 利用三层交换机的路由功能,实现不同vlan间的通信
  • 思科模拟器三层交换机的配置

    千次阅读 2019-06-01 17:54:39
    开启三层交换机的路由功能( 不要忘记了 ) 输入 ip routing 开启路由功能 //1. 创建vlan Switch#conf t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#int vlan 10 Switch...
  • 关于思科模拟器三层交换机的实验ping通不同vlan,ping通外网,以及三层交换机的dhcp动态获取地址配置的方法
  • 思科模拟器三层交换机配置实验

    千次阅读 2019-11-20 21:37:06
    注:两台笔记本用于配置两台交换机 pc_name ip mask rlation_f laptop2 192.168.3.100 192.168.3.1 f0/4 pc0 192.168.1.100 192.168.1.1 f0/1 pc1 192.168.2.100 192.168.2.1 f0/2 配置3960 Switch...
  • 思科模拟器 --- 三层交换机实现VLAN间路由

    千次阅读 多人点赞 2019-10-23 17:31:58
    学习目标:掌握三层交换机基本配置和 vlan 路由的配置方法实现vlan间相互通信 1.实验场景 为了安全和便于管理对两个部门的主机进行了VLAN的划分,研发部和人事部处于不同的VLAN,由于工作需求,需要人事部和研发部...
  • 理解三层交换机的基本原理; 掌握三层交换机物理端口开启路由功能的配置方法; 实验背景 公司现有1台三层交换机,要求你进行测试,该交换机的三层功能是否工作正常。 技术原理 开启路由功能 Switch(config)#ip ...
  • 思科模拟器中的交换机使用方法

    万次阅读 多人点赞 2018-10-08 18:11:07
    思科模拟器中有较多种交换机型号,这里只是简单的介绍一下二层交换机2960,以及三层交换机中的3560 1.关于交换机的原理: 交换机是通过其保存的MAC地址表来进行工作的,而其地址表的内容大概是这样的: 交换机中...
  • 学习目标:理解和掌握三层交换机的基本原理和配置方法 1.实验设备:交换机35601台 、PC1台 、直通线、配置线 2.配置PC0的IP地址: IP地址:192.168.1.2 MAC地址:255.255.255.0 3.通过PC0的Terminal配置...
  • 端口聚合工作原理 将连接多个物理链路的端口捆绑在一起形成一个逻辑端口,这个逻辑端口成为聚合端口(AP)。聚合端口AP的功能遵循IEEE802.3ad...二层端口聚合针对二层交换机,交换机接口只能是二层性质的,接口链路类
  • 满意答案miwen93092013.05.31...假设三层交换机的fa0/1到fa0/6分别连接pc0至pc5,那么请参考如下命令:enablevlan databasevlan 10vlan 11exitconfigure terminalip routinginterface vlan 10ip address 192.168.10...
  • 思科模拟器上怎么配置交换机VTP?VTP 被组织成管理域(VTP Domain),VTP 可以分为种模式:服务器模式(Server),客户机模式(Client),透明模式,下面我们来看看配置方法
  • Cisco三层交换机的详细配置

    万次阅读 多人点赞 2021-04-08 17:01:58
    使用到的机器型号为:五台电脑,一台服务器,三个普通交换机(2960型号),一个三层交换机(3560-24PS),两台普通服务器(2811) 文章目录一、什么是三层交换机二、配置交换机步骤1.配置二层交换机2.配置三层交换机...
  • 思科模拟器上怎么配置动态路由RIP?动态路由会自主选择最佳路径的,不像静态路由某个节点瘫痪了,整个网络就都瘫痪了,下面我们来看看思科模拟器上配置动态路由RIP的图文教程
  • 思科三层交换机配置DHCP中继

    千次阅读 2021-03-20 11:52:04
    三层交换机配置DHCP中继 实验目的: 通过本实验掌握如何给不同网段配置DHCP,掌握DHCP中继配置。 实验拓扑: 对交换机SW1进行预配置。 Switch>en Switch#conf t Enter configuration commands, one per line. ...
  • #在配置完三个vlan接口后,使用show vlan命令三个接口对应的接口能够出来,但启用三层交换机路由功能并设置sci接口后,使用命令show ip route后,vlan99没有出现
  • 三层交换机配置: Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#vlan 30 Switch(config-vlan)#vlan 40 Switch(config-vlan)#exit Switch...
  • 2、配置交换机SW1 Switch>en Switch#conf t Switch(config)#vlan 2 Switch(config-vlan)#exit Switch(config)#vlan 3 Switch(config-vlan)#exit Switch(config)#int f0/1 Switch(config-if)#switchport mode ...
  • 目的:PC0 ping通 PC1 ...ip routing #三层交换机开启路由功能 interface FastEthernet0/1 switchport trunk encapsulation dot1q #为交换机接口启动bot1q协议 switchport mode trunk #接口模式改为t...
  • 首先配置终端设备 在配置VLAN 关键是一定要配置静态路由才能首先两台电脑的互通
  • 思科三层交换机ACL配置 说明:ACL 主要是应用在路由器上,但现在三层交换机在大中型企业中的应用越来越广泛,三层交换机因拥有路由器的功能而逐渐代替路由器。 ACL 访问控制列表是构建安全规范的网络不可缺少的,但...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,401
精华内容 560
关键字:

思科模拟器三层交换机