精华内容
下载资源
问答
  • IPv6作为下一代互联网协议标准,将...本文结合现有内蒙古工业大学校园网特点,在尽可能利用现有网络资源的基础上,研究了逐步部署IPv6网络及相关应用的方案,通过双协议栈和隧道代理系统的实现,在全校范围内部署IPv6协议。
  • 一、什么是IPv6。 IP version 6 (IPv6)是IP协议(Internet Protocol)的最新版本,设计作为IP version 4 (IPv4) [RFC791]的继任版本。从IPv4到IPv6的改变主要有以下几点: 扩展的地址容量; 简化的头字段格式...

    一、什么是IPv6。

    IP version 6 (IPv6)是IP协议(Internet Protocol)的最新版本,设计作为IP version 4 (IPv4) [RFC791]的继任版本。从IPv4到IPv6的改变主要有以下几点:

    1.  扩展的地址容量;
      
    2.  简化的头字段格式;
      
    3.  改进了报文扩展字段和选项,使转发更灵活高效;
      
    4.  提供流标签功能;
      
    5.  增强的认证和隐私功能。
      

    二、为什么迁移ipv6,迁移ipv6背景

    1.  主因:政策驱动
      

    2017年11月26日,中共中央办公厅、国务院办公厅印发了《推进互联网协议第六版(IPv6)规模部署行动计划》,链接:http://www.xinhuanet.com/2017-11/26/c_1122012631.htm

    2018年5月2日,工信部发文:工业和信息化部关于贯彻落实《推进互联网协议第六版(IPv6)规模部署行动计划》的通知,链接:http://www.miit.gov.cn/n1146295/n1652858/n1652930/n3757020/c6154756/content.html

    1.  辅因:市场、技术驱动
      

    随着5G、IoT技术的不断成熟,万物互联时代即将到来,随之而来的是海量的终端设备接入需求,目前的IPv4地址空间不足以支撑未来发展要求。另外由于IPv4地址的枯竭,也使得其交易价格也在不断攀升。

    三、政策解读

    根据中办,国办下发的《行动计划》,和工信部下发的《通知》。我们可以总结出以下要点:

    1.  时间节奏:分为3个时间节点,2018年末,2020年末和2025年。
      
    2.  改造目标:2018年末要求IPv6活跃用户数超2亿,v6用户占总用户数不低于20%;2020年末要求超5亿,不低于50%;2025年v6用户数要达到世界第一。
      
    3.  改造对象:
      

    a) 应用:2018年末要求前50大互联网企业网站及应用,省级政府网站,央企网站和新闻媒体网站全部改造支持IPv6;2020年末要求前100大互联网企业,市级政府和新闻媒体和工业互联网应用支持IPv6。

    b) 基础设施:这一部分主要是和电信运营商相关的滚动改造任务。对各个时间点运营商移动/接入/骨干/国际出口网络等需要达到的目标。

    c) 应用基础设施:重点是2018年末要求云计算厂商提供的50%云产品支持IPv6;2020年末100%的云产品支持IPv6。

    四、阿里云IPv6演进规划:稳中求进

    IPv4到IPv6的演进遵循先外部后内部,以双栈技术为过渡的原则。

    第一期主要对公网入口相关产品进行IPv6的改造,目标是应对政策文件的第一阶段要求,即2018年底前,前50大互联网企业的应用及政府部门网站具备IPv6访问能力,提供用户快速部署IPv6的解决方案。主要涉及SLB,IPv6转换服务,云解析DNS,和CDN四款产品,相关产品已经于2018年6月上线发布。

    第二期将对主要云产品进行IPv4和IPv6双栈改造,包括VPC,ECS,DTS等。目标是为客户提供端到端的IPv6解决方案,让客户能够完全利用上IPv6的网络特性。预计2018年下半年完成。

    第三期的目标是去掉IPv4访问能力,使产品只支持IPv6访问。这是一个长期的目标,具体时间需要统筹考虑政策,市场,技术等多方面因素。预计时间在2019年以后。

    五、阿里云IPv6相关产品介绍

    1.  负载均衡SLB
      

    传统的负载均衡只提供IPv4的访问能力,且后端通过v4方式访问后端服务器。鉴于第一期VPC和ECS等核心组建不具备IPv6能力条件下,采用先将暴露给客户的公网侧进行v6改造的方案。

    通过在SLB上暴露公网IPv6地址,实现对IPv6用户访问能力,同时在SLB内部进行NAT64转换,将前端v6地址转为v4地址,仍然使用v4方式访问后端服务器,这样就实现了v6用户访问v4后端服务器的能力。

    1.  阿里云IPv6转换服务
      

    对于没有上云的客户,改造v6的难点主要在于技术难度大,周期长,需要大量资金等,而且会面临改造过程中的业务中断风险。随着政策要求的2018年末时间点越来越近,所剩时间已经不多。基于这个背景,阿里云推出了IPv6转换服务,客户可以方便的在阿里云上部署IPv6公网入口,同时将实例后端关联到线下IDC或其他云平台的服务器。在阿里云上完成v6 to v4地址的转换,让客户能够在短时间内免配置快速部署IPv6,完成政策规定的指标要求。

    1.  云解析DNS
      

    DNS是面对客户的第一个入口,根据我们对政策的分析,有些网站采取的不同域名分别解析v4和v6地址的做法是不符合政策精神的。云解析DNS现在可以做到一个域名,双栈地址,即用户对一个域名的查询,会将记录的v4和v6地址同时返回给客户,阿里云DNS符合政策要求。

    1.  阿里云CDN
      

    CDN已经是现在互联网应用不可或缺的一环。CDN是否支持IPv6是客户迁移时一定会考虑的因素。目前教育网CDN v6节点已经全部上线,其他三大运营商的CDN v6节点在陆续开通中。客户关心的一个问题是,在CDN v6节点尚未全面铺开时,是否会有频繁断网的可能从而影响用户的访问体验?答案是不会,目前已有的v6用户均为v4/v6双栈部署,短期内不存在v6 only的用户。在CDN访问过程中,用户首先需要进行DNS查询过程,阿里云DNS会根据CDNv6节点开通情况,将本地相同运营商的CDN节点地址返回给客户,也就是说,只有在同区域同运营商具备CDNv6节点资源时,用户才能得到CDNv6节点地址并进行访问,其他情况,DNS会返回给客户v4地址,通过v4方式访问网站,因此从用户角度看,这一过程是平滑无感知的。

    1.  DDoS
      

    公网的安全防护也是客户不得不考虑的问题之一,因此在IPv6发布的第一天,阿里云就已经支持v6的DDoS功能,默认对客户开启基础免费版本。

    六、客户解决方案

    下面两个场景主要是对第一期迁移任务提出的,由于第一期迁移任务量大,缺乏环境基础,因此相对于复杂的应用内部改造,从公网入口改造相对容易也能快速看到成效。

    1.  场景一:应用部署在阿里云
      

    这是典型的在阿里云上部署业务的场景示意图,涉及到DNS,CDN和SLB产品,由于这三个产品均已支持IPv6,因此IPv6客户可以获得和IPv4客户一样的使用体验。部署的过程分为以下几步:

    1. 创建新的SLB v6实例并将IPv4版本ECS下挂到IPv6 SLB和IPv4 SLB配置方式相同。

    2. 在DNS中增加IPv6解析地址记录。

    3. 阿里云CDN已支持双栈。

    其中NAT64的处理过程对客户透明,客户无需额外配置,只需按一般SLB的操作方法,直接将v4后端服务器加载到v6 SLB下面即可。

    1.  场景二:应用部署在其他环境
      

    对于应用部署在其他环境的客户,需要应用最新推出的阿里云IPv6转换服务,这个服务实例前端暴露给客户一个公网IPv6地址,后端暴露2个IPv4地址,用于和客户的线下其他环境的IPv4公网进行通信。IPv6客户发起访问时,流量从IPv6转换服务实例的v6公网进入,在实例中进行NAT64的转换后,由IPv4出口通过公网回到客户其他环境。这种方案的优势是:

    1. 现有业务0改造,免配置快速部署IPv6。

    2. IPv6转换服务实例采用高可用部署。

    缺点是:

    1. 由于后端使用v4公网访问用户数据中心,产生了额外的公网费用。
      
    2. 也是由于公网访问后端,转发质量由运营商公网决定,没有保障。
      
    3. 用户数据中心暂无法获取客户端的地址。
      

    以上,这个方案只适合短期使用,并非长期方案。

    展开全文
  • 关于IPv6部署的资料,里面列举了IPv6部署的几种方案,有些没有涉及到,比如NAT444,
  • 园区网典型升级方案 — 现有IPv4网络 现有IPv4网络升级策略2 — 双栈接入 现有IPv4网络升级策略2(补充) — 隧道方式
  • 包含在企业网内部署IPV6的所有知识,有启用IPV6的市场驱动力、IPV6企业网络设计的层次化模型、企业网各区块的IPV6部署方案、IPV6网络管理、以及IPV6实验、试点环境搭建等
  • 阿里云IPV6解决方案

    千次阅读 2019-09-11 11:23:46
    前端网络改造成能够同时支持IPv4和IPv6终端访问的双栈网络,后端应用和网络可以彻底改造成双栈,也可以暂不改造(需要在应用系统前端部署NAT64的网络转换系统,进行前端V6和后端V4间转换)。 A...

    阿里云IPv6解决方案助力企业快速升级到IPv6基础架构,针对企业官网、电子政务、应用商店审核、广电传媒等多个行业和场景,提供丰富的产品选择和可靠安全的服务体验。

    方案优势及场景
    网站改造典型场景
    前端网络改造成能够同时支持IPv4和IPv6终端访问的双栈网络,后端应用和网络可以彻底改造成双栈,也可以暂不改造(需要在应用系统前端部署NAT64的网络转换系统,进行前端V6和后端V4间转换)。

    APP 改造典型场景
    前端网络改造: 同时支持IPv4和IPv6终端访问的双栈网络; 后端应用和网络: 可以彻底改造成双栈,也可以暂不改造(前后端间部署NAT64网络转换); APP客户端改造: 支持IPv4 Only/IPv6 Only/IPv64双栈的环境识别。

    提供企业IPv4-IPv6全栈改造方案
    全球双栈方案覆盖国内所有地域,海外包含新加坡,印度,美国。改造彻底、平滑演进到IPv6 Only,打造未来云上直接访问云下的业务创新。整体架构不变、网络部分独立购买使用。阿里云多种双栈产品支持。

    提供SLBv6转换方案
    快速满足国家IPv6政策要求。整体架构不变、网络部分独立购买使用。作为过渡方案前端网络分钟级即可支持IPv6,后端业务系统改动小。

    更多方案详情介绍,请参考阿里云IPv6解决方案-IPv4升级改造

     

    方案使用入门
    IPv64方案部署指导
    1.云上基础设施升级
    业务系统所在VPC配置IPv6网络
    2.云上基础设施升级
    业务系统使用的ECS、RDS、OSS等升级支持IPv6并分配到IPv6地址
    3.云上业务系统升级
    业务系统完成IPv6改造后升级版本
    4.Internet 组件升级
    CDN、DDOS、WAF升级支持IPv6并完成配置
    5.Internet 组件升级
    HTTP-DNS、DNS在给原有域名增加IPv6记录
    6.Internet 组件升级
    HTTP-DNS/DNS上根据IPv6用户放量计划配置灰度引流策略
    7.Internet 组件升级
    如果是网站业务,需要在阿里云上备案
    8.客户端升级
    APP客户端完成IPv6改造、上线并推送版本升级

    SLBv6方案部署指导
    1.云上业务系统升级
    业务系统完成IPv6地址溯源改造后升级版本
    2.Internet 组件升级
    购买SLBv6,挂接原对外提供服务的ECS、并完成SLB其他相关配置
    3.Internet 组件升级
    CDN、DDOS、WAF升级支持IPv6并完成配置
    4.Internet 组件升级
    HTTP-DNS、DNS在给原有域名增加IPv6记录
    5.Internet 组件升级
    HTTP-DNS/DNS上根据IPv6用户放量计划配置灰度引流策略
    6.Internet 组件升级
    如果是网站业务,需要在阿里云上备案
    7.客户端升级
    APP客户端完成IPv6改造、上线并推送版本升级

    方案搭配云产品
    1.IPv6 转换服务
    通过IPv6转换服务,你原有的IPv4业务架构无需改动,即可快速为IPv6用户提供访问能力。
    2.VPC 专有网络
    专属的隔离网络环境,并能自定义IP 地址范围、网段等;此外,也可以通过专线等方式实现云上云下互联。
    3.SLB 负载均衡
    可以通过流量分发扩展应用系统对外的服务能力,通过消除单点故障提升应用系统的可用性。
    4.弹性公网IP
    独立的公网IP资源,可以绑定/ 动态解绑阿里云专有网络VPC的ECS、NAT网关、私网负载均衡SLB。
    5.ECS 云服务器
    快速部署网站应用,业务发展时可随时扩容/降低运维成本,让您专注于核心网站业务创新。
    6.CDN 内容分发
    稳定、极速、智能、安全,支持双栈IPv4和IPv6,帮助客户在线业务交付极致的数字化体验。
    7.DNS 云解析
    为企业和开发者将易于管理识别的域名转换为计算机用于互连通信的数字IP地址。
    8.WAF 应用防火墙
    支持企业版及旗舰版。对网站或者APP的业务流量进行恶意特征防护,将安全的流量回源到服务器。
    9.DDoS 高防
    用户可通过配置高防IP,将攻击流量引流到高防IP,确保源站的稳定可靠。
    10.对象存储OSS
    海量、安全、低成本、高可靠的云存储服务,提供99.999999999%的数据可靠性。
    11.云数据库 MySQL 版
    MySQL 是全球最受欢迎的开源数据库之一,作为开源软件组合LAMP中的重要一环。

     

    展开全文
  • 6RD是IPv6快速部署IPv6 Rapid Deployment)的简称,其对应标准为RFC5569,6RD是在6to4基础上发展起来的一种IPv6网络过渡技术方案。通过在现有IPv4网络中增加6RD-BR,向使用IPv6的用户提供IPv6接入;在IPv6用户的...

    6RD技术的实施

    6RD简介

    6RD是IPv6快速部署(IPv6 Rapid Deployment)的简称,其对应标准为RFC5569,6RD是在6to4基础上发展起来的一种IPv6网络过渡技术方案。通过在现有IPv4网络中增加6RD-BR,向使用IPv6的用户提供IPv6接入;在IPv6用户的家庭网关和6RD网关之间建立6in4隧道,从而实现在IPv4网络提供IPv6服务的能力.
    6RD在向IPv6过渡的过程中已经取得了部分成功,因为它容易实施,扩展性强而且可靠,同时它还是无状态的。
    6RD是6to4自动隧道的扩展技术,部署更加灵活。它使得运行商通过已经部署完毕的IPv4网络提供IPv6服务,当然也是通过最常用的把IPv6封装在IPv4中实现。
    6RD和6to4自动隧道的区别:
    6RD不需要特定的使用2002::/16,它可以使用运行商自己的地址块,这大大的增加了实施的便利性。
    32位的IPv4的目标地址需要在IPv6的有效负荷重承载
    思科6RD-从IPv4快速过渡到IPv6部署,从理论到实现讲解

    图7-12 6RD示意图
    如图7-12所示,CE侧为客户的IPv6单播服务,CEs之间可以实现客户的IPv6互访,也可以通过BR(边界中继设备)访问BR后的IPv6网络。数据穿越运营商的现有IPv4网络。
    我们在图7-14中实施6RD,其中R3和R6为CE,而R5为BR设备。各个设备上的环回口5模拟IPv6主机。
    图7-13为6RD隧道的地址格式,后64位是客户自己的地址空间,前64位是授权的地址空间,其中前32位是运行商的前缀,紧更着后边32位是IPv4地址,这32位中分为IPv4通用地址前缀和IPv4通用后缀(本案例通用后缀为0.0.0.0)。
    思科6RD-从IPv4快速过渡到IPv6部署,从理论到实现讲解
    图7-13 6RD隧道的地址格式

    图7-14 6RD实施拓扑

    思科6RD-从IPv4快速过渡到IPv6部署,从理论到实现讲解

    步骤1.完成IPv4网络

    三台设备的配置相同,启用了eigrp作为承载路由的协议
    r```
    outer eigrp 90
    network 172.16.0.0
    CE-R3#show ip eigrp neighbors
    EIGRP-IPv4 Neighbors for AS(90)
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    1 172.16.123.1 Et0/0 13 00:49:29 10 100 0 6
    0 172.16.123.2 Et0/0 14 00:49:30 8 100 0 5
    CE-R3#show ip route eigrp
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
    a - application route

      • replicated route, % - next hop override

    Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks

    D 172.16.0.1/32 [90/409600] via 172.16.123.1, 00:49:38, Ethernet0/0
    D 172.16.0.2/32 [90/409600] via 172.16.123.2, 00:49:38, Ethernet0/0
    环回口必须数据可达,因为IPv6的通信其实是6RD隧道的源地址之间的通信,而在本案例中,我们6RD隧道的源地址为环回接口
    CE-R3#ping 172.16.0.1 source loopback 0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
    Packet sent with a source address of 172.16.0.3
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/6 ms
    CE-R3#ping 172.16.0.2 source loopback 0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
    Packet sent with a source address of 172.16.0.3
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/6 ms

    ## 步骤2.实施6RD隧道以及实现IPv6的路由
    BR-R5
    ipv6 general-prefix 6RD 6rd Tunnel1 //6RD隧道1的前缀通过通用前缀获得
    !
    interface Tunnel1
     no ip address
     no ip redirects
     ipv6 address 6RD ::/128 //隧道的地址通过6RD获得
     tunnel source Loopback0 //隧道的源地址为环回口,而在前边的实施中已经使得环回口数据可达
     tunnel mode ipv6ip 6rd //实施隧道的模式为6RD
     tunnel 6rd ipv4 prefix-len 16 //定义6RD隧道的通用IPv4前缀长度为16,没有定义通用IPv4后缀
     tunnel 6rd prefix 2003:AABB::/32 //自定义6RD隧道的前32位
    !
    ipv6 route 2003:AABB::/32 Tunnel1 //定义静态路由,到达2003:AABB::/32前缀的出接口为隧道1
    !
    interface Loopback5
     no ip address
     ipv6 address 2003:8888::1/64 //该接口默认IPv6互联网地址
    CE-R6:
    ipv6 general-prefix 6RD 6rd Tunnel1
    !
    interface Tunnel1
     no ip address
     no ip redirects
     ipv6 address 6RD ::/128
     tunnel source Loopback0
     tunnel mode ipv6ip 6rd
     tunnel 6rd ipv4 prefix-len 16
     tunnel 6rd prefix 2003:AABB::/32
     tunnel 6rd br 172.16.0.1 //在客户侧的CE设备上定义BR,可以通过BR实现互联网访问
    !
    ipv6 route 2003:AABB::/32 Tunnel1 //到达IPv6的通用前缀出接口为隧道1
    ipv6 route ::/0 Tunnel1 2003:AABB:1:: //实施到达IPv6的默认路由出接口为隧道1,下一跳中继到BR的6RD隧道的48位通用前缀。
    !
    interface Loopback5
     no ip address
     ipv6 address 2003:AABB:3:1::1/64
    CE-R3
    ipv6 general-prefix 6RD 6rd Tunnel1
    !
    interface Tunnel1
     no ip address
     no ip redirects
     ipv6 address 6RD ::/128
     tunnel source Loopback0
     tunnel mode ipv6ip 6rd
     tunnel 6rd ipv4 prefix-len 16
     tunnel 6rd prefix 2003:AABB::/32
     tunnel 6rd br 172.16.0.1
    !
    ipv6 route 2003:AABB::/32 Tunnel1
    ipv6 route ::/0 Tunnel1 2003:AABB:1::
    !
    interface Loopback5
     no ip address
     ipv6 address 2003:AABB:2:1::1/64
    验证6RD隧道和IPv6路由
    CE-R2#show tunnel 6rd 
    Interface Tunnel1:
      Tunnel Source: 172.16.0.2
      6RD: Operational, V6 Prefix: 2003:AABB::/32
           V4 Prefix, Length: 16, Value: 172.16.0.0
           V4 Suffix, Length: 0, Value: 0.0.0.0
           Border Relay address: 172.16.0.1
      General Prefix: 2003:AABB:2::/48
    CE-R3#show tunnel 6rd 
    Interface Tunnel1:
      Tunnel Source: 172.16.0.3
      6RD: Operational, V6 Prefix: 2003:AABB::/32
           V4 Prefix, Length: 16, Value: 172.16.0.0
           V4 Suffix, Length: 0, Value: 0.0.0.0
           Border Relay address: 172.16.0.1
      General Prefix: 2003:AABB:3::/48
    BR-R1#show tunnel 6rd 
    Interface Tunnel1:
      Tunnel Source: 172.16.0.1
      6RD: Operational, V6 Prefix: 2003:AABB::/32
           V4 Prefix, Length: 16, Value: 172.16.0.0
           V4 Suffix, Length: 0, Value: 0.0.0.0
      General Prefix: 2003:AABB:1::/48 //BR设备得到的通用路由前缀
    CE-R3#show ipv6 route
    IPv6 Routing Table - default - 6 entries
    Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
           B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
           H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
           IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
           ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
           O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
           ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
           ld - LISP dyn-EID, a - Application
    S   ::/0 [1/0]
         via 2003:AABB:1::, Tunnel1
    S   2003:AABB::/32 [1/0]
         via Tunnel1, directly connected
    LC  2003:AABB:3::/128 [0/0]
         via Tunnel1, receive
    C   2003:AABB:3:1::/64 [0/0]
         via Loopback5, directly connected
    L   2003:AABB:3:1::1/128 [0/0]
         via Loopback5, receive
    L   FF00::/8 [0/0]
         via Null0, receive
    CE-R2#show ipv6 route
    IPv6 Routing Table - default - 6 entries
    Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
           B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
           H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
           IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
           ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
           O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
           ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site
           ld - LISP dyn-EID, a - Application
    S   ::/0 [1/0]
         via 2003:AABB:1::, Tunnel1
    S   2003:AABB::/32 [1/0]
         via Tunnel1, directly connected
    LC  2003:AABB:2::/128 [0/0]
         via Tunnel1, receive
    C   2003:AABB:2:1::/64 [0/0]
         via Loopback5, directly connected
    L   2003:AABB:2:1::1/128 [0/0]
         via Loopback5, receive
    L   FF00::/8 [0/0]
         via Null0, receive
    CE-R3#ping 2003:8888::1 source lo5
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2003:8888::1, timeout is 2 seconds:
    Packet sent with a source address of 2003:AABB:3:1::1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/6 ms
    !
    CE-R2#ping 2003:8888::1 source lo5
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2003:8888::1, timeout is 2 seconds:
    Packet sent with a source address of 2003:AABB:2:1::1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    
    IPv6主机已经可以通信,那么报文又是如何封装的呢,读者可以通过图7-15查看
    
    图7-15 6RD隧道的封装解析
    
    
    ![](https://s1.51cto.com/images/blog/201903/22/94e2ff752d2e689be931ea1d3e7f1b77.png?x-oss-process=image/watermark,size_16,text_QDUxQ1RP5Y2a5a6i,color_FFFFFF,t_100,g_se,x_10,y_10,shadow_90,type_ZmFuZ3poZW5naGVpdGk=)

    转载于:https://blog.51cto.com/enderjoe/2367434

    展开全文
  • docker nginx网站 ipv6改造方案和步骤整体概况改造原因ipv6和ipv4基础知识部署详情改造方案具体实施实施步骤结束语 整体概况 改造原因 最近公司在做ipv6的系统改造,从网络到程序都需要制作ipv4和ipv6的支持。一、...

    整体概况

    改造原因

    最近公司在做ipv6的系统改造,从网络到程序都需要制作ipv4和ipv6的支持。一、保证用户可以在仅支持ipv6的网络下进行正常访问。二、为以后全面扩展ipv6实施做基础工作。因为ipv6将全面取代ipv4.

    ipv6和ipv4基础知识

    1. IPv4可提供4,294,967,296个地址,IPv6将原来的32位地址空间增du大到128位,数目是2的128次方。能够对地球上每平dao方米提供6×1023个网络地址,在可预见的将来是不会耗尽的。
    2. IPv4 使用地址解析通讯协议 (ARP) IPv6使用用多点传播 Neighbor Solicitation消息取代地址解析通讯协议 (ARP) 。
    3. IPv4 中路由器不能识别用于服务质量的QoS 处理的payload。IPv6中路由器使用 Flow Label 字段可以识别用于服务质量的 QoS 处理的 payload
    4. IPv4的回路地址为: 127.0.0.1, IPv6的回路地址为 :
      000:0000:0000:0000:0000:0000:0000:0001 可以简写为 ::1。
    5. 在IPv4中,动态主机配置协议( Dynamic Host
      ConfigurationProtocol,DHCP)实现了主机IP地址及其相关配置的自动设置。一个DHCP服务器拥有一个IP地址池,主机从DHCP服务器租借IP地址并获得有关的配置信息(如缺省网关、DNS服务器等),由此达到自动设置主机IP地址的目的。IPv6继承了IPv4的这种自动配置服务,并将其称为全状态自动配置(stateful autoconfiguration)
    6. Pv4使用 Internet 群组管理通讯协议 (IGMP) 管理本机子网络群组成员身份,IPv6使用 Multicast Listener Discovery (MLD) 消息取代 IGMP
    7. 内置的安全性。IPSec由IETF开发是确保秘密、完整、真实的信息穿越公共IP网的一种工业标准。IPsec不再是IP协议的补充部分,在IPv6中IPsec是IPv6自身所具有的功能。IPv4选择性支持IPSec,IPv6自动支持IPSec
    8. 更好的QoS支持。QoS是网络的一种安全机制,通常情况下不需要QoS,但是对关键应用和多媒体应用就十分必要。当网络过载或拥塞时,QoS 能确保重要业务量不受延迟或丢弃,同时保证网络的高效运行。在IPv6 的包头中定义了如何处理与识别传输, IPv6 包头中使用 Flow Label 来识别传输,可使路由器标识和特殊处理属于一个流量的封包。流量是指来源和目的之间的一系列封包,因为是在 IPv6包头中识别传输,所以即使透过 IPSec 加密的封包 payload,仍可实现对 QoS 的支持

    详细对比请看 ipv6和ipv4史上最全对比

    部署详情

    应用层:
    现在部署的网站用docker启动nginx容器,使用服务器800端口映射nginx内部80端口,供外部访问
    网络层:
    1.外网ip(v4)映射内网ip(v4),让用户通过ip访问
    2.域名映射到外网ip(v4)地址,让用户通过域名进行访问
    以上也是最常见的一套网站部署方案。现需要加一个ipv6地址供用户访问

    改造方案

    刚开始总觉得ipv4升到ipv6 这一块应该是网络层更新就好了,查阅资料后发现不管网络层需要新增ipv6,启动的服务应用层也需要做配置,就那docker来说。默认是不启动ipv6映射带容器内部的,需要自己手动配置,具体操作见下文。
    因此改造要分两步走
    1.申请外网ipv6地址、和内网ipv6地址。若公司网络之前只支持ipv4的就需要联系三大网络运营商拉专线,
    2.之前的域名进行再加一个外网ipv6的指向地址。一个域名是可以同时指向不同类型的ip的
    3.应用程序开启ipv6的支持。

    具体实施

    实施步骤

    通过上面的整改方案大致可以分为以下走
    一、内网ip访问
    1.网络资源申请 (一个内网ipv6 一个外网ipv6)
    2.域名添加ipv6映射
    3.服务器本地网络配置
    经过1 2两步后我们得到了ipv6内网地址,然后我们需要将ip和网关在服务器上配置一下,目前服务器为linux,配置部署如下
    ①修改/etc/sysconfig/network-scripts/ifcfg-ens数字 (根据服务器的网口数)
    在这里插入图片描述
    ②重启网络
    执行命令 service network restart
    在这里插入图片描述
    重启好了测试一下内网ipv6是否可以访问
    执行ping -6 ipv6地址
    在这里插入图片描述
    可以ping通说明ipv6内网地址可以访问
    二、内网程序访问
    程序基于docker部署的,docker本身对ipv6是支持的,但是需要手动进行配置
    目前只做到所有的容器都指定到服务器申请的内网ipv6上。没有对每个容器单独分ipv6地址
    ①修改/etc/docker/daemon.json文件
    添加

     "ipv6": true,
     "fixed-cidr-v6": "内网ipv6地址/64",
    

    在这里插入图片描述
    ②重启docker
    执行systemctl reload docker
    ③有些服务可能没有自动启动 用docker ps查看一下,没启动的话用docker start容器名启动一下
    在这里插入图片描述
    ④验证容器内部是否支持ipv6
    执行docker inspect 容器名
    在这里插入图片描述
    ⑤验证内网服务是否支持ipv6
    使用curl "http://\[内网ip\]:800"
    注意地址加 " " 和 [] 前加\进行转义
    在这里插入图片描述
    因为是网站,curl后可以看到html信息说明内网的ipv6访问已经通了
    三、程序的外网ipv6访问
    内网已经通了,应该问题不大了
    先测试一下外网通不通,测试工具分享一下,因为现在办公网络还不支持ipv6。
    ipv6测试验证
    测一下外网ip如下就是不通的
    在这里插入图片描述
    具体原因就是ipv6的防火墙没关,ipv4和ipv6的防火墙需要分别关
    关闭具体步骤如下

    1. Linux7.x系统关闭防火墙iptables命令如下:
      查看防火墙的状态:firewall-cmd --state或者使用iptables -L

    关闭防火墙:systemctl stop firewalld.service,但是开机之后还会启动防火墙

    systemctl disable firewalld.service #禁止firewall开机启动

    查看防火墙配置:cat /etc/sysconfig/iptables-config

    1. Linux6.x系统关闭防火墙iptables命令如下:
      查看防火墙的状态:service iptables status 或者使用iptables -L

    关闭防火墙:service iptables stop ,但是开机之后还会启动防火墙

    chkconfig iptables off #禁止firewall开机启动

    查看防火墙配置:cat /etc/sysconfig/iptables

    1. 介绍如何使用在Ubuntu16.04中开启和关闭防火墙
      开启防火墙 :ufw enable

    关闭防火墙: ufw disable

    备注说明:

    1. iptables在Linux6和7系统,开启或者关闭命令和配置文件名都发生变化

    2. ipv6的防火墙,将对应的命令进行修改比如,将iptables改成ip6tables就是开启或者关闭ipv6的防火墙
      关闭之后再测一下 链接通畅。外网地址测一下
      在这里插入图片描述
      在这里插入图片描述

    结束语

    整体改造的难度不大,但是对整个网络架构和部署架构要有一定的了解,对linux的基本命令操作要有一定了解。再改造前查了很多资料,但是都觉得不是很详细,也就零零散散的找了一些资料,出现问题接着查资料,然后再尝试。做完之后对整个服务链路有进一步的认识。

    展开全文
  • 建立IPv6校园网.校园网IPV6部署方案
  • 《IPv6在企业网络中的部署》包含了在企业网内部署IPv6的所有知识,包含的主要内容有:启用IPv6的市场驱动力、IPv6企业网络设计的层次化模型、企业网各区块内的IPv6部署方案、IPv6网络管理,以及IPv6实验、试点网络...
  • IPv6解决方案ND防攻击技术白皮书

    千次阅读 2018-06-13 16:44:47
    ND,ARP,ND攻击,ARP攻击,交换机,IPV6 摘 要:本文介绍了在IPv6网络中的ND攻击及防攻击的技术思路以及H3C公司的ND防攻击方案部署的典型方案以及技术特点。 缩略语清单:缩略语 英文全名 中文解释 NDP Nei...
  • IPv6宽带接入网有很多值得学习的地方,这里我们主要介绍IPv6宽带接入网络部署方案。考虑到下一代互联网的发展趋势,未来的IPv6宽带接入网应该可以为每个用户分配一个静态的IPv6地址段。因此,需要考虑一些新技术的...
  • 企业IPv6双栈部署IPv6-ospf

    千次阅读 2018-11-13 20:06:03
    IPv6双栈部署概述此实验模拟一个企业外部门户网站进行IPv6改造,采用双栈方案,即网站IPv4与IPv6共存。实验还同时模拟了运营商网络,采用的是IPv6 OSPF。实际环境中可能不同的运营商会有不同的网络接入模式,需要...
  • 过对现网IPv6部署情况的分析,提出部署DS-lite(轻型双栈)过渡方案的可行性和必要性,然后对DS-Lite过渡方案的技术原理和网络层面的实现流程进行描述。其间对未部署过渡技术时普通家庭宽带开户的IT全流程进行介绍,通过...
  • :在探讨IPv6网络过渡策略和总结现有校园网基本 组网模型的基础上,提出了针对不同...结合济南大学IPv6网络的建设过程,对方案 的可行性进行了讨论。在济南大学校园主干网和学生宿舍 网中进行了部署,并同CEBNKI2连通。
  • 12月6日,阿里云宣布为企业提供全栈IPv6解决方案,加速推进中国下一代互联网应用。 作为国内首个全面支持IPv6的云厂商,过去5个月,阿里云DNS的IPv6日查询量增长了600倍,目前,核心产品已全面支持。 当下,各国...
  • IPv6全网解决方案

    2021-01-22 17:41:09
    IPv6全网解决方案 应用背景 IPv4协议是目前广泛部署的因特网协议,然而,随着Internet的发展,该协议在历经了20多年的实践与考验后,已逐渐暴露出设计的先天不足以及诸多局限,成为IP技术应用和未来发展的瓶颈制约。...
  • IPv6校园网方案建议书模板 第1章 建设背景与需求 第2章 XXX大学IPv6网络架构设计 第3章 IPv6部署的关键要素 .........
  • EPC部署IPv6策略研究

    2021-01-19 21:08:12
    IPv6的过渡技术、演进方案、地址分配建议、核心网的IPv6业务流程进行了详尽分析,给出了一种4G核心网EPC部署IPv6的策略,并结合中国电信在湖南的IPv6现场实验,对现网部署的4G 核心网EPC 设备进行了验证。
  • 访问: 阿里云 - 最高1888元通用代金券立即可用 作为国内首个全面支持IPv6的云厂商,过去5个月,...当下,各国都在加速推进下一代互联网的部署,今年5月,工信部发布了推进互联网协议第六版(IPv6)规模部署行动...
  • 摘 要:为应对IPv4地址枯竭,无锡城域网在规模部署双栈的基础上引入NAT444、DS-Lite等IPv6过渡技术,通过网络改造、溯源机制...描述了IPv6的过渡背景,对IPv6过渡技术进行了概述,介绍了过渡技术规模部署方案和情况。
  • 基于IPv6的SD-WAN部署

    2021-01-19 17:36:45
    介绍了SD-WAN的发展背景及目前基于IPv4的SD-WAN方案,提出了将IPv6应用到SD-WAN场景的方案,分析了要实现基于IPv6的SD-WAN方案需要在现有underlay和overlay层面上做出改变,并对利用IPv6技术实现SD-WAN的可行性进行...

空空如也

空空如也

1 2 3 4 5 ... 7
收藏数 134
精华内容 53
关键字:

ipv6部署方案