精华内容
下载资源
问答
  • 绍Linux下代理服务器安装调试的例子。
  • IBM X系列服务器安装调试,系统调试,配置
  • AD WINDOS 2003 主域、备域、邮件服务器安装调试手册_N
  • 1. 主域、备域、邮件服务器安装调试。 2. 主域正常关机,备域、邮件服务器出现何种情况? 3. 主域直接断电或直接断网,备域、邮件服务器出现何种情况? 4. 主域、备域角色互换(FSMO五种角色),互换后邮件服务器...
  • samba 做为主要的windown 和 Linux 通讯的服务器之一。 1. 查看是否安装了smb服务。  #rpm -ga|grep samba 或者 #service smb status 2.安装smb  # yum list samba 查询服务  # yum install samba 安装服务 ...

    samba 做为主要的windown 和 Linux 通讯的服务器之一。

    1. 查看是否安装了smb服务。

      #rpm -ga|grep samba     或者 #service smb status

    2.安装smb

      # yum list samba      查询服务

      # yum install samba 安装服务

    3.运行smb

      #systemctl start samba.service

    4.添加smb帐号

      #smbpasswd -a username

    5.配置smb.conf

        [tools]    中括号内为共享名

      comment =                           说明共享    

      path =          共享路役
      browseable =       是否可为浏览
      public =                                  匿名用户访问
      read only =                             是否为只读
      writable =         是否为可写
      write list = user1,user2    用户组
            @group
      vilid users = 那些用户可以访问(白名单)
      invalid users = 那些不能访问 (黑名单)

    6. 测试samba配置文件语法。 

      #testparm 

    7.配置完成就可以直接用\\IP   连接

      输入用户名,密码就可以访问了。

     

    注:#

      mkdir /share/test -pv  新建共享目录。

      #SElinux 关闭。

      getenforce 确保他没有运行。

      setenforce 0

      vi /etc/sysconfig/selinux
      把里边的一行改为
      SELINUX=disabled
      改了之后保存,然后重启就可以了

      #防火墙关闭:

      systemclt status firewalld.service  查看防火墙

      systemctl stop firewalld.service  关闭防火墙

      systemctl disable  firewalld.service 禁止防火墙开机启动

      systemctl start firewalld.service  启动防火墙

      #添加目录权限

      setfacl -m u:lytieshou:rwx  /share/test/

      #查看文件内容

      cat /shart/test/abc.txt

      ll -d /shart/test/  

      #smb 用户操作

      smbpasswd -a username   增加

      smbpasswd -d username   禁止

      smbpasswd -e username   启用

      smbpasswd -x username   删除

      #smb服务

      #service smb status  查看

      #service smb start  启动

      #service smb stop  停止

      #service smb restart  重启

      #service smb reload  重新载入

      

      

    转载于:https://www.cnblogs.com/yihao529/p/10026319.html

    展开全文
  • 服务器操作系统:CentOS7 一、挂载数据盘 如果没有买额外的数据盘,就跳过这步吧。不过估计很少有人不买吧。 阿里云有完整的挂载教程,直接照做就可以了,不再赘述 教程地址:...

    服务器操作系统:CentOS7

    一、挂载数据盘

    如果没有买额外的数据盘,就跳过这步吧。不过估计很少有人不买吧。

    阿里云有完整的挂载教程,直接照做就可以了,不再赘述

    教程地址:http://help.aliyun.com/view/13435365.html

    需要说明的是,如果你想挂载在自己的某个目录下,那么,先mkdir新建好目录,才能使用mount -a正确挂载

     

    二、配置防火墙

    虽然阿里方面声称他们有无敌安全防火墙--云盾,但是自己的服务器不弄个防火墙,就绝对不会踏实。

    另写了一篇专门配置防火墙的: http://www.cnblogs.com/kreo/p/4368811.html

     

    三、新建用户

    为什么好说的,总不能事事都麻烦root大神吧!人家很忙的。

    #不要用useradd,那个不会自动建立用户目录
    adduser www
    #设置www用户的密码
    passwd www

     

    四、安装配置FTP服务器 vsftpd

    详见 http://www.cnblogs.com/kreo/p/4377376.html

     

    四、安装配置WEB服务器 ngnix

    详见 http://www.cnblogs.com/kreo/p/4378086.html

     

    转载于:https://www.cnblogs.com/kreo/p/4377346.html

    展开全文
  • 系统管理员:OS安装调试 第一条、 安装OS ,取消默认共享等具有安全隐患的操作。 安装WIN2003 R2版并保证所有的磁盘都为NTFS格式.安装后更改主机名,命名规则为”应用简写_网段号_IP地址”如”YY_1_8”表示应用...

     

    系统管理员:OS安装调试

    第一条、      安装OS ,取消默认共享等具有安全隐患的操作<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

    安装WIN2003 R2版并保证所有的磁盘都为NTFS格式.安装后更改主机名,命名规则为应用简写_网段号_IP地址”YY_1_8”表示应用服务器.地址为*.*.1.8.如果是IIS服务器或者是K3应用服务器需要安装下列系统组件并根据各自的需要进行调试。

    IIS:需要安装应用程序服务器-ASP.NET、INTERNET信息服务器(IIS)、启用用网络COM+访问

    添加组件后设置系统密码。并停止没有用的用户。特别是对于有外网映射的IIS服务器,应做如下修改。禁止如下的用户。添加一个新用户如IISUSER来作为匿名访问INTERNET信息服务的用户。并限制该用户只为USER权限

    <?xml:namespace prefix = v ns = "urn:schemas-microsoft-com:vml" />

    由于禁止了系统默认的IIS匿名访问用户。所以需要做如下调整

    将网站的目录安全性中的匿名访问用户改为我们新建立的IISUSER

    K3系统:需要安装应用程序服务器-ASP.NET、INTERNET信息服务器(IIS)、启用用网络COM+访问、启用网络DTC访问

    如果服务器超过4g内存又有数据库的话。则需要打开系统的3gb开关。

    修改启动文件,添加/pae/3gb开关,步骤为:
    右击我的电脑 --> 属性 --> 高级 --> 启动和恢复 --> 设置 --> 手工编辑启动文件,加入开关,
    以下是一个 Boot.ini 文件的示例,其中已添加了 PAE(打开系统对大内存的支持) 3gb(打开SQL超过2Gb限制)开关
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect /PAE /3gb
    修改后需要立即测试系统是否正常,并确认性能不会反而下降。.删除注册表中HKEY_LOCAL_MACHINE-SAM-SAM权限中的administrator用户只保留SYSTEM服务.
    除非特殊需要.否则删除 磁盘的USEREVERYONE权限.
    检查禁止下列系统服务.

    1.NetMeeting Remote Desktop Sharing:允许受权的用户通过NetMeeting在网络上互相访问对方。这项服务对大多数个人用户并没有多大用处,况且服务的开启还会带来安全问题,因为上网时该服务会把用户名以明文形式发送到连接它的客户端,***的嗅探程序很容易就能探测到这些账户信息。
    2.Universal Plug and Play Device Host:此服务是为通用的即插即用设备提供支持。这项服务存在一个安全漏洞,运行此服务的计算机很容易受到***。***者只要向某个拥有多台Win XP系统的网络发送一个虚假的UDP包,就可能会造成这些Win XP主机对指定的主机进行***(DDoS)。另外如果向该系统1900端口发送一个UDP包,令“Location”域的地址指向另一系统的chargen端口,就有可能使系统陷入一个死循环,消耗掉系统的所有资源(需要安装硬件时需手动开启)。
    3.Messenger:俗称信使服务,电脑用户在局域网内可以利用它进行资料交换(传输客户端和服务器之间的Net SendAlerter服务消息,此服务与Windows Messenger无关。如果服务停止,Alerter消息不会被传输)。这是一个危险而讨厌的服务,Messenger服务基本上是用在企业的网络管理上,但是垃圾邮件和垃圾广告厂商,也经常利用该服务发布弹出式广告,标题为“信使服务”。而且这项服务有漏洞,MSBlastSlaMMer病毒就是用它来进行快速传播的。 
    4.Performance Logs And Alerts:收集本地或远程计算机基于预先配置的日程参数的性能数据,然后将此数据写入日志或触发警报。为了防止被远程计算机搜索数据,坚决禁止它。
    5.Terminal Services:允许多位用户连接并控制一台机器,并且在远程计算机上显示桌面和应用程序。如果你不使用Win XP的远程控制功能,可以禁止它。
    6.Remote Registry:使远程用户能修改此计算机上的注册表设置。注册表可以说是系统的核心内容,一般用户都不建议自行更改,更何况要让别人远程修改,所以这项服务是极其危险的。
    7.Fast User Switching Compatibility:在多用户下为需要协助的应用程序提供管理。Windows XP允许在一台电脑上进行多用户之间的快速切换,但是这项功能有个漏洞,当你点击“开始→注销→快速切换”,在传统登录方式下重复输入一个用户名进行登录时,系统会认为是暴力破解,而锁定所有非管理员账户。如果不经常使用,可以禁止该服务。或者在“控制面板→用户账户→更改用户登录或注销方式”中取消“使用快速用户切换”。
    8.Telnet:允许远程用户登录到此计算机并运行程序,并支持多种 TCP/IP Telnet客户,包括基于 UNIX Windows 的计算机。又一个危险的服务,如果启动,远程用户就可以登录、访问本地的程序,甚至可以用它来修改你的ADSL Modem等的网络设置。除非你是网络专业人员或电脑不作为服务器使用,否则一定要禁止它。
    9.Remote Desktop Help Session Manager:如果此服务被终止,远程协助将不可用。
    10.TCP/IP NetBIOS HelperNetBIOSWin 9X下就经常有人用它来进行***,对于不需要文件和打印共享的用户,此项也可以禁用
    Computer Browser 维护网络上计算机的最新列表以及提供这个列表
        Routing and Remote Access 在局域网以及广域网环境中为企业提供路由服务

        Removable storage 管理可移动媒体、驱动程序和库

       Print Spooler 将文件加载到内存中以便以后打印。要用打印机的朋友不能禁用这项

    Distributed Link Tracking Client 当文件在网络域的NTFS卷中移动时发送通知
      Alerter 通知选定的用户和计算机管理警报

      Error Reporting Service 收集、存储和向 Microsoft 报告异常应用程序

        IPSEC Policy Agent 管理IP安全策略以及启动ISAKMP/OakleyIKE)IP安全驱动程序

    改部分目录权限

    1、系统盘权限设置
      C:分区部分:

      
    c:\
      administrators 全部(该文件夹,子文件夹及文件
    )
      CREATOR OWNER 全部(只有子文件来及文件
    )
      system 全部(该文件夹,子文件夹及文件
    )
      IIS_WPG 创建文件/写入数据(只有该文件夹
    )
      IIS_WPG(该文件夹,子文件夹及文件)

    遍历文件夹/运行文件
      列出文件夹/读取数据

      读取属性

      创建文件夹/附加数据

      读取权限

         
    c:\Documents and Settings
      administrators 全部(该文件夹,子文件夹及文件
    )
      Power Users (该文件夹,子文件夹及文件
    )
      读取和运行

      列出文件夹目录

    读取
      SYSTEM全部(该文件夹,子文件夹及文件
    )
      
    C:\Program Files
      administrators 全部(该文件夹,子文件夹及文件
    )
      CREATOR OWNER全部(只有子文件来及文件
    )
      IIS_WPG (该文件夹,子文件夹及文件
    )
      读取和运行

      列出文件夹目录

    读取
      Power Users(该文件夹,子文件夹及文件
    )
      修改权限

      SYSTEM全部(该文件夹,子文件夹及文件
    )
      TERMINAL SERVER USER (该文件夹,子文件夹及文件
    )
      修改权限

    请找到c盘的这些文件,把安全性设置只有特定的管理员有完全操作权限
      下列这些文件只允许administrators访问

      
    net.exe
      
    net1.exet
      
    cmd.exe
      
    tftp.exe
      
    netstat.exe
      
    regedit.exe
      
    at.exe
      
    attrib.exe
      
    cacls.exe
      format.com

    net.exe,net1.exe,cmd.exe,tftp.exe,netstat.exe,regedit.exe,at.exe,attrib.exe,cacls.exe,format.com

    删除c:\inetpub目录,
    修改审核权限
    如下
    第二条、            OS补丁,保证系统最新。

    1. 由于安装WIN2003 R2 SP2版本后。系统补丁更新到WIN2003 SP2 更新补丁更新到2008-06-10日。所以可以根据情况更新补丁。

    2. Kb957097 SAM补丁

     

    2OS日志文件默认路径修改。系统日志不能被修改路径。

    默认保存的位置为C:\WINDOWS\system32\config\*Evt为了保存日志信息。使用下列命令对日志进行备份

    copy C:\WINDOWS\system32\config\*.evt D:\软件\log >D:\软件\log\log.txT另存为批处理文件后使用计划任务每天2200执行。

    第三条、            安装杀毒,并更新病毒库到最新。

    安装趋势网络版杀毒或者诺顿杀毒软件,安装后设置网络地址等信息。升级杀毒软件。如果安装其他杀毒软件。需要先进行测试是否杀毒软件是否与K3或者网站等程序有冲突

    安装并升级杀毒后使用最新的病毒码对全盘进行扫描.直到不能查找到任何病毒为止

    数据库安装。

    第四条、            数据库补丁安装。

    MSSQL2000安全设置

    SQL SERVER设置:

    1,master表中存储过程"sp_password"publicguest权限取消

    2,删除win系统用户sqldebugger ---没用的帐号,还经常给***利用

    3,用户去掉db_onwer权限

    IIS方面:

    1,删除默认站点

    2删除不使用的脚本映射(.htw,.idc)

    3,禁止"FrontPage Server Extensions"

    4,在"Web 服务扩展"中禁止"WebDAV"

    5asp的站就删除剩下asp映射,php就删除剩下php映射

    第五条、            交付给软件部门进行软件安装调试.

    软件部门安装调试结束后.新建os用户,并分配可进行中间件操作权限。

    修改或重建管理员用户。避免使用默认的管理员用户名称。

    收回OS管理员用户及数据库的最高权限的用户密码,并分配有权限控制软件维护员用户。

    第六条、            等待应用调试完成后。

    取消所有的默认共享。关闭远程访问。添加绿色的系统检测软件对系统进行全面检查。包括。

    进程检测程序,启动程序检测程序。查看系统发包程序,天网防火墙2.0绿色版.并按照应用开放端口

    分别检测系统是否有可以进程,

    启动进程.服务.驱动中是否有可疑项

    是否有程序大量发包.

    是否有不明地址进行大量的探测性连接

     

    转载于:https://blog.51cto.com/pysx0503/165915

    展开全文
  • 一台CISCO2501路由器,作为AAA服务器的客服端,一台内网的PC机作为AAA服务器端,PC机上面安装又Cisco sectuer ASC软件。 实验要求: 安装服务器(ACS),并对服务器进行基本设置:User、指定Client端IP及Key。 ...

    实验环境
    一台CISCO2501路由器,作为AAA服务器的客服端,一台内网的PC机作为AAA服务器端,PC机上面安装又Cisco sectuer ASC软件。

    实验要求:
    安装服务器(ACS),并对服务器进行基本设置:User、指定Client端IP及Key。
    配置Client端,所有默认用户登陆时使用Tacacs+服务器进行认证,并当Tacacs+服务器出错时才采用Client本地数据库进行认证。
    允许某些账号拥有Enable最高权限,某些账号只拥有Enable 7权限,密码均保存在Tacacs+服务器中。
    4为EXE会话进行记账,进程开始和结束时发通告给Tacacs+服务器。
    5使用没有enable权限的用户能够在用户模式下使用 show starup-config 命令。

    实验配置:
    AAA客服端
    Router>
    Router>en
    Router#conf t
    Router(config)#host gaokai
    gaokai(config)#line con 0
    gaokai(config-line)#pass gaokai
    gaokai(config-line)#login
    gaokai(config-line)#exec-t 0 0
    gaokai(config-line)#logg syn
    gaokai(config-line)#line vty 0 4
    gaokai(config-line)#pass gaokai1
    gaokai(config-line)#login
    gaokai(config-line)#line aux 0
    gaokai(config-line)#pass gaokai2
    gaokai(config-line)#login
    gaokai(config-line)#exit
    < 基本配置>
    gaokai(config)#int e/0
    gaokai(config-if)#ip add 192.168.1.221 255.255.255.0
    gaokai(config-if)#no shut
    <配置客服端IP地址后,要PingAAA服务器端,Ping通是实验成功的前提条件>
    gaokai(config-if)#exit
    gaokai(config)#aaa new-model
    <启用AAA服务>
    gaokai(config)#username gaokai password gaokai
    <设置本地用户和密码/gaokai>
    gaokai(config)#tacacs-server host 192.168.1.6
    <指定AAA服务器端IP地址>
    gaokai(config)#tacacs-server key ccie
    <指定TACACS+加密密钥,这个密钥两端要设置一样>
    gaokai(config)#aaa authentication login default group tacacs+ local none
    <启用所有线路人身份验证功能,默认时候连接TACACS+服务器验证,当连接失败时使用本地用户和密码认证>
    gaokai(config)#aaa authentication enable default group tacacs+ enable none
    <启用特权模式身份认证,默认时使用TACACS+服务器,当连接失败时,使用本地特权认证>
    gaokai(config)#aaa accounting exec default start-stop group tacacs+
    <启用AAA统计模式,记录访问开始和结束时段的信息>
    gaokai(config)#privilege exec level 0 sh starup-config
    <把"sh starup-config"命令权限下降到0>
    gaokai(config)#exit
    gaokai#sh run
    Building configuration...

    Current configuration : 1362 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname gaokai
    !
    boot-start-marker
    boot-end-marker
    !
    !
    username gaokai password 0 gaokai
    aaa new-model
    !
    !
    aaa authentication login default group tacacs+ local none
    aaa authentication enable default group tacacs+ enable none
    aaa accounting exec default start-stop group tacacs+
    aaa session-id common
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.221 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial1/0
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    no ip http server
    ip classless
    !
    !
    tacacs-server host 192.168.1.6
    tacacs-server directed-request
    tacacs-server key ccie
    privilege exec level 0 show
    !
    line con 0
    exec-timeout 0 0
    password gaokai
    logging synchronous
    transport preferred all
    transport output all
    line aux 0
    password gaokai2
    transport preferred all
    transport output all
    line vty 0 4
    password gaokai1
    transport preferred all
    transport input all
    transport output all
    !
    End

    转载于:https://blog.51cto.com/cisco130/1094694

    展开全文
  • 服务器基础安装调试

    2013-07-09 15:44:23
    浪潮服务器上架方法及注意事项 操作系统安装方式及过程介绍
  • 用于搭建自己的云平台时,安装调试caddy,步骤简单。
  • wampserver安装调试

    2020-07-13 22:56:37
    wampservevr服务器安装调试
  • Ubuntu安装网络调试助手
  • Linux服务器队列安装调试。自己整理的安装队列的一系列步骤和注意的内容。
  • 1: mysql下载与安装过程 可参考网址: https://blog.csdn.net/weixin_40396510/article/details/79277731 2 : 所遇mysql启动问题  安装mysql时报错计算机中丢失MSVCR120.dll 文件  可参考网址 : ...
  • 远程调试需要服务器端的组件支持,我们今天的内容就是怎么来安装这个服务器调试环境,用到的调试组件是Zend Debugger,它是轻便而且够用的,在撰写本文时,其最新版本是5.2.14,与网络上广为流传的5.2.10版略有...
  • 这是之前公司离开之前编写出来的一些资料,前面部分比较有参考性,后面的属于公司的一些业务,可不看,由于工作忙,没做后面的调整,各位大概参考一下。
  • 本章介绍织梦内容管理系统(dedecms)服务器安装调试。使用的ftp上传工具falshfxp 转载于:https://www.cnblogs.com/dukey/archive/2012/05/25/2518714.html
  • zabbix官网zabbix agent客户端下载页面:https://www.zabbix.com/download_agents(包含各种服务器的各种不同版本,选择对应版本下载安装即可) zabbix agent官网下载链接:...
  • IBM_BladeCenter_S刀片服务器基本安装调试
  • 功能:本地服务器。可以在局域网内访问/调试html网页文件。
  • 服务器远程调试

    2018-10-24 09:41:00
    但是我的电脑上没有,原因是没有安装过微软的远程调试工具,可以上官网上下载,选择需要的版本进行安装 安装成功后进入到以下文件夹 C:\Program Files\Microsoft Visual Studio 12.0\Common7\IDE...
  • 版权声明:可以任意转载,转载时请务必以超链接形式标明文章...Fedora Core 1服务器调试手记 关键字 samba fedora smb smbclient smbpasswd Samba3.0服务器实战调试 fedora预装的samba已经是samba-3.0....
  • 使用vscode进行远程服务器代码调试

    千次阅读 2019-07-22 16:07:45
    使用vscode进行远程服务器代码调试 使用了一段时间的vscode对...主机、服务器安装ssh 将主机的ssh id_rsa.pub 写入服务器的/home/user_name/.ssh/authorized_keys文件中 vscode 的扩展中安装 Remote Developme...
  • 调试技术是我们编程中不可或缺的重要部分,调试器...既然如此,Zend Studio的集成环境拥有一个调试器也就是理所当然的事情了,但是,该调试器在配置使用起来,其显示出来的强劲功能一定会让你惊叹不已! 事实...
  • 通用的做法是ssh服务器,vim代码,之后python运行文件,但是如果遇到调试问题怎么办? 尽管调试对于很多大牛是没有必要的,但是对于我们这些深度学习渣渣还是很有必要在编写程序的时候进行调试;下面就开始讲解如何...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,020
精华内容 2,808
关键字:

服务器安装调试