精华内容
下载资源
问答
  • 路由汇聚特点及环路避免

    千次阅读 2018-05-25 11:12:30
    配置路由聚合后,如果被聚合IP地址范围内的某条链路频繁Up和Down,该变化并不会通告到被聚合的IP地址范围外的设备(因为被聚合的各子路由最终是以聚合路由的形式通告出去),可以避免网络中的路由震荡,...

    某个路由器上做路由汇聚时,该路由器本身的路由表是保持不变的,仍为各网段的明细路由,但是他们通告给其他路由器时,其他路由器只有该汇聚路由。
    配置汇聚路由可以有效减少路由表中的条目,减小对系统资源的占用。配置路由聚合后,如果被聚合IP地址范围内的某条链路频繁Up和Down,该变化并不会通告到被聚合的IP地址范围外的设备(因为被聚合的各子路由最终是以聚合路由的形式通告出去),可以避免网络中的路由震荡,在一定程度上提高了网络的稳定性。
    在配置黑洞路由时,注意所配置的网段大小要与聚合后的路由一致,这样才能完全防止聚合环路。

    192.168.0.1,192.168.1.1,192.168.2.1,192.168.3.1 可以汇聚成 192.168.0.0/22 汇聚成 192.168.0.0 / 21 就扩大了,包含 192.168.4.1,192.168.5.1, 192.168.6.1,192.168.7.1 。

    展开全文
  • SEP是一种以太环路保护机制,它通过有选择性地阻塞网络环路冗余链路,来达到消除网络二层环路的目的,避免报文在环路网络中增生和无限循环,有效防止形成网络风暴。本人刚接手了一套网络,布局也不是太复杂,基本全...

      作者:邓聪聪

      智能以太保护SEP(Smart Ethernet Protection)是一种专用于以太网链路层的环网协议。SEP是一种以太环路保护机制,它通过有选择性地阻塞网络环路冗余链路,来达到消除网络二层环路的目的,避免报文在环路网络中增生和无限循环,有效防止形成网络风暴。本人刚接手了一套网络,布局也不是太复杂,基本全是2层网络,所以就利用了sep这个小技术。

      实例1:

     

    sysname sw1
    #
    vlan batch 11 to 12 4008 4094
    #
    stp disable
    #
    sep segment 5
     control-vlan 4008
     block port optimal
     preempt delay 30
     protected-instance 0 to 48
    sep segment 10
     control-vlan 4094
     block port optimal
     preempt delay 30
     tc-notify segment 5
     protected-instance 0 to 48
    #
    interface Vlanif12
     ip address 10.1.1.1 255.255.255.224
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 11 4008
     stp disable
     sep segment 5
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 11
    #
    interface GigabitEthernet0/0/3
     shutdown
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 to 12 4008
     stp disable
     sep segment 5 edge primary
    #
    interface GigabitEthernet0/0/5
     shutdown
     port link-type trunk
     port trunk allow-pass vlan 11 4094
     stp disable
     sep segment 10 edge primary
    #
    sysname sw2
    #
    stp disable
    #
    sep segment 5
     control-vlan 4008
     protected-instance 0 to 48
    #

      sep segment 11
      control-vlan 100
      block port optimal
      preempt delay 30
      tc-notify segment 5
      protected-instance 0 to 48

    interface GigabitEthernet0/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 4008
     stp disable
     sep segment 5
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 4008
     stp disable
     sep segment 5

      interface GigabitEthernet0/0/4
      port link-type trunk
      port trunk allow-pass vlan 11 100
      stp disable
      sep segment 11 edge primary

    sysname sw3
    #
    stp disable
    #
    sep segment 5
     control-vlan 4008
     protected-instance 0 to 48
    sep segment 10
     control-vlan 4094
     tc-notify segment 5
     protected-instance 0 to 48
    #
    interface Vlanif11
     ip address 1.1.1.30 255.255.255.224
    #
    interface Vlanif12
     ip address 10.1.1.2 255.255.255.224
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 11
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 4008
     stp disable
     sep segment 5
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 to 12 4008
     stp disable
     sep segment 5
     sep segment 5 priority 128
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 4094
     stp disable
     sep segment 10
     sep segment 10 priority 128
    #
    sysname sw4
    #
    vlan batch 11 4094
    #
    stp disable
    #
    sep segment 10
     control-vlan 4094
     protected-instance 0 to 48
    #

      sep segment 11
      control-vlan 100
      tc-notify segment 10
      protected-instance 0 to 48

    interface Vlanif11
     ip address 1.1.1.4 255.255.255.224
    #

     interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 11 100
     stp disable
     sep segment 11
     sep segment 11 priority 128

    interface GigabitEthernet0/0/4
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 4094
     stp disable
     sep segment 10
    #
    interface GigabitEthernet0/0/5
     port link-type trunk
     port trunk allow-pass vlan 11 4094
     stp disable
     sep segment 10
    sysname sw5
    #
    sep segment 11
     control-vlan 100
     protected-instance 0 to 48
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 11 100
     stp disable
     sep segment 11
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 11 100
     stp disable
     sep segment 11
    #

     

     

      实例2:

    9306配置:

    sep segment 1
    control-vlan 4094
    block port optimal
    preempt delay 30
    tc-notify segment 2
    protected-instance 0 to 48
    sep segment 2
    control-vlan 4094
    block port optimal
    preempt delay 15
    tc-notify segment 1
    protected-instance 0 to 48
    sep segment 3
    control-vlan 4090
    block port optimal
    preempt delay 15
    protected-instance 0 to 48
    #
    interface Vlanif1
    ip address 1.1.1.1 255.255.255.0
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
    shutdown
    port hybrid tagged vlan 4094
    stp disable
    sep segment 1 edge secondary
    #
    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 4094
    stp disable
    sep segment 2 edge primary
    #
    interface GigabitEthernet0/0/3
    port hybrid tagged vlan 4094
    stp disable
    sep segment 1 edge primary
    #
    interface GigabitEthernet0/0/4
    port hybrid tagged vlan 4090
    stp disable
    sep segment 3 edge primary
    #
    interface GigabitEthernet0/0/5
    port hybrid tagged vlan 4090
    stp disable
    sep segment 3 edge secondary
    #

     

    分支1-5700配置:

    sep segment 1
     control-vlan 4094
     block port optimal
     protected-instance 0 to 48
    
    #
    interface Vlanif1
     ip address 1.1.1.254 255.255.255.0
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 4094
     stp disable
     sep segment 1
    #
    interface GigabitEthernet0/0/2
     port hybrid tagged vlan 4094
     stp disable
     sep segment 1
    #

    分支3-5700配置:

    sep segment 1
    control-vlan 4094
    tc-notify segment 2
    protected-instance 0 to 48
    sep segment 2
    control-vlan 4094
    tc-notify segment 1
    protected-instance 0 to 48
    #
    interface Vlanif1
    ip address 1.1.1.2 255.255.255.0
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 4094
    stp disable
    sep segment 2 edge secondary
    #
    interface GigabitEthernet0/0/2
    port hybrid tagged vlan 4094
    stp disable
    sep segment 1
    sep segment 1 priority 128
    #
    interface GigabitEthernet0/0/3
    port hybrid tagged vlan 4094
    stp disable
    sep segment 1
    #

    分支2-5700配置:

    sep segment 2
    control-vlan 4094
    protected-instance 0 to 48
    #
    interface Vlanif1
    ip address 1.1.1.3 255.255.255.0
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
    port hybrid tagged vlan 4094
    stp disable
    sep segment 2
    sep segment 2 priority 128
    #
    interface GigabitEthernet0/0/2
    shutdown
    port hybrid tagged vlan 4094
    stp disable
    sep segment 2

    分支1配置:

    sep segment 3
     control-vlan 4090
     protected-instance 0 to 48
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 4090
     stp disable
     sep segment 3
    #
    interface GigabitEthernet0/0/4
     port hybrid tagged vlan 4090
     stp disable
     sep segment 3
    #

    分支2配置:

    sep segment 3
     control-vlan 4090
     protected-instance 0 to 48
    #
    interface Vlanif1
     ip address 1.1.1.6 255.255.255.0
    #
    interface MEth0/0/1
    #
    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 4090
     stp disable
     sep segment 3
     sep segment 3 priority 128
    #
    interface GigabitEthernet0/0/5
     port hybrid tagged vlan 4090
     stp disable
     sep segment 3

     

    转载于:https://www.cnblogs.com/dengcongcong/p/9072943.html

    展开全文
  • 提出了一种将拓扑排序应用于片上网络的死锁检测与恢复的方法...结果表明,所提出的方法简单有效,可以支持各种路由算法,与广泛应用的死锁避免策略相比,其网络资源的利用率和网络性能有所提高,并具有一定的容错能力。
  • 简介 由于RIP基于距离矢量算法,存在收敛慢(30s)、易产生路由环路(需要水平分割、毒性反转等防环)、可拓展性差(16跳不可达)等问题,所以被OSPF取代。...采用的SPF算法可以有效避免环路 触发...

    简介

    1. 由于RIP基于距离矢量算法,存在收敛慢(30s)、易产生路由环路(需要水平分割、毒性反转等防环)、可拓展性差(16跳不可达)等问题,所以被OSPF取代。
    2. OSPF(开放式最短路径优先协议)特性:
    • 大中型网络上使用最为广泛的IGP协议
    • 链路状态路由协议
    • 无类
    • 使用组播(224.0.0.5和224.0.0.6)
    • 收敛较快
    • 以开销(Cost)作为度量值
    • 采用的SPF算法可以有效避免环路
    • 触发式更新(以较低频率发送定期更新(30s),被称为链路状态泛洪
    • 区域的设计使得OSPF能支持更大规模的网络
    • 通过LSA形式发布路由
    • 不支持自动汇总,支持手动汇总

    OSPF区域概述

    术语 备注
    区域(area) 为适应大型网络,OSPF在AS内划分多个区域;区域是以接口为单位来划分的;每个OSPF路由器只维护所在区域的完整链路状态信息
    区域ID 可以表示为一个十进制数字,如1;也可以表示为一个IP,如0.0.0.1
    区域优点 尽量减少路由表条目(从而减小了CPU、内存的消耗);使拓扑变化仅影响本区域内部

    OSPF区域类型

    类型 备注
    骨干区域 Area 0,核心区域,也叫传输区域(负责在不同的非骨干区域间分发路由信息)
    非骨干区域 非Area 0区域,也称为常规区域
    备注 所有其他非骨干区域必须和骨干区域直接相连

    OSPF路由器类型

    类型 备注
    IR 内部路由器,所有接口都属于同一区域
    BR 骨干路由器,至少有一个接口属于骨干区域
    ABR 区域边界路由器,连接一个或多个区域到骨干区域,至少有一个接口属于骨干区域
    ASBR 自治系统边界路由器,把从其他路由协议学习到的路由以引入的方式到OSPF进程中
    备注 一台路由器可以同时属于多种类型

    OSPF核心工作流程

    1. 发现并建立邻居
    2. 传播LSA(区别于距离矢量的路由表更新)
    • Link State Advertisement,链路状态宣告(路况信息)
    • 链路:路由器接口
    • 状态:描述接口信息(地址、掩码、开销、网络类型、邻居关系等)
    1. 将LSA泛洪到区域中的所有OSPF路由器,而不仅是直连的路由器
    2. 收集LSA创建LSDB(链路状态数据库、地图)
    3. 使用SPF算法计算到每个目标网络的最短距离,并将其置于路由表中

    OSPF三张表

    • 邻居表(dis ospf peer):记录所有邻居关系
    • 链路状态数据库(dis ospf lsdb):记录所有链路状态路由信息
    • 路由表(dis ospf rout):记录最佳路由

    Router ID

    • 运行OSPF协议前,必须选取一个RID
    • 用来唯一标识一台OSPF路由器
    • RID可以手动配置,也可以自动生成(如果什么都没有配置的情况下,默认RID为0.0.0.0)
    规则 备注
    RID选取顺序规则 1. 手动配置(推荐);2. 回环接口上选取IP地址最高的;3. 物理接口上选取IP地址最高的
    备注 RID选举具有非抢占性,除非重启OSPF进程

    OSPF数据包结构和类型

    在这里插入图片描述
    在这里插入图片描述

    封装在IP协议之上,IP协议号89

    OSPF数据包的五种类型

    OSPF数据包类型 作用
    Hello 建立并维护邻居关系
    Database Description(DBD) LSDB的摘要(仅包含LSA头部)
    Link State Request(LSR) 请求LSA
    Link State Update(LSU) 发送LSA
    Link State Acknowledge(LSAck) 对LSU的确认

    Hello发送间隔:10s
    死亡间隔:40s
    注:不同网络类型Hello包发送间隔不同,具体可查看OSPF不同网络类型之间通讯

    OSPF状态机制

    在这里插入图片描述

    状态 解释
    Down(失效状态) 没有收到Hello包
    Init(初始状态) 没有收到Hello包,且在邻居列表没有看到自己
    2-way(双向通讯状态) 没有收到Hello包,但在邻居列表看到自己,形成邻居关系
    Exstart(交换初始状态) 决定信息交换时路由器的主从关系
    Exchange(交换状态) 向邻居发送DBD数据包
    Loading(加载状态) LSR和LSU交换
    Full(完全临接状态) LSDB同步,形成临接关系
    备注 只有2-way和Full是稳定状态

    OSPF工作流程

    在这里插入图片描述

    选定OSPF主从路由器步骤:

    在这里插入图片描述

    设:R1和R2开启OSPF,抓包后看到如图信息。则:
    R1和R2分别发送DBD包,包含如图信息,则判断两台路由器的RID,RID大的为主路由器,从路由器会跟随主路由器序列号进行发送
    解释:
    (I)Init:表示是否为自己发送的第一个包
    (M)More:表示后面是否还有包
    (MS)Master:表示是否为主路由器(Yes表示为主路由器,但每台设备最初都会认为自己是主路由器)
    DD Sequence:自己的序列号(随机值)

    OSPF第一阶段是使用Hello包建立双向通信过程,称为邻居(2-way)关系
    在这里插入图片描述

    第二阶段通过LSA达到LSDB同步,建立临接关系
    在这里插入图片描述

    OSPF邻居建立条件:必须三层直连

    OSPF邻居建立条件:

    • RID唯一
    • Hello/Dead时间间隔一致
    • 区域ID一致
    • 认证(如果启用了认证)一致
    • 链路MTU大小一致(华为默认不开启检查,思科默认开启)
    • 子网掩码一致(以太网环境)
    • 网络地址一致
    • 末梢区域设置一致

    OSPF网络类型:基于端口

    在这里插入图片描述
    在这里插入图片描述

    缺省情况下,OSPF认为以太网的网络类型是广播类型,PPP、HDLC的网络类型是点到点类型
    缺省情况下,OSPF认为帧中继(FR)、ATM(异步传输)的网络类型为NBMA(非广播多路访问)

    DR和BDR

    在这里插入图片描述

    术语 描述
    DR 指定路由器
    BDR 备用DR
    DRother 非DR、BDR设备
    关系 DR、BDR和其他DRother是临接关系(Full);DRother之间是邻居关系(2-way)
    地址 224.0.0.6是DRother向DR、BDR发送链路状态更新;224.0.0.5是DR向所有OSPF路由器发送链路状态更新
    选举规则 首先比较Hello报文中携带的优先级:优先级范围0~255,默认=1,优先级最高的被选举为DR,优先级次高的被选举为BDR,优先级为0的不参与选举;优先级一致的情况下,比较RID,越大越优;选举具有非抢占性,除非当DR和BDR都失效或重启OSPF进程

    OSPF度量值

    • cost开销:在每一个运行OSPF的接口上,都维护着一个接口COST。
    • Cost=100Mbps/带宽(默认情况下)
    • 到一个目标网络的度量值=从源到目标所有出站接口的COST值累加
    • 华为回环口开销默认为0
    • 思科回环口开销默认为1
    • 优先走COST值小的路径

    OSPF配置

    命令 备注
    ospf 1 router-id 1.1.1.1 开启OSPF,进程号缺省为1;手动配置Router ID为1.1.1.1
    area 0 配置区域(0默认骨干区域)
    network 192.168.0.0 0.0.0.255 宣告网络,即指定运行OSPF的接口;使用反掩码来匹配(0.0.0.0则表示精确宣告)
    display ospf peer [brief] 显示OSPF邻居信息(brief表示只显示简短信息)
    display ospf lsdb 显示OSPF链路状态数据库
    display ospf routing-table 显示OSPF路由信息
    ospf timer hello 10 修改Hello包发送间隔(默认10s,死亡时间为Hello包间隔的4倍)
    display ospf interface g0/0/0 显示OSPF接口信息
    ospf dr-priority 100 修改OSPF接口优先级(0~255 0不参与选举)值大的则为DR(注:OSPF是非抢占性的 )
    ospf cost × (进入接口)修改OSPF接口cost值
    bandwidth-reference 100 调整带宽参考值,默认为100Mbps;需要在整个OSPF网络中统一进行调整
    reset ospf process 重启OSPF进程

    OSPF认证

    在这里插入图片描述

    命令 备注
    int g0/0/0-> ospf authentication-mode ma5 1 ciper wakin 配置接口认证
    ospf 1->area 0 -> authentication-mode md5 1 cipher wakin 配置区域认证
    备注 如果同时配置,接口认证优先生效

    md5表示加密算法
    1表示秘钥ID,需要保证秘钥ID一致
    cipher:密码的英文
    wakin表示秘钥


    OSPF综合实验

    题目:
    在这里插入图片描述

    配置:
    可选择在eNSP中单台路由器一个个进行配置,也可“敲白板”。单个配置可能由于快慢问题造成DR、BDR选举不如意;敲白板也有可能造成此问题,下面写步骤及解决办法。

    1. 配置主机名及地址、配置OSPF、配置RID
      R1:
    sys--------进入用户视图
    sysname R1------将设备名修改为R1
    int g0/0/0--------进入g0/0/0端口
    ip add 192.168.0.1 24-----将g0/0/0端口配置192.168.0.1 /24的子网掩码
    ospf 1 route-id 1.1.1.1----配置OSPF,进程号为1,手动配置RouterID为1.1.1.1
    area 0-----配置区域0
    network 192.168.0.1 0.0.0.0----在OSPF中宣告此地址192.168.0.1 0.0.0.0表示精确宣告(也可选择网段范围宣告,即network 192.168.0.0 0.0.0.255)
    

    R2:

    sys
    sysname R2
    int g0/0/0
    ip add 192.168.0.2 24
    ospf 1 route-id 2.2.2.2
    area 0
    network 192.168.0.2 0.0.0.0
    

    R3、R4、R6设备修改部分信息即可(注:需要根据自己搭建的拓扑图对应接口进行调整)

    问题点:
    将R1、R2、R3、R6设备配置完成,通过dis ospf peer br查看邻居表/通过dis ospf int g0/0/0查看端口OSPF信息,寻找已经选举出来的DR、BDR是否为R1及R2。如不是,则通过将R1、R2设备的优先级调整为200、100,并重启R1、R2的OSPF进程即可。步骤为(两台设备分别配置):

    int g0/0/0-----进入g0/0/0端口
    ospf dr-pri 200---将端口优先级调整为200
    quit--------退出到上一级视图(也可直接按Ctrl+Z到系统视图)
    q--------退出到上一级视图
    q--------退出到上一级视图(到达系统视图)
    reset ospf process---重置OSPF进程
    y----------------------确认重置OSPF进程
    

    再次通过查看邻居表进行验证,通过查看R1的路由表可得:R1到4.4.4.4的开销是49,R1到34.0.0.0网段开销也是49。所以验证得:华为LoopBack口的开销值为0;并且由于R3–R4间是通过串口相连,串口传输速率为2.048Mbps,所以R3–R4网段的开销值为48

    1. 配置R8设备
    sys
    sysn R8
    int g0/0/0
    ip add 48.0.0.8 8
    ip route-static 0.0.0.0 0.0.0.0 48.0.0.4---配置默认路由(第一字段0.0.0.0表示目的网段,第二字段0.0.0.0表示该网段的子网掩码,48.0.0.4表示去往该网段的下一跳地址)
    

    验证:R4ping R8测试是否可通

    在R4配置默认路由到R8

    ip route-static 0.0.0.0 0.0.0.0 48.0.0.8
    
    1. 在R4配置默认外部路由:
    ospf 1
    default-rotue-advertise----OSPF缺省路由发布命令(一般在企业出口路由器配置)
    

    验证:在R1查看路由表,是否有48.0.0.0网段

    1. 配置ACL及NAT(之后更新具体内容)
      R4:
    acl 2000
    rule 1 permit
    quit
    int g0/0/0
    nat outbound 2000
    
    1. 认证
      R1、R2、R3、R6:
    ospf 1
    area 0
    authentication-mode md5 1 cipher wakin
    

    抓包验证:
    在这里插入图片描述

    Auth Type:表示有认证
    Auth Crypt Key id:秘钥ID
    Auth Crypt Data Length:秘钥长度
    Auth Crypt Sequence Number:秘钥序列号
    Auth Crypt Data:秘钥数据(加密后的)

    展开全文
  • 建立了完整的0-1矩阵微粒群优化计算法则,在网络寻优过程中仅通过改变有向边的方向去除网络中出现的环路,以保证搜索过程中网络结构的完整性.通过ASIA网和CarStart网的数据实验证明了算法的有效性.
  • ospf原理

    万次阅读 多人点赞 2017-11-26 20:23:03
    OSPF的特别:采用组播更新的方式进行更新(224.0.0.5、224.0.0.6),增量更新(只发送别人没有的),以cost作为度量值,有效避免环路(在单区域中可以完全避免环路,但是在多区域中并不能完全避免环路

    1.OSPF协议的基本原理:

    RIP的缺点:存在最大跳数是15跳,无法应用在大型网络中;周期性的发送自己的全部的路由信息,浪费流量,收敛速度缓慢;本身的算法存在环路的可能性很大

    OSPF的特别:采用组播更新的方式进行更新(224.0.0.5、224.0.0.6),增量更新(只发送别人没有的),以cost作为度量值,有效的避免了环路(在单区域中可以完全避免环路,但是在多区域中并不能完全避免环路)。

    2.OSPF的表:

    邻居表:记录了建立邻居关系的路由器

    LSDB(链路状态数据库):包含了本路由器上的区域的所有的链路状态信息,并实时同步

    路由表:经过SPF算法计算出的路由存放在OSPF路由表中

    3.生成OSPF路由:

    相同区域内的每一台路由器的LSDB是相同的,有LSDB得到带权的有向图,每台路由器以自己为根节点极端最小生成树

    4.骨干区域和非骨干区域的划分:

    为了减少路由器上LSDB的规模,骨干区域负责转发非骨干区域的之间的路由,骨干区域的区域号为0

    OPSF划分区域的要求:

    1.骨干区域必须是保持连通

    2.非骨干区域必须与骨干区域连通(可以通过虚链接的方式实现非骨干区域与骨干区域不是物理上的连通)

    5.OPSF路由器的类型:

    区域内路由器(Internal Router)

    区域边界路由器(ABR)

    骨干路由器(BR)

    自治系统边界路由器(ASBR)

    一台路由器可以同时是ABR,BR和ASBR

    6.OSPF的网络类型:

    Router ID:是一个32bit的无符号整数,可以在一个自治系统中唯一标识一台路由器,可以自动生成,也可以手动配置。

    自动生成Router ID:如果本设备上配置了loopback接口地址,则选择loopback接口地址最大的作为Router ID,如果没有配置loopback接口地址,则选择所有接口中ip地址最大的作为Router ID

    网络类型有:Broadcast(广播网络:Ethernet)、NBMA(非广播多点可达:fr)、P2P(点对点网络:PPP)、P2MP(点对多点网络:没有链路默认是点对多点,可以通过修改)

    7.OSPF报文和封装:

    Hello报文:建立并维持邻居关系

    DD报文:对LSDB内容的汇总(仅仅包含LSA摘要)

    LSR报文:请求自己没有的或是比自己更新的链路状态信息(LSA)

    LSU报文:链路状态更新信息

    LSAck:对LSU报文的确认

    封装格式:

    链路层帧头

    IP Header

    OSPF Packet

    链路层帧尾

    8.邻居的建立和状态的迁移

    邻居的建立和维持都是通过交互Hello报文来实现的

    Broadcast网络中,NBMA网络中都需要进行DR和BDR的选举

    DR/BDR的选举原则:首先比较hello报文中所携带的优先级,优先级大的成为DR,当优先级为0的时候则不会进行选举。

    优先级一致的情况下,则比较Router ID,Router ID大的成为DR

    保持稳定的原则:一旦网络中DR/BDR选举完成之后,就算出现优先级更高的路由器,也不会再重新选举。

    邻居关系的建立过程

     

    (1)RTA发送Hello报文

    DR=0.0.0.0

    Neighbors seen=0

    RTB收到Hello报文之后,发现RTA这个邻居将自己的邻居表进行修改:

    邻居ID

    邻居地址

    邻居状态

    1.1.1.1

    10.1.0.1

    lint

    接下来发送的Hello报文

    DR=2.2.2.2

    Neighbors seen=RTA

    RTA收到RTB发送的Hello报文之后,将自己的邻居表进行修改:

    邻居ID

    邻居地址

    邻居状态

    2.2.2.2

    10.1.0.2

    2-way

    接下来发送的Hello报文:

    DR=2.2.2.2

    Neighbors seen=RTB

    RTB收到之后,将自己的邻居表里面的邻居状态修改为2-way

    第一阶段完成

    邻居建立第二阶段:

    RTA发送DD报文,RTB接收到之后,对比自己的LSDB数据库,如果RTA发送的DD报文中的LSA摘要,自己这边都有,则状态立马进入Full,如果有没有的或是更新的,则RTB发送LSR请求自己没有的和比自己更新的LSA,RTA通过发送LSU报文对RTB进行更新,RTB收到LSU报文之后,更新完成状态进入Full,并且回复LSAck报文,RTA状态进入Full。

    LSDB的更新,接收到一条LSA,如果这条LSA自己的LSDB中不存在,则直接进行更新,如果自己的LSDB数据库中存在,那么会与那一条LSA进行比较,留下LSA序列号更大的。

    9.配置和优化OSPF

    OSPF中的network命令是指定接口开启OSPF

    OSPF优化命令,因为在P2P网络中不需要进行DR/BDR的选举,所以收敛速度大大加快,会将Broadcast的网络改为P2P

    命令:ospf network-type p2p

    也可以修改Hello报文的发送时间间隔(默认为2s)

    命令:ospf time hello 2

    当两端的OSPF的网络类型不同时,邻居关系能达到邻居关系能达到Full但是不能进行路由学习。

    10.配置OSPF的接口的参考带宽:

    bandwidth-refernce (缺省为100M cost为1)

    cost=参考带宽/接口带宽

    参考带宽最好根据实际情况修改为最大的(本设备上)接口带宽。

     

    假设接口的cost值修改为上图所示,RTA上有一个100.1.1.1,当RTA把这个宣告进OSPF的时候,RTC收到这条路由之后,这条路由的cost=20+40=60(就是相当于,这条路由传递方向的进方向的接口带宽),例如:当RTC上有一条20.0.0.0/24的路由要传递给RTA的时候,此时这条路由到达RTA之后的cost=40(10+30)

    OSPF cost计算标准:沿着路由传递方向累加进站口的cost

    11.OSPF报文的定时器的默认值

    网络类型

    Hello定时器

    邻居失效时间

    Broadcast

    10

    40

    P2P

    10

    40

    NBMA

    30

    120

    P2MP

    30

    120

    12.配置OSPF引入外部缺省路由:

    在公网与内网相接的设备上,做OSPF引入缺省路由,可以告诉内网的所有开启OSPF的设备,要想到达外网,可以通过本设备。

    default-route-advertise

    参数:always :当本机没有默认路由的时候,会产生一条缺省路由,发给其他邻居,但是本机上不会存在。

    Cost:默认路由的度量值

    13.OSPF高级特性:

    OSPF虚链接:解决了骨干区域被分割的问题和非骨干区域和骨干区域无法连通的问题。

    命令:在这两个区域的ABR上的中间区域中配置vlink-peer 对方的Router ID

    LSA类型和路由选择:

    LSA报文头的三个关键字:LS TYPE(LSA的类型)、Link state ID(链路状态ID,不同的LSA的链路状态ID不同)、Advertising Router(产生这条LSA的Router ID),这三个关键字唯一的标识了一条LSA。

    常用的六类LSA:

    LSA的类型

    可以发送的角色

    第一类LSA(Router LSA)

    ALL Routers

    第二类LSA(Network LSA)

    DR

    第三类LSA(Network Summary LSA)

    ABR

    第四类LSA(ASBR Summary LSA)

    ABR

    第五类LSA(AS External LSA)

    ASBR

    第七类LSA(NSSA External LSA)

    ASBR

    第一类LSA:所有的开启OSPD功能的路由器都会产生,描述的是自己直连网段的链路信息(链路类型、开销),将自己所有的直连链路的信息汇总成一条发布给本区域内的其他路由器,不可以跨区域传输。

     

    第二类LSA:描述的是一个NBMA网络,或是一个Broadcast网路的所有的路由器以及掩码的信息,在区域内传播。如果一个单一区域,那么这个区域内可以只存在第一类LSA和第二类LSA。

     

    第三类LSA:将所连接区域的链路信息以子网的形式,发送给相邻的区域,三类LSA的link State ID是目的网段。当从一个非骨干区域通过骨干区域传输到另一个非骨干区域的时候,会将Advertising Router修改为本区域的发送这条路由的ABR的Router ID

     

    第五类LSA:描述到AS外部的信息,跨区域传输的时候,不会改变始发者。这样就可能会造成下一跳不可达,所以就通过第四类LSA来进行弥补。

     

    第四类LSA:描述的是目标网络是ASBR的Router ID的LSA,始发者会随着区域间额传输而改变。

    如果没有五类LSA则不会存在四类LSA,但是当有五类LSA的时候,也不一定存在四类LSA。

    比如:

    RTB上引入了一条外部路由,此时在RTA和RTC上并不存在目标网络是RTB 的 Router ID的四类LSA,因为RTA与RTC知道怎么到达RTB,并不会产生下一跳不可达的情况。

    第五类LSA的两种外部路由:

    第一类外部路由:cost=外部开销+内部开销(外部路由可靠性高)

    第二类外部路由:cost=外部开销(外部开销默认为1)(外部路由可靠性低)都会默认为第二类外部路由

    14.OSPF选路原则:

    区域内路由、区域间路由、第一类外部路由、第二类外部路由

    在类型相同的情况下在比较cost值。

    15.引入外部路由时导致的问题及解决的办法

    引入外部路由的时候,产生对应的五类LSA,Link State ID为目的网络,但是不会携带掩码的信息,所以当引入了两条目的网络一样但是掩码不一样的路由的时候,会认为是同一条LSA,导致路由学习错误。

    当遇到这种情况的时候,ASBR会将这两条路由中的掩码大的那一条的LSA的Link State ID修改为子网的广播地址,来进行区分。

    16.OSPF特殊区域:

    Stub区域、Totally stub区域、NSSA区域

    Stub区域:一般都是将边缘区域划分成Stub区域,在这个区域中不存在第四类和第五类LSA,但是会由ABR发送一条默认路由,下一跳指向ABR

    Totally stub区域(完全stub 区域):为了进一步缩小路由的数量,这个区域禁止了第三类LSA的存在,同时第四类和第五类LSA也不存在,但是会由ABR产生一条三类的默认路由下一跳指向ABR

    NSSA区域(不是那么完全的stub区域):需要ASBR的存在但是 又不允许五类LSA的出现,所以这个区域不存在第四类和第五类LSA,但是,会由ASBR产生一条七类的LSA,七类LSA只能在NSSA区域中传播,经过ABR传递到其他的区域的时候,会转换成五类的LSA。

    17.OSPF协议的路由聚合:

    ABR对三类LSA的聚合:

    abr-summary advertise/not-advertise

    advertise 聚合后并且发布出去

    not-advertise 聚合后不发送出去

    在做聚合时应该在路由产生的区域做

    ASBR对五类或是七类LSA的聚合

    asbr-summary

    18.OSPF过滤计算出的路由(在LSA经过SPF算法得到最佳路由导入的路由表的时候,进行过滤):只会影响到本设备上的路由表中的路由,并不会影响到其他的设备。

    在区域中配置:filter-policy acl import

    19.OSPF过滤三类LSA:

    Filter acl import/export 对不同的区域import 或是 export不同。

    展开全文
  • 然而已有的多路径路由算法要么存在潜在的路由环路,要么网络的冗余链路未能充分利用,为此,采用邻居链路屏蔽和源标识嵌入相结合的技术,设计了一种有效的链路多样性多路径路由算法,可以有效避免路由环路,冗余链路也...
  • 每个路由表的条目都经过了特别的处理,能够相互分辨出是旧有的还是新的路由,从而有效避免路由环路。AWR在移动和固定的无线网状网络中都表现非常出色。AWR已被用于许多实际场合。许多仿真和试验结果也显示:AWR在...
  • west-first路由算法

    2020-05-28 12:35:26
    其基本思想是在路由中禁止最少的拐弯 以避免通道之间的循环依赖,从而有效避免死锁。 在二维 Mesh网络中,存在8种可能的拐弯并且可 能形成两个环路,如图2a所示。为了避免死锁,必 须禁止其中的一些拐弯情况...
  • 6.1动态路由——OSPF

    2019-11-09 17:15:56
    一、概述 OSPF全称:Open Shortest Path First,开放式最短路径优先协议。 OSPF协议是一种基于链路状态的内部网关路由协议。...采用的SPF算法可以有效避免环路 触发式更新(以较低频率,每30分钟发送定期...
  • 一、OSPF协议描述OSPF(Open ShortestPath First)开放最短路径优先协议为IETF开发的一种开放式的动态路由协议,该协议根据当前链路状态进行SPF算法,通过将大型网络...,提升网络收敛速度以及可以有效避免环路产生...
  • BGP协议

    2015-09-10 19:48:00
    BGP属于自治系统间路由协议。BGP的主要目标是为处于不同AS中的路由器之间进行路由信息通信提供保障。...通路向量信息十分有用的,因为只要简单地查找一下BGP路由更新的AS编号就能有效避免环路的出现。BGP对...
  • STP通过阻塞端口来消除环路,并实现链路备份的目的,首先可以在 生成树中选择一个根桥,其他的都是非根桥,在根桥上选择一个指定端口,在非根桥上选择一个根端口,没有成为指定端口和根端口的都是预备端口被阻塞,...
  • •采用的SPF算法可以有效避免环路 •在互联网上大量使用,是运用最广泛的路由协议 工作原理 邻居表建立、建立LSA树、LSDB表建立、路由表 OSPF个区域之间通信必须经过区域0 1.邻居发现:以224.0....
  • 你搞懂OSPF协议了吗?

    2021-01-09 13:43:38
    使用SPF算法可以有效避免环路 触发式更新(30分钟发送定期更新,被称为链路泛洪) 区域设计使OSPF能支持更大规模的网络 通过LSA(链路状态)形式发布路由 不支持自动汇总,支持手动汇总 OSPF直接运行在IP协议之上,...
  • OSPF多区域路由协议

    2019-10-23 15:51:46
    3、3类LSA和路由聚合可以有效减少或避免某区域内的路由变化对整网带来路由震荡。这个在网络大的时候非常重要。 当然划分区域也有一些弊端: OSPF是链路状态算法,是loop free(无路由环路)的。这个链路状态算法...
  • 为了避免RIP路由在网络中被无休止地泛洪,RIP定义了路由的最大跳数为15跳,也就是说,RIP路由的最大可用跳数为15跳,当一条路由的度量值达到16跳时,该路由被视为不可用,路由所指向的网段被视为不可达。 很显然,...
  • 高速板设计技术

    2012-02-19 23:05:23
    1.3.1.1 地线电缆的有效性 11 1.3.1.2 分离模拟电源平面与数据电源平面 12 1.3.1.3 避免重叠分离的板平面 12 1.3.1.4 隔开敏感元件 12 1.3.1.5 隔开敏感元件将电源总线靠近信号线 12 1 2. 传输信号线 2.1 ...
  •  为避免递归查找: 串行网络:使用出接口  以太网络:同时使用中间地址和出接口  4.反复的静态路由安装和删除  尽可能地使用出接口而不是中间地址来配置静态路由。  5.使用丢弃路由  有时网络中有环路的...
  • 单IP限速,解决BT/QQ直播占用大量网络带宽,影响网速等问题 3、最精细的单IP限速,合理分配网络带宽,避免网络扔堵,拒绝掉线! 小区,学校,酒店作宽带二级运营的ISP商功能  1.PPPoE用户认证+Radius或者利用内置的...
  • 控制部分就是由CPU中央处理系统、输入电路(键盘)、输出电路(数码管)、双音多频DTMF检测电路、用户环路状态检测电路、自动交换网络驱动电路与交换网络转换电路、扩展电路、信号音控制电路等电路组成。 下面简要...
  • 1.常用网络命令: 25 2.网线的制作: 27 3.局域IP地址配置: 27 4.采用TP-LINK路由器连接上网: 27 第五章 系统常用命令及格式转换 30 1.Msconfig 系统的关闭起动项命 30 2.Dxdiag系统信息查看命令 30 3....

空空如也

空空如也

1 2
收藏数 25
精华内容 10
关键字:

有效避免网络环路