精华内容
下载资源
问答
  • 不行python -m pip install --upgrade pip升级后安装 2.在anaconda中安装(anaconda中又可能没有目标) 3 .whl文件安装 https://www.lfd.uci.edu/~gohlke/pythonlibs/ pip install whlfilepath\filename.whl 4.查找...

    1.pip install 库名
    不行python -m pip install --upgrade pip升级后安装
    或者多试几次,pip不稳定说不定第二次就成功了:
    因为pip安装失败多数属于网速问题,换个网络环境再试一下吧,good luck to you!
    eg:

    
    C:\Users\ASUS>pip install pymongo
    Collecting pymongo
      Could not find a version that satisfies the requirement pymongo (from versions: )
    No matching distribution found for pymongo
    
    C:\Users\ASUS>pip install pymongo
    Collecting pymongo
      Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ConnectTimeoutError(<pip._vendor.urllib3.connection.VerifiedHTTPSConnection object at 0x000001869DA25EF0>, 'Connection to files.pythonhosted.org timed out. (connect timeout=15)')': /packages/10/35/f081e8f16cb357cc1e082743fed98fb699f3b9f215addc1b4b8bd1b58472/pymongo-3.7.2-cp37-cp37m-win_amd64.whl
      Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ConnectTimeoutError(<pip._vendor.urllib3.connection.VerifiedHTTPSConnection object at 0x000001869DA2A550>, 'Connection to files.pythonhosted.org timed out. (connect timeout=15)')': /packages/10/35/f081e8f16cb357cc1e082743fed98fb699f3b9f215addc1b4b8bd1b58472/pymongo-3.7.2-cp37-cp37m-win_amd64.whl
      Downloading https://files.pythonhosted.org/packages/10/35/f081e8f16cb357cc1e082743fed98fb699f3b9f215addc1b4b8bd1b58472/pymongo-3.7.2-cp37-cp37m-win_amd64.whl (311kB)
        100% |████████████████████████████████| 317kB 19kB/s
    Installing collected packages: pymongo
    Successfully installed pymongo-3.7.2
    

    2.在anaconda中安装(anaconda中又可能没有目标库)
    3 .whl文件安装
    https://www.lfd.uci.edu/~gohlke/pythonlibs/
    pip install whlfilepath\filename.whl
    4.查找目标库的pypi官网:
    eg:snownlp
    https://pypi.org/project/snownlp/0.12.3/#files
    ![在这里插入图片描述](https://img-blog.csdnimg.cn/20190310112256121.png?x-oss-process=image/watermark,type_ZmFuZ3poZW5naGVpdGk,shadow_10,text_aHR0cHM6Ly9ibG9nLmNzZG4ubmV0L3FxXzQxMjI4MjE4,size_16,color_FFFFFF,t_70
    在这里插入图片描述
    pip install path/filename.py
    5.先下载sdk文件:
    https://blog.csdn.net/xxzj_zz2017/article/details/79452028

    6.下载GitHub上的python模块,比如itchat
    7.有时会有GFW的问题,则使用国内源:(当然这里需要感谢豆瓣)

    pip install packagename -i --trusted-host http://pypi.douban.com/simple/
    

    或者https加密的直接就信任了:

    pip install packagename -i  http://pypi.douban.com/simple/
    
    展开全文
  • 因为需要用到python的wordcloud 第三方库。刚开始我用的原始的方法,直接在控制台输入pip3.7 install wordcloud直接下载,网速贼慢。还在下载中出现了错误 在最后面有个warning 大概意思就是让升级pip的版本 然后...

    新人小白,大佬勿喷!

    因为需要用到python的wordcloud 第三方库。刚开始我用的原始的方法,直接在控制台输入pip3.7 install wordcloud直接下载,网速贼慢。还在下载中出现了错误
    在这里插入图片描述
    在最后面有个warning
    在这里插入图片描述
    大概意思就是让升级pip的版本

    然后我用下面的代码升级到了最新版本 pip-20.2.3

    python -m pip install --upgrade pip -i https://pypi.douban.com/simple
    

    再次下载还是不行。
    在这里插入图片描述

    可能是因为下载国外的资源,网速太慢导致的。
    还有种下载第三方库的方法,在 清华大学开源软件镜像站 下载,由于是国内的,所以网速相对快一些

    直接打开cmd,输入以下代码(pip/pip3/pip3.7具体使用什么,还需要看你有哪些pip的版本,可以在Scripts中查找):`

    pip3.7 install -i https://pypi.tuna.tsinghua.edu.cn/simple wordcloud
    

    在这里插入图片描述

    展开全文
  • 继上篇文章知道,指定Python语言版本进行安装第三方库,只要执行命令:py -3 -m pip install 库名==Version即可;但出现报错的情况,如下: 从报错信息上看,可知:是由于pip版本过低,导致无法安装。此时可以...

    继上篇文章知道,指定Python语言版本进行安装第三方库,只要执行命令:py -3 -m pip install 库名==Version即可;但出现报错的情况,如下:

    从报错信息上看,可知:是由于pip版本过低,导致无法安装。此时可以升级pip的版本。

    执行命令:py -3 -m pip install --upgrade pip 即可。

    pip升级完成后,再执行py -3 -m pip install selenium==version即可(注意:第三方库指定版本时,双等号两边不能有空格。)

     

    【注意】当通过cmd导入第三方库完成后,但是在pycharm中引用仍报错。是由于在pycharm中没有引入第三方库包。

    此时,应该点击pycharm中file-》setting-》选择Project->点击工程文件右侧“+”按钮->在左侧头部搜索输入框,搜索selenium->选择对应版本进行安装。安装成功后,再次返回到执行代码文件,运行即可

    展开全文
  • python全球社区: https://pypi.org/ 三种方法: 1、pip安装方法(需要联网) 常用的pip命令: pip install 库名 pip install -U 库名(升级版本) ...某些第三方库pip下载,需要编译才能安装 http://

    python全球社区: https://pypi.org/
    三种方法:
    1、pip安装方法(需要联网)
    常用的pip命令:
    pip install 库名
    pip install -U 库名(升级版本)
    pip show 库名 (查看信息)
    pip search 关键词 (搜索相关第三方库)
    pip list (列举已经安装过的第三方库)
    2、第三方库集成安装方法
    Anaconda
    3、文件安装方法
    为什么有些第三方库用pip可以下载,但无法安装?
    某些第三方库pip下载后,需要编译才能安装
    http://www.lfd.uci.edu/~gohlke/pythonlibs/ (有很多编译后的版本)
    在uci页面上搜索相关库名

    展开全文
  • 众所周知,安装第三方库需要使用pip工具,cmd打开命令行直接输入pip install ModuleName,比如笔者要安装pyperclip模块,就应输入pip install pyperclip。 然而安装过程中却出现了pip版本过低,必须升级pip version...
  • python用pip安装第三方库总是不成功

    万次阅读 2018-08-09 14:43:29
    发现第三方库的奥妙所在,想去尝试用用新的用法,可却遇到了问题 怎么明明别人一句话就安装上了。我这个就出现问题了 结果是因为pip版本低了,升级下你的pip 重新使用新的命令行 python -m pip install xxx ...
  • 文章目录安装pip如何查看自己的pip版本和升级pip安装第三方库 安装pip   因为在2020年后python2.7已经停止了对python3的支持,正式停用,而python3中自带了 pip,所以无需安装。 如何查看自己的pip版本和升级pip ...
  • 2020版本安装与卸载Python第三方库(pycharm) 一、安装 1、在文件(File)菜单中选择默认设置( Settings)。 2、在打开的界面中,左侧列表中点击项目解释器选项(Project InterPreter);界面右侧的项目解释器...
  • 最近电脑升级到了win10,以前是win7,运用pip工具安装Python第三方库时遇到如下问题,与win7有一些差别如下: 1. Python安装过程比win7较慢,等了有五分钟左右才装好,3.5.4版本。 2. pip的使用,win10自带的...
  • 1. 注意:  pip命令执行不成功,有...2. pip升级命令举例:  python -m pip install --upgrade pip 3. pip在线安装命令举例:  pip install pymysql 4. 在线安装的路径举例:  C:\Program Files\python3...
  • 本来是想安装第三方库,但是出现提示: 于是便按照指令 'python -m pip install --upgrade pip’进行安装,结果尝试多次,都是在安装中途报错,显示如下: 问题解决 通过在网上查找相关原因时,发现问题的原因...
  • 1、查看本机中是否有需要升级的官方网站最新版的模块包 pip list --outdated 2、选择需要更新到最新版的模块包: 方法一: pip install -U xxx (xxx表示安装包) //适用于需要更新包不多的情况 方法二:首先安装pip...
  • 问题: File “D:\Solfware\Annaconda\lib\site-packages\pandas_init_.py”, line 19, in “Missing required dependencies {0}”....pandas 升级后 报上述错误,看网上的介绍基本方法都是卸载重装numpy,卸载重装
  • 我们的服务器由Puppet配置管理工具来管理,服务器上线由puppet...等初始化完成开始运行,运行一段时间有一些需要自动和手动操作的任务(比如升级、重启、备份等),这时候我们使用Fabric来批量执行这些临时任务。
  • Linux下python升级后requests模块的安装

    千次阅读 2016-05-10 14:38:58
    毕竟丰富的第三方库python的优势所在,为了更加方便的安装第三方库,使用pip命令,我们需要进行相应的安装。 在安装pip过程前需要先安装setuptools 1、安装pip前需要前置安装setuptools1.安装setuptools wget -...
  • 今天用pycharm安装bs4的时候一直报错,retry几次之后报ssl出错,然后所有的第三方库都无法安装,但是当时一直在听歌就没意识到可能是网络问题。尝试了很多方法,1.升级pip工具2.下载beautifulsoup使用Python命令...
  • ,这个装了所有项目的第三方库,这个比较杂,后续可以分区建,现在将就下吧 找到了上面的路径,接下来就简单多了,我们新建的项目可以通过继承来获取所有的相关库, 1.先看看我们的设置操作 先进入到设置页面 2....
  • 安装一个第三方库sviewgui结果使得pyqt的版本升级导致与spyder冲突,巧的是这已经是第二次了。不过这一次是我不知道它会升级。。。。。然后尝试各种方法,没有成功,只好使用终极大法——重装anaconda。写下提醒...
  • 在使用python过程中,经常需要下载一些第三方库,这里就有可能遇到一些问题。 1、提示找不到 这时pip就可能需要更新了,可以通过 python -m pip install --upgrade pip -i ...
  • 老版本的一些第三方软件库会随着新版本软件的更新,老本版所支持的第三方库就没有人去维护和更新了,后面在使用的过程中,如果出现了bug,就会花很大的精力去解决。 步骤 基于上面的要求,我将生产虚机上的ython...
  • 学爬虫导入第三方库的时候,出问题,所以尝试升级pip,也是同样的问题,网上找了好多种方法无解,小白好难![图片说明](https://img-ask.csdn.net/upload/202008/28/1598578075_695092.png) ![图片说明]...
  • 安装显示黄色部分 —黄色表示警告,不妨碍使用,一般以版本过低显示.可以直接忽略,可以升级版本(建议直接忽略) 安装中有:”拒绝访问:’C:\programe files(x86)\python…’”这样的字眼 –表是安装路径是C盘下面,...
  • 参考博客:Pycharm无法安装第三方...升级结束,继续安装第三方库,又出现了之前的错误: socket.timeout: The read operation timed out 和 ERROR: Command errored out with exit status 1: python setup.py egg_...
  • 看到Python3.9.0版本发布,...最后自己尝试将所有第三方库升级最新解决,记录一下最终解决的步骤: 1、将脚本用到的第三方库升级到最新 首先执行pip list命令,看看有哪些库是可以升级的 然后执行pip li..
  • 配置软件仓库:ubuntu的正式仓库没有3.6,我们通过第三方仓库: sudo add-apt-repository ppa:deadsnakes/ppa sudo apt update sudo apt install python3.6 安装成功就ok,不要做任何更改,避免入坑,我给大家...
  • 从在公司实习到正式入职,一直还在被同事使用的是我写的一个自动发布...因为涉及到sftp的相关操作,最初选择了paramiko这个饱受好评的第三方库。可是当时该库只支持Python2,所以我的这个自动化工具在Python2的环...
  • python语言简洁、有大量第三方库 (二):Python IDE推荐 Pycharm Visual Studio Code (三):基础语法 1-1:简单输入打印语句 dream = input("你的梦想是什么?") print(dream) 1-2:条件判断语句 level =...
  • 1.先用pip list查看了第三方库的列表,显示有openpyxl的库 2.在cmd操作的时候英文显示pip库的版本太低,于是先升级pip版本,不料用pip安装pip时,出现了错误,pip也好像没有了,于是在python的官网下载压缩文件安装...
  • 小编在论坛中看到有同学询问如何安装Python3.7,考虑到不少同学从panda进化到Lion,也有了安装Python最新版本的需求,下面小编就来带着大家一起在...这样可以避免之后安装 Python 时缺少第三方库的问题。 ...
  • 在安装第三方库的时候,有的会提示需要pip升级后才能用,然后我们就用提示中的命令去升级,发现还是报错。 报错如:You are using pip version 19.0.3, however version 20.0.2 is available.. 解决办法: 报错...

空空如也

空空如也

1 2 3 4 5
收藏数 87
精华内容 34
关键字:

python升级后第三方库

python 订阅