精华内容
下载资源
问答
  • Linux提示Python版本

    2020-12-12 17:15:52
    今天想给虚拟机安装docker, 在安装docker-compose的时候报错, 提示 imageio requires Python ‘>=3.5’ but the running Python is 2.7.13 解决办法: cd /usr/bin/ ls -l | grep python 可以看到是python...

    今天想给虚拟机安装docker, 在安装docker-compose的时候报错, 提示

    imageio requires Python ‘>=3.5’ but the running Python is 2.7.13
    

    解决办法:

    1. cd /usr/bin/

    2. ls -l | grep python
      可以看到是python指向的是python2,而Python2指向的是Python2.7

    lrwxrwxrwx 1 root root          16 8月  14 14:26 python -> /usr/bin/python2
    lrwxrwxrwx 1 root root           9 10月  3  2017 python2 -> python2.7
    
    1. 只要把python的指向改为python3即可
     sudo rm -rf python
     sudo ln -s /usr/bin/python3  /usr/bin/python
    

    最后执行 python, 可以看到已经python版本已经提升为3.7.3
    在这里插入图片描述

    展开全文
  • 之前为了学习安装了python2.7是通过anaconda2安装的现在想换用Python3 所以寻找版本并存 可以来回切换的方法打开命令提示符,记住是命令提示符 不是win10自带的windows powershell 等会会说他俩的区别输入以下指令...

    之前为了学习安装了python2.7是通过anaconda2安装的

    现在想换用Python3 所以寻找版本并存 可以来回切换的方法

    打开命令提示符,记住是命令提示符 不是win10自带的windows powershell 等会会说他俩的区别

    输入以下指令(我选择的是python3.6版本):

    conda create --name py36 python=3.6

    安装完以后 屏幕会提示你activate py36字样

    在anaconda/envs/目录下会出现一个以py36为名字的文件夹 这个就是pyhon3.6的位置

    接着输入

    conda info --envs

    会打印出

    20180310163328159960.png

    其中root代表我们之前默认的python2.7版本

    输入activate py36 (就这里,如果你在windows powershell里面输入的话 会不起作用)

    会告诉你已经激活

    查询当前python版本 python -V会显示版本已经切换成功了

    但是此时 如果你输入pip -V 你会发现pip依然是之前版本的python

    怎么办?

    去anaconda/envs/py36/Script/目录下

    20180310163328522242.png

    找到上图两个文件 添加一个数字3或者36都行 用于区别

    然后呢 也要配置一下环境变量

    把pip3.exe所处的那个目录添加到PATH中去

    这样 在命令提示符里面输入pip对应的是py27的pip 输入pip3对应的是py36的pip3

    给py36安装一些包的时候以前使用pip intsall 现在就要用pip3 install 了

    切回原来的版本 使用avtivate root

    20180310163328640398.png

    展开全文
  • Python】如何查看安装的python版本

    万次阅读 多人点赞 2018-08-14 20:34:07
    首先,将如下路径(根据安装时设置的路径而变)添加到环境变量的path中(环境变量中的用户变量和...然后,在命令提示符中输入python --version,显示当前的版本号,如下图: 附python扩展包的下载地址:https:/...

    首先,将如下路径(根据安装时设置的路径而变)添加到环境变量的path中(环境变量中的用户变量和系统变量均可,我添加的是用户变量的path中):

    E:\PyCharm\python-3.6.5,因为python.exe在这个文件夹中,如下图所示:

    然后,在命令提示符中输入python --version,显示当前的版本号,如下图:

     

     附python扩展包的下载地址:https://www.lfd.uci.edu/~gohlke/pythonlibs/

    展开全文
  • Python版本共存安装

    2018-11-16 20:52:00
    下载系统对应的Python版本 按照提示步奏安装,安装路径选择自定义,方便查找 安装完成后,按win+R键,输入cmd进入cmd程序,输入Python,如果能够进入交互环境,则表示安装完成 Python版本共存  1.多版本...

    Python的安装

    1. 进入Python官方网站:www.python.org下载系统对应的Python版本
    2. 按照提示步奏安装,安装路径选择自定义,方便查找
    3. 安装完成后,按win+R键,输入cmd进入cmd程序,输入Python,如果能够进入交互环境,则表示安装完成

    Python多版本共存

      1.多版本共存是什么意思?为什么要安装Python多版本呢?

        所谓多版本共存指的是Python2版本和Python3版本共存;虽然目前的主流版本是Python3版本,且Python2版本已经停止更新,由于目前任有很大一部分企业的Python程序是用Python2版本编写,所以避免不了还要使用Python2版本过渡。

       2. 如何实现Python多版本共存?

    1. 分别下载好python2和python3相对较新版本安装到计算机上
    2. windows系统—>win+R—>cmd—>python,你会发现你只能打开最先安装的Python版本
    3. 打开电脑属性—>高级系统设置—>环境变量:修改用户变量里的“PATH”,点击“编辑”,添加“PATH"的读取路径,在原路径的基础上输入”;“+当前Python版本存放的地址。

                

       4.分别进入不同版本Python存放的文件夹找到Python.exe文件,复制并粘贴到当前文件夹,更改两者文件为py3和py2(保证两者不同,且方便调用即可)

      5.重复2步骤,分别输入py3或者py2就可以调用不同版本的Python版本了。

    • Python中的pip工具安装步骤同上

    • win10版本操作系统安装步骤与win7一致,在环境变量位置稍有不同:环境变量—>PATH—>新增—>添加Python文件存放位置路径(win7的环境变量是从左到右读取,win10环境变量从上往下读取,对照理解第2步出现的原因)。

    转载于:https://www.cnblogs.com/liusijun113/p/9971522.html

    展开全文
  • 如果已安装cv2,但版本不对应。 可用代码pip unstallopencv-contrib-python pip unstallopencv-python 如果提示未下载。 可删除带opencv的文件。注意opencv下载的时间。因为系统中 会有其他带opencv的文件名。...
  • 文章目录python的使用一.问题二.解决办法 python的使用 一....输入下面命令安装第三方库的时候,提示You are using pip version 19.2.3, ...提示pip版本太低 根据提示继续输入命令 python -m pip install --upgra...
  • mac电脑下载python版本安装后python快捷方式指向的还是老版本 mac电脑自带python,其版本比较低,比如我的版本python2.7,这是就需要升级python。...去官网下载python最新版版,之后按照提示一步步按照 修...
  • 对于python语言提示更新pip,通常是因为pip版本过低,更新pip可以更利于安装最新版本的第三方库和包。我当初第一次遇到这个问题的时候是因为我装Tensorflow2.0遇到,今天有一个朋友问我怎么更新pip,我想着这虽然不是...
  • Python版本并存

    2020-03-13 23:15:37
    从官网分别下载所需版本,选择"Add to PATH",分别安装。 安装后,修改对应Python目录下的python.exe和pythonw.exe,修改Script目录下的pip.exe...假如以上pip无法正常显示版本提示Fatal error in launcher: Unab...
  • python 3.7版本import scikit-learn(0.20版本)包时出现 DeprecationWarning: the imp module is deprecated in favour of importlib; see the module’s documentation for alternative uses提示 类似于使用scikit-...
  • 问题描述:You are using pip version 9.0.1, however version 18.0 isavailable.You should consider upgrading via the 'python -m pip install--upgrade pip' command.博主装的是anaconda,在进行装三方包的时候...
  • 查看Python版本

    2019-10-13 22:44:15
    window10系统 (管理员)命令提示符: 输入:python 有安装会提示版本,并且进入 python shell 模式。
  • 我在 Pycharm 中使用的 Python 版本与 cmd 中默认的版本不同,导致在 cmd 中执行 .py 文件时,有些模块会显示没有安装,而该文件在 Pycharm 中又可以运行。 解决方法 cmd 中的 Python 默认使用的是环境变量 Path 中...
  • 如何查看自己下载python版本

    千次阅读 2020-03-21 02:56:23
    打开anaconda prompt 或者命令提示符(cmd)输入python,便可查看自己安装的python版本
  • 运行命令 python manage.py celery worker 当启动时报错,从pychram报错的地方找 djcelery :异步框架 如图下: 当报错时,复制报错的名字,然后粘贴到我的电脑搜索命令行里按下回车找到你提示报错的文件夹里 如图二...
  • 1.先下载,你要升级的python版本(我升级的是python3.3.0)可使用系统自带下载工具wget下载:wget http://www.python.org/ftp/python/3.3.0/Python-3.3.0.tgz提示下:你使用wget下载后,下载的文件,在你当前的工作...
  • 现在想换用Python3 所以寻找版本并存 可以来回切换的方法 打开命令提示符,记住是命令提示符 不是win10自带的windows powershell 等会会说他俩的区别 输入以下指令(我选择的是python3.6版本): conda create --...
  • 无关紧要的python环境配置?
  • 某些python版本能够正确安装TensorFlow的提示前言py3.6+ TensorFlowpy3.7.6 TensorFlow过程安装numpy安装TensorFlow验证 前言 验证可行的windows下,系统要求64位,TensorFlow好像不支持32位系统,无论Linux或win。 ...
  • 解决python3.8版本anaconda安装tensorflow

    千次阅读 2020-10-15 11:03:44
    解决pyhon3.8版本anaconda安装tensorflow 因为之前的conda被我卸载了,需要重新安装的时候才发现conda已经默认python3.8。 安装tensorflow后jupyter一直提示No Module named TensorFlow anaconda terminal报错: ...
  • 1、导入模块psutil时提示报错:ImportError: No module named psutil 2、下载psutil模块后,安装python setup.py install过程中报错:error: command 'gcc' failed with exit status 1 二、问题分析 1、...
  • 首先在官网下载所需要的python版本,格式为tgz https://www.python.org/downloads/release/python-371/ 下载完成后在解压的后的跟目录下输入 ./configure --with-ssl make sudo make install 编译安装时需要提前...
  • python2版本是可以输出详细的错误信息,在这个版本没有详细的异常信息输出,可以通过引入 traceback 来打印异常信息提示。 try: assert 1 == 2 except Exception as e: import traceback print(traceback....
  • Python 不同版本redis 库 zadd之坑 import redis r= redis.Redis(host= XXX,port= XXX,db = X) score = 1 Python 3.7.3 redis2.10.6 之zadd zadd 命令 3.0以上的redis 版本库 在Python中是zadd(self,name,mapping,...
  • python提示缺"Python.h"库 sudo apt install python-dev 需要注意python的版本,有些系统默认会安装 python2.7-dev 如果python环境是3.7的话,执行上面的命令依然无法解决 出现这种情况的时候可以指定版本 sudo apt ...
  • 好像问题就是在这里,我在终端用 pip install 安装python第三方库的时候总会有问题,提示pip版本过低,我想更新pip又会失败;或者根本无法安装。 然后我就选择从pycharm上搜索第三方库并安装,奇怪的是有的库可以...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,095
精华内容 2,438
关键字:

python提示版本

python 订阅