精华内容
下载资源
问答
  • 华为交换机基础配置命令参考

    万次阅读 多人点赞 2019-03-24 10:06:03
    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置模式 视图模式下,输入局部配置命令,如interface ...

    华为交换机基础配置命令参考

    基础配置

    用户模式

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令;

     

    视图模式

    用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令;

     

    局部配置模式

    视图模式下,输入局部配置命令,如interface GE 1/0/0,进入GE1/0/0端口配置模式,

     

    此外局部配置模式有很多种,可根据不同需求进入vlan配置模式、端口聚合配置模式等,可输入?,查看当前模式下,能执行哪些命令;

     

    输入quit返回上一层配置模式,输入commit提交已有配置,用户模式下输入save保存配置;

     

     

    查看设备信息

    <HUAWEI>display version

     

    其中关键信息有:

    软件版本:Version 8.130 (S6800 V800R013C00SPC560B560)

    设备型号:HUAWEI S6800

    运行时间:0 day, 0 hour, 15 minutes

     

    查看和修改系统时间

    <HUAWEI>display clock

    <HUAWEI>clock datetime 12:00:00 2018-01-01

     

     

    修改设备名称

    <HUAWEI>system-view

    [~HUAWEI]sysname CE6800

    如果没有commit,需退出一次系统视图模式后保存;

     

     

     配置设备说明信息

    添加登录设备说明内容,举例:Only the administrator can configure the equipment

    [*CE6800]header shell information "Only the administrator can configure the equipment!"

     

    退出视图模式后可见

     

     

    配置console登录认证方式及超时时间

    Console登录:默认console登录无密码,任何人通过串口线直连设备console接口,可直接修改配置,管理员可配置console密码,登录不需要用户名,初次配置时使用console;

     

    超时时间:指连接设备后,一段时间内无操作,系统自动退出,需重新登录,默认超时时间为10min;

     

    进入console配置模式

    [*CE6800]user-interface console 0

     

    Console认证方式为password

    [*CE6800-ui-console0]authentication-mode password

     

    设置console密码为密文形式huawei@123

    [*CE6800-ui-console0]set authentication password cipher huawei@123

     

    设置超时时间为20min

    [*CE6800-ui-console0]idle-timeout 20 0

     

    使用quit返回视图模式,保存后使用display this检查配置结果,乱码是加密后的密码;

     

     

    Telnet 配置

    配置密文登录验证

    进入vty配置模式,0 4表示允许5个并发telnet连接

    [~CE6800]user-interface vty 0 4

     

    指定认证方式为password,出现要求使用aaa认证提示信息,暂时忽略

    [~CE6800-ui-vty0-4]authentication-mode password

     

     

    配置telnet使用密文认证,密码Gauss_234

    [*CE6800-ui-vty0-4]set authentication password cipher Gauss_234

     

    配置用户等级3,缺省为级别1

    [*CE6800-ui-vty0-4]user privilege level 3

     

    退出保存后,使用display this查看配置

     

     

    用户等级说明

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。
    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

     

    注:某些型号设备用户等级有0-15级,区分更细,其中15级与LEVEL 3权限一致,配置时需依据具体情况而定。

     

    配置aaa登录认证

    aaa认证

    authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;

     

    进入vty配置模式

    [~CE6800]user-interface vty 0 4

     

    退出vty配置模式后,进入aaa配置模式

    [*CE6800]aaa

     

    配置本地用户huawei密码为密文Gauss_234

    [*CE6800-aaa]local-user huawei password cipher Gauss_234

     

    配置huawei用户服务类型为telnet

    [*CE6800-aaa]local-user huawei service-type telnet

     

    配置huawei用户特权等级15(模拟器不支持此配置,只有用户等级0-3)

    [*CE6800-aaa]local-user huawei privilege level 15

     

    配置完成后查看结果,其中aaa认证模式无特殊要求,均采用默认模式

     

     

    telnet登录时会要求输入username和password

    配置设备超级密码

    超级密码

    在用户权限较低时(例如Telnet登陆时,可以定义权限级别为0戒1),此时

    可以使用super命令迚行权限提升。为避免非法权限提升带来的危害,应该配置

    超级密码迚行防护。

     

    为CE6800设置超级密码,密码以simple(明文)方式存储(模拟器不支持)

    [*CE6800]super password simple huawei

     

    保存及查看配置

    保存所有配置信息,先提交后保存

    [~CE6800]commit

    <CE6800>save

     

     

    查看已保存的所有配置

    [*CE6800]display saved-configuration

     

    查看当前所有配置

    [*CE6800]display current-configuration

     

     

    IP及路由配置

    配置接口IP

    拓扑图如下:

     

    CE6800配置

    [*CE6800]undo portswitch batch GE 1/0/0                                                  GE 1/0/0开启三层转发

    [*CE6800]interface GE 1/0/0                                                                       进入接口配置模式

    [*CE6800-GE1/0/0]ip address 10.0.12.1 24                                                配置IP及netmask

    [*CE6800-GE1/0/0]description this port connect to CE12800 GE 1/0/0      添加端口说明(可选)

    [*CE6800-GE1/0/0]undo shutdown                                                             激活接口

    [*CE6800-GE1/0/0]quit                                                                               退出接口配置模式

    [*CE6800]commit                                                                                        提交配置

     

    保存后查看配置:

     

     

    CE12800配置

    配置GE 1/0/0地址为10.0.12.1 24

    其余配置与CE6800相同,查看配置结果如下

     

     

    从CE6800 ping 对端CE12800,测试连通性

     

     

    配置静态路由

    接上一个案例,拓扑图如下:

     

    目标:让CE6800能ping通CE6850上的8.0.10.2

     

    在CE12800上,配置GE 1/0/1接口IP为8.0.10.1/24

     

     

    在CE6850上,配置GE 1/0/0 接口IP为8.0.10.2/24

     

     

    网络连通后,尝试从CE6800 ping CE6850上的8.0.10.2,结果ping不通;

    查看CE6800路由表,没有去往8.0.10.0/24的路由

     

     

    在CE6800上添加去往8.0.10.0/24的静态路由,下一跳地址应为CE12800上的10.0.12.2

    [*CE6800]ip route-static 8.0.10.0 24 10.0.12.2

     

    再尝试从CE6800 ping CE6850上的8.0.10.2,结果仍然ping不通,

    原因是CE6850没有去往10.0.12.0/24网段的路由,导致ping数据包“有去无回”;

    在CE6850上添加去往10.0.12.0/24的静态路由,下一跳地址应为CE12800上的8.0.10.1

    [~CE6850]ip route-static 10.0.12.0 24 8.0.10.1

     

    提交保存后,CE6800可以ping通CE6850上的8.0.10.2;

     

    查看CE6800、CE12800及CE6850路由表,分别如下图

     

     

    注意到Proto字段,有两种类型:Direct直连和Static静态,

    其中CE12800路由均为直连,Pre字段为0,

    而CE6800和CE6850有两条静态路由,Pre字段为60,

    Pre表示路由优先级,越小越优,路由会优先匹配;

     

    华为路由器默认协议优先级如下表

     

    其余协议均为动态路由协议,包括:

    OSPF(开放式最短路径优先协议)

    RIP(路由信息协议)

    IS-IS(中间系统到中间系统协议)

    BGP(边界网关协议)

     

    配置默认路由

     

    该拓扑图中,在CE6800和CE6850上配置默认路由,也可以互相ping通,配置示例如下:

     

    CE6800配置:

    [~CE6800]ip route-static 0.0.0.0 0.0.0.0 10.0.12.2

     

    CE6850配置:

    [~HUAWEI]ip route-static 0.0.0.0 0.0.0.0 8.0.10.1

     

    分别查看路由表:

     

     

    利用默认路由,拓扑图中两端设备也可以互相ping通;

     

    配置端口聚合

    LACP协议

    LACP,基于IEEE802.3ax标准的LACP(Link Aggregation Control Protocol,链路汇聚控制协议)是一种实现链路动态汇聚的协议。LACP协议通过LACPDU(Link Aggregation Control Protocol Data Unit,链路汇聚控制协议数据单元)与对端交互信息

     

    静态LACP汇聚由用户手工配置,不允许系统自动添加或删除汇聚组中的端口。汇聚组中必须至少包含一个端口。当汇聚组只有一个端口时,只能通过删除汇聚组的方式将该端口从汇聚组中删除。静态汇聚端口的LACP 协议为使能状态,当一个静态汇聚组被删除时,其成员端口将形成一个或多个动态LACP 汇聚,并保持LACP 使能。禁止用户关闭静态汇聚端口的LACP 协议。

    动态LACP汇聚是一种系统自动创建或删除的汇聚,动态汇聚组内端口的添加和删除是协议自动完成的。只有速率和双工属性相同、连接到同一个设备、有相同基本配置的端口才能被动态汇聚在一起。即使只有一个端口也可以创建动态汇聚,此时为单端口汇聚。动态汇聚中,端口的LACP 协议处于使能状态。

     

    端口聚合配置示例

    拓扑图如下:

     

    CE6850的GE1/0/1~GE1/0/3分别直连对端CE12808的GE1/0/1~GE1/0/3,将三条链路做链路聚合(channel);

     

    CE6850配置如下:

    [~CE6850]interface Eth-Trunk 1                                                进入Eth-Trunk子配置模式,

    [*CE6850-Eth-Trunk1]mode lacp-dynamic                                 选择lacp动态模式

    [*CE6850-Eth-Trunk1]lacp max active-linknumber 1                                          

    [*CE6850-Eth-Trunk1]least active-linknumber 1                                              

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/0

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/1

    [*CE6850-Eth-Trunk1]trunkport GE 1/0/2                                 将三个端口加入Eth-Trunk 1

    [*CE6850-Eth-Trunk1]commit                                                   提交配置

     

    CE12808配置与CE6850相同;

     

    查看Eth-Trunk 1配置

     

     

     

    两端设备的三根连线形成链路聚合,逻辑接口为Eth-Trunk 1

     

    展开全文
  • 华为交换机配置命令

    2013-09-19 16:38:57
    建立本地配置环境,将主机串口通过配置电缆与以太网交换机的Console口连接。 在主机上运行终端仿真程序(如Windows超级终端等)...键入命令配置以太网交换机查看以太网交换机运行状态。需要帮助可以随时键入"?
  • 华为交换机的基本配置命令 华为交换机的常用命令: 进入系统视图——sy 交换机命名——sysname huawei 返回上一级——quit(q) 直接返回视图——return(ret) 保存配置——save(sa) 重启设备——reboot 查看配置...

    华为交换机的基本配置命令
    华为交换机的常用命令:

    进入系统视图——sy

    交换机命名——sysname huawei

    返回上一级——quit(q)

    直接返回视图——return(ret)

    保存配置——save(sa)

    重启设备——reboot

    查看配置——display current-configuration(dis cur)

    查看VLAN——dis vlan

    查看端口——dis int g0/0/1

    新建VLAN——vlan 100

    删除vlan——undo vlan 100

    进入vlan——int vlan 100

    将端口放入vlan——port g0/0/1

    删除vlan中的端口——undo port g0/0/1

    配置vlan管理地址——ip address

    进入端口——int g0/0/1

    设置端口为access模式——port link-type access

    将端口放入vlan中——port default vlan 100

    设置端口为trunk模式——port link-type trunk

    删除端口配置——undo port link-type

    擦除旧的配置文件——reset saved-configuration

    配置telnet远程(其中一种)aaa

    开启telnet服务——telnet server enable

    限制用户数量登陆——user-interface vty 0 4(0.1.2.3.4共五个用户)

    设置认证模式——authenticatioon-mode aaa

    quit

    进入aaa认证模式——aaa

    设置登陆用户和密码——local-user admin pass simple huawei123(telnet名称admin,密码huawei123)

    设置远程用户服务类型——local-user admin service-type telnet

    设置远程用户级别——local-user admin privilege level 3

    quit

    save

    展开全文
  • 华为交换机查询常用命令 1.undo info-center enable //华为取消消息提示 2.reset saved-configuration //华为交换机初始化 3.dispaly ip routing-table //查看路由表 ...华为交换机配置基础命令 dhcp ..
    华为交换机查询常用命令
    1.undo info-center enable  //华为取消消息提示
    2.reset saved-configuration     //华为交换机初始化
    3.dispaly ip routing-table      //查看路由表
    4.reset ip pool name xxxx all   //释放某个地址池的
     dis int br 查看端口状态
     sys 
     dis cu 查看所有配置
     dis this 查看当前配置

     

    华为交换机配置基础命令
    dhcp enable (开启dhcp服务器)
    
    新建vlan
    vlan1
    vlan2
    
    
    端口指定vlan
    interface GigabitEthernet 0/0/1
     port link-type access
     port tdefault vlan 1
    
    interface GigabitEthernet 0/0/2
     port link-type access
     port tdefault vlan 2
    
    
    
    
    
    地址池pool
    interface Vlanif1
     ip address 192.168.10.1 255.255.255.128
     dhcp select global
    
    ip pool vlan1
     gateway-list 192.168.10.1
     network 192.168.10.0 mask 255.255.255.128
     lease day 0 hour 0 minute 30(设置租约,华为默认一天)
     dns-list 114.114.114.114 8.8.8.8 (DNS服务器设置)
    
    
    
    
    interface Vlanif2
     ip address 192.168.10.129 255.255.255.128
     dhcp select global
    
    ip pool vlan2
     gateway-list 192.168.10.129
     network 192.168.10.129 mask 255.255.255.128
     lease day 0 hour 0 minute 30(设置租约,华为默认一天)
     dns-list 114.114.114.114 8.8.8.8 (DNS服务器设置)
    展开全文
  • <br>2.1.1 命令行视图 S2000B系列以太网交换机的命令行视图是针对不同的配置要求实现,它们之间有联系又有区别,比如,与S2000B系列建立连接即进入用户视图,它只完成查看运行状态和统计信息简单功能,再...
  • 华为交换机配置手册

    2015-05-26 13:44:20
    华为交换机配置手册 1、开始 建立本地配置环境,将主机串口通过配置电缆与以太网交换机Console口连接。 在主机上运行终端仿真程序(如Windows超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位...
  • 华为交换机:基础命令入门学习

    千次阅读 2020-10-17 11:28:29
    登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令; <Huawei> 视图模式 用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可

    华为交换机学习

    参考资料:
    https://blog.csdn.net/hnjb5873/article/details/88773904
    https://blog.csdn.net/weixin_43815140/article/details/104803603

    一、基础配置命令

    1、用户模式

    登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令;

    <Huawei>
    

    2、视图模式

    用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的命令;

    <Huawei>system-view
    Enter system view, return user view with Ctrl+Z.
    [Huawei]
    

    3、交换机改名

    [Huawei]sysname switch01    #改交换机名字
    [switch01]
    Oct 16 2020 16:02:51-08:00 switch01 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011
    .5.25.191.3.1 configurations have been changed. The current change number is 4, 
    the change loop count is 0, and the maximum number of records is 4095.               
    

    Oct 16 2020 16:02:51-08:00 switch01 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011
    .5.25.191.3.1 configurations have been changed. The current change number is 4,
    the change loop count is 0, and the maximum number of records is 4095.

    这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉

    undo terminal monitor
    

    4、进入接口

    [switch01]int g0/0/1
    [switch01-GigabitEthernet0/0/1]
    

    5、退出此端口

    q
    

    二、创建vlan并将端口加入vlan

    1、创建vlan

    创建单个vlan

    [HUAWEI]vlan 10                #创建vlan10,创建后会自动进入vlan10
    [HUAWEI-vlan2]q
    

    批量创建vlan

    [HUAWEI]vlan batch 3 to 10          #批量建立vlan,3-10
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [HUAWEI]                            #批量建立vlan后不会进入vlan
    

    2、更改端口的链接类型

    由于华为交换机的端口出厂时默认都是hybrid类型auto类型的,所以无法立即加入vlan,需要更改端口的link-type后,才可以加入vlan。单个端口更改方式如下:

    [HUAWEI]int g0/0/1
    [HUAWEI-GigabitEthernet0/0/1]port link-type access
    

    为何要选择access类型??
    因为我们是终端PC与交换机相连,要求PC只能只能和上级交换机通信,所以必须只属于1个vlan

    以太网端口的链路类型有三种:

    • Access 类型:端口只能属于1 个VLAN,一般用于交换机与终端用户之间的连接;
    • Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机 之间的连接;
    • Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换 机之间连接,也可以用于连接用户的计算机。Hybrid 端口可以允许多个VLAN 的报文发送时不携带标签,而Trunk 端口只允许缺省VLAN 的报文,发送时不携带标签。
    • trunk端口用于交换机相连,pvid必须一致
    • access 类型只能属于1 个vlan
    • 规模较大的企业局域网,不建议使用vlan1,所以trunk端口不允许vlan1通过

    3、端口加入vlan

    [HUAWEI-GigabitEthernet0/0/1] port default vlan 10   #端口1加入vlan10
    

    以上的操作是单个操作,如果配置端口比较多就很麻烦,下面我们来批量操作。

    4、端口的批量操作——端口组

    原理就是创建一个端口组,把要更改的端口加入到端口组中,然后统一更改类型加入vlan。也可以理解为群组端口,统一配置类型加入vlan.

    批量更改,先更改端口类型,再统一加入某个vlan,如下:

    port-group pokes         #pokes是端口组名
    [swh-port-group-pokes]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2
    port link-type access 设置为access模式
    port default vlan 3 加入vlan3
    
    
    [swh]vlan 10            #创建vlan10
    [swh-vlan10]q
    [swh]port-group pokes   #pokes是端口组名
    [swh-port-group-pokes]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2      #把1、2两个端口加入到端口组中
    [swh-port-group-pokes]port link-type access        #更改组的端口类型
    [swh-GigabitEthernet0/0/1]port link-type access    #自动生成行
    [swh-GigabitEthernet0/0/2]port link-type access    #自动生成行
    [swh-port-group-pokes]port default vlan 10         #端口组加入vlan10
    [swh-GigabitEthernet0/0/1]port default vlan 10     #自动生成行
    [swh-GigabitEthernet0/0/2]port default vlan 10     #自动生成行
    

    5、vlan的查看

    全局查看vlan信息

    [swh]dis vlan     #查看vlan信息
    The total number of vlans is : 2
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:GE0/0/3(U)      GE0/0/4(U)      GE0/0/5(D)      GE0/0/6(D)      
                    GE0/0/7(D)      GE0/0/8(D)      GE0/0/9(D)      GE0/0/10(D)     
                    GE0/0/11(D)     GE0/0/12(D)     GE0/0/13(D)     GE0/0/14(D)     
                    GE0/0/15(D)     GE0/0/16(D)     GE0/0/17(D)     GE0/0/18(D)     
                    GE0/0/19(D)     GE0/0/20(D)     GE0/0/21(D)     GE0/0/22(D)     
                    GE0/0/23(D)     GE0/0/24(D)                                     
    
    10   common  UT:GE0/0/1(U)      GE0/0/2(U)                                      
    
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010 
    

    查看端口与vlan对应关系

    [swh]display port vlan
    Port                    Link Type    PVID  Trunk VLAN List
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/1    access       10    -                                   
    GigabitEthernet0/0/2    access       10    -                                   
    GigabitEthernet0/0/3    hybrid       1     -                                   
    GigabitEthernet0/0/4    hybrid       1     -                                   
    GigabitEthernet0/0/5    hybrid       1     -                                   
    GigabitEthernet0/0/6    hybrid       1     -                                   
    GigabitEthernet0/0/7    hybrid       1     -                                   
    GigabitEthernet0/0/8    hybrid       1     -                                   
    GigabitEthernet0/0/9    hybrid       1     -                                   
    GigabitEthernet0/0/10   hybrid       1     -                                   
    GigabitEthernet0/0/11   hybrid       1     -                                   
    GigabitEthernet0/0/12   hybrid       1     -                                   
    GigabitEthernet0/0/13   hybrid       1     -                                   
    GigabitEthernet0/0/14   hybrid       1     -                                   
    GigabitEthernet0/0/15   hybrid       1     -                                   
    GigabitEthernet0/0/16   hybrid       1     -                                   
    GigabitEthernet0/0/17   hybrid       1     -                                   
    GigabitEthernet0/0/18   hybrid       1     -                                   
    GigabitEthernet0/0/19   hybrid       1     -                                   
    GigabitEthernet0/0/20   hybrid       1     -                                   
    GigabitEthernet0/0/21   hybrid       1     -                                   
    GigabitEthernet0/0/22   hybrid       1     -                                   
    GigabitEthernet0/0/23   hybrid       1     -                                   
    GigabitEthernet0/0/24   hybrid       1     -  
    

    6、允许所有vlan通过

    [switch01-port-group-link-type]port trunk allow-pass
    

    三、首次登入交换机或路由器

    第一次上电和恢复出厂是一样的,我们先说一下恢复出厂设置。

    1、恢复出厂设置

    注意Y和N的选项,不要输错。

    <S1>reset saved-configuration 
    Warning: The action will delete the saved configuration in the device.
    The configuration will be erased to reconfigure. Continue? [Y/N]:y
    
    <S1>reboot
    Info: The system is now comparing the configuration, please wait.
    Warning: The configuration has been modified, and it will be saved to the next startup saved-configuration file . Continue? [Y/N]:n
    
    Info: If want to reboot with saving diagnostic information, input 'N' and then execute 'reboot save diagnostic-information'.
    System will reboot! Continue?[Y/N]:y
    

    2、设置新密码

    新交换机第一次上电,或恢复出厂设置后,要求设置新密码
    出厂自带的用户名是admin,密码是admin@huawei.com

    Login authentication
    
    
    Username:admin
    Password:
    Warning: The default password poses security risks.
    The password needs to be changed. Change now? [Y/N]: y
    Please enter old password: 
    Please enter new password:       --------------输入密码时没有任何显示
    Please confirm new password: 
    The password has been changed successfully.
    

    3、首次保存配置

    第一次保存设置时,需输入文件名,只需按回车

    <HUAWEI>save
    The current configuration will be written to the device.
    Are you sure to continue?[Y/N]y
    Info: Please input the file name ( *.cfg, *.zip ) [vrpcfg.zip]:
    May 28 2019 10:57:52 HUAWEI %%01CFM/4/SAVE(s)[1]:The user chose Y when deciding whether to save the configuration to the device.
    flash:/vrpcfg.zip exists, overwrite?[Y/N]:y
    May 28 2019 10:57:54 HUAWEI %%01CFM/4/OVERWRITE_FILE(s)[2]:When deciding whether to overwrite the configuration file vrpcfg.zip, the user chose Y.
    Now saving the current configuration to the slot 0......
    Save the configuration successfully.
    

    4、设置日期和时间

    <HUAWEI>clock datetime 10:46:30 2019-05-28
    

    设置console口的连接方式,可设置为无,仅密码,用户名密码等方式

    [HUAWEI]user-interface console 0
    [HUAWEI-ui-console0]authentication-mode ?
      aaa       AAA authentication, and this authentication mode is recommended
      none      Login without checking
      password  Authentication through the password of a user terminal interface
    
    [HUAWEI-ui-console0]set authentication password
    
    [HUAWEI-ui-console0]set authentication password cipher administrator
    

    5、开启必要的服务和功能

    开启telnet服务,stp功能,http服务

    [HUAWEI]telnet server enable                #开启telnet服务
    [HUAWEI]stp mode rstp                       #设置stp模式为rstp
    [HUAWEI]stp enable                          #开启stp功能
    [HUAWEI]http server enable                  #开启http服务(默认就是开启的)
    

    6、设置vty,telnet登录

    [HUAWEI]user-interface maximum-vty 15       #vty界面最大值15
    
    authentication-mode password                #认证模式设置为仅需密码,也可设置为aaa模式
     user privilege level 15                    #用户权限级别15(非常重要)
     set authentication password cipher $1a$IZ,o~LZ$Z.$GHlQ-zn9-Gn<*8(yp-@F#6wmH;M\%L#($\PXNa.:$---此处是密码,输入时是明文,根据需要设置
     history-command max-size 256               #命令行最大历史记录
     idle-timeout 6 0                           #用户超时时间6分0秒
     screen-length 100                          #屏幕长度100行
     protocol inbound telnet                    #允许telnet协议进入(非常重要)
    

    7、设置一个用户用于网页登录

    [HUAWEI]aaa
    [HUAWEI-aaa]dis local-user
      ----------------------------------------------------------------------------
      User-name                      State  AuthMask  AdminLevel  
      ----------------------------------------------------------------------------
      admin                          A      MH        15         
      ----------------------------------------------------------------------------
      Total 1 user(s)
    [HUAWEI-aaa]undo local-user admin
    Error: Have user(s) online, can not be deleted.
    [HUAWEI-aaa]quit
    

    由于第一次登录时,console口要求用户名密码登录,所以无法删除本地用户admin,此时可退到<>视图,保存设置,退出交换机,再重新登录。由于我们已经将console口的认证方式改为仅需密码,所以可以再次进入aaa,删除用户admin。删除后,再建立admin,权限,服务类型等,均可由我们自己控制。

    [HUAWEI]aaa
    [HUAWEI-aaa]undo local-user admin
    [HUAWEI-aaa]local-user admin password irreversible-cipher administrator idle-timeout 6 0       #administrator为密码,根据需要设置
    Info: Add a new user.
    [HUAWEI-aaa]local-user admin service-type http
    [HUAWEI-aaa]local-user admin privilege level 15
    Warning: This operation may affect online users, are you sure to change the user privilege level ?[Y/N]y
    [HUAWEI-aaa]local-user admin ftp-directory flash:
    

    如遇更新版本的交换机软件,telnet服务要求必须是aaa认证(用户名密码认证),可按上面所述再建立一个用户,service-type设置为telnet。

    8、关闭交换机自动弹出配置改变告警

    输入配置命令后设备会提示如下类似信息:

    DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.191.3.1 configurations have been changed. The current change number is 1, the change loop count is 64, and the maximum number of records is 1.

    这个是配置改变的告警提示信息,不是错误信息,可以配置如下命令屏蔽此信息:

    [HUAWEI]info-center source DS channel console trap level warning state off
    

    四、设置链路聚合

    [HUAWEI]interface Eth-Trunk 1
    [HUAWEI-Eth-Trunk1]port link-type trunk
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [HUAWEI-Eth-Trunk1]port trunk pvid vlan 10
    [HUAWEI-Eth-Trunk1]port trunk allow-pass vlan 2 to 4000
    Info: This operation may take a few seconds. Please wait a moment....done.
    [HUAWEI-Eth-Trunk1]undo port trunk allow-pass vlan 1
    Info: This operation may take a few seconds. Please wait a moment...done.
    [HUAWEI-Eth-Trunk1]dis this
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 4000
    #
    return
    

    以上命令建立一个聚合端口,并设置了端口的属性

    [HUAWEI]interface GigabitEthernet 0/0/25
    [HUAWEI-GigabitEthernet0/0/25]eth-trunk 1
    Info: This operation may take a few seconds. Please wait a moment...done.
    

    以上命令将G 0/0/25端口加入聚合端口eth-trunk 1,无需更多设置。可将更多的端口加入聚合端口。

    五、交换机DHCP

    开启DHCP功能,设置地址池,并应用

    [HUAWEI]dhcp enable
    
    ip pool 192.168.2.0                               #建立一个地址池,名为192.168.2.0
     gateway-list 192.168.2.254                       #设置网关地址
     network 192.168.2.0 mask 255.255.255.0           #设置网段
     excluded-ip-address 192.168.2.251 192.168.2.253  #设置不参与分配的IP地址范围
     lease day 0 hour 0 minute 30                     #设置租期时长
     dns-list 114.114.114.114 8.8.8.8                 #设置dns地址
    
     
    
    [HUAWEI]interface Vlanif 2                       #进入vlanif 2
    [HUAWEI-Vlanif2]ip address 192.168.2.254 24     #给vlanif 2 设置IP地址(就是上面地址池的网关地址)
    [HUAWEI-Vlanif2]dhcp select global              #DHCP选择全局,会自动匹配地址池
    

    六、开启流控制功能,限制某些网段互链

    主要是限制访客网与办公网、财务网互访

    [HUAWEI]acl number 3001       #添加一个高级ACL,可控制源地址和目的地址
    Info: When the ACL that is referenced by SACL is modified, the SACL will be dynamically updated. During the update, these SACL will become invalid temporarily.
    [HUAWEI-acl-adv-3001]rule 1000 deny ip source 172.16.0.0 0.0.255.255 destination 192.168.0.0 0.0.255.255
    [HUAWEI-acl-adv-3001]rule 1100 deny ip source 172.16.0.0 0.0.255.255 destination 175.40.0.0 0.0.255.255
    [HUAWEI-acl-adv-3001]quit
    

    注意源地址和目的地址的反向掩码

    [HUAWEI]traffic-filter inbound acl 3001   #在全局层面应用ACL 3000里面的规则
    
    展开全文
  • 华为交换机常用命令

    万次阅读 多人点赞 2015-09-19 15:26:56
    总结了一下常用的华为交换机常用命令如下:1.查看Linux下查看端口状态root@root:~# netstat -an|grep -E "6002|6003"2.华为交换机显示当前配置display current-configuration 或者简写 display cur 3.显示端口信息 ...
  • 华为3026c交换机ftp备份配置:方法一:iis建ftp服务器,要设置用户名密码(百度经验)前提:先找一台能ping通交换机的电脑,通过iis建ftp服务器。1、查看当前路径下文件和目录>dir2、连接ftp服务器>ftp 192....
  • 登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置模式 视图模式下,输入局部配置命令,如interface ...
  • H3C交换机路由器命令,display ip routing-table verbose 查看路由表全部详细信息
  • 登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令; 2、视图模式 用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的...
  • 登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置模式 视图模式下,输入局部配置命令,如interface ...
  • 登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令; 2、视图模式 用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的...
  • 历史命名查询 display history-command 配置主机名 sys sysname xxx 状态信息查询 display version display users ...display current-configuration #是显示当前交换机的配置信息 reset saved-configuration
  • 几乎每条配置命令都有对应undo操作。 查看所有接口信息:display interface 查看指定接口信息:display interface Ethernet0/0/1 进入Ethernet0/0/1接口:interface Ethernet0/0/1 显示当前接口信息:display ...
  • display current-configuration //查看当前生效的配置参数 display version //查看设备版本情况 display interface display current-configuration interface // display interface brief //查看...
  • 查看设备当前配置信息 ...查看flash中的配置信息 <>dis saved-configuration 删除Flash中的配置信息 <>reset saved-configuration 重新启动交换机 <>reboot 查看软件系统版本 <...
  • (二)、交换机以太网接口工作模式(三)、配置准备三、交换机基本命令1、历史命令查询2、配置主机名3、状态信息查询4、进入接口模式并查看信息5、配置文件管理命令6、关闭华为的信息提示中心7、永不超时8、...
  • 华为交换机怎么查看接口流量

    万次阅读 2019-06-11 17:07:50
    今天我们整理了华为交换机的监控命令,其中比较重要几个命令我记一下,也方便能看到这篇文章同学。 首先得ssh登录到设备终端或者用sshpass命令 display current-configuration 显示当前配置 display interface ...
  • 华为交换机批量处理端口的配置(端口组配置)

    万次阅读 多人点赞 2019-11-14 21:48:29
    创建端口组名称 port-group 名称(命令用来创建Port Group名称) [Huawei]port-group 1-24 undo port-group 名称(命令用来...display port-group(令用来查看永久端口组成员接口信息) [Huawei]dis port-group 1-...
  • 华为路由交换机常用命令

    千次阅读 2020-03-10 16:29:07
    常用系统命令 display clock命令用来查看系统当前日期和时钟。 display diagnostic-information命令用来查看系统当前诊断...display this命令用来查看系统当前视图运行配置。 display version命令用来查看系统版本...
  • 华为交换机RIP配置实验

    千次阅读 2018-01-22 16:46:24
    给上图四台路由器分别配置接口IP地址;分别用版本2,开启summary,配置...验证命令查看当前路由协议R1#show ip route 查看路由表R1#show ip route rip仅仅查看RIP路由条目 转载于:https://blog.51cto.com/13...
  • 常用交换机配置命令

    千次阅读 2019-06-26 14:30:52
    本文基于华为和思科各数通设备的常用命令来对比学习,这两个命令体系是网络项目中常见的,其他一些厂家也是基于类似的命令体系.下面也会根据公司业务需求列举部分网络设备厂家,比如H3C,盛科的命令不同之处. 1. 查看...
  • 交换机 手册 配置 维护 巡检 方案 第1章 加载BOOTROM和主机软件 2 1.1 加载方式简介 2 1.2 本地加载 3 1.2.1 BOOT菜单 3 1.2.2 通过Console口利用XModem完成加载 ...4.4 利用设备管理命令实现远程升级交换机配置举例 33
  • 1、给交换机配置ip: <huawei>system-view <huawei>sysname switch //修改名字 //注:查看端口状态,确保端口phy和Protocol属性分别为up,up.查看命令: display interface brief <switch>...
  • 详解华为交换机中的批量处理端口的配置(思科中叫端口组配置),即快速配置具有相同配置的接口。 创建端口组名称 port-group name #命令用来创建Port Group名称。 undo port-group name #命令用来删除Port Group名称。...

空空如也

空空如也

1 2 3 4 5
收藏数 89
精华内容 35
关键字:

查看华为交换机配置的命令