精华内容
下载资源
问答
  • eNSP配置RIP动态路由

    万次阅读 2018-07-04 22:54:21
    配置路由 step1:配置好CLIENT1,CLIENT2 step2:配置各路由器的相邻的两个网段 注意要先进行sys命令后,才可以进行如下操作。 上面的rip 1指明了进程号是1,如不写,默认是1 已经全部ping通了 .....

    拓扑结构

    这里写图片描述

    配置路由

    step1:配置好CLIENT1,CLIENT2

    这里写图片描述
    这里写图片描述

    step2:配置各路由器的相邻的两个网段

    注意要先进行sys命令后,才可以进行如下操作。

    这里写图片描述
    上面的rip 1指明了进程号是1,如不写,默认是1

    这里写图片描述

    这里写图片描述

    已经全部ping通了

    这里写图片描述
    这里写图片描述

    展开全文
  • 基于eNSP的华为设备--单臂路由配置,静态路由配置RIP动态路由配置,OSPF动态路由配置华为模拟器配置单臂路由功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码...

    基于eNSP的华为设备--单臂路由配置,静态路由配置,RIP动态路由配置,OSPF动态路由配置

    华为模拟器配置单臂路由

    拓扑图如下在这里插入图片描述

    拓扑图简介:
    两个二层交换机下,有vlan 10 和vlan 20 ,网关在路由器,设置一个单臂路由使vlan 10 与vlan 20可以通信。

    路由器R1:
    #
    interface GigabitEthernet0/0/0.1
     dot1q termination vid 10
     ip address 192.168.1.1 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet0/0/0.2
     dot1q termination vid 20
     ip address 192.168.2.1 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet0/0/1
     ip address 10.10.1.1 255.255.255.0
    #
    //配置时记得进行dot1q进行封装:
     dot1q termination vid 10       /dot1q封装,对应所属vlan
     arp broadcast enable         /启用arp广播
     //创建以及开启VLAN
     int vlan 10
     vlan 10
     
    

    对于交换机LSW1 与LSW2
    设置vlan 将其放入相应端口

    LSW1:
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/5
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet0/0/10
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/11
     port link-type access
     port default vlan 20
     #
    

    将PC设置好静态地址,则可以Ping通。

    华为模拟器配置静态路由

    拓扑图如下:
    在这里插入图片描述

    实验目的:配置静态路由,使两边PC能够ping通。

    路由器R12 与R13:

    R-12:
    interface GigabitEthernet0/0/0
     ip address 10.10.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.1.1 255.255.255.0
     dhcp select global
    
    ip route-static 192.1.4.0 255.255.255.0 10.10.1.2
    //华为模拟器和思科模拟器在静态路由配置上的区别。
    
    //DHCP 的配置:
    
    dhcp enable  //打开dhcp
    ip pool test   //配置地址池的名字
    gateway-list  192.168.1.1  //配置网关地址
    network 10.1.1.0 mask 24 //配置地址池地址
    excluded-ip-address 10.1.1.2 10.1.1.5   //不允许分配的地址
    
    R -13配置等同类似
    

    华为模拟器配置RIP路由

    拓扑如图:
    在这里插入图片描述目的:为三个路由器配置rip协议,实现动态路由

    R2上的配置:
    //Rip -v2的配置
    rip 1
     undo summary
     version 2
     network 192.168.1.0
     network 192.168.2.0
    #
    //包括其后的端口及ip配置
    //以及PC上静态配置ip
    

    R3上的配置

    #
    interface GigabitEthernet0/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.3.1 255.255.255.0
    #
    rip 1
     undo summary  //自动取消汇总
     version 2
     network 192.168.2.0
     network 192.168.3.0
    #
    
    //查看路由命令
     display ip routing-table 
     display ip routing-table protocol rip 
    

    华为模拟器配置单区域OSPF

    在这里插入图片描述
    配置OSPF为什么最好设置一个环回口呢?意义和好处是什么?

    A:回环口IP可以做为路由器的管理IP,而且回环口IP是路由器ID取值的第一标准,如果配置了回环口IP,那么这个IP就是路由器的ID,如果没有配置回环口IP,那么路由器ID就选取物理接口上IP最大的作为ID,而且环回口都是UP状态,除非路由器挂掉,不会频繁变动,因此路由器不必频繁重新向邻居介绍自己或者是更新路由状态,可以减少不必要的开销。

    答疑以后,下面是命令

    设置回环口:

    //  设置回环口,并设置IP地址
    
    [Huawei]int LoopBack 5
    [Huawei-LoopBack5]ip add 10.10.2.4 24
    
    

    配置OSPF的命令:

    ospf 1 router-id 10.0.1.1
     area 0.0.0.0
      network 10.0.1.0 0.0.0.255
      network 10.0.12.0 0.0.0.255
    #
    

    华为模拟器配置多区域OSPF

    拓扑图如下:
    在这里插入图片描述

    //用红线标出来的地方,分别是area 1 ,area 0 和 area 2

    设置环回口,设置接口及其IP地址,设置OSPF及不同区域,将不同的区域中添加上不同的网段即可。

    R-14的配置:

    #
    interface GigabitEthernet0/0/0
     ip address 10.0.0.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.0
    #
    ospf 1 router-id 1.1.1.1
     area 0 
      network 1.1.1.0 0.0.0.255
      network 12.0.0.0 0.0.0.255
     area 1
      network 10.0.0.0 0.0.0.255
    #
    其他的以此类推!
    
    展开全文
  • 具体实施:通过给路由器配置RIP协议来实现动态路由。 二、实验拓扑图 本次实验采用的路由器型号为:AR2220。但是由于模块不够,我们给路由器加模块。模块的添加必须在路由器处于关机时候才可以添加。 拓扑图展示 三...


    一、实验题目

    四台路由器,四台PC,实现动态路由的配置。具体实施:通过给路由器配置RIP协议来实现动态路由。

    二、实验拓扑图

    本次实验采用的路由器型号为:AR2220。但是由于模块不够,我们给路由器加模块。模块的添加必须在路由器处于关机时候才可以添加。
    添加模块拓扑图展示
    拓扑图展示

    三、实验内容

    1.配置确定

    网段:
    192.168.3.0/30
    192.168.10.0/24
    192.168.20.0/24
    192.168.30.0/24
    192.168.40.0/24
    

    2.主机配置

    PC1:192.168.10.1 24 192.168.10.254
    PC2:192.168.20.1 24 192.168.20.254
    PC3:192.168.30.1 24 192.168.30.254
    PC4:192.168.40.1 24 192.168.40.254
    

    3.配置路由器

    R1配置:
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.10.254 24
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 192.168.3.5 30
    [R1-GigabitEthernet0/0/1]int g0/0/2
    [R1-GigabitEthernet0/0/2]ip add 192.168.3.9 30
    [R1-GigabitEthernet0/0/2]int g3/0/0
    [R1-GigabitEthernet3/0/0]ip add 192.168.3.1 30
    [R1-GigabitEthernet3/0/0]rip
    [R1-rip-1]version 2
    [R1-rip-1]undo summary 
    [R1-rip-1]network 192.168.10.0
    [R1-rip-1]network 192.168.3.0
    ------------------------------------------------------
    R2配置:
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 192.168.3.6 30
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 192.168.3.17 30
    [R2-GigabitEthernet0/0/1]int g0/0/2
    [R2-GigabitEthernet0/0/2]ip add 192.168.20.254 24
    [R2-GigabitEthernet0/0/2]rip
    [R2-rip-1]version 2
    [R2-rip-1]undo summary 
    [R2-rip-1]network 192.168.20.0
    [R2-rip-1]network 192.168.3.0
    ------------------------------------------------------
    R3配置:
    R3配置与R1配置相似,但是注意ip地址的配置。在此不多加赘述。
    ------------------------------------------------------
    R4配置:
    R4配置与R2配置相似,但是注意ip地址的配置。在此不多加赘述。
    

    4.测试不同主机的连通性

    PC1:
    PC1测试连通性PC3:
    PC3测试连通性

    实验总结

    我们本次实验运用到以下知识:

    1. RIP配置

    2. 需要掌握以下指令

      rip				//启动RIP进程
      version 2		//选择RIP版本号,可选择RIPv1,RIPv2
      undo summary	//启动路由聚合功能
      network (网络号)	//指定参与RIP创建动态路由的接口与网络
      
    展开全文
  • 今天放一篇多内容集合,这篇结合了多个知识点:【RIP动态路由】;【DHCP服务】;【ACL控制访问】等步骤稍微复杂繁多,细心观看。RIP2 在中小型企业也会用到。DHCP自动获取IP地址省去了手动配置IP的繁琐ACL流控可以...

    今天放一篇多内容集合,这篇结合了多个知识点:【RIP动态路由】;【DHCP服务】;【ACL控制访问】等
    步骤稍微复杂繁多,细心观看。
    RIP2 在中小型企业也会用到。
    DHCP自动获取IP地址省去了手动配置IP的繁琐
    ACL流控可以实现流量访问控制,想让谁上网想让谁上不了网

    地址之类的规划按照自己的规划去做效果是最好的,最好看懂后按照自己的想法去做
    步骤其实都已经算详细了,之所以没有直接写命令步骤,也是怕很多初学者难以看懂,所以图片是最好的
    虽然很多,耐心看下去就好
    越往后也会逐一增加难度
    时间仓促,写完后还没好好检查,如有错误还请谅解
    
    打开华为ENSP模拟器,如图所示规划好拓扑图

    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    搭建好后配置所有的IP地址,如图所示,把4个PC机同样配置好
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    注意地址不要配错了
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    还有所有路由器的地址
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    要习惯使用查看命令查看配置的信息
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    1
    1
    之前有篇幅教怎么配置静态路由,但是静态路由只适合设备比较少的小型网络
    如果多达几十甚至更多的路由器再去配置静态路由会要人命的
    所以为了节省更多的时间提高工作效率,才有了动态路由RIP2
    但是RIP2 也只是部分中小型企业才会用到,另外还有更好的动态路由协议,这里就先不说了
    下图简单的介绍一下RIP2动态路由的原理
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    然后我们开始配置动态路由。AR1,AR2,AR3都要配置,这里只放一张图,其他路由的配置
    步骤相同,只是输入网段不同,只要输入路由的直连网段即可,不要输入非直连网段
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络

    配置完动态路由之后,用PC机互相Ping通,不通则检查动态路由是否配置错误,是否是rip2 ,IP地址是否错误。
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络

    下面开始配置DHCP服务器。打开AR1配置,注意:DCHP enable这个步骤不能少
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    配置往后打开PC1和PC2,点开DHCP
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    然后在命令提示界面输入命令
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    这里就表示获取成功了,另外PC3 和PC4同样的步骤,AR3也是同样的步骤,注意地址不同(dns 8.8.8.8这个随意就好,配不配都没关系)

    AR3的步骤是一样的,我就不放图了,这是获取结果(虽然也反了,不过这不重要,我不是×××座)
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    获取到地址之后 再去ping通,看看是否都是联通。下图红框部分显示的信息是延迟的,具体含义简单的说下
    三次没有成功是因为中间过了3个路由器,前面三个数据包是被路由解析掉了,第二次在ping 就是全部通,因为路由器解析过后MAC地址被保存在MAC地址表里,但是地址在MAC地址表里只存活5分钟,时间一过,MAC地址表就会自动删除地址,再次ping 就要重新获取地址。

    做完上面的操作之后,开始做ACL访问流控。详图如下
    我们只让PC2和PC3互相通信,在AR2里配置ACL 拦截PC1和PC4的访问流量
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    打开AR2 做ACL设置
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    单独的配置ACL,并不代表什么,要加入端口上才能发挥效果

    所以配置好后 就可以愉快的去Ping了,慢慢的去验证发现新大陆
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络
    下面这条是查询命令
    eNSP模拟器RIP2动态路由,DHCP服务,ACL流控,组合使用的拓扑网络

    由于时间太晚了,很多详细的设置和命令没有做出来,想学的可以自己去挖掘那些命令,【不懂就? 问】
    这些知识点都是基础,可能用得上,也可能用不上,但是学会了,总有用的上的时候。

    转载于:https://blog.51cto.com/13725377/2141222

    展开全文
  • 2.给PC地址子网掩码网关配置(另一个同理) 3.配置路由器1 sys Enter system view, return user view with Ctrl+Z. [Huawei]int g0/0/0 [Huawei-GigabitEthernet0/0/0]ip add 192.168.10.2 24 //给端口添加IP地址 ...
  • 动态路由RIP配置 R1配置 R2配置 R3配置 P1和p2互ping
  • 动态路由信息协议RIP;配置RIP命令;测试路由器之间联通情况;Wireshark抓包分析e/0/0/0。
  • ensp rip配置

    千次阅读 2020-08-21 21:19:20
    二、rip配置动态路由) 画出拓扑图,并标注出划分的地址和相关信息。例如: 2. 路由器的基本配置 R1: Huawei>system-view (进入系统视图) [Huawei]interface GigabitEthernet 0/0/0(进入0/0/0接口) ...
  • RIP动态路由协议一、动态路由1、什么是动态路由2、动态路由的特点3、动态路由协议概述4、动态路由的度量值5、收敛是什么意思6、动态路由协议的分类二、RIP协议RIP(距离矢量协议)RIP:邻居:周期更新:Metric:版本...
  • 基于eNSP的静态、动态路由配置

    千次阅读 2020-08-06 20:47:09
    2.动态路由协议:RIP OSPF ISIS BGP(这里只介绍RIP和OSPF)。 二、静态路由配置 我们放置好以下设备,配置好IP地址: 1.普通静态路由 静态路由配置只需要记住”“目的 下一跳”即可: 目的:需要达到的目的...
  • RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法,使用“跳数”来衡量到达目标地址的路由...
  • OSPF动态路由协议实验与RIP动态路由协议的路由重分发配置方法 一、OSPF与RIP的区别 二、OSPF路由器类型 区域内路由器(InternalRouter) 区域边界路由器ABR(Area Border Router) 骨干路由器(BackboneRouter) ...
  • 动态路由协议 IPv6 eNSP

    2020-12-28 12:55:44
    基于RIP互联 主机配置 172.16.1.1/24 172.16.5.1/24 拓扑图 路由器配置 第一台 第四台 设置被主机连接的路由器的端口ip时,要与主机网关相同,一般末尾254 结果 基于OSPF的网络互联 拓扑图 主机配置 同上 ...
  • 分别配置三台路由器:R1ripv1版本,R3ripv2版本,R2兼容模式,调整R2端口rip协议版本让三台路由器能互相学习路由表 二、实验环境 在华为ENSP中建立如图所示拓扑图 在R1中设置 [R1]interface g0/0/0 ##配置接口ip [R1...
  • 文章目录3 实验四:动态路由协议3.1 实验目的和内容3.1.1实验目的3.1.2 实验内容3.2 实验过程3.2.1 基于RIP动态路由协议的网络互联3.2.2 基于OSPF动态路由协议的ipv43.2.3 基于OSPF动态路由协议的ipv63.3 实验分析...
  • ensp dhcp配置

    2020-11-27 14:19:39
    通过rip动态路由实现全网通,在R1建立DHCP,R3为DHCP中继。 网路拓扑图 R1配置 Huawei> system-view (进入系统视图模式) [Huawei]interface GigabitEthernet 0/0/0(进入0/0/0接口) [Huawei-GigabitEthernet0...
  • RIP动态协议原理以及实验配置精讲一:动态路由1.1:动态路由协议基础1.1.1:动态路由1.1.2动态路由特点:1.2:动态路由协议1.2.1:动态路由协议概述1.2.2:度量值1.2.3:收敛二:RIP路由协议工作原理2.1:RIP路由...
  • 网络综合实验配置一、实验目的和环境二、实验规划拓扑图三、实验设备配置LSW1的配置LSW2 的配置LSW7 的配置R1 的配置R2 的配置R3 的配置R4 的配置R5 的配置PC端的配置注:看不懂的可以看其他博客有详细文字配置解析...
  • ensp

    千次阅读 2020-06-24 19:13:44
    ensp配置静态路由、默认路由动态RIP动态OSPF ensp中DHCP、ACL、NAT、STP、VRRP配置 ensp中WLAN和防火墙配置 在ubuntu中搭建DHCP服务器 在ubuntu中搭建AAA服务器 在ubuntu上基于ssh配置FTP服务器 在ubuntu中...
  • Ensp实验随心记——RIP

    2020-07-23 01:22:06
    RIP基础配置动态路由协议的优势入方向接口附加度量出入方向接口附加度量 实验步骤都是有顺序性的,真心学的话,看懂并不难,反而有益于建立思路。 基础配置 如果有多个接口属于同一个主网,那么只需要写...
  • 单区域OSPF配置 由于是在上一遍博客的基础上进行的实验,所以配置命令省去给端口设地址的部分,如果需要查看请参考上一篇博客 华为ensp 计网实验 动态路由RIP配置 R1配置 R2配置 R3 Pc1和pc2互ping ...
  • 动态路由。 人工配置量小,不易出错。路由条目是路由协议根据算法自动产生的条目,能够自动适应拓扑变化。 RIP是基于距离矢量算法的。 距离:RIP衡量链路的好坏。RIP计算开销是不考虑其他参数只考虑跳数。RIP最大...
  • RIP

    2020-12-27 17:16:59
    掌握华为动态路由配置 1.2实验拓展 1.3实验要求 1、全网可达 2、R4的的环回不能被宣告 3、R2 .R3.R4各有两个环回需要汇总 4、保证更新安全 5、加快收敛速度 1.4实验步骤 1.在eNSP模拟器中按实验拓扑要求构建拓扑 2...
  • 实际网络设备操作二、路由器动态配置(RIP、OSPF协议) 【有时间再细细回想来写】1.背景知识2.ENSP模拟过程3.实际网络设备操作三、ACL和NAT配置1.背景知识2.ENSP模拟过程3.实际网络设备操作 之前实验: 基于eNSP模拟...
  • 然后按照区域进行rip以及ospf动态路由的宣告。 完成后先将7环回直连宣告进ospf [r7-ospf-1]import-route direct 然后在R2和R3上使用双向重发布。此时发现,R1~4形成环路, ************************R3************...
  • 一个简单的RIP实验

    2020-04-10 16:36:20
    动态路由RIP实验 首先这里的环境和eNSP就不多介绍了,直接上图吧! 按图为各个路由器分配IP地址。这里就给大家发一个的配置过程,其余的参考这个。 好了这个是AR1的路由的IP配置过程,其它的大家各自配好。这时候...

空空如也

空空如也

1 2
收藏数 33
精华内容 13
关键字:

ensp配置rip动态路由