精华内容
下载资源
问答
  • 有的交换机在将端口设置trunk的时候会报这个错误, Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. 出现这个错误的时候,先给端口封装dot1Q协议...

    有的交换机在将端口设置为trunk的时候会报这个错误,

    Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

    出现这个错误的时候,先给端口封装dot1Q协议,再切换为trunk模式就OK了。

    命令如下

    Switch(config-if)#switchport trunk encapsulation dot1q

    展开全文
  • 两台交换机创建相同的vlan,这里是vlan10,然后将两台主机连接端口划分到创建的vlan中,将两台交换机连接的端口设置trunk模式,设置完成后,连接在两台交换机上的两台pc就可以ping通了。 SW1: enable conf t ...

    现有两台pc,分别连接在两台交换机的int f0/1接口上。两台交换机创建相同的vlan,这里是vlan10,然后将两台主机连接端口划分到创建的vlan中,将两台交换机连接的端口设置为trunk模式,设置完成后,连接在两台交换机上的两台pc就可以ping通了。

    SW1:
    enable
    conf t
    vlan 10
    exit
    int f0/1
    switchport access vlan 10
    exit
    int f0/12
    switchport mode trunk
    
    SW2:
    enable
    conf t
    vlan 10
    exit
    int f0/1
    switchport access vlan 10
    exit
    int f0/12
    switchport mode trunk

    这只是最简单的网络环境,网络中只有一个vlan10,如果遇到特殊的情况,需要指定只有允许的vlan可以将vlan数据包通过trunk口传出去。可以这样设置,现在要设置trunk口不转发vlan10的数据包。

    SW1: 
    enable
    conf t
    int f0/12
    sw trunk allowed vlan remove 10

    只需要在sw1上操作就行了,这样sw1的trunk端口就不会转发和接收vlan10的数据包,两台pc就ping不通了。

    sw trunk allowed vlan 有四种模式

    sw trunk allowed vlan add vlan-id        #添加允许通过的vlan
    sw trunk allowed vlan remove vlan-id     #禁止通过的vlan
    sw trunk allowed vlan except vlan-id     #除了指定的vlan,其他的都可通过
    sw trunk allowed vlan all vlan-id        #允许所有vlan通过

    要想恢复通信就输入  sw trunk allowed vlan add 10  或者  sw trunk allowed vlan all

    展开全文
  • 情况描述: 公司网络改造,一台深信服的AF防火墙上面一个三层...相连的交换机接口设置trunk反而不能通,需要设置成access,且把 它放在虚 接口所在vlan中才能通。 转载于:https://blog.51cto.com/jinkaiye/2153749...

    情况描述:

    公司网络改造,一台深信服的AF防火墙上面一个三层接口下联一个核心交换机

    防火墙三层接口IP 172.18.17.254

    核心交换机设置了一个虚接口172.18.17.1

    相连的交换机接口设置成trunk反而不能通,需要设置成access,且把 它放在虚

    接口所在vlan中才能通。

    转载于:https://blog.51cto.com/jinkaiye/2153749

    展开全文
  • tracer中三层交换机端口无法直接设置trunk口是因为需要封装dot1q ,dot1q的dot是“点”的意思,指的就是802.1q 。封装dot1q后会在以太网一个帧当中加入4个字节,在虚拟局域网vlan中可用来标示vlan(标识你属于哪个vlan...

    tracer中三层交换机端口无法直接设置trunk口是因为需要封装dot1q ,dot1q的dot是“点”的意思,指的就是802.1q 。封装dot1q后会在以太网一个帧当中加入4个字节,在虚拟局域网vlan中可用来标示vlan(标识你属于哪个vlan)。

    当执行命令 switchport mode trunk 时 tracer的三层交换机提示

    Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.

    说明你未对该端口进行802.1q的封装 ,你需要在上述命令之前加上 switchport trunk encapsulation dot1q即可

    Switch(config-if)#switchport trunk encapsulation dot1q
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#

    展开全文
  • Cisco三层交换机端口设置trunk方法

    万次阅读 多人点赞 2014-04-24 22:55:48
    问题症状:  Switch(config-if)#switchport mode... Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.  解决方法:  Switch(config-if)#swit
  • 接口设置trunk怎样再改为access

    千次阅读 2020-03-07 18:26:38
    直接清除此接口的配置,重新设置 clear con int g0/0/0 第二种: [Huawei]int g0/0/3 [Huawei-GigabitEthernet0/0/3]undo port trunk allow-pass vlan all [Huawei-GigabitEthernet0/0/3]port trunk allo...
  • 迈普2800路由器设置trunk

    千次阅读 2018-08-09 10:08:34
    vlan 1 port 21 untagged exit vlan 1001  port 21 tagged  port 18-19 untagged  exit port 18-19 ...设置port 21口为trunk口,且允许vlan1001通过。18、19口为access口 interface giga...
  • Trunk(端口汇聚)的概念与设置

    万次阅读 2016-07-31 13:19:31
    在二层交换机的性能参数中,常常提到一个重要的指标:TRUNK,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK功能,从而可以为互连的交换机之间提供更好的传输性能。那到底什么是TRUNK呢?使用TRUNK功能...
  • 当mode trunk出现如下提示时,要先封装协议再设置trunk端口。 第一步:switchport trunk encap dot1q \封装协议 第二步:switch mode trunk \设置trunk端口 如下
  • Esxi6.7网络trunk端口设置和vlan端口设置访问 1,Esxi网络trunk端口设置,即带tag的端口 1.1, 网络—虚拟交换机设置—添加标准虚拟交换机VlanAll,绑定vmnic3网卡,安全模式都接受,如下设置 1.2, 网络端口组...
  • rhcsa6入门初级学习的参考材料 Linux下网卡的trunk配置讲解
  • Trunk

    2021-04-03 20:53:52
    Trunk Trunk技术产生的背景 通常,我们都知道处于同一交换机下的相同vlan间可以通信,但是如何实现因地理位置影响而处于不同交换机下的相同Vlan进行通信呢? Trunk技术能够解决什么问题 实现当处于不同交换机下的...
  • 华为交换机Trunk配置

    千次阅读 2019-11-13 18:12:37
    华为交换机Trunk配置 Trunk 采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继...
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置为Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • Trunk端口的配置

    万次阅读 2019-03-27 09:37:51
    以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机与交换机之间、交换机与路由器之间)承载多个不同VLAN...
  • 配置Trunk接口

    千次阅读 2020-11-23 15:10:44
    port default vlan 20 //加入vlan20 inte eth0/0/1 //进入接口 port link-type trunk //接口模式为干道 port trunk allow-pass vlan 10 20 //允许vlan通过 S5 vlan 10 //创建vlan10 vlan 20 //创建vlan20 inte eth0/...
  • TRUNK 的介绍和配置

    万次阅读 多人点赞 2019-08-16 18:20:28
    一、 TRUNK 的背景 : 如果交换机与交换机之间存在多条链路,交换机每增加一个vlan,交换机与交换机就会增加一条链路。这样会存在链路浪费,就产生了 DTP ( dynamic trunk protocols) 采用trunk后,所有的vlan都...
  • 交换机trunk配置

    千次阅读 2019-05-15 13:49:30
    在路由器上配置DHCP服务为客户端自动分配IP地址如图 1,VLAN 1:192.168.1.0/24 2,网关192.168.1.244 3,首选DNS为202.106.0.20 4,预留IP地址打印服务器:192.168....3)设置主机A的IP配置为自动获取如图
  • 1、理解Trunk的运行原理 2、掌握Trunk的配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的...
  • [huaiwei G0/0/1]dis this # port link type trunk port trunk allow-pass vlan all 设置成这样通信不了 [huaiwei G0/0/1]dis this # port link type trunk undo port trunk allow-pass vlan 1 设置成这样就能通信了
  • HUAWEI设备如何配置Trunk ①进入对应接口配置接口类型 [SW1]interface e0/0/1 [SW1-Ethernet0/0/1]port link-type trunk 注意:如果这一步错了,需要一层一层的来删除配置,直到恢复到默认的配置,参考代码如下 ...
  • 交换机VLAN划分及Trunk配置

    千次阅读 2020-07-27 21:15:21
    port trunk allow-pass vlan 10 20 设置trunk模式允许vlan10 20的数据通过 通过以上配置后,我们也需要将右边的交换机进行如上配置,将右边的设备进行如“vlan划分”中提到的代码进行配置,再配置好IP地址,我们配置...
  • 华为交换机VLAN Trunk模式设置

    万次阅读 2018-01-09 14:32:15
    通过console线连接交换机。 使用MobaXterm连接交换机。 ...设置端口1为trunk模式 interface GigabitEthernet 0/0/1 port link-type trunk port trunk allow-pass vlan all display this
  • 华为交换机配置trunk接口

    万次阅读 2020-02-11 18:37:12
    配置Trunk接口 trunk端口一般用于交换机之间连接的端口,trunk端口可以属于多个vlan,可以接受发发送多个vlan的报文。 本次的实验如下图: 模拟两天办公区怎么互信通信,切互不影响,PC1与PC3是同网段,PC2与PC4是...
  • 交换机端口配置Trunk端口的配置 前面提到交换机端口的Access端口的配置,直白的的说就是对于交换机与用户相连接的端口的划分配置,能够对广播风暴起到抵御作用,提高了网络的安全性。今天,继续对交换机与交换机...
  • 思科交换机如何配置Trunk

    千次阅读 2021-02-25 14:30:58
    1、理解Trunk的运行原理 2、掌握Trunk的配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应...
  • 如何使用eNSP配置VLAN与Trunk

    千次阅读 2020-03-27 18:04:00
    port link-type access [SW1-Ethernet0/0/2]port default vlan 10 [SW1]interface Ethernet0/0/24 [SW1-Ethernet0/0/24]port link-type trunk [SW1-Ethernet0/0/24]port trunk allow-pass vlan 5 10 2)配置第2台...
  • GNS3实验 :Trunk配置

    千次阅读 2019-10-20 23:05:52
    GNS3实验: Trunk配置 实验目的:使不同VLAN通过共享链路与其它交换机中的相同VLAN进行通信。 搭建环境:配备两台相连的交换机,同时每台交换机配置两台PC机,预设四台PC机的IP地址。 实验思路:第一步,配置两台...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 41,407
精华内容 16,562
关键字:

设置trunk