精华内容
下载资源
问答
  • 华为交换机常用命令

    2018-12-11 17:58:39
    华为交换机常用命令包括华为交换机常用ACL、端口、安全配置命令等。
  • 华为交换机常用命令:1、display current-configuration 显示当前配置2、display interface GigabitEthernet 1/1/4 显示接口信息3、display packet-filter interface GigabitEthernet 1/1/4 显示接口acl应用信息4、...

    华为交换机常用命令

    1、display current-configuration 显示当前配置

    2、display interface GigabitEthernet 1/1/4 显示接口信息

    3、display packet-filter interface GigabitEthernet 1/1/4 显示接口acl应用信息

    4、display acl all 显示所有acl设置 3900系列交换机

    5、display acl config all 显示所有acl设置 6500系列交换机

    6、display arp 10.78.4.1 显示该ip地址的mac地址,所接交换机的端口位置

    e80f8373743d2b58aaab8a85eab6043c.png

    7、display cpu显示cpu信息

    8、system-view 进入系统图(配置交换机),等于config t 命令

    9、acl number 5000 在system-view命令后使用,进入acl配置状态

    10、rule 0 deny 0806 ffff 24 0a4e0401 f 40 在上面的命令后使用,,acl 配置例子

    11、rule 1 permit 0806 ffff 24 000fe218ded7 f 34 //在上面的命令后使用,acl配置例子

    12、interface GigabitEthernet 1/0/9 //在system-view命令后使用,进入接口配置状态

    13、[86ZX-S6503-GigabitEthernet1/0/9]qos //在上面的命令后使用,进入接口qos配置

    14、[86ZX-S6503-qosb-GigabitEthernet1/0/9]packet-filter inbound user-group 5000 //在上面的命令后使用

    ,在接口上应用进站的acl

    cb65dbfeee77e33c369b5535b4ebd47c.png

    15、[Build4-2_S3928TP-GigabitEthernet1/1/4]packet-filter outbound user-group 5001 //在接口上应用出站

    的acl

    16、undo acl number 5000 //取消acl number 5000 的设置

    17、ip route-static 0.0.0.0 0.0.0.0 10.78.1.1 preference 60 //设置路由

    18、reset counters interface Ethernet 1/0/14 //重置接口信息

    19、save //保存设置

    98c7975d2e8a8bc229c08c181a631c71.png

    20、quit //退出

    展开全文
  • 华为交换机常用命令视图分类用户视图登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the numberof current VTY users on line is 1.The current login ...

    华为交换机常用命令

    视图分类

    用户视图

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the number

    of current VTY users on line is 1.

    The current login time is 2020-04-10 12:15:00+00:00.

    系统视图

    用户模式下,输入system-view命令进入视图模式,可执行设备全局配置的命令system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]

    局部视图

    系统视图模式下,输入局部配置命令,进入局部对像的配置视图。如interface GE 1/0/0,进入GE1/0/0端口配置模式system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]interface GigabitEthernet 1/0/1

    [ZD_agg_5720-GigabitEthernet1/0/1]

    常用命令

    命令简介命令缩写解释displaydis查看相应对象信息

    undo撤消或反向操作对应命令

    system-viewsy进入系统视图

    sysname设置交换机名称

    quitq退出当前视图

    reboot交换机重启

    reset

    restart重新启动当前接口

    shutdown关闭当前接口

    信息查看命令

    交换机信息查看display version 查看交换机软件版本

    display clock 查看交换机时钟

    交换机配置查看display saved-configuration 显示系统保存配置

    display current-configuration 显示系统当前配置

    当前对象信息查看display this 显示当前信息。

    display this include-default 显示当前接口视图下的接口信息,包括默认值。

    display this interface 显示当前接口视图下的接口信息。

    查看接口display interface 查看接口当前运行状态和接口统计信息

    display interface brief 查看接口状态和配置的简要信息。

    display interface description 查看指定接口的描述信息

    display interface vlanif 查看VLANIF接口的状态信息、配置信息和统计信息。

    查看IP相关display ip interface 查看接口与IP相关的配置和统计信息,包括接口接收和发送的报文数、字节数和组播报文数,以及接口接收、发送、转发和丢弃的广播报文数。

    display ip interface brief 看接口与IP相关的简要信息,包括IP地址、子网掩码、物理链路和协议的Up/Down状态以及处于不同状态的接口数目。

    display ip interface description 查看接口与IP相关的简要信息,包括IP地址、子网掩码、物理层状态、链路层协议状态,及接口描述信息和处于不同状态的接口数目。

    display ip pool 显示所有ip pool

    display ip pool name {pool name} {all|conflict|expired|used} 显示ip pool详细信息

    display ip host 查看静态DNS表项

    display ip socket 查看已创建的IPv4 Socket信息。

    display ip statistics 显示IP流量统计信息。

    查看路由display ip routing-table 显示路由信息

    display ospf peer 查看ospf邻接等信息

    display ospf peer brief 查看ospf邻接等简要信息

    display rip 查看rip路由信息

    网络及流量display network status { all|tcp|udp|port port-number } 显示IP流量统计信息

    display tcp statistics 查看TCP流量统计信息

    display udp statistics 查看UDP流量统计信息

    VLAN查看display vlan 显示VLAN信息

    display vlan {pvid} verbose 查看vlan的详细信息

    display port vlan 查看VLAN中包含的接口信息

    display sub-vlan 查看Sub-VLAN类型的VLAN表项信息

    display super-vlan 查看Super-VLAN类型的VLAN表项信息

    display mac-vlan mac-address all 查看所有MAC地址划分VLAN的配置信息

    display mac-vlan vlan 2 查看vlan 2 MAC地址划分VLAN的配置信息

    查看ACL配置display acl {all | name | ipv6} 查看ACL

    display traffic classifier user-defined 查看用户定义的流分类

    display traffic behavior user-defined 查看用户定义的流行为

    display traffic policy user-defined {policy name} 查看用户定义的流策略

    display traffic-applied {inbound | outbound | interface | vlan} 查看流策略应用情况

    display traffic policy {global | interface | statistics | vlan } {inbound | outbound} 查看更多流策略信息

    display traffic policy statistics {global | interface | vlan} {inbound | outbound} 查看流策略统计信息

    display traffic-filter applied-record 查看acl应用的接口

    查看NAT配置#路由器命令

    display nat static {acl | global | inside | interface} 查看静态NAT信息

    display nat session {all | dest | number | protocol | source} 查看动态NAT信息

    display nat server {acl | global | inside | interface} 查看NAT server信息

    配置管理命令

    端口管理port 配置接口的缺省VLAN并加入该VLAN

    port description 配置接口的描述信息,描述与接口相连的设备类型。

    port gigabitethernet 0/0/1 to 0/0/4

    port default vlan 配置接口的缺省VLAN并同时加入这个VLAN。

    port link-type {access | hybird | trunk} 配置接口的链路类型

    port trunk allow-pass vlan {vlanid} 将trunk接口加入vlan

    端口配置speed {10|100|auto} 配置端口工作速率

    duplex {half|full|auto} 配置端口工作状态

    端口组操作display port-group {all} 查看端口组

    port-group {id} 创建端口组

    group-member gigabitethernet 0/0/2 to gigabitethernet 0/0/10 将2到10端口加入端口组

    VLAN管理vlan {id} 创建VLAN并进入VLAN视图,如果VLAN已存在,直接进入该VLAN的视图。

    vlan batch 10 to 20 批量创建VLAN

    vlan range 10 to 20 创建临时VLAN组,并进入VLAN-Range视图

    vlan statistics 配置VLAN的流量统计模式,即配置按包或按字节进行VLAN流量统计。

    vlan statistics interval 配置VLAN的流量统计的时间间隔

    ip address 用来配置接口的IP地址。

    接口管理interface gigabitethernet 0/0/1 进入指定的接口或子接口视图,进入0/0/1的接口

    DNS管理#查看

    display dns dynamic-host 查看动态DNS表项

    display dns domain 查看域名后缀的相关信息

    display dns server 查看DNS服务器的相关信息

    #设置

    dns domain domain-name 命令用来配置域名后缀,如 dns domain com.cn。

    dns resolve 命令用来使能动态域名解析功能

    dns server {ip} 命令用来配置DNS服务器的IP地址

    ip host {domain} {ip} 命令用来配置静态DNS表项 ip host www.huawei.com 10.10.10.4。

    DHCP管理dhcp enable 命令用来开启DHCP功能。

    dhcp select global 从全局配置中获取dhcp配置

    ACL管理acl {name | number | ipv6} 创建acl

    rule [{ruleid}] permit ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建允许规则

    rule [{ruleid}] deny ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建拒绝规则

    traffic-filter {inbound | outbound} acl {acl number} 在接口上应用acl规则

    #创建流分类

    traffic classifier {classifier name} operator { and |or }

    if-match acl {acl number} 为流分类设置匹配规则

    #创建流行为

    traffic behavior {behavior name}

    permit | deny | redirect 为流行为配置动作

    #创建流策略

    traffic policy {policy name}

    classifier {classifier name} behavior {behavior name} 关联流分类与流行为

    #将流策略应用到接口

    interface g0/0/1

    traffic-policy {policy name} {inbound | outbound} 接口绑定流策略

    NAT管理#边界路由器接口上配置静态NAT

    nat static global {外部ip} inside {内部ip} 添加静态nat,内外部ip一对一

    #动态NAT,使用dis nat session查看

    nat address-group {groupid} {ip开始} {ip结束} 添加外部可用地址池

    nat outbound {acl id} address-group {address-group id} no-pat 添加动态地址转换

    #NAPT,使用dis nat session查看

    nat outbound {acl id} [address-group {address-group id}] 添加动态端口地址转换

    #NAT server,使用dis nat server查看

    nat server protocol tcp global {外部ip} {外部端口} inside {内部ip} {内部端口} 添加nat server转换

    用户管理#查看本地用户

    display local-user

    #查看用户接口

    display user-interface

    #设置用户vty0为4个并发

    user-interface vty 0 4

    #进入用户console0接口

    user-interface console 0

    #用户管理

    local-user {username} password cipher {password}

    local-user {username} level 15

    local-user {username} service-type telnet terminal ssh

    绑定IP与MACuser-bind ip-address 10.0.0.2 mac-address 0001-0203-0405

    user privilege level 3

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。

    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

    日志与统计#打开统计

    display counters 查看接口的流量统计计数

    statistic enable

    trace mac enable

    trace mac aa99-6600-5600 vlan 2

    其它命令display stp 显示生成树信息

    display mac-address 显示MAC地址表

    display bridge mac-address 查看当前桥接设备mac地址

    display arp 显示ARP信息表

    display voice-vlan oui 查看Voice VLAN的OUI及其相关属性。

    display voice-vlan status 查看当前Voice VLAN的相关信息

    mac-vlan mac-address

    操作实战

    VLAN操作

    创建vlan,设置vlan的ip,并将端口加入vlan中。#进入全局配置视图

    system-view

    #新建vlan2

    [Huawei] vlan 2

    #进入vlan2的接口视图

    [Huawei] interface vlan 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #进入0/0/1接口,配置为access接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/1

    [Huawei-GigabitEthernet0/0/1] port link-type access

    [Huawei-GigabitEthernet0/0/1] port default vlan 2

    #进入0/0/2接口,配置为trunk接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/2

    [Huawei-GigabitEthernet0/0/2] port link-type trunk

    [Huawei-GigabitEthernet0/0/2] port trunk allow-pass vlan 2

    #查看端口配置的信息

    [Huawei-GigabitEthernet0/0/2] dis this

    #进入vlan2,将0/0/2到0/0/5端口加入到vlan2中(port link-type需要是access类型)

    [Huawei] vlan 2

    [Huawei-vlan2] port GigabitEthernet 0/0/2 to 0/0/5

    端口组操作

    需要对多个端口进行相同操作时,可以创建端口组进行批量操作。#创建端口组1,进行批量端口操作

    [Huawei] port-group 1

    #将6到10端口加入端口组

    [Huawei-port-group-1] group-member gigabitethernet 0/0/6 to gigabitethernet 0/0/10

    #批量将2~10端口修改为access模式

    [Huawei-port-group-1] port link-type access

    #批量将6~10端口加入到vlan 2中

    [Huawei-port-group-1] port default vlan 2

    IP POOL操作 system-view

    #进入ip pool中

    [Huawei] ip pool vlan10

    #在ip pool中添加dns server

    [Huawei-ip-pool-vlan10] dns-list 8.8.8.8

    #设置网关

    [Huawei-ip-pool-vlan10] gateway-list 10.0.0.1

    #设置ip pool的ip段和池,需要与vlanif接口配置匹配,否则ip分配不了

    [Huawei-ip-pool-vlan10] network 10.0.0.0 mask 255.255.255.0

    #过期时间

    [Huawei-ip-pool-vlan10] lease day 10

    DHCP操作 system-view

    #全局打开DHCP服务

    [Huawei] dhcp enable

    #进入vlan的接口视图

    [Huawei] interface vlanif 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #从全局配置中获取dhcp配置

    [Huawei-Vlanif2] dhcp select global

    静态添加路由 system-view

    display ip routing-table

    #ip route-static 目的ip 目标地址掩码 下一跳ip

    [Huawei] ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    #删除路由

    [Huawei] undo ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    RIP路由管理 system-view

    #修改loopback0地址

    [Huawei] int LoopBack 0

    [Huawei-LoopBack0] ip address 1.1.1.1 0

    #创建rip进程

    [Huawei] rip 1

    #启动版本2

    [Huawei-rip-1] version 2

    #宣告网段

    [Huawei] network 10.0.0.0

    [Huawei] network 1.0.0.0

    OSPF路由管理 system-view

    #创建ospf

    [Huawei] ospf 1 router-id 1.1.1.1

    #创建area0区域

    [Huawei-ospf-1] area 0

    #加入192.168.0.0/24子网

    [Huawei-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

    [Huawei-ospf-1-area-0.0.0.0]dis this

    #

    area 0.0.0.0

    network 192.168.0.0 0.0.0.255

    #

    [Huawei-ospf-1-area-0.0.0.0]

    ACL管理 system-view

    #配置acl

    [Huawei] acl 3000

    [Huawei-acl-adv-3000] rule permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] quit

    #配置流分类,匹配acl

    [Huawei] traffic classifier c0 operator or

    [Huawei-classifier-c0] if-match acl 3000

    [Huawei-classifier-c0] quit

    #配置流行为,设置动作

    [Huawei-behavior-b0] traffic behavior b0

    [Huawei-behavior-b0] permit

    [Huawei-behavior-b0] quit

    #配置流策略,关联流分类c0与流行为b0

    [Huawei] traffic policy p0

    [Huawei-trafficpolicy-p1] classifier c0 behavior b0

    [Huawei-trafficpolicy-p1] quit

    #配置流策略应用到接口

    [Huawei] interface g0/0/1

    [Huawei-GigabitEthernet0/0/1] traffic-policy p0 inbound

    [Huawei-GigabitEthernet0/0/1] return

    用户管理#查看本地用户

    display local-user

    system-view

    #进入aaa配置模式

    [Huawei] aaa

    #配置本地用户账号密码

    [Huawei-aaa] loca-user user1 password cipher 123456

    #用户服务类型为telnet,使用telnet登陆

    [Huawei-aaa] local-user user1 service-type telnet

    #配置用户特权等级15

    [Huawei-aaa] local-user user1 privilege level 15

    展开全文
  • http://hi.baidu.com/sosofa/blog/item/7a595ccf270e503bf9dc6150.html华为交换机常用命令2008-10-0715:45disvlan显示vlannametext指定当前vlan的名称undoname取消[h3c]vlan2[h3c-vlan2]nametestvlandisusers显示...

    http://hi.baidu.com/sosofa/blog/item/7a595ccf270e503bf9dc6150.html

    华为交换机常用命令

    2008-10-07 15:45

    dis vlan

    显示

    vlan

    name text

    指定当前

    vlan

    的名称

    undo name

    取消

    [h3c] vlan 2

    [h3c-vlan2]name test vlan

    dis users

    显示用户

    dis startup

    显示启动配置文件的信息

    dis user-interface

    显示用户界面的相关信息

    dis web users

    显示

    web

    用户的相关信息。

    header login

    配置登陆验证是显示信息

    header shell

    undo header

    lock

    锁住当前用户界面

    acl

    访问控制列表

    acl number inbound/outbound

    [h3c]user-interface vty 0 4

    [h3c-vty0-4] acl 2000 inbound

    shutdown:

    关闭

    vlan

    接口

    undo shutdown

    打开

    vlan

    接口

    关闭

    vlan1

    接口

    [h3c] interface vlan-interface 1

    [h3c-vlan-interface] shutdown

    vlan vlan-id

    定义

    vlan

    undo valn vlan-id

    display ip routing-table

    display ip routing-table protocol static

    display ip routing-table statistics

    display ip routing-table verbose

    查看路由表的全部详细信息

    interface vlan-interface vlan-id

    进入

    valn

    management-vlan vlan-id

    定义管理

    vlan

    reset ip routing-table statistics protocol all

    清除所有路由协议的路由

    信息

    .

    display garp statistics interface GigabitEthernet 1/0/1

    显示以太网端口

    上的

    garp

    统计信息

    display voice vlan status

    查看语音

    vlan

    状态

    [h3c-GigabitEthernet1/0/1]

    broadcast-suppression

    20

    允许接受的最大广播

    流量为该端口传输能力的

    20%.

    超出部分丢弃

    .

    展开全文
  • 感谢您的支持,如果还有其他问题,请私信给我前几期讲解了华为交换机的一些配置,今天讲解一些简单的命令和一些技巧,主要是显示华为交换机配置的一些命令,这些命令对于网络管理很有帮助,也是华为交换机常用命令。...

    如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有其他问题,请私信给我

    前几期讲解了华为交换机的一些配置,今天讲解一些简单的命令和一些技巧,主要是显示华为交换机配置的一些命令,这些命令对于网络管理很有帮助,也是华为交换机的常用命令。下面进入正题:

    1. system-view,可简写为sys ,这条命令是由用户视图登录到系统视图的必须命令。用户视图与系统视图的区别为:用户视图在交换机名字两边为 <>,系统视图为{ }.如下图

    60578c37170f8e8843dd09d98c0f80d2.png

    现在为用户视图

    246d1fdb3c4927226f50891acb3674c1.png

    现在为系统视图

    2. display ,可以简写为dis,这条命令是显示你想要查询的配置,例如,

    例如查询当前版本:dis ver

    83a2cb3ce95afbbd472eac777b619c1f.png

    查询当前配置 dis curr

    0049c5156de4fc75f97d393f6f73a42c.png

    查询接口信息:dis int

    bc975c4fe82b930d23b3d074168a3c3b.png

    3. TAB键。

    TAB键在华为的交换机和路由器中是最常用的一个键,主要的功能是补全命令。我们知道display 是显示的意思,那么我们忘记了怎么拼,或者拼错了怎么办?我们只需要建入前三个字符,然后按下TAB键,如图:

    33b64d97e33923d422b77ca57f1b4f1e.png

    ,这个命令是唯一的,意思是在系统里只有这一个以dis开头的命令,所以,按下TAB键后自动补全命令。

    4. ?(问号)

    这个也是常用的一个符号,是华为系统的帮助功能。如果你登录到一个视图中,不知道应该输入什么命令,或者只记得命令的开头一个或两个字符,那么?这个符号就派上用场了,还是以display 来做演示,我们只记得第一个字符d,然后,在d的后面加上一个?号,看看是一个什么样的效果

    fa316612b691e127a94e197341dcf6f5.png

    列出来以d开头的所有命令,然后我们再在这个命令里查找需要的命令.

    有的时候呢,我们把命令全忘了,只是知道在哪个视图下面,那么我们直接登录到该视图下,直接输入?号。如下图,我们要设置vlan ,但是命令我们不记得了,直接在vlan视图下输入?号,看看是什么结果:

    7e388e9e96897244b1a9d80b28fb633d.png

    可以看得出,左边是命令,右边是命令的简介,这样配置起来是不是很简单了?

    到这里华为常用命令和技巧介绍完毕了,如果您还有什么不明白的,请留言或私信给我。

    如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有其他问题,请私信给我

    展开全文
  • 思科和华为交换机常用命令对比学习,基本命令对比介绍
  • 华为交换机常用命令:查看交换机VLAN IP命令:display ip interface brief退出系统视图,保存更改: save查看交换机所有VLAN命令:dis vlan更改交换机名称为SW1: sysname SW1查看所有端口配置信息: dis ...
  • 华为交换机批量修改端口第一步建组port-group 1第二步把端口加入组group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/10第三步对组里的端口进行操作。这些操作将同时应用以上面的端口port link-type ...
  • 华为交换机常用命令:查看交换机VLAN IP命令:display ip interface brief退出系统视图,保存更改: save查看交换机所有VLAN命令:dis vlan更改交换机名称为SW1: sysname SW1查看所有端口配置信息: dis ...

空空如也

空空如也

1 2 3 4 5 ... 18
收藏数 355
精华内容 142
关键字:

华为交换机常用命令