精华内容
下载资源
问答
  • 初学BGP协议实验
    2021-07-23 18:20:28

    实验题目

    请添加图片描述

    1. 该网络中所有路由器运行BGP协议
    2. 所有PC间可以互相访问

    拓扑搭建

    请添加图片描述

    实验思路

    1. AS 2中启用OSPF协议,实现内部路由互通
    2. AS1与AS2、AS2与AS3间建邻EBGP,AS2内部所有路由器建邻IBGP(为避免路由黑洞,所以此次实验中AS2内所有路由器皆启BGP协议,而实际工程不会这么做,因为能承载BGP协议的路由器价格昂贵,成本巨大;后期将使用MPLS 多协议标签交换来解决路由黑洞,便无需使所有路由器都开启BGP协议)
    3. 配置完成后,邻居间单播TCP三次握手,目标端口179,建立TCP的会话;之后所有的BGP协议数据包基于该会话进行传输;
    4. 邻居关系建立后,管理员选择性将本地路由表中通过任意来源获取的路由条目,向BGP协议中进行宣告;使用updata数据包进行邻居间路由共享;之后生成BGP表——装载本地发出及接收到的所有路由条目;

    关键易错点

    1. EBGP建邻时,建议启用环回接口来保持TCP会话畅通,设置备份网线,当一条网线断开时,将启用另一条网线来继续保持TCP会话,增强稳定性

    2. IBGP建邻时,由于一个AS的内部大多拓扑冗余比较丰富,若使用物理接口来作为源、目IP地址建立BGP邻居,将浪费冗余资源;建议使用环回接口作为源/目ip地址;稳定且可以同时使用多条链路资源

    3. 由于IBGP的水平分割防环机制,本地从一个IBGP邻居处学习到的路由条目,不得传递给本地的其他IBGP邻居,因此R3无法转发R2和R4的路由,必须将R2和R4进行非直连建邻,依靠单播更新来互相发送路由条目

    4. IBGP内部发送数据包时,由于BGP协议使用AS-BY-AS规则而非hop-by-hop,在一个AS内部条目传递的过程中,默认不会修改任何的属性,所以每个路由器须手动将自身设为下一跳的终点。否则除直连路由器外,其余路由器不会将路由条目加表

    5. TTL问题,默认IBGP邻居间的数据包TTL值默认为255,EBGP邻居间TTL值默认为1,因此若使用环回来建立EBGP邻居关系,TTL不够;故必须修改TTL值

    实验配置

    启用BGP,设置router-id

    [R1]bgp 1   //启动时需要定义AS号,没有多进程概念;一台设备只能在一个AS中工作
    [R1-bgp]router-id 1.1.1.1  //建议配置RID;RID的生成规则同OSPF;
    

    多链路的EBGP邻居关系
    以R4和R5为例

    [R4]bgp 2 
    [R4-bgp]peer  5.5.5.5 as-number 3 //和5.5.5.5接口建邻
    [R4-bgp]peer  5.5.5.5 connect-interface LoopBack 0 //将接邻接口设为自身环回,否则默认为物理接口
    [R4]ip route-static  5.5.5.0 24 45.1.1.2 //IP可达问题,R4路由表中没有R5环回地址,所以手动配置静态路由
    [R4]ip route-static 5.5.5.0 24 54.1.1.2
    [R4-bgp]peer 5.5.5.5 ebgp-max-hop 2 //修改TTL
    
    [R5]bgp 3 
    [R5-bgp]peer  4.4.4.4 as-number 2 //和4.4.4.4接口建邻
    [R5-bgp]peer  4.4.4.4 connect-interface LoopBack 0 //将接邻接口设为自身环回,否则默认为物理接口
    [R5]ip route-static  4.4.4.0 24 45.1.1.1 //IP可达问题,R5路由表中没有R4环回地址,所以手动配置静态路由
    [R5]ip route-static 4.4.4.0 24 54.1.1.1
    [R5-bgp]peer 4.4.4.4 ebgp-max-hop 2 //修改TTL
    

    两端配置完成后,邻居间先进行TCP的三次握手,建立TCP的会话

    IBGP配置

    [R2]bgp 2 
    [R2-bgp]peer  3.3.3.3 as-number 2
    [R2-bgp]peer  3.3.3.3 connect-interface LoopBack 0
    [R2-bgp]peer  4.4.4.4 as-number 2
    [R2-bgp]peer  4.4.4.4 connect-interface LoopBack 0
    
    [R3]bgp 2 
    [R3-bgp]peer  4.4.4.4 as-number 2
    [R3-bgp]peer  4.4.4.4 connect-interface LoopBack 0
    [R3-bgp]peer  2.2.2.2 as-number 2
    [R3-bgp]peer  2.2.2.2 connect-interface LoopBack 0
    
    [R4]bgp 2 
    [R4-bgp]peer  3.3.3.3 as-number 2
    [R4-bgp]peer  3.3.3.3 connect-interface LoopBack 0
    [R4-bgp]peer  2.2.2.2 as-number 2
    [R4-bgp]peer  2.2.2.2 connect-interface LoopBack 0
    

    宣告路由

    [R1]bgp 1 
    [R1-bgp]network 192.168.1.0 24
    [R2]bgp 2
    [R2-bgp]network 192.168.2.0 24
    [R3]bgp 2
    [R3-bgp]network 192.168.3.0 24
    [R4]bgp 2
    [R4-bgp]network 192.168.4.0 24
    [R5]bgp 3
    [R5-bgp]network 192.168.5.0 24
    

    修改下一跳配置

    [R2]bgp 2 
    [R2-bgp]peer  3.3.3.3 next-hop-local   //R2将路由传输给3.3.3.3时,修改下一跳地址为R2;
    [R2-bgp]peer  4.4.4.4 next-hop-local   //R2将路由传输给4.4.4.4时,修改下一跳地址为R2;
    
    [R4]bgp 2 
    [R4-bgp]peer  3.3.3.3 next-hop-local   //R4将路由传输给3.3.3.3时,修改下一跳地址为R4;
    [R4-bgp]peer  2.2.2.2 next-hop-local   //R4将路由传输给2.2.2.2时,修改下一跳地址为R4;
    
    更多相关内容
  • BGP协议实验

    2021-08-12 15:36:19
    BGP实验 要求: 1.如图连接网络,合理规格IP地址,AS200内IGP协议 为OSPF 2.R1属于AS 100 ; R2-R3-R4小AS 234 R5-R6-R7小AS 567,同时声明大AS 200,R8属于AS300 ...3、运行BGP协议 先部署小as,在申明大as

    BGP实验

    在这里插入图片描述
    要求:
    1.如图连接网络,合理规格IP地址,AS200内IGP协议
    为OSPF
    2.R1属于AS 100 ; R2-R3-R4小AS 234 R5-R6-R7小AS
    567,同时声明大AS 200,R8属于AS300
    3.R2-R5 R4-R7之间为联邦EBGP邻居关系
    4.R1-R8之间通信

    实验步骤:

    1、首先配置IP地址
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述

    测试:
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    2、as200内 igp协议为ospf协议.R2-R8运行ospf协议在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    查看学习到的路由
    在这里插入图片描述在这里插入图片描述
    3、运行BGP协议
    先部署小as,在申明大as
    R1 AS 100在这里插入图片描述
    R2-R4 做小AS 234
    声明大AS 200在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    在这里插入图片描述
    R4和R7之间是ebgp 邻居关系没建立在这里插入图片描述
    所以设置多跳在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    查看邻居状态,已建立在这里插入图片描述
    在R1上通告1的环回。看 R3R4、R7是否学习到在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    ibgp水平分割,ibgp不能传给ibgp路由。可在边界之间建立bgp。
    R3,R4都为ibgp不能传递路由,所以在ibgp中全互联。在R2、R4之间建立邻居在这里插入图片描述在这里插入图片描述
    在这里插入图片描述
    查看在这里插入图片描述
    R7括号里234是簇ID,是联邦里用来防环的在这里插入图片描述在这里插入图片描述
    在R8上通告R8的环回,在R1上也可以学习到在这里插入图片描述在这里插入图片描述
    继续做 小as567
    在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述在这里插入图片描述
    查看
    在这里插入图片描述在这里插入图片描述在这里插入图片描述
    R5上没有8.8.8.8的路由 由于ibgp的水平分割
    在R7和R5建立邻居
    建立ibgp全互联的邻居关系在这里插入图片描述在这里插入图片描述
    查看
    在这里插入图片描述

    展开全文
  • BGP协议实验(华为)

    千次阅读 多人点赞 2020-11-10 15:07:18
    文章目录一、实验环境二、实验目的三、实验拓扑图四、实验过程 一、实验环境 eNSP 5台路由器(R1~R5) R1、R2处于Rip中(AS100) R3、R4、R5处于Ospf中(AS200) 二、实验目的 通过配置,实现全网互通 三、实验...


    一、实验环境

    • eNSP
    • 5台路由器(R1~R5)
    • R1、R2处于Rip中(AS100)
    • R3、R4、R5处于Ospf中(AS200)

    二、实验目的

    通过配置,实现全网互通


    三、实验拓扑图

    在这里插入图片描述

    四、命令简介

    仅供参考,只用理解命令意义,不要纠结数字编号

    [R1]bgp 100 ###创建bgp编号为100 (也就是AS100)
    [R1-bgp]router-id 1.1.1.1 ###配置BGP的Router ID
    [R1-bgp] peer 2.2.2.2 as-number 100 ###指定对等体的回环网口IP地址及其所属的AS编号
    [R1-bgp]peer 2.2.2.2 connect-interface LoopBack0 ##更新发送bgp报文的接口为Loopback0接口

    [R3-bgp]peer 2.2.2.2 next-hop-local
    --------ASBR从ebgp邻居学习到的路由传递给ibgp邻居时,修改该命令
    [R3-bgp]peer 7.7.7.7 ebgp-max-hop 2
    --------两个AS之间用回环网口建的邻居要将它们的邻居的最大跳数改为2,默认的是1 (因为不是直连而是用Loopbacko接口,需要经过2个路由,而默认EBGP传递时TTL值为1)

    [R3-bgp]network 1.1.1.1 255.255.255.255 ###宣告指定的IGP、静态、默认路由进BGP进程

    [R3]ip route-static 7.7.7.7 255.255.255.255 12.1.1.2
    ------两个AS之间的ebgp对等体需要建立tcp连接,这里用静态做底层的寻址,也可以使用IGP路由搭建底层寻址(比如RIP)
    [R3-bgp]network 7.7.7.7 255.255.255.255 ###ebgp用于配置静态路由或IGP路由的网段或IP需要在两端ebgp都宣告

    五、实验过程

    1.配置IP地址(回环),RIP和OSPF(宣告网段)

    R1
    在这里插入图片描述
    R2
    在这里插入图片描述
    R3在这里插入图片描述
    R4在这里插入图片描述
    R5
    在这里插入图片描述

    2.配置BGP

    R1
    在这里插入图片描述

    R2
    在这里插入图片描述
    在这里插入图片描述

    R3

    在这里插入图片描述

    R4

    在这里插入图片描述

    R5

    在这里插入图片描述

    3.实验验证

    Ping一下,注意这里命令有区别

    在这里插入图片描述
    OK,成功实现全网互通

    展开全文
  • BGP协议简单实验

    千次阅读 2022-01-21 22:08:25
    使用BGP,按照真实网络环境的逻辑配置,实现所有PC段间互相连通 1.配置ip 2.相邻as间配置EBGP,as间使用ibgp 3.修改,改善 配置命令 [r1-LoopBack0]ip add 1.1.1.1 24 [r1-GigabitEthernet0/0/0]ip add 12.1....

    使用BGP,按照真实网络环境的逻辑配置,实现所有PC段间互相连通

    1.配置ip                   2.相邻as间配置EBGP,as间使用ibgp         3.修改,改善

     配置命令

    [r1-LoopBack0]ip add 1.1.1.1 24
    [r1-GigabitEthernet0/0/0]ip add 12.1.1.1 24
    [r1-GigabitEthernet0/0/1]ip add 192.168.1.1 24

    [r2-LoopBack0]ip add 2.2.2.2 24
    [r2-GigabitEthernet0/0/0]ip add 12.1.1.2 24
    [r2-GigabitEthernet0/0/1]ip add 23.1.1.1 24
    [r2-GigabitEthernet0/0/2]ip add 192.168.2.1 24

    [r3-LoopBack0]ip add 3.3.3.3 24
    [r3-GigabitEthernet0/0/0]ip add 23.1.1.2 24
    [r3-GigabitEthernet0/0/2]ip add 192.168.3.1 24
    [r3-GigabitEthernet0/0/1]ip add 34.1.1.1 24

    [r4-LoopBack0]ip add 4.4.4.4 24
    [r4-GigabitEthernet0/0/0]ip add 34.1.1.2 24
    [r4-GigabitEthernet0/0/1]ip add 45.1.1.1 24
    [r4-GigabitEthernet0/0/2]ip add 192.168.4.1 24
    [r4-GigabitEthernet4/0/0]ip add 45.1.2.1 24

    [r5-LoopBack0]ip add 5.5.5.5 24
    [r5-GigabitEthernet0/0/0]ip add 45.1.1.2 24
    [r5-GigabitEthernet0/0/1]ip add 192.168.5.1 24
    [r5-GigabitEthernet0/0/2]ip add 45.1.2.2 24

    AS间配置ospf协议(最左边右边不配置宣告)(直连可直接连接)

    [r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
    [r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [r2-ospf-1-area-0.0.0.0]network 192.168.2.1 0.0.0.0

    [r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
    [r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    [r3-ospf-1-area-0.0.0.0]network 192.168.3.1 0.0.0.0
    [r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0

    [r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
    [r4-ospf-1-area-0.0.0.0]network 192.168.4.1 0.0.0.0
    [r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0

    配置BGP

    [r1]bgp 1
    [r1-bgp]router-id 1.1.1.1    
    [r1-bgp]peer 12.1.1.2 as-number 2

    [r2]bgp 2
    [r2-bgp]router-id 2.2.2.2    
    [r2-bgp]peer 12.1.1.1 as-number 1
    [r2-bgp]peer 3.3.3.3 as-number 2
    [r2-bgp]peer 3.3.3.3 connect-interface LoopBack 0

    [r3]bgp 2    
    [r3-bgp]router-id 3.3.3.3    
    [r3-bgp]peer 2.2.2.2 as-number 2
    [r3-bgp]peer 2.2.2.2 connect-interface lo 0
    [r3-bgp]peer 4.4.4.4 as-number 2
    [r3-bgp]peer 4.4.4.4 connect-interface LoopBack 0

    [r4]bgp 2
    [r4-bgp]router-id 4.4.4.4    
    [r4-bgp]peer 3.3.3.3 as-number 2    
    [r4-bgp]peer 3.3.3.3 connect-interface LoopBack 0

    r4到r5之间需要配置静态路由(多路链接)

    [r4]ip route-static 5.5.5.0 24 45.1.1.2
    [r4]ip route-static 5.5.5.0 24 45.1.2.2

    [r5]ip route-static 4.4.4.0 24 45.1.1.1
    [r5]ip route-static 4.4.4.0 24 45.1.2.1

    [r4]bgp 2    
    [r4-bgp]peer 5.5.5.5 as-number 3    
    [r4-bgp]peer 5.5.5.5 connect-interface lo 0
    [r4-bgp]peer 5.5.5.5 ebgp-max-hop 2
    (提高跳数,可以到达环回)

    [r5]bgp 3
    [r5-bgp]router-id 5.5.5.5
    [r5-bgp]peer 4.4.4.4 as-number 2    
    [r5-bgp]peer 4.4.4.4 connect-interface lo 0
    [r5-bgp]peer 4.4.4.4 ebgp-max-hop 2

    BGP宣告(逐条)

    [r1]bgp 1
    [r1-bgp]network 192.168.1.0 24
    [r2-bgp]network 192.168.2.0 24
    [r3-bgp]network 192.168.3.0 24
    [r4-bgp]network 192.168.4.0 24
    [r5-bgp]network 192.168.5.0 24

    宣告r3无法*>,改r2下一跳为本地
    [r2]bgp 2
    [r2-bgp]peer 3.3.3.3 next-hop-local
    [r2-bgp]peer 4.4.4.4 next-hop-local

    [r4-bgp]peer 3.3.3.3 next-hop-local
    [r4-bgp]peer 2.2.2.2 next-hop-local

    3的BGP水平分割,无法传递给r4,r2和r4连
    (IBGP传递属性不变,EBGP属性变化)
        
    [r2-bgp]peer 4.4.4.4 as-number 2    
    [r2-bgp]peer 4.4.4.4 connect-interface lo 0
        
    [r4-bgp]peer 2.2.2.2 as-number 2
    [r4-bgp]peer 2.2.2.2 connect-interface lo 0
     

    配置结果

    调式

    179服务端口,50870客户端
    dis bgp peer 
    查看BGP库   dis bgp peer       dis bgp routing-table

     

    展开全文
  • BGP协议实验PPT

    2011-09-07 15:03:07
    BGP协议实验 BGP协议分析实验 BGP状态转换分析实验 BGP路由聚合实验 BGP路由属性实验 BGP路由策略和路由过滤实验 共64张幻灯片
  • 实验拓扑 拓扑中,配置BGP,CR1、CR2、AR属于AS65004,并且内部运行OSPF,BR属于AS65003,BR与CR1、CR2建立EBGP关系,其中AR所接用户网络使用loopback1,loopback2,loopback3模拟。 配置IP地址 interface ...
  • BGP协议总结

    2021-08-06 17:06:10
    1.bgp协议的定义 2.关于AS 二.IGP/EGP/IBGP/EBGP 三.BGP特点 四.BGP数据包 五、BGP的工作过程 六、BGP的路由黑洞问题 1.路由黑洞的描述 2.解决方法 七、BGP的防环机制 –水平分割 1、EBGP水平分割—解决EBGP环路; ...
  • 外部网关协议----BGP及实验bgp的特点bgp协议特征bgp报文类型open报文update报文natification报文Keepalive报文route-refreshbgp的六种状态 bgp的特点 1.能够承载大批量的路由信息,能够支撑大规模网络 2.不能自己...
  • BGP路由协议实验.doc

    2020-06-29 16:25:40
    BGP虽然是一种动态路由协议,但它实际上本身并不产生路由、不发现路由、不计算路由,其主要功能是完成最佳路由的选择并在BGP邻居之间进行最佳路由的传递。BGP选择了TCP作为其传输协议,端口号是179。 BGP的邻居关系...
  • BGP实验报告

    千次阅读 2022-01-21 19:32:57
    一、实验内容 二、拓扑设计 环回为1.1.1.0/24、2.2.2.0/24、3.3.3.0/24、4.4.4.0/24、5.5.5.0/24 三、实施 1、底层,所有节点拥有合法的IP地址 R1: R2: R3: R4: R5...
  • BGP实验

    2022-01-22 19:38:02
    1.了解BGP路由协议的工作原理。 2.了解BGP路由协议的应用场景。 3.掌握BGP路由协议的基本配置。 三、实验方案设计 本次实验采用四台路由器分别为RTA、RTB、RTC、RTD。 RTA属于AS100;RTB和RTC属于AS200;RTD属于AS...
  • BGP协议详解及工作原理

    千次阅读 2020-08-01 15:21:44
    边界网关协议BGP) 是运行于 TCP 上的一种自治系统的路由协议BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议BGP的特征 传输协议:tcp 端口号179 ...
  • BGP协议配置实验

    2021-04-20 18:28:13
    文章目录BGP协议配置实验 BGP协议配置实验 R1: [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]ip a 12.0.0.1 24 Apr 20 2021 16:00:23-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface ...
  • bgp案例分析实验报告

    2011-07-20 12:41:54
    对于bgp的一些常见案例进行整合,供广大网友学习。
  • 文章目录一、BGP概述1.1 自治系统(AS)1.2 动态路由的分类按自治系统分为按协议类型分类1.3 BGP的概念1.4 BGP的特征二、BGP工作原理2.1 BGP报文2.2 BGP数据库2.3 BGP的类型三、BGP配置3.1 BGP配置思路3.2 配置实例...
  • BGP 基本配置实验(超详细)

    千次阅读 2021-07-28 09:39:08
    实验拓扑 注:如无特别说明,描述中的 R1 或 SW1 对应拓扑中设备名称末尾数字为 1 的设备,R2 或 SW2 对应拓扑中设备名称末尾数字为2的设备,以此类推;另外,同一网段中,IP 地址的主机位为其设备编号,如 R3 的 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,629
精华内容 2,251
关键字:

bgp协议实验

友情链接: java-chat.zip