精华内容
下载资源
问答
  • ensp链路聚合

    2020-08-19 09:19:37
    二层链路聚合配置 [Huawei]int eth-trunk 1 [Huawei]q [Huawei]int g0/0/1 [Huawei-GigabitEthernet0/0/1]eth-trunk 1 [Huawei]q [Huawei]int g0/0/2 [Huawei-GigabitEthernet0/0/2]eth-trunk 1 [Huawei-...

    二层链路聚合配置

    [Huawei]int eth-trunk 1     //创建聚合链路
    [Huawei]q
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]eth-trunk 1     //划分端口
    [Huawei]q
    [Huawei]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]eth-trunk 1
    [Huawei-GigabitEthernet0/0/2]                            
    [Huawei]dis int eth-trunk 1
    Eth-Trunk1 current state : UP
    Line protocol current state : UP
    Description:
    Switch Port, PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW:
     2G, Current BW: 2G, The Maximum Frame Length is 9216
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 4c1f-cc32-6785
    Current system time: 2020-08-14 16:35:12-08:00
        Input bandwidth utilization  :    0%
    
        Output bandwidth utilization :    0%
    -----------------------------------------------------
    PortName                      Status      Weight
    -----------------------------------------------------
    GigabitEthernet0/0/1          UP          1
    GigabitEthernet0/0/2          UP          1
    -----------------------------------------------------
    The Number of Ports in Trunk : 2
    The Number of UP Ports in Trunk : 2
    

    三层链路聚合配置

    [Huawei]int Eth-Trunk 1
    [Huawei-Eth-Trunk1]undo portswitch
    [Huawei-Eth-Trunk1]q
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]eth-trunk 1
    [Huawei-GigabitEthernet0/0/0]q
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]eth-trunk 1
    [Huawei-GigabitEthernet0/0/1]q
    [Huawei]int Eth-Trunk 1
    [Huawei-Eth-Trunk1]ip address 192.168.1.1 24
    [Huawei-Eth-Trunk1]q
    [Huawei]dis eth-trunk 1
    Eth-Trunk1's state information is:
    WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP         
    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8              
    Operate status: up          Number Of Up Port In Trunk: 2                     
    --------------------------------------------------------------------------------
    PortName                      Status      Weight 
    GigabitEthernet0/0/0          Up          1      
    GigabitEthernet0/0/1          Up          1      
    

    *删除链路聚合组中删除成员接口
    在接口视图下执行undo eth-trunk命令。
    在Eth-Trunk视图下执行undo trunkport interface-type { interface-number1 [ to interface-number2 ] } &<1-8>命令

    展开全文
  • ensp 链路聚合的配置

    千次阅读 2020-10-23 22:25:27
    链路聚合(英语:Link Aggregation)是一个计算机网络术语,指将多个物理端口汇聚在一起,形成一个逻辑端口,以实现出/入流量吞吐量在各成员端口的负荷分担,交换机根据用户配置的端口负荷分担策略决定网络封包从...

    链路聚合(英语:Link Aggregation)是一个计算机网络术语,指将多个物理端口汇聚在一起,形成一个逻辑端口,以实现出/入流量吞吐量在各成员端口的负荷分担,交换机根据用户配置的端口负荷分担策略决定网络封包从哪个成员端口发送到对端的交换机。当交换机检测到其中一个成员端口的链路发生故障时,就停止在此端口上发送封包,并根据负荷分担策略在剩下的链路中重新计算报文的发送端口,故障端口恢复后再次担任收发端口。链路聚合在增加链路带宽、实现链路传输弹性和工程冗余等方面是一项很重要的技术。 —来源百度百科

    链路聚合的分类

    类型 作用
    手动模式 这个模式下的所有端口都是处于转发状态,每一个端口彼此分担流量的压力
    LACP静态模式 又叫备份链路模式,有的链路在正常情况下是没有流量通过的(down掉的)当其他链路出现故障,自动会替换其工作
    动态模式 不常用

    配置过程如下

    网络结构拓扑图
    在这里插入图片描述
    手动模式的配置
    LSW1和LSW2的配置(配置相同)

    [LSW1]interface Eth-Trunk 1      //进入eth-trunk接口
    [LSW1-Eth-Trunk1]trunkport g 0/0/2 to 0/0/4   //将接口2到4捆绑在一起
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [LSW1-Eth-Trunk1]port link-type trunk    //将链路设置trunk模式
    [LSW1-Eth-Trunk1]port trunk allow-pass  vlan all 
    [LSW1]display eth-trunk      //查看eth-trunk的状态
    Eth-Trunk1's state information is:
    WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP         
    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8              
    Operate status: up          Number Of Up Port In Trunk: 3                     
    --------------------------------------------------------------------------------
    PortName                      Status      Weight 
    GigabitEthernet0/0/2          Up          1      
    GigabitEthernet0/0/3          Up          1      
    GigabitEthernet0/0/4          Up          1  
    

    LACP静态模式的配置
    网络结构图如上一致
    LSW1和LSW2的配置(配置相同)

    [LSW1]lacp priority 1000    //修改当前交换机的优先级,使之成为主动端(默认的优先级为32768)[这个命令只在第一个交换机上进行修改]
    [LSW1]interface Eth-Trunk 1    //进入eth-trunk接口
    [LSW1-Eth-Trunk1]mode lacp-static   //设置模式为lacp-static
    [LSW1-Eth-Trunk1]trunkport g 0/0/2 to 0/0/4    //绑定对应的端口
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [LSW1-Eth-Trunk1]display eth-trunk    //查看当前的状态
    Eth-Trunk1's state information is:
    Local:
    LAG ID: 1                   WorkingMode: STATIC (模式变为了静态)                              
    Preempt Delay: Disabled     Hash arithmetic: According to SIP-XOR-DIP   (类型为)     
    System Priority: 1000 (优先级)      System ID: 4c1f-ccd1-6fe8                         
    Least Active-linknumber: 1  Max Active-linknumber: 8                          
    Operate status: up          Number Of Up Port In Trunk: 3                     
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    GigabitEthernet0/0/2   Selected 1GE      32768   3      305     10111100  1     
    GigabitEthernet0/0/3   Selected 1GE      32768   4      305     10111100  1     
    GigabitEthernet0/0/4   Selected 1GE      32768   5      305     10111100  1     
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    GigabitEthernet0/0/2   32768    4c1f-ccfa-3154  32768   3      305     10111100
    GigabitEthernet0/0/3   32768    4c1f-ccfa-3154  32768   4      305     10111100
    GigabitEthernet0/0/4   32768    4c1f-ccfa-3154  32768   5      305     10111100
    
    更改负载均衡(可以指定流量走对应的链路)
    [LSW1-Eth-Trunk1]load-balance ?   //默认下有这个多模式的
      dst-ip       According to destination IP hash arithmetic
      dst-mac      According to destination MAC hash arithmetic
      src-dst-ip   According to source/destination IP hash arithmetic
      src-dst-mac  According to source/destination MAC hash arithmetic
      src-ip       According to source IP hash arithmetic
      src-mac      According to source MAC hash arithmetic
    [LSW1-Eth-Trunk1]load-balance  dst-mac     //修改为目标地Mac地址
    
    2:1备份链路
    [LSW1-Eth-Trunk1]max active-linknumber 2   //默认会依据端口的序号来进行设置哪一些是活动端口
    [LSW1-Eth-Trunk1]dis eth-trunk   
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    GigabitEthernet0/0/2   Selected 1GE      32768   3      305     10111100  1     
    GigabitEthernet0/0/3   Selected 1GE      32768   4      305     10111100  1     
    GigabitEthernet0/0/4   Unselect 1GE      32768   5      305     10100000  1     //只有端口4是unsettle状态
    
    通过修改端口号的优先级来指定哪一些端口处于备份状态
    [LSW1-Eth-Trunk1]int g0/0/2
    [LSW1-GigabitEthernet0/0/2]lacp priority 100
    [LSW1-GigabitEthernet0/0/2]int g0/0/4
    [LSW1-GigabitEthernet0/0/4]lacp priority 100
    [LSW1]int Eth-Trunk 1
    [LSW1-Eth-Trunk1]shutdown    //关闭端口来进行测试
    [LSW1-Eth-Trunk1]undo shutdown 
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    GigabitEthernet0/0/2   Selected 1GE      100     3      305     10111100  1     
    GigabitEthernet0/0/3   Unselect 1GE      32768   4      305     10111100  1     
    GigabitEthernet0/0/4   Selected 1GE      100     5      305     10100000  1   
    [LSW1]display trunkmembership eth-trunk 1   //查看详细状态
    Trunk ID: 1 
    Used status: VALID 
    TYPE: ethernet 
    Working Mode : Static 
    Number Of Ports in Trunk = 3
    Number Of Up Ports in Trunk = 2
    Operate status: up 
      
    Interface GigabitEthernet0/0/2, valid, operate up, weight=1
    Interface GigabitEthernet0/0/3, valid, operate down, weight=1
    Interface GigabitEthernet0/0/4, valid, operate up, weight=1
    
    展开全文
  • 第二步 配置链路聚合 首先配置LACP链路聚合。 手动配置链路聚合 检查链路状态 STATIC代表静态LACP模式 如果status下显示为Selected时则为正常状态,若如下图一样显示Unselect时则配置未成功。 NORMAL为手动绑定...

    第一步 搭建拓扑。

    在这里插入图片描述

    第二步 配置链路聚合

    首先配置LACP链路聚合。
    在这里插入图片描述

    在这里插入图片描述

    手动配置链路聚合
    在这里插入图片描述在这里插入图片描述
    检查链路状态在这里插入图片描述
    STATIC代表静态LACP模式
    如果status下显示为Selected时则为正常状态,若如下图一样显示Unselect时则配置未成功。
    在这里插入图片描述
    NORMAL为手动绑定的链路聚合。
    在这里插入图片描述
    在这里插入图片描述

    注:配置lacp动态链路聚合时,此链路不得有任何已捆绑的链路,如果有则如下图。
    在这里插入图片描述

    第三步 配置MSTP

    在这里插入图片描述
    进入实例生成树配置界面。
    在这里插入图片描述
    此时display之后没有显示是因为少了一条命令,

    active region-configuration

    注:之后在此界面新做配置后也需要输入此条命令来更新MSTP的配置。
    配置后:
    在这里插入图片描述
    在这里插入图片描述

    为LSW3配置边缘接口。
    在这里插入图片描述
    把stp的模式改为mstp

    LSW1:
    设置自己为实例1(instance 1)的根桥。
    设置自己为实例2(instance 2)的备份根桥。
    在这里插入图片描述
    LSW2:
    设置自己为实例2(instance 2)的根桥。
    设置自己为实例1(instance 1)的备份根桥。
    在这里插入图片描述

    第四步 配置交换机,保证全网互通

    1. 创建vlan 100 和vlan 200
    2. 把端口类型设置成truck模式
    3. 在端口上允许vlan 100 200通过

    在这里插入图片描述

    1. 退出,三台交换机(除LSW3)做相同的配置,在LSW4中配置网关。

    在这里插入图片描述

    1. 为端口划分vlan。

    在这里插入图片描述
    配置完成。

    • 检查自己做的是否符合图中所设要求。

    在这里插入图片描述
    在这里插入图片描述

    实验完成。

    MSTP排除错误指南------

    1. 没有出现阻塞端口,可以检查一下其他接口是否配置接口类型与允许通过的命令。
    2. 检查region-name与revision-level是否一致。
    3. 检查是否因为没有 active region-configuration而导致没有命令。

    谢谢观看,如有错误还请指出。

    展开全文
  • 链路聚合:手工负载分担模式 [S 1]interface Eth-Trunk 1 //创建链路聚合组Eth-Trunk接口(1-63) [S 1-Eth-Trunk1]mode manual load-balance //配置为手工负载分担模式(缺省) [S 1-Eth-Trunk1]trunkport e 0/0/A ...

    链路聚合:手工负载分担模式
    [S 1]interface Eth-Trunk 1 //创建链路聚合组Eth-Trunk接口(1-63)
    [S 1-Eth-Trunk1]mode manual load-balance //配置为手工负载分担模式(缺省)
    [S 1-Eth-Trunk1]trunkport e 0/0/A to 0/0/B //将以太网接口A到B加入Eth-Trunk接口
    [S 1-Eth-Trunk1]least active-linknumber 2 //设置活动接口下限,缺省下限=1
    [S 1-Eth-Trunk1]max bandwidth-affected-linknumber 3 //设置活动接口下限,缺省上限=8
    普通负载分担方式(6种)
    [S 1-Eth-Trunk1]load-balance src-ip dst-ip src-mac dst-mac dst-dst-mac src-dst-ip(缺省)
    [S 1-Eth-Trunk1]disply Eth-Trunk 1 //查看聚合组信息

    链路聚合:LACP模式
    [S 1-Eth-Trunk1]mode lacp-static //配置为LACP模式
    [S 1-Eth-Trunk1]trunkport e 0/0/A to 0/0/B //将以太网接口A到B加入Eth-Trunk接口
    [S 1-Eth-Trunk1]max active-linknumber X //设置活动接口上限
    [S 1-Eth-Trunk1]least active-linknumber X //设置活动接口下限
    [S 1]lacp priority 300 //设置系统优先级(缺省32768)
    [S 1-Ethernet0/0/11]lacp priority 11 //设置端口优先级 (缺省32768)
    [S 1-Eth-Trunk1]lacp preempt enable //激活抢占功能(缺省disable)
    [S 1-Eth-Trunk1]lacp preempt delay 40 //设置抢占延时(缺省30)

    STP:
    [SW]stp enable //交换机上使能STP功能
    [SW]stp mode stp //选择STP模式,默认情况下是MSTP
    [SW]stp root primary 0//配置交换机桥ID为0,默认 32768 越小越优先,必须是4096的整数倍
    [SW]display stp //查看STP信息
    [SW]display stp brief //查看STP摘要信息
    [SW]display stp interface e0/0/1 //查看接口的STP状态

    RSTP:
    [sw]stp mode rstp //选择RSTP模式
    [sw]stp priority 4096 //配置交换机优先级为4096,默认 是32768
    [SW-Ethernet0/0/X]stp cost [1-200000000] //配置端口开销值
    [SW-Ethernet0/0/X]stp edged-port enable //配置边缘端口
    [SW-Ethernet0/0/X]stp root-protection //配置根保护
    [SW]stp bpdu-protection //配置BPDU保护:
    [SW-Ethernet0/0/X]stp loop-protection // 环路保护

    MSTP:
    [SW]stp mode mstp //选择MSTP模式
    [SW]stp region mstp //进入mstp配置视图
    [SW-mst-region]region name rg1 //设置mstp域名为rg1
    [SW-mst-region]instance 1 vlan 1 to 10 //vlan1-10跟instance1做映射
    [SW-mst-region]instance 2 vlan 11 to 20 //vlan11-20跟instance2做映射
    [SW-mst-region]active region-configuration //启用配置(不配置则上面几条不生效)
    [SW]stp instance 1 primary //配置instance1优先级(0)
    [SW]stp instance 2 second //配置instance2优先级(4096)
    [SW-Ethernet0/0/X]stp instance 1 cost 2000000 //配置接口Ethernet0/0/X instance1的开销
    [SW]display stp brief //查看STP摘要信息

    MAC地址:
    [SW]display mac-address //查看MAC地址转发表
    [SW]display mac-address aging-time //查看动态MAC地址老化时间
    [SW]mac-address static vlan <1-4094> //配置静态MAC地址条目
    [SW]mac-address blackhole vlan <1-4094> //配置静态黑洞MAC地址
    [SW]mac-address aging-time <0,10-1000000> //配置动态MAC地址老化时间
    [SW-Ethernet0/0/1]mac-address learning disable //配置关闭当前端口动态学习MAC地址
    [SW-Ethernet0/0/1]mac-address learning disable action <discard/forward> //配置关闭当前端口动态学习功能并禁止/开启转发数据(默认)
    [SW-vlan1]mac-address learning disable //配置关闭当前vlan动态学习MAC地址功能
    [SW-Ethernet0/0/1]mac-limit maximum <0-4096> //配置当前端口MAC学习数量上限
    [SW-Ethernet0/0/1]mac-limit alarm <enable/disable> //配置当前端口超过MAC学习数量上限时 警告(默认)/不警告

    安全动态MAC地址 和Sticky MAC地址
    [SW-Ethernet0/0/1]port-security enable //配置端口学习到的MAC地址类型为security
    [SW-Ethernet0/0/1]port-security max-mac-num <1-4096> //配置端口可学习到的安全动态MAC地址数量(缺省1)
    [SW-Ethernet0/0/1]port-security protect-action <protect/restrict> //配置端口学到超过指定数量安全动态MAC地址后操作为丢弃/丢弃警告
    [SW-Ethernet0/0/1]port-security mac-address sticky vlan <1-4094> //配置security地址为sticky MAC地址

    防漂移:高优先级 和 同优先级 信任端口
    [SW-Ethernet0/0/1]mac-learning priority 3 // 配置端口的优先级(范围0-3 ,缺省0,值越大越优先)
    [SW]undo mac-learning priority 3 allow-flapping //SW上设置相同优先级防漂移

    DHCP
    1.全局DHCP:
    [SW]dhcp enable //启用DHCP功能
    [SW]ip pool pool_1 //配置地址池的名字为 pool_1
    [SW-ip-pool-pool_1]network x.x.x.x mask X //IP地址池的范围
    [SW-ip-pool-pool_1]gateway-list x.x.x.x //配置网关地址
    [SW-ip-pool-pool_1]dns-list x.x.x.x(more) //配置DNS池(可多个)
    [SW-ip-pool-pool_1]lease day 0 hour 0 minute 2 //配置租期
    [SW-Vlanif10]dhcp select global //在VALNIF10接口选用全局地址池分配ip地址
    [SW-ip-pool-pool_1]static-bind ip-address x.x.x.x mac-address H-H-H //地址保留
    [SW-ip-pool-pool_1]excluded-ip-address x.x.x.x //地址排除
    [SW]display current-configuration、display ip pool name pool_1 used //查看地址池使用情况
    2.端口DHCP:
    [SW]dhcp enable //启用DHCP功能
    [SW-Vlanif10]dhcp select interface //启用vlanif10接口采用接口地址池的DHCP服务功能
    [SW-Vlanif10]dhcp server dns-list x.x.x.x (MORE) //配置DNS池,可多个
    [SW-Vlanif10]dhcp server lease day 0 hour 8 //配置租期
    [SW-Vlanif10]dhcp server static-bind ip x.x.x.x mac-address H-H-H //地址保留
    [SW-Vlanif20]excluded-ip-address x.x.x.x //地址排除
    [SW]display current-configuration/ip pool interface vlanif20 used //查看地址池使用情况

    3.DHCP中继
    配置前提全网互通
    中继上(路由器)配置:
    [SW-Ethernet0/0/0]dhcp select relay //配置接口成为中继
    [SW-Ethernet0/0/0]dhcp relay server-ip x.x.x.x //配置DHCP服务器IP地址

    静态路由、缺省路由、黑洞路由:
    [Huawei]ip route-static ip地址 子网掩码 下一跳ip地址 //配置静态路由
    [Huawei]ip route-static 0.0.0.0 0 1下一条ip地址 //配置缺省路由
    [Huawei]ip route-static ip地址 子网掩码 NULL 0 //配置黑洞路由
    [Huawei]display ip routing-table //查看IP路由表
    [Huawei]display fib //查看FIB表

    RIP:
    [Huawei]rip [1~65535] //全局启动RIP
    [Huawei-rip-X]network 直连网段ip //指定网段使能RIP
    [Huawei-rip-X]version [1~2] //全局指定RIP版本
    [Huawei- Ethernet0/0/X]rip version [1~2] //接口指定RIP版本
    [Huawei-rip-X]import-route rip 20 //引入RIP进程
    [Huawei-rip-X]preference [1~255] //配置RIP优先级
    [Huawei- Ethernet0/0/X]rip metricout/metricin [1~15] //发送/接收度量值
    [Huawei- Ethernet0/0/X]rip authenticat mode simple/MD5 //rip简单认证/MD5报文认证
    [Huawei- Ethernet0/0/X]rip authenticat mode MD5 nonstandard/usual //MD5非标准/标准通用报文认证
    [Huawei- Ethernet0/0/X]rip split-horizon //激活水平分割(缺省)
    [Huawei- Ethernet0/0/X]rip poison-reverse //激活毒性反转
    [Huawei- Ethernet0/0/X]rip summary-address ip地址 子网掩码 //手动路由汇总
    [Huawei–rip-X]summary always //自动路由汇总
    [Huawei]display rip 1 interface Ethernet0/0/X verbose //查看接口RIP配置信息
    [Huawei] display rip 1 route   //查看rip路由表

    展开全文
  • eNSP链路聚合

    2020-11-02 21:24:21
    eNSP链路聚合 链路聚合简介 原理:将多个物理接口捆绑成一个逻辑接口的捆绑技术。 作用:不用提高成本增加带宽,实现线路备份/解决环路问题。 分类:静态聚合、动态LACP模式。 静态聚合和动态LACP模式的区别: 1、...
  • ensp链路聚合

    2021-04-06 17:22:39
    手工负载分担模式链路聚合配置任务 通过配置链路聚合可以达到负载分担、增加带宽、提高可靠性的目的。本节介绍手工负载分担模式链路聚合的配置与管理方法。首先介绍它的基本配置任务,也可以说是它的基本配置思路。 ...
  • 华为eNSP配置链路聚合

    千次阅读 2021-01-24 11:08:37
    链路聚合/链路捆绑/端口聚合/eth-channel。采用链路聚合技术可以在不进行硬件升级的条件下,通过将多个物理接口捆绑为一个逻辑接口,来达到增加链路带宽的目的。在实现增大带宽目的的同时,链路聚合采用备份链路的...
  • ensp-链路聚合实验

    千次阅读 2020-04-14 09:34:17
    链路聚合介绍 链路聚合特性: 虚拟技术的一种,将多个以太网链路捆绑为一条逻辑的以太网链路; 所有链路的带宽都可以充分用来转发两台设备之间的流量; 三层链路连接两台设备,可以起到节省IP地址的作用。 二层环境...
  • ENSP静态链路聚合实验配置实例

    千次阅读 2018-11-25 20:57:00
    配置要点:第一步:创建链路聚合端口:(系统模式)interface eth-trunk 1(端口号)第二步:指定聚合端口的链路类型:(聚合端口模式)port link-type trunk第三步:如果聚合链路端口是trunk类型,则需要进一步指定...

空空如也

空空如也

1 2 3 4 5 6
收藏数 119
精华内容 47
关键字:

ensp链路聚合