精华内容
下载资源
问答
  • 华为交换机-不同Vlan如何通信

    千次阅读 多人点赞 2019-08-16 13:58:37
    华为交换机-不同Vlan如何通信一、vlan的基本介绍二、两个不同vlan的通信方式1、三层交换机2、单臂路由器三、易错点新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入...

    全文脉络

    在这里插入图片描述

    一、vlan的基本介绍

    vlan,全称为“Virtual Local Area Network”,中文名为“虚拟局域网”。

    vlan的用处,简单的理解,就是将许多主机人为划分成几个队列,不仅方便管理,也加快的查询速率。

    举个例子,比如说,高三的学生一共有500人,大家乱一团,如果想要找到A,就得一个一个找。

    假如,将所有人按50 人分为20个班。你就可以先找到他们班级,再从班里找到他。

    不同vlan之间的通信,就可以理解为两个班级的人如何交流。

    二、两个不同vlan的通信方式

    1、三层交换机

    三层交换机
    配置可以分为三个步骤:

    (1)主机配置
    在这里插入图片描述
    (2)A2,A3交换机配置
     
     a,创建两个vlan,分别是vlan 10与vlan 20
     b,将连接两个pc的端口设置为access状态,划分为不同vlan
     c,将上联口g/0/0/1设置为trunk,且允许vlan 10,vlan 20 的数据通过

    sysname A2
    #
    vlan batch 10 20
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 20
    

    (3)A1配置
     a,创建两个vlan
     b,将连接两个交换机的端口设置trunk,且允许vlan 10,vlan 20 的数据通过
     c,申请两个逻辑接口vlanif ,将其设置为两个vlan的网关。

    sysname A1
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.1.254 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.254 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10  20
    

    2、单臂路由器

    在这里插入图片描述
    (1)主机配置在这里插入图片描述
    (2)A1 交换机配置
     
     a,创建vlan 10与vlan 20
     b,将连接两个pc的端口设置为access状态,划分为不同vlan
     c,将上联口g/0/0/1设置为trunk,且允许vlan 10,vlan 20 的数据通过

    sysname A1
    #
    vlan batch 10  20
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10  20
    

    (3)R1配置
     a,将连接两个交换机的端口设置trunk,且允许vlan 10,vlan 20 的数据通过
     b,在物理端口E0/0/0,先取消物理端口的IP地址,再申请两个逻辑接口vlanif ,将其设置为两个vlan的网关。

    #
    sysname R1
    #
    interface Ethernet0/0/0     /*取消物理端口的IP地址*/
     undo ip address     /*如果不设置,则两个主机无法通信*/
    #
    interface Ethernet0/0/0.10
     dot1q termination vid 10              /*可以终结含多层VLAN的数据包的最外层标签*/
     ip address 192.168.1.254 255.255.255.0
     arp broadcast enable                  /*用来使能终结子接口的ARP广播功能*/
    #
    interface Ethernet0/0/0.20
     dot1q termination vid 20
     ip address 192.168.2.254 255.255.255.0
     arp broadcast enable
    
    

    三、易错点

    (1)主机配置:IP地址,网关,子网掩码,缺一不可

    (2)经常会忘记申请vlan —>进入交换机后,首先声明vlan

    (3)设置路由器时,一定要取消物理端口的IP地址

    展开全文
  • 同一台交换机的不同vlan如何通信 我想大家都明白,一个vlan就是一个广播域。如果想让两个vlan通信就必须使用,单臂路由和三层交换。但如果只有一台2层交换机如何实现两个vlan的通信呢? 大家看一下面这个实验 ...

      前几天写了一篇关于单臂路由的文章,后面有一些关于acesstrunk转发机制的分析

    ,今天就在其基础上做一个分析。
       同一台交换机的不同vlan如何通信
       我想大家都明白,一个vlan就是一个广播域。如果想让两个vlan通信就必须使用,单臂路由和三层交换。但如果只有一台2层交换机如何实现两个vlan的通信呢?
       大家看一下面这个实验
    交换机1的接口配置如下
    Fa0/1               acess                  vlan2
    Fa0/2               acess                  vlan3
    Fa0/3               acess                  vlan2
    Fa0/4               acess                  vlan3

    我们让Fa0/1 Fa0/2各接一台PC机,利用交叉线将Fa0/3 Fa0/4互连

    拓扑如下:(由于模拟器中无法把Fa0/3 Fa0/4互连,我们利用一个Hub来实现这个功能)

    配置如下
    version 12.1

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !
    hostname Switch
    !
    !
    !
    interface FastEthernet0/1
     switchport access vlan 2
    !
    interface FastEthernet0/2
     switchport access vlan 3
    !
    interface FastEthernet0/3
     switchport access vlan 2
    !
    interface FastEthernet0/4
     switchport access vlan 3
    !
    测试我们利用PC0  ping  PC1

    我们发现是可以互通的!

    分析:

    数据流分析

    PC0 ping PC1首先把对方的IP地址和自己的子网掩码相与发现在同一网段。封装数据包发出。数据包通过Fa0/1进入交换机1,由于Fa0/1access口,进站打上TAG标记。SW1会在vlan2的广播域内进行洪泛。即数据包会从Fa0/3发出由于Fa0/3access口。即出站时会拆掉Tag标记。之后数据包又会通过Fa0/4再次进入交换机由于Fa0/4access口,进站打上TAG标记。SW1会在vlan3的广播域内进行洪泛。即数据包会从Fa0/2发出由于Fa0/2access口。即出站时会拆掉Tag标记,后PC2即可收到(返程数据流同理)

    2.accressdot1q Trunk的转发方式区别。

     Access的转发机制

    1.       数据包通过access口离开交换机是,拆除TAG标记。

    2.       交换机的access口收到不带有TAG标记的数据包时,查找接口所在vlan若交换机有该vlan则在该vlan内洪泛。

    3.       交换机若在access口收到带有TAG标记的数据包则直接丢弃。

     

    Dot1qTrunk的转发机制

    1数据包通过Trunk离开交换机时,除Native vlan不带TAG标记,其他所有数据包均带对应的TAG标记

    2如果交换机从Trunk收到带有tag标记的数据包,若该接口允许TAG标记所对应的vlan通过并且交换机上存在该vlan,则允许数据包通过,其他情况均丢弃。

    3. 如果交换机从Trunk收到不带有tag标记的数据包,若该接口允许Native vlanvlan通过并且交换机上存在Native vlan,则允许数据包通过,其他情况均丢弃。

    转载于:https://blog.51cto.com/sunpeng51/817309

    展开全文
  • 实验任务:(1) 掌握和完成设置不同vlan间通过路由器互通的方法;(2) 完成同vlan间计算机的测试。2. 实验目的:(1) 进一步熟悉交换机vlan间互通的配置方法;(2) 熟悉和掌握不同vlan间互通的测试方法。二、原理(条件)1....

    一、任务与目的

    1. 实验任务:

    (1) 掌握和完成设置不同vlan间通过路由器互通的方法;

    (2) 完成同vlan间计算机的测试。

    2. 实验目的:

    (1) 进一步熟悉交换机vlan间互通的配置方法;

    (2) 熟悉和掌握不同vlan间互通的测试方法。

    二、原理(条件)

    1.相关知识: (1) Vlan的工作原理; (2) 交换机与路由器的配置相关命令。

    2.实验条件:(1) cisco pt软件。

    三、内容与步骤

    1.实验内容:如图5,通过配置不同vlan间的计算机通过路由器互通。

    不同VLAN间通信配置结构图

    不同VLAN间通信配置结构图

    2. 测试方法(1)未配置路由前,pc1 ping pc2、pc3、p4查看结果;pc2 ping pc3、pc4 查看结果;pc3 ping pc4查看结果。

    (2)配置路由后pc1 ping pc2、pc3、p4查看结果;pc2 ping pc3、pc4 查看结果;pc3 ping pc4查看结果。

    四、数据处理(现象分析)1.实验步骤

    (1)设置不同vlan的网络地址

    (2)设置pc机的ip地址

    (3)配置路由器端口地址

    (4)在交换机上划分不同vlan

    (5)指定端口到不同vlan

    (6)设置pc机的默认网关

    2.实验代码(1)配置路由器

    Router#conf t Router(config)#int fa0/0

    Router(config-if)#ip address 210.5.11.1 255.255.255.0

    Router(config)#int fa0/1

    Router(config-if)#ip address 211.5.11.1 255.255.255.0

    Router(config-if)#no shutdown

    (2)交换机上生成vlan

    Switch# vlan database

    Switch(vlan)# vlan 20 Switch(vlan)#vlan 30

    Switch(vlan)#exit

    Switch#show vlan

    (3指定端口到不同vlan

    Switch#conf t Switch(config)#int fa0/1

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 20

    Switch(config-if)#no shutdown

    Switch(config-if)#int fa0/3

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 20

    Switch(config-if)#int fa0/10 Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 30

    Switch(config-if)#no shutdown

    Switch(config-if)#end

    3.实验结果截图

    未配置路由前

    (1)未配置路由前

    未配置路由前

    (2)配置路由后

    配置路由后

    五、结论未配置路由前对于不同网段之间无法ping通,经过配置路由端口,分成不同的网段,连在同一路由器上不同网段能够ping通。


    转载于:https://blog.51cto.com/lucifer119/1441029

    展开全文
  • 要实现vlan通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢?1、三层交换机三层交换机,本质上就是“带有路由功能的(二层)交换机”。路...

    有很多朋友反映有没有更详细、更简单的内容,这次我们用一个实例来讲解vlan的创建及组网过程,且所有的命令都有流释,我们一起来看下。在了解vlan之间,我们先来简单的了解下三层交换机。

    一、什么是三层交换机?

    要实现vlan间通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢?

    1、三层交换机

    三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的交换机才被称为“三层交换机”。

    关于三层交换机的内部结构,可以参照下面的简图。

    4b3541c21783b89215f30cb8b0182f0e.png

    在一台本体内,分别设置了交换机模块和路由器模块;而内置的路由模块与交换模块相同,使用ASIC硬件处理路由。因此,与传统的路由器相比,可以实现高速路由。

    二、三层交换机实现vlan间的相互通信

    VLAN生成后交换机是互不相通的。因此,在交换机上设置VLAN后,如果未做其他处理,VLAN间是无法通信的。

    为了使大家理解,我们用个实例来讲解三层交换机的配置,实例不同vlan间进行通信,很详细。

    实例:

    如下图,有一个公司的网络,共有4个vlan,有4个交换机(分别为S1S2S3S4),用三层交换机让不同vlan的主机能互相通信,也就是让vlan10、vlan20、vlan30、vlan40之间实现通信。

    一、拓扑图如下:

    477f5a86fff659f3dcde6ad3d7877fc0.png

    二、配置步骤如下:

    1、S1三层交换机配置:

    Switch>en--进入特权模式

    Switch#conf t--进入全局配置模式

    Switch(config)#hostname S1 --修改三层交换机主机名为S1

    S1(config)#vtp domain test --创建vtp

    Domain name already set to test.

    S1(config)#vtp mode server--设置当前交换机在vtp的工作模式为server

    Device mode already VTP SERVER.

    S1(config)#vlan 10--创建vlan 10

    S1(config-vlan)#vlan 20--创建vlan 20

    S1(config-vlan)#vlan 30--创建vlan 30

    S1(config-vlan)#vlan 40--创建vlan40

    S1(config-vlan)#interface f0/1--进入端口

    S1(config-if)#switchport mode access--将端口模式改为access模式

    S1(config-if)#switchport mode trunk --将端口模式改为trunk模式

    S1(config-if)#interface range f0/2-3 --进入端口

    S1(config-if-range)#switchport mode access--将端口模式改为access模式

    S1(config-if-range)#switchport access vlan 40--将端口划入vlan 40

    S1(config-if-range)#exit--返回上一级

    S1(config)#ip routing--启动三层交换机的路由功能

    S1(config)#interface vlan 10 --进入vlan 10

    S1(config-if)#ip address 192.168.1.254 255.255.255.0--给vlan 10添加ip地址

    S1(config-if)#interface vlan 20 --进入vlan 20

    S1(config-if)#ip address 192.168.2.254 255.255.255.0--给vlan 20添加ip地址

    S1(config-if)#interface vlan 30--进入vlan 30

    S1(config-if)#ip address 192.168.3.254 255.255.255.0--给vlan 30添加ip地址

    S1(config-if)#interface vlan 40 --进入vlan 40

    S1(config-if)#ip address 192.168.4.254 255.255.255.0--给vlan 40添加ip地址

    S1(config-if)#end--返回特权模式

    S1#copy running-config startup-config--保存配置

    [OK]--保存成功

    2、S2交换机配置

    Switch>en--进入特权模式

    Switch#conf t --进入全局配置模式

    Switch(config)#hostname S2--修改交换机名为S2

    S2(config)#vtp mode client--设置当前交换机在vtp中为客户机模式

    Device mode already VTP CLIENT.

    S2(config)#interface f0/10--进入端口

    S2(config-if)#switchport mode trunk--将端口设置为trunk模式

    S2(config-if)#interface f0/1--进入端口

    S2(config-if)#switchport mode access--将端口设置为access模式

    S2(config-if)#switchport access vlan 30--将端口划入vlan30

    S2(config-if)#interface f0/2--进入端口

    S2(config-if)#switchport mode access--将端口设置为access模式

    S2(config-if)#switchport access vlan 20--将端口划入vlan 20

    S2(config-if)#interface f0/3--进入端口

    S2(config-if)#switchport mode access --将端口设置为access模式

    S2(config-if)#switchport access vlan 10--将端口划入vlan 10

    S2(config-if)#end--返回特权模式

    S2#copy running-config startup-config--保存配置

    [OK] --保存成功

    3、S3交换机配置

    Switch>en--进入特权模式

    Switch#conf t --进入全局配置模式

    Switch(config)#hostname S3--修改交换机名为S3

    S3(config)#vtp mode client --设置当前交换机在vtp中为客户模式

    Device mode already VTP CLIENT.

    S3(config)#interface range f0/10-12--进入端口

    S3(config-if-range)#switchport mode trunk--将端口设置为trunk模式

    S3(config-if-range)#interface f0/1--进入端口

    S3(config-if)#switchport mode access--将端口设置为access模式

    S3(config-if)#switchport access vlan 30--将端口划入vlan 30

    S3(config-if)#interface f0/2 --进入端口

    S3(config-if)#switchport mode access--将端口设置为access模式

    S3(config-if)#switchport access vlan 20 --将端口划入vlan20

    S3(config-if)#interface f0/3--进入端口

    S3(config-if)#switchport mode access--将端口设置为access模式

    S3(config-if)#switchport access vlan 10--将端口划入vlan 20

    S3(config-if)#end--返回特权模式

    S3#copy running-config startup-config --保存配置

    [OK]--保存成功

    4、S4交换机配置

    Switch>en--进入特权模式

    Switch#conf t--进入全局配置模式

    Switch(config)#hostname S4--修改交换机名为S4

    S4(config)#vtp mode client--设置当前交换机在vtp中为客户模式

    S4(config)#interface f0/10--进入端口

    S4(config-if)#switchport mode trunk--将端口设置为trunk模式

    S4(config-if)#interface f0/1--进入端口

    S4(config-if)#switchport mode access--将端口设置为access模式

    S4(config-if)#switchport access vlan 30--将端口划入vlan 30

    S4(config-if)#interface f0/2--进入端口

    S4(config-if)#switchport mode access--将端口设置为access模式

    S4(config-if)#switchport access vlan 20 --将端口划入vlan 20

    S4(config-if)#interface f0/3 --进入端口

    S4(config-if)#switchport mode access--将端口设置为access模式

    S4(config-if)#switchport access vlan 10 --将端口划入vlan 10

    S4(config-if)#end --返回特权模式

    S4#copy running-config startup-config --保存配置

    [OK]--保存成功

    三、验证

    测试不同vlan下的主机是否互通。

    1、PC11PC33

    9c602ac334a4a375b0cd3b36068344ea.png

    vlan10与vlan30互通

    2、PC13PC21

    e2ee7226aac38b182d078ba20cbfe879.png

    vlan10与vlan20互通。

    展开全文
  • 步骤我们要用 S1 来实现分别处于 VLAN1 和 VLAN2 的 PC1 和 PC2 间的通信。(1) 步骤 1:在 S1 上划分 VLANS1(config)# vlan 2S1(config-vlan)# exitS1(config)# int f0/5S1(config-if)# switchport mode a...
  • 步骤我们要用 S1 来实现分别处于 VLAN1 和 VLAN2 的 PC1 和 PC2 间的通信。(1) 步骤 1:在 S1 上划分 VLANS1(config)# vlan 2S1(config-vlan)# exitS1(config)# int f0/5S1(config-if)# switchport mode a...
  • VLAN是一种将局域网设备从逻辑上划分成一个个网段,从而实现虚拟工作组的新兴数据交换技术。那么如何实现同一路由器不同vlan之间的通信?下面就详情来看看vlan配置方式了解下
  • 在工作中,我们不仅仅需要会划分VLAN,而且要保证不同VLAN之间能够正常通信。今天通过介绍两种常用的方法实现不同VLAN间进行通信。方法一:单臂路由实现不同VLAN之间互通什么是单臂路由呢?其实单臂路由就是指在...
  • 点击蓝字关注我们如何利用单臂路由进行vlan通信实验拓扑实验场景如图所示,R1通过一个三层以太网接口与S1互联。用户主机被划分到两个VLAN,部门1(PC1)和部门2(PC2)中拥有相同的上网业务,但是属于不同VLAN且位于...
  • 其实不同VLAN之间相互通信的两种方式,单臂路由、三层交换机,它们分别如何配置呢?哪一种好呢?今天我们来看下,这两种方式是如何来实现vlan间的通信。本篇文章要从三个问题开始说起?1、实现vlan间的通信有...
  • 1、相同网段 不同VLAN第一、不同VLAN就意味着不能通过二层通信,广播根本发送不过去第二、同网段就意味着路由器的两个接口要配置为同一个网段,但是这个根本就不符合路由器的配置规范,单臂路由行不通的。2、思路分析...
  • 可以借助三层交换机的三层功能,即路由转发; 例如:PC1(192.168.255.2/24)连接在GE0/0/1 PC2(192.168.254.2/24)连接在GE0/0/2   int GE0/0/1 属于vlan 2 int GE0/0/2 属于vlan 3
  • 一定要开启lacp模式后在建立eth-trunk 链路,创建后无法开启 此拓扑整体是个经典口字型拓扑,实现不同VLAN的互通,同网段通只需交换机,不同网段通信需要通过路由器转发。 PC3—PC4通信过程 PC3纯数据进入LSW3 入口...
  • 不同VLAN之间通信的原理在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信,可以采取以下3种方案之一。1.三层VLANIF接口方案这是一种通过计算机网络体系结构中第三层(网络层)来实现VLAN间通信...
  • 上次我们有发布到交换机的三种vlan划分方法详解,划分vlan不再难有多个朋友就问到弱电君关于vlan间的通信如何实现不同vlan通信互访,如果我们前面对vlan不了解的话,那么这期可以详细了解下。一、案例要求若企业...
  • 为了更好理解本文,强烈建议先阅读上一篇文章:两个vlan互通和划分到同一个vlan有何区别?本文是上一篇文章的姊妹篇。有读者会说,这还不容易啊?一根网线的两端同时插入交换机,网线的一段连VLAN 1端口(假定端口1)...
  • 如何不同vlan之间通信,我们通常提到了,vlan间通信需要三层交换机,那么不用三层交换机能不能通信呢?其实不同VLAN之间相互通信的两种方式,单臂路由、三层交换机,它们分别如何配置呢?哪一种好呢?今天我们来看...
  • VLAN(Virtual Local Area Network...本文是小编带来如何实现同一路由器不同vlan之间的通信,大家可以参考了解下!第一步,看拓扑图。先把pc上的ip都配好。开始设置switch0:>en>conf t>vlan 2>exit>i...
  • 今天和大家分享一个技术问题,是我们在IDC运维和网络管理中经常操作的内容,让不同VLAN间相互通信。 只要讨论的是:单臂路由(如下图) 创建VLAN 开关(配置)#VLAN 10 开关(config-vlan)#vlan 20 进入...
  • 一、VLAN 间路由在交换机上划分 VLAN 后,VLAN 间的计算机就无法通信了。VLAN 间的通信需要借助第...1、单臂路由处于不同 VLAN 的计算机即使它们是在同一交换机上,它们之间的通信也必须使用路由器。可以在每个 VLA...
  • 前面我们曾提到关于vlan组网及一些配置,仍然有不少的朋友问到关于交换机的配置?...要实现vlan通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢...
  • 一、企业网络实例:实现不同vlan间的通信为了安全及便于管理,企业为服务器专门划分VLAN,用户属于VLAN 10,服务器属于VLAN 20。用户与服务器间跨接入、汇聚和核心交换机,其中接入是二层交换机,汇聚、核心是三层...
  • 不同vlan之间的通信

    2021-01-16 15:08:35
    想实现不同vlan通信时,都有什么方法呢? 一、单臂路由 单臂路由是由二层交换机和路由器构成,原理是路由器重新封装MAC地址,转换Vlan标签。交换机与PC机用access,与路由器用trunk。 如图要使PC1与PC2不在相同...
  • 如何不同vlan之间通信,我们通常提到了,vlan间通信需要三层交换机,那么不用三层交换机能不能通信呢?其实不同VLAN之间相互通信的两种方式,单臂路由、三层交换机,它们分别如何配置呢?哪一种好呢?今天我们来看...
  • 交换机的VTP技术如何实现不同Vlan和网络间通信
  • 前面我们曾提到关于vlan组网,有很多朋友...要实现vlan通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢?1、三层交换机三层交换机,本质上就是“带...
  • 华为定义:华为交换机默认...PVID(端口vlan标识符):代表了指定接口连接哪个vlanaccess接口接受数据 :如果带有vlan标记的帧,先查看vlan标记是否是pvid的vlan标记,是则接受,不是则丢失,如果不带vlan标记,直...
  • 要实现vlan通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢? 1、三层交换机 三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于...
  • 三层交换技术就是二层交换技术加三层路由转发技术,传统的交换技术在数据链路层进行... 了解了三层交换技术,我们下面通过交换机的VTP技术来实现不同Vlan、网络间的通信,之所以使用VTP技术主要原因在于大大减轻了我们

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 244
精华内容 97
关键字:

不同vlan如何通信