精华内容
下载资源
问答
  • 还有一般企业都有的后勤部门和财务部门等。公司管理层组成:董事会,1个总经理,3个副总经理。3个总监。 二.需求分析 用户需求 公司网络需求主要有以下几点: (1).1层为市场部和后勤部; 2层为生产部; 3层为研发...

    一.工程概况

    公司有一栋独立大楼,高4层,每层面积2000平方米。由研发技术部(成员60人,分成硬件(25)和软件(35)2大部门)、生产部(主要产品是手持电子产品,110人,管理人员10人)和市场部(30个销售,10个工程师)组成。还有一般企业都有的后勤部门和财务部门等。公司管理层组成:董事会,1个总经理,3个副总经理。3个总监。

    二.需求分析

    用户需求

    公司网络需求主要有以下几点:

    (1).1层为市场部和后勤部;

    2层为生产部;

    3层为研发技术部;

    4层为公司内部管理人员办公室和财务部。

    (2). 各部门都有各自独立的文件服务器,且文件服务器通常不允许跨部门访问。.但管理层办公室可以访问四个部门的文件服务器。

    (3). 公司内部的计算机间采用公司内部的电子邮件系统和IM(即时通讯)系统联系。

    (4). 公司内部网络与Interner之间采用10M光纤接入。

    (5). 公司内部架设Web服务器,对Internet提供公司的形象和电子商务服务。

    (6). 财务部可以访问财务数据服务器,其他部门不能访问财务数据服务器。

    (7). 为保证安全,Internet与公司内部网络间应该采用防护措施,防止外界对内部网络未经授权的访问。

    (8). 具体要求:

    WWW服务

    E-mail、FTP服务

    集团内行政管理

    拨号上网服务

    文件服务管理系统

    数据库服务

    防火墙系统

    邮件服务

    视频会议系统

    2.稳定可靠需求

    现代企业的网络应具有更全面的可靠性设计,以实现网络通信的实时畅通,保障企业生产运营的正常进行。随着企业各种业务应用逐渐转移到计算机网络上来,网络通信的无中断运行已经成为保证企业正常生产运营的关键。现代大型企业网络在可靠性设计方面主要应从以下3个方面考虑。

    (1)、设备的可靠性设计:不仅要考察网络设备是否实现了关键部件的冗余备份,还要从网络设备整体设计架构、处理引擎种类等多方面去考察。

    (2)、业务的可靠性设计:网络设备在故障倒换过程中,是否对业务的正常运行有影响。

    (3)、链路的可靠性设计:以太网的链路安全来自于多路径选择,所以在企业网络建设时,要考虑网络设备是否能够提供有效的链路自愈手段,以及快速重路由协议的支持。

    三.网络系统设计规划

    网络设计总体要求

    灵活性:系统具有较高的适应变化的能力。当用户的物理位置发生变化时可以在非常简便的调整下重新连接;布线系统且具有一定的扩展能力。

    实用性:系统具有低成本、使用方便、简单、易扩展的特点。布线系统应在满足各种需求的情况下尽可能降低材料成本;布线系统具有操作简单、使用方便、易于扩展的特点。

    可扩展性:网络结构和系统结构模块化,易于扩充,适应未来发展。

    高可靠性:网络建设应立足于现有成熟的技术,具有高可靠性,并考虑主干设备的备份

    网络IP地址规划及VLAN划分

    企业网计划使用私有的C类IP地址。IP地址分配原则如下:集团使用IPv4地址方案。

    VLAN 号

    VLAN 名称

    IP 网段

    默认网关

    说明

    VLAN 2

    SCB

    192.168.1.0/24

    192.168.1.254

    市场部

    VLAN 3

    HQB

    192.168.2.0/24

    192.168.2.254

    后勤部

    VLAN 4

    SCB1

    192.168.3.0/24

    192.168.3.254

    生产部1

    VLAN 5

    SCB2

    192.168.4.0/24

    192.168.4.254

    生产部2

    VLAN 6

    YFBYJ

    192.168.5.0/24

    192.168.5.254

    研发部(硬件)

    VLAN 7

    YFBRJ

    192.168.6.0/24

    192.168.6.254

    研发部(软件)

    VLAN 8

    GLC

    192.168.70/24

    192.168.7.254

    管理层

    VLAN 9

    CWB

    192.168.8.0/24

    192.168.8.254

    财务部

    3.网络应用方案

    邮件服务器

    邮件服务器构成了电子邮件系统的核心。每个收信人都有一个位于某个邮件服务器上的邮箱(mailbox)。Bob的邮箱用于管理和维护已经发送给他的邮件消息。一个邮件消息的典型旅程是从发信人的用户代理开始,游经发信人的邮件服务器,中转到收信人的邮件服务器,然后投递到收信人的邮箱中。当Bob想查看自己的邮箱中的邮件消息时,存放该邮箱的邮件服务器将以他提供的用户名和口令认证他。Alice的邮件服务器还得处理Bob的邮件服务器出故障的情况。如果Alice的邮件服务器无法把邮件消息立即递送到Bob的邮件服务器,A1ice的服务器就把它们存放在消息队列(messagequeue)中,以后再尝试递送。这种尝试通常每30分钟左右执行一次:要是过了若干天仍未尝试成功,该服务器就把这个消息从消息队列中去除掉,同时以另一个邮件消息通知发信人(即Alice)。

    设备选择

    ( 1 )汇聚层采用三层交换机,选择CISCOWS-C3560G-24TS-S,功能较全面,稳定可靠,接口丰富。可以在其上配置ACL,控制各部门访问的权利。实现流量的汇聚。

    ( 2 )核心层的路由器选择CISCO2911/K9 ,内置了防火墙,但防火墙主要还是应用华为赛门铁克USG5320(4GE/AC),支持×××。优点是业务多重,智能管理,安全性高,集成多业务路由器均提供嵌入式硬件加密加速、支持语音和视频的数字信号处理器插槽、可选防火墙、***预防、呼叫处理、语音信箱以及应用程序服务。

    (3)防火墙选择华为赛门铁克USG5320(4GE/AC),网络吞吐量为2000Mbps,支持×××,可以抵御大流量的DDOS×××,甚至达到每秒数百万包以上的DDOS×××,还能提供病毒流量的识别和防范能力。防火墙应连在核心层的路由器上,作为病毒进入企业网络的第一层抵御,保护企业的网络不被破坏,数据不丢失。

    网络安全系统设计

    网络安全是指网络系统的硬件、软件及其系统中的数据受到保护,不因偶然的或者恶意的原因而遭受到破坏、更改、泄露,系统连续可靠正常地运行,网络服务不中断。本项目用采用华为赛门铁克USG5320(4GE/AC)型号的防火墙,其系列安全网关采用多核并行处理技术,最大可支持数十条线程并行处理,要性能指标在业界处于领先位置,其作为防火墙最关键的性能指标“每秒新建连接数”,达到了惊人的每秒15万条,能在短时间内为用户的网络访问建立大量的连接,提供网络的高速转发和低延迟,同时,也可以有效的应对网络中产生的大量突发流量和网络×××流量。还可以为用户提供超高的×××性能和多达20000条的×××并发隧道数。

    四.网络布线系统设计

    1.布线系统总体结构设计

    总体四层,从总部机房用十二芯单模光纤与其他四层建筑的设备间|BD|相连,每个设备间也设用十二芯多模光纤与每层的电信间|FD|,并用五类非屏蔽双绞线从电信间与工作站相连接,集团园区网采用10M的光纤以太网接入到因特网服务提供商的网络,然后接入到因特网中,使集团实现与外界的信息交换和网络通信。集团统一由总部机房的一个出口访问Internet,集团能够控制网络的安全。在服务器和核心交换机间:使用UTP电缆来将服务器连接到核心交换机。

    展开全文
  • 计算机网络课设--小型企业网络规划设计

    千次阅读 多人点赞 2021-07-13 22:16:58
    题目 网络设计规划与实现 学年学期 20Xx-20Xx学年第一学期 课程名称 计算机网络实践 院 系 XXX学院 专 业 计算机科学与技术 学 号 ...

    《计算机网络实践》报告

    题目    网络设计的规划与实现                                    

    学年学期 20Xx-20Xx学年第一学期

    课程名称   计算机网络实践                 

    院    系       XXX学院             

    专    业    计算机科学与技术           

    学    号    

    姓    名        

    指导教师          XXx

    二OXx  六月

    1 需求分析

    1.1 项目背景

    星辰公司是家中等规模企业的网络公司,公司分布情况主要有财务部、销售部、技术部、经理部四个部门。本方案主要是建设公司网络系统,总体建设目标是建设阳阳公司的内部局域网,实现公司内部网络的高速互通,各个部门利用内部网络接入Internet,以充分利用因特网上的资源。

    1.2 项目需求

    公司目前开展的企业网建设,旨在推动公司的信息化建设,其最终建设目标是将公司建设成了一个借助信息化办公和管理的高水平的智能化、数字化的企业网络,满足企业信息化的要求,为各类应用系统提供方便,快捷的信息通路,具有良好的性能,能够支持大容量和实时性的各类应用,能够可靠的运行,具有较低的故障率和维护要求。公司的网络系统是建立在高速光纤网的基础上,构建内网相互独立的网络系统,以提供安全的办公局域网和可访问Internet的网络系统。实现各部门内部和各部门之间公共网络化,构建网络信息共享,实现资源共享,为各部门提高办事效率办事透明度以及快速反应提供可靠的保障。网络系统主要是以光纤作为传输媒介、IP和Internet技术为技术主体、核心路由器为交换中心、下属部门信息网络系为分接点的多层结构、 提供与各种网络技能相关的 、功能齐全、技术先进、资源统一的网络应用系统。网络系统建设主要实现以下功能:

    1.系统主干采用百兆以太网交换,下属子网采用百兆以太网,采用 TCP/IP协议,提供标准化的高速度主干网连接,实现100Mb/s交换到桌面的网络。使用三层交换机来代替路由,实现数据的快速转发;

    2.企业网络内部资源的共享,包括文件共享,硬件共享,软件共享等;

    3.文件传输能快速地, 在不需要移动存储设备的情况下在各电脑之间进行文件的拷贝;

    4.能通过内部网络高速接入 Internet 进行工作,浏览网页查找资料;

    5.交换机采用主流、成熟和售后服务均佳的产品,具有较高的性价比。网络中使用的设备和协议应完全符合国际通用的技术标准。

    1.3 网络管理要求

     企业网络系统必需具备有完善的、安全的智能化网络管理功能,其基本需求如下:

    (1)网络设备支持基于端口的虚拟网(VLAN)划分,利用网络管理软件能动态地调整配置VLAN。使划分的各虚网之间既能相互共享所需的信息,又能分别独立运作,加强各虚网之间信息的安全性。这样易于实现网络重组并具备隔离广播风暴的能力;

    (2)具有基于端口的访问控制模式,有效防止外部或内部对某些重要信息点的访问,达到控制信息流向的目的,增强网络的安全性;

    (3)动态监控登录网络代理用户数,有效及时地防止某些非法访问;

    (4)对网络故障及时报警,并实现隔离。

    2 网络设计原则

    2.1 网络需求调研与系统设计的基本原则

    本网络主要进行路由组织、IP地址、网络安全、VLAN划分和设备具体配置等设计。企业局域网是企业网建设的基础,也是本次企业网络系统组建规划的主要工作,其他所有的建设都是建立在此基础之上的。企业信息网络系统应是一个以宽带IP网为目标,建立数据连接为一体化的内部办公网络和外部宽带。网络系统应实现虚拟局域网( VLAN)的功能,以保证全网的良好性能及网络安全性。主干网交换机应具有很高的传输速度,整个网络应具有高速的三层交换功能。主干网络应该采用成熟的、可靠的百兆以太网技术作为网络系统主干。应该选择有成功案例的网络厂商的设备, 同时为 Internet 提供接口,网络还应具有良好的扩展性。建设覆盖整个企业的局域网包括网络技术选型,拓扑结构设计,布线系统设计和网络方案的具体设计。网络方案设计中的核心、汇聚、接入层三层是其重点。其次进行VLAN划分,子网配置和 IP 地址的分配 ,最后进行服务器、交换机和路由器的配置。

    2.2 网络工程设计总体原则

    遵循《中国公众多媒体通信网技术体制》、《中国公众多媒体通信网工程实施技术要求》、以及其它国家相关标准和技术体制。采用层次化设计,网络结构的不同部分有不同的功能,使网络具有优良的结构。提供有效的安全保密措施,确保整个网络的安全。

    网络具有较强的可升级性,在将来需要时可以对网络进行必要的扩充。在增加新硬件设备时能方便地接入网络,软件上便于更新、维护、升级。尽量详细准确,减低工程的复杂程度,使系统建设和改造的工作量减至最少,以保证工程的顺利和有效完成。

    3 设计方案

    3.1 网络设备选型

    3.1.1 网络设备选择

    星辰公司使用的是在众多网络设备企业排行第一的美国Cisco公司的网络设备Cisco Packet Tracer软件 。

    3.1.2 服务器设备的选择

    服务器在企业网络中充当不可或缺的角色,公司需要发布信息、构建自己的WEB服务器,根据阳阳公司的实际情况,至少需要 2 台服务器设备,具体服务器设备如表2-1所示:

    服务器名

    数量

    FTP

    1

    WWW

    1

    表2-1 企业网络服务器要求

    WWW服务器主要功能是提供网上信息浏览服务,是访问Internet信息的主要查询工具。WEB服务器。网络间的计算机通信首先必须由DNS服务器将域名解析为对应的IP地址,同时也可以将IP地址反解析为主机域名。通过DNS服务连接Internet浏览网页可以提高公司的办事效率,企业网络中搭建DNS服务器可以解决IP地址难以记忆的问题,同时也提高网络访问速度,由此可以DNS服务器是信息网络中不可或缺的。

    3.2 网络方案拓扑设计

    在此次星辰公司网络的设计中,网络拓扑结构选用星型网络拓扑结构,星型网络拓扑结构具有安全、 可靠、易扩展等特点 ,我们采用层次化模型来设计网络拓扑结构。层次化模型有利于实现较为复杂的网络功能要求且节省成本,也可以支持较大的网络规模便于企业网的升级扩大。因公司要求网络主干具备高可靠性和可用性 ,且考虑到以后扩充和该公司的业务比较重要,为了保证数据转发的快速和可靠,核心层的设计上采用了二台三层交换机,做到设备冗余和负载均衡,就算其中某个交换机发生故障,网络也可以快速恢复,增加网络的可靠性。拓扑结构图如图3-1所示:

        

     

    图  3-2 网络拓扑图

    3.3 IP 地址规划

    绝大多数企业局域网采用 TCP/IP 协议,因此 IP 地址规划在组建企业局域网时至关重要。在企业网网络规划中,好的 IP 地址方案不仅可以减少网络负荷 ,还能为以后的网络扩展打下良好的基础。 IP 地址规划应考虑:

    唯一性——一个IP网络中不能有两台主机采用相同的IP地址;

    连续性——为同一网络区域分配连续的网络地址,缩减速路由表的表项,提高路由表的处理效率;

    可扩充性——为一个网络区域分配的IP应有一定的地址冗余, 以便于主机数量增加,保证网络的可持续发展;

    简单性——地址分配简单,避免在主干上采用复杂的掩码方式;

    安全性——公司网络内可按不同的部门划分不同的网段,以便进行管理。公司申请了一个电信公网IP:61.190.10.1/24,本设计方案的网络地址规划如表3-3、3-4所示:

    设备名称

    接口

    IP 地址

    描述

    sw1

    F0/5

    192.168.2.1/24

    3L-Switch

    sw2

    F0/5

    192.168.3.1/24

    3L-Switch

    sw2

    F0/6

    192.168.4.2/24

    3L-Switch

    R1

    F0/0

    192.168.2.2/24

    Router

    3-3 设备IP地址分配表

    部门

    IP 网段

    财务部

    192.168.5.0

    销售部

    192.168.6.0

    技术部

    192.168.7.0

    经理部

    192.168.8.0

    表 3-4 部门 IP 地址分配表

    3.4 ACL 访问控制

    通过访问列表,可以设置允许或拒绝某些数据包通过,或者允许或拒绝某些端口进行访问和使用,从而达到设置网络安全策略,防止网络中的敏感数据受到非授权访问的情况。访问控制列表控制了网络的流量,控制了用户的网络行为,控制了网络病毒的传播,在本方案中财务部启用了 ACL 访问控制,其主要目的是防止公司财务数据被窃。

    3.5 STP 生成树协议

    STP技术提供在链路冗余的同时防止网络产生环路,从而避免了广播风暴的产生,并在个别线路出现故障时能有效地切换线路从而保证通信顺畅。STP创建了一个无环树结构。协议可以保证一个网络的冗余性,在一个网络中设置冗余链路,并用生成树协议让备份链路阻塞,而一旦出现故障,启用备份链路。

    3.6 VLAN 端口划分及配置

    VLAN 号

    网段 IP

    名称

    描述

    2

    192.168.5.1/24

    cwb

    财务部

    3

    192.168.6.1/24

    xcb

    销售部

    4

    192.168.7.1/24

    jcb

    技术部

    5

    192.168.8.1/24

    jlb

    经理部

    3-5 VLAN IP 地址规划表

    4 网络设计方案设计

    4.1 设备选型原则

    1.具备较强的安全性;

    2.代表目前网络系统设备的先进水平;

    3.具备优良的可扩充性和升级能力;

    4.具有优良的性价比,根据现在需求和未来扩展需求选择设备型号,避免追

    求高档和最新技术花费巨大的代价;

    5.选择售后服务好且有一套完善的服务体系及未来在该领域的发展计划的厂商产品。

    为保证企业的信息系统的稳定性和高效运行,因此,应该采用主流的网络产品。CISCO 是网络业界第一品牌和最大的研发专家,是项目可持续应用的投资保护和规避厂家风险的首选。根据实际调查,综合考虑各家公司的发展状况、技术实力、市场占有率等各方面因素,本方案选择 CISCO 公司的网络设备,以确保网络实用与性价比。

    4.2 核心层交换机选型

    核心层为网络主干,选用三层交换机最为合适。为公司办公网络主干选用二台 CISCO WS-C6509-E 交换机作为核心交换机来连接各级交换机,对全网的数据进行高速无阻塞的交换。 CISCO WS-C6509-E 为企业级模块化交换机,具备极高的交换能力和端口密度,充分满足网络互联的需求。交换机以固定的配置存储转发的交换方式,提供了线速度快速以太网和千兆以太网连接, 并带有三层路由的引擎,可使公司网络具有很强的升级能力,大大增加了网络的传输能力、系统的实时性和系统的互动性。

    4.3 接入层设备选型

    接入层,我们经常称之为访问网。访问网主要用来支撑客户端机器对服务器的访问,主要是指接入路由器、交换机、终端访问用户。它利用多种接入技术,迅速覆盖至用户节点,将不同地理分布的用户快速有效地接入到信息网的汇聚。对上连接至汇聚层和核心层,对下实现用户的接入。为方便跨交换机的VLAN划分,优化网络性能,简化网络拓扑结构,在本设计中接入层统一使用10/100Mbps自适应的CISCO WS-2950-24普通交换机。背板带宽为8.8Gbps,包转发率为3.6Mpps,人文科技学院计算机网络技术毕业论文以存储转发的交换方式和全双工的传输模式,配备有百兆的上行链路,所有的接入层交换机组以百兆RJ-45直通双绞线交换到桌面,在网络中提供高密度的接入。用于VLAN边缘为交换机的端口间提供安全性和隔离性,同时保证语音流量从进入点通过虚拟通道直接传输到核心层设备上,而不会被定位到其它无关端口。保证了投资成本少及易于管理的要求。

    4.4 企业网服务器设备选择

    服务器是所有C/S模式网络中最核心的网络设备,在相当程度上决定了整个网络的性能。它既是网络的文件中心,同时又是网络的数据中心。星辰公司需对外发布企业商业信息网站,且WEB站点为动态网页,我为该公司的服务器选择了联想万全R525 S5405企业级机架式服务器,它是一款内存1G,CPU为Intel XeonE5405、主频2000MHZ,硬盘容量73GB,集成ATI显示芯片,16MB显存,集成Intel双千兆自适应网卡,支持网卡冗余、负载均衡等功能,可选外插Intel千兆自适应网卡的服务器。它支持 Windows server 2003 R2 Standard Edition中文版/英文版(X32)、Windows server 2003 R2 Enterprise Edition中文版/英文版 (X32)、Windows server 2003 R2 Standard Edition英文版(X64)、Windows Server2003存储增强版V2(WSS)等操作系统。且价格适中,有较高的性价比。

    4.5 出口路由设备选型

    由于大量的数据都发生在局域网内部,所以对路由器的性能要求不高,可以选用中低端路由器。因此出口路由器选用CISCO 2811模块化路由器。它是企业网络对外的出口,也可以作为企业网络的第一道防火墙。CISCO 2811模块化路由器提供了安全、可扩展的网络连接,容纳多种流量类型,如VPN等,最大DRAM内存为760MB,传输速率为10/100Mbps,支持IEEE 802.3x网络标准。内置的防火墙功能提高了局域网的安全性, 利用 CISCO 2811 网络服务还可以预防和响应网络攻击和威胁。

    5 交换机和路由器的配置

    5.1 路由器与交换机的配置

    5.1.1 路由器的配置

    路由器R1与内网的连接端口为f0/0,此端口的IP地址为192.168.2.2。s1/0为外部端口,IP地址为61.190.10.1。通过以下对路由器R1的配置完成了该校内部网络与外部Internet的通信,并使用NAT技术完成。

    Router>

    Router>en

    Router#conf t

    Router(config)#hostname R1

    R1(config)#ip nat pool router 61.190.10.1 61.190.10.1 net 255.255.255.0

    R1(config)#access-list 1 per any

    R1(config)#ip nat inside source list 1 poo router overload

    R1(config)#int fa0/0

    R1(config-if)#ip add 192.168.2.2 255.255.255.0

    R1(config-if)#ip nat inside

    R1(config-if)#no sh

    R1(config-if)#int s1/0

    R1(config-if)#ip add 61.190.10.1 255.255.255.0

    R1(config-if)#ip nat outside

    R1(config-if)#no shutdown

    R1(config-if)#exit

    R1(config)#ip route 0.0.0.0 0.0.0.0 s1/0

    R1(config)#access-list 1 deny host 192.168.5.0

    R1(config)#access-list 1 per any

    R1(config)#int fa0/0

    R1(config-if)#ip access-group 1 in

    R1(config)#end

    R1(config)#router os 100

    R1(config-router)#net 192.168.2.0 0.0.0.255 a 0

    R1#write

    Building configuration...

    [OK]

    5.1.2 核心层交换机的配置

    下面为sw1交换机的具体配置:

    启动交换机后默认进入用户模式

    Switch>                                           # 进入特权模式

    Switch>enable                                     # 进入全局模式

    Switch#configure

    Switch(config)#host SW1                          # 交换机名称配置

    SW1(config)#enable pass 123456              # 配置进入特权模式口令

    SW1(config)#int fa0/5              # 进入接口0/5并为其端口设置IP

    SW1(config-if)#no sw

    SW1(config-if)#ip add 192.168.2.1 255.255.255.0

    SW1(config-if)#no shutdown

    SW1(config-if)#exit                               # 返回全局模式

    SW1(config)#int ran fa0/3-4      # 进入3 4号端口,设置为trunk口

    SW1(config-if-range)#switchport trunk encapsulation dot1q

    SW1(config-if-range)#switchport mode trunk

    SW1#vlan database

    SW1(vlan)#vlan 2

    VLAN 2 added:

    Name: VLAN0002

    SW1(vlan)#vlan 3

    VLAN 3 added:

    Name: VLAN0003

    SW1(vlan)#vlan 4

    VLAN 4 added:

    Name: VLAN0004

    SW1(vlan)#vlan 5

    VLAN 5 added:

    Name: VLAN0005

    SW1(config-if)#int vlan 2

    SW1(config-if)#ip add 192.168.5.1 255.255.255.0

    SW1(config-if)#no shutdown

    SW1(config-if)#int vlan 3

    SW1(config-if)#ip add 192.168.6.1 255.255.255.0

    SW1(config-if)#no shutdown

    SW1(config-if)#int vlan 4

    SW1(config-if)#ip add 192.168.7.1 255.255.255.0

    SW1(config-if)#no shutdown

    SW1(config-if)#int vlan 5

    SW1(config-if)#ip add 192.168.8.1 255.255.255.0

    SW1(config-if)#no shutdown

    SW1(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2

    SW1(config)#ip routing

    SW1(config)#router ospf 100

    SW1(config-router)#network 192.168.2.0 0.0.0.255 a 0

    SW1(config-router)#network 192.168.5.0 0.0.0.255 a 0

    SW1(config-router)#network 192.168.6.0 0.0.0.255 a 0

    SW1(config-router)#network 192.168.7.0 0.0.0.255 a 0

    SW1(config-router)#network 192.168.8.0 0.0.0.255 a 0

    SW1(config)#spanning-tree vlan 1-5

    SW1(config)#spanning-tree vlan 2-3 priority 4096

    SW1(config)#line vty 0 1

    SW1(config-line)#login

    SW1(config-line)#pass 123456

    SW1(config-line)#exi

    SW1(config)#end

    SW1#wr

    下面为sw2交换机的具体配置:

    启动交换机后默认进入用户模式

    Switch(config)#host SW2

    SW2(config)#enable pass 12345

    SW2(config)#int fa0/6

    SW2(config-if)#no sw

    SW2(config-if)#int fa0/5

    SW2(config-if)#no switchport

    SW2(config-if)#ip add 192.168.4.2 255.255.255.0

    SW2(config-if)#no shutdown

    SW2(config-if)#span vlan 1-5

    SW2(config)#int fa0/6

    SW2(config-if)#no sw

    SW2(config-if)#ip add 192.168.3.1 255.255.255.0

    SW2(config-if)#no shutdown

    SW2#vlan database

    SW2(vlan)#vlan 2

    VLAN 2 added:

    Name: VLAN0002

    SW2(vlan)#vlan 3

    VLAN 3 added:

    Name: VLAN0003

    SW2(vlan)#vlan 4

    VLAN 4 added:

    Name: VLAN0004

    SW2(vlan)#vlan 5

    VLAN 5 added:

    Name: VLAN0005

    SW2(config)#int vlan 5

    SW2(config-if)#ip add 192.168.8.2 255.255.255.0

    SW2(config-if)#no shutdown

    SW2(config)#int ran fa0/3-4

    SW2(config-if-range)#sw tr en d

    SW2(config-if-range)#sw mo tr

    SW2(config-if-range)#no shutdown

    SW2(config)#ip routing

    SW2(config)#router os 100

    SW2(config-router)#net 192.168.3.0 0.0.0.255 a 0

    SW2(config-router)#net 192.168.4.0 0.0.0.255 a 0

    SW2(config-router)#net 192.168.8.0 0.0.0.255 a 0

    5.1.3 汇聚层交换机的配置

    下面是汇聚交换机 sw3 的详细配置:

    启动交换机后默认进入用户模式

    Switch>en

    Switch#conf t

    Switch(config)#host SW3

    SW3(config)#enable password 12345

    SW3(config)#exi

    SW3#vlan database

    SW3(vlan)#vlan 2

    VLAN 2 added:

    Name: VLAN0002

    SW3(vlan)#vlan 3

    VLAN 3 added:

    Name: VLAN0003

    SW3(vlan)#vlan 4

    VLAN 4 added:

    Name: VLAN0004

    SW3(vlan)#vlan 5

    VLAN 5 added:

    Name: VLAN0005

    SW3(config)#int fa0/3

    SW3(config-if)#sw acc vlan 2

    SW3(config-if)#no sh

    SW3(config-if)#int fa0/4

    SW3(config-if)#sw mo acc

    SW3(config-if)#sw acc vlan 3

    SW3(config-if)#exi

    SW3(config)#int ran fa0/1-2

    SW3(config-if-range)#sw tr en d

    SW3(config-if-range)#sw mo tr

    SW3(config-if-range)#exi

    SW3(config)#spanning-tree vlan 2-5

    SW3(config)#exi

    SW3#wr

    Building configuration...

    [OK]

    下面是汇聚交换机 sw4 的详细配置:

    启动交换机后默认进入用户模式

    Switch>en

    Switch#conf t

    Switch(config)#host SW4

    SW4(config)#enable pass 12345

    SW4(config)#exi

    SW4#vlan database

    SW4(vlan)#vlan 2

    VLAN 2 added:

    Name: VLAN0002

    SW4(vlan)#vlan 3

    VLAN 3 added:

    Name: VLAN0003

    SW4(vlan)#vlan 4

    VLAN 4 added:

    Name: VLAN0004

    SW4(vlan)#vlan 5

    VLAN 5 added:

    Name: VLAN0005

    SW4(config)#int fa0/3

    SW4(config-if)#sw acc vlan 4

    SW4(config-if)#int fa0/4

    SW4(config-if)#sw acc vlan 5

    SW4(config-if)#int ran fa0/1-2

    SW4(config-if-range)#sw mo tr

    SW4(config-if-range)#no sh

    SW4(config-if-range)#exi

    SW4(config)#spanning-tree vlan 2-5

    SW4(config)#end

    SW4#

    %SYS-5-CONFIG_I: Configured from console by console

    wr

    Building configuration...

    [OK]

    6 系统测试

    SW1路由的收敛,收到全网ospf的路由宣告条目如图6-1所示:

     

    图 6-1

    PC0机连通测试如图6-2所示:

    6-2

     

    PC1机连通测试如图6-3所示:

     

    图 6-3

    PC2机IP配置以及成功访问到域名服务器,并且能够成功解析出域名服务器中的已有条目,如图6-4所示:

     

    图 6-4

    PC3机连通测试如图6-5所示:

     

    图 6-5

    成功通过域名解析能够访问到web服务器,如图6-6所示:

     

    图 6-6

    DNS服务器配置如图6-7、6-8所:

     

    图 6-7

     

    图 6-8

    WEB服务器设置如图6-9、6-10所示:

     

    图 6-9

     

    图 6-10

    本次实验将组网所需的设备选型、拓扑结构图、IP规划、具体配置技术等必备步骤一一罗列,阐述了企业网络组建对提升企业发展空间的重要性。由于企业网功能齐全,接触面广,在网络设计规划中都非常复杂,因此在论述中也不能做到面面俱到。在设计过程中借鉴和参考了许多有关方面的资料,也通过Internet在广阔的网络平台寻找设计的题材,我感受到了网络的无穷魅力同时也发现自己掌握的网络知识是如此欠缺,在设计过程中接触了很多全新的网络知识,并通过多方面的努力把所学的知识加以应用,通过这次综合实践,丰富了我在网络方面的知识,同时也加强了我的实际操作能力和动手能力。特别在网络设计、交换机、路由器方面,我有了更加丰富的理论和实践经验。我一定在以后的学习生活中更加努力,相信有一天我能做的更好。

    考 文 献:

    [1]谢希仁 .计算机网络 (第七版 )[M]. 北京:电子工业出版社 ,2017

    [2]褚建立 .网络综合布线实用技术 [M]. 清华大学出版社 ,2002

    [3]蔡建新 .网络工程概论 [M]. 清华大学出版社 ,2002

    [4]程庆梅 .计算机网络实训教程 [M]. 高等教育出版社 ,2003

    [5]罗皇.网路组建与管理教程 [M]. 清华大学出版社 ,2004

    [6]陈义杰 .网络规划与设计 [M]. 冶金工业出版社 ,2005

    [7]陈应明 .计算机网络与应用 [M]. 冶金工业出版社 ,2005

    [8]陆魁军 .基于 Cisco 路由器和交换机 [M]. 清华大学出版社 ,2007

    展开全文
  • 任何企业都离不开无线网络,无线网络技术已经成为网工必备技能。因此,开此无线专题,暂定12篇内容,主要是普及无线基础知识及典型无线场景,不涉及具体设备配置。典型配置案例后续再开设专题分享!希望对大家有帮助...

    无线专题共12篇,本文为第十篇(点击标题跳转历史文章):

    无线专题(一):无线网络的前世今生

    无线专题(二):Wi-Fi6与5G之战

    无线专题(三):无线网络是通过空气传输数据吗?

    无线专题(四):你家Wi-Fi网速为什么这么慢?

    无线专题(五):Wi-Fi信号满格网速就一定快吗?

    无线专题(六):企业无线网络设备介绍

    无线专题(七):这些无线基础概念你绝对没听过!

    无线专题(八):企业WLAN网络典型组网架构分析

    无线专题(九):典型室内场景无线网络部署方案

    无线专题(十):企业无线网络规划设计与交付流程

    无线专题(十一):无线网络常用软件与工具

    无线专题(十二):无线网络常用优化手段

    ……

    01

    前言

    网络规划需从用户需求出发,进行容量与覆盖的设计,并选择合适的覆盖方式,确保工程的可实施性。

    为了给WLAN网络使用者有很好的用户体验,需要做好WLAN网络的规划设计,目的是通过合理的网络规划来降低WLAN网络信号覆盖盲区、WLAN信号干扰等问题的出现概率,规划AP接入合理数量的终端,保证各终端的带宽需求,提供更好的WLAN体验。

    本篇文章着重讨论WLAN无线网络规划的相关内容。

    02

    为什么需要进行无线网络规划

    如果没有进行专业的WLAN网规设计,项目交付后可能会出现以下问题:

    图片

    所以,针对用户需求,结合实际情况进行网络规划与设计,才能为提升用户体验打下坚实基础。

    03

    WLAN网络规划及交付流程

    图片

    一、WLAN网络规划设计—需求收集

    图片

    重点搜集如下信息:

    图片

    图片

    可准备需求搜集Checklist表,通过Checklist表进行用户需求搜集和记录,避免遗漏。

    • 覆盖区域详细图纸是最基本的要求。

    • 接入人数要考虑是接入的终端数量。

    • 配电方式要考虑AP的供电方式。

    • 交换机位置要考虑POE供电情况下,网线的长度不要长于80米(支持PoE++可达到200米)。

    二、WLAN网络规划设计—现场工勘

    图片

    无线工勘的价值:

    无线网络的勘测与设计是WLAN项目能够高满意度落地的前提条件,良好的勘测设计方案,其价值体现在

    • 实现无线网络最大化契合用户业务需求

    • 提高设备配比效率,保障客户投资回报率

    • 以最优化理念指导部署,降低无线网络后期维护投入

    现场工勘采集信息表:

    图片

    图片

    三、WLAN网络规划设计-信号覆盖分析

    图片

    信号覆盖设计的原则:

    图片

    所有需要满足的信号指标中,信号强度是首要指标,需要确保第一位实现。

    1、信号覆盖需求分析:覆盖区域

    图片

    2、信号覆盖需求分析:AP的布放位置

    图片

    3、信号覆盖需求分析:单AP覆盖距离及衰减参考

    图片

    4、信号覆盖需求分析:天线选型

    图片

    5、信号覆盖需求分析:选型案例

    图片

    四、WLAN网络规划设计—容量设计

    图片

    容量设计原则

    图片

    • 用户带宽,简单地可理解为终端使用某业务需要的网络带宽。

    • 不同区域用户并发、带宽要求不完全相同,设计时应针对不同场景和区域进行设计。

    1、业务分析

    图片

    2、吞吐量设计原则

    图片

    3、WLAN网规参考表

    单终端(双空间流,支持Wi-Fi5)带宽要求与支持并发终端数对照表。

    图片

    单终端(双空间流,支持Wi-Fi6)带宽要求与支持并发终端数对照表。

    图片

    4、场景化AP数量计算

    图片

    五、WLAN网络规划设计—设备选型

    图片

    设备选型参考因素

    图片

    六、WLAN网络规划设计—信道规划

    图片

    信道设计

    确认当地可用信道:

    以中国为例,网桥回传用的5G频段可选信道:149、153、157、161、165。

    不同国家或地区,可用信道不同,有些地区会预留一些信道,所以规划前必须确认清楚。

    避免同频干扰:

    多楼层同时考虑周边和上下楼AP信道错开。

    如信道实在无法错开,通常降低功率来减少重叠区域范围。

    图片

    信道规划原则

    图片

    可适当调整发射功率,避免跨区域同频干扰

    七、WLAN网络规划设计—AP布放设计

    图片

    信道规划-室内放装AP

    减少跨层干扰

    避免信道冲突

    统一规划信道

    图片

    在多楼层无线覆盖时,信道设置要着眼三维空间的考量,依然采用蜂窝式进行立体频点规划,避免空间信号干扰。

    图片

    • 尽量减少信号穿过障碍物数量。

    • 保证AP正面正对覆盖目标区域,AP布放远离干扰源。

    • 对于需PoE供电的场景,需考虑AP布放位置与弱电间(PoE供电端)的距离,该距离建议小于80m。如果是PoE++供电,该距离建议小于200 m。

    图片

    • 站点到覆盖区域之间要直接可见,不能有障碍物阻挡;

    • 站点附近避免强电强磁及其他信号的干扰;

    • 站点需要有可靠电源;

    八、WLAN网络规划设计—供电走线设计

    图片

    供电和走线设计:供电方式设计

    POE供电(推荐)

    由POE交换机负责AP的数据传输和供电:网线或光电混合缆;

    本地供电

    非POE交换机负责AP的数据传输,独立电源负责AP的供电;

    POE模块供电

    由POE适配器负责AP的数据传输和供电。

    图片

    供电和走线设计:走线设计

    走线设计原则

    • AP到POE交换机的网线长度不超过80米;

    • AP到交换机的光电混合缆长度不超过200米;

    • 网线/光电混合缆在AP点位处长度需要预留5米左右,以备后期调整;

    • 远离强电强磁;

    • 提前与用户确认,避免因物业、美观等其他原因,用户不同意施工。

    • 馈线长度越长,天线覆盖范围内的信号强度越差。请使用尽量短的馈线,不建议使用15m馈线。

    图片

    九、WLAN网络规划设计—安装方式设计

    1、室内放装AP安装方式及原则

    图片

    • 室内安装方式说明:

    吸顶安装(推荐):安装高度低于6米则使用全向天线AP,高于6米建议使用定向天线AP

    挂壁安装:不便吸顶安装时考虑;

    支架安装:是不便吸顶或挂墙情况下的临时安装方式,通常用于临时展会场景。

    2、面板AP安装方式

    图片

    • 安装方式说明:

    除了室内AP常见的吸顶和挂壁安装方式外,敏分RU还有桌面安装和面板安装两种方式。

    桌面安装直接放置于桌面上,面板安装则安装在房间内的86盒上。

    3、室外AP及天线安装方式

    图片

    04

    WLAN项目验收

    覆盖性能测试验收

    图片

    业务性能测试验收

    图片

    好了,本期关于企业无线网络规划设计就给大家分享这些,欢迎大家交流讨论!

    无线专题共12篇,本文为第十篇(点击标题跳转历史文章):

    无线专题(一):无线网络的前世今生

    无线专题(二):Wi-Fi6与5G之战

    无线专题(三):无线网络是通过空气传输数据吗?

    无线专题(四):你家Wi-Fi网速为什么这么慢?

    无线专题(五):Wi-Fi信号满格网速就一定快吗?

    无线专题(六):企业无线网络设备介绍

    无线专题(七):这些无线基础概念你绝对没听过!

    无线专题(八):企业WLAN网络典型组网架构分析

    无线专题(九):典型室内场景无线网络部署方案

    无线专题(十):企业无线网络规划设计与交付流程

    无线专题(十一):无线网络常用软件与工具

    无线专题(十二):无线网络常用优化手段

    ……

    关注我!一起提升网络技术!

    展开全文
  • VMware 虚拟化平台规划设计方案

    千次阅读 2020-12-26 14:35:01
    VMware 虚拟化平台规划设计方案 https://mp.weixin.qq.com/s?__biz=MjM5NTk0MTM1Mw==&mid=2650634298&idx=1&sn=12a014727ae3f8c695461eee5f070478&chksm=bef906bc898e8faa208ceaff0919066c546b7...

    VMware 虚拟化平台规划设计方案

    https://mp.weixin.qq.com/s?__biz=MjM5NTk0MTM1Mw==&mid=2650634298&idx=1&sn=12a014727ae3f8c695461eee5f070478&chksm=bef906bc898e8faa208ceaff0919066c546b7aaba223a11fd30249dac90bf137ac7f85c053aa&scene=21#wechat_redirect

    原创 赵海 twt企业IT社区 2018-06-16

    1 需求分析

    XX银行目前虚拟化平台为3年前建设投产的,版本为vSphere 5.5,一直没有更新。随着XX银行业务的高速发展,原有平台已经满足不了目前的应用需求,而且有些版本老旧,给运维带来很多不便。基于上述原因,现决定构建全新的虚拟化平台,采用最新的vSphere 6.0版本,并考虑到未来的业务扩展。

    现阶段规划5个分区,分别为生产业务区、管理区、网银Web区、网银App区、运维基础区。每个业务区承载着不同数量的虚拟机,并且随着业务发展不断增加。随着新业务不断增长要求,未来将逐步把小型机服务器上应用系统迁移到虚拟化平台,最终实现数据中心x86服务器的全部虚拟化。

    本方案将根据用户现有虚拟化平台的现状和物理服务器进行评估,给出新数据中心虚拟化平台的详细设计,作为以后项目实施测试和验收的依据。

     

    2 总体架构

    XX银行虚拟化平台总体架构由86台主机组成,分别为生产业务区、管理区、网银Web区、网银App区、运维基础区构成,面向正式生产业务,由一个放在运维/基础区的vCenter统一管理。

    图片
    每个业务区域之间是网络隔离的,但vCenter管理网络是相通的。

    2.1 ESXi主机配置

    2.1.1 硬件配置规格

    图片

    2.1.2 BIOS设置

    图片

    2.1.3 ESXi主机软件版本

    Name: VMware ESXi 6.0 Update 1

    2.1.4 配置NTP时间源

    ESXi使用是UTC(Universal Time/Temps Cordonn 世界标准时间)时区,而且ESXi已经不支持修改时区。如果没有NTP服务器,可以手动调整ESXi主机时间。

    安装ESXi主机后,立刻调整时间(未调整时间之前不能建立和迁移新虚拟机)。强烈建议统一配置NTP时间源,所有主机须与时间源同步。

    2.1.5 ESXi主机命名规范

    bkxx-esxi55-e<编号>

    FQDN示例:bkxx-esxi55-e01.bkxx.cn,全小写。ESXi主机与vCenter服务器名称解析,加入XX银行为此项目搭建的DNS服务器(DNS服务安装于vCenter服务器)。

     

    3 群集和资源池设计

    3.1 VMware HA群集设计原理

    至少2台以上ESXi主机组建为一个HA群集。虚拟机文件放置在由光纤存储组成的共享存储上。 ESXi主机产生故障时,虚拟机自动在群集内其他可用的ESXi主机上重新启动。VMware HA为虚拟机中的运行提供快速计划外中断恢复和具有成本效益的高可用性。

    VMware HA不需要在应用程序或虚拟机内安装任何特殊软件。HA群集中的所有虚拟机均受 VMware HA 保护。VMware HA要求虚拟机必须驻留在共享存储上。

    VMware HA代理会在ESXi主机间相互通信,并监控群集内各台ESXi主机的活跃度。默认情况下,此通信通过每秒交换一次检测信号来完成。如果15 秒过去后仍未收到检测信号,而且 ping 不到该ESXi主机,则系统会声明该ESXi主机发生故障。

    网络检测信号是确定主机状态的关键,数据存储检测信号使主机更加正确地判断管理网络不可达的状态。默认情况下,HA会选择2个数据存储心跳,这个选出的的数据存储在集群内所有的主机上有效。

    如果连接服务器的物理网络交换机支持 PortFast(或等效)设置,请将其启用。此设置可防止ESX主机在执行冗长的跨树算法期间误认为网络已被隔离。

    在虚拟化平台进入运行维护期后,如果需要执行可能会触发主机隔离响应的网络维护,建议首先禁用HA群集中的“主机监控”功能,以挂起 VMware HA。完成维护后,请重新启用“主机监控”。

    虚拟机重新启动优先级用于设定在ESX主机发生故障后虚拟机的重新启动相对顺序。这些虚拟机在新主机上按顺序重新启动,首先启动优先级最高的虚拟机,然后是那些低优先级的虚拟机。建议为提供最重要服务的虚拟机分配较高的重新启动优先级。

    3.2 集群和资源池的划分

    群集为运行的虚拟机提供一个高可用性和冗余环境。虚拟机可以在以资源池为单位的范围内负载均衡,灵活调配。

    根据数据中心网络和业务架构,每个业务区为一个独立集群,每个集群即为一个独立的资源池。生产区域共分为5个集群单元:管理区集群、业务区集群、网银Web区集群、网银App区集群和运维基础区集群,所有集群由运维基础区的vCenter统一管理调度。

    3.3 群集接入控制策略设置

    第一类 指定故障切换主机

    使用“指定故障切换主机”,在群集中空置一台ESXi主机备用,指定它做为故障切换ESXI主机。则在ESXI主机发生故障时,VMware HA 将尝试在备用ESXI主机上重新启动其虚拟机。备用ESXI主机CPU和内存配置不得低于群集内的其他ESXI主机。

    第二类 群集允许的主机故障数目

    使用“群集允许的主机故障数目” ,VMware HA 允许指定数目的ESXI主机发生故障,同时可以确保群集内留有足够的资源来对这些主机上的虚拟机进行故障切换。此类HA规则适用于虚拟机CPU和内存耗用(或保留值)较平均的场景。目前,XX银行项目中采用此种群集设置规则,设置群集允许的主机故障数目为1。

    计算插槽大小

    插槽大小由两个组件(CPU 和内存)组成。CPU 的方法是选择已启动虚拟机上的 CPU 预留最大值。无CPU 预留,则默认值 256 MHz(使用 das.vmCpuMinMHz 更改)。内存的方法是选择已启动虚拟机的内存预留,然后再选择最大值(使用 das.slotMemInMB 更改)。

    确定每台主机可以支持的最大插槽数目

    用主机的 CPU/内存资源数除以插槽大小,得出最大插槽数目,计算群集允许的主机故障数目。

    示例,下图中主机故障数目为1

    图片

    第三类 预留的群集资源的百分比

    可以将vSphere HA 配置为通过预留特定百分比的群集CPU 和内存资源来执行接入控制,用于从主机故障中进行恢复。

    使用“预留的群集资源的百分比”接入控制策略,vSphere HA 可确保预留CPU 和内存资源总量的指定百分比以用于故障切换。

    XX银行选择第二种“群集允许的主机故障数目”接入控制策略,值为“1”,即“允许1台主机出现故障”。

    注:如果vCenter不可用,它不会影响到群集的现有配置。故障切换时没有vCenter加入,HA只是依赖vCenter配置和监视群集。

    3.4 VMware DRS功能

    VMware DRS监控群集内所有主机和虚拟机的 CPU 和内存资源的分布情况和使用情况。在给出群集内资源池和虚拟机的属性、当前需求以及不平衡目标的情况下,DRS会将这些衡量指标与理想状态下的资源利用率进行比较。然后,DRS会相应地执行虚拟机迁移(或提供迁移建议)。群集中首次启动虚拟机时,DRS 将尝试通过在相应主机上放置该虚拟机或提出建议来保持适当的负载平衡。

    DRS 的自动化级别:

    手动 : 初始放置位置:显示推荐的主机。

    迁移:显示迁移建议。

    半自动:初始放置位置:自动。

    迁移:显示迁移建议。

    全自动:初始放置位置:自动。

    迁移:自动执行迁移建议。

    在目前设置下,考虑到虚拟机与驻留主机的固定配置关系,暂不启用DRS功能或者选择“手动”DRS方式。启用DRS功能,只需在群集配置中勾选启用DRS,以及配置相应规则。在正确规划和操作的情况下,DRS的配置不影响虚拟机的正常运行。

     

    4 管理中心vCenter设计

    管理软件vCenter是整个虚拟化平台管理控制的核心,考虑其考虑重要性和可管理性,我们设计把域控制器,vCenter服务器和数据库服务器分离,逻辑架构图如下:

    图片

    以上各组件说明:

    图片

    vCenter服务器采用虚拟机部署方式,部署在该运维区。建议配置如下:

    图片

    vCenter与其数据库分离,采用虚拟机形式安装。这样便于利用VMware的HA技术进行保护,而且安装后建议克隆vCenter服务器作为一个备份镜像。数据库每天使用Oracle备份工具备份vCenter数据,并在ESXi主机本地内置磁盘上保留vCenter数据库服务器的完整克隆。根据vCenter服务器所管理的ESXi主机与虚拟机的数量,估算vCenter数据库的容量如下:

    按约50台ESXi主机和200台虚拟机进行预估,vCenter数据库容量估算工具,请参考《VC Database Sizing Calculator》。

    图片

    创建数据库时,按照该容量的3倍进行数据库空间的预留,即50GB。

    4.1 安装vMA

    VMware vSphere Management Assistant (vMA) 是VMware对外提供的工具。vMA 将 vSphere 命令行界面、vSphere SDK for Perl 以及日志记录和身份验证模块打包到一个方便的捆绑包中。vMA还可以托管第三方代理,以增强管理功能。

    图片

    建议安装vMA,并凭此工具对ESXi主机进行集中管理。同时,vMA还配置成syslog日志服务器,用于管理ESXi主机的日志。由于ESXi主机发生紫屏死机,重启后log就丢失,所以推荐配置syslog服务器,把日志转储。

    从安全性考虑,不建议打开ESXi主机的SSH功能,如果需要命令行管理主机,可以使用vMA管理助手。

    4.2 用户、组、权限和角色

    定义用户、组、角色和权限能够控制哪些用户可以访问 vSphere 受管对象以及这些用户可以执行哪些具体操作。vCenter Server 授权用户是包括在 vCenter Server 引用的 Windows 域列表中的用户,或者是 vCenter Server系统上的本地 Windows 用户。

    角色是一组预定义的特权。特权定义用户执行操作和读取属性所需的个人权限。当给用户或组分配权限时,将用户或组与角色配对,并关联与清单中某一受管对象,直接与vCenter服务器中的最高层级的对象相关联。

    根据项目建设和未来运营管理的实际需要,在建设初期,按照运维管理的模式与需求,创建相关用户、组和vCenter角色,并创建若干具有管理员权限的用户。进入运营管理阶段后,则删除原具有管理员权限的用户(保留Administrator),按照既定的用户、组和vCenter角色设置,对vSphere进行操作。

    4.2.1 vCenter角色

    图片

    4.2.2 vCenter服务器域用户组

    根据角色设置,在域控服务器创建域用户组(如果使用新的用户组来管理),具体设置如下:

    图片

    4.2.3 vCenter角色与用户组关联

    在vCenter服务器最上层级(),做vCenter角色与用户组的关联。

    4.3 vSphere监控事件报警

    借助事件监控和报警系统,在vSphere、vCenter中将被配置以便监控所有核心虚拟架构的健康和性能内容,包括ESXi主机、群集、HA、虚拟机操作如VMotion和vCenter自身的健康。

    配置以下被监视事件。条件和阀值配置细节如下:

    图片

    当以上告警触发后,配置vCenter发送SNMP traps到网络管理软件;同时也将由邮件发送到相关负责人和所有vSphere企业管理组中。

    vSphere企业管理组将定期负责审查和管理这些有vCentre、ESXi主机、虚拟机产生的健康和系统日志。这些日志将为企业的保留策略和程序做准备和归档。

    SNMP 接受端得配置如下表所示:

    图片

    vCenter告警邮件转发的SMTP配置如下表所示:

    图片

     

    5 虚拟化网络设计

    XX银行虚拟化网络设计考虑了以下基本原则:

    1)物理交换机和网卡均冗余配置;

    2)充分利用分布式交换机的优点,物理网卡上均设置为Active-Active模式,有效提高带宽,负载均衡策略和故障切换策略;

    3)物理交换机连接到ESXi主机的端口设置为Trunk访问模式,允许VLAN访问。

    主机物理网卡布局示意图如下:

    图片

    每台ESXi主机共配有2片(每片有4个网口)千兆网卡,ESXi主机自带2个千兆网口,共有10个网口可用。在标准虚拟交换机中,为管理网络、VMotion端口、iSCSI存储和FT端口提供网络服务。正式部署前,管理网络和VMotion端口、iSCSI存储和FT端口都需要分配好固定IP地址。两片网卡交叉备份,一旦第一片网卡或网络链路出现故障,则自动切换到第二片网卡上运行。

    虚拟机业务网络采用分布式交换机方式,使用主机自带两个网络端口。在虚拟端口组中,这两片网卡都处于活动状态,虚拟机的业务流量按照实际物理流量规则进行负载均衡,在这两片网卡上进行转发。连接这两块网卡的物理交换机端口设置为TRUNK访问模式,允许虚拟机业务VLAN通过。

    对于生产业务区、管理区、网银Web区、网银App区的虚拟化网络规划如下图:

    图片

    管理区、生产区和网银区ESXi主机网络规划表

    图片

    注:运维基础区由于是一个集群承担运维和基础业务两种角色,并且运维和基础业务有各自的网段,其上承载的虚拟机不能互访。所以需要把FT和iSCSI的备用网卡都拿出来到分布式交换机的vm network上,保证基础业务和运维每个网段都有两张网卡可以接到各自的两台物理交换机上,保障物理设备和链路的冗余。

    虚拟交换机配置:

    图片

    分布式交换机的负载均衡选择“基于物理网卡负载的路由”

    图片

    应客户要求,如果以后网络进行万兆改造,服务器上只有两个网口,那么为了做到网络隔离,推荐下列设计:

    图片

    两个网卡一个负责虚拟机网络,另一个负责管理网络和vmkernel应用,二者互为主备。可以通过NIOC设置份额,让各个vmkernel网络按份额比例分配。

    图片

    6存储规划

    6.1 设备连接冗余设计

    存储设备的高可用性非常重要,建议连接到共享存储的每台ESX主机配备两块HBA卡,并提供两台物理光纤交换机,避免单点故障。

    图片

    ESXi主机安装后可以管理多路径,对于配备了两个控制器的存储,使用主动-主动控制器,路径选择策略可以是“固定”或“循环”策略。

    图片

    6.3 共享存储容量规划

    共享存储总共规划容量6T,由20个LUN构成,每个大小300G。根据VMware最佳实践,推荐Datastore与Lun一一对应,按照此规则各个集群数据存储容量规划方案如下:

    图片

    6.4 存储命名规范

    本地存储命名

    • 三位:ESX主机名最后三位;

    • 一位:连接符“-”;

    • 五位:固定字串“local”;

    • 一位:连接符“-”;

    • 二位:序号,从1开始。

    例子:e01-local-01

    共享存储命名

    • 群集后5位;

    • 一位:连接符“-”;

    • 五位:存储类型标识 “fc” – Fiber Channel SAN storage “iscsi” – iSCSI storage “nas” - NAS storage “vplex” - vplex storage

    • 一位:连接符“-”;

    • 二位:序号,从1开始。

    示例:cls01-fc-01

     

    7 备份规划

    vSphere Data Protection (VDP) 是一个基于磁盘的备份和恢复解决方案,可靠且易于部署。 vSphere Data Protection 与 VMware vCenter Server 完全集成,可以对备份作业执行有效的集中式管理,同时将备份存储在经过重复数据消除的目标存储中。

    7.1 vSphere Data Protection 具有优势

    1 针对所有虚拟机提供快速有效的数据保护,甚至可保护那些已关闭或在物理主机之间移动的虚拟机。

    2 在所有备份上使用智能重复数据消除,从而可极大地减少备份数据所消耗的磁盘空间。

    3 通过使用更改数据块跟踪和 VMware 虚拟机快照,降低了备份虚拟机的成本,最大程度地缩短了备份窗口。

    4 可实现轻松备份,无需在每个虚拟机上安装第三方代理。

    5 可以作为集成组件简单直接地安装到 vSphere 中,可通过 Web 门户进行管理。

    6 对 vSphere Data Protection 配置的直接访问已集成到标准的 vSphere Web Client 中。

    7 使用检查点和回滚机制保护备份。

    8 从基于 Web 的界面中,通过最终用户启动的文件级恢复 (诸多限制)提供 Windows 和 Linux 文件的简化恢复。

    7.2 vSphere Data Protection 体系结构

    vSphere Data Protection (VDP) 使用 vSphere Web Client 和 vSphere Data Protection 应用装置将备份存储到经过重复数据消除的存储中。

    vSphere Data Protection 由一组在不同计算机上运行的组件构成 (如下图所示)。

    1 vSphere

    2 vSphere Data Protection Appliance

    3 vSphere Web Client

    图片

    vSphere Data Protection 应用装置有三种选项可用:

    图片

    建议XX银行虚拟化数据中心采用2TB VDP类型。由于每个集群互不相通,所以每个集群各部署一个VDP Appliance。备份介质可以使用NAS,在网络设计部分已经建立iSCSi端口,可以通过网络进行备份。虚拟机备份保留策略为每天一备,保留7天。

    注:VDP是已虚拟机为最小单位的备份工具,对于虚拟机里面的应用和Oracle数据库不能单独备份。建议客户采用应用和Oracle的专用备份工具对其备份。对于Lan-Free备份方式,可以咨询Netapp和赛门铁克等厂商。他们针对虚拟化平台有对于的产品和解决方案可以把虚拟机备份到带库中。

     

    8 虚拟机设计

    8.1 安装和配置VMware Tools

    每台虚拟机安装好操作系统后,第一件事就是必须安装vmware tools。没有vmware tools驱动,vsphere的一些功能将使用受限。
    以下功能是仅当安装VMware Tools 时才可用的一些功能:

    • 支持Aero 的操作系统上大大提升的图形性能和Windows Aero 体验

    • 在虚拟机与主机或客户端桌面之间复制并粘贴文本、图形和文件

    • 改进的鼠标性能

    • 虚拟机中的时钟与主机或客户端桌面上的时钟同步

    • 帮助自动执行客户机操作系统操作的脚本

    安装步骤请参考VMWare知识库文档:1014294

    http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=ex&bbid=TSEBB_1267116806002&url=&stateId=1%200%20125994156&dialogID=125988560&docTypeID=DT_KB_1_1&externalId=1014294&sliceId=1&rfId=
    Installing VMware Tools in a Windows virtual machine (1018377)
    Installing VMware Tools in an Ubuntu virtual machine (1022525)
    Installing VMware Tools in a Novell virtual machine (1018299)
    Installing VMware Tools in a Linux virtual machine using RPM (1018392)
    Installing VMware Tools in a Linux virtual machine using Compiler (1018414)
    Installing VMware Tools in a Solaris virtual machine (1023956)

    8.2 虚拟机模板管理

    虚拟机模板统一放置在运维区,需要部署到其他区时候,进行虚拟机克隆,导出ovf文件形式再导入到相应区域进行部署。

    8.3 虚拟机磁盘格式选择

    虚拟磁盘有三种方式供给方式:

    • 厚置备延迟置零(Thick Provision Lazy Zeroed):以默认的厚格式创建虚拟磁盘。创建虚拟磁盘时分配虚拟磁盘所需的空间。创建过程中不会清除物理设备上保留的数据,但以后首次从虚拟机写入时则会按需置零。使用默认的平面虚拟磁盘格式,不会根除或消除恢复已删除文件或还原此已分配空间上可能存在的旧数据的可能性。无法将平面磁盘转换为精简磁盘。

    • 厚置备置零(Thick Provision Eager Zeroed):一种厚虚拟磁盘类型,可支持群集功能,如 Fault Tolerance。在创建时为虚拟磁盘分配所需的空间。与平面格式相反,创建虚拟磁盘时,会将物理设备上保留的数据置零。创建这种格式的磁盘所需的时间可能会比创建其他类型的磁盘长。

    • 精简置备(Thin Provision):使用此格式可节省存储空间。对于精简磁盘,可以根据输入的磁盘大小值置备磁盘所需的任意数据存储空间。但是,精简磁盘开始时很小,只使用与初始操作所需的大小完全相同的存储空间。注意 如果虚拟磁盘支持群集解决方案(如 Fault Tolerance),请勿将磁盘设置为精简格式。如果精简磁盘以后需要更多空间,它可以增长到其最大容量,并占据为其置备的整个数据存储空间。而且,您可以将精简磁盘手动转换为厚磁盘。

    三种方式各有利弊:

    • 若虚拟磁盘创建时间缩至最短比初始写入性能最大化更为重要,则使用厚置备延迟置零虚拟磁盘格式。

    • 若实现最大初始写入性能比虚拟磁盘创建时间缩至最短更为重要,则使用厚置备置零格式。

    建议将I/O负载较重的虚拟机分别驻留在不同的VMFS(LUN)上。

    8.4 虚拟机文件系统选择

    VMFS 数据存储是VMkernel处理磁盘的默认方式;VMkernel对磁盘分区并进行格式化,创建了VMFS文件系统的磁盘在vSphere中称为数据存 储,而且VMkernel能够读取磁盘,VMFS的优势是单个磁盘(在SAN中术语为LUN)能够承载多个虚拟机。

    有关每个LUN应该承载 多少个虚拟机,平均数应该是12(生产系统推荐8个,测试类系统可用16个)个虚拟机共享一个数据存储。一个数据存储能够承载多个虚拟机及构成虚拟机的所有文件。这些文件包括VMX文 件(该文件列出了虚拟机的硬件配置)和VMDK文件(虚拟机的硬盘以及构成虚拟机的其他零散文件)。

    使用RDM,VMkernel不会对LUN进行格式化,而是由虚拟机客户操作系统对LUN执行格式化。每个RDM是一块单独的虚拟机硬盘,而且通常只关联到单个虚拟机。RDM存储虚拟机的磁盘内容而非虚拟机文件,构成虚拟机的文件需要存放在RDM之外的数据存储上。

    图片

    部署RDM通常基于RDM能够提供更好的性能这一理念,因为其开销要比VMFS上的VMDK文件低。但是在某些情况下,RDM要比VMFS的性能还要差一些。

    关于RDM配置,请参考官方文档《vSphere 存储》第18章“裸设备映射”一节。

    注:除非软件应用有要求使用RDM,VMWare官方推荐客户使用VMFS文件系统,可用充分利用虚拟化的一切特性。

    8.5 虚拟机集群共享存储配置

    Virtual SCSI 适配器

    集群的成员虚拟机必须选择专用的SCSI适配器。参考官方文档KB1037959

    For example, if the system disk (drive C:) is attached to SCSI0:0, the first shared disk would be attached to SCSI1:0, and the data disk attached to SCSI1:1.

    The shared storage SCSI adapter for Windows Server 2008 and higher must be the LSI Logic SAS type, while earlier Windows versions must use the LSI Logic Parallel type.

    Disk configurations

    •RDM: Configurations using shared storage for Quorum and/or Data must be on Fibre Channel (FC) based RDMs (physical mode for cluster across boxes "CAB", virtual mode for cluster in a box "CIB") in vSphere 5.1 and earlier. RDMs on storage other than FC (iSCSI and FCoE) are only supported in vSphere 5.5..

    •VMFS: Virtual disks used as shared storage for clustered virtual machines must reside on VMFS datastores and must be created using the EagerZeroedThick option. This can be done using the vmkfstools command from the console, the vSphere CLI, or from the user interface. To create EagerZeroedThick storage with the vmkfstools command:

    1.Log into the console of the host or launch the VMware vSphere CLI.

    2.For example, to create a 10 GB file in datastore1 named myVMData.vmdk, run the command:

    ▪Using the console:vmkfstools –d eagerzeroedthick –c 10g /vmfs/volumes/datastore1/myVM/myVMData.vmdkNote: Replace 10g with the desired size.

    ▪Using the vSphere CLI:vmkfstools.pl –-server ESXHost –-username username --password passwd –d eagerzeroedthick –c 10g /vmfs/volumes/datastore1/myVM/myVMData.vmdk

    •To create EagerZeroedThick storage with the user interface:

    1.Using the vSphere Client, select the virtual machine for which you want to create the new virtual disk.

    2.Right-click the virtual machine and click Edit Settings.

    3.From the virtual machine properties dialog box, click Add to add new hardware.

    4.In the Add Hardware dialog box, select Hard Disk from the device list.

    5.Select Create a new virtual disk and click Next.

    6.Select the disk size you want to create.

    7.Select the datastore with the virtual machine or select a different datastore by clicking Specify a datastore and browsing to find the desired datastore.

    8.To create an EagerZeroedThick disk, select Support clustering features such as Fault Tolerance.Note: Step 8 must be the last configuration step. Changes to datastores after selecting Support clustering features such as Fault Tolerance cause it to become deselected.

    Complete the wizard to create the virtual disk.

    根据以往经验,如果数据库的大小<800G,建议使用VMFS格式,如果数据库大小>800G,可以考虑使用RDM方式。

    需要设置的共享盘:心跳盘,数据库用到的磁盘(NEC Cluster设置需要磁盘多宿主)。

    在使用NEC Cluster时候,主应用虚拟机允许迁移,但不设置回切。在主备虚拟机之间设置关联规则:互斥,避免应用双机同时迁移到同一台ESXi主机上。

    设置NEC Cluster共享盘时, 心跳磁盘大小大于200M以上即可,使用VMFS方式。

    设置集群IP时:分为Service IP(对外),public IP(管理),private IP(心跳)。Service IP与public IP在同一网段内,private IP单独规划出一个网段,做到网络隔离。

     

    本文作者:赵海,毕业于大连理工大学系统工程研究所。2007年加入IBM,任软件工程师,主要从事日本生命保险等项目的软件开发工作。2009年开始专注于日本松下电器项目的系统运维及优化工作。2011年加入惠普中国,任高级系统工程师,专注于客户案例解决及方案咨询工作。2013年加入IBM Devops Solution Team,参加云计算项目建设及部署,以及后期的咨询及解决方案提供工作。2014年加入某城商银行系统规划设计中心,任系统架构师,专注于银行数据中心解决方案规划及设计工作。

     

    相关资料:

    VMware 资料大全

     

    更多虚拟化资料,可点击阅读原文到社区“虚拟化”,有大量资料、文章、问答

     

    展开全文
  • 2009-2021网络规划设计师论文题汇总

    千次阅读 2021-11-19 20:35:26
    分类 论文题目 网络规划设计 2009-11:论电子政务专用网络的规划与设计 2010-05:论网络规划设计中的可扩展性问题 2010-05:论大中型网络的逻辑网络设计 2010-11:论校园网/企业网的网络规划设计 2010-11:论...
  • 【ENSP】校园网、企业规划设计

    千次阅读 2021-11-11 21:18:10
    文章简介:本文用华为ensp对网络进行了规划和模拟,一共分为三个区域,可以当成一个主校区,两个分校区。也可以当成一个总公司,两个分公司。可私信获取ensp项目和技术文档。 作者简介:网络工程师,希望能认识更多...
  • 《C语言程序设计网络课程建设方案《C语言程序设计》精品资源共享课程建设方案一、课程建设规划1. 总体目标以计算机软件技术专业的发展为基本依据,按照软件技术类岗位要求,结合工学结合的人才培养模式,以提高...
  • 2021年网络规划设计师论文真题

    千次阅读 2021-11-26 17:42:38
    随着5G、AI、物联网等新兴技术与企业云的广泛应用,一种新的网络技术SD-WAN(软件定义广域网络)将企业的分支、总部和企业云互联起来,在不同混合链路(MPLS、Internet、5G、LTE等)之间选择最优的链路进行传输,...
  • 本文为企业网络架构规划、实施进行详细说明。 对企业网络中涉及到的各设备中vlan划分、无线AC初始化,AP上线以及业务下发、防火墙的安全策略、服务器服务的映射以及内网之间的互访都做了相关具体介绍以及测试结果。 ...
  • 因此,完善企业信息化建设方案,需建立在数据的基础上,以先进科学技术的管理理念,通过IT信息化辅助,打造企业内部可靠、实用性强的信息化。 【关键词】信息化管理;建设方案;数据安全性 1 引言 3 1.1 研究背景及...
  • 计算机网络课程设计报告课程设计题目:组建小型企业局域网姓名 : 陈煌学号 : 201220180915专业 : 软件工程指导教师 :赵美丽2012年5月30日组建过程一 、 课程设计的目的及要求……………………………….1二、课程...
  • 4、掌握IP子网划分、网络规划的基本方法 5、熟悉组网仿真工具GNS3使用方法 6、学会使用路由器的基本配置命令 7、深入理解路由表基本结构、路由过程 8、学会静态路由、默认路由配置基本操作 9、掌握路由分析、网络...
  • (中小型企业网络设计开题报告湖 南 工 业 大 学专科毕业设计(论文)开题报告(2009届)学 院(部): 计算机与通信学院 专 业: 计算机网络技术 学 生 姓 名: 刘 班 ...
  • 一个小型企业网络方案设计&&龙腾

    千次阅读 2021-11-28 23:06:20
    一个小型企业网络方案设计 【实验目的】 ⑴ 理解不同服务的作用和工作原理; ⑵ 掌握利用 Windows 服务器实现不同网络服务的配置; ⑶ 掌握 IP 规划方法; ⑷ 掌握使用 Cisco 设备进行网络互联的配置。 【实验环境...
  • 信息系统项目管理师跟网络规划设计师都属于计算机技术与软件专业技术资格(水平)考试(即软考)中的高级资格考试。 信息系统项目管理师与网络规划设计师概念介绍 信息系统项目管理师是软考里面的一项考试,通过本考试...
  • 2001年,有关权威人士提出:数字化医院是以网络管理为基础模式,以信息为医院发展的基本功能,以信息技术为依托,增强医院的技术实力,以信息文化改变着人们的教育、工作方式和思想观念的新兴群体形态,以信息化建设...
  • 精品文档计算机网络课程设计报告课程设计题目:组建小型企业局域网姓名 : 陈煌学号 : 201220180915专业 : 软件工程指导教师 :赵美丽2012 年 5 月 30 日随意编辑精品文档组建过程一 、 课程设计的目的及要求…………...
  • 网络服务器方案计划范例目录TOC \o "1-3" \h \z \u HYPERLINK \l "_Toc231468832" 1.概述 PAGEREF _Toc231468832 \h 3HYPERLINK \l "_Toc231468833" 1.1 网络服务器应用 PAGEREF _Toc231468833 \h 3HYPERLINK \l "_...
  • 方案重新规划设计了该企业网络结构,使整个网络结构更加规范、合理;更新了核心服务器和交换机,核心层采用环形结构,使整个网络性能得到提升;详细规划设计了IP地址,增加了终端网络接口,给以后的网络扩展留下...
  • 尤其是2019年爆发的疫情,企业网络边界已经逐渐模糊 ,像以前一个机房搞定信息化的时代已经一去不返,做为企业的核心的ERP系统,SAP在该领域当属姣姣者。近几年越来越多的企业会把SAP“放心”的迁移到云上或者SAP...
  • .word 资料山东理工大学成人高等教育《计算机网络规划设计》复习题一、填空题1.常用的计算机网络系统工程设备有: 、 、 、 、 、2.交换机(Switch),工作在OSI模型中的 ,其转发信息的单位叫 。3.交换机的二层...
  • 一、概述企业网是针对企业的特殊需求而构造的高效而又经济的信息传输和事务处理系统,能满足企业高效运作的需求。企业网的建设目标是以信息技术为手段,把分布在不同地点的现有资源迅速结合成一种没有(或几乎没有)...
  • 网络规划 华为模拟器ensp 配置拓扑 应用技术
  • 基础知识 基于网络的信息系统基本结构 网络管理系统 网络应用系统 网络安全系统 网络数据库管理系统 网络软件开发工具
  • 阿里云企业上云最佳实践方案

    千次阅读 2021-03-19 17:05:59
    阿里云解决方案最佳实践,是基于众多客户上云的成功案例萃取而成的最优化企业上云指导。每个最佳实践包括使用场景、...2.企业应用(酒店PMS)上云混合云网络解决方案最佳实践 本方案主要通过阿里云CEN、SAG等产品构建混
  • 软件园区网络设计网络详细设计

    千次阅读 多人点赞 2021-08-12 16:10:57
    公司 A 搭建网络的时候,使用如上图的拓扑,很多公司部署网络的时候也是使用三层网络模型来设计的;三层网络模型一般需要配置那些协议呢?可运行DHCP 协议,可达到为 PC 主机动态分配 IP 地址;OSPF 开放式最短路径...
  • 技术架构的设计内容主要包括∶ 基础设施、技术平台、信息化标准和信息安全体系。 技术架构的设计目标包括 ∶ - 构建双活数据中心,并推进异地容灾数据中心建设;- 积极运用云技术、服务化、虚拟化等理念和技术,...
  • 一、设计内容 二、需求分析 三、方案一Cisco拓补图构建 四、方案一通信基本配置(Cisco命令) 4.1:一些常用的命令 4.2:完整基础配置命令 4.3:静态路由配置 4.4:将端口从VLAN中删除(实例) 4.5:路由器...
  • 计算机应用专业建设规划(2012年—2016年)专业建设是中职学校的一项教学基本建设,它决定着中职学校人才培养的质量与办学特色,是学校建设和发展的关键。我校计算机应用专业创始于2004年,是为适应我国信息化需要而设立...
  • BI——商业智能,一个高大上的名字,一直被很多人认为是企业信息化中的“面子工程”。什么是面子工程?“面子工程”是“形象工程”的意思,内含只做表面形象,不解决实际问题,在当今社会成为了一个贬...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 55,190
精华内容 22,076
关键字:

企业网络规划设计方案