精华内容
下载资源
问答
  • 思科模拟器上怎么配置动态路由RIP动态路由会自主选择最佳路径的,不像静态路由某个节点瘫痪了,整个网络就都瘫痪了,下面我们来看看思科模拟器上配置动态路由RIP的图文教程
  • 利用三层交换机实现rip动态路由配置。有详细的拓扑图和命令
  • 一、网络拓扑搭建 二、命令配置 命令配置都是大同小异,这里我们简单看一下和pc4连接的路由器是怎么配置的 ...R2(config)#router rip(进入rip协议配置) R2(config-router)#version 2 (启...

    一、网络拓扑搭建

    二、命令配置

    命令配置都是大同小异,这里我们简单看一下和pc4连接的路由器是怎么配置的

    最顶上的路由器

    最左边的路由器

    三、rip协议配置

    配置rip协议的时候需要申明路由器链接的所有网段,这里我一最左边的路由器为例看一下

    R2(config)#router rip(进入rip协议配置)

    R2(config-router)#version 2 (启用rip v2版本)

    R2(config-router)#no auto   (关闭路由自动汇总)

    R2(config-router)#network 192.168.12.0 (通过RIP宣告该网段)

    R2(config-router)#network 192.168.21.0

    R2(config-router)#network 192.168.23.0

    R2(config-router)#end

    同理我们也要申明剩余的两个路由器的rip协议,也就是按照R2的方法来的

    四、测试

    我们先用pc4

    最左下角的路由器

    最上边的路由器

    右下角路由器

    pc5

    展开全文
  • Cisco 动态路由协议(RIP)的配置 目录Cisco 动态路由协议(RIP)的配置1.线的连接2.Ip、封装等设置3.设置动态路由 1.线的连接 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。 需要给路由器添加...

    Cisco 动态路由协议(RIP)的配置

    1.线的连接

    在这里插入图片描述

    • 路由器间采用背对背的连接方式连接,一条DCE电缆和一条DTE电缆一组。
    • 需要给路由器添加模块,再连接。
      模块:WIC-2T
      在这里插入图片描述
      路由间的线:serial DCE(串行DCE)
      在这里插入图片描述
      注意:路由需要手动开启

    2.Ip、封装等设置

    设置ip、对s端口进行ppp封装、配置时钟速率
    Bandwidth 命令设置将接口的带宽值与高级协议交流的信息参数

    • 对三个路由器分别执行以下操作(以此类推这里仅展示其中一个路由的配置):
    Router>en
    Router#conf t
    Router(config)#hostname cisco-2621
    Cisco-2621(config)#no logg on
    Cisco-2621(config)#int fa0/0
    Cisco-2621(config-if)#ip addr 172.16.1.10 255.255.255.0
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#int s0/0
    Cisco-2621(config-if)#ip addr 172.16.12.1 255.255.255.0
    Cisco-2621(config-if)#encapsulation ppp
    Cisco-2621(config-if)#clockrate 64000
    Cisco-2621(config-if)#bandwidth 64
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#int s0/1
    Cisco-2621(config-if)#ip addr 172.16.13.1 255.255.255.0
    Cisco-26201(config-if)#encapsulation ppp
    Cisco-2621(config-if)#clockrate 64000
    Cisco-2621(config-if)#bandwidth 64
    Cisco-2621(config-if)#no shut
    Cisco-2621(config-if)#exit
    Cisco-2621(config)#exit
    Cisco-2621#wr
    
    • 需要给PC设置网关 在这里插入图片描述

    注意:IP设置时,同根线上网段是一样的。

    3.设置动态路由

    • 这样设置后,三台PC还不能互相发送信息,还需要设置动态路由(以此类推这里仅展示其中一个路由的配置):
    Cisco-2621#config t
    Cisco-2621(config)#router rip
    Cisco-2621(config-router)#version 2
    Cisco-2621(config-router)#network 172.16.1.0
    Cisco-2621(config-router)#network 172.16.12.0
    Cisco-2621(config-router)#network 172.16.13.0
    Cisco-2621(config-router)#no auto-summary
    Cisco-2621(config-router)#end
    Cisco-2620#wr
    

    这样三台PC就可以互ping了。

    展开全文
  • cisco 动态路由RIP配置

    2017-11-12 02:39:00
    动态路由RIP运用在一个较大的企业网络,在有多个路由器的时候. 动态路由就是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程. 动态路由协议分类: 距离矢量路由协议 根据跳数来...

      动态路由RIP运用在一个较大的企业网络,在有多个路由器的时候.

      动态路由就是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程.

     

      动态路由协议分类:
      距离矢量路由协议 根据跳数来选择路由 如RIP IGRP
      链路状态路由协议 根据度量值选择路由 如OSPF IS-IS

     

    RIP使用跳数作为唯一的度量值,最多的跳数为15,16跳视为不可达。

     

    配置过程:

    1. 配置pc的ip

    PC1

    wKioL1XRa1bweYGvAACSVWmu62U840.jpg

    PC2

    wKiom1XRaUzCp1JuAACf5Pfhqro180.jpg

     

    测试PC1和PC2的连接情况,发现不通

    wKioL1XRa1aT4jeTAAE7kphSzdw108.jpg

     

    router1配置RIP

    wKiom1XRaUyiSp2wAAATJhi35fQ261.jpg

    wKiom1XRaUyw6IFpAABRVPFu5sU452.jpg

     

    查看rip配置情况

    wKioL1XRa9-BU9BaAAHHrFftMhE949.jpg

     

    router2配置rip

    wKioL1XRa9_TACC8AAB7o7_kqd8306.jpg

     

    router3配置rip

    wKiom1XRadXQQ_GNAAB3efrclGw783.jpg

     

    查看路由表

    wKioL1XRa9-yJ3T8AAHOmuCakzw346.jpg

     

    PC1发现可以ping通PC2了

    wKiom1XRadWx7bEtAAEr_8wJoww098.jpg

     

    到此RIP配置完成!


    本文转自 红色的菠萝 51CTO博客,原文链接:http://blog.51cto.com/10460741/1685195


    展开全文
  • 思科高级配置(RIP动态路由配置)

    千次阅读 2019-05-15 21:21:22
    在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他路由器更新信息时又会消耗网络资源)。 然而在大型网络中,...

    问题
    在相对较小而且结构不变的网络中,静态路由是很好的解决方案,它配置简单而且不过多消耗设备资源(动态路由协议在运行时要消耗路由器内部资源,在与其他路由器更新信息时又会消耗网络资源)。
    然而在大型网络中,网络非常多,而且很有可能因为某些因素的影响,网络拓扑会有轻微变化。这时如果仍然采用静态路由就非常不方便了。
    1)通过RIP实现路由间通信
    方案
    动态路由协议配置灵活,路由器会发送自身的路由信息给其他路由器,同时也会接收其他路由器发来的路由信息建立自己的路由表。这样在路由器上就不必像静态路由那样为每个目标地址都配置路由,因为路由器可以通过协议学习这些路由。网络拓扑改变,路由信息也会自动更新,无需管理员干预。
    网络拓扑如图所示:
    在这里插入图片描述
    步骤
    实现此案例需要按照如下步骤进行。

    步骤一:VLAN以及端口配置与上面3三层交换配置路由完全一致,不再赘述配置
    
    步骤二:将上面【1.3在三层交换机上配置路由】中的静态、默认路由删除
    

    tarenasw-3L(config)#no ip route 0.0.0.0 0.0.0.0 192.168.10.1
    tarena-rouer(config)#no ip route 192.168.1.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#no ip route 192.168.2.0 255.255.255.0 192.168.10.2
    tarena-rouer(config)#no ip route 192.168.3.0 255.255.255.0 192.168.10.2

    步骤三:分别在三层交换机和路由器上配置RIP路由协议
    

    RIP路由协议在配置network时,只需要配置该路由器所直连的主类网络,不与该路由器直连的网络不需要包含在network中。
    RIP默认工作在第一版本下,但是RIP-V1是有类路由协议,而且通过广播的方式进行路由更新,无论是功能上还是效率上都有一些缺陷,这些缺陷RIP-V2可以弥补。在使用时建议采用RIP-V2而不是RIP-V1。
    tarenasw-3L(config)#router rip
    tarenasw-3L(config-router)#version 2
    tarenasw-3L(config-router)#no auto-summary
    tarenasw-3L(config-router)#network 192.168.1.0
    tarenasw-3L(config-router)#network 192.168.2.0
    tarenasw-3L(config-router)#network 192.168.3.0
    tarenasw-3L(config-router)#network 192.168.10.0
    tarena-rouer(config)#router rip
    tarena-rouer(config-router)#version 2
    tarena-rouer(config-router)#network 192.168.10.0
    tarena-rouer(config-router)#network 200.1.1.0

    步骤四:分别在三层交换机和路由器上查看路由表
    

    注意以R开头的路由,这些路由表示通过RIP协议从其他运行RIP的路由器学习过来的路由。每条路由都写明了目标网络、下一跳IP地址以及从自己哪个端口发出去。
    tarenasw-3L#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route
    Gateway of last resort is not set
    C 192.168.1.0/24 is directly connected, Vlan1
    C 192.168.2.0/24 is directly connected, Vlan2
    C 192.168.3.0/24 is directly connected, Vlan3
    C 192.168.10.0/24 is directly connected, FastEthernet0/23
    R 200.1.1.0/24 [120/1] via 192.168.10.1, 00:00:07, FastEthernet0/23
    tarena-rouer#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route
    Gateway of last resort is not set
    R 192.168.1.0/24 [120/1] via 192.168.10.2, 00:00:10, FastEthernet0/0
    R 192.168.2.0/24 [120/1] via 192.168.10.2, 00:00:10, FastEthernet0/0
    R 192.168.3.0/24 [120/1] via 192.168.10.2, 00:00:10, FastEthernet0/0
    C 192.168.10.0/24 is directly connected, FastEthernet0/0
    C 200.1.1.0/24 is directly connected, FastEthernet0/1

    步骤五:在Server上测试到三个VLAN中主机的通信
    

    SERVER>ipconfig
    FastEthernet0 Connection:(default port)
    Link-local IPv6 Address…: FE80::2E0:8FFF:FE14:BB43
    IP Address…: 200.1.1.10
    Subnet Mask…: 255.255.255.0
    Default Gateway…: 200.1.1.1
    SERVER>ping 192.168.1.10
    Pinging 192.168.1.10 with 32 bytes of data:
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.1.10: bytes=32 time=1ms TTL=126
    Ping statistics for 192.168.1.10:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    SERVER>ping 192.168.2.10
    Pinging 192.168.2.10 with 32 bytes of data:
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.2.10: bytes=32 time=0ms TTL=126
    Ping statistics for 192.168.2.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
    SERVER>ping 192.168.3.10
    Pinging 192.168.3.10 with 32 bytes of data:
    Reply from 192.168.3.10: bytes=32 time=1ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Reply from 192.168.3.10: bytes=32 time=0ms TTL=126
    Ping statistics for 192.168.3.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
    SERVER>
    31% /misc/nfsdir

    展开全文
  • Cisco路由器的rip动态路由配置

    千次阅读 2019-10-22 10:00:14
    通过配置rip路由协议,实现不同网段主机之间的通信。 三 实验环境 GNS3,Windows10操作系统,SecureCRT8.0 四 实验过程 1.对路由器R1,R2,R3,R4进行接口ip配置: R1: conf t int f0/0 ip add 192.168.20.1 255.255...
  • RIP(Routing Information Protocols,路由信息协议)是应用较早、使用较普遍的 IGP内部网管协议,使用于小型同类网络,是距离矢量协议; RIP 协议跳数作为衡量路径开销的,RIP 协议里规定最大跳数为 15;跳计数 16 则...
  • Cisco Packet Tracer 动态路由RIP配置

    千次阅读 2019-04-03 15:52:06
    Cisco Packet Tracer 动态路由RIP配置 一、拓扑图 二、PC、路由IP配置 PC0: PC1: route0配置: Router>en Router#conf t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#...
  • CISCO仿真软件Packet tracer下进行基于动态协议RIP/OSPF的路由配置,增强学生对网络概念的理解。通过实验使大家掌握常见CISCO设备的操作方法,具备独立组建简单网络的能力。
  • 动态路由RIP协议的原理及配置

    千次阅读 2019-10-21 16:21:38
    动态路由RIP协议的原理及配置 一:RIP路由协议原理 ​ RIP 路由协议是基于距离矢量算法,使用跳数(metric)来衡量到达目标地址的距离。它是一个用于路由器和主机间交换路由信息的距离向量协议。这种协议的路由器只与...
  • 思科动态路由协议RIP

    2019-09-01 16:36:53
    思科动态路由协议 规划网段(路由是隔离网段的) 配置每个节点IP地址。 R0 Router(config)#interface f0/0 Router(config-if)#no shutdown Router(config-if)#ip address 192.168.10.1 255.255.255.0 ...
  • 掌握RIP路由配置。 二.实验要点: 1)根据拓扑图进行网络布线。 2)清除启动配置并将路由器重新加载为默认状态。 3)在路由器上执行基本配置任务。 4)解释 debug ip routing 的输出。 5)配置并激活串行接口和以太网...
  • 学习目标:掌握RIP动态路由配置方法 1.动态路由的特点 ①RIP是应用较早、使用较普遍的IGP内部网管协议,使用于小型同类网络,是距离矢量协议。 ②RIP协议跳数作为衡量路径开销的,RIP协议里规定最大跳数为15。 ...
  • 2、熟练掌握rip动态路由配置过程; 3、掌握RIP动态路由的特征和功能。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置...
  • 动态路由RIP协议配置

    2018-12-07 18:50:20
    动态路由RIP协议配置 网络工程与技术课的实验报告,有需要的小伙伴可以下载
  • 思科仿真实验–RIP动态路由 实验设备 PC 2 台;Switch_3560 1 台;Router-PT 2 台;直连线;交叉线;DCE 串口线 设备配置情况 PC1 IP: 192.168.1.2 Submask: 255.255.255.0 Gateway: 192.168.1.1 PC2 IP: 192.168....
  • 南 昌大学 实验 报告 学生姓名 学 号 专业班级 实验类型 验证 综合 设计 创新 实验日期 2017/12/14 实验成 绩 实验六 动态路由协议RIP配置实训 一实验目的 深入了解RIP协议的工作原理 学会配置RIP协议网络 掌握RIP...
  • 思科动态路由配置

    千次阅读 2020-10-11 18:22:08
    1.取消静态路由配置的方法: R1取消静态路由 r1#show run r1(config)#no ip route 192.168.4.0 255.255.255.0 192.168.2.2 R2取消静态路由 r2(config)#no ip route 192.168.4.0 255.255.255.0 192.168.3.2 r2...
  • 动态路由协议RIP配置

    2021-06-02 17:54:36
    动态路由是指网络中的路由器之间相互通信,并传递路由信息,再利用收到的路由信息,更新路由表的过程。它能实时的适应网络结构的变化。如果路由更新信息表明网络发生变化,路由选择协议就会重新计算路由,并发出新的...
  • GNS3是一款优秀的具有图形化界面可以运行在多平台,那么怎么用GNS3配置RIP与OSPF路由重发布?下面脚本之家的小编带大家一起学习一下,用GNS3配置RIP与OSPF路由重发布的步骤
  • 实验5 动态路由协议RIP与OSPF的配置 实验学时2 一实验目的 1熟悉CISCO IOS和CLI命令模式的使用 2了解和掌握路由器基本配置命令的使用 3掌握动态路由协议的配置 4掌握VLAN中路由器的设置 3.掌握RIP与OSPF路由协议及其...
  • 思科五台路由rip配置Hi, today we will look for some networking stuff. Up to now, I have not written any routing-related technical post. In this article, I am gonna show you some simple dynamic routing ...
  • 传送门
  • 思科路由配置RIP协议实现多个路由的互通 作者 | 闫露坤 实验拓扑:              
  • 路由协议一般工作在OSI参考模型的传输层或者应用层,常见的路由协议有RIP、OSPF、BGP(Border Gateway Protocol,边界网关协议)等。 可路由协议:又称为被路由协议,指可以被路由器在不同逻辑网段间路由的协议。可...
  • RIP动态路由配置 目录 RIP动态路由配置 命令 RIP训练题 一、如图所示配置相应IP地址 二、配置路由器R1(宣告R1的所有网段) 三、配置路由器R2(宣告R2的所有网段) 四、在R2擦看路由表( show ip route ) ...
  • 交换机的RIP动态路由配置 实验目的: 要实现当前网络的所有计算机能相互通信,就要在两个交换机中分别各自规划3个Vlan,分别为Vlan10、Vlan20、Vlan100和Vlan30、Vlan40、Vlan100,每个Vlan设置对应网段的IP地址,...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,425
精华内容 4,170
关键字:

cisco动态路由配置rip