精华内容
下载资源
问答
  • 根据公司办公需求,设计符合实际应用的网络结构
  • 小型企业网络拓扑结构设计

    万次阅读 多人点赞 2019-01-08 16:52:39
    小型企业网络拓扑结构设计 一、设计目的 企业局域网的最终目标是建设整个单位的互联、统一、高效、实用、安全的局域网络,近期可支持上百个,远期至少可支持上午个并发用户,提供广泛的资源共享(包括硬件、软件和...

    小型企业的网络拓扑结构设计

    一、设计目的
    企业局域网的最终目标是建设整个单位的互联、统一、高效、实用、安全的局域网络,近期可支持上百个,远期至少可支持上午个并发用户,提供广泛的资源共享(包括硬件、软件和信息资源共享)。网络结构清楚、布线合理、充分考虑房间分布;局域网性能稳定、安全;软、硬件结合良好,公司日常办公需要,方便资源共享、游览有良好的兼容性和可扩展性,具备单位局域网与其他单位局域网互连,并根据具体需求实现网上视频信号传输的能力。两个办公区可以实现互相通信。
    二、设计要求
    (一)实用性:网络建设从应用实际需求出发,坚持为领导决策服务,为经营管理服务,为生产建设服务。另外,如果是对现有网络升级改造,还应该充分考虑如何利用现有资源,尽量发挥设备效益。
    (二)适度先进性:规划局域网,不但要满足用户当前的需要,还应该有一定技术前瞻性和用户需求预见性,考虑到能够满足未来几年内用户对网络功能和带 宽的需要。采用成熟的先进技术,兼顾未来的发展趋势,即量力而行,又适当超 前,留有发展余地。
    (三)安全可靠性:确保网络可靠运行,在网络的关键部分应具有容错能力,提供公共网络连接、通信链路、服务器等全方位的安全管理系统。
    (四)开放性:采用国际标准通信协议、标准操作系统、标准网管软件、采用符合标准的设备,保证整个系统具有开放特点,增强与异机种、异构网的互联能。
    (五)可扩展性:系统便于扩展,保证前期的投资的有效性与后期投资的连续性。
    (六)安全保密性:为了保证网上信息的安全和各种应用系统的安全,在规划 时就要为局域网考虑一个周全的安全保密方案。
    三、网络拓扑图

    图1拓扑图
    四、设计过程
    (一)IP地址的划分
    财务部 192.168.1.1
    销售部 192.168.2.1
    科研部 192.168.3.1
    人事部 192.168.4.1
    表1IP地址表
    (二)设计步骤及主要源代码
    1、办公区A的路由器发布rip协议
    Router (config)#inter f0/0
    Router config-if)#ip add 192.168.5.1 255.255.255.252
    Router (config-if)#no shu
    Router config-if)#interface FastEthernet1/0
    Router config-if)#interface FastEthernet1/0.2
    Router config-if)#encapsulation dot1Q 2
    Router config-if)#ip address 192.168.1.254 255.255.255.0
    Router config-if)#interface FastEthernet1/0.3
    Router config-if)#encapsulation dot1Q 3
    Router config-if)#ip address 192.168.2.254 255.255.255.0
    Router (config-if)#router rip
    Router (config-router)#net 192.168.1.0
    Router (config-router)#net 192.168.2.0
    Router (config-router)#net 192.168.5.0
    Router (config-router)#ver 2
    Router (config-router)#end

    图2办公区A路由图
    2、办公区B的路由器发布ospf协议
    Router (config)# interface FastEthernet1/0
    Router (config-if)#ip address 192.168.6.2 255.255.255.252
    Router (config)#interface FastEthernet0/0
    Router (config-if)#ip address 192.168.7.1 255.255.255.252
    Router (config-if)#no shutdown
    Router (config)#router ospf1
    Router (config-router)# network 192.168.6.0 0.0.0.255 area 0
    Router (config-router)# network 192.168.7.0 0.0.0.255 area 0 Router (config)#int se 2/0
    Router (config-if)#end

    图3办公区B路由图
    3、对sw3进行ospf的发布
    SW3(config)#inter fa 0/1
    SW3(config-if)#ip add 192.168.7.2 255.255.255.252
    SW3(config-if)#inter fa 0/2
    SW3(config-if)#ip add 192.168.3.254 255.255.255.0
    SW3(config-if)#inter fa 0/3
    SW3(config-if)#ip add 192.168.4.254 255.255.255.0
    SW3(config-if)#router ospf 1
    SW3(config-router)#net 192.168.3.0 0.0.0.255 ar 0
    SW3(config-router)#net 192.168.4.0 0.0.0.255 ar 0
    SW3(config-router)#net 192.168.7.0 0.0.0.255 ar 0

    图4 3560交换机图
    4、对中间路由r1发布ospf和rip
    Router (config)#interface FastEthernet0/0
    Router (config-if)#ip address 192.168.5.2 255.255.255.0
    Router (config)#interface FastEthernet1/0
    Router (config-if)#ip address 192.168.6.1 255.255.255.0
    Router (config)#router ospf 1
    Router (config-router)#redistribute rip subnets
    Router (config-router)#network 192.168.6.0 0.0.0.255 area 0
    r1(config)#router rip
    Router (config-router)#version 2
    Router (config-router)#redistribute ospf 1
    Router (config-router)#network 192.168.5.0

    图5 混合发布图
    五、结果实现

    图6科研部与其他部交互信息图

    图7销售部与其他部交互信息图

    图8财务部与其他部交互信息图

    图9人事部与其他部交互信息图
    六、设计结论
    通过过本次课程设计首先让我对计算机网络这一门课程的知识融入到实践设计中,对知识的掌握从理论到实践有了进一步的跨越,尤其是网络的各项协议,组成,数据传输,通信等内容,有了更深的体会. 其次,使我熟悉了各种网络服务器的配置、网络集成方案设计以及领会各种网络设备选择和方案设计要点。
    通过对这次的课程设计,让我知道了在课程设计的过程中,必须要学会查看已经设置了的东西,并注意设置时的细节,在改正时清楚自己清除或修改了哪些。总的来说,学要学精,不能似懂非懂,否则会出很多问题,很多要求完成不了,其次要有耐心以及细心。虽然有很多不足,但学无止境,只要在学习中善于总结和归纳一定可以找到最佳解决办法。一次整体网络的设计组建,使我学到的网络知识有了完整的系统结构,对网络的各个部分以及各部分之间的连接有了进一步的认识。

    不是太会发表文章,具体的图和pkt文件后面我会发表,等我会了后,谁可以教我怎么发压缩包
    下载的拓扑图在这https://download.csdn.net/download/weixin_43964548/10904300

    展开全文
  • 企业网络拓扑设计

    2019-01-08 17:00:09
    其中包含详细的网络结构设计和拓扑图PKT文件,详细的源代码。
  • 大型企业网的拓扑

    2013-10-06 13:11:51
    涵盖网络整体拓扑图和协议,可以帮助学习网络协议以及刚刚接触网络拓扑结构的同学更好的了解
  • 教程名称:华为 华三中小型企业网络架构搭建       课程目录: 【】【1.基础架构】 【】【2.无线架构部署】 【】【3.防火墙安全部署】 【】【4.统一设备管理】 【】【5....
  • 路由与交换技术综合实例 小型企业拓扑图及详细配置
  • 企业网络拓扑

    2013-01-08 17:27:22
    企业网络拓扑 packet tracer做的网络拓扑图
  • 企业计划建设自己的企业园区网络,希望通过这个新建的网络,提供一个安全、可 靠、可扩展、高效的网络环境,将两个办公地点连接到一起,使企业内能够方便快捷的实 现网络资源共享、全网接入 Internet 等目标,同时...
  • 公司网络拓扑

    2016-05-12 17:48:01
  • 中小型网络架构拓扑图,以及配置文档。

    千次阅读 多人点赞 2020-04-01 21:17:18
    AR1 u t m sys sys AR1 int g0/0/0 ip add 192.168.1.2 24 int g0/0/1 ip add 192.168.2.1 24 quit ip route-static 192.168.10.0 24 192.168.1.1 ip route-static 192.168.20.0 24 192.168.1.1 ...

    在这里插入图片描述
    AR1

    u t m
    sys
    sys AR1
    int g0/0/0 
    ip add 192.168.1.2 24
    int g0/0/1
    ip add 192.168.2.1 24
    quit
    ip route-static 192.168.10.0 24 192.168.1.1
    ip route-static 192.168.20.0 24 192.168.1.1
    ip route-static 192.168.30.0 24 192.168.1.1
    ip route-static 192.168.40.0 24 192.168.2.2
    ip route-static 192.168.50.0 24 192.168.2.2
    ip route-static 192.168.60.0 24 192.168.2.2
    ip route-static 192.168.70.0 24 192.168.2.2
    ip route-static 192.168.80.0 24 192.168.2.2
    return
    

    AR2

    u t m
    sys
    sys AR2
    int g0/0/0
    ip add 192.168.1.1 24
    int g0/0/1.1
    ip add 192.168.10.254 24
    dot1q termination vid 10
    arp broadcast enable
    int g0/0/1.2
    ip add 192.168.20.254 24
    dot1q termination vid 20
    arp broadcast enable
    int g0/0/1.3
    ip add 192.168.30.254 24
    dot1q termination vid 30
    arp broadcast enable
    quit
    ip route-static 192.168.40.0 24 192.168.1.2
    ip route-static 192.168.50.0 24 192.168.1.2
    ip route-static 192.168.60.0 24 192.168.1.2
    ip route-static 192.168.70.0 24 192.168.1.2
    ip route-static 192.168.80.0 24 192.168.1.2
    return
    

    SW2

    u t m
    sys
    sys SW2
    vlan batch 10 20 30
    int e0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int e0/0/2
    port link-type access
    port default vlan 10
    int e0/0/3
    port link-type access
    port default vlan 20
    int e0/0/4
    port link-type access
    port default vlan 30
    return
    

    SW1

    u t m
    sys
    vlan batch 2 3 40 50 60
    int vlanif 2
    ip add 192.168.2.2 24
    int vlanif 3
    ip add 192.168.3.1 24
    int vlanif 40
    ip add 192.168.40.254 24
    int vlanif 50
    ip add 192.168.50.254 24
    int vlanif 60
    ip add 192.168.60.254 24
    int g0/0/1
    port link-type access
    port default vlan 2
    int g0/0/2
    port link-type access
    port default vlan 3
    int g0/0/3
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    ip route-static 192.168.10.0 24 192.168.2.1
    ip route-static 192.168.20.0 24 192.168.2.1
    ip route-static 192.168.30.0 24 192.168.2.1
    ip route-static 192.168.70.0 24 192.168.3.2
    ip route-static 192.168.80.0 24 192.168.3.2
    return
    

    SW3

    u t m
    sys
    sys SW3
    vlan batch 40 50 60
    int e0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int e0/0/2
    port link-type access
    port default vlan 40
    int e0/0/3
    port link-type access
    port default vlan 50
    int e0/0/4
    port link-type access
    port default vlan 60
    return
    

    AR3

    sys
    sys AR3
    int g0/0/0
    ip add 192.168.3.2 24
    int g0/0/1.1
    ip add 192.168.70.254 24
    dot1q termination vid 70
    arp broadcast enable
    int g0/0/1.2
    ip add 192.168.80.254 24
    dot1q termination vid 80
    arp broadcast enable
    quit
    ip route-static 192.168.10.0 24 192.168.3.1
    ip route-static 192.168.20.0 24 192.168.3.1
    ip route-static 192.168.30.0 24 192.168.3.1
    ip route-static 192.168.40.0 24 192.168.3.1
    ip route-static 192.168.50.0 24 192.168.3.1
    ip route-static 192.168.60.0 24 192.168.3.1
    return
    

    SW4

    u t m
    sys
    sys SW4
    vlan batch 70 80
    int e0/0/1
    port link-type trunk 
    port trunk allow-pass vlan all
    int e0/0/3
    port link-type trunk 
    port trunk allow-pass vlan all
    int e0/0/2
    port link-type access
    port default vlan 70
    return
    

    SW5

    u t m
    sys
    sys SW5
    vlan batch 70 80
    int e0/0/1
    port link-type trunk 
    port trunk allow-pass vlan all
    int e0/0/2
    port link-type access
    port default vlan 80
    return
    
    展开全文
  • 企业网络拓扑图简述20200805

    千次阅读 2020-08-05 20:34:34
    下图为2020年8月5日下午课上所画的企业网络拓扑图。图右模拟场景为一中型企业,主要网络设备有pc端计算机、...图左为一小型企业网络拓扑图,由一台交换机进行接入,再使用一台路由器进行网络接入。其优点在于结构简单.
     下图为2020年8月5日下午课上所画的企业网络拓扑图。图右模拟场景为一中型企业,主要网络设备有pc端计算机、服务器、无线设备、接入层交换机、汇聚层交换机、以及核心路由器。其中企业pc端用户数百个,由三台接入层交换机接入进行数据接入,再用两台汇聚层交换机进行数据的汇聚,最后由两台核心级路由器进行快速的转发。其优点在于在其核心层以及汇聚层分别使用两台交换机和路由器,使其网络结构更加安全,冗余;缺点在于其成本较高。图左为一小型企业网络拓扑图,由一台交换机进行接入,再使用一台路由器进行网络接入。其优点在于结构简单,易维护,成本低,缺点为单点故障,安全性低。
    

    在这里插入图片描述

    展开全文
  • 企业网络拓扑

    2012-10-18 17:27:53
    这个拓扑图做得比较好,有需要的朋友下载参考。
  • 2.5网络三层结构设计 12 2.5.1核心交换机设备选型 13 2.5.2接入层交换机备选型 14 2.5.3 路由器设备选型 15 2.5.4无线路由器设备选型 16 第3章网络设备配置清单 17 3.1 PC配置 17 3.2路由器配置 19 3.3交换机配置 20...
  • 华为中小型企业网络1架构
  • 企业园区网建设的拓扑

    热门讨论 2011-12-15 14:38:14
    网络工程的企业园区网建设实验的拓扑图,这个图片比较清晰,另外一个是packet tracer产生的拓扑图文件,格式是pkt。
  • 网工必备技能:网络拓扑结构设计

    千次阅读 2019-06-20 22:14:12
    这里所指的小型星型网络是指只有一台交换机(当然也可以是集线器,但前已很少使用)的星型网络,主要应用于小型独立办公室企业和SOHO用户。这类小型网络所能连接的用户数一般在20个左右,当然也有可以连接高达40多...

    一、小型星型网络结构设计示例

    星型网络主要是以相对廉价的双绞线为传输介质的,网线的两端各用一个RJ-45水晶头为网络连接器。这里所指的小型星型网络是指只有一台交换机(当然也可以是集线器,但前已很少使用)的星型网络,主要应用于小型独立办公室企业和SOHO用户中。这类小型型网络所能连接的用户数一般在20个左右,当然也有可以连接高达40多个用户的,如48 的交换机,具体要根据交换机可用端口数而定。

    1.网络要求

    • 所有网络设备都与同一台交换机连接。
    • 整个网络没有性能瓶颈。
    • 要有一定的可扩展余地。

    2.设计思路

    (1)确定网络设备总数
    这是整个网络拓扑结构设计的基础,因为一个网络设备至少需要连接一个端口,设备数一旦确定,所需交换机的端口总数也就确定下来了。这里所指的网络设备包括工作站、服务器、网络打印机、路由器和防火墙等所有需要与交换机连接的设备。本示例的设备总数就是 20个以内工作站用户+一台服务器+一台宽带路由器+一台网络打印机=23。根据这样的计算结果,24口是最低要求,而本示例中的交换机有24个1 O/1 00Mbps端口,两个1 O/1 00/1 00Mbps 端口,一共26个端口,可以满足该网络的连接需求,但最好选择端口数更多的交换机。
    (2)确定交换机端口类型和端口数
    一般中档二层交换机都会提供两种或以上类型的端口,如本示例中的1 O/1 00Mbps和 1 O/1 00/1 00Mbps,都是采用双绞线RJ-45端口。有的还提供各种光纤接口。之所以要提供这么多不同类型的端口就是为了满足不同类型设备网络连接的带宽需求。一般来说,在网络中的服务器、边界路由器、下级交换机、网络打印机、特殊用户工作站等所需的网络带宽较高,所以通常连接在交换机的高带宽端口。如本示例中的服务器所承受的工作负荷是最重的,直接与交换机的其中一个千兆位端口连接(另一个保留用于网络扩展);其他设备的带宽需求不是很明显(宽带路由器目前的出口带宽受连接线路限制,一般在 1 0Mbps以内,所以在局域网端口方面就没必要连接高带宽端口了,其他企业级路由器就不一样了),只需连接在普通的1 O/1 00Mbps快速自适应端口即可。
    (3)保留一定的网络扩展所需端口
    交换机的网络扩展主要体现在两个方面:一是用于与下级交换机连接的端口,另一个是用于连接后续添加的工作站用户。与下级交换机连接方面,一般是通过高带宽端口进行的,毕竟下级交换机所连用户都是通过这个端口进行的。如果交换机提供了Uplink(级联)端口,则直接用这个端口即可,因为它本身就是一个经过特殊处理的端口,其可利用的背板带宽比一般的端口宽。但如果没有级联端口,则只能通过普通端口进行了,这时为了确保下级交换机所连用户的连接性能,最好选择一个较高带宽的端口。本示例中可以留下一个干兆位端口用于扩展连接,当然在实际工作中,这个高带宽端口还是可以得到充分利用的,只是到需要时能重新空余下来即可。
    (4)确定可连接工作站总数
    交换机端口总数不等于可连接的工作站用户数,因为交换机中的一些端口还要用来连接那些不是工作站的网络设备,如服务器、下级交换机、网络打印机、路由器、网关、网桥等。如本示例中,网络中有一台专门的服务器、一台宽带路由器和一台网络打印机,所以网络中可连接的工作站用户总数就为26(24个1 O/1 00Mbps端口+2个1 O/1 00/1 00Mbps端口)一3=23 个。如果要保留一个端口用于网络扩展(在小型网络中保留一个扩展端口基本上可以满足,因为在一般的交换机上还有一个用于级联下级交换机的级联端口Uplink),则实际上可连接的最多工作站用户数为22个。

    3.设计步骤

    在明白了网络拓扑结构设计基本思路后,接下来的具体设计步骤就非常明朗了。在本示例中,网络用户和交换机规格都已定下来了,现在要做的就是根据这些已有条件设计一个实用的小型办公室网络方案。在此所介绍的方法仍是手工绘制法。具体步骤如下。
    (1)首先确定关键设备连接,把需要连接在高带宽端口的设备连接在交换机的可用高带宽端口上。如本示例中,把交换机图示(从自己积累的元素图中获取,或者通过专门的拓扑结构软件获得)放在设计的平台中心位置,然后把服务器与交换机连接的一个1 O/1 00/1 000Mbps 端口连接起来,并标注其端口类型,如图3—3 8所示。当然这要求服务器的以太网网卡也是支持双绞线千兆位以太网标准的。因为该交换机只有一个可用(另一个要用于保留)的千兆位端口,所以在此理论上仅需把最关键的网络服务器作为关键设备与高带宽端口连接即可。
    服务器与交换机千兆位端

    (2)把所有工作站用户计算机设备和网络打印机分别与交换机的10/100Mbps端口连接,如图3—39所示。

    在这里插入图片描述

    (3)如果网络系统要通过路由器与其他网络连接(如本例中通过宽带路由器与因特网连接),则还需要设计因特网连接。路由器与外部网络连接是通过路由器的WAN端口进行的。虽然路由器的WAN端口类型有多种,但宽带路由器提供的WAN端口基本上也都是普通的 RJ-45 1 0/1 00Mbps以太网端口,直接与因特网宽带设备即可,如图3-40所示。如属小区光纤以太网连接,则无须宽带设备。
    在这里插入图片描述

    通过以上简单的3个步骤就把这个只有一台交换机设备的简单小型办公室星型网络结构设计好了。从这里可以看出,整个步骤非常简单,最关键的是要思路清晰,分门别类地把有不同带宽需求的设备连接在交换机的对应类型端口上,确保整个网络不会出现性能瓶颈。另外一个,就在选择交换机时,一定要注意,端口数一定要大于现有网络所有需要与交换机连接的网络设备总数,因为还要预留一定数量的端口用于将来扩展。

    二、中型扩展星型网络结构设计示例

    中型扩展星型网络是指在整个网络中包括多个交换机,而且各交换机是通过级联方式的分层结构。在中型,或以上的星型网络中,一般有“边缘层”(也有称“接入层”)“会聚层”和“核心层”3个层次。在各层中的每一台交换机又各自形成一个相对独立的星型网络结构。这主要应用于在同一楼层的中小型企业网络中。在这种网络中通常会有一个单独的机房,集中摆放所有关键设备,如服务器、管理控制台、核心或骨干层交换机、路由器、防火墙、UPS等。

    1.网络要求

    • 核心交换机能提供负载均衡和冗余配置。
    • 所有设备都必须连接在网络上,且使各服务器负载均衡,整个网络无性能瓶颈。
    • 各设备所连交换机要适当,不要出现超过双绞线网段距离的1 OO米限制。
    • 结构图中可清晰知道各主要设备所连端口类型和传输介质。

    2.设计思路

    这种扩展型星型网络比起前面介绍的小型星型网络要复杂得多,在其中涉及到的网络技术也复杂许多。下面是设计这类网络结构的基本思路。

    1. 采用白上而下的分层结构设计
      首先确定的是核心交换机的连接,然后是会聚层交换机的连接。再次是边缘层的交换机连接。
    2. 把关键设备冗余连接在两台核心交换机上
      要实现核心交换机负载均衡和冗余配置,最好对核心交换机之问、核心交换机与骨干层 交换机之间,以及核心交换机与关键设备之间进行均衡和冗余连接和配置。
    3. 连接其他网络设备
      把关键用户的工作站和大负荷网络打印机等设备连接在核心交换机,或者会聚层交换机 的普通端口上;把工作负荷相对较小的普通工作站用户连接在边缘交换机上。

    3.设计步骤

    以下的设计步骤也是根据以上基本设计思路进行展开的。

    (1)确定核心交换机位置及主要设备连接

    本示例中两台核心交换机是通过SC光纤端口进行负载均衡和冗余连接的,所以首先把两台交换机的SC端口用一条光纤电缆连接起来。然后再把与核心交换机连接的服务器通过两块双绞线千兆位网卡与两台核心交换机进行冗余连接。本示例的连接如图3—41所示。
    在这里插入图片描述

    (2)缴联F级会聚层交换机
    通过普通双绞线,连接核心交换机与会聚层交换机的千兆位端口,以实现扩展级联。当然,为了实现冗余连接,会聚层的每台交换机都要与每台核心交换机分别连接。因为本示例中核心交换机和会聚层交换机都有足够的RJ一45千兆位端口,可以满足冗余连接要求。然后把其他要与核心交换机连接的网络设备连接起来,如管理控制台、一些特殊应用工作站、负荷较重的网络打印机等。但要注意至少每台交换机要留有两个以上备用端口。本示例连接如图3.42所示。

    在这里插入图片描述

    (3)级联边缘层交换机
    通过普通的双绞线把边缘层交换机与会聚层交换机的1 O/1 OOMbps端口(因为已没有千兆立端口了)对应级联起来,此处否必配置冗余连接。同时要把需要与会聚层,以及边缘层交换机连接的其他网络设备与普通l O/l OOMbps端口连接起来。同样在会聚层每台交换机上至少要留有两个以上备用端口。本示例如图3-43所示。这样,整个局域网部分就全部连接完成。

    在这里插入图片描述

    (4)为了确保与外部网络之间的连接性能,通常与外部网络连接的防火墙或路由器是直接连接在核心交换机上的。如果同时有防火墙和路由器,则防火墙直接与核心交换机连接,而路由器直接与外部网络连接,因为路由器的WAN(广域网)端口丰富。本示例如图3-44所示。
    在这里插入图片描述
    此网络结构是一个典型、高效的企业局域网结构,适合于200个用户左右的中型企业局域网选用。网络中的冗余和负载均衡配置也是目前企业局域网中经常采用的,当然这要求核心交换机支持这两方面的技术,在选购时要充分考虑。在网络结构中没有特别标注的端口和传输介质类型都为普通的1 0/1 00Mbps双绞线RJ-45端口。至于网络位置,如无特别,且各节点离交换机的距离都在规定的1 00米限制之内,则也可无须特别标注。
    以上就是较复杂的扩展型星型网络结构的设计方法,其步骤也很简单。在扩展型星型网络中其实就是一个个星型连接的交换机串、并联,或者串/并联基本星型连接混合组成。最重要的是要充分考虑网络中所采用的特殊技术,并根据不同用户的性能要求连接在不同层次的交换机上。

    三、大型混合型网络结构设计示例

    所谓的混合型网络结构,通常是指星型网络与总线型网络这两种网络结构在一个网络中的混合使用。之所以在企业网络中要采用这两种基本网络结构,是因为星型网络和总线型网络都有各自不同的优缺点,如果把它们混合在一个网络中应用,则可在缺点上相互弥补。如星型网络的优点是便于扩展和维护,但距离较短,不便于工作于远距离连接(双绞线网络直径限制在200米);而总线型网络的优点(细同轴电缆最大长度达1 8 5米,粗同轴电缆最大长度可达500米,光纤则更长)正好弥补了星型网络的缺点,而其不便于扩展的缺点又得到星犁网络的弥补。

    1.网络要求

    • 网络中的所有设备都必须用上,且必须尽可能地保障负载均衡,无性能瓶颈。
    • 各楼的核心交换机用一条光纤以总线型网络类型连接在一起,为各楼用户问访问提 供1 0Mbps的网络连接。
    • 核心交换机通过两个双绞线千兆位端口,采用链路聚合技术与会聚交换机连接,提 供最高可达2000Mbps的连接性能。
    • 会聚层的两台交换机采用堆栈技术连接,进一步扩展端口实际可用的带宽。
    • 核心交换机和会聚交换机都要留有可扩展端口。
    • 结构图中可清晰地知道各主要设备所连端口类型和传输介质类型。

    2.设计思路

    很明显这样一个混合型网络其实就是多个扩展型星型网络的互联,本示例为3个扩展型星型网络的互联。基本思路如下。
    (1)首先确定主干网络中,各楼核心交换机的光纤总线连接。在本示例中,各楼核心交换机要求与会聚层交换机采用链路聚合技术,以实现双干兆位(达2Gbps连接性能)网络连接,以提高整体网络连接性能。
    (2)再针对各楼星型网络的具体网络要求一一部署。在会聚层交换中选用的是支持堆栈技术的可堆栈交换机,所以在具体连接前也先需把各楼两台会聚交换机堆栈连接好。
    (3)对各楼内部的扩展星型网络进行部署。具体各楼内部的星型网络结构设计思路参见上节介绍的方法即可。

    3.设计步骤

    根据以上设计思路,作出的具体设计步骤如下。
    (1)用一条长度为250米左右、带宽为200MHz/km、波长为62.5/1 25微米的多模光纤 (最大长度为2 75米)以总线方式连接到各楼核心交换机的多模光纤端口上。注意在光缆的两端要加上终接器,以抵消回路信号反射。如图3.45所示。
    在这里插入图片描述
    (2)把需要与核心交换机,或者会聚交换机连接的工作站、管理控制台、网络打印机等设备(除路由器和防火墙外)在普通1 0/1 00Mbps以太网端口连接起来,如图3-46所示。不过在此,要充分考虑各交换机上所承受的负载,既要考虑到不能有性能瓶颈,同时又要充分考虑各交换机的负载尽可能均衡,特别是同一层次交换机之间。同时还要注意在各核心交换机和会聚层交换机上留有两个以上的备用端口。
    (3)各楼核心交换机的总线连接完成后,再把域控制器、会聚层交换机分别与对应的核心交换机连接。网络中的两台域控制器是直接与行政楼核心交换机的一个双绞线千兆位端口连接的,各楼的会聚交换机分别与对应楼的核心交换机以链路聚合技术连接,实现双千兆位双绞线端口连接,以实现2000Mbps的连接速率。仍参见图3-46所示。
    在这里插入图片描述
    (4)对所有工作站及其他网络设备按带宽需求和应用负荷大小进行分类,把最高需求的连接在核心交换机上的空余普通端口上,把次等需求的设备连接在会聚层交换机的空余普通端口上;把余下的网络设备连接在边缘层交换机的空余普通端口上。但要注意的是,在核心层和会聚层交换机上不能把所有端口都用上,每台交换机至少要保留两个端口用于替换损坏端口和网络扩展。连接后的网络结构如图3.47所示。
    在这里插入图片描述
    以上是局域网部分的全部连接。因为一般的企业局域网,与外部网络连接是必不可少的,所以最后还要部署内部网络与外部网络之间的连接。在行政楼核心交换机的一个端口(具体端口类型根据实际应用需要而定)上连接防火墙和路由器设备,以连接外部网络。最终的网络结构如图3—48所示。
    在这里插入图片描述
    通过以上简单的4个步骤,我们就完成了网络拓扑结构的设计,其实也很简单,关键是思路要清晰,哪些端口连接哪些设备,采用哪种连接方式,哪种传输介质。当然对于网络中的一些特殊技术应用需求,我们应当格外注意,在设计网络结构开始时就要留意,以便于工作有相应类型的端口使用。

    四、园区网络结构设计示例

    1.网络要求

    通过对用户网络结构和应用的分析可以得出这样一个大型校园网,必须具备以下基本网络要求。
    • 整个网络无性能瓶颈,特别是教学区中的多媒体教室。
    • 各子网间既要保持相对独立,又要允许有权限的用户能相互访问。
    • 各楼层都要预留一定的交换端口,以备扩展。
    • 结构图中可清晰地知道各主要设备连接的传输介质类型。
    • 整个网络设计的性价比要高。

    2.设计思路

    本示例为多个扩展型星型网络的双绞线,或者光纤互连。根据以上网络要求可以得出以下网络结构基本设计思路。
    (1)对于有多媒体教室的教学楼,在楼层交换机与建筑物设备问交换机之间,以及相应建筑物设备问交换机与总机房核心交换机之间可采用GEC技术进行多链路聚合,最高可达到 8Gbps的连接性能,确保所需的高带宽。
    (2)为了确保各子网问相对独立,又可以允许有权限用户问的互访,可在各区网络中采用子网划分方法,同时通过中间节点路由器可以设置允许相互访问的用户列表。
    (3)根据各建筑物的相隔距离通常是这样部署各机房和设备间的:各建筑物的设备问均设在各楼的第一层,子网设备问选择该区中位置相对中央的一建筑物第一层,与该建筑物的设备问共处一室,整个校园网的机房设在整个校园网中位置相对中央的一栋教学楼第一层,与该教学楼,甚至该建筑物所在子网的设备间区处一室。
    (4)主干网络中各子网核心交换机与总机房路由器之间,以及同一子网内部建筑物设备间交换机与子网核心交换机之间都采用光纤星型连接,而同一建筑物的不同楼层则采用双绞线千兆位连接。
    (5)楼层交换机所需预留的端口较多,而设备间和机房核心交换机则可预留少数端口,因为端口的使用主要体现在最终用户端。
    (6)本节主要介绍各楼层交换机与建筑物设备间核心交换机,建筑物设备间交换机与子网设备问核心交换机之间,以及子网设备间核心交换机与网络总机房路由器之间的连接,具体各楼内部的星型网络结构设计思路参见3.1.1节介绍即可。

    3.设计步骤

    根据以上设计思路,作出的具体设计步骤如下。
    (1)选择好用于总机房的教学楼,在其第一层某房间作为总机房,各建筑物的第一层也用一个房间用于建筑物设备问。各建筑物设备间交换机用一条带宽为400MHz/km、波长为 50/1 25微米的多模光纤(最大长度为500米)连接到总机房的路由器的多模光纤端口上(要求路由器支持相应的光纤连接类型)。教学区子网由于有多媒体教室之类高带宽需求应用,所以采取GEC技术(要求相应的核心交换机和路由器都支持GEC技术和千兆位以太网技术),把两个千兆位端口聚合起来,实现2Gbps的链路。如图3-49是教学区、学生宿舍区、教师家属区和娱乐区4个子网设备间核心交换机与总机房路由器的连接。
    在这里插入图片描述
    一般来说,如子网设备间会和该子网中其中一栋建筑物设备问在同一房问部署的。因为网络总机房设在教学区的一栋建筑物中,所以在教学区中会有一个机房同时部署网络总机房、教学区子网设备和该建筑物交换设备,担当3种角色。 (2)把各子网中不同建筑物设备间的交换机通过带宽为400MHz/km、波长为50/1 25微米的多模光纤与子网设备间的核心交换机连接起来,并标注相应的连接介质。如图3—50仅是一个示例,图中各子网设备问与其中一个建筑物设备间在同处一室部署。图中建筑物设备问交换机与子网核心交换机问,以及各子网核心交换机与总机房中间节点路由器之间的连接均为多模光纤千兆位连接。
    在这里插入图片描述
    (3)整个网络的主干部分设计好后,接下来就要对各建筑物内部各楼层交换网络结构进行设计。在这样一个大型校园网络中,因为教学区子网的宽带需求较高,所以在各教学楼内部所采用的交换机档次通常要高些,当然通常也都是采用相对廉价的双绞线千兆位连接,主要不J司体现在干兆位端口的数量较多,用于高带宽需求的用户终端连接。有时为了提高各端口的实际可用带宽而采用堆叠,或者链路聚合(包括FEC和GEC)功能。图3—5 1和图3—52 分别是学生宿舍区子网和教学区子网各一建筑物主干网络结构示例,其中学生宿舍区子网建筑物内部各楼层交换机通常采用普通的双绞线千兆位以太网交换机与建筑物设备问交换机连接,而对于终端用户比较集中的教学区建筑物内部各楼层交换机则采用堆叠方式与建筑物设备问进行双绞线千岁邑位连接。
    在这里插入图片描述

    (4)整个网络的主干部分和各建筑物内部的主干网络结构确定后,接下就要进行主要网络设备,如各种服务器、边界路由器和防火墙等的连接了。首先在整个网络的机房内把网络根域控制器和额外域控制器均连接在校园网核心交换机高速端口上,整个网络的边界路由器则根据实际需要选择,通常直接利用中间节点路由器即可,因为中间节点路由器除了具有局域网内部网段连接功能外,同样具有外部网络连接功能,支持多种接入方式。然后再把边界防火墙接在路由器的一个WAN端口上(也可把防火墙连接在路由器与校园网核心交换机之间)。另外,还需要配置一台管理控制台计算机,直接连接在机房校园网核心交换机的普通端口上。
    在各子网设备间同样把子网的域控制器连接在子网设备问交换机高速端口上,在各建筑物设备间中分别部署一台子网额外域控制器,起到负载均衡和域控制器冗余作用,参见图3—5 l 和图3—52。同样在子网设备间和建筑物设备问都可以部署一台管理控制计算机,连接在交换机的普通端口即可。
    (5)最后再把各建筑物内部的用户终端连接在各建筑物内部各楼层交换机的普通端口上即可,要注意的是各交换机所连接的用户终端数和负荷要尽可能均衡,同时要为每台交换机预留至少4个以上的端口用于维护和未来扩展。

    五、无线局域网结构设计示例

    1.网络要求

    • 所有该办公室用户均可通过无线AP与有线网络连接,且不能有冲突。
    • 两台无线AP负载要相对均衡,以免出现性能瓶颈。
    • 所有无线网络用户均能通过有线网络中的宽带路由器访问因特网。

    2.设计思路

    这类网络结构其实设计起来也很简单,基本思路如下。
    (1)把两台无线AP安装在办公室的适当位置,同时在距离上要确保两台无线AP能很好地覆盖对应的无线网络用户范围。
    (2)把两台无线AP通过一条直通双绞线连接到有线网络交换机的一个普通端口上,然后按有线网络一样的方法配置各无线用户的TCP/IP协议,即可实现与有线网络的连接,具体配置方法参见笔者编著的《网管员必读——网络组建》一书。如果有线网络中本来就配置有宽带路由器,无线网络用户就可以直接利用宽带路由器上网了,当然要确保这些用户没有在宽带路由器用户排除范围之内。
    (3)在无线AP上配置两台AP所采用的信道不能有重叠现象,配置各无线网络用户,选择使用对应的无线AP网络。

    3.设计步骤

    本示例仅说明无线网络部分的设计步骤,有线网络部分的设计参照本部分的前面几个示例。而且本示例有线网络部分以最基本的网络结构代表,实际上可以是任何复杂的网络结构。只需要把无线网络中的无线AP连接到有线网络的交换机(通常是核心交换机)即可。
    (1)首先确定无线网络用户的基本位置,把整个无线网络用户划分成两个区域。划分区域时不仅要考虑到网络用户数,还要充分考虑到各用户的具体网络应用性能需求,尽可能使得两个区域的用户带宽总需求保持基本一致。
    (2)把两台IEEE 802.1 1 g标准的无线AP分别安装在以上两个用户区域的中问位置,如图3—5 3所示。
    (3)从两台无线AP的RJ-45 LAN端口中拉出一条直通双绞线到有线网络至少骨干层的一个普通LAN端口,以实现与有线网络的连接。
    在这里插入图片描述
    以上就是基础结构的无线局域网拓扑结构设计步骤。下面简单介绍一下网络中各AP的信道配置问题。
    配置的两台无线AP的信道ID不能重叠。在工作于2.4GHz频段的IEEE 802.1 1 b和IEEE 802.1 1 g两标准中均提供了1 3个可供选择的信道。默认为第6信道。在单一无线AP的网络中,这里可以随便选择,而如果在无线网络中还有其他无线AP,则一定要注意,各AP所选择的信道所覆盖频段不能重叠。根据经验所得,一般在一个半径为50米以内的区域中,只允许有3个无线AP,所选的3个子信道只能是1、6、11,或者2、7、1 2,或者3、8、1 3这样的组合,主要是为了避免各AP所发出的信号相互干扰和冲突。

    展开全文
  • 计算机网络拓扑结构及其主要特点
  • 典型工业领域的网络拓扑结构

    千次阅读 2019-11-28 10:03:45
    简书上看到的,觉得很详细,留存: https://www.jianshu.com/p/dbfa1925109f
  • 计算机网络拓扑结构

    千次阅读 2017-11-29 15:30:00
    计算机网络拓扑(Computer Network Topology)是指由计算机组成的网络之间...一、计算机网络拓扑结构 计算机网络的拓扑结构,即是指网上计算机或设备与传输媒介形成的结点与线的物理构成模式。网络的结点有两类:一类...
  • 企业网络建设拓扑

    千次阅读 2019-09-24 10:42:56
    1.通过实验了解企业网络建设拓扑方案 2.加深熟悉在建设运用到的网络协议 3.锻炼自己的排错能力 二、实验器材 公司内部: 1.接入层:二层交换机x4 2.汇聚层:三层交换机x2 3.核心层:三层交换机x2 4.边界:路由器x2...
  • 大型公司网络构建拓扑图(华为)

    万次阅读 2018-01-25 14:25:47
    今天简单了解一下,大型公司的网络搭建。 对于很多大型公司来讲,网络的稳定性,会直接影响到公司的收益,比如,双十一的阿里巴巴,京东,等等。如果这个时候网络出现问题,对于公司的损失将会是不可估量的。可见...
  • 大型企业网络架构

    万次阅读 多人点赞 2018-11-24 10:57:01
    可以看到,在大型企业网络架构,有非常多的产品:交换机、路由器、防火墙、IDS、IPS、服务器等设备。 那么有很多人会问,有了防火墙为什么还要IPS和IDS呢? 防火墙较多的应用在内网保护(NAT),流控,过滤等...
  • 网络拓扑图及企业网络设计基本流程

    千次阅读 多人点赞 2020-07-20 23:37:54
    网络拓扑图及企业网络设计基本流程认识网络常见的路由协议分类:常见路由协议类型:网络层次结构:TCP/IP协议网络拓扑企业网络设计基本流程网络设计基本原则网络拓扑设计原则网络设计的方法和思路网络架构安全域和...
  • 3.2.2 企业网络拓扑图 3 4 企业网络详细设计 3 4.1 设计思路 3 4.2 设计步骤 4 4.2.1 按照拓扑图要求连接好设备 4 4.2.2 IP地址与VLAN规划 4 4.2.3 配置内网DHCP服务器 5 4.2.4 核心层交换机配置 5 4.2.5 汇聚层...
  • 思科----小型网络拓扑

    千次阅读 2020-09-27 23:05:54
    我准备搭建一个小型网络拓扑,有二层交换机、三层交换机、路由器、电脑、服务器等。 (1)PC0访问外网服务器(76.12.32.1)。 (2)外网访问内网服务器server0。 (3)禁止PC1 ping通外网主机PC2。   ...
  • 网络拓扑结构设计

    万次阅读 2013-09-20 10:25:22
    这里所指的小型星型网络是指只有一台交换机(当然也可以是集线器,但前已很少使用)的星型网络,主要应用于小型独立办公室企业和SOHO用户。这类小型网络所能连接的用户数一般在20个左右,当然也有可以连接高达40多...
  • 一分钟搞懂中小型企业网络架构

    千次阅读 多人点赞 2020-03-14 11:33:02
    江湖规矩先来说说项目背景: 1. 某公司有100台电脑(其实200...网络拓扑: 拓扑说明: 1. 拓扑里我用Cisco 2811充当防火墙,实属无奈,这个版本PT模拟器里ASA没有NAT功能,实际项目我们肯定使用专业防火墙设备...
  • 大中企业的三层交换机+二层交换机+路由,一用一备,可以联接两条外线,划分多个VLAN,隔离广播域,同一VLAN的主机可以PING通,不同VLAN间主机PING不通
  • 某大企业。有多个部门,财务部、人事部、销售部、工程部。同部门之间采用二层交换网络相连;不同部门之间采用VLAN路由方式互访。企业有一台内部web服务器,承载着内部网站,方便员工了解公司的即时信息。局域网...
  • Cisco 企业网络结构设计案例 设计思路: 1、 路由器上配置NAT转换,默认路由至ISP,静态路由至三层交换机 2、 三层交换机上划VLAN,实现VLAN间路由,至路由器默认路由; 3、 三层交换机上做ACL列表演,写实现...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 11,523
精华内容 4,609
关键字:

大型企业网络拓扑结构