精华内容
下载资源
问答
  • DHCP Relay即DHCP中继,它是为解决服务器和...华为5700交换机dhcp配置方法请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上应用场景:用户侧网段与DHCP服务器处于不同网段SwitchA为DHCP中继的配置思路在Sw...

    DHCP Relay即DHCP中继,它是为解决服务器和客户端不在同一个网段而提出来的,它提供了对DHCP广播报文的透明传输功能,下面是学习啦小编给大家整理的一些有关华为5700交换机dhcp配置方法,希望对大家有帮助!

    华为5700交换机dhcp配置方法

    请自行准备好华为交换机和电脑

    并且让你的电脑和交换机连接上

    应用场景:

    用户侧网段与DHCP服务器处于不同网段

    SwitchA为DHCP中继的配置思路

    在SwitchA上创建DHCP服务器组并为服务器组添加DHCP服务器SwitchB,使SwitchB成为公司分配IP地址给其它主机的服务器。

    在接口VLANIF100下使能DHCP中继功能,使之成为DHCP中继服务器。

    为接口VLANIF100绑定创建的DHCP服务器组,指定中继指向的公司的主服务器。

    SwitchB为DHCP服务器的配置思路如下:

    配置DHCP服务器到中继的接口Eth 0/0/1的路由,使公司服务器到中继的路由可达。

    使能公司服务器的DHCP功能,配置DHCP服务器的接口Eth 0/0/1下的各楼宇内的主机从服务器全局地址池中获取IP地址。

    在公司DHCP服务器上创建全局地址池,为公司内的主机分配IP地址。

    创建DHCP服务器组并为服务器组添加DHCP服务器。

    # 创建DHCP服务器组。

    system-view

    [Quidway] dhcp server group dhcpgroup1

    # 为DHCP服务器组添加DHCP服务器。

    [Quidway-dhcp-server-group-dhcpgroup1] dhcp-server 100.10.10.1

    [Quidway-dhcp-server-group-dhcpgroup1] quit

    在VLANIF接口下使能DHCP中继功能。

    # 创建VLAN并将Eth 0/0/1接口加入到VLAN中。

    [Quidway] vlan 100

    [Quidway-Vlan100] quit

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port link-type trunk

    [Quidway-Ethernet0/0/1] port trunk allow-pass vlan 100

    [Quidway-Ethernet0/0/1] quit

    # 使能全局DHCP功能,并使能VLANIF接口下DHCP中继功能。

    [Quidway] dhcp enable

    [Quidway] interface vlanif 100

    [Quidway-Vlanif100] dhcp select relay

    [Quidway-Vlanif100] quit

    为VLANIF接口绑定指定的DHCP服务器组。

    # 为VLANIF接口配置IP地址。

    [Quidway] interface vlanif 100

    [Quidway-Vlanif100] ip address 20.20.20.1 24

    # 为VLANIF接口指定DHCP服务器。

    [Quidway-Vlanif100] dhcp relay server-select dhcpgroup1

    [Quidway-Vlanif100] quit

    配置DHCP服务器。

    # 创建VLAN并将Eth 0/0/1接口加入到VLAN中。

    [Quidway] vlan 20

    [Quidway-Vlan20] quit

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port link-type trunk

    [Quidway-Ethernet0/0/1] port trunk allow-pass vlan 20

    [Quidway-Ethernet0/0/1] quit

    # 启动DHCP服务,配置接口VLANIF20下的客户端从全局地址池中获取IP地址。

    system-view

    [Quidway] dhcp enable

    [Quidway] interface vlanif 20

    [Quidway-Vlanif20] ip address 100.10.10.1 24

    [Quidway-Vlanif20] dhcp select global

    [Quidway-Vlanif20] quit

    在DHCP服务器上配置一个20.20.20.0/24网段的IP地址池,并且添加到SwitchA的静态路由,保证DHCP服务器到20.20.20.0/24网段路由可达。

    [Quidway] ip pool 1

    [Quidway-ip-pool-1] network 20.20.20.0 mask 24

    [Quidway-ip-pool-1] quit

    # 将IP地址池网段添加到DHCP中继的静态路由,保证DHCP服务器到20.20.20.0/24网段路由可达。(略)

    验证配置结果。

    # 在SwitchA上使用display dhcp relay命令用来查看接口的DHCP中继配置情况。

    [Quidway] display dhcp relay interface vlanif100

    DHCP relay agent running information of interface Vlanif100 :

    Server group name : dhcpgroup1

    Gateway address in use : 100.10.10.1

    # 在SwitchB上使用display ip pool命令用来查看IP地址池配置情况。

    [Quidway] display ip pool

    -----------------------------------------------------------------------

    Pool-Name : 1

    Pool-No : 0

    Position : Local Status : Unlocked

    Gateway-0 : -

    Mask : 255.255.255.0

    Vpn instance : --

    IP address Statistic

    Total :250

    Used :0 Idle :248

    Expired :0 Conflict :0 Disable :2

    查看配置文件

    SwitchA的配置文件

    #

    sysname Quidway

    #

    vlan 100

    #

    dhcp enable

    #

    dhcp server group dhcpgroup1

    dhcp-server 100.10.10.1

    #

    interface Vlanif100

    ip address 20.20.20.1 255.255.255.0

    dhcp select relay

    dhcp relay server-select dhcpgroup1

    #

    interface Ethernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 100

    #

    return

    SwitchB的配置文件

    #

    sysname Quidway

    #

    vlan batch 20

    #

    dhcp enable

    #

    ip pool 1

    network 20.20.20.0 mask 255.255.255.0

    #

    interface Vlanif20

    ip address 100.10.10.1 255.255.255.0

    dhcp select global

    #

    interface Ethernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 20

    #

    return

    华为设置连接两个无线路由器的方法

    1、网口2的位置添加一个家用交换机,有4个口,你刚好可以使用3个口,相当于自来水的4通(一个口空闲)

    这个必须要求2个路由器都有不同的上网帐号 密码,都可以自己拨号,基本上不现实//大学宿舍基本上是这样做的

    2、路由器2接路由器1

    A 路由器1负责拨号上网,路由器2要么接路由器lan口到路由器2wav口(设置动态ip,lan口ip调整)

    假设路由器1lanip 未192.168.a.1 路由器2必须设置lan ip未192.168.b.1

    B路由器1负责拨号,开启dhcp,填写你网络服务商的dns,路由器1lan口出线到路由器2lan口,,路由器2lan口ip设置再前方路由器ip段里面,关闭路由器2dhcp,相当于前方路由器的交换机,2个路由器均可设置无线功能

    假设路由器1lanip 未192.168.a.1 路由器2必须设置lan ip未192.168.a.c(c可以在2~253之间,推荐150)

    看了“华为5700交换机dhcp怎么配置”的人还看了

    展开全文
  • 今天给大家带来日常工作中经常用到的一个技术,那就是DHCP技术,细节类型请转战其他地方即可,理论一大把,不具体细说了。不做同质化内容。拓扑看过我的视频的同学都应该知道这个环境是啥意思,上面一朵云指的是我的...

    今天给大家带来日常工作中经常用到的一个技术,那就是DHCP技术,细节类型请转战其他地方即可,理论一大把,不具体细说了。不做同质化内容。

    拓扑

    901ce3fc3dbd85cdafe608a2d6109063.png

    看过我的视频的同学都应该知道这个环境是啥意思,上面一朵云指的是我的本地网络,虚拟机的那朵云指的是虚拟机桥接到一张虚拟网卡上了,可以参考的我的视频看看。

    第一种环境

    DHCP方式:本地DHCP配置方式:接口下启用业务VLAN ID:2网段:10.0.0.0/24网关:10.0.0.1dns:114.114.114.114

    配置脚本

    dhcp enable #启用DHCP服务vlan 2       #创建VLAN2interface Vlanif2    ##创建SVI口 ip address 10.0.0.1 255.255.255.0 dhcp select interface  ##选择接口下启用DHCP dhcp server dns-list 114.114.114.114 ##DNS interface g0/0/1port link-type access port default vlan 2

    效果

    190e55e97955ffe08570b3509f11c0f5.png

    终端侧

    3c256e3a33fe0e87f8aa2c7ffdb0b453.png

    交换机侧

    第二种环境

    DHCP方式:本地DHCP配置方式:全局调用业务VLAN ID:2网段:10.0.0.0/24网关:10.0.0.1排除网段:10.0.0.254dns:114.114.114.114

    配置脚本

    dhcp enable #启用DHCP服务vlan 2       #创建VLAN2ip pool kasar gateway-list 10.0.0.1 network 10.0.0.0 mask 255.255.255.0 excluded-ip-address 10.0.0.254 dns-list 114.114.114.114interface Vlanif2    ##创建SVI口 ip address 10.0.0.1 255.255.255.0ip pool kasar gateway-list 10.0.0.1 network 10.0.0.0 mask 255.255.255.0 excluded-ip-address 10.0.0.254 dns-list 114.114.114.114interface g0/0/1port link-type access port default vlan 2

    效果

    02b423a13131ab9a1cec1dddcb6c4a35.png

    终端侧

    82d7880f34b557dd7d846a0958f1c184.png

    交换机侧

    第三种环境(Relay)

    DHCP方式:外部DHCP配置方式:接口下选择relay业务VLAN ID:2网段:192.168.31.0/24 ##本地环境网关:192.168.31.1DHCP服务器:192.168.31.1

    配置脚本

    dhcp enable #启用DHCP服务vlan 2       #创建VLAN2interface Vlanif2    ##创建SVI口 ip address 192.168.31.100 255.255.255.0dhcp select relay ##选择relay方式dhcp relay server-ip 192.168.31.1    ##指定relay server地址interface g0/0/1  ##接虚拟机环境接口port link-type access port default vlan 2interface g0/0/2 ##接本地环境接口port link-type access port default vlan 2

    效果

    eefd156c38dc73bcc138cb7f2d8d253b.png

    客户端侧

    5566abdcb24dd30837abe3a42424d823.png

    交换机侧

    bc02299c2d69b36283dbb56abeaf0c66.png

    抓包结果,符合relay预期

    bec2d0c1c71304ca6c4a63de3a576e68.png

    访问外网正常

    实验到这里就结束了,文章看起来比视频看起来要累,所以如果有兴趣的朋友可以去看我的视频,已经发布了,本身企业的一些网络技术都是由一些小小的技术点组合而成,逐个击破,你的技术自然而然就提升了,最后如果该文章对您有用,帮忙点波关注,后续带来更优质的文章哦

    展开全文
  • 华为交换机DHCP配置

    2021-04-08 15:57:28
    华为交换机DHCP配置 设备型号:华为交换机–S3700 时间:2021.3.19 环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动...

    华为交换机DHCP配置

    设备型号:华为交换机–S3700
    时间:2021.3.19

    环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动获取网段为192.168.20.0/24的IP地址。

    拓扑:
    在这里插入图片描述

    DHCP配置:
    <Huawei>system-view -----进入配置模式

    [Huawei]dhcp enable -----开启DHCP服务

    [Huawei]vlan 10 -----创建vlan10

    [Huawei-vlan10]quit -----退出

    [Huawei]vlan 20 -----创建vlan20

    [Huawei-vlan20]quit -----退出

    [Huawei]port-group 1 -----创建端口组

    [Huawei-port-group-1]group-member Ethernet 0/0/1 to Ethernet 0/0/10 -----加入端口组成员

    [Huawei-port-group-1]port link-type access -----端口组成员配置为access

    [Huawei-port-group-1]port default vlan 10 -----端口组成员划为vlan10

    [Huawei-port-group-1]quit -----退出

    [Huawei]port-group 2 -----创建端口组

    [Huawei-port-group-2]group-member Ethernet 0/0/11 to Ethernet 0/0/20 -----加入端口组成员

    [Huawei-port-group-2]port link-type access -----端口组成员配置为access

    [Huawei-port-group-2]port default vlan 20 -----端口组成员划为vlan20

    [Huawei-port-group-2]quit -----退出

    [Huawei]ip pool 1 -----创建地址池

    [Huawei-ip-pool-1]network 192.168.10.0 mask 24 -----配置地址池

    [Huawei-ip-pool-2]gateway-list 192.168.20.1 -----配置地址池网关

    [Huawei-ip-pool-1]dns-list 114.114.114.114 -----配置地址池DNS

    [Huawei-ip-pool-1]lease day 3 -----配置地址池租约

    [Huawei-ip-pool-1]quit -----退出

    [Huawei]ip pool 2 -----创建地址池

    [Huawei-ip-pool-2]network 192.168.20.0 mask 24 -----配置地址池

    [Huawei-ip-pool-2]gateway-list 192.168.20.1 -----配置地址池网关

    [Huawei-ip-pool-2]dns-list 114.114.114.114 -----配置地址池DNS

    [Huawei-ip-pool-2]lease day 3 -----配置地址池租约

    [Huawei-ip-pool-2]quit -----退出

    [Huawei]int vlan 10 -----进入vlan10

    [Huawei-Vlanif10]ip address 192.168.10.1 255.255.255.0 -----配置vlan10IP地址

    [Huawei-Vlanif10]dhcp select global -----配置vlan10中PC从全局地址池中 获取IP地址

    [Huawei-Vlanif10]int vlan 20 -----进入vlan20

    [Huawei-Vlanif20]ip address 192.168.20.1 255.255.255.0 -----配置vlan20地址

    [Huawei-Vlanif20]dhcp select global -----配置vlan20中PC从全局地址池中 获取IP地址

    [Huawei-Vlanif20]return -----返回用户视图

    <Huawei>save -----保存

    总结:本实验用一个简单的例子,来描述如何为使用交换机配置DHCP。在本例子中演示的是为多个vlan配置DHCP,当只有一个vlan时,只用配置一个地址池就好了。

    展开全文
  • 华为核心交换机:S5720S-36C-EI-AC 管理IP:172.30.5.1华为桌面交换机:S5700S...如下图所示:核心交换机配置:(华为交换机dhcp server配置:DHCP配置)接入层交换机配置:[SW_ACC_5.10]dhcp enable[SW_ACC_5.10]dhcp ...

    华为核心交换机:S5720S-36C-EI-AC 管理IP:172.30.5.1

    华为桌面交换机:S5700S-52P-LI-AC 管理IP:172.30.5.10

    核心交换机24聚合与桌面交换机47,48 聚合口互联。

    如下图所示:

    75cd36bc602293a453df3f47ed5d4ea1.png

    核心交换机配置:

    (华为交换机dhcp server配置:DHCP配置)

    接入层交换机配置:

    [SW_ACC_5.10]dhcp enable

    [SW_ACC_5.10]dhcp snooping enable

    [SW_ACC_5.10]int eth-trunk 1

    [SW_ACC_5.10-eth-trunk1]dhcp snooping enable

    [SW_ACC_5.10-eth-trunk1]dhcp snooping trusted

    [SW_ACC_5.10-eth-trunk1]quit

    [SW_ACC_5.10]int range g0/0/1 to g0/0/46

    [SW_ACC_5.10-Group]dhcp snooping enable

    [SW_ACC_5.10-Group]quit

    来源:51CTO

    作者:adong2838

    链接:https://blog.51cto.com/2221384/2530546

    展开全文
  • 华为交换机DHCP Server释放IP

    千次阅读 2020-04-13 12:49:52
    reset ip pool name vlan40 172.16.4.254用户视图下有效。本文链接地址: 华为交换机DHCP Server释放IP
  • 华为交换机DHCP

    2013-09-16 16:40:03
    基于接口的DHCP  interface Vlanif 1  ip address 192.168.1.1 255.255.255.0  dhcp select interface  dhcp server static-bind ip-address 192.168.1.8 mac-address 1803-7300-0d33  dhcp ...
  • ip pool name 1 #指定要做静态分配的地址池static-bind ip-address 172.16.1.11 mac-address 0017-6110-C599 #将172.16.1.11固定分配给0017-6110-C599本文链接地址: 华为交换机DHCP固定分配...
  • f99b4cbdf76d478393de658f5c53f6ca-300x220.jpg (8.78 KB, 下载次数: 22)华为S7706交换机DHCP Server 配置不成功问题2016-6-10 14:22 上传问题描述如下图所示:S7706交换机作为DHCP服务器,S5700作为接入交换机连接...
  • system-view[Quidway] dhcp server group dhcpgroup1# 为DHCP服务器组添加DHCP服务器。[Quidway-dhcp-server-group-dhcpgroup1] dhcp-server 100.10.10.1[Quidway-dhcp-server-group-dhcpgroup1] quit在VLANIF接口下...
  • 求助:小弟菜鸟一枚,ENSP实验将S1作为dhcp服务器,S3作为dhcp中继,S1、S2、S3之间运行ospf协议,现在PC2无法获取到地址,配置如下,万分感谢sysname S1#vlan batch 10 20 30#cluster enablentdp enablendp enable#...
  • DHCP(动态主机配置协议)是一个局域网的网络协议。指的是由服务器控制一段lP地址范围,客户机登录服务器时就可以自动获得服务器分配的lP地址和子网掩码。默认情况下,DHCP作为Windows Server的一个服务组件不会被...
  • 华为交换机DHCP SNOOPING 配置实例

    千次阅读 2012-02-23 09:46:58
    华为交换机DHCP SNOOPING 配置实例 拓扑说明:华为交换机1号与2号端口分别连接无线AP,都带有DHCP地址自动分配功能,3号端口为PC客户端; 需求分析:PC客户端的IP地址仅有无线AP-1分配,不受2号端口无线AP-2的影响...
  • 配置思路1.使能DHCP Snooping功能。...4.使能根据DHCP Snooping绑定表生成接口的静态MAC表项功能,以防止非DHCP用户攻击。5.使能对DHCP报文进行绑定表匹配检查的功能,防止仿冒DHCP报文攻击。6.配置DHCP报...
  • 华为交换机DHCP snooping

    千次阅读 2019-01-11 13:54:19
    配置思路 1.使能DHCP Snooping功能。...4.使能根据DHCP Snooping绑定表生成接口的静态MAC表项功能,以防止非DHCP用户攻击。 5.使能对DHCP报文进行绑定表匹配检查的功能,防止仿冒DHCP报文攻击。 6.配...
  • DHCP维护在确认需要清除DHCP服务器的统计信息后,请在用户视图下执行reset dhcp server statistics命令。在确认需要清除DHCP中继的统计信息后,请在用户视图下执行reset dhcp relay statistics命令。使用命令display...
  • 下面看看在交换机设备上是如何实现IPv6的DHCP的。第一步:先开启设备的DHCP功能开启DHCP功能第二步:配置连接电脑的端口,将电脑网卡放入到vlan 3501电脑网卡使用vlan 3501电脑网卡用3501是在虚拟机上...
  • 华为交换机 DHCP中继全局不同网段配置

    万次阅读 多人点赞 2018-07-02 17:06:02
    1、DHCP作为公司汇聚交换机,在上面配置DHCP全局地址池,然后接入交换机根据不同vlan会获取到不同网段IP地址。 2、网络拓扑 二、操作步骤 1、客户端 1)创建DHCP服务器组,并为DHCP服务器组添加DHCP服务器对应...
  • 为什么要开启,因为可以防止其他设备如路由器接入后开启DHCP会导致合法用户获得该DHCP分配的不合法IP,从而可能不能正常上网。总之作用是屏蔽接入网络中的非法的 DHCP 服务器。即开启 DHCP Snooping 功能后,网络中的...
  • ping 网关 192.168.X.1时网络能通arp -a 查询到网关mac地址为  xx.xx.xx.xx.xx.xx在S7706核心交换机上 dis arp | in 192.168.X.1查询网关mac地址两个mac地址一致,排除arp攻击导致无法获取地址。...
  • 交换机的配置: <Huawei>sysname SW2 [SW2]vlan batch 10 20 [SW2]interface e0/0/1 [SW2-Ethernet0/0/1]port link-type access [SW2-Ethernet0/0/1]port default vlan 10 [SW2-Ethernet0/0/1]q [SW2]...
  • 华为交换机 DHCP配置查看

    千次阅读 2012-10-25 08:44:29
    【命令】expired { day day [ hour hour ... 【视图】DHCP 地址池视图  【参数】day day:表示天数,取值范围0~365。hour hour:表示小时数,取值范围0~23。minute minute:表示分钟数,取值范围0~59。unlimite
  • 在生产环境中,当主机的数量太多的时候,...华为交换机如何配置呢?下面来看看吧。超级简单。拓扑配置步骤1、基本配置[SW1]vlan 10 //创建vlan10//把g0/0/1接口添加到vlan10[SW1]interface GigabitEthernet 0/0/1[SW...
  • 可以使用 命令 SYS下 输入stp disable 禁止生成树协议,来使电脑很快获得到路由器防火墙的内网地址。 转载于:https://blog.51cto.com/zhangzupenghi/1850928...
  • 同时因为涉及到跨网段的DHCP,还需要在三层交换机上配置DHCP中继。 我是T型人小付,一位坚持终身学习的互联网从业者。喜欢我的博客欢迎在csdn上关注我,如果有问题欢迎在底下的评论区交流,谢谢。 文章目录操作...
  • 今天分享一下如何在华为三层交换机上配置DHCP服务。拓扑图三台终端分别为三个不同的部门,分别加入到不同的VLAN中,为了后续扩展需求,现在,采用动态获取IP地址。配置思路在交换机上创建VALN10-30。把三台终端分别...
  • 华为交换机配置:DHCP 一、实验环境 二、给交换机起个名称 [Huawei]sysname switch [switch] 三、全局开启dhcp [switch]dhcp ena [switch]dhcp enable Info: The operation may take a few seconds. Please wait...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 472
精华内容 188
关键字:

华为交换机dhcp