精华内容
下载资源
问答
  • 思科和华为交换机链路聚合命令对比在本人经历过的项目中,有思科交换机和华为交换机对接,通过链路聚合将两条以上物理线路绑在一起成为一条逻辑线路。因为是两个品牌的交换机,其中的配置不同,稍有差错将聚合不成功...

    思科和华为交换机链路聚合命令对比
    在本人经历过的项目中,有思科交换机和华为交换机对接,通过链路聚合将两条以上物理线路绑在一起成为一条逻辑线路。因为是两个品牌的交换机,其中的配置不同,稍有差错将聚合不成功导致线路不通,下面列出两个品牌的命令对比。
    (一) 思科交换机配置命令
    思科交换机逻辑端口为 Port-channel

    1. 物理口所有配置如下,注意哪些是自动跟随逻辑口配置的,哪些是要在物理口上配置的,这些特别容易混淆。
      通过查看端口配置命令,最后物理端口配置如下:
      interface GigabitEthernet3/17
      switchport trunk encapsulation dot1q(跟随逻辑口配置,物理口不需配置)
      switchport mode trunk (跟随逻辑口配置,物理口不需配置)
      channel-protocol lacp (链路聚合协议lacp,物理口需配置)
      channel-group 3 mode active (主动模式,物理口需配置)
      特别需要注意的是,当需要更改配置时,物理口的配置不能同步到逻辑口上,反之可以。

    2. 逻辑口配置
      interface Port-channel1
      switchport access vlan 109 (当逻辑口取消trunk配置时,端口所属vlan)
      switchport trunk encapsulation dot1q
      switchport mode trunk

    3. 大多数链路聚合都会把逻辑口配置为Trunk口,目的是让多个vlan通过。当需要禁止某个Vlan通过Trunk口时,配置命令如下,包括不允许vlan1通过也是以下命令,这点和华为交换机不同。
      switchport trunk allowed vlan remove vlanID

    4. 当不知道哪些vlan有没有被允许通过Trunk口时,通过以下命令查看
      show int trunk module 1

    (二) 华为交换机配置,需要注意和思科交换机配置的不同之处。
    华为交换机逻辑端口为Eth-trunk

    1. 物理口只需如下配置,通过命令查看物理口的配置并没有同步逻辑口的配置,这点和思科不同。
      interface GigabitEthernet0/0/47
      eth-trunk 1

    2. 逻辑口配置
      interface Eth-Trunk1
      port link-type trunk
      port trunk allow-pass vlan all
      mode lacp (华为端口聚合协议lacp是在逻辑口配置的,思科是在物理口配置的)

    3. 禁止某个Vlan通过Trunk口时,配置命令如下:
      undo port trunk allow-pass vlanID
      因为华为交换机vlan1是默认PVID,PVID默认又是允许通过Trunk口。当要禁止vlan1通过Trunk口时,需要先更改PVID为其他vlanID。在逻辑口上配置命令如下:
      interface Eth-Trunk1
      port trunk pvid vlan 201

    4. 当不知道哪些vlan有没有被允许通过Trunk口时,通过以下命令查看
      display port vlan

    最后,虽然思科和华为交换机在链路聚合配置命令上的不同,但在原理上是一样的,要熟悉两个品牌的配置,除了深入了解原理之外,平时还要多练习,做好归纳总结。

    展开全文
  • 华为交换机链路聚合命令

    千次阅读 2018-10-12 12:05:25
    配置链路聚合1、创建聚合组sysinterface eth-trunk 22、配置聚合模式为手工模式interface eth-trunk 2mode manual load-balance 表示手工模式mode lacp lacp模式,可以自动检测链路是否错误;3、将接口成员加入聚合...

    配置链路聚合
    1、创建聚合组
    sys
    interface eth-trunk 2
    2、配置聚合模式为手工模式
    interface eth-trunk 2
    mode manual load-balance 表示手工模式
    mode lacp   lacp模式,可以自动检测链路是否错误;
    3、将接口成员加入聚合组
    interface eth-trunk 2
    trunkport g1/0/1 to 1/0/3 mode { active | passive }
    或者进到接口模式下:
    interface g1/0/1
    eth-trunk 2 mode { active | passive }
    注意:
    一个以太网接口只能加入到一个Eth-Trunk接口;
    当成员接口加入Eth-Trunk后,学习MAC地址或ARP地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习;
    删除聚合组时需要先删除聚合组中的成员接口
    4、配置链路聚合的负载分担方式(可选)
    Eth-Trunk的负载分担是逐流进行的,逐流负载分担能保证包的顺序,保证了同一数据
    流的帧在同一条物理链路转发。而不同数据流在不同的物理链路上转发从而实现分担负载;
    可以配置普通负载分担模式,基于报文的IP地址或MAC地址来分担负载;
    由于负载分担只对出方向的流量有效,因此链路两端接口的负载分担模式可以不一致,两端互不影响;
    配置普通负载分担方式:
    interface eth-trunk 2
    load-balance { dst-ip | dst-mac | src-ip | src-mac | src-dst-ip | src-dstmac }
    dst-ip(目的IP地址)模式:根据目的IP地址进行负载分担;
    dst-mac(目的MAC地址)模式;
    src-ip(源IP地址)模式;
    src-mac(源MAC地址)模式;
    src-dst-ip(源IP地址异或目的IP地址)模式:根据源IP异或目的IP地址的结果进行负载分担。
    src-dst-mac(源MAC地址异或目的MAC地址)模式;
    5、检查配置结果
    display eth-trunk 2 查看Eth-Trunk的配置信息;
    display trunkmembership eth-trunk 2,查看Eth-Trunk的成员接口信息

    转载于:https://blog.51cto.com/11009796/2299162

    展开全文
  • 聚合链接 输入 /example #所有的帮助信息中查找example 输入 n #跳转匹配 [root@desktop0 ~]# man teamd.conf [root@server0 /]# nmcli connection add type team autoconnect yes ifname team...

    链路聚合

    输入 #所有的帮助信息中查找example

    $ man teamd.conf      #man  teamd.conf ,搜索 /example找出需要的聚合模式
    $ nmcli connection add type team autoconnect yes  ifname team0 con-name team0 config '{"runner": {"name": "activebackup"}}'   
    
    $ nmcli connection add type team-slave ifname eth1 con-name team0-1 autoconnect yes master team0 
    
    $ nmcli connection add type team-slave ifname eth2 con-name team0-2 autoconnect yes master team0 
    
    $ nmcli connection modify team0 ipv4.method manual ipv4.addresses 192.168.1.1/24 connection.autoconnect yes 
    
    $ nmcli connection up team0
    
    $ nmcli connection up team0-1
    
    $ nmcli connection up team0-2
    
    $ ifconfig team0     
    
    $ nmcli connection delete team0 
    
    $ nmcli connection delete team0-1
    
    $ nmcli connection delete team0-2
    

    配置IPv6

    $ nmcli connection modify 'System eth0' ipv6.method manual ipv6.addresses 2003:ac18::305/64 connection.autoconnect  yes
    
    $ nmcli connection up 'System eth0'
    

    参考链接:
    https://www.cnblogs.com/liuhedong/p/10695969.html

    展开全文
  • 链路聚合配置命令

    万次阅读 2018-04-09 21:18:49
    1.1 概述1.1.1 链路聚合简介在路由器上使用多链路进行互连时,可以把多条物理链路进行捆绑,对外呈现一条逻辑链路,并屏蔽实际的物理链路。这种方式称之为链路聚合(Aggregate,简称AG),且把实际的物理链路称之...
  • 链路聚合

    2019-05-30 15:09:35
    为啥要用链路聚合: 网卡属于硬件设备,硬件设备使用的时候难免会有损坏,至于啥时候这个网卡会坏掉我们是算不出来的,那这个隐患就会一直存在,不知道哪天就爆发了...首先我们使用帮助文档查找链路聚合命令 #man...
  • 链路聚合及VRRP

    2021-03-16 14:14:41
    链路聚合及VRRP以态网链路聚合以态网链路聚合链路聚合命令VRRP工作原理VRRP概述VRRP术语VRRP路由器VRRP组虚拟路由器虚拟IP、MAC器地址Master路由器Backup路由器 以态网链路聚合 以态网链路聚合 Eth-trunk多链路汇聚...
  • 链路聚合概念+配置命令

    千次阅读 2020-04-25 10:33:14
    随着网络的扩大,硬件要求变高,需付出高额费用,且不灵活,链路聚合再不需要升级硬件,通过多物理接口捆绑为一个逻辑接口,还可以链路备份 链路聚合一,应用场景二,链路聚合三,模式四,数据流控制五,二层链路...
  • nmcli和teamnmcli基于会话的网络管理查看网卡信息网卡状态修改网卡配置修改team链路聚合什么是teamingteaming和bonding的区别team的工作模式team链路聚合配置配置软件桥接配置桥接 team0配置team配置br0配置文件文末...
  • 链路聚合技术: 也可以称为端口聚合,或者叫链路捆绑。eth-channle 将两条或者更多条链路捆绑到一起。 链路聚合的背景 采用链路聚合技术可以在不进行硬件升级的条件下进行。 链路聚合技术的作用: 1.增大网络带宽 2....
  • 手工负载分担模式链路聚合 介绍了手工负载分担模式链路聚合配置场景、step及注意事项。 1.1.1 建立配置任务 1.1.2 创建Eth-Trunk 1.1.3 (可选)配置Eth-Trunk 工作模式为手工负载分担模式 1.1.4 向Eth-Trunk...
  • 以太网链路聚合和VRRP

    2021-03-16 13:45:15
    内容概要1、以太网链路聚合命令2、VRRP(虚拟路由冗余协议)2-1、VRRP概述2-2、VRRP术语2-3、VRRP状态机2-4、VRRP的作用命令 1、以太网链路聚合 以太网链路聚合----Eth-trunk多链路汇聚,将多条物理链路变为一条E-...
  • 配置eth-trunk链路聚合 原理概念: 优势:1、负载分担。 2、提高可靠性。 3、增加带宽。 实验目的: 1、 理解使用eth-trunk的应用场景。 2、 掌握配置eth-trunk链路聚合的方法。 3、 掌握配置eth-trunk链路聚合的...
  • 命令为介绍华三的链路聚合使用,并且是在某医院做过实际操作的配合思科上联设备,作为下联设备时所遇到的问题如何处理使用,全是干货 有图
  • Trunk:单条链路可以承载多vlan的数据流量。 Hybrid:混合接口,可以选择access还是trunk接口属性工作。 Pvid:打标签。 Untagged:出交换机会把指定标签解除的一张列表。 Tagged:当某些指定vlan(有相应标签的)...
  • 链路聚合实验

    千次阅读 2020-01-16 17:21:23
    1链路聚合配置实验 1.1实验内容 1.2实验原理 1.3关键命令 1.4配置过程 2链路聚合与VLAN配置实验 2.1实验内容 2.2实验原理 2.3 配置过程 3链路聚合与生成树配置实验 3.1实验内容 3.2实验原理 3.3 配置...
  • 链路聚合与VRRP

    2021-03-16 14:01:05
    链路聚合命令二. VRRP原理和命令1. VRRP原理2. VRRP命令 一. 链路聚合 1. 以太网链路聚合 以太网链路聚合----Eth-trunk多链路汇聚,将多条物理链路变为一条E-trunk的逻辑链路,从而实现增加链路带宽的目的。链路...
  • 文章目录VRRP的概述VRRP的作用虚拟路由器Master报文的发送VRRP状态机VRRP华为命令配置链路聚合命令 VRRP的概述 1.利用VRRP,一组路由器(同一个LAN中的接口),协同工作,但是只有一个处于Master状态,处于该状态的...
  • Windows 10 链路聚合

    2021-03-28 17:15:20
    链路聚合,Windows server 服务器上是NIC Windows 10上面只能用命令来做,也没找到工具。 链路聚合优点,可以获得更佳的网络负载均衡和故障转移能力。能把宽带叠加。掉了一根网线, 另外一跟还可以继续用,不过网速...

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 255
精华内容 102
关键字:

链路聚合命令