精华内容
下载资源
问答
  • (思科 h3c) 静态路由静态路由(static routing)是指由用户或网络管理员手工配置的路由信息。在早期网络中,网络的规模不大,路由器的数量很少,路由器也相对较小,通常采用手动的方法对每台路由器的路由表进行...

    1535301258556053.jpg
    (思科 h3c)

    静态路由:

    静态路由(static routing)是指由用户或网络管理员手工配置的路由信息。在早期网络中,网络的规模不大,路由器的数量很少,路由器也相对较小,通常采用手动的方法对每台路由器的路由表进行配置,即静态路由。这种方法适合于在规模较小、路由表也相对简单的网络中使用。它较简单,容易实现,沿用了很长一段时间。

    在小规模的网络中,静态路由的优点有两点,一是手动配置,可以精确控制路由选择,改进网络的性能,二是不需要动态路由协议参与,这将会减少路由器的开销,为重要的应用保证带宽。缺点是大型和复杂的网络环境通常不宜采用静态路由。一方面,网络管理员难以全面地了解整个网络的拓扑结构;另一方面,当网络的拓扑结构和链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。当网络发生变化或网络发生故障时,不能重选路由,很可能使路由失败。

    下面具体来比较思科和H3C关于静态路由的配置命令:

    思科静态路由配置如下:

    Router(config)#ip route 目的网段 子网掩码 下一跳/出接口

    H3C 静态路由配置如下:

    [Switch]ip route-static 目的网段 子网掩码 下一跳/出接口

    注意:对于接口类型为非点对点的接口,不能够指定出接口,必须指定下一跳地址。

    目的IP地址和掩码都为0.0.0.0的路由为默认路由。

    OSPF:

    OSPF(Open Shortest Path First,开放最短路径优先)是IETF 开发的基于链路状态的自治系统内部路由协议。与距离矢量协议不同,链路状态路由协议使用Dijkstra的最短路径优先算法(SPF)计算和选择路由。这类路由协议关心网络中链路或接口的状态,每个路由器将其已知的链路状态向该区域的其他路由器通告,通过这种方式,网络上的每台路由器对网络结构都会有相同的认识。随后,路由器以其为依据,使用SPF算法计算和选择路由。

    OSPF具有如下特点:

    适应范围广:支持各种规模的网络,最多可支持几百台路由器。

    快速收敛:在网络的拓扑结构发生变化后立即发送更新报文,使这一变化在自治系统中同步。

    无自环:由于OSPF根据收集到的链路状态用最短路径树算法计算路由,从算法本身保证了不会生成自环路由。

    区域划分:允许自治系统的网络被划分成区域来管理。路由器链路状态数据库的减小降低了内存的消耗和CPU的负担;区域间传送路由信息的减少降低了网络带宽的占用。

    等价路由:支持到同一目的地址的多条等价路由。

    路由分级:使用4类不同的路由,按优先顺序来说分别是:区域内路由、区域间路由、第一类外部路由、第二类外部路由。

    支持验证:支持基于接口的报文验证,以保证报文交互和路由计算的安全性。

    组播发送:在某些类型的链路上以组播地址发送协议报文,减少对其他设备的干扰。

    下面具体来比较思科和H3C关于静态路由的配置命令。

    思科OSPF配置如下:

    router(config)#router ospf 进程号 //进入路由协议配置模式

    router(config-router)#network 接口网段 反掩码 area 区域号 //宣告网段

    show ip ospf neighbor //查看ospf邻居状态

    H3C OSPF配置如下:

    [Router] ospf 1 //启动OSPF进程

    [Router-ospf-1] area 0 //配置OSPF区域

    [Router-ospf-1-area-0.0.0.0] network 接口网段 反掩码 //在指定的接口上启动OSPF

    [Router] display ospf peer //显示OSPF邻居信息

    了解更多资讯www.jinruiedu.com

    展开全文
  • H3C路由查看命令 测试 实验二 实验目的: 实验设备: 设备的端口IP地址 设备的配置信息 MSR36-20_1的配置 MSR36-20_2的配置 MSR36-20_3的配置 前言 H3C版本HCL_V2.1.0_Setup VirtualBox版本VirtualBox-...

    目录

    前言

    实验一

    一、实验目的

    二、实验原理

    三、实验拓扑图

    路由器及交换机的IP地址配置

    主机PC的IP地址配置

    R1的配置

    R2的配置

    R3的配置

    SWA的配置

    H3C路由查看命令

    测试

    实验二

    实验目的:

    实验设备:

    设备的端口IP地址

    设备的配置信息

    MSR36-20_1的配置

    MSR36-20_2的配置

    MSR36-20_3的配置


    前言

    H3C版本 HCL_V2.1.0_Setup
    VirtualBox版本 VirtualBox-4.2.4-81684-Win
    (版本需匹配才可以正常使用H3C)

    一共做两个实验。两个基础的H3C静态路由实验。

    实验一

    一、实验目的

    1.了解静态路由的实验原理
    2.掌握静态路由的配置

    二、实验原理

    (1)静态路由定义
    要想实现全网通信,也就是网络中的任意两个节点都能通信,这就要求每个路由器的路由表中必须有到所有网段的路由。对于路由器来说,它只知道自己直连的网段,对于没有直连的网段,需要管理员人工添加到这些网段的路由。管理员人工添加到某个网段如何转发,就是静态路由。

    (2)静态路由配置
    要想实现全网络通信,必须添加路由条目。

    AR1路由器直连A、B两个网段,C、D网段没有直连,则需要添加到C、D网段的路由。
    ip route-static 到达的目标网络号 子网掩码 下一跳的路由器接口地址
    ip route-static 172.16.1.0 24 172.16.0.2

    三、实验拓扑图

    路由器及交换机的IP地址配置

    路由器 端口 端口IP地址
    R1 GE_0/1

    192.168.2.1/24

      GE_0/0

    192.168.1.1/24

    R2 GE_0/1

    192.168.3.1/24

      GE_0/0

    192.168.2.2/24

    R3 GE_0/1

    192.168.4.1/24

      GE_0/0

    192.168.3.2/24

    SWA GE_0/1

    192.168.4.2/24

      GE_0/2

    192.168.5.1/24

    主机PC的IP地址配置

    主机名 IP地址/网络掩码 网关
    PC1

    192.168.1.88/24

    192.168.1.1

    PC2

    192.168.5.88/24

    192.168.5.1

    R1的配置

    <H3C>system-view
    [H3C]interface GigabitEthernet0/0
    [H3C-GigabitEthernet0/0] ip address 192.168.1.1 255.255.255.0
    [H3C-GigabitEthernet0/0] quit
    [H3C]interface GigabitEthernet0/1
    [H3C-GigabitEthernet0/1] ip address 192.168.2.1 255.255.255.0
    [H3C-GigabitEthernet0/1] quit
    [H3C]ip route-static 192.168.3.0 24 192.168.2.2
    [H3C]ip route-static 192.168.4.0 24 192.168.2.2
    [H3C]ip route-static 192.168.5.0 24 192.168.2.2
    

    R2的配置

    <H3C>system-view
    [H3C]interface GigabitEthernet0/0
    [H3C-GigabitEthernet0/0] ip address 192.168.2.2 255.255.255.0
    [H3C-GigabitEthernet0/0] quit
    [H3C]interface GigabitEthernet0/1
    [H3C-GigabitEthernet0/1] ip address 192.168.3.1 255.255.255.0
    [H3C-GigabitEthernet0/1] quit
    [H3C]ip route-static 192.168.1.0 24 192.168.2.1
    [H3C]ip route-static 192.168.4.0 24 192.168.3.2
    [H3C]ip route-static 192.168.5.0 24 192.168.3.2
    

    R3的配置

    <H3C>system-view
    [H3C]interface GigabitEthernet0/0
    [H3C-GigabitEthernet0/0] ip address 192.168.3.2 255.255.255.0
    [H3C-GigabitEthernet0/0] quit
    [H3C]interface GigabitEthernet0/1
    [H3C-GigabitEthernet0/1] ip address 192.168.4.1 255.255.255.0
    [H3C-GigabitEthernet0/1] quit
    [H3C]ip route-static 192.168.1.0 24 192.168.3.1
    [H3C]ip route-static 192.168.2.0 24 192.168.3.1
    [H3C]ip route-static 192.168.5.0 24 192.168.4.2
    

    SWA的配置

    [H3C]vlan 10
    [H3C-vlan10]port g1/0/1
    [H3C-vlan10]int vlan 10
    [H3C-Vlan-interface10]ip address 192.168.4.2 24
    [H3C-Vlan-interface10]vlan 20
    [H3C-vlan20]port g1/0/2
    [H3C-Vlan-interface20]ip address 192.168.5.1 24
    [H3C-Vlan-interface20]quit
    [H3C]ip route-static 192.168.1.0 24 192.168.4.1
    [H3C]ip route-static 192.168.2.0 24 192.168.4.1
    [H3C]ip route-static 192.168.3.0 24 192.168.4.1
    [H3C]int g1/0/1
    [H3C-GigabitEthernet1/0/1]port link-type access
    [H3C-GigabitEthernet1/0/1]port access vlan 10
    [H3C-GigabitEthernet1/0/1]int g1/0/2
    [H3C-GigabitEthernet1/0/2]port link-type access
    [H3C-GigabitEthernet1/0/2]port access vlan 20

    H3C路由查看命令

    (1)显示全部路由:display ip routing-table
    (2)只显示静态路由:display ip route-table protocol static
    (3)删除静态路由:undo ip route-static 172.16.1.0 24 172.16.0.2

    测试

    两台PC机互相ping通

    1.路由器只关心到某个网段如何转发数据包,因此在路由器上添加路由,必须是到某个网段(子网)的路由,不能添加到某个特定地址的路由。添加到一个IP地址的路由,主机位会自动归零。

    2.路由器点到点链路的另一种路条目写法
    ip route-static 到达的目标网络号 子网掩码 下一跳的路由器接口
    ip route-static 172.16.1.0 24 E0/0

    3.trunk口用于同vlan不同交换机间通信。 

    实验二

    实验目的:

    实现多网段间的互相通信,划分数据包的路径。

    实验设备:

    设备的端口IP地址

    设备名称 端口 端口IP地址/网络掩码
    MSR36-20_1 GE 0/0 192.168.1.2/24
      GE 0/1 192.168.2.1/24
    MSR36-20_2 GE 0/0

    192.168.1.1/24

    MSR36-20_3 GE 0/1 192.168.2.2/24

    设备的配置信息

    MSR36-20_1的配置

    [H3C]int GigabitEthernet 0/0

    [H3C-GigabitEthernet0/0]ip address 192.168.1.2 24

    [H3C-GigabitEthernet0/0]quit

    [H3C]int GigabitEthernet 0/1

    [H3C-GigabitEthernet0/1]ip address 192.168.2.1 24

    [H3C-GigabitEthernet0/1]quit

    MSR36-20_2的配置

    [H3C]int GigabitEthernet 0/0

    [H3C-GigabitEthernet0/0]ip address 192.168.1.1 24

    [H3C-GigabitEthernet0/0]quit

    [H3C]ip route-static 192.168.2.0 24 192.168.1.2

    MSR36-20_3的配置

    [H3C]int GigabitEthernet 0/1

    [H3C-GigabitEthernet0/1]ip address 192.168.2.2 24

    [H3C-GigabitEthernet0/1]quit

    [H3C]ip route-static 192.168.1.0 24 192.168.2.1

    这样就可以实现全网的互通了,这些都是基础的实验。 

    展开全文
  • 华三 h3c Vlan静态路由

    2020-12-13 16:05:25
    Vlan静态路由 先把基本的配置配完,按照图上的标识,把端口划入到对应的vlan中去,此时注意如果要配置交换机端口的IP地址,有俩种方法,第一种就是我这种方法,把端口加入到vlan中去,然后配置vlan的ip地址, ...

    Vlan静态路由

     

        先把基本的配置配完,按照图上的标识,把端口划入到对应的vlan中去,此时注意如果要配置交换机端口的IP地址,有俩种方法,第一种就是我这种方法,把端口加入到vlan中去,然后配置vlan的ip地址,

    第二种就是把端口类型改为三层接口,命令为:

    [SWC]int g 1/0/24

    [SWC-GigabitEthernet1/0/24]port link-mode route

    [SWC-GigabitEthernet1/0/24]ip address 1.1.1.1 24

    另外,这里交换机之间的IP网段我进行了子网划分,节约资源,SWA的0/2(vlan40)为40.1.1.1,SWB的(van40)0/2为40.1.1.2;SWB的0/3为50.1.1.1,SWC的0/3为50.1.1.2

    基础配置完成之后,要配置静态路由实现全网联通,因为PCA可以访问的地址有很多,所以在SWA上面配置默路由比较方便,同理SWC也是如此。

    因为SWA和SWC上面都配置了默认路由,如果SWB也配置了默认路由的话,会引起路由环路,所以此时SWB应该配置具体的静态路由。

    注意:在配置静态路由时,建议不要直接指定广播类型接口作出接口,有可能会出现多个下一跳。另外静态路由是单方西的,所以必须配置有来有回。

     

    [SWA]ip route-static 0.0.0.0 0.0.0.0 40.1.1.2-----下一跳是SWB的1/0/2端口

    [SWB]ip route-static 10.1.1.0 255.255.255.0 40.1.1.1-----去往10网段的下一跳是SWA的1/0/2

    [SWB]ip route-static 30.1.1.0 255.255.255.0 50.1.1.2-----去往30网段的下一跳是SWC的1/0/3

    [SWC]ip route-static 0.0.0.0 0.0.0.0 50.1.1.1-----下一跳是SWB的1/0/3端口

    此时查看交换机的路由表(display ip routing-table),会发现路由表中存在着类型为static,优先级为60,出接口为vlan的路由表项。

    展开全文
  • H3C IPv4与ipv6静态路由

    2019-09-26 17:39:21
    IPv4和IPv6静态路由、默认路由配置 配置IPv6命令 配置链路链路接口(两种方法) 自动生成 [RTA-Ethernet0/1] ipv6 address aotu link-local 手工配置 [RTA-Ethernet0/1] ipv6 address FE80::1 link-local ...

     

    IPv4IPv6静态路由、默认路由配置

    配置IPv6命令

    配置链路链路接口(两种方法)

    自动生成

    [RTA-Ethernet0/1] ipv6 address aotu link-local

    手工配置

    [RTA-Ethernet0/1] ipv6 address FE80::1 link-local

     

    配置站点本地地址(两种形式)---两种方式的不同,实验三有详细介绍

    [RTA-Ethernet0/1] ipv6 address FE80::1/64

    [RTA-Ethernet0/1] ipv6 address FE80::1/64 eui-64

     

    配置全球单播地址(两种形式)

    [RTA-Ethernet0/1] ipv6 address FEc0::1/64

    [RTA-Ethernet0/1] ipv6 address FEc0::1/64 eui-64

    实验目录

    一.IPv4静态、默认配置

    二.IPv6地址配置、静态、默认配置

    三.配置IPv6遇到的问题

    .Ipv4静态、默认路由配置

    实验要求:

    R1配置默认路由

    R2配置静态路由

    R3配置默认路由

     

     

    上图配置IP地址

     

    给R1设置默认路由

    [r1]ip route-static 0.0.0.0 0 192.168.1.2

     

    给R2设置到1.1.1.0网络的静态路由

    [r2]ip route-static 1.1.1.1 32[高1]  192.168.1.1

    给R2设置到3.3.3.0网络的静态路由

    [r2]ip route-static 3.3.3.3 24 192.168.2.2

    给R3配置默认路由

    [r3]ip route-static 0.0.0.0 0 192.168.2.1

    查看r1.r2.r3的路由表

     

     

     

     

    实验连通性

     

        

     

     

    二.IPv6地址配置、静态、默认配置

    实验拓扑

     

     

     

    为接口配置ipv6地址

    [r1]int s0/2/0

    [r1-Serial0/2/0]ipv6 address 2000::1/64 ?

     eui-64  Use eui-64 interface identifier

     <cr>   

     

    [r1-Serial0/2/0]ipv6 address 2000::1/64

    [r1]ipv6 route-static :: 0 2000::2                    //配置ipv6默认路由

     

     

    [r2]int s0/2/0

    [r2-Serial0/2/0]ipv6 address 2000::2/64

    [r2-Serial0/2/0]int s0/2/2

    [r2-Serial0/2/2]ipv6 address 2001::1/64

     

    [r3]int s0/2/0

    [r3-Serial0/2/0]ipv6 address 2001::2/64

    [r3]ipv6 route-static 2000:: 64 2001::1             //配置ipv6的静态路由

     

    检测连通性

    [r1]ping ipv6 2001::2

      PING 2001::2 : 56  data bytes, press CTRL_C to break

        Reply from 2001::2

        bytes=56 Sequence=1 hop limit=63  time = 14 ms

        Reply from 2001::2

        bytes=56 Sequence=2 hop limit=63  time = 1 ms

        Reply from 2001::2

        bytes=56 Sequence=3 hop limit=63  time = 20 ms

        Reply from 2001::2

        bytes=56 Sequence=4 hop limit=63  time = 4 ms

        Reply from 2001::2

        bytes=56 Sequence=5 hop limit=63  time = 9 ms

     

      --- 2001::2 ping statistics ---

        5 packet(s) transmitted

        5 packet(s) received

        0.00% packet loss

        round-trip min/avg/max = 1/9/20 ms

     

     

    三.配置IPv6遇到的问题

     

    实验虽然做通了但是有点疑问-----看下图

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    同一个地址,一个复杂、一个简单,不同的表示有什么区别??

    [r1-Serial0/2/0]ipv6 address 2000::1/64 ?

     eui-64  Use eui-64 interface identifier

     <cr> 

    左面没有出现那么长的地址,是因为在配置ipv6地址时,没有添加“eui-64”参数

    [r1-Serial0/2/0]ipv6 address 2000::1/64

    而右边的出现的那么长的地址,是因为使用了“eui-64”参数

    [r1-Serial0/2/0]ipv6 address 2000::1/64 eui-64

     

     

     

    对实验的影响

    [r1-Serial0/2/0]ipv6 address 2000::1/64 eui-64

     

    当使用“eui-64”参数时,在R3上通过简单的方式来ping,是ping不通的!

     

    必须ping生成的格式!

     

     

     

     

    加“eui-64”与不加对实验影响的总结

     

    R1

    R2

    R3

    结果

     

     

     

    只能ping同生成的复杂地址

    不加

    不加

    不加

    能ping同自己配置的简单地址

     + “eui-64”

    不加“eui-64”

    不加“eui-64”

    要ping通R1必须ping复杂地址

     

    另外对路由没有影响,即使配置是使用了“eui-64”参数,在配合路由时使用的是简单的地址,路由仍然生效!!

     

     

     

     

     

     

     


    Lo口要求是32位掩码,但是在配置静态路由时,可以写成24位!

    转载于:https://www.cnblogs.com/niezhongle/p/11213313.html

    展开全文
  • 配置命令适用于H3C S12500-CMW520-R1825P01及H3C S5800-CMW520-R1211。 一、IPV6 OSPFv3协议配置 OSPFv3主要启用对IPV6协议的支持; 配置OSPFv3,必须手动指定router id,建议配置为lookback0地址。 12508配置...
  • 《轻轻松松配交换 V2.0》,新增:常用配置2篇(包含V5 /V7交换机静态路由、Track与NQA联动); 2019-5-31 《轻轻松松配交换 V1.9》,新增:常用配置2篇(包含V5 V7交换机环路检测配置方法); 2019-4-29 ...
  • H3C的由来及基础配置

    2019-09-05 08:30:31
    2、H3C与Cisco命令对比 二、H3C基础配置 1、主机名与接口配置 2、配置Telnet接入(用户名和密码双认证) 3、配置静态默认路由 4、配置VLAN与Trunk 5、配置ACL 6、配置NAT 7、配置策略路由 一、H3C的由来 H3C的...
  • 一、静态路由巡查大法梳理思路:GO1---查看全局路由表中是否有该静态路由---检查下一跳可达性---检查静态路由掩码长度。G02---查看全局路由表中是否有该静态路由---检查出接口状态---检查BFD或者...h3c> dis ip r...
  • h3c做nqa的相关配置及作用

    千次阅读 2017-09-23 22:58:24
    H3C的nqa作用主要是用来做主备路由使用,保障线路通常。一、组网需求:Server可以通过两台路由器...3、所写的静态路由关联track具体配置命令如下:1、需要在主路由器上写nqa的相关命令例如:nqa entry admin piaojiao...
  • 配置OSPF引入缺省路由

    2020-08-22 09:34:05
    OSPF 不能通过 import-route 命令从其它协议引入缺省路由,如果想把缺省路由引入到OSPF 路由区域,必须要使用下面命令配置 OSPF 引入缺省路由。 <H3C>system-view //进入系统视图 [H3C]ospf //进入OSPF视图 [H...
  • H3C S5000E-X轻轻松松配交换 V2.8 更新说明 《轻轻松松配交换 V2.8》,新增:常用配置1篇(V7交换机基本QINQ配置方法) 2019-1-17 《轻轻松松配交换 V2.7》,新增:常用配置2篇(包含V5交换机和V7交换机...
  • 11-IPv4与ipv6静态路由.doc 12-IPv4和IPv6负载均衡.doc 13.0-RIP路由初始化.doc 13.1-RIP实验大集合.doc 14.1-OSPF实验大集合(IPv4).doc 14.2-OSPF实验大集合(IPv6).doc 15.0-IS-IS基础配置.doc 15.1-IS-IS实验大...
  • msr30-40,s3600, 命令:ping ,tracert,debug, 配置端口ip地址 interface gigabitethernet 0/1 ip add 192.168.0.1 24 ping命令设置发送报文数:...静态路由出入端口: ip route-static 192.168.2.0 255.255.255.0 192
  • Route-policy控制路由

    千次阅读 2018-08-07 12:19:42
    ·掌握如何在路由器上配置RIP协议引入静态和OSPF路由 ·掌握如何在路由器上配置OSPF协议引入静态和 RIP路由 ...[H3C]sys RTA [RTA]int g0/0 [RTA-GigabitEthernet0/0]ip add 10.0.1.1 24 [RTA-GigabitEther...
  • 扩展访问控制列表配置命令 配置TCP/UDP协议的扩展访问列表: rule {normal|special}{permit|deny}{tcp|udp}source {|any}destination |any} [operate] 配置ICMP协议的扩展访问列表: rule {normal|special}{...
  • NQA作用

    2018-04-27 10:33:47
    H3C的nqa作用 主要是用来做主备路由使用,保障线路通常。 一、组网需求: Server可以通过两台路由器到达对端 线路保证冗余及断线自动切换 二、实际配置nqa nqa主要分三个步骤 1、配置nqa检测。 2、配置track与nqa的...
  • 介绍有关T C P拦截的所有配置和调试命令。在 T C P拦截这一部分,最后给出几个使用该特性的 示例。之后,介绍 N AT的整体概念,包括 N AT的引入、 N AT特性以及如何将其用于网络中。 最后将讨论有关N AT的配置和...
  • 09年下半年网管上午

    2011-12-22 17:49:50
    c)中,配置lan接口的是 (1) ,配置wan接口的是 (2) 。答案:(1)(a) 或图4-2(a) (2)(b)或 图4-2(b) 为保证内网 PC 可以访问 Internet,图 4-3 所示 wan 接口的地址池中,起始地址为 (3) ...
  • 精易模块[源码] V5.15

    2015-03-21 22:03:37
    MD5: 3C01272B9E2DAFDEF08D20C191E3C265 精易模块 V5.12 what’s new:(20150108) 1、删除“IP_取外网IP”与 网页_取外网IP()功能重复命令,感谢易友【67564226】反馈。 2、修正“正则元字符转义”子程序,对应...
  • 生成的配置过程如UNIX中newconfig命令;DOS中config.sys文件;维护由系统管理员负责。 操作系统的五大类型是批处理操作系统、分时操作系统、实时操作系统、网络操作系统、分布式操作系统。 多道程序设计:即...
  • 2.1.5 vim 配置文件....................................................................................................... .. 2 . 1 . 6 使用其他编辑器......................................................

空空如也

空空如也

1 2
收藏数 23
精华内容 9
关键字:

h3c静态路由配置命令