精华内容
下载资源
问答
  • 中小型企业网络架构拓扑图搭建过程

    万次阅读 多人点赞 2020-04-04 11:44:27
    创建地址池 租约: 50% 发的是单播 默认3天,剩余1.5,发一个更新租约 的request报文,续约后变为1.5+3=4.5 87.5% 发的广播,发给网络中的所有DHCP服务器一个光 的request报文 SW1 u t m system-view sys SW1 dhcp ...

    在这里插入图片描述
    单臂路由 有缺陷 三层交换机

    1.创建vlan 原则:所有交换机创建一模一样的vlan
    2.把接口类型做好 原则:只在交换机的接口配置,交换机之间一定是trunk,交换机与 其他设备一定是aceess(单臂路由和无线设备除外)
    3.做MSTP 原则:所有MSTP配置必须一模一样(优先级的命令除外)
    4.网关
    5.路由
    6.DHCP 全局:网关和DHCP服务器是同一台设备
    网关处开全局模式,创建地址池
    接口:几乎不用
    中继:网关和DHCP服务器不是同一台设备且不是同一个网段
    中继:网关在哪里,哪里做中继命令(2条命令)
    服务器:服务器IP地指处开全局,创建地址池
    租约: 50% 发的是单播 默认3天,剩余1.5,发一个更新租约 的request报文,续约后变为1.5+3=4.5
    87.5% 发的广播,发给网络中的所有DHCP服务器一个光 的request报文

    SW1
    u t m
    system-view
    sys SW1
    dhcp enable
    vlan batch 6 10 20 30 40
    port-group group-member g0/0/1 to g0/0/5
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    quit
    stp instance 1 priority 0
    stp instance 2 priority 4096
    interface vlanif 10
    ip add 192.168.10.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    interface vlanif 20
    ip add 192.168.20.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    return

    SW2
    u t m
    system-view
    dhcp enable
    sys SW2
    vlan batch 6 10 20 30 40
    port-group group-member g0/0/1 to g0/0/5
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int g0/0/6
    port link-type access
    port default vlan 6
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    quit
    stp instance 1 priority 4096
    stp instance 2 priority 0
    interface vlanif 30
    ip add 192.168.30.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    interface vlanif 40
    ip add 192.168.40.254 24
    dhcp select relay
    dhcp relay server-ip 192.168.6.2
    interface vlanif 6
    ip add 192.168.6.1 24
    return

    SW3
    u t m
    system-view
    sys SW3
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 10
    int e0/0/4
    port link-type access
    port default vlan 20
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    SW4
    u t m
    system-view
    sys SW4
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 10
    int e0/0/4
    port link-type access
    port default vlan 30
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    SW5
    u t m
    system-view
    sys SW5
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 20
    int e0/0/4
    port link-type access
    port default vlan 40
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration
    SW6
    u t m
    system-view
    sys SW6
    vlan batch 6 10 20 30 40
    port-group group-member e0/0/1 e0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    quit
    int e0/0/3
    port link-type access
    port default vlan 40
    int e0/0/4
    port link-type access
    port default vlan 30
    quit
    stp region-configuration
    region-name 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    DHCP
    u t m
    sys
    sys DHCP
    dhcp enable
    interface g0/0/0
    ip add 192.168.6.2 24
    dhcp select global
    quit
    ip pool p10
    network 192.168.10.0 mask 24
    gateway-list 192.168.10.254
    ip pool p20
    network 192.168.20.0 mask 24
    gateway-list 192.168.20.254
    ip pool p30
    network 192.168.30.0 mask 24
    gateway-list 192.168.30.254
    ip pool p40
    network 192.168.40.0 mask 24
    gateway-list 192.168.40.254
    quit
    ip route-static 192.168.0.0 16 192.168.6.1
    return

    展开全文
  • 企业网络拓扑图简述20200805

    千次阅读 2020-08-05 20:34:34
    下图为2020年8月5日下午课上所画的企业网络拓扑图。图右模拟场景为一中型企业,主要网络设备有pc端计算机、服务器、无线设备、接入层交换机、汇聚层交换机、以及核心路由器。其中企业pc端用户数百个,由三台接入层...
     下图为2020年8月5日下午课上所画的企业网络拓扑图。图右模拟场景为一中型企业,主要网络设备有pc端计算机、服务器、无线设备、接入层交换机、汇聚层交换机、以及核心路由器。其中企业pc端用户数百个,由三台接入层交换机接入进行数据接入,再用两台汇聚层交换机进行数据的汇聚,最后由两台核心级路由器进行快速的转发。其优点在于在其核心层以及汇聚层分别使用两台交换机和路由器,使其网络结构更加安全,冗余;缺点在于其成本较高。图左为一小型企业网络拓扑图,由一台交换机进行接入,再使用一台路由器进行网络接入。其优点在于结构简单,易维护,成本低,缺点为单点故障,安全性低。
    

    在这里插入图片描述

    展开全文
  • 大中型网络架构,各种拓扑图,仅供参考
  • 内含河南大学,银行,等多企业网络拓扑图,详细讲解企业内部网络结构
  • 网络拓扑图企业网络设计基本流程认识网络常见的路由协议分类:常见路由协议类型:网络层次结构:TCP/IP协议网络拓扑图企业网络设计基本流程网络设计基本原则网络拓扑设计原则网络设计的方法和思路网络架构安全域和...

    认识网络

    构建网络的目的:就是为了相互之间能够通信,而通信的目的就是为了传达信息。(信息传达和信息接收的安全性。)
    企业网络的目的:是作为企业业务的支撑平台,是企业的信息中枢。

    • 网络:被称为计算机网络,它是计算机技术和通信技术相结合的产物。
    • 节点:这里的节点就是一个个的机房以及机房里面的设备(路由器、交换机、防火墙、PC…)
    • 链路:就是有线和无线,有线:网络、光纤、电缆等等…

    网络中常见的协议:

    • VLAN技术:虚拟局域网;
    • STP技术:生成树协议;
    • VRRP技术:虚拟路由冗余协议;
    • VPN:虚拟专用网络。
      在这里插入图片描述

    常见的路由协议分类:

    • 静态:设置好路由器和主机并将路由信息固定的一种方法。
    • 动态:路由协议在进行过程中自动的设置路由控制信息的一种方法

    静态路由通常手工配置,网络发生故障时需要管理员手动修改,动态路由协议可以在由其他路可达目的主机的前题下自动学习路由,绕过故障节点。
    在这里插入图片描述

    常见路由协议类型:

    一、内部网关协议:
    内部网关协议(IGP:Interior Gateway Protocol),适用于单个ISP的统一路由协议的运行,一般由一个ISP运营的网络位于一个AS(自治系统)内,有统一的AS number(自治系统号),用来处理内部路由。


    RIP、IGRP(Cisco私有协议)、EIGRP(Cisco私有协议)、OSPF、IS-IS等都是内部网关协议。


    1、RIP(Routing Information Protocol):路由信息协议。
    是一种比较简单的内部网关协议,主要用于规模较小的网络,比如校园网以及结构较简单的地区性网络。对于更为复杂的环境和大型网络,一般不使用RIP。
    RIP是一种基于距离矢量(Distance-Vector)算法的协议,它通过UDP报文进行路由信息的交换,使用的端口号为520。其使用跳数来衡量到达目的地址的距离,为了限制收敛时间,RIP规定度量值(该值等于从本网络到达目的网络间的路由器数量)为0到15之间的整数,大于等于16的跳数将会定义为网络或主机不可达,因此RIP不适合大型网络。
    RIP有两个版本:RIP V1(有类别路由协议)和RIP V2(无分类路由协议)。


    2、IGRP(Interior Gateway Routing Protool):内部网关路由协议。
    属于Cisco的私有协议,最大跳数默认为100,现已被Cisco独立开发的EIGRP协议取代。


    3、OSPF(Open Shortest Path First):开放式最短路径优先协议。
    属于链路状态路由协议,OSPF提出了“区域(area)”的概念,每个区域中所有路由器维护着一个相同的链路状态数据库 (LSDB),其使用链路状态数据库,通过最短生成树算法(SPF算法)计算得到路由表,因此其收敛速度较快。目前OSPF协议在各种网络中广泛部署,目前针对IPv4协议使用的是OSPF Version 2(RFC2328);针对IPv6协议使用OSPF Version 3(RFC2740)。


    4、IS-IS(Intermediate System-to-Intermediate System):中间系统到中间系统路由协议。
    属于链路状态路由协议。与OSPF协议相似,其使用最短路径优先SPF(Shortest Path First)算法进行路由计算。

    二、域间路由协议
    BGP(Border Gateway Protocol):边界网关协议。
    为了维护各个ISP的独立利益,标准化组织制定了ISP间的路由协议BGP,其用来处理各ISP之间的路由传递。
    与内部网关协议不同的是,其不在于发现和计算路由,而在于控制路由的传播和选择最佳路由。

    网络层次结构:

    传统的网络层次结构是OSI七层模型,但在现实中采用的是TCP/IP协议。
    (一)OSI七层模型
    (1)物理层
    设备之间原始数据传输,数据格式比特流。
    (2)数据链路层
    将原始比特流转换成逻辑传输数据,mac地址寻址,数据格式帧。
    (3)网络层
    最复杂的一层,通信子网最高层。通过路由算法提供最佳传输路径。数据格式IP数据包。
    数据链路层解决同一网络节点间数据传输,网络层解决不同子网间通信。
    (4)传输层
    拆分数据包,提供端对端不同主机用户进程间传输数据,提供可靠或不可靠传输及流量控制,是连接通信子网和资源子网的桥梁。数据格式TCP数据包。
    (5)会话层
    不同机器用户间建立或解除会话关系。
    (6)表示层
    数据的表示方式(格式处理及编码转换)及特定功能实现(加解密、解压缩等)。
    (7)应用层
    向用户提供服务,完成用户在网络上想完成的工作。如上网、发邮件、下载ftp等。

    TCP/IP协议

    (1)链路层
    包括物理层和数据链路层链路层是通过mac地址传输数据的。
    (2)网络层
    包括多种协议。
    IP协议:通过路由选择将数据封装后交给链路层。
    ICMP协议:用于主机和路由器直接传递控制消息,常用的ping就是用这个协议。
    ARP协议:是正向地址解析协议,通过IP查找mac地址。
    RARP协议:是反向地址解析协议,通过mac地址查找IP。
    (3)传输层
    TCP协议:传输控制协议,面向连接的、可靠的、基于IP的传输层协议。
    UDP协议:用户数据报协议,提供面向事务的简单不可靠信息传送协议。
    (4)应用层
    FTP协议:文件传输协议,用于文件的上传下载。
    Telnet协议:用户远程登录服务。
    DNS协议:域名解析协议,提供域名到IP的解析。
    SMTP协议:简单的邮件传送协议,用于控制信件的发送中转。
    NFS协议:网络文件系统,用于不同主机间文件共享。
    HTTP协议:超文本传输协议,用于实现互联网访问功能。

    模型结构:

    在这里插入图片描述

    网络拓扑图

    • 拓扑简单的的说就是几何结构,是指网络中各个站点相互连接的形式,主要有总线型拓扑、星型拓扑、环形拓扑以及混合型拓扑。

    网络拓扑结构类型:

    1. 总线拓扑
      总线拓扑结构是将网络中的所有设备通过相应的硬件接口直接连接到公共总线上,结点之间按广播方式通信,一个结点发出的信息,总线上的其它结点均可“收听”到。
      优点:结构简单、布线容易、可靠性较高,易于扩充,是局域网常采用的拓扑结构。
      缺点:所有的数据都需经过总线传送,总线成为整个网络的瓶颈;出现故障诊断较为困难。最著名的总线拓扑结构是以太网(Ethernet)。
      在这里插入图片描述

    1. 星型拓扑
      每个结点都由一条单独的通信线路与中心结点连结。
      优点:结构简单、容易实现、便于管理,连接点的故障容易监测和排除。
      缺点:中心结点是全网络的可靠瓶颈,中心结点出现故障会导致网络的瘫痪。
      在这里插入图片描述

    3.环形拓扑
    各结点通过通信线路组成闭合回路,环中数据只能单向传输。
    优点:结构简单、容易实现,适合使用光纤,传输距离远,传输延迟确定。
    缺点:环网中的每个结点均成为网络可靠性的瓶颈,任意结点出现故障都会造成网络瘫痪,另外故障诊断也较困难。最著名的环形拓扑结构网络是令牌环网(Token Ring)
    在这里插入图片描述


    1. 树型拓扑
      是一种层次结构,结点按层次连结,信息交换主要在上下结点之间进行,相邻结点或同层结点之间一般不进行数据交换。
      优点:连结简单,维护方便,适用于汇集信息的应用要求。
      缺点:资源共享能力较低,可靠性不高,任何一个工作站或链路的故障都会影响整个网络的运行。
      在这里插入图片描述

    5.网状拓扑
    又称作无规则结构,结点之间的联结是任意的,没有规律。
    优点:系统可靠性高,比较容易扩展,但是结构复杂,每一结点都与多点进行连结,因此必须采用路由算法和流量控制方法。目前广域网基本上采用网状拓扑结构。
    缺点:由于结点也多个结点连接,故结点的路由选择由选择和流量控制难度大,管理软件复杂,硬件成本高。
    在这里插入图片描述
    广域网与局域网所使用的网络拓扑结构有所不同。广域网多采用分布式或树型结构,局域网常用总线型、环型、星型或树型结构

    企业网络设计基本流程

    网络设计基本原则

    网络设计的基本原则
    可靠性:要求网络在发生一定的故障时,仍然能够保证承载的业务不中断
    可扩展性:要求网络能够支持不断增加的业务量。
    可运营性:保证网络的运行和维护
    可管理性:要求网络提供标准的管理手段,便于监控和维护
    成本问题:综合考虑,选择性价比高的网络设计方案。

    网络拓扑设计原则

    在这里插入图片描述

    模块化设计原则:根据所承载的功能区域来划分不同的模块;
    层次化设计原则:根据企业需求设计网络,选用二层,三层网络模型;
    性价比:
    高性能:
    可靠性:
    安全性:

    网络设计的方法和思路

    • 模块化的设计方法、层次化的设计方法

    层次化设计的优点:
    节约成本、容易理解、有利于模块化、有利于故障隔离;
    模块化设计优点:
    将一个企业网络按照功能的不同,分为了不同的模块,不同的模块有不同的需求和特点;
    每一个模块相对独立,可以单独构建这个模块里面需要的一些结构,模块之间相互没有影响;
    便于扩容、管理,不同模块有不同的安全策略;在这里插入图片描述
    DMZ:非军事区域(官方称呼),互联网服务区或者互联网隔离区(民间称呼);


    模块的安全等级:
    安全等级由低到高:
    陌生访客–>分支机构–>DMZ–>数据中心/服务器群–>管理中心;
    分支机构一般有固定的地址;
    管理中心存储着高权限的账号,一旦被入侵,对整个网络危害最大;

    • 自上而下的设计思路和自下而上的设计思路
      在这里插入图片描述

    • 根据场景设计合适的方案
      在这里插入图片描述

    网络架构

    • 三层网络架构:接入层–>汇聚层–>核心层;
      适用场景–通常用于大型网络的构建,需要通过IP路由实现跨网段的通讯;

    • 二层网络架构:接入层–>汇聚层或者核心层;
      它的组网能力是非常有限的,一般用于中小型局域网;

    一般企业网络使用三层网络结构:

    • 接入层:终端的接入、访问控制;
    • 汇聚层:路由汇聚、流量收敛;
    • 核心层:高速数据转发、要求高可靠性。

    安全域和边界:

    企业网络的经典结构就是基于安全域的网络结构,一般包括企业数据中心,企业办公内网,DMZ区,广域网和Internet几个部分。

    企业网络各个区域之间通信受到限制,区域内部通信多不进行限制。

    为了保障企业的信息安全,我们应该从哪几个方面入手?

    1、终端计算机

    2、互联网出入口

    3、广域网出入口

    4、公司对外发布服务的DMZ服务器

    5、VPN和类似远程连接设备。

    上述五个方面,基本涵盖了公司网络边界的几个方面。

    对公司网络边界进行防护,仅仅是做好公司信息安全防护工作的第一步。

    那么接下来我们应该考虑什么呢?

    当然是如果上述五个方面被黑客攻陷了,那么我们还拿什么进行防护?

    这就涉及到了黑客攻击的几个步骤,黑客提权或者拿到设备权限之后,第一件事就是想知道我们的内网是什么样子的。

    那么,他们一定会进行内网扫描。而网络扫描这种事情,又是一种特征非常明显的网络攻击行为,非常易于识别。

    这就要求我们企业安全管理人员要重点关注内网扫描,做好被攻击后的进一步防护工作。

    由于上述5个方面易于被黑客攻陷,易于产生信息安全问题,那么我们就不能让这些区域可直接访问我们的核心资源。因此,需要进行安全域划分。同时,我们也要在各个高风险安全域的核心交换机上部署IDS,做好网络安全监控,并且在安全域出入口处部署防火墙,针对IDS产生的报警及时切断相关网络访问路径,保障损失的最小化。

    于是,企业网络安全的基本中的基本要求就是根据面临的风险,划分安全域,在安全域之间部署防火墙,在每个安全域内部署IDS。这也是我个人理解的网络安全域划分的本质安全需要。

    设计流程

    在这里插入图片描述

    • 对于小企业来说,一般参照到IP连通这个步骤。
    • 大型企业基本上可以完全参照这个流程来。

    1 . 规划
    组织策略:考虑公司的组织架构,就是公司有哪些部门。

    • 业务策略:就是公司当前的业务以及公司未来需要发展的业务。比如教育行业,物流行业等等。
    • 财务决策:公司的财务情况,能拿多少钱出来,预算是多少。

    2 . 简要的网络设计方案。

    • 设计:根据业务需求客户需要规划出网络拓扑图。
    • 需求分析:就是根据组织策略,来考虑不同部门的网络配置情况。
    • 项目计划:考虑项目进度(开始时间、完成时间)、成本多少、质量达到什么标准。
    • 设备选购:需要购买哪些设备。CPU 内存,吞吐量够不够,支持哪些协议,带机数量不同的接入,他们的流量是不一样的。

    3 . 详细设计的网络方案

    • 满足企业用户现阶段技术和业务上的需求。

    4 . 实施:根据需求规划网络

    • 新建网络:根据详细设计方案,直接进行落实。
    • 主要点:验证/测试整个网络是否满足企业在业务和技术上需求。
    • 对现有网络的改造:割接

    5 . 运营:

    • 保障企业网络业务能够持续、健康的运作。
    • 主要是对设备/系统运行进行主动监控。
    • CPU 内存 带宽 链路带宽比例。

    这些指标达到一定的预警范围,我们就需要对它进行处理(80-85%)。
    考虑是否进行扩容,
    可用性、可靠性、安全性

    6 . 提升:

    • 主要是围绕规划中的组织策略来的,针对的是企业网络在运营过程中遇到的问题。

    为什么要分析用户需求

    用户需求:即企业需求(这里的用户指的就是企业);

    IT应用:实际上就是将给我们的业务需求转换成我们的技术需求。(主要是由架构师和售前做的);

    如何分析用户需求:

    1. 识别网络现状:
      通过查看现有网络的文档;
      通过咨询相关岗位的负责人;
      通过网络监听;
      通过流量分析;
    2. 定义组织目标:
      提升客户满意度;
      扩展业务类型,增加服务项目;
      增强竞争力;
      削减开支;
    3. 组织限制:
      政策、预算、人力资源、技术资源、时间安排等客观因素;
    4. 定义技术目标:
      扩大网络容量;
      简化网络管理;
      提升网络安全;
      增强网络可靠性;
    5. 定义技术限制:
      设备限制,设备能否达到技术要求,
    展开全文
  • 什么是网络拓扑图 网络拓扑图就是指用传输媒体互联各种各样机器设备的物理布局,即哪...网络拓扑图往往是由网络拓扑图软件绘制,网络拓扑图软件可以让使用者方便地对网络拓扑图进行添加,修改、保存、复制等操作。这...

    什么是网络拓扑图

    网络拓扑图就是指用传输媒体互联各种各样机器设备的物理布局,即哪种方法把互联网中的电子计算机等机器设备相互连接。拓扑绘画出云端服务器、服务中心的互联网配备和相互之间的联接。互联网的拓扑结构有很多种多样,关键有星形构造、环型构造、总线

    在线制图 网络拓扑图

    用网络拓扑图软件的优点和缺点

    网络拓扑图往往是由网络拓扑图软件绘制,网络拓扑图软件可以让使用者方便地对网络拓扑图进行添加,修改、保存、复制等操作。这些事情如果是由手工绘制来操作的话,会麻烦许多。但对于网络拓扑图软件来说,都不是问题。另外对于有条件上网的使用者来说,以软件形式存在的网络拓扑图无疑能够更方便地与他人共享。

    网络拓扑图分类

    星型拓扑结构

    星型结构是最古老的一种连接方式,大家每天都使用的电话属于这种结构。星型结构是指各工作站以星型方式连接成网。网络有中央节点,其他节点(工作站、服务器)都与中央节点直接相连,这种结构以中央节点为中心,因此又称为集中式网络。

    这种结构便于集中控制,因为端用户之间的通信必须经过中心站。由于这一特点,也带来了易于维护和安全等优点。端用户设备因为故障而停机时也不会影响其它端用户间的通信。同时它的网络延迟时间较小,传输误差较低。但这种结构非常不利的一点是,中心系统必须具有极高的可靠性,因为中心系统一旦损坏,整个系统便趋于瘫痪。对此中心系统通常采用双机热备份,以提高系统的可靠性。

    在线制图 网络拓扑图

    环型网络拓扑结构

    环型结构在LAN中使用较多。这种结构中的传输媒体从一个端用户到另一个端用户,直到将所有的端用户连成环型。数据在环路中沿着一个方向在各个节点间传输,信息从一个节点传到另一个节点。这种结构显而易见消除了端用户通信时对中心系统的依赖性。

    环行结构的特点是:每个端用户都与两个相临的端用户相连,因而存在着点到点链路,但总是以单向方式操作,于是便有上游端用户和下游端用户之称;信息流在网中是沿着固定方向流动的,两个节点仅有一条道路,故简化了路径选择的控制;环路上各节点都是自举控制,故控制软件简单;由于信息源在环路中是串行地穿过各个节点,当环中节点过多时,势必影响信息传输速率,使网络的响应时间延长;环路是封闭的,不便于扩充;可靠性低,一个节点故障,将会造成全网瘫痪;维护难,对分支节点故障定位较难。

    总线拓扑结构

    总线结构是使用同一媒体或电缆连接所有端用户的一种方式,也就是说,连接端用户的物理媒体由所有设备共享,各工作站地位平等,无中心节点控制,公用总线上的信息多以基带形式串行传递,其传递方向总是从发送信息的节点开始向两端扩散,如同广播电台发射的信息一样,因此又称广播式计算机网络。各节点在接受信息时都进行地址检查,看是否与自己的工作站地址相符,相符则接收网上的信息。
    使用这种结构必须解决的一个问题是确保端用户使用媒体发送数据时不能出现冲突。在点到点链路配置时,这是相当简单的。如果这条链路是半双工操作,只需使用很简单的机制便可保证两个端用户轮流工作。在一点到多点方式中,对线路的访问依靠控制端的探询来确定。然而,在LAN环境下,由于所有数据站都是平等的,不能采取上述机制。对此,研究了一种在总线共享型网络使用的媒体访问方法:带有碰撞检测的载波侦听多路访问,英文缩写成CSMA/CD。
    这种结构具有费用低、数据端用户入网灵活、站点或某个端用户失效不影响其它站点或端用户通信的优点。缺点是一次仅能一个端用户发送数据,其它端用户必须等待到获得发送权;媒体访问获取机制较复杂;维护难,分支节点故障查找难。尽管有上述一些缺点,但由于布线要求简单,扩充容易,端用户失效、增删不影响全网工作,所以是LAN技术中使用最普遍的一种。

    在线制图 网络拓扑图

    分布式拓扑结构

    分布式结构的网络是将分布在不同地点的计算机通过线路互连起来的一种网络形式。
    分布式结构的网络具有如下特点:由于采用分散控制,即使整个网络中的某个局部出现故障,也不会影响全网的操作,因而具有很高的可靠性;网中的路径选择最短路径算法,故网上延迟时间少,传输速率高,但控制复杂;各个节点间均可以直接建立数据链路,信息流程最短;便于全网范围内的资源共享。缺点为连接线路用电缆长,造价高;网络管理软件复杂;报文分组交换、路径选择、流向控制复杂;在一般局域网中不采用这种结构。

    树型拓扑结构

    树型结构是分级的集中控制式网络,与星型相比,它的通信线路总长度短,成本较低,节点易于扩充,寻找路径比较方便,但除了叶节点及其相连的线路外,任一节点或其相连的线路故障都会使系统受到影响。

    网状拓扑结构

    在网状拓扑结构中,网络的每台设备之间均有点到点的链路连接,这种连接不经济,只有每个站点都要频繁发送信息时才使用这种方法。它的安装也复杂,但系统可靠性高,容错能力强。有时也称为分布式结构。

    蜂窝拓扑结构

    蜂窝拓扑结构是无线局域网中常用的结构。它以无线传输介质(微波、卫星、红外等)点到点和多点传输为特征,是一种无线网,适用于城市网、校园网、企业网。

    混合拓扑结构

    混合拓扑结构是由星型结构或环型结构和总线型结构结合在一起的网络结构,这样的拓扑结构更能满足较大网络的拓展,解决星型网络在传输距离上的局限,而同时又解决了总线型网络在连接用户数量上的限制。
    混合拓扑的优点:应用相当广泛,它解决了星型和总线型拓扑结构的不足,满足了大公司组网的实际需求。扩展相当灵活。速度较快:因为其骨干网采用高速的同轴电缆或光缆,所以整个网络在速度上应不受太多的限制。缺点是:由于仍采用广播式的消息传送方式,所以在总线长度和节点数量上也会受到限制。同样具有总线型网络结构的网络速率会随着用户的增多而下降的弱点。较难维护,这主要受到总线型网络拓扑结构的制约,如果总线断,则整个网络也就瘫痪了。

    用在线工具制作例子效果图

    在线制图 网络拓扑图

    网络拓扑图的制作

    创建网络拓扑图的方式有很多,若选择在线绘制网络拓扑图,推荐使用在线制图网站: freedgo Design。 freedgo Design ,其访问地址为: https://www.freedgo.com 。freedgo design 在线制图网站是一款多类型的图形图表设计软件,软件内容自带丰富的几何图形模板,可以用于绘制专业的网络拓扑图,泳道图、影响图、SDL图、审批图、会计网络拓扑图等,提供丰富的网络图例子,上手更轻松

    在具体的网络拓扑图中需要把业务逻辑分解成更小、更具体的步骤。 然后,考虑流程中任何可能的异常,如果是,为备选路径添加决策节点。
    继续重复这个过程,直到你达到了每个人都能完全理解的简单步骤。

    现在,一起开看如何使用Freedgo Design制好看的网络拓扑图。

    步骤一:

    访问 https://www.freedgo.com ,先注册一个用户,注册成功后,登录到 首页

    步骤二:

    访问 https://www.freedgo.com/draw_index.html ,进入制图页面,或者从 首页 页面 顶部菜单点击开始制作

    进入制图页面后 点击 文件 -> 从类型中新建 -> 网络架构 -> 网络图

    在线制图 网络拓扑图

    或者点击图例,在图例中找到 网络架构 -> 网络图,选择一个类似的图例进行改动

    在线制图 网络拓扑图

    步骤三:

    从左侧符号栏拖拽合适的几何图形至画布,松手后,椭圆图形就被固定画布上,双击几何图形,还可输入文字。当鼠标放置在图形上时,
    图形四周会显示“小三角形”,是为了方便用户点击后能够快速生成新的图形。

    在线制图 网络拓扑图

    在线制图 网络拓扑图

    步骤四:

    软件提供多种连接样式,在该网络拓扑图中,可以选择普通的直角连接线。在连接线上,还可以输入文字做进一步的说明。

    在线制图 网络拓扑图

    步骤五:

    网络拓扑图制作工具拥有一套功能丰富的样式,用户可以对封闭图形进行单色填充、渐变填充、文本大小位置颜色调整。经过图案填充的网络拓扑图,颜值提升了不少。
    在线制图 网络拓扑图

    步骤六:

    按照绘图要求,一步一步的地完成网络拓扑图的绘制。最终完成了整幅的绘制任务。
    在线制图 网络拓扑图

    [注]: 在线网络拓扑图设计 如何在线制图网络拓扑图 网络拓扑部署制作 怎么画网络拓扑图 网络拓扑工具 物理网络部署图 网络拓扑图与部署架构图 基本网络图制作 网络拓扑图制作

    更多基本流程的例子 请参考 [图例] (https://www.freedgo.com/showcase.html) 或者直接访问 : https://www.freedgo.com/showcase.html

    转载于:https://blog.51cto.com/486221/2403078

    展开全文
  • 网络拓扑架构图

    千次阅读 2021-01-03 18:15:37
    阿里云应用网络拓扑图 云应用网络架构是指建立在可编程的基础设施之上, 基于统一的运行管理平台, 按需的分配资源 的网络架构。云网络架构在物理链路、主机网络、网关、控制器四个纬度上全面升级,大大提高了整体网络...
  • 思科网络拓扑图

    2019-01-12 01:15:50
    55张思科网络拓扑图,总有一款是你要找的! 这些资料均为互联网收集的,是当时在做网络工程课程设计的时候查找到的,这些资料质量都还不错,对于网络设计有一定的参考价值,可以下载看看。(如果有侵权请联系删除)
  • AR1 u t m sys sys AR1 int g0/0/0 ip add 192.168.1.2 24 int g0/0/1 ip add 192.168.2.1 24 quit ip route-static 192.168.10.0 24 192.168.1.1 ip route-static 192.168.20.0 24 192.168.1.1 ...
  • 各种网络拓扑图,包括国内的很多大学的校园网拓扑图!!很有用的吆!
  • 大型企业网的拓扑图

    2013-10-06 13:11:51
    涵盖网络整体拓扑图和协议,可以帮助学习网络协议以及刚刚接触网络拓扑结构的同学更好的了解
  • 100张网络拓扑结构图

    2010-03-12 16:17:09
    100张网络拓扑结构图 100张网络拓扑结构图 100张网络拓扑结构图
  • 网络拓扑图源码

    2015-03-23 17:04:33
    网络拓扑图 后期的做了相应的改善和修改! 这里是修改后的源码
  • 网站完整架构拓扑图 株洲传承品牌网络传媒有限公司 作者汤蓉 (toro) 第 2 页共15 页 不一样的电子商务 1网站前台整体框架 首页 企业 品牌 企业列表 品牌列表 网站架构拓扑图 美 商 网 品牌商城看 代 理 图片 新品...
  • visio画的网络拓扑图(我们企业的)

    热门讨论 2011-12-26 13:41:33
    用visio画的全厂网络拓扑图,有感兴趣的可以作参考。
  • 网络拓扑图是指由网络节点设备和通信介质构成的网络结构图。 什么是网络拓扑架构网络拓扑结构是指用传输媒体互联各种设备的物理布局,就是用什么方式把网络中的计算机等设备连接起来。 网络拓扑结构有哪些? ...
  • 前言计算机网络拓扑结构是引用拓扑学中研究与大小,形状无关的点、线关系的方法。把网络中的计算机和通信设备抽象为一个点,把传输介质抽象为一条线,由点和线组成的几何图形就是计算机网络拓扑结构网络拓扑...
  • NETWORK06 - 企业网络拓扑图

    千次阅读 2018-06-01 22:09:23
    为路由器与三层交换机相连的接口配置 ip 配置动态路由协议,使所有内网互通。 在 ms1 中开启 ospf 动态路由,并宣告直连网段 Switch(config)#routerospf 1 Switch(config-router)#network192.168.10.0 0.0.0.255...
  • 企业网络建设拓扑

    千次阅读 2019-09-24 10:42:56
    1.通过实验了解企业网络建设拓扑方案 2.加深熟悉在建设中运用到的网络协议 3.锻炼自己的排错能力 二、实验器材 公司内部: 1.接入层:二层交换机x4 2.汇聚层:三层交换机x2 3.核心层:三层交换机x2 4.边界:路由器x2...
  • 企业网络拓扑设计

    2019-01-08 17:00:09
    其中包含详细的网络结构设计和拓扑图PKT文件,详细的源代码。
  • 拓扑图是一种量化图,是由专题地图演变而成的,这种图形具有地图与统计图之间的过渡型特点。 拓扑图是从拓扑学引用的名称,拓扑学是几何学中一个分支,它是研究几何图形在连续改变形状时还能保留不变的一些特点,它...
  • 小型企业网络拓扑结构设计

    万次阅读 多人点赞 2019-01-08 16:52:39
    小型企业网络拓扑结构设计 一、设计目的 企业局域网的最终目标是建设整个单位的互联、统一、高效、实用、安全的局域网络,近期可支持上百个,远期至少可支持上午个并发用户,提供广泛的资源共享(包括硬件、软件和...
  • 为楼或房间画拓扑结构图,一楼是网管室,楼层分开画,房间采用星型结构,联网所需设备,数量,组网双绞线线序,IP地址分配,接internet网,防火墙结构
  • 您可能感兴趣的文章: IT基础架构规划方案一(网络系统规划) 餐饮行业解决方案之客户分析流程 餐饮行业解决方案之采购战略制定与实施流程 餐饮行业解决方案之业务设计流程 供应链需求调研CheckList 企业应用之性能...
  • H3C网络方案拓扑图模板汇总集
  • 企业内部网络,使用了汇聚层备份技术,提高网络可用性。为了充分利用设备,我们在汇聚层使用负载均衡。网络综合实验 网络拓扑图 vrrp mstp
  • 某部门内部网络拓扑图

    千次阅读 2020-03-13 11:53:06
    title: “某部门内部网络拓扑图” date: 2019-11-23 lastmod: 2019-11-23 tags: [“运维”,“网络拓扑”,“ESXi”] categories: [“运维”] 描述 某公司某部门内部的网络拓扑图示例。包含ESXi,网关防火墙,多个物理...
  • Mininet是一个网络仿真器,可简单理解为 SDN 网络系统中的一种基于进程虚拟化平台,它支持 OpenFlow、Open vSwith 等各种协议,它可以在单个 Linux 内核上模拟和运行一个完整的网络主机、链接和交换机,在同一台...
  • 中小企业园区网建设的拓扑图

    热门讨论 2011-12-15 14:38:14
    网络工程的中小企业园区网建设实验的拓扑图,这个图片比较清晰,另外一个是packet tracer产生的拓扑图文件,格式是pkt。

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 21,480
精华内容 8,592
关键字:

企业网络架构拓扑图