精华内容
下载资源
问答
  • 华为交换机基本命令

    万次阅读 多人点赞 2018-11-10 21:10:55
    命令不区分大小写,支持“Tab”键补全,支持命令简写。 一、常用命令 用户视图 <Huawei>   进入系统视图 <Huawei> system-view 或者 sys 或者 system [Huawei]   更改设备...

    命令不区分大小写,支持“Tab”键补全,支持命令简写。


    一、常用命令

    用户视图

    <Huawei>

     

    进入系统视图

    <Huawei>  system-view   或者  sys  或者 system

    [Huawei]  

     

    更改设备的名字

    [Huawei] sysname  HW  

    [HW]

     

    进入接口视图

    [Huawei]interface Ethernet0/0/1  或者int         interface 接口类型+接口编号 

    [Huawei-Ethernet0/0/1]

     

    关闭接口

    [Huawei-Ethernet0/0/1] shutdown

    开启接口

    [Huawei-Ethernet0/0/1] undo shutdown

     

    查看vlan

    display vlan 或者 dis vlan

     

    查看当前配置:display  current-configuration 或者 display cu

    查看已保存配置:display saved-configuration  或者  display sa

    查看版本: display version

     

    保存配置:save

    清除已保存的配置:reset saved-configuration

     

    返回上级视图:quit

    返回用户视图:return

     

    重启设备:reboot

     

     

    二、配置和管理Vlan

    #1.基于接口划分VLAN -- 静态

    创建vlan  

    [Switch] vlan 10

    [Switch] vlan batch 10  20  同时创建两个vlan

    [Switch] vlan batch 10 to 20  创建10-20的vlan

     

    进入接口模式

    [Switch]  interface Ethernet0/0/1

    [Switch-Ethernet0/0/1]

     

    配置接口类型为Acces接口

    [Switch-Ethernet0/0/1]  port  link-type  access

    [Switch-Ethernet0/0/1]  port default vlan 10           配置接口所属的VLAN

     

    配置接口类型为Trunk口

    [Switch]  interface Ethernet0/0/3

    [Switch-Ethernet0/0/3]  port link-type trunk    

    [Switch-Ethernet0/0/3]  port trunk allow-pass vlan 10  20   配置接口所属的VLAN

                          port trunk allow-pass vlan all  运行所有vlan通过

     

    简写:int e0/0/1   int g0/0/1

     

     

    设置vlan描述

    [SW] vlan 10

    [SW-vlan10]  description  xxxxx  设置该vlan描述

     

    设置接口组(批量设置)

    [SW]  port-group vlan 10

    [SW-port-group-vlan10]  group-member Ethernet0/0/1  to Ethernet0/0/8

     

    # 2.基于MAC地址划分VLAN  -- 静态

    华为交换机上所有二层以太网端口缺省都是Hybrid类型并且发送数据帧时都是不带VLAN标签的

    如果该交换机的缺省配置有改变,需要重新恢复其缺省配置

    <HUAWEI>  system-view  

    [HUAWEI]  vlan 10       管理vlan10

    PC的MAC地址与VLAN 10关联

    [HUAWEI-Vlan10]  mac-vlan mac-address 22-22-22  

    [HUAWEI-Vlan10]  mac-vlan mac-address 33-33-33  

    [HUAWEI-Vlan10]  mac-vlan mac-address 44-44-44  

    [HUAWEI-Vlan10]  quit

    配置接口加入的VLAN10

    [HUAWEI] interface ethernet 0/0/1  

    [HUAWEI-Ethernet0/0/1] port hybrid Untagged vlan 10   允许VLAN 10的数据帧通过,且发送时不带VLAN标签[HUAWEI-Ethernet0/0/1] quit  

    [HUAWEI] interface ethernet 0/0/2

    [HUAWEI-Ethernet0/0/2] port hybrid Tagged vlan 10    允许VLAN 10的数据帧通过,且发送时带有VLAN标签 [HUAWEI-Ethernet0/0/2] quit  

     

    启用基于MAC地址的VLAN划分功能

    [HUAWEI] interface ethernet 0/0/1  

    [HUAWEI-Ethernet0/0/1] mac-vlan enable    

    [HUAWEI-Ethernet0/0/1] quit  

     

    三、链路和接口类型

    两种链路: 接入链路(Access Link) 、干道链路(Trunk Link)

     

    四种接口:  Access接口、   Trunk接口、  Hybird接口、  QinQ接口

    分别连接:   终端            交换机                         公网

     

     

    概述:

    Access类型:端口只能属于一个vlan,一般用于连接计算机。

     

    Trunk类型:端口可以属于多个vlan,可以接收和发送多个vlan报文,多用于交换机之间。

     

    Hybrid类型:端口可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间,也可以用于连接用户主机。  

     

    Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为Hybrid端口。

     

     

     

     

     

     

     

    配置交换机的管理

    [SW] interface vlanif10                创建vlan的vlanif接口

    [SW-vlanif10] ip address 1.1.1.1       创建vlanif的接口ip

     

    [SW]telnet server enable      开启telnet

    [SW]user-interface vty 0 4     开启vtf线路模式,开启0-4的5个用户终端

    [SW-ui-vty0-4]

    [SW-ui-vty0-4]  protocol inbound telnet   配置telnet协议

    [SW-ui-vty0-4] authentication-mod aaa     配置认证方式

    [SW-ui-vty0-4] quit

    [SW]  aaa

    [SW-aaa] quit

    <SW> save    用户视图下保存配置

     

    aaa服务器是验证、授权和记账(Authentication、Authorization、Accounting )

     

     

     

     

     

     

    其他概念:

    交换机Console口连接计算机串口。

    vlan(虚拟局域网)工作在第二层和第三层。

    每个vlan都形成一个广播域。

    vlan间通信需要通过路由器(第三层)组成的主干网段。

     

    静态vlan配置:基于端口 (管理员手动分配)

    动态vlan配置:基于MAC 或 IP

     

     

    STP生成树Spanning Tree Protocol

    网络中,存在二层环路的主要原因是对设备或链路存在冗余备份,以保障网络的可靠性。

    如果二层交换网络中存在环路,则会导致广播风暴、帧的重复复制、MAC地址表动荡

    生成树协议能发现并自动消除荣誉网络扩扑中的环路

     

    STP生成树协议作用:

    1. 消除环路:通过阻断冗余链路来消除环路()
    2. 链路备份:当活动路径发生故障是,激活备份链路,恢复网络连通性。

     

    生成树算法:进行环路分解

     

     

     

     

     

    展开全文
  • 华为交换机常用命令大全

    千次阅读 2021-05-15 18:12:49
    01 — 基础配置命令 ...3、交换机改名 这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 02 — 创建vl...

     

    01

    基础配置命令

     

    1、用户模式

    登陆设备后,直接进入用户模式,尖括号表示用户模式,在这个模式下只能执行少量查看配置的命令;

    图片

     

    2、视图模式

    用户模式下,输入system-view或者sys进入视图模式,方括号表示视图模式,可执行设备全局配置的命令;

    图片

     

    3、交换机改名

    图片

    图片

    这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉

    图片

     

    4、进入接口

    图片

     

    5、退出此端口

    图片

     

     

    02

    创建vlan并将端口加入vlan

     

    1、创建vlan

    创建单个vlan

    图片

    批量创建vlan

    图片

     

    2、更改端口的链接类型

    由于华为交换机的端口出厂时默认都是hybrid类型或auto类型的,所以无法立即加入vlan,需要更改端口的link-type后,才可以加入vlan。单个端口更改方式如下:

    图片

    为何要选择access类型??

    因为我们是终端PC与交换机相连,要求PC只能只能和上级交换机通信,所以必须只属于1个vlan

    以太网端口的链路类型有三种:

    Access 类型:端口只能属于1 个VLAN,一般用于交换机与终端用户之间的连接;

    Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机 之间的连接;

    Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换 机之间连接,也可以用于连接用户的计算机。Hybrid 端口可以允许多个VLAN 的报文发送时不携带标签,而Trunk 端口只允许缺省VLAN 的报文,发送时不携带标签。

    • trunk端口用于交换机相连,pvid必须一致。

    • access 类型只能属于1 个vlan

    • 规模较大的企业局域网,不建议使用vlan1,所以trunk端口不允许vlan1通过

     

    3、端口加入vlan

    图片

    以上的操作是单个操作,如果配置端口比较多就很麻烦,下面我们来批量操作。

     

    4、端口的批量操作——端口组

    原理就是创建一个端口组,把要更改的端口加入到端口组中,然后统一更改类型加入vlan。也可以理解为群组端口,统一配置类型加入vlan.

     

    批量更改,先更改端口类型,再统一加入某个vlan,如下:

    图片

     

    5、vlan的查看

    全局查看vlan信息

    图片

    查看端口与vlan对应关系

    图片

     

    6、允许所有vlan通过

    图片

     

     

    03

    首次登入交换机或路由器

     

    第一次上电和恢复出厂是一样的,我们先说一下恢复出厂设置。

     

    1、恢复出厂设置

    注意Y和N的选项,不要输错。

    图片

     

    2、设置新密码

    新交换机第一次上电,或恢复出厂设置后,要求设置新密码

    出厂自带的用户名是admin,密码是admin@huawei.com

    图片

     

    3、首次保存配置

    第一次保存设置时,需输入文件名,只需按回车

    图片

     

    4、设置日期和时间

    图片

    设置console口的连接方式,可设置为无,仅密码,用户名密码等方式

    图片

     

    5、开启必要的服务和功能

    开启telnet服务,stp功能,http服务

    图片

     

    6、设置vty,telnet登录

    图片

     

    7、设置一个用户用于网页登录

    图片

    由于第一次登录时,console口要求用户名密码登录,所以无法删除本地用户admin,此时可退到<>视图,保存设置,退出交换机,再重新登录。由于我们已经将console口的认证方式改为仅需密码,所以可以再次进入aaa,删除用户admin。删除后,再建立admin,权限,服务类型等,均可由我们自己控制。

    图片

    如遇更新版本的交换机软件,telnet服务要求必须是aaa认证(用户名密码认证),可按上面所述再建立一个用户,service-type设置为telnet。

     

    8、关闭交换机自动弹出配置改变告警

    输入配置命令后设备会提示如下类似信息:

    图片

    这个是配置改变的告警提示信息,不是错误信息,可以配置如下命令屏蔽此信息:

    图片

     

    04

    设置链路聚合

     

    图片

    以上命令建立一个聚合端口,并设置了端口的属性

    图片

    以上命令将G 0/0/25端口加入聚合端口eth-trunk 1,无需更多设置。可将更多的端口加入聚合端口。

     

    05

    交换机DHCP

     

    开启DHCP功能,设置地址池,并应用

    图片

     

    06

    开启流控制功能,限制某些网段互链

     

    主要是限制访客网与办公网、财务网互访

    图片

    注意源地址和目的地址的反向掩码

    图片

     

     

    1

     

     

    end

    展开全文
  • 华为交换机常用命令

    万次阅读 2021-01-17 17:05:43
    华为交换机常用命令视图分类用户视图登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the numberof current VTY users on line is 1.The current login ...

    华为交换机常用命令

    视图分类

    用户视图

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the number

    of current VTY users on line is 1.

    The current login time is 2020-04-10 12:15:00+00:00.

    系统视图

    用户模式下,输入system-view命令进入视图模式,可执行设备全局配置的命令system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]

    局部视图

    系统视图模式下,输入局部配置命令,进入局部对像的配置视图。如interface GE 1/0/0,进入GE1/0/0端口配置模式system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]interface GigabitEthernet 1/0/1

    [ZD_agg_5720-GigabitEthernet1/0/1]

    常用命令

    命令简介命令缩写解释displaydis查看相应对象信息

    undo撤消或反向操作对应命令

    system-viewsy进入系统视图

    sysname设置交换机名称

    quitq退出当前视图

    reboot交换机重启

    reset

    restart重新启动当前接口

    shutdown关闭当前接口

    信息查看命令

    交换机信息查看display version 查看交换机软件版本

    display clock 查看交换机时钟

    交换机配置查看display saved-configuration 显示系统保存配置

    display current-configuration 显示系统当前配置

    当前对象信息查看display this 显示当前信息。

    display this include-default 显示当前接口视图下的接口信息,包括默认值。

    display this interface 显示当前接口视图下的接口信息。

    查看接口display interface 查看接口当前运行状态和接口统计信息

    display interface brief 查看接口状态和配置的简要信息。

    display interface description 查看指定接口的描述信息

    display interface vlanif 查看VLANIF接口的状态信息、配置信息和统计信息。

    查看IP相关display ip interface 查看接口与IP相关的配置和统计信息,包括接口接收和发送的报文数、字节数和组播报文数,以及接口接收、发送、转发和丢弃的广播报文数。

    display ip interface brief 看接口与IP相关的简要信息,包括IP地址、子网掩码、物理链路和协议的Up/Down状态以及处于不同状态的接口数目。

    display ip interface description 查看接口与IP相关的简要信息,包括IP地址、子网掩码、物理层状态、链路层协议状态,及接口描述信息和处于不同状态的接口数目。

    display ip pool 显示所有ip pool

    display ip pool name {pool name} {all|conflict|expired|used} 显示ip pool详细信息

    display ip host 查看静态DNS表项

    display ip socket 查看已创建的IPv4 Socket信息。

    display ip statistics 显示IP流量统计信息。

    查看路由display ip routing-table 显示路由信息

    display ospf peer 查看ospf邻接等信息

    display ospf peer brief 查看ospf邻接等简要信息

    display rip 查看rip路由信息

    网络及流量display network status { all|tcp|udp|port port-number } 显示IP流量统计信息

    display tcp statistics 查看TCP流量统计信息

    display udp statistics 查看UDP流量统计信息

    VLAN查看display vlan 显示VLAN信息

    display vlan {pvid} verbose 查看vlan的详细信息

    display port vlan 查看VLAN中包含的接口信息

    display sub-vlan 查看Sub-VLAN类型的VLAN表项信息

    display super-vlan 查看Super-VLAN类型的VLAN表项信息

    display mac-vlan mac-address all 查看所有MAC地址划分VLAN的配置信息

    display mac-vlan vlan 2 查看vlan 2 MAC地址划分VLAN的配置信息

    查看ACL配置display acl {all | name | ipv6} 查看ACL

    display traffic classifier user-defined 查看用户定义的流分类

    display traffic behavior user-defined 查看用户定义的流行为

    display traffic policy user-defined {policy name} 查看用户定义的流策略

    display traffic-applied {inbound | outbound | interface | vlan} 查看流策略应用情况

    display traffic policy {global | interface | statistics | vlan } {inbound | outbound} 查看更多流策略信息

    display traffic policy statistics {global | interface | vlan} {inbound | outbound} 查看流策略统计信息

    display traffic-filter applied-record 查看acl应用的接口

    查看NAT配置#路由器命令

    display nat static {acl | global | inside | interface} 查看静态NAT信息

    display nat session {all | dest | number | protocol | source} 查看动态NAT信息

    display nat server {acl | global | inside | interface} 查看NAT server信息

    配置管理命令

    端口管理port 配置接口的缺省VLAN并加入该VLAN

    port description 配置接口的描述信息,描述与接口相连的设备类型。

    port gigabitethernet 0/0/1 to 0/0/4

    port default vlan 配置接口的缺省VLAN并同时加入这个VLAN。

    port link-type {access | hybird | trunk} 配置接口的链路类型

    port trunk allow-pass vlan {vlanid} 将trunk接口加入vlan

    端口配置speed {10|100|auto} 配置端口工作速率

    duplex {half|full|auto} 配置端口工作状态

    端口组操作display port-group {all} 查看端口组

    port-group {id} 创建端口组

    group-member gigabitethernet 0/0/2 to gigabitethernet 0/0/10 将2到10端口加入端口组

    VLAN管理vlan {id} 创建VLAN并进入VLAN视图,如果VLAN已存在,直接进入该VLAN的视图。

    vlan batch 10 to 20 批量创建VLAN

    vlan range 10 to 20 创建临时VLAN组,并进入VLAN-Range视图

    vlan statistics 配置VLAN的流量统计模式,即配置按包或按字节进行VLAN流量统计。

    vlan statistics interval 配置VLAN的流量统计的时间间隔

    ip address 用来配置接口的IP地址。

    接口管理interface gigabitethernet 0/0/1 进入指定的接口或子接口视图,进入0/0/1的接口

    DNS管理#查看

    display dns dynamic-host 查看动态DNS表项

    display dns domain 查看域名后缀的相关信息

    display dns server 查看DNS服务器的相关信息

    #设置

    dns domain domain-name 命令用来配置域名后缀,如 dns domain com.cn。

    dns resolve 命令用来使能动态域名解析功能

    dns server {ip} 命令用来配置DNS服务器的IP地址

    ip host {domain} {ip} 命令用来配置静态DNS表项 ip host www.huawei.com 10.10.10.4。

    DHCP管理dhcp enable 命令用来开启DHCP功能。

    dhcp select global 从全局配置中获取dhcp配置

    ACL管理acl {name | number | ipv6} 创建acl

    rule [{ruleid}] permit ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建允许规则

    rule [{ruleid}] deny ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建拒绝规则

    traffic-filter {inbound | outbound} acl {acl number} 在接口上应用acl规则

    #创建流分类

    traffic classifier {classifier name} operator { and |or }

    if-match acl {acl number} 为流分类设置匹配规则

    #创建流行为

    traffic behavior {behavior name}

    permit | deny | redirect 为流行为配置动作

    #创建流策略

    traffic policy {policy name}

    classifier {classifier name} behavior {behavior name} 关联流分类与流行为

    #将流策略应用到接口

    interface g0/0/1

    traffic-policy {policy name} {inbound | outbound} 接口绑定流策略

    NAT管理#边界路由器接口上配置静态NAT

    nat static global {外部ip} inside {内部ip} 添加静态nat,内外部ip一对一

    #动态NAT,使用dis nat session查看

    nat address-group {groupid} {ip开始} {ip结束} 添加外部可用地址池

    nat outbound {acl id} address-group {address-group id} no-pat 添加动态地址转换

    #NAPT,使用dis nat session查看

    nat outbound {acl id} [address-group {address-group id}] 添加动态端口地址转换

    #NAT server,使用dis nat server查看

    nat server protocol tcp global {外部ip} {外部端口} inside {内部ip} {内部端口} 添加nat server转换

    用户管理#查看本地用户

    display local-user

    #查看用户接口

    display user-interface

    #设置用户vty0为4个并发

    user-interface vty 0 4

    #进入用户console0接口

    user-interface console 0

    #用户管理

    local-user {username} password cipher {password}

    local-user {username} level 15

    local-user {username} service-type telnet terminal ssh

    绑定IP与MACuser-bind ip-address 10.0.0.2 mac-address 0001-0203-0405

    user privilege level 3

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。

    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

    日志与统计#打开统计

    display counters 查看接口的流量统计计数

    statistic enable

    trace mac enable

    trace mac aa99-6600-5600 vlan 2

    其它命令display stp 显示生成树信息

    display mac-address 显示MAC地址表

    display bridge mac-address 查看当前桥接设备mac地址

    display arp 显示ARP信息表

    display voice-vlan oui 查看Voice VLAN的OUI及其相关属性。

    display voice-vlan status 查看当前Voice VLAN的相关信息

    mac-vlan mac-address

    操作实战

    VLAN操作

    创建vlan,设置vlan的ip,并将端口加入vlan中。#进入全局配置视图

    system-view

    #新建vlan2

    [Huawei] vlan 2

    #进入vlan2的接口视图

    [Huawei] interface vlan 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #进入0/0/1接口,配置为access接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/1

    [Huawei-GigabitEthernet0/0/1] port link-type access

    [Huawei-GigabitEthernet0/0/1] port default vlan 2

    #进入0/0/2接口,配置为trunk接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/2

    [Huawei-GigabitEthernet0/0/2] port link-type trunk

    [Huawei-GigabitEthernet0/0/2] port trunk allow-pass vlan 2

    #查看端口配置的信息

    [Huawei-GigabitEthernet0/0/2] dis this

    #进入vlan2,将0/0/2到0/0/5端口加入到vlan2中(port link-type需要是access类型)

    [Huawei] vlan 2

    [Huawei-vlan2] port GigabitEthernet 0/0/2 to 0/0/5

    端口组操作

    需要对多个端口进行相同操作时,可以创建端口组进行批量操作。#创建端口组1,进行批量端口操作

    [Huawei] port-group 1

    #将6到10端口加入端口组

    [Huawei-port-group-1] group-member gigabitethernet 0/0/6 to gigabitethernet 0/0/10

    #批量将2~10端口修改为access模式

    [Huawei-port-group-1] port link-type access

    #批量将6~10端口加入到vlan 2中

    [Huawei-port-group-1] port default vlan 2

    IP POOL操作 system-view

    #进入ip pool中

    [Huawei] ip pool vlan10

    #在ip pool中添加dns server

    [Huawei-ip-pool-vlan10] dns-list 8.8.8.8

    #设置网关

    [Huawei-ip-pool-vlan10] gateway-list 10.0.0.1

    #设置ip pool的ip段和池,需要与vlanif接口配置匹配,否则ip分配不了

    [Huawei-ip-pool-vlan10] network 10.0.0.0 mask 255.255.255.0

    #过期时间

    [Huawei-ip-pool-vlan10] lease day 10

    DHCP操作 system-view

    #全局打开DHCP服务

    [Huawei] dhcp enable

    #进入vlan的接口视图

    [Huawei] interface vlanif 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #从全局配置中获取dhcp配置

    [Huawei-Vlanif2] dhcp select global

    静态添加路由 system-view

    display ip routing-table

    #ip route-static 目的ip 目标地址掩码 下一跳ip

    [Huawei] ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    #删除路由

    [Huawei] undo ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    RIP路由管理 system-view

    #修改loopback0地址

    [Huawei] int LoopBack 0

    [Huawei-LoopBack0] ip address 1.1.1.1 0

    #创建rip进程

    [Huawei] rip 1

    #启动版本2

    [Huawei-rip-1] version 2

    #宣告网段

    [Huawei] network 10.0.0.0

    [Huawei] network 1.0.0.0

    OSPF路由管理 system-view

    #创建ospf

    [Huawei] ospf 1 router-id 1.1.1.1

    #创建area0区域

    [Huawei-ospf-1] area 0

    #加入192.168.0.0/24子网

    [Huawei-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

    [Huawei-ospf-1-area-0.0.0.0]dis this

    #

    area 0.0.0.0

    network 192.168.0.0 0.0.0.255

    #

    [Huawei-ospf-1-area-0.0.0.0]

    ACL管理 system-view

    #配置acl

    [Huawei] acl 3000

    [Huawei-acl-adv-3000] rule permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] quit

    #配置流分类,匹配acl

    [Huawei] traffic classifier c0 operator or

    [Huawei-classifier-c0] if-match acl 3000

    [Huawei-classifier-c0] quit

    #配置流行为,设置动作

    [Huawei-behavior-b0] traffic behavior b0

    [Huawei-behavior-b0] permit

    [Huawei-behavior-b0] quit

    #配置流策略,关联流分类c0与流行为b0

    [Huawei] traffic policy p0

    [Huawei-trafficpolicy-p1] classifier c0 behavior b0

    [Huawei-trafficpolicy-p1] quit

    #配置流策略应用到接口

    [Huawei] interface g0/0/1

    [Huawei-GigabitEthernet0/0/1] traffic-policy p0 inbound

    [Huawei-GigabitEthernet0/0/1] return

    用户管理#查看本地用户

    display local-user

    system-view

    #进入aaa配置模式

    [Huawei] aaa

    #配置本地用户账号密码

    [Huawei-aaa] loca-user user1 password cipher 123456

    #用户服务类型为telnet,使用telnet登陆

    [Huawei-aaa] local-user user1 service-type telnet

    #配置用户特权等级15

    [Huawei-aaa] local-user user1 privilege level 15

    展开全文
  • 1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s...键入命令,配置以太网交换机或查...

    1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。

    在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。

    以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如)。

    键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?"

    2、命令视图

    (1)用户视图(查看交换机的简单运行状态和统计信息):与交换机建立连接即进入

    (2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view

    (3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface ethernet 0/1

    (4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan 1

    (5)VLAN接口视图(配置VLAN和VLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface vlan-interface 1

    (6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user user1

    (7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface

    3、其他命令

    设置系统时间和时区clock time Beijing  add 8

    clock datetime 12:00:00 2005/01/23

    设置交换机的名称[Quidway]sysname TRAIN-3026-1[TRAIN-3026-1]

    配置用户登录[Quidway]user-interface vty 0 4

    [Quidway-ui-vty0]authentication-mode scheme

    创建本地用户[Quidway]local-user huawei

    [Quidway-luser-huawei]password simple huawei

    [Quidway-luser-huawei] service-type telnet level 3

    4、VLAN配置方法

    『配置环境参数』

    SwitchA端口E0/1属于VLAN2,E0/2属于VLAN3

    『组网需求』

    把交换机端口E0/1加入到VLAN2 ,E0/2加入到VLAN3

    数据配置步骤

    『VLAN配置流程』

    (1)缺省情况下所有端口都属于VLAN 1,并且端口是access端口,一个access端口只能属于一个vlan;

    (2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;

    (3)除了VLAN1,如果VLAN XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。

    【SwitchA相关配置】

    方法一:

    (1)创建(进入)vlan2

    [SwitchA]vlan 2

    (2)将端口E0/1加入到vlan2

    [SwitchA-vlan2]port ethernet 0/1

    (3)创建(进入)vlan3

    [SwitchA-vlan2]vlan 3

    (4)将端口E0/2加入到vlan3

    [SwitchA-vlan3]port ethernet 0/2

    方法二:

    (1)创建(进入)vlan2

    [SwitchA]vlan 2

    (2)进入端口E0/1视图

    [SwitchA]interface ethernet 0/1

    (3)指定端口E0/1属于vlan2

    [SwitchA-Ethernet1]port access vlan 2

    (4)创建(进入)vlan3

    [SwitchA]vlan 3

    (5)进入端口E0/2视图

    [SwitchA]interface ethernet 0/2

    (6)指定端口E0/2属于vlan3

    [SwitchA-Ethernet2]port access vlan 3

    测试验证

    (1)使用命令disp cur可以看到端口E0/1属于vlan2,E0/2属于vlan3;

    (2)使用display interface Ethernet 0/1可以看到端口为access端口,PVID为2;

    (3)使用display interface Ethernet 0/2可以看到端口为access端口,PVID为3

    5、交换机IP地址配置

    功能需求及组网说明

    『配置环境参数』

    三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan 2、vlan 3;

    以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关;

    以vlan 3的三层接口地址分别是2.0.0.1/24作为PC2的网关;

    『组网需求』

    PC1和PC2通过三层接口互通

    【SwitchA相关配置】

    (1)创建(进入)vlan2

    [Quidway]vlan 2

    (2)将端口E0/1加入到vlan2

    [Quidway-vlan2]port ethernet 0/1

    (3)进入vlan2的虚接口

    [Quidway-vlan2]interface vlan 2

    (4)在vlan2的虚接口上配置IP地址

    [Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0

    (5)创建(进入)vlan3

    [Quidway]vlan 3

    (6)将E0/2加入到vlan3

    [Quidway-vlan3]port ethernet 0/2

    (7)进入vlan3的虚接口

    [Quidway-vlan3]interface vlan 3

    (8)在vlan3的虚接口上配置IP地址

    [Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0

    测试验证

    (1)PC1和PC2都可以PING通自己的网关

    (2)PC1和PC2可以相互PING通

    6、端口的trunk配置

    『配置环境参数』

    (1)SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连

    (2)SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连

    『组网需求』

    (1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通

    (2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通

    数据配置步骤

    【SwitchA相关配置】

    (1)创建(进入)vlan10

    [SwitchA] vlan 10

    (2)将E0/1加入到vlan10

    [SwitchA-vlan10]port Ethernet 0/1

    (3)创建(进入)vlan20

    [SwitchA]vlan 20

    (4)将E0/2加入到vlan20

    [SwitchA-vlan20]port Ethernet 0/2

    (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

    [SwitchA-Ethernet0/3]port link-type trunk

    (6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

    [SwitchA-Ethernet0/3]port trunk permit vlan all

    【SwitchB相关配置】

    (1)创建(进入)vlan10

    [SwitchB] vlan 10

    (2)将E0/1加入到vlan10

    [SwitchB-vlan10]port Ethernet 0/1

    (3)创建(进入)vlan20

    [SwitchB]vlan 20

    (4)将E0/2加入到vlan20

    [SwitchB-vlan20]port Ethernet 0/2

    (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传

    [SwitchB-Ethernet0/3]port link-type trunk

    (7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值

    [SwitchB-Ethernet0/3]port trunk permit vlan all

    【补充说明】

    (1)如果一个端口是trunk端口,则该端口可以属于多个vlan;

    (2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID;

    (3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。

    (4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。

    (5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。

    测试验证

    (1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通

    (2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通

    (3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通

    (4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通

    7、端口汇聚配置

    『配置环境参数』

    (1)交换机SwitchA和SwitchB通过以太网口实现互连。

    (2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。

    『组网需求』

    增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚

    数据配置步骤

    【SwitchA交换机配置】

    (1)进入端口E0/1

    [SwitchA]interface Ethernet 0/1

    (2)汇聚端口必须工作在全双工模式

    [SwitchA-Ethernet0/1]duplex full

    (3)汇聚的端口速率要求相同,但不能是自适应

    [SwitchA-Ethernet0/1]speed 100

    (4)进入端口E0/2

    [SwitchA]interface Ethernet 0/2

    (5)汇聚端口必须工作在全双工模式

    [SwitchA-Ethernet0/2]duplex full

    (6)汇聚的端口速率要求相同,但不能是自适应

    [SwitchA-Ethernet0/2]speed 100

    (7)根据源和目的MAC进行端口选择汇聚

    [SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

    【SwitchB交换机配置】

    [SwitchB]interface Ethernet 0/1

    [SwitchB-Ethernet0/1]duplex full

    [SwitchB-Ethernet0/1]speed 100

    [SwitchB]interface Ethernet 0/2

    [SwitchB-Ethernet0/2]duplex full

    [SwitchB-Ethernet0/2]speed 100

    [SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

    【补充说明】

    (1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。

    (2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

    8、端口镜像配置

    『环境配置参数』

    (1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24

    (2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24

    (3)E0/24为交换机上行端口

    (4)Server接在交换机E0/8端口,该端口作为镜像端口

    『组网需求』

    (1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

    根据Quidway交换机不同型号,镜像有不同方式进行配置:

    基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

    基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

    S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像

    8016交换机支持基于端口的镜像

    3500/3026E/3026F/3050支持基于流的镜像

    5516/6506/6503/6506R支持对入端口流量进行镜像

    数据配置步骤

    以Quidway S3026C为例,通过基于二层流的镜像进行配置:

    (1)定义一个ACL

    [SwitchA]acl num 200

    (2)定义一个规则从E0/1发送至其它所有端口的数据包

    [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

    (3)定义一个规则从其它所有端口到E0/1端口的数据包

    [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

    (4)将符合上述ACL的数据包镜像到E0/8

    [SwitchA]mirrored-to link-group 200 interface e0/8

    9、生成树STP配置

    『配置环境参数』

    (1)交换机SwitchA、SwitchB和SwitchC都通过GE接口互连

    (2)SwitchB和SwitchC交换机是核心交换机,要求主备。

    『组网需求』

    要求整个网络运行STP协议

    数据配置步骤

    (1)【SwitchA交换机配置】

    启动生成树协议: [SwitchA]stp enable

    (1)【SwitchB交换机配置】

    启动生成树协议:[SwitchB]stp enable

    (3)配置本桥为根桥

    [SwitchB]stp root primary

    (4)【SwitchC交换机配置】

    a 启动生成树协议[SwitchC]stp enable

    b 配置本桥为备份根桥[SwitchC]stp root secondary

    (5)【SwitchD交换机配置】

    a 启动生成树协议[SwitchD]stp enable

    【补充说明】

    (1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优先级来实现;

    (2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式;

    (3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。

    测试验证

    (1)使用display stp查看交换机STP运行状态

    (2)查看端口STP状态display stp interface Ethernet XX是否正确

    10、Quidway交换机维护

    显示系统版本信息:display version

    显示诊断信息:display diagnostic-information

    显示系统当前配置:display current-configuration

    显示系统保存配置: display saved-configuration

    显示接口信息:display interface

    显示路由信息:display ip routing-table

    显示VLAN信息:display vlan

    显示生成树信息:display stp

    显示MAC地址表:display mac-address

    显示ARP表信息:display arp

    显示系统CPU使用率:display cpu

    显示系统内存使用率:display memory

    显示系统日志:display log

    显示系统时钟:display clock

    验证配置正确后,使用保存配置命令:save

    删除某条命令,一般使用命令: undo

    华为交换机的配置方法小编这里整理完毕了,再给大家推荐个华为交换机的购买地址(有内部优惠券可以领!!!)

    展开全文
  • 华为交换机常用命令(以s5700-SI为例)

    万次阅读 多人点赞 2016-08-04 09:49:00
    交换机的三种模式: Access模式:一般用来连接计算机与交换机. 此模式下有一个PVID就是本端口所属的VLAN号,如果从链路上收到无标签的帧,则打上默认VLAN号,然后发给其他端口,如果从链路上收到有标签的帧,如果这个帧的...
  • 小白也能看懂的华为交换机常用命令大全

    千次阅读 多人点赞 2021-04-16 14:41:05
    01 — ...3、交换机改名 这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 02 — 创建vlan并...
  • 1.基本查询命令(在用户视图下使用) pwd 查看当前目录 dir 显示当前目录下的文件信息 more 查看文本文件的具体内容 2.基本目录操作命令(在用户视图下使用) cd 切换目录 mkdir 创建新的目录 rmdir 删除目录 cd… ...
  • 网络工程必考的认证:HCIA HCIP...3、交换机改名 这个提示信息,比较烦人。每次更改了什么配置都会显示出来,影响调试。可以使用下面的命令关闭掉 4、进入接口 5、退出此端口 1、创建vlan 创建...
  • 一、华为交换机配置基础命令 1、创建vlan: <Quidway> //用户视图,也就是在Quidway模式下运行命令。<Quidway>system-view //进入配置视图[Quidway] vlan 10 //创建vlan 10,并进入vlan10配置视图,...
  • [Quidway]description string ;指定VLAN描述字符 [Quidway]description ;删除VLAN描述字符 [Quidway]display vlan [vlan_id] ;查看VLAN设置 [Quidway]stp {enable|disable}...重置保存配置 reboot ;重新启动。 全部
  • 华为交换机基础配置命令参考

    万次阅读 多人点赞 2019-03-24 10:06:03
    华为交换机基础配置命令参考 基础配置 用户模式 登陆设备后,直接进入用户模式,只能执行少量查看配置的命令; 视图模式 用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令; 局部配置...
  • 怎么查看华为交换机的系统日志?如果需要,您可以手动将事件添加到您要设置的每个事件中,并将其添加到您要踩踏的电话中。华为手机自有日历:无一次性设置,无共享日历链接,只从其他日历导入华为日历,华为日历不能...
  • 展开全部华为交换机配置命令有以下几种:1、用户模式:交换机启动32313133353236313431303231363533e59b9ee7ad9431333363396463后在控制台直接按回车就进入用户模式(远程管理telnet 交换机ip时需要口令)。...
  • 华为交换机常用配置命令 1.基本配置命令 <huawei>system-view 进入系统视图模式(即特权模式) [Switch A]sysname Switch A 交换机命名为Switch A [Switch A]vlan 2 创建vlan 2 [Switch A-Vlan2]...
  • 华为交换机基本配置命令大全

    千次阅读 2019-12-02 13:42:16
    查看万兆端口模块收发光:display transceiver ...命令 命令解释 system 进入系统视图 system-view 进入系统视图 quit 退到系统视图 undo vlan 20 删除vlan 20 sysname 交换机命名 disp vlan 显示vlan...
  • 华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明华为交换机日志说明
  • 华为交换机命令

    千次阅读 2012-05-22 14:45:28
    华为交换机命令 返回上一级命令:quit ...配置保存命令:save 华为交换机命令 进入配置模式 [Quidway]dis cur ;显示当前配置 [Quidway]display current-configuration ;显示当前配置 [Qu
  • 华为交换机命令汇总

    2021-01-14 17:01:30
    华为交换机命令返回上一级命令:quit配置保存命令:save华为交换机命令<>sys进入配置模式[Quidway]discur;显示当前配置[Quidway]displaycurrent-configuration;显示当前配置[Quidway]displayinterfaces;...
  • 华为交换机启动配置命令详解大全

    千次阅读 2021-01-14 09:09:16
    华为交换机启动配置命令详解大全1、自动保存配置[Huawei]set save-configuration ?backup-to-server Back up theconfiguration to the server on the network#保存配置文件到服务器cpu-limit Specify theupper limit...
  • 华为交换机5720常用命令

    万次阅读 多人点赞 2018-07-17 15:48:17
    (一)交换机的概念  交换机(Switch)意为“开关”是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。  以太网交换机是基于以太网传输数据的交换机,以太网...
  • 华为交换机配置常用命令

    千次阅读 2021-01-17 02:41:42
    华为交换机配置常用命令一、配置软件和硬件1、配置(Console)电缆连接配置电缆是一根8芯屏蔽电缆,一端是压接的RJ-45连接器,插入交换机的Console口里;另一端则同时带有一个DB-9(孔)和DB-25(孔)连接器2、配置软件及...
  • 华为交换机配置命令---转

    千次阅读 2021-01-12 01:12:09
    华为交换机配置命令本文网址:http://bbs.bitscn.com/121555 复制华为QuidWay交换机配置命令手册:1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。在主机上运行终端仿真程序(如...
  • 华为交换机基本配置命令详解

    千次阅读 2020-12-24 08:24:45
    5: 交换机保存设置和重置命令 save //保存配置信息 reset saved-configuration /重置交换机的配置 reboot //重新启动交换机 6:交换机常用的显示命令 用户视图模式下: display current-configuration //显示现在...
  • 华为交换机配置命令汇总

    千次阅读 2019-09-30 08:17:19
    ◆command-privilege level rearrange ——用户级别为15级才能执行,将所有缺省注册为2、3级的命令,分别批量提升到10和15级。 ◆undocommand-privilege level rearrange——批量恢复。 ◆command-privilege ...
  • 交换机的基础命令汇总 system-view 进入系统视图 quit 退到系统视图 sysname 交换机命名 vlan 20 创建vlan(进入vlan20) display vlan 显示vlan undo vlan 20 删除vlan20 display vlan 20 显示vlan里的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,045
精华内容 1,218
关键字:

华为交换机保存命令

友情链接: weather.zip