精华内容
下载资源
问答
  • 华为交换机基本命令华为交换机基本命令华为交换机基本命令华为交换机基本命令华为交换机基本命令华为交换机基本命令
  • 华为交换机基本命令

    2020-12-01 22:17:38
    华为交换机基本命令 一、常用命令 用户视图 进入系统视图 system-view 或者 sys 或者 system [Huawei] 更改设备的名字 [Huawei] sysname HW [HW] 进入接口视图 [Huawei]interface Ethernet0/0/1 或者int interface...

    华为交换机基本命令

    一、常用命令

    用户视图

    进入系统视图

    system-view 或者 sys 或者 system

    [Huawei]

    更改设备的名字

    [Huawei] sysname HW

    [HW]

    进入接口视图

    [Huawei]interface Ethernet0/0/1 或者int interface 接口类型+接口编号

    [Huawei-Ethernet0/0/1]

    关闭接口

    [Huawei-Ethernet0/0/1] shutdown

    开启接口

    [Huawei-Ethernet0/0/1] undo shutdown

    查看vlan

    display vlan 或者 dis vlan

    查看当前配置:display current-configuration 或者 display cu

    查看已保存配置:display saved-configuration 或者 display sa

    查看版本: display version

    保存配置:save

    清除已保存的配置:reset saved-configuration

    返回上级视图:quit

    返回用户视图:return

    重启设备:reboot

    二、配置和管理Vlan

    #1.基于接口划分VLAN – 静态

    创建vlan

    [Switch] vlan 10

    [Switch] vlan batch 10 20 同时创建两个vlan

    [Switch] vlan batch 10 to 20 创建10-20的vlan

    进入接口模式

    [Switch] interface Ethernet0/0/1

    [Switch-Ethernet0/0/1]

    配置接口类型为Acces接口

    [Switch-Ethernet0/0/1] port link-type access

    [Switch-Ethernet0/0/1] port default vlan 10 配置接口所属的VLAN

    配置接口类型为Trunk口

    [Switch] interface Ethernet0/0/3

    [Switch-Ethernet0/0/3] port link-type trunk

    [Switch-Ethernet0/0/3] port trunk allow-pass vlan 10 20 配置接口所属的VLAN

                      port trunk allow-pass vlan all  运行所有vlan通过
    

    简写:int e0/0/1 int g0/0/1

    设置vlan描述

    [SW] vlan 10

    [SW-vlan10] description xxxxx 设置该vlan描述

    设置接口组(批量设置)

    [SW] port-group vlan 10

    [SW-port-group-vlan10] group-member Ethernet0/0/1 to Ethernet0/0/8

    2.基于MAC地址划分VLAN – 静态

    华为交换机上所有二层以太网端口缺省都是Hybrid类型,并且发送数据帧时都是不带VLAN标签的。

    如果该交换机的缺省配置有改变,需要重新恢复其缺省配置

    system-view

    [HUAWEI] vlan 10 管理vlan10

    PC的MAC地址与VLAN 10关联

    [HUAWEI-Vlan10] mac-vlan mac-address 22-22-22

    [HUAWEI-Vlan10] mac-vlan mac-address 33-33-33

    [HUAWEI-Vlan10] mac-vlan mac-address 44-44-44

    [HUAWEI-Vlan10] quit

    配置接口加入的VLAN10

    [HUAWEI] interface ethernet 0/0/1

    [HUAWEI-Ethernet0/0/1] port hybrid Untagged vlan 10 允许VLAN 10的数据帧通过,且发送时不带VLAN标签[HUAWEI-Ethernet0/0/1] quit

    [HUAWEI] interface ethernet 0/0/2

    [HUAWEI-Ethernet0/0/2] port hybrid Tagged vlan 10 允许VLAN 10的数据帧通过,且发送时带有VLAN标签 [HUAWEI-Ethernet0/0/2] quit

    启用基于MAC地址的VLAN划分功能

    [HUAWEI] interface ethernet 0/0/1

    [HUAWEI-Ethernet0/0/1] mac-vlan enable

    [HUAWEI-Ethernet0/0/1] quit

    三、链路和接口类型

    两种链路: 接入链路(Access Link) 、干道链路(Trunk Link)

    四种接口: Access接口、 Trunk接口、 Hybird接口、 QinQ接口

    分别连接: 终端 交换机 公网

    概述:

    Access类型:端口只能属于一个vlan,一般用于连接计算机。

    Trunk类型:端口可以属于多个vlan,可以接收和发送多个vlan报文,多用于交换机之间。

    Hybrid类型:端口可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间,也可以用于连接用户主机。

    Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为Hybrid端口。

    配置交换机的管理

    [SW] interface vlanif10 创建vlan的vlanif接口

    [SW-vlanif10] ip address 1.1.1.1 创建vlanif的接口ip

    [SW]telnet server enable 开启telnet

    [SW]user-interface vty 0 4 开启vtf线路模式,开启0-4的5个用户终端

    [SW-ui-vty0-4]

    [SW-ui-vty0-4] protocol inbound telnet 配置telnet协议

    [SW-ui-vty0-4] authentication-mod aaa 配置认证方式

    [SW-ui-vty0-4] quit

    [SW] aaa

    [SW-aaa] quit

    save 用户视图下保存配置

    aaa服务器是验证、授权和记账(Authentication、Authorization、Accounting )

    其他概念:

    交换机Console口连接计算机串口。

    vlan(虚拟局域网)工作在第二层和第三层。

    每个vlan都形成一个广播域。

    vlan间通信需要通过路由器(第三层)组成的主干网段。

    静态vlan配置:基于端口 (管理员手动分配)

    动态vlan配置:基于MAC 或 IP

    STP生成树Spanning Tree Protocol

    网络中,存在二层环路的主要原因是对设备或链路存在冗余备份,以保障网络的可靠性。

    如果二层交换网络中存在环路,则会导致广播风暴、帧的重复复制、MAC地址表动荡

    生成树协议能发现并自动消除荣誉网络扩扑中的环路

    STP生成树协议作用:

    消除环路:通过阻断冗余链路来消除环路()
    链路备份:当活动路径发生故障是,激活备份链路,恢复网络连通性。

    生成树算法:进行环路分解

    华为交换机基本配置命令

    一、单交换机VLAN划分

    命令 命令解释

    system 进入系统视图

    system-view 进入系统视图

    quit 退到系统视图

    undo vlan 20 删除vlan 20

    sysname 交换机命名

    disp vlan 显示vlan

    vlan 20 创建vlan(也可进入vlan 20)

    port e1/0/1 to e1/0/5 把端口1-5放入VLAN 20 中

    disp vlan 20 显示vlan里的端口20

    int e1/0/24 进入端口24

    port access vlan 20 把当前端口放入vlan 20

    undo port e1/0/10 表示删除当前VLAN端口10

    disp curr 显示当前配置

    二、配置交换机支持TELNET

    system 进入系统视图

    sysname 交换机命名

    int vlan 1 进入VLAN 1

    ip address 192.168.3.100 255.255.255.0 配置IP地址

    user-int vty 0 4 进入虚拟终端

    authentication-mode password (aut password) 设置口令模式

    set authentication password simple 222 (set aut pass sim 222) 设置口令

    user privilege level 3(use priv lev 3) 配置用户级别

    disp current-configuration (disp cur) 查看当前配置

    disp ip int 查看交换机VLAN IP配置

    删除配置必须退到用户模式

    reset saved-configuration(reset saved) 删除配置

    reboot 重启交换机

    三、跨交换机VLAN的通讯

    在sw1上:

    vlan 10 建立VLAN 10

    int e1/0/5 进入端口5

    port access vlan 10 把端口5加入vlan 10

    vlan 20 建立VLAN 20

    int e1/0/15 进入端口15

    port access vlan 20 把端口15加入VLAN 20

    int e1/0/24 进入端口24

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all 同上

    在SW2上:

    vlan 10 建立VLAN 10

    int e1/0/20 进入端口20

    port access vlan 10 把端口20放入VLAN 10

    int e1/0/24 进入端口24

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

    disp int e1/0/24 查看端口24是否为TRUNK

    undo port trunk permit vlan all 删除该句

    四、路由的配置命令

    system 进入系统模式

    sysname 命名

    int e1/0 进入端口

    ip address 192.168.3.100 255.255.255.0 设置IP

    undo shutdown 打开端口

    disp ip int e1/0 查看IP接口情况

    disp ip int brief 查看IP接口情况

    user-int vty 0 4 进入口令模式

    authentication-mode password(auth pass) 进入口令模式

    set authentication password simple 222 37 设置口令

    user privilege level 3 进入3级特权

    save 保存配置

    reset saved-configuration 删除配置(用户模式下运行)

    undo shutdown 配置远程登陆密码

    int e1/4

    ip route 192.168.3.0(目标网段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的接口) 静态路由

    ip route 0.0.0.0 0.0.0.0 192.168.12.1 默认路由

    disp ip rout 显示路由列表

    华3C AR-18

    E1/0(lan1-lan4)

    E2/0(wan0)

    E3/0(WAN1)

    路由器连接使用直通线。wan0接wan0或wan1接wan1

    计算机的网关应设为路由器的接口地址。

    五、三层交换机配置VLAN-VLAN通讯

    sw1(三层交换机):

    system 进入视图

    sysname 命名

    vlan 10 建立VLAN 10

    vlan 20 建立VLAN 20

    int e1/0/20 进入端口20

    port access vlan 10 把端口20放入VLAN 10

    int e1/0/24 进入24端口

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

    sw2:

    vlan 10

    int e1/0/5

    port access vlan 10

    int e1/0/24

    port link-type trunk 把24端口设为TRUNK端口

    port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

    sw1(三层交换机):

    int vlan 10 创建虚拟接口VLAN 10

    ip address 192.168.10.254 255.255.255.0 设置虚拟接口VLAN 10的地址

    int vlan 20 创建虚拟接口VLAN 20

    ip address 192.168.20.254 255.255.255.0 设置虚拟接口IP VLAN 20的地址

    注意:vlan 10里的计算机的网关设为 192.168.10.254

    vlan 20里的计算机的网关设为 192.168.20.254

    六、动态路由RIP

    R1:

    int e1/0 进入e1/0端口

    ip address 192.168.3.1 255.255.255.0 设置IP

    int e2/0 进入e2/0端口

    ip adress 192.168.5.1 255.255.255.0 设置IP

    rip 设置动态路由

    network 192.168.5.0 定义IP

    network 192.168.3.0 定义IP

    disp ip rout 查看路由接口

    R2:

    int e1/0 进入e1/0端口

    ip address 192.168.4.1 255.255.255.0 设置IP

    int e2/0 进入e2/0端口

    ip adress 192.168.5.2 255.255.255.0 设置IP

    rip 设置动态路由

    network 192.168.5.0 定义IP

    network 192.168.4.0 定义IP

    disp ip rout 查看路由接口

    (注意:两台PC机的网关设置PC1 IP:192.168.3.1 PC2 IP:192.168.4.1)

    七、IP访问列表

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.168.1.1 255.255.255.0

    int e3/0

    ip address 192.168.2.1 255.255.255.0

    acl number 2001 (2001-2999属于基本的访问列表)

    rule 1 deny source 192.168.1.0 0.0.0.255 (拒绝地址192.168.1.0网段的数据通过)

    rule 2 permit source 192.168.3.0 0.0.0.255(允许地址192.168.3.0网段的数据通过)

    以下是把访问控制列表在接口下应用:

    firewall enable

    firewall default permit

    int e3/0

    firewall packet-filter 2001 outbound

    disp acl 2001 显示信息

    undo acl number 2001 删除2001控制列表

    扩展访问控制列表

    acl number 3001

    rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255 destination-port eq ftp

    必须在r-acl-adv-3001下才能执行

    rule permit ip source an destination any (rule permit ip)

    int e3/0

    firewall enable 开启防火墙

    firewall packet-filter 3001 inbound

    必须在端口E3/0下才能执行

    八、命令的标准访问IP列表(三层交换机):

    允许A组机器访问服务器内资料,不允许访问B组机器(服务器没有限制)

    sys

    vlan 10

    name server

    vlan 20

    name teacher

    vlan 30

    name student

    int e1/0/5

    port access vlan 10

    int e1/0/10

    port access vlan 20

    int e1/0/15

    port access vlan 30

    int vlan 10

    ip address 192.168.10.1 255.255.255.0

    undo sh

    int vlan 20

    ip address 192.168.20.1 255.255.255.0

    int vlan 30

    ip address 192.168.30.1 255.255.255.0

    acl number 2001

    rule 1 deny source 192.168.30.0 0.0.0.255

    rule 2 permit source any

    disp acl 2001 查看2001列表

    int e1/0/10

    port access vlan 20

    packet-filter outbound ip-group 2001 rule 1

    出口

    九、允许A机器访问B机器的FTP但不允许访问WWW,C机器没有任何限制。

    vlan 10

    vlan 20

    vlan 30

    int e1/0/5

    port access vlan 10

    int e1/0/10

    port access vlan 20

    int e1/0/15

    port access vlan 30

    int vlan 10

    ip address 192.168.10.1 255.255.255.0

    undo sh

    int vlan 20

    ip address 192.168.20.1 255.255.255.0

    int vlan 30

    ip address 192.168.30.1 255.255.255.0

    acl number 3001

    rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0 0.0.0.255 destination-port eq www

    int e1/0/15

    packet-filter inbound ip-group 3001 rule 1

    进口

    十、NAT地址转换(单一静态一对一地址转换)

    R1:

    sys

    sysname R1

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.1.1.1 255.255.255.0

    R2:

    sys

    sysname R2

    int e2/0

    ip address 192.1.1.2 255.255.255.0

    int e1/0

    ip address 10.80.1.1 255.255.255.0

    回到R1:

    nat static 192.168.3.1 192.1.1.1

    int e2/0

    nat outbound static

    ip route 0.0.0.0 0.0.0.0 192.1.1.2

    十一、NAT内部整网段地址转换

    R1:

    sys

    sysname R1

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.1.1.1 255.255.255.0

    acl number 2008

    rule 0 permit source 192.168.3.0 0.0.0.255

    rule 1 deny

    quit

    int e2/0

    nat outbound 2008

    quit

    ip route-static 0.0.0.0 0.0.0.0 192.1.1.2 preference 60

    下一个路由接口地址

    R2:

    sys

    sysname R2

    int e2/0

    ip address 192.1.1.2 255.255.255.0

    int e1/0

    ip address 10.80.1.1 255.255.255.0

    NAT地址池配置:

    R1:

    sys

    sysname R1

    int e1/0

    ip address 192.168.3.1 255.255.255.0

    int e2/0

    ip address 192.1.1.1 255.255.255.0

    nat address-group 1 192.1.1.1 192.1.1.5 配置地址池

    undo address-group 1 删除地址池

    acl number 2001 创建访问列表

    rule permit source 192.168.1.0 0.0.0.255

    允许192.168.1.0/24网段地址转换(ethernet2/0指路由器wan口):

    int e2/0

    nat outbound 2001 address-group 1 启用协议

    ip route 0.0.0.0 0.0.0.0 192.1.1.2 默认路由

    R2:

    sys

    sysname R2

    int e1/0

    ip address 10.80.1.1 255.255.255.0

    int e2/0

    ip address 192.1.1.2 255.255.255.0

    展开全文
  • 1. 交换机连接方式本地:计算机COM口/USB口 --> Console线 -->... 华为VRP网络操作系统1)华为有四种视图模式//用户视图:查看运行状态或其他参数[Huawei]//系统视图:配置设备的系统参数[Huawei-...

    1. 交换机连接方式

    本地:计算机COM口/USB口 --> Console线 --> 交换机Console口(新购买设备,远程管理不方便进行设备维护)

    远程:Putty、SecureCRT、Xshell远程管理工具(工作中最主要的管理方式)

    2. 华为VRP网络操作系统

    1)华为有四种视图模式

    //用户视图:查看运行状态或其他参数

    [Huawei]//系统视图:配置设备的系统参数

    [Huawei-GigabitEthernet0/0/1]//接口视图:配置接口

    [Huawei-ospf-1]//协议视图:配置xx协议

    2)切换不同的视图

    system-view     //进入系统视图

    [Huawei]

    [Huawei]interface GigabitEthernet 0/0/1//进入千兆接口g0/0/01    (如果是s3700,是 int e0/0/1--百兆接口)

    [Huawei-GigabitEthernet0/0/1]

    [Huawei]ospf//进入ospf 协议视图

    [Huawei-ospf-1]

    3)视图回退操作

    quit//返回前一个视图(逐级返回)

    return = Ctrl+Z//直接返回到用户视图

    4)操作技巧

    tab自动补齐:当输入的命令前几个字母唯一标识一个命令的时候tab键则会自动补齐该命令

    ?在输入的命令字母后面紧跟着?则会把以该字母开头的所有命令显示出来

    在输入的命令后面空格+?显示这个命令后面接的命令有哪些

    命令可以简写,不区分大小写

    sys//按tab键,自动补齐

    system-view //按Ctrl+z键,返回到用户模式

    sy?//?获取帮助,

    system-view

    sy//按回车键

    Enter system view, return user view with Ctrl+Z.

    [Huawei]QUIT//大写

    3. 命令行基本操作

    display version//显示系统版本,设备型号,已开机时间信息

    [Huawei]sysname bj-wsl-sw1//配置设备名,便于区分

    [bj-wsl-sw1]inter  g/0/0/1//进入g0/0/1接口

    [bj-wsl-sw1-GigabitEthernet0/0/1]shutdown //默认自动开启,手动禁用接口

    [bj-wsl-sw1-GigabitEthernet0/0/1]undo shutdown //启用接口

    [bj-wsl-sw1]display current-configuration //查看当前交换机配置

    save //保存当前配置

    备注:

    华为大多数查询类的命令在任意一个视图下都能完成,用户视图下可以,系统视图下也可以,大多数查询命令不区分视图。

    4. 实用配置技巧

    1)设置终端密码,进入用户视图的密码

    system-view //进入系统视图

    [bj-wsl-sw1]user-interface console 0//进入终端配置

    [bj-wsl-sw1-ui-console0]authentication-mode password //启用密码认证

    [bj-wsl-sw1-ui-console0]set authentication password cipher Taren1//设置终端登录密码Taren1

    [bj-wsl-sw1-ui-console0]return //返回到用户视图

    quit//退出用户视图外

    2)更改自动退出超时,默认10分钟终端不操作会自动退出

    system-view //进入系统视图

    [bj-wsl-sw1]user-interface console 0//进入终端配置

    [bj-wsl-sw1-ui-console0]idle-timeout 1440//更改自动退出时间为1440分钟

    3)取消终端提示信息

    undo terminal monitor     //关闭日志消息

    4)恢复出厂设置

    reset saved-configuration (按Y)//恢复出厂设置

    reboot (按N,按Y)//重启,按N,按Y回车

    暂无标签

    展开全文
  • 这个是基本的网络设备操作命令 适合初学者 简单直观 操作方便
  • 查看交换机MAC地址表:display mac-address 刚启动时MAC地址表是空的 主机间通信测试: 在计算机网络中交换机有自学习功能,其内部的帧交换表(又称地址表)是通过自学习算法自动的逐渐建立起来的 ...

    网络拓扑:
    在这里插入图片描述

    Host-1的IP地址为:192.168.66.11 /24
    Host-2的IP地址为:192.168.66.12 /24
    Host-3的IP地址为:192.168.66.13 /24
    Host-4的IP地址为:192.168.66.14 /24

    查看交换机MAC地址表:display mac-address
    在这里插入图片描述
    刚启动时MAC地址表是空的
    主机间通信测试:
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在计算机网络中交换机有自学习功能,其内部的帧交换表(又称地址表)是通过自学习算法自动的逐渐建立起来的

    展开全文
  • 查看交换机接口模式、速率:display interface Ethernet brief 配置GigabitEthernet0/0/1接口: ①.interface GigabitEthernet 0/0/1 进入该接口 ②.接口改为非自协商:undo negotiation auto ③.设置接口速率:...

    查看交换机接口模式、速率:display interface Ethernet brief

    在这里插入图片描述
    配置GigabitEthernet0/0/1接口:
    ①.interface GigabitEthernet 0/0/1 进入该接口
    ②.接口改为非自协商:undo negotiation auto
    ③.设置接口速率:speed 100
    ④.设置接口为全双工:duplex full
    在这里插入图片描述

    展开全文
  • 命令前加undo关键字,可用来禁用某个功能或者删除某项配置。几乎每条配置命令都有对应的undo操作。 查看所有接口信息:display interface 查看指定接口信息:display interface Ethernet0/0/1 进入Ethernet0/0/1...
  • 1、[HUAWEI]command-privilege level 15 view shell reboot //设置reboot用户最高访问权限2、[HUAWEI]fixdisk flash //修复文件系统3、[HUAWEI]startup system-software file //设置下次启动的配置4、[HUAWEI]...
  • 本次实验:华为模拟器eNSP官方版(交换机网络仿真平台)进行实验 本次学习:华为S5700怎么划分VLAN? 把vlan划分到端口上大概思路:①创建VLAN②进入端口中,改变端口模式③将端口划入到VLAN中④查看是否成功把端口加入...
  • 华为交换设备基本配置 华为交换机基本命令操作
  • 华为交换机基本配置命令交换机是按照通信两端传输信息的需要,用人工或设备自动完成的方法,把要传输的信息送到符合要求的相应路由上的技术的统称。那么华为交换机的配置命令有哪些呢?下面跟yjbys小编一起来看看吧!...
  • 主要介绍了华为交换机基本配置命令详解,需要的朋友可以参考下
  • [Huawei]intg0/0/1[Huawei]portlink-typeaccess(注:接口类型access,hybrid、trunk)[Huawei]portdefaultvlan10批量端口放入VLAN[Huawei]port-group1[Huawei-port-group-1]group-memberethernetG0/0/1...
  • 5: 交换机保存设置和重置命令 save //保存配置信息 reset saved-configuration /重置交换机的配置 reboot //重新启动交换机 6:交换机常用的显示命令 用户视图模式下: display current-configuration //显示现在...
  • 深圳信狮华为交换机基本配置命令,介绍华为基本命令,二层交换配置,三层交换配置以及访问控制列表技术应用
  • 华为交换机基本配置命令 一、单交换机VLAN划分 命令 命令解释 system 进入系统视图 system-view 进入系统视图 quit 退到系统视图 undo vlan 20 删除vlan 20 sysname 交换机命名 disp vlan 显示vlan vlan 20...
  • 达内网络运维工程师 华为交换机、路由器的基本命令 更新中
  • 前言:最近一直有读者咨询有关于交换机配置命令的汇总有没有,我们从事弱电集成工作,会一些简单的交换机配置还是有必要的,想深入学习的话,还是要偏向于网络工程师了。正文:一、单交换机VLAN划分命令 命令解释...
  • 华为交换机配置命令

    2018-07-13 15:13:17
    华为交换机基础配置命令基本操作配置虚拟接口、配置vlan ID等

空空如也

空空如也

1 2 3 4 5 ... 15
收藏数 293
精华内容 117
关键字:

华为交换机基本命令