精华内容
下载资源
问答
  • 思科路由器NAT配置详解(转)

    万次阅读 2019-08-07 20:23:10
    思科路由器NAT配置详解(转) 网络技术 2010-07-11 17:48:14 阅读104 评论0 字号:大中小订阅 思科路由器NAT配置详解 一、NAT简介: NAT(Network Address Translation)网络地址转换。 最早出现在思科...

    思科路由器NAT配置详解(转)

    网络技术 2010-07-11 17:48:14 阅读104 评论0   字号: 订阅

    思科路由器NAT配置详解 - ILCHN - ILCHN

    思科路由器NAT配置详解

    一、NAT简介: 

    NAT(Network Address Translation)网络地址转换。 

    最早出现在思科11.2 IOS中,定义在RFC1631和RFC3022中。

    NAT最主要的作用是为了缓解IPv4地址空间的不足。

    同时也带来了一些问题,如每个数据包到达路由器后都要进行包头的转换操作,所以增加了延迟;DNS区域传送,BOOTP/DHCP等协议不可穿越NAT路由器;

    改动了源IP,失去了跟踪到端IP流量的能力,所以使责任不明确了。   

    但是利还是要大于弊的,不然也不会学习它了!最新的CCNA640-802学习指南中依然有专门的一章来讲解NAT,它的重要性可见一斑。   

    二、NAT术语:比较难理解,所以这里用最明了的语言总结如下 -  

    内部本地地址( inside local address ):局域网内部主机的地址,通常是RFC1918地址空间中的地址,称为私有地址。(待转换的地址)  

    内部全局地址(inside global address):内部本地地址被NAT路由器转换后的地址,通常是一个可路由的公网地址。

    外部全局地址(outside global address):是与内部主机通信的目标主机的地址,通常是一个可路由的公网地址。

    外部本地地址(outside local address):是目标主机可路由的公网地址被转换之后的地址,通常是RFC1918地址空间中的地址。

    三、NAT配置详解:  

    静态NAT:将一个私有地址和一个公网地址一对一映射的配置方法,这种方式不能节省IP,通常只为需要向外网提供服务的内网服务器配置。

     

    如图所示:

              PC1地址:192.168.0.2/24  

              PC2地址:192.168.0.3/24

              R1 E0/0地址:192.168.0.1/24     

              R1 S0/0地址:202.106.0.1/24

              R2 S0/0地址:202.106.0.2/24 

              R2 E0/0地址:202.106.1.1/24

              PC3地址:202.106.1.2/24

    各接口地址按上面配置好之后,在R1和R2上配置路由(注意不要为192.168.0.0网络增加路由项,因为私有网络不可以出现在公网路由表中,不然也不叫私有地址了)  

    路由配置好之后在R1上可以ping通PC3,但是PC1只能ping到R1的S0/0,再向前就ping不通了。因为没有192.168.0.0网络的路由表项,所以被丢弃了!下面在R1上配置静态NAT让PC1可以和PC3通信。 

    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口   

    Router(config-if)#int s0 /0/0

    Router(config-if)#ip nat outside //将该接口标记为外部接口

    Router(config-if)#exit

    Router(config)#ip nat inside source static 192.168.0.2 202.106.0.3 //将来自标记为内部接口的地址做为转换源,将 192.168.0.2一对一的转换成 202.106.0.3   

            2、动态NAT:现在PC1就可以和PC3通信了。但是PC2不能,因为R1并没有为PC2提供地址转换。当然我们可以在R1上像给PC1做静态转换一样也给PC2做一个,可如果我们有100台机器工作量就太大了。下面在R1上再继续配置:   

    Router(config)#access-list 10 permit 192.168.0.0 0.0.0.255  //定义标准访问控制列表10只允许定义的地址能够被转换

    Router(config)#ip nat pool out 202.106.0.4 202.106.0.24 netmask 255.255.255.0  //定义名称为out的地址池。

    Router(config)#ip nat inside source list 10 pool out //将访问控制列表定义的地址和地址池关联这样就有前21个内部主机能够得到公网地址。  

    现在PC2也可以和PC3通信了。这就是动态NAT,这种方式也不能节约IP地址。有一百台主机就要100个公网IP,不常用。 

           3、PAT(Port Address Translation)端口地址转换:用一个或多个公网IP为多个私有地址提供转换,能够节省大量IP地址,这种方式在现实网络环境中最常用。

    Router(config)#ip nat inside source list 10 pool out  overload //只需要在动态NAT的基础上多出一个“overload”就可以让上面的21个公网地址反复使用。  

    如果我们只有一个公网地址且已经分配给了R1的S0/0口,可以使用下面的命令来对这仅有的一个公网地址反复利用或叫超载。   

    Router(config)#ip nat inside source list 10 interface serial 0 overload //就是在R1上不设置地址池,因为只有一个公网地址,而只对S0/0接口的地址超载。 

    注意:一条NAT转换条目要占用160字节内存,因此NAT的转换数目受路由器的内存限制。 

       4、配置端口映射:看配置就明白了

    还是上面的图和IP,看下面的配置   

    Router(config)#int fa0/0

    Router(config-if)#ip nat inside  //将该接口标记为内部接口  

    Router(config-if)#int s0  

    Router(config-if)#ip nat outside //将该接口标记为外部接口  

    Router(config-if)#exit  

    Router(config)#ip nat inside source static tcp 192.168.0.2 80 202.106.0.3 80 //将 192.168.0.2的80端口一对一的转换成 202.106.0.3的80端口,也就外网用户在浏览器里输入202.106.0.3时,会打开192.168.0.2上的WWW服务。这里公网地址也可以改成interface Serial1/0 80,如下: 

    Router(config)#ip nat inside source static tcp 192.168.0.3 21  interface Serial1/0 21 //如果只有一个公网地址还可以这样来转换。这样外网访问的不同服务就会定向到不同的内网服务器。   

        5、配置TCP负载平衡:还是上图IP也不变,假如PC1和PC2提供的是相同的WWW服务,为了实现负载平衡可以做如下配置:  

    Router(config)#ip nat pool www 192.168.0.2 192.168.0.3 netmask 255.255.255.0 type rotary //配置地址池www并设成旋转。

    Router(config)#access-list 10 permit 202.106.0.3

    Router(config)#ip nat inside destination list 10 pool www //这样当外网主机访问202.106.0.3的时候路由器会自动定向到192.168.0.2再有请求就定向到192.168.0.3如果地址池里还有别的地址会依次循环,实现负载平衡的目的。注意,地址有了,网络中还要有对应的主机存在,否则会使对方第一次连接失败。

    转载于:https://www.cnblogs.com/mac_arthur/archive/2011/05/26/2057835.html

    展开全文
  • Cisco路由器配置NAT的主要命令: 静态NAT: 1、指定NAT内部接口 在内网相应接口的接口配置模式下执行:ip nat inside 2、指定NAT外部接口 在外网相应接口的接口配置模式下执行:ip nat outside 3、在内部...

    一、基础

    Cisco路由器配置中NAT的主要命令:
    
      静态NAT:
         1、指定NAT内部接口
             在内网相应接口的接口配置模式下执行:ip nat inside
         2、指定NAT外部接口
             在外网相应接口的接口配置模式下执行:ip nat outside
         3、在内部本地地址与内部全局地址之间建立静态地址转换关系:
             ip nat inside source static 内部本地地址 内部全局地址
         4、在外部全局地址与外部本地地址之间建立静态地址转换关系:
             ip nat outside source static 外部全局地址 外部本地地址
         5、
             show ip nat translations:显示当前存在的NAT转换信息。 
            show ip nat statics:查看NAT的统计信息。 
            show ip nat translations verbose:显示当前存在的NAT转换的详细信息。 
            debug ip nat:跟踪NAT操作,显示出每个被转换的数据包。 
            Clear ip nat translations *:删除NAT映射表中的所有内容.
    
      动态地址NAT:
         1、指定NAT内部接口
             在内网相应接口的接口配置模式下执行:ip nat inside
         2、指定NAT外部接口
             在外网相应接口的接口配置模式下执行:ip nat outside
         3、在全局配置模式下,定义一个标准的access-list规则,声明允许哪些内部本地地址可以进行动态地址转换:
             access-list list-number permit 源地址 通配符
             其中,list-number为1-99之间的一个任意整数。
         4、在全局配置模式下,定义内部全局地址池:
             ip nat pool 地址池名  起始IP地址  终止IP地址  netmask  子网掩码
             其中,地址池名可以任意设定,但最好有一定的说明意义。
         5、在全局配置模式下,定义符合先前定义的access-list规则的IP数据包与先前定义的地址池中的IP地址进行转换:
             ip nat inside source list list-number pool 内部全局地址池名
         6、no ip nat pool name            删除全局地址池
             no access-list access-list-number        删除访问列表
             no ip nat inside source            删除动态源地址转换
    
      网络地址端口转换NAPT:
         1、指定NAT内部接口
             在内网相应接口的接口配置模式下执行:ip nat inside
         2、指定NAT外部接口
             在外网相应接口的接口配置模式下执行:ip nat outside
         3、在全局配置模式下,定义内部全局地址池:
             ip nat pool  地址池名  起始IP地址  终止IP地址  netmask  子网掩码
             其中,地址池名可以任意设定,但最好有一定的说明意义。
         4、在全局配置模式下,定义一个标准的access-list规则,声明允许哪些内部本地地址可以进行复用地址转换:
             access-list list-number permit 源地址 通配符
             其中,list-number为1-99之间的一个任意整数。
         5、在全局配置模式下,定义符合先前定义的access-list规则的IP数据包与先前定义的地址池中的IP地址进行复用地址转换:
             ip nat inside source list list-number pool 内部全局地址池名 overload
    
    

    注:

    内部本地地址、内部全局地址、外部本地地址、外部全局地址

    ip nat inside/outside针对的是不同方向的流量/数据包。
    ip nat inside是指从内网发送的数据包,提取包头的源IP地址,转换为外网地址;ip nat outside是指从外网返回的数据包,提取包头的目的ip地址,转换为内网地址。
    inside/outside不是用来区分NAT路由器的内外部接口,而是用来区分需要NAT地址转换的不同方向的流量。inside指内部网络;outside指内部网络需要连接的网络,一般指互联网

    二、实例

    1、静态nat

    基本命令

    ip nat inside source static 192.168.1.10 13.0.1.3
    ip nat inside
    ip nat outside
    

    这里先使用静态nat使pc1能与R2连接通信

    先配置pc1和pc2的ip

    再配置路由器R1和R2

    R1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config)#int f0/0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#int
    *Mar  1 00:02:12.327: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:02:13.327: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R1(config-if)#int f1/0
    R1(config-if)#ip address 13.0.1.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#
    *Mar  1 00:02:41.819: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
    *Mar  1 00:02:42.819: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
    R1(config-if)#exit
    R1(config)#ip nat inside source static 192.168.1.10 13.0.1.3
    R1(config-if)#int f0/0
    R1(config-if)#ip nat inside
    R1(config-if)#
    *Mar  1 00:03:29.095: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
    R1(config-if)#int f1/0
    R1(config-if)#ip nat outside
    
    
    R2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R2(config)#int f0/0
    R2(config-if)#ip address 13.0.1.2 255.255.255.0
    R2(config-if)#no sh
    
    

    测试

    2、动态NAT

    使用动态nat使pc2与R2通信

    R1(config)#ip nat pool test 13.0.1.10 13.0.1.20 netmask 255.255.255.0
    !定义内部全局地址池
    R1(config)#access-list 10 permit 192.168.1.0 0.0.0.255
    !定义访问控制列表,内部本地地址范围
    R1(config)#ip nat inside source list 10 pool test
    !建立映射关系
    
    R1(config)#int f0/0
    R1(config-if)#ip nat inside                                            !定义内部网络接口
    R1(config)#int f1/0
    R1(config-if)#ip nat outside                                        !定义外部网络接口
    

    将192.168.1.0/24网段的内部主机动态转换到全局地址13.0.1.10-13.0.1.20之间的ip,内部网络的其他网段(非192.168.1)的主机不允许做NAT

    测试

    3、PAT

    1)静态PAT

    R1(config)#ip nat inside source static {UDP|TCP} local-address port global-address port
    

    例:

    这里我们将C1的telnet服务映射到13.0.1.3的999端口,来测试一下静态PAT

    R3模拟为主机C1,并且开启telnet服务

    c1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    c1(config)#no ip routing
    c1(config)#int f0/0
    c1(config-if)#ip address 192.168.1.2 255.255.255.0
    c1(config-if)#no sh
    c1(config-if)#
    *Mar  1 00:03:16.475: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:03:17.475: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    c1(config-if)#exit
    c1(config)#ip def
    c1(config)#ip default-g
    c1(config)#ip default-gateway 192.168.1.1
    c1(config)#end
    c1#sho
    *Mar  1 00:04:06.223: %SYS-5-CONFIG_I: Configured from console by console
    c1#show ip route
    Default gateway is 192.168.1.1
    
    Host               Gateway           Last Use    Total Uses  Interface
    ICMP redirect cache is empty
    c1#
    
    
    !开启telnet
    
    c1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    c1(config)#line vty 0 4
    c1(config-line)#login
    % Login disabled on line 130, until 'password' is set
    % Login disabled on line 131, until 'password' is set
    % Login disabled on line 132, until 'password' is set
    % Login disabled on line 133, until 'password' is set
    % Login disabled on line 134, until 'password' is set
    c1(config-line)#password zwish
    c1(config-line)#access-list 101 permit ip any any
    c1(config-line)#end
    

    R2

    R2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R2(config)#int f0/0
    R2(config-if)#ip address 13.0.1.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#
    *Mar  1 00:06:58.331: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:06:59.331: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2(config-if)#
    
    

    R1配置静态PAT

    R1#en
    R1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config)#int f0/0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#int
    *Mar  1 00:06:06.983: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:06:07.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R1(config-if)#int f1/0
    R1(config-if)#ip address 13.0.1.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#
    *Mar  1 00:06:27.363: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
    *Mar  1 00:06:28.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
    R1(config-if)#exit
    R1(config)#ip nat inside source static tcp 192.168.1.2 23 13.0.1.3 999
    R1(config)#int f0/0
    R1(config-if)#ip nat inside
    R1(config-if)#int f1/0
    R1(config-if)#ip nat outside
    R1(config-if)#exit
    
    

    这里最重要异步就是将192.168.1.2的telnet服务映射到了13.0.1.3的999端口

    最后配置好了,用R2来telenet登陆一下C1,telnet 13.0.1.3 999

    成功!

    抓个包看一下,源地址和目的地址分别为13.0.1.2和192.168.1.2

    2)动态PAT

    R1配置

    R1#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config)#int f0/0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#int f1/0
    R1(config-if)#
    *Mar  1 00:01:11.115: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:01:12.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R1(config-if)#int f1/0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    % 192.168.1.0 overlaps with FastEthernet0/0
    R1(config-if)#ip address 13.0.1.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#
    *Mar  1 00:05:50.503: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
    *Mar  1 00:05:51.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
    R1(config-if)#exit
    R1(config)#ip nat pool test 13.0.1.3 13.0.1.3 netmask 255.255.255.0
    R1(config)#ac
    *Mar  1 00:07:20.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
    R1(config)#access-list 10 permit 192.168.1.0 0.0.0.255
    R1(config)#ip nat inside source list 10 pool test overload
    R1(config)#int f0/0
    R1(config-if)#ip nat inside
    R1(config-if)#int f1/0
    R1(config-if)#ip nat outside
    
    

    R2

    R2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R2(config)#int f0/0
    R2(config-if)#ip address 13.0.1.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#
    *Mar  1 00:06:05.027: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar  1 00:06:06.027: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2(config-if)#
    
    

    pc1和pc2

    VPCS[1]> ip 192.168.1.2 192.168.1.1 24
    Checking for duplicate address...
    PC1 : 192.168.1.2 255.255.255.0 gateway 192.168.1.1
    
    VPCS[1]> 2
    VPCS[2]> ip 192.168.1.3 192.168.1.1 24
    Checking for duplicate address...
    PC2 : 192.168.1.3 255.255.255.0 gateway 192.168.1.1
    
    VPCS[2]> show
    
    NAME   IP/MASK              GATEWAY           MAC                LPORT  RHOST:PORT
    VPCS1  192.168.1.2/24       192.168.1.1       00:50:79:66:68:00  20000  127.0.0.1:30000
           fe80::250:79ff:fe66:6800/64
    VPCS2  192.168.1.3/24       192.168.1.1       00:50:79:66:68:01  20001  127.0.0.1:30001
           fe80::250:79ff:fe66:6801/64
    
    

    pc1和pc2分别ping R2,发现源地址都是13.0.1.3

    展开全文
  • 很实用的实战思科路由器NAT案例配置详解,路由器是利用NAT技术,把内网的多个IP与端口映射 到外网IP(WAN口)的端口进行通讯
  • 思科路由器NAT配置详解s.pdf
  • cisco路由器nat配置

    2015-07-17 11:34:34
    nat的简单介绍,以及cisconat的具体配置,如要理解nat的概念,请联系百度。
  • 思科路由器NAT配置详解.docx
  • 微思讲师-视频教学:思科路由器动态NAT配置https://www.zhihu.com/zvideo/1459172004850565120 1. 理解动态NAT的转换原理 2. 掌握动态NAT的配置方法 实验拓扑 1. 根据实验拓扑图,完成设备的基本配置...

    相关学习推荐: 优秀的网工都会NAThttps://blog.csdn.net/XMWS_IT/article/details/121508603?spm=1001.2014.3001.5502

     微思讲师-视频教学  思科路由器动态NAT配置https://www.zhihu.com/zvideo/1459172004850565120 

    1. 理解动态NAT的转换原理

    2. 掌握动态NAT的配置方法

    实验拓扑

    1. 根据实验拓扑图,完成设备的基本配置;

    2. 在R2上创建Loopback0接口,IP地址是9.2.6.7/32,模拟公网上的一台服务器;

    3. 在R1上配置动态NAT,地址池范围为12.1.1.11~12.1.1.20,使得PC1和PC2能够访问公网服务器。

    步骤1:设备的基本配置

    配置PC1

    Router>enableRouter#configure terminalRouter(config)#hostname PC1PC1(config)#no ip routingPC1(config)#ip default-gateway 192.168.1.254PC1(config)#interface ethernet0/0PC1(config-if)#ip address 192.168.1.1 255.255.255.0PC1(config-if)#no shutdownPC1(config-if)#endPC1#

    配置PC2:

    Router>enableRouter#configure terminalRouter(config)#hostname PC2PC2(config)#no ip routingPC2(config)#ip default-gateway 192.168.1.254PC2(config)#interface ethernet0/0PC2(config-if)#ip address 192.168.1.2 255.255.255.0PC2(config-if)#no shutdownPC2(config-if)#endPC2#

    配置SW1

    Switch>enaSwitch#conf tSwitch(config)#no ip domain-lookupSwitch(config)#line console 0Switch(config-line)# logging sSwitch(config-line)# exec-t 0 0Switch(config-line)# exitSwitch(config)#hostname SW1SW1(config)#endSW1#

    配置R1:

    ​​​​​​​

    Router>enableRouter#configure terminalRouter(config)#hostname R1R1(config)#no ip domain-lookupR1(config)#line console 0R1(config-line)#exec-timeout 0 0R1(config-line)#logging synchronousR1(config-line)#exitR1(config)#interface ethernet0/0R1(config-if)#ip address 192.168.1.254 255.255.255.0R1(config-if)#no shutdownR1(config-if)#exitR1(config)#interface ethernet0/1R1(config-if)#ip address 12.1.1.1 255.255.255.0R1(config-if)#no shutdownR1(config-if)#endR1#

    配置R2:​​​​​​​

    Router>enableRouter#configure terminalRouter(config)#hostname R2R2(config)#no ip domain-lookupR2(config)#line console 0R2(config-line)#exec-timeout 0 0R2(config-line)#logging synchronousR2(config-line)#exitR2(config)#interface loopback0R2(config-if)#ip address 9.2.6.7 255.255.255.255R2(config-if)#exitR2(config)#interface ethernet0/0R2(config-if)#ip address 12.1.1.2 255.255.255.0R2(config-if)#no shutdownR2(config-if)#endR2#

    步骤2:配置动态NAT

    配置R1​​​​​​​

    R1(config)#ip nat pool xmws 12.1.1.11 12.1.1.20 netmask 255.255.255.0   //创建地址池R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255   //通过ACL定义哪些子网能做NATR1(config)#ip nat inside source list 1 pool xmws   //关联ALC和地址池R1(config)#interface ethernet 0/0R1(config-if)#ip nat inside   //指定inside接口R1(config-if)#exitR1(config)#interface ethernet 0/1R1(config-if)#ip nat outside   //指定outside接口R1(config-if)#exitR1(config)#ip route 0.0.0.0 0.0.0.0 12.1.1.2   //配置到达公网的默认路由

    测试PC1访问服务器:​​​​​​​

    PC1#ping 9.2.6.7Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 9.2.6.7, timeout is 2 seconds:!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

    测试PC2访问服务器:

    ​​​​​​​

    PC2#ping 9.2.6.7Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 9.2.6.7, timeout is 2 seconds:!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

    检查R1的NAT表项:​​​​​​​

    R1#show ip nat translationsPro Inside global      Inside local       Outside local      Outside globalicmp 12.1.1.12:6       192.168.1.1:6      9.2.6.7:6          9.2.6.7:6--- 12.1.1.12          192.168.1.1        ---                ---icmp 12.1.1.13:4       192.168.1.2:4      9.2.6.7:4          9.2.6.7:4--- 12.1.1.13          192.168.1.2        ---                ---
    
    

    展开全文
  • cisco路由器nat配置[参考].pdf
  • 思科路由器静态NAT配置

    千次阅读 2019-04-24 16:40:28
    2、R5配置SNAT命令行 #进入config节点 R5#configure terminal Enter configuration commands, one per line. End with CNTL/Z. #配置接口IP R5(config)#interface Ethernet 1/0 R5(config-if)#ip address 11.11....

    1、拓扑图

    2、R5配置SNAT命令行

    #进入config节点
    R5#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    #配置接口IP
    R5(config)#interface Ethernet 1/0
    R5(config-if)#ip address 11.11.11.2 255.255.255.0
    R5(config-if)#no shutdown
    R5(config-if)#exit
    R5(config)#interface Ethernet 1/1
    R5(config-if)#ip address 13.13.13.1 255.255.255.0
    R5(config-if)#no shutdown
    R5(config-if)#exit
    
    #配置静态源NAT策略
    R5(config)#ip nat inside source static 11.11.11.1 13.13.13.1
    
    #进入接口E1/1
    R5(config)#interface ethernet 1/1
    
    #配置接口属性为NAT出接口
    R5(config-if)#ip nat outside
    R5(config-if)#exit
    
    #进入接口E1/2
    R5(config)#interface ethernet 1/2
    
    #配置接口属性为NAT入接口
    R5(config-if)#ip nat inside

    3、结果验证:

    R2 ping R3,在R3端debug查看

    展开全文
  • Hello大家好,本篇博文讲述的是大学网络工程思科路由器NAT实验,供各大专院校学生与老师参考,如需转载,需注原创 有关NAT实验的代码 ip nat inside source static 192.168.1.2 222.0.1.3 int f0/0 ip nat inside ...
  • 静态NAT转换 采用如图所示的结构,每个端口配置如下的ip 首先得理解这个结构,r4的s2/0端口和r6和pc8共同组成外网 r4的f0/0和交换机s2以及pc6 pc7组成内网, 因此配完ip后,还得保证r4能ping通pc8 同样pc8也能ping...
  • NATvpdn enable no vpdn logging 由于ADSL的PPPoE应用是通过虚拟拨号来实现的所以在路由器中需要使用VPDN的功能 ! vpdn-group pppoe 为PPPoE启动了VPDN的进程 request-dialin protocol pppoe 设置拨号协议为PPPoE!...
  • Cisco NAT 配置指南

    万次阅读 多人点赞 2018-08-05 14:26:20
    NAT的基本知识 NAT(Network Address Translation )技术提供了一种完全将内部网络和Internet网隔离的方法,让内部网络中的计算机通过少数几个甚至一个合法IP地址(已申请的一个公网IP)访问Internet资源,从而节省...
  • NAT即Network Address Translation,它可以让那些使用私有地址的内部网络连接到Internet或其 它IP网络上。NAT路由器在将内部网络的数据包发送到公用网络时,在IP包的报头把私有地址转换成合法 的IP地址。
  • NAT是将IP数据报报头中的IP...本文为大家介绍一个思科路由器NAT配置实例,把内网地址转换成公网地址,并通过ACL控制,有选择地对内网地址段进行NAT转换,从而灵活控制可以上网的用户。 一、组网结构和需求 ...
  • 思科路由器NAT配置详解思科路由器NAT配置详解22
  • 思科路由器上实现NAT实例(设置企业WEB服务器)
  • CISCO路由器配置NAT功能 http://www.enet.com.cn/eschool/2011年07月13日11:59来源:来自论坛作者:佚名 【文章摘要】随着internet的网络迅速发展,IP地址短缺已成为一个十分突出的问题。为了解决这个问题,...
  • 思科路由器--nat

    千次阅读 2017-12-04 14:09:49
    思科路由器上做nat技术
  • 路由器NAT功能配置简介

    千次阅读 2019-08-07 17:53:15
    路由器NAT功能配置简介  随着internet的网络迅速发展,IP地址短缺已成为一个十分突出的问题。为了解决这个问题,出现了多种解决方案。下面几绍一种在目前网络环境中比较有效的方法即地址转换(NAT)功能。 一、NAT...
  • ip nat pool pool-name start-ip end-ip { netmask network | prefx-length prefix-lengh} 关键字netmask 或prefx-lengh指示哪些地址位于属于网络,哪些位于该地址范围内的主机。 步骤二:配置标准ACL、 范围太宽的...
  • Cisco 路由器 一定要配置 nat 超时时间。 ezvpn ,s2s vpn 避免断线了很久才重新链接,或者链接不会断开; 需要配置tcp 超时时间。 IP nat tcp timeout 130ms
  • 很久没有接触NAT地址转换了,我记得有一次在笔试一个做系统集成的公司,其中有一道题就是NAT与PAT的区别。当时对网络基本就没概念,所以只是简单说了一个NAT是地址转换,PAT是端口转换之类的笼统的话。以下的话抄自...
  • int g0/0 ip address 124.207.70.106 255.255.255.248 ip nat outside ip nat pool OUT 124.207.70.102 124.207.70.105 netmask 255.255.255.248 ...ip nat inside source list 100 pool OUT overload...
  • 以上图中的三台路由器,在做NAT之前,只需要都能访问到100段的网段就可以了 R1上路由只配置:bash ip route 0.0.0.0 0.0.0.0 100.1.1.2 R2上路由只配置:bash ip route 200.1.1.0 255.255.255.0 150.1.1.2 R3上路由...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,763
精华内容 3,505
关键字:

思科路由器nat配置