精华内容
下载资源
问答
  • cisco交换机vlan-trunk配置详解及应用实例
    千次阅读
    2020-12-18 22:40:43

    配置思路:

    1.创建vlan

    sw1#vlan database        进入vlan数据库

    sw1(vlan)#vlan 2 name jishu   创建名为:技术的vlan

    VLAN 40 modified:

    Name: jishu

    sw1(vlan)#vlan 3 name caiwu    创建名为:财务的vlan

    VLAN 41 modified:

    Name: caiwu

    sw2#vlan database        进入vlan数据库

    sw2(vlan)#vlan 2 name jishu   创建名为:技术的vlan

    VLAN 40 modified:

    Name: jishu

    sw2(vlan)#vlan 3 name renshi   创建名为:人事的vlan

    VLAN 41 modified:

    Name: renshi

    注:两台交换机的vlanid应该一致!

    2.将端口划分到以创建的vlan中

    sw1(config)#interface f0/1

    sw1(config-if-range)# switchport mode access           将1号接口设置为接入链路

    sw1(config-if-range)#switchport access vlan 2        将1号接口放进vlan2

    sw1(config-if)#no shutdown                              激活此端口

    sw1(config)#interface f0/2

    sw1(config-if-range)# switchport mode access           将2号接口设置为接入链路

    sw1(config-if-range)#switchport access vlan 3          将2号接口放进vlan3

    sw1(config-if)#no shutdown                             激活此端口

    sw2(config)#interface f0/1

    sw2(config-if-range)# switchport mode access           将1号接口设置为接入链路

    sw2(config-if-range)#switchport access vlan 2        将1号接口放进vlan2

    sw2(config-if)#no shutdown                              激活此端口

    3.配置trunk口,实现通信:

    sw1(config)#interface f0/0                        进入要设置的端口(f0/0)

    sw1(config-if)#switchport mode trunk                将端口进行trunk设置

    sw1(config-if)#no shutdown                         激活此端口

    sw2(config)#interface f0/0                        进入要设置的端口(f0/0)

    sw2(config-if)#switchport mode trunk                将端口进行trunk设置

    sw2(config-if)#no shutdown                         激活此端口

    这样我们就完成了交换机的配置了!

    测试:

    1.依据拓扑图配置ip地址

    2.同一vlan进行测试

    3.不同lan进行测试

    测试成功!!!!!

    更多相关内容
  • 思科CISCOTRUNK简单配置

    万次阅读 2019-05-12 10:28:35
    思科TRUNK配置 一、项目背景 需要 TRUNK 才能在交换机之间传递 VLAN 信息。交换机上的端口可以是接入端口,或者是 TRUNK 端口。接入端口传输来自分配给该端口的特定 VLAN 的流量。TRUNK端口默认为所有 VLAN 的成员...

    思科TRUNK的简单配置

    一、项目背景

    需要 TRUNK 才能在交换机之间传递 VLAN 信息。交换机上的端口可以是接入端口,或者是 TRUNK 端口。接入端口传输来自分配给该端口的特定 VLAN 的流量。TRUNK端口默认为所有 VLAN 的成员;因此,它传输所有 VLAN 的流量。本练习主要介绍创建 TRUNK 端口并将它们分配给本征 VLAN(而不是默认 VLAN)。

    地址分配表

    设备接口IP地址子网掩码交换机端口VLAN
    PC1NIC172.17.10.21255.255.255.0S1F0/1110
    PC2NIC172.17.20.22255.255.255.0S1 F0/1820
    PC3NIC172.17.30.23255.255.255.0S1 F0/630
    PC4NIC172.17.10.24255.255.255.0S2 F0/1110
    PC5NIC172.17.20.25255.255.255.0S2 F0/1820
    PC6NIC172.17.30.26255.255.255.0S2 F0/630

    项目示意图

    示意图

    二、 实施计划

    1.大概流程:

    检查所有设备连接
    查看设备配置
    将未配置的设备配上配置
    检查配置结果

    三、实施过程

    1、查看所有的设备连接是否中断

    1.连接正常

    无问题

    2、检验设备配置(以S1为例)

    1.检验VLAN是否根据地址分配表创建

    检验VLAN的命令是:show vlan brief
    检验vlan
    S1已经创建了所需的VLAN

    2.查看是否创建中继和本征VLAN

    先查看交换机是哪些端口相互连接
    查看端口
    本征VLAN只需要配置在这些端口上
    在这里插入图片描述
    本征VLAN并未创建在G0/1和G0/2端口上

    3、在 S1 上配置中继并将 VLAN 99 用作本征 VLAN

    1.配置命令:

    S1 G0/1配置命令如下

    S1(config)#interface  g0/1
    S1(config-if)#switchport mode trunk
    S1(config-if)#switchport trunk native vlan 99
    

    在这里插入图片描述
    S1 G0/2配置命令如下

    S1(config)#interface  g0/2
    S1(config-if)#switchport mode trunk
    S1(config-if)#switchport trunk native vlan 99
    

    在这里插入图片描述

    2.检验S1上的配置

    检查本征VLAN是否为99

    方法1

    S1#show interface g0/1 switchport
    

    在这里插入图片描述
    方法2

    S1#show running-config
    

    在这里插入图片描述

    S2和S3皆可按照上面步骤进行配置、

    展开全文
  • 思科交换机如何配置trunk

    千次阅读 2021-04-02 14:43:43
    2、掌握Trunk配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20; 4...

    实验目的

     

    1、理解Trunk的运行原理

    2、掌握Trunk的配置方法

     

    实验拓扑

     

    图片

    实验需求

     

    1、根据实验拓扑图,完成设备的基本配置;

    2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR;

    3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20;

    4、把SW1和SW2互连的链路配置成Trunk,采用Dot1q封装;

    5、测试PC之间的网络连通性。

     

    实验步骤

     

     

     

    步骤1:设备的基本配置

    配置PC1

    •  
    •  
    VPCS> set pcname PC1   //设置主机名PC1> ip 10.1.1.1/24      //设置IP地址

     

    配置PC2

    •  
    •  
    VPCS> set pcname PC2PC2> ip 10.1.2.1/24

     

    配置PC3

    •  
    •  
    VPCS> set pcname PC3PC3> ip 10.1.1.2/24

     

    配置PC4

    •  
    •  
    VPCS> set pcname PC4PC4> ip 10.1.2.2/24

     

    配置SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    Switch>enableSwitch#configure terminalSwitch(config)#hostname SW1SW1(config)#no ip domain-lookupSW1(config)#line console 0SW1(config-line)#exec-timeout 0 0SW1(config-line)#logging synchronousSW1(config-line)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    Switch>enableSwitch#configure terminalSwitch(config)#hostname SW2SW2(config)#no ip domain-lookupSW2(config)#line console 0SW2(config-line)#exec-timeout 0 0SW2(config-line)#logging synchronousSW2(config-line)#endSW2#

     

    步骤2:VLAN的配置

    配置SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1(config)#vlan 10SW1(config-vlan)#name ITSW1(config-vlan)#exitSW1(config)#vlan 20SW1(config-vlan)#name HRSW1(config-vlan)#exitSW1(config)#interface Eth0/1SW1(config-if)#switchport mode accessSW1(config-if)#switchport access vlan 10SW1(config-if)#exitSW1(config)#interface Eth0/2SW1(config-if)#switchport mode access   SW1(config-if)#switchport access vlan 20SW1(config-if)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2(config)#vlan 10SW2(config-vlan)#name ITSW2(config-vlan)#exitSW2(config)#vlan 20SW2(config-vlan)#name HRSW2(config-vlan)#exitSW2(config)#interface Eth0/1SW2(config-if)#switchport mode accessSW2(config-if)#switchport access vlan 10SW2(config-if)#exitSW2(config)#interface Eth0/2SW2(config-if)#switchport mode access   SW2(config-if)#switchport access vlan 20SW2(config-if)#endSW2#

     

    步骤3:Trunk的配置

    配置SW1

    •  
    •  
    •  
    •  
    •  
    SW1(config)#interface Eth0/0SW1(config-if)#switchport trunk encapsulation dot1qSW1(config-if)#switchport mode trunkSW1(config-if)#endSW1#

     

    配置SW2

    •  
    •  
    •  
    •  
    •  
    SW2(config)#interface Eth0/0SW2(config-if)#switchport trunk encapsulation dot1qSW2(config-if)#switchport mode trunkSW2(config-if)#endSW2#

     

    实验检查

     

     

    步骤1:检查VLAN

    检查SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1#show vlan brief
    
    VLAN Name                             Status    Ports---- -------------------------------- --------- -------------------------------1    default                             active     Et0/310   IT                                 active     Et0/120   HR                                active     Et0/21002 fddi-default                     act/unsup1003 token-ring-default               act/unsup1004 fddinet-default                  act/unsup1005 trnet-default                    act/unsupSW1已经创建好VLAN10和VLAN20,并已将对应接口划入。

     

    检查SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2#show vlan brief
    
    VLAN Name                             Status    Ports---- -------------------------------- --------- -------------------------------1    default                             active    Et0/310   IT                                 active    Et0/120   HR                                active    Et0/21002 fddi-default                     act/unsup1003 token-ring-default               act/unsup1004 fddinet-default                  act/unsup1005 trnet-default                    act/unsupSW2已经创建好VLAN10和VLAN20,并已将对应接口划入。

     

    步骤2:检查Trunk

    检查SW1

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW1#show interfaces Eth0/0 switchportName: Et0/0Switchport: EnabledAdministrative Mode: trunkOperational Mode: trunkAdministrative Trunking Encapsulation: dot1qOperational Trunking Encapsulation: dot1qNegotiation of Trunking: OnAccess Mode VLAN: 1 (default)Trunking Native Mode VLAN: 1 (default)Administrative Native VLAN tagging: enabledVoice VLAN: noneAdministrative private-vlan host-association: noneAdministrative private-vlan mapping: noneAdministrative private-vlan trunk native VLAN: noneAdministrative private-vlan trunk Native VLAN tagging: enabledAdministrative private-vlan trunk encapsulation: dot1qAdministrative private-vlan trunk normal VLANs: noneAdministrative private-vlan trunk associations: noneAdministrative private-vlan trunk mappings: noneOperational private-vlan: noneTrunking VLANs Enabled: ALLPruning VLANs Enabled: 2-1001Capture Mode DisabledCapture VLANs Allowed: ALLProtected: falseAppliance trust: noneE0/0接口当前是Trunk,封装的协议是dot1q。SW1#show interfaces trunkPort        Mode            Encapsulation   Status        Native vlanEt0/0       on               802.1q         trunking      1
    
    Port        Vlans allowed on trunkEt0/0       1-4094Port        Vlans allowed and active in management domainEt0/0       1,10,20Port        Vlans in spanning tree forwarding state and not prunedEt0/0       1,10,20E0/0封装的Trunk协议是dot1q,当前的状态是trunking。SW1#sh run int Eth0/0Building configuration...Current configuration : 90 bytes!interface Ethernet0/0 switchport trunk encapsulation dot1q switchport mode trunkendE0/0接口的Trunk封装协议是dot1q,模式是trunk。

     

    检查SW2

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    •  
    SW2#show interfaces trunkPort        Mode             Encapsulation  Status        Native vlanEt0/0       on                802.1q        trunking      1
    
    Port        Vlans allowed on trunkEt0/0       1-4094Port        Vlans allowed and active in management domainEt0/0       1,10,20Port        Vlans in spanning tree forwarding state and not prunedEt0/0       1,10,20E0/0封装的Trunk协议是dot1q,当前的状态是trunking。

     

    步骤4:网络连通性测试

    测试PC1和PC3的连通性:

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    PC1> ping 10.1.1.284 bytes from 10.1.1.2 icmp_seq=1 ttl=64 time=1.603 ms84 bytes from 10.1.1.2 icmp_seq=2 ttl=64 time=1.234 ms84 bytes from 10.1.1.2 icmp_seq=3 ttl=64 time=1.027 ms84 bytes from 10.1.1.2 icmp_seq=4 ttl=64 time=2.372 ms84 bytes from 10.1.1.2 icmp_seq=5 ttl=64 time=1.200 msPC1和PC3的网络连通性正常。

     

    测试PC2和PC4的连通性:

    •  
    •  
    •  
    •  
    •  
    •  
    •  
    PC2> ping 10.1.2.284 bytes from 10.1.2.2 icmp_seq=1 ttl=64 time=0.887 ms84 bytes from 10.1.2.2 icmp_seq=2 ttl=64 time=0.932 ms84 bytes from 10.1.2.2 icmp_seq=3 ttl=64 time=1.295 ms84 bytes from 10.1.2.2 icmp_seq=4 ttl=64 time=0.926 ms84 bytes from 10.1.2.2 icmp_seq=5 ttl=64 time=1.011 msPC2和PC4的网络连通性正常。

     

    展开全文
  • 有的思科交换机用户不知道怎么配置,这次我们来介绍一下思科交换机虚拟串口配置VLAN Trunk的步骤。交换机串口(Trunk)的作用:在以太网上通过交换机的串口实现中继可以使用如下两种封装类型:—IEEE 802.1Q—ISL...

    思科交换机是目前最为著名的品牌产品,大部分的大型企业都使用思科交换机,其它品牌交换机明显没有这么受欢迎,交换机市场份额最大的无疑是思科。有的思科交换机用户不知道怎么配置,这次我们来介绍一下思科交换机虚拟串口配置VLAN Trunk的步骤。

    交换机串口(Trunk)的作用:

    在以太网上通过交换机的串口实现中继可以使用如下两种封装类型:

    —IEEE 802.1Q

    —ISL(Inter Switch Link, Cisco私有)

    配置步骤:

    第一步:在交换机上添加VLAN

    Switch1#vlan database

    Switch1(vlan)#vlan 2

    Switch1(vlan)#vlan 3

    Switch1(vlan)#exit

    第二步:将接口添加到相应的VLAN中

    Switch1#config terminal

    Switch1(config)#interface fastEthernet 0/1

    Switch1(config-if-range)#switchport access vlan 2

    Switch1(config)#interface fastEthernet 0/2

    Switch1(config-if-range)#switchport access vlan 3

    第三步:配置交换机之间互联的端口为串口(Trunk)

    Switch1(config)#interface f0/15

    Switch1(config-if-range)#switchport mode trunk

    相关其他命令

    去除VLAN:

    Switch(config-if)#switchport trunk allowed vlan removevlan-list

    添加VLAN:

    Switch(config-if)#switchport trunk allowed vlan add vlan-list

    查看端口状态:

    Switch#show interface f0/15switchport

    检查中继端口允许VLAN的列表:

    Switch#show interface interface-id switchport

    查看VLAN信息:

    Switch#show vlan brief

    查看配置:

    Switch#show running-config

    结束语:

    思科交换机虚拟串口配置VLAN Trunk的步骤到这里就介绍完了,思科路由器也非常受用户欢迎

    展开全文
  • Cisco交换机Trunk配置命令是什么?

    千次阅读 2020-12-28 20:22:40
    展开全部TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于...
  • 6. 交换机端口链路类型介绍6.1 交换机端口链路类型介绍交换机以太网端口共有三种链路类型:Access、Trunk 和 Hybrid。1.Access 类型的端口只能属于 1 个 VLAN,一般用于连接计算机的端口;2.Trunk 类型的端口可以...
  • 【CCNA】cisco交换机配置trunk

    万次阅读 2018-08-14 11:57:22
    a、不同vlan之间的通信需要依赖三层设备,图中的单臂路由就是实现不同vlan间通信用的,通过单臂路由配置不同的子接口ip,该子接口ip设置成相关需要通信vlan的网关地址即可。 b、经过trunk口的数据包会封装新的包头...
  • #配置 trunk 链路的封装类型,同一链路的两端封装要相同。有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。 Switch(config)#interface f0/2 Switch(config-if)#switchport trunk encapsulation dot1q...
  • 思科交换机配置TRUNK的主要步骤

    千次阅读 2020-12-18 22:39:12
    思科交换机配置TRUNK的主要步骤到底什么是TRUNK呢?使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的交换机产品中怎样来进行交换机配置TRUNK,下面我们来了解一下这些方面的知识。在二层交换机的性能...
  • 思科交换机如何配置Trunk

    千次阅读 2021-02-25 14:30:58
    2、掌握Trunk配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20...
  • 思科交换机端口配置

    2021-10-29 11:02:43
    思科端口配置前言强制Trunk模式主动模式被动模式协商被动模式和被动模式Trunk是建立不成功的 前言 思科端口配置命名 强制Trunk模式 在接口模式下进入Trunk模式 主动模式 在接口模式下输入switchport mode dynamic ...
  • Cisco交换机配置VLAN与TRUNK

    千次阅读 2020-12-28 20:22:37
    0x01准备:Cisco模拟器0x02正文:要求:VLAN 10 左边的IP:192.168.1.11 192.168.2.11 192.168.3.11 右边的IP:192.168.1.12 192.168.2.12 192.168.3.12VLAN 20VLAN 30配置好VLAN和弄好Trunk还...
  • 思科交换机配置trunk模式及vtp

    千次阅读 2022-03-21 09:12:25
    一、 TRUNK 的背景 : 如果交换机与交换机之间存在多条链路,交换机每增加一个vlan,交换机与交换机就会增加一条链路。这样会存在链路浪费,就产生了 DTP ( dynamic trunk protocols)采用trunk后,所有的vlan都走...
  • 1,特权模式下进入配置某个端口 Switch(config)#interface f0/24 2,封装协议 Switch(config-if)#switchport trunk encap dot1q 3,设置trunk Switch(config-if)#switchport mode trunk ...
  • 交换机之间trunk端口的设置问题

    千次阅读 2020-12-28 20:22:39
    如图:(R1)------(SW1)------(PC1)//PC1属于vlan2,属于192.168.2.0网段||(SW2)------(PC2) //PC2属于vlan3,属于192.168.3.0网段sw1和sw2都用自身的fa0/3连接,把他们配置trunk模式,在设置sw1和sw2之间连接端口...
  • cisco端口聚合配置

    千次阅读 2020-04-17 11:05:16
    实验目标 理解端口聚合基本原理;... 掌握一般交换机端口聚合的配置方法; 实验背景 端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端...
  • 一直在想要不要把锐捷的命令整理出来,其实锐捷的命令和思科的基础命令是一样的,只要熟悉 思科命令,那么锐捷的命令基本上是没有问题的。但是有好多的粉丝私信我想要一份,我就稍微整理一下一些的基础命令。整理...
  • Cisco思科)路由器端口配置

    千次阅读 2020-12-14 18:25:52
    Cisco思科)路由器端口配置 小编都是喜欢借助实验写博客 一、拓扑图 结合图可以知道我们一共有四个网段(四个vlan) 1.vlan 1 ip:192.168.1.0网段 自带的vlan不需要在路由器添加的 2.vlan 2 ip:192.168.2.0...
  • 本次实验采用思科交换机仿真软件Boson NetSim,仿真了最简单的网络拓扑结构的交换机虚拟局域网划分方法。并查看了划分前、划分后、不同的Trunk配置下各台终端设备的连通情况。同时熟悉了思科交换机的配置命令。
  • Cisco交换机配置新手篇之端口配置

    万次阅读 2019-06-17 15:18:18
    上回跟大家介绍了如何正确连接交换机,今天用一些配置片段给大家介绍一下端口配置。鉴于网上大多数配置事例都是show-run出来的结果。不利于新手对命令配置过程的了解,所以笔者将配置片段和注意的地方都注明了一下...
  • VLAN与Trunk配置

    2022-03-15 20:02:27
    四、Trunk配置 一、 VLAN VLAN(Virtual Local Area Network)全称为虚拟局域网。 在传统的交换式以太网中,所有的用户在同一个广播域中,当网络规模较大时,广播包的数量会急剧增加,当广播包的数量占到总量的...
  • Access类型的端口只能属于一个VLAN(只允许和交换机端口一致的VLAN通过),一般用于连接主机的端口。 Tag(标签) 标准以太网帧报头中不包含关于这个帧所属 VLAN 的信息。因此,当以太网帧必须要添加关于这个以太网...
  • 交换机之间互连的端口就称为trunk端口。trunk是基于OSI第二层数据链路层(DataLinkLayer)的技术。 两台交换机上分别创建了多个VLAN(VLAN是基于Layer 2的),在两台交换机上相同的VLAN(比如VLAN10)要通信,需要...
  • trunk端口汇聚的意思,允许交换机与交换机,交换机与路由器,主机与交换机或者理由器之间通过两个或多个端口并行连接同时传输以提供更高的带宽,更大的吞吐量,大幅度提供整个网络能力。 端口设置trunk模式,是...
  • 后来回家实验了下,不足为怪,是因为cisco端口默认trunk mode 为auto,可以与trunk口形成trunk.这样,核心交换机的SVI就up了,也就可以ping通了。mark. 转载于:https://blog.51cto.com/gojustin...
  • 展开全部cisco二层交换机设置trunk:S1>enable //进入特权e5a48de588b63231313335323631343130323136353331333431356564模式S1#config terminal //进入全局配置模式S1(config)# interface vlan [vlanID] //进入...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,252
精华内容 3,300
关键字:

思科trunk端口配置