精华内容
下载资源
问答
  • 2020-02-28 17:57:27

    实验环境的搭建


    基础知识

    • MAC地址表:

    (1)静态MAC地址表:管理员手工配置生成的,永不老化;

    配置:

       mac-address static 0002-03AD-9876G0/0/3 vlan 1
       //在系统视图下配置

    (2)动态MAC地址表:设备每收到了一个数据帧以后,就会将源MAC地址和对应的端口映射加入到MAC地址表中!

    • 交换机转发行为(根据目的MAC)

    1.转发:将某个接口所收到的数据,从另一个接口转发出去。

    2.泛洪:将某个接口所收到的数据,从其他所有的接口转发出去。(未知的单播帧,组播帧,播帧)

    3.丢弃:将某个接口收到的数据,直接丢弃。

    丢弃条件:

    更多相关内容
  • 交换机MAC地址学习

    千次阅读 2022-04-18 16:58:17
    首先我们要了解交换机mac地址是怎么学习的之前要了解一下交换机是如何工作的。 参考模型 交换机工作在OSI模型的第二层,也就是数据链路层,数据链路层传输的数据叫数据帧。数据链路层使用的封装一般使用以太网...

    首先我们要了解交换机mac地址是怎么学习的之前要了解一下交换机是如何工作的。

    参考模型

     交换机工作在OSI模型的第二层,也就是数据链路层,数据链路层传输的数据叫数据帧。数据链路层使用的封装一般使用以太网进行封装,也就是Ethernet Ⅱ 以太帧。

    这里随便抓个包演示一下

    由于交换机工作在数据链路层,也就是说交换机收到一个报文他只会解封装到数据链路层,以太,然后在根据目的mac地址来对数据帧进行传输。

    当交换机从接口收到一个报文后,解封装,然后将源mac记录在mac地址表,记录这个mac地址来源于哪个接口,当接口为down状态或超过老化时间,交换机会将来源于该接口的mac地址删除,这里后面我会实验演示。

    1.泛洪:收到目的mac地址为ff:ff:ff:ff:ff:ff,向同一广播域的接口复制转发(一对所有)

    抓包演示

    2.转发:从一个接口接收到数据帧后,查看mac地址表,存在目的mac地址,然后一对一接口转发(一对一)

    3.丢弃:从一个接口接收到数据帧后,mac地址表不存在对应mac地址或数据帧不合法,丢弃

    有了以上基础,我们就可以实战演示一下交换机的mac地址表是怎么生成的,以及如何转发数据帧。

    以下实验使用华为模拟器实现,其他模拟器也可以同样验证,原理一样。

    拓扑图

    步骤一

    第一步我们先看看交换机的mac地址表

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname S1                                  #设置主机名
    [S1]display mac-address                             #查看mac地址表

     

     我们可以看到初始状态交换机的mac地址表是空的,华为交换机直接不显示,下一步我们看看交换机是如何将mac添加到表上的。

    步骤二

    为PC1添加IP地址,然后发送广播帧。

    由于是二层网络,这里不需要添加网关IP地址。

    然后ping一个网络中没有的主机地址,发送广播帧。

     

     抓包截取

    PC1尝试广播获取目的IP地址mac。

    步骤三

    查看交换机mac地址表

     此时可以看到交换机将PC1的mac地址记录并标明来源的接口。

    总结:也就是说当交换机收到某接口的数据帧时,将该数据帧的源mac地址记录到交换机的mac地址表并标明来源接口,下一次收到数据帧时,并通过mac地址表进行转发。

    扩展:交换机MAC地址绑定(静态)

    拓扑图

     R1

    [Huawei]sysname R1
    [R1]interface Ethernet0/0/0
    [R1-Ethernet0/0/0]ip address 192.168.1.1 24
    [R1-Ethernet0/0/0]mac-address 1-1-1          #更改mac地址

    R2

    [Huawei]sysname R2
    [R2]interface Ethernet0/0/0
    [R2-Ethernet0/0/0]ip address 192.168.1.2 24
    [R2-Ethernet0/0/0]mac-address 2-2-2          #更改mac地址

    S1

    [S1]mac-address static 1-1-1 Ethernet 0/0/1 vlan 1     #静态mac绑定
    [S1]mac-address static 2-2-2 Ethernet 0/0/2 vlan 1     #静态mac绑定
    [S1]interface Ethernet0/0/1
    [S1-Ethernet0/0/1]port link-type access                
    [S1-Ethernet0/0/1]q
    [S1]interface Ethernet0/0/2
    [S1-Ethernet0/0/2]port link-type access 
    [S1-Ethernet0/0/2]q
    

    查看交换机MAC地址表

    END

    展开全文
  • 1、掌握中兴二层交换机学习MAC地址过程和MAC地址表老化时间的设置。 二、实验内容 1、通过对中兴二层交换机2850的MAC地址表的查看和老化时间的修改,加深对二层交换机MAC地址表的建立过程和MAC地址表老化时间的...

    中兴二层交换机的MAC地址学习

    一、实验目的

    1、掌握中兴二层交换机学习MAC地址的过程和MAC地址表老化时间的设置。

    二、实验内容

    1、通过对中兴二层交换机2850的MAC地址表的查看和老化时间的修改,加深对二层交换机MAC地址表的建立过程和MAC地址表老化时间的理解。

    三、实验过程

    1、实验任务说明

    如下图所示,将一台中兴2850交换机port4口和一个路由器的以太网接口相连,并使用一台电脑打开超级终端软件,通过九针串口线连接到一台2850交换机的console口,完成二层交换机的MAC地址表查看和MAC地址表老化时间设置的操作。

    在这里插入图片描述
    2、业务配置流程图

    在这里插入图片描述
    3、实验配置过程

    在这里插入图片描述
    在这里插入图片描述
    四、实验查看及验证

    1、MAC地址表的建立查看。配置模式下,输入sh fdb detail命令查看MAC地址表的内容。

    在这里插入图片描述
    2、在配置模式下,输入sh fdb agingtime查看当前定义的老化时间。

    在这里插入图片描述
    3、在二层交换机的配置模式下,输入set fdb agingtime 30将老化时间修改为30秒,输入show fdb detail进行MAC地址表老化时间的验证。

    在这里插入图片描述
    五、实验思考与总结

    1、通过这次实验,我掌握了中兴二层交换机的学习MAC地址的过程和MAC地址表老化时间的设置。老化时间是由于考虑到电脑设备的更换影响到主机mac地址的变换,所以高速缓存表的清空是由于有老化时间,但是我们可以自己设置交换机的老化时间。

    展开全文
  • arp协议,交换机地址学习机制,交换机mac地址转发原理。
  • 1.它收到一个帧的时候,先检查源MAC地址,看看自己维护的一个地址表中有没有这个地址。如果有,则2;...交换机的工作原理中,交换机之间的MAC地址学习室通过端口泛洪的方式举例:你想要让我找到他,我又不知...
    1.它收到一个帧的时候,先检查源MAC地址,看看自己维护的一个地址表中有没有这个地址。如果有,则2;如果没有,则将这个MAC地址、进入的端口、进入的时间放入这个表中;
    2.检查目的MAC地址,然后到该表中查找,如果有匹配项,则按照表项中的端口号进行转发;如果没有,则转发到除进口之外的其他所有端口。
     
     
    交换机的工作原理中,交换机之间的MAC地址学习室通过端口泛洪的方式
    举例:你想要让我找到他,我又不知道他是谁,我就运用我所有的关系去一个一个问,总有一个是对的,并且把他记住,这样你以后问我我就知道了
     
     
    交换机是能自学pc的mac地址的没错,局域网有广播问题,说下我的理解:
    既然是局域网,就会接好多pc,如果少量pc,就可以不考虑广播风暴,但是当上百台pc就应该考虑了。如果不划分vlan,其中一台pc-1发信,另外所有pc都会收到信息,有时可能pc-1只想给pc-2发信,这样,对于不是pc-2的机器来说,就是产生广播了。
     
     
    广播风暴与VLAN有什么关系? VLAN不是为了防广播风暴的。是为了更加有效的管理网络,使用IP的。 一个交换机不是只能学习一个MAC。 广播风暴是指网络环路了。两者之间根本风马牛不相及。

    追问

    Google一下“vlan 广播风暴”,看到不少“利用Vlan控制与隔离广播风暴”之类的题目。

    再查一下百科,环路问题只是广播风暴的其中一种表现,除此之外还有不少其他现象也叫广播风暴
    回答
    你好好学习下网络基础东西吧。 基本上还是环路或者病毒之类的问题,要不就是端口坏了,无法投递数据。 一个交换机端口并不是只对应一个MAC的。所以在交换下面再接交换机接几十台电脑还可以用。 VLAN是虚拟局域网,这个技术主要是为了解决IP地址不够用,方便管理。  GOOGLE的东西说的没错。但是你还是没了解网络运行的原理。等你仔细看过基础的网络知识,弄懂以后就知道了。 不是三两句能表述清楚的。
    展开全文
  • 中兴二层交换机MAC地址学习实验

    千次阅读 2021-01-26 11:03:31
    1、掌握中兴二层交换机学习MAC地址过程和MAC地址表老化时间的设置 二、实验内容 1、通过对中兴二层交换机2850的MAC地址表的查看和老化时间的修改,加深对二层交换机MAC地址表的建立过程和MAC地址表老化时间的理解...
  • 查看交换机的mac地址表dis mac-address 此时路由表为空 为pc配置IP地址 由pc3 ping 数据包 通过发送arp数据包 可使交换机学习到 pc3的mac地址此时交换机学习到了pc3的mac地址 通过 E0/0/1接口 通过数据抓包可见 ping...
  • 相信有很多人在学习网络的过程中,都会对路由器与交换机的区别与联系感到疑惑不解,因为这两台设备的功能看起来似乎一样。然而,其实路由器与交换机大有不同,下面是我对此的一些理解,希望能够帮助到你!青春是萤火...
  • 交换机地址学习

    千次阅读 2020-10-12 21:28:17
    2.通过观察交换机地址学习过程,理解交换机的工作原理。 3.理解广播域、冲突的概念 5.2实验分析 1.清除ESW1上的MAC地址表 经过前面的实验,ESW1上已经保存有接入设备的MAC地址表了,这里先清除MAC地址表。 2.再次...
  • 最近有几个学生粉丝后台私信我,让我说说交换机与 VLAN。我在阅读这几个粉丝私信中发现一个有趣的现象,那就是吐槽大学计算机网络课程的晦涩枯燥,而不是去深层次解释协议出现的原因或者用来去解决什么问题。帅天...
  • 浅谈交换机MAC地址学习和数据转发

    万次阅读 多人点赞 2017-07-15 11:51:29
    下面将谈谈MAC地址学习这块的东西,欢迎大家一块探讨,补充! 图1 网络拓扑结构 PC1要与PC2通信,基于以太网通信中,必须在数据帧中指定目标MAC地址才可以进行正常通信。 假定PC1的arp表项中没有对应...
  • .交换机根据收到数据帧中的源MAC地址建立该地址交换机端口的映射,并将其写入MAC地址表中。2.交换机将数据帧中的目的MAC地址同已...二、交换机的三个主要功能学习:以太网交换机了解每一端口相连设备的MAC地址,...
  • 交换机MAC地址表实验任务

    千次阅读 2021-01-24 09:20:17
    1、掌握交换机学习MAC地址过程 二、实验内容 1、跟据所给题目完成MAC地址表实验 三、实验过程 1、实验任务说明 如图1-1所示,在GNS3软件中,使用一台三层交换机(S3950)以及两台PC机,进行配置后根据实验过程中给...
  • MAC地址由48比特长、12位的16进制数字组成,其中从左到右开始,0到23bit是厂商向IETF等机构申请用来标识厂商的代码,24到47bit由厂商自行分派,是各个厂商制造的所有网卡的一个唯一编号。 MAC地址可以分为3种类型:
  • 1、二层交换机基于mac地址转发数据,为什么不同 网段不能通信 ? 我们来用一个ping命令的过程来解释: 一个交换机,连两个电脑A和B,A和B不在一个网段,他们的IP分别是192.168.1.2,255.255.255.0,B是 192.168.2.1,255.255...
  • 最常用的二层交换机所用的依据是MAC地址表,而三层交换机的依据是路由表,多层交换机的依据是网络协议或端口号 MAC地址MAC地址表记录了相连设备的MAC地址、接口号以及所属的VLAN ID之间的对应关系,是VLAN内数据...
  • MAC地址学习

    千次阅读 2021-12-13 19:12:09
    大家好呀,我是请假君,今天又来和大家一起学习数通了,今天要分享的知识是MAC地址学习。 一、MAC地址表初始化: 为了转发报文,以太网交换机需要维护MAC地址表。MAC地址表的表项中包含了与本交换机相连的终端...
  • 以太网MAC地址组成与交换机基本知识点 1、以太网MAC地址 MAC地址由48位二进制数组成,通常分为六段,用十六进制表示 例:08 - 00 - 5a - e3 - 93 - 6c 前二十四位是供应商标识,后二十四位:供应商对网卡的唯一...
  • 一、交换网络基础 1、越来越多的用户需要接入到网络,交换机提供的大量的接入端口能够很好地...1、交换机中有一个MAC地址表,里面存放了MAC地址交换机端口的映射关系。MAC地址表也称为CAM(Content Addressabl...
  • MAC地址 MAC(Media Access Control,介质访问控制)地址,或称为MAC位址、硬件地址,用来定义网络设备的位置。MAC集成在网卡,由48bit的16进制的数字组成,0~23位数字叫作组织唯一标志符(organizationally unique...
  • 说到MAC地址表,就不得不说一下交换机的工作原理了,因为交换机是根据MAC地址表转发数据帧的。在交换机中有一张记录着局域网主机MAC地址交换机接口的对应关系的表,交换机就是根据这张表负责将数据帧传输到指定的...
  • “华为数通学习(七)理解华为交换机三种端口模式Access、Hybrid和Trunk对数据包Tag的处理过程” “华为数通学习(八)-交换综合实验(包含Hybrid,MAC VLAN、三层路由及单臂路由)” “华为数通学习(九)-华为...
  • 1:交换机MAC地址学习   在交换机初始化的,也就是刚启动的时候,交换机MAC地址表是没有任何MAC地址和端口的映射条目的   当PCA要想和PCC,PCB,PCD进行通信时,当该二层数据帧通过端口E1/0/1发送到交换机上...
  • 交换机功能和学习MAC过程.这个过程应该是比较详细,如果有问题还可以一起讨论下,这个过程有助于网络的排错
  •     如上图所示的网络,当A想要向B发送信息,交换机在接口1收到该帧,交换机将A的MAC地址和进入交换机的接口号进行登记,存放在帧交换表中。而此时由于帧交换表中没有B的MAC地址,所以交换机1将该帧泛洪处理,即...
  • 1、网桥和交换机 网桥: ...交换机 ...-(2) 每个交换机可以支持多个spanning-tree switch ...3、交换机的工作原理(地址...地址学习过程就是建立MAC表的过程 初始时,MAC地址表是空的 主机A向主...
  • ① 学习(Learning):交换机在进行数据转发时,交换机对发送端的MAC地址和端口进行记录,这个过程就叫做学习。 如图所示:PC1 想要传输数据帧到 PC2,交换机从 E0/0/1 口接收到数据帧,查看其源MAC地址并将与其...
  • 计算机网络-实验3-交换机的交换表及MAC地址管理

    万次阅读 多人点赞 2019-04-20 20:48:12
    交换机MAC地址表的配置 实验内容 一:交换表的工作原理 存储转发方式 把整个数据帧先缓存后再进行处理。 交换机建立一个交换表,根据交换表来转发数据。 1.1 以太网交换机的自学习功能 以太网交换机运行...
  • 交换机的工作原理一、以太网MAC地址二、以太网帧格式三、交换机的工作原理3.1交换机以太网接口的工作模式3.1.1单工3.1.2半双工3.1.3全双工交换机以太网接口速率3.2交换机的转发原理 一、以太网MAC地址 MAC地址是用来...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 18,295
精华内容 7,318
关键字:

交换机学习mac地址过程

友情链接: 54100-90913.rar