精华内容
下载资源
问答
  • ENSP配置 实例九 动态Nat配置

    千次阅读 2020-06-19 12:03:31
    ENSP配置 实例九 动态Nat配置 动态nat配置 sy [Huawei]sy R1 [R1]int g0/0/0 [R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24 [R1-GigabitEthernet0/0/0]int g0/0/1 [R1-GigabitEthernet0/0/1]ip add 200.0.12.1...

    ENSP配置 实例九 动态Nat配置

    在这里插入图片描述
    sy
    [Huawei]sy R1
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 200.0.12.1 24

    [R1]nat address-group 1 200.0.12.3 200.0.12.5 ##

    [R1]acl 2000 ##
    [R1-acl-basic-2000]rule 5 permit source 192.168.1.0 0.0.0.255
    [R1-acl-basic-2000]q

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound 2000 address-group 1

    [R1-GigabitEthernet0/0/1]undo nat outbound 2000 address-group 1 ##切换
    [R1-GigabitEthernet0/0/1]nat outbound 2000 address-group 1 no-pat ##切换

    [R1]dis nat address-group 1 ## 配置验证

    静态nat配置
    [R1]int g0/0/0 # [R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24
    [R1-GigabitEthernet0/0/0]int g0/0/1 # [R1-GigabitEthernet0/0/1]ip add 200.0.12.1 24
    [R1-GigabitEthernet0/0/1]nat static globle 200.0.12.1 inside 192.168.1.1
    [R1-GigabitEthernet0/0/1]nat static globle 200.0.12.1 inside 192.168.1.2
    Easy IP配置

    [R1]acl 2000
    [R1-acl-basic-2000]rule 5 permit source 192.168.1.0 0.0.0.255
    [R1-acl-basic-2000]q

    [R1]int g0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound 2000

    展开全文
  • 华为eNSP:华为静态NAT,动态NAT配置实列

    千次阅读 多人点赞 2020-06-29 16:13:29
    华为eNSP:华为静态NAT,动态NAT配置实列拓扑图实验拓扑以及IP地址分配如下静态NAT(服务器地址转换)动态NAT代码展示交换机的代码路由器R1的代码路由器R2的代码配置展示交换机配置路由器R1配置路由器R2配置 ...

    拓扑图实验拓扑以及IP地址分配如下

    在这里插入图片描述

    静态NAT(服务器地址转换)

    • 静态NAT实现了私有地址和公有地址的一对一转换,一个公网地址对应一个私网地址

    动态NAT

    • 动态NAT基于地址池来实现私有地址和公有地址的转换,转换是随机的

    代码展示

    交换机的代码

    <Huawei>system-view 
    [Huawei]sysname SW1
    [SW1]vlan batch  10 20 30 40                                       ##创建VLAN
    [SW1]interface  GigabitEthernet 0/0/1                              ##进入线路
    [SW1-GigabitEthernet0/0/1]port link-type access                    ##定义他为access端口
    [SW1-GigabitEthernet0/0/1]port default vlan 10                     ##打标签
    [SW1]interface  GigabitEthernet 0/0/2
    [SW1-GigabitEthernet0/0/2]port link-type access
    [SW1-GigabitEthernet0/0/2]port default vlan 20
    [SW1]interface  GigabitEthernet 0/0/3
    [SW1-GigabitEthernet0/0/3]port link-type access
    [SW1-GigabitEthernet0/0/3]port default vlan 30
    [SW1]interface  GigabitEthernet 0/0/4
    [SW1-GigabitEthernet0/0/4]port link-type access
    [SW1-GigabitEthernet0/0/4]port default vlan 20
    [SW1]interface  GigabitEthernet 0/0/5
    [SW1-GigabitEthernet0/0/5]port link-type access
    [SW1-GigabitEthernet0/0/5]port default vlan 40
    [SW1]interface  GigabitEthernet 0/0/6
    [SW1-GigabitEthernet0/0/6]port link-type access
    [SW1-GigabitEthernet0/0/6]port default vlan 10
    [SW1]interface  Vlanif 10                                          ##进入VLAN
    [SW1-Vlanif10]ip address 192.168.10.1 24                           ##设置ip地址
    [SW1]interface  Vlanif 20
    [SW1-Vlanif10]ip address 192.168.20.1 24
    [SW1]interface  Vlanif 30
    [SW1-Vlanif10]ip address 192.168.30.1 24
    [SW1]interface  Vlanif 40
    [SW1-Vlanif10]ip address 11.0.0.2 24
    [SW1]ip route-static 0.0.0.0 0.0.0.0 11.0.0.1                      ##设置静态路由
    

    路由器R1的代码

    <Huawei>system-view 
    [Huawei]sysname R1
    [R1]]interface GigabitEthernet 0/0/0                               ##进入线路
    [R1-GigabitEthernet0/0/0]ip add 11.0.0.1 24                        ##设置ip地址
    [R1]]interface GigabitEthernet 0/0/0 
    [R1-GigabitEthernet0/0/1]ip add 12.0.0.1 24
    [R1]ip route-static 192.168.10.0 24 11.0.0.2                       ##设置静态路由
    [R1]ip route-static 192.168.20.0 24 11.0.0.2 
    [R1]ip route-static 192.168.30.0 24 11.0.0.2 
    [R1]ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    [R1]nat static global 8.8.8.8 inside 192.168.10.10                 ##静态nat设置
    [R1]]interface g 0/0/1                                       
    [R1-GigabitEthernet0/0/1]nat static enable                         ##开通nat服务
    [R1]nat address-group 1 212.0.0.100 212.0.0.200                    ##设置外网ip群
    [R1]acl 2000                                                       ##设置内网ip池名为2000
    [R1-acl-basic-2000]rule permit  source  192.168.20.0 0.0.0.255     ##设置地址池范围
    [R1-acl-basic-2000]rule permit source  11.0.0.0 0.0.0.255
    [R1-acl-basic-2000]int g 0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound 2000 address-group 1 no-pat  ##将内网地址池2000里面的ip转换成外网地址群里面address-group 1
    [R1-acl-adv-3000]rule permit ip source 192.168.30.0 0.0.0.255
    [R1]int g 0/0/1
    [R1-GigabitEthernet0/0/1]nat outbound  3000
    [R1]int g 0/0/1
    [R1-GigabitEthernet0/0/1]nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www
    

    路由器R2的代码

    <Huawei>system-view 
    [Huawei]sysname R2
    [R2]interface GigabitEthernet 0/0/0
    [R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
    [R2]interface loo 0
    [R2-LoopBack0]ip add 114.114.114.114 32
    [R2]ip route-static 8.8.8.8 32 12.0.0.1
    [R2]ip route-static 212.0.0.0 24 12.0.0.1
    [R2]interface g 0/0/1
    [R2-GigabitEthernet0/0/1]ip add 13.0.0.1 24
    [R2]ip route-static 9.9.9.9 24 12.0.0.1
    

    配置展示

    交换机配置

    SW1交换机一配置
    vlan batch 10 20 30 40
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
    interface Vlanif20
     ip address 192.168.20.1 255.255.255.0
    interface Vlanif30
     ip address 192.168.30.1 255.255.255.0
    interface Vlanif40
     ip address 11.0.0.2 255.255.255.0
    interface MEth0/0/1
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 20
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
    interface GigabitEthernet0/0/4
     port link-type access
     port default vlan 20
    interface GigabitEthernet0/0/5
     port link-type access
     port default vlan 40
    interface GigabitEthernet0/0/6
     port link-type access
     port default vlan 10
    ip route-static 0.0.0.0 0.0.0.0 11.0.0.1
    

    路由器R1配置

    acl number 2000  
     rule 5 permit source 192.168.20.0 0.0.0.255 
     rule 10 permit source 11.0.0.0 0.0.0.255 
    acl number 3000  
     rule 5 permit ip source 192.168.30.0 0.0.0.255 
     nat address-group 1 212.0.0.100 212.0.0.200
     nat static global 8.8.8.8 inside 192.168.10.10 netmask 255.255.255.255
    interface GigabitEthernet0/0/0
     ip address 11.0.0.1 255.255.255.0 
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.0 
     nat server protocol tcp global 9.9.9.9 www inside 192.168.10.100 www
     nat outbound 2000 address-group 1 no-pat
     nat outbound 3000
     nat static enable
    ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
    ip route-static 192.168.10.0 255.255.255.0 11.0.0.2
    ip route-static 192.168.20.0 255.255.255.0 11.0.0.2
    ip route-static 192.168.30.0 255.255.255.0 11.0.0.2
    
    

    路由器R2配置

    interface GigabitEthernet0/0/0
     ip address 12.0.0.2 255.255.255.0 
    interface GigabitEthernet0/0/1
     ip address 13.0.0.1 255.255.255.0 
    ip address 114.114.114.114 255.255.255.255 
    ip route-static 8.8.8.8 255.255.255.255 12.0.0.1
    ip route-static 9.9.9.9 255.255.255.255 12.0.0.1
    ip route-static 212.0.0.0 255.255.255.0 12.0.0.1
    
    展开全文
  • 华为动态NAT配置

    千次阅读 2018-11-01 22:20:51
    华为动态NAT配置 试验要求:1)将内部网络10.1.1.0/24转换为公网地址200.1.1.1~200.1.1.10/28上网(访问Server3),并抓包分析2)验证动态NAT是单向转换 环境部署:PC1:IP:10.1.1.1 /24GW:10.1.1.254 /24Client1:IP...

    华为动态NAT配置

    试验要求:
    1)将内部网络10.1.1.0/24转换为公网地址200.1.1.1~200.1.1.10/28上网(访问Server3),并抓包分析
    2)验证动态NAT是单向转换

    环境部署:
    PC1:
    IP:10.1.1.1 /24
    GW:10.1.1.254 /24
    Client1:
    IP:10.1.1.2 /24
    GW:10.1.1.254 /24
    Client2:
    IP:100.1.1.1 /24
    GW:100.1.1.254 /24
    Server1:
    IP:10.1.1.11 /24
    GW:10.1.1.254 /24
    Server2:
    IP:10.1.1.12 /24
    GW:10.1.1.254 /24
    R1:
    GE 0/0/0:
    IP:10.1.1.254 /24
    GE 0/0/1:
    IP:100.1.1.254 /24
    GE 0/0/2:
    IP:200.1.1.14 /28

    配置步骤:
    R1:
    [R1]acl 2000 #创建编号为2000的基本ACL列表
    [R1-acl-basic-2000]rule 50 permit source 10.1.1.0 0.0.0.255
    #创建序号为50的条目,允许(permit)来自(source)10.1.1.0网段的所有主机通过
    [R1-acl-basic-2000]q #退出ACL模式
    [R1]nat address-group 1 200.1.1.1 200.1.1.10
    #创建NAT地址池(address-group)1,200.1.1.1-200.1.1.10
    [R1]int g 0/0/2 #进入GE 0/0/2端口
    [R1-GigabitEthernet0/0/2]nat outbound 2000 address-group 1 no-pat
    #在端口上启用动态NAT,将ACL2000匹配的流量应转换到该端口作为源地址,并匹配从该出口出去(outbound)的流量,关联NAT地址池(address-group)1,并且不做端口转换(no-pat),只做地址转换。

    结果验证:

    注:
    根据实验要求,最右侧设备为Server3,但配置完成后并不能形成单向的动态NAT,因此我将Server3换成了AR2240,配置好IP地址后再进行测试,结果就是正确的了,因此在验证结果时,如果经过反复排查发现自己的配置没有任何问题的情况下,可以考虑是否是由模拟器导致的问题,尝试更换设备。

    #=============================================================================#

    华为静态NAT配置

    试验要求:
    1)将内部地址10.1.1.11/24、10.1.1.12/24静态转换为公网地址200.1.1.11/28、200.1.1.12/28 ,以便访问外网(Server3)或被外网(Server3)访问,并抓包分析
    2)验证静态NAT是双向转换

    环境部署:
    PC1:
    IP:10.1.1.1 /24
    GW:10.1.1.254 /24
    Client1:
    IP:10.1.1.2 /24
    GW:10.1.1.254 /24
    Client2:
    IP:100.1.1.1 /24
    GW:100.1.1.254 /24
    Server1:
    IP:10.1.1.11 /24
    GW:10.1.1.254 /24
    Server2:
    IP:10.1.1.12 /24
    GW:10.1.1.254 /24
    R1:
    GE 0/0/0:
    IP:10.1.1.254 /24
    GE 0/0/1:
    IP:100.1.1.254 /24
    GE 0/0/2:
    IP:200.1.1.14 /28

    配置步骤:
    [R1]int g 0/0/2 #进入GE 0/0/2端口
    [R1-GigabitEthernet0/0/2]nat static global 200.1.1.11 inside 10.1.1.11
    #配置全局(global)静态(static)NAT,将内网10.1.1.11地址转换成200.1.1.11
    [R1-GigabitEthernet0/0/2]nat static global 200.1.1.12 inside 10.1.1.12
    #配置全局(global)静态(static)NAT,将内网10.1.1.12地址转换成200.1.1.12

    结果验证:

    #=============================================================================#

    华为NAPT配置

    试验要求:
    公司要求将内部网络10.1.1.0/24转换为一个公网地址200.1.1.10/28上网(访问Server3)。

    环境部署:
    PC1:
    IP:10.1.1.1 /24
    GW:10.1.1.254 /24
    Client1:
    IP:10.1.1.2 /24
    GW:10.1.1.254 /24
    Client2:
    IP:100.1.1.1 /24
    GW:100.1.1.254 /24
    Server1:
    IP:10.1.1.11 /24
    GW:10.1.1.254 /24
    Server2:
    IP:10.1.1.12 /24
    GW:10.1.1.254 /24
    R1:
    GE 0/0/0:
    IP:10.1.1.254 /24
    GE 0/0/1:
    IP:100.1.1.254 /24
    GE 0/0/2:
    IP:200.1.1.14 /28

    配置步骤:
    [R1]acl 2000 #创建编号为2000的基本ACL列表
    [R1-acl-basic-2000]rule 50 permit source 10.1.1.0 0.0.0.255
    #创建序号为50的条目,允许(permit)来自(source)10.1.1.0网段的主机通过
    [R1-acl-basic-2000]q #退出ACL模式
    [R1]nat address-group 1 200.1.1.10 200.1.1.10
    #创建NAT地址池1,并指定地址池内IP为200.1.1.10
    [R1]int g 0/0/2 #进入GE 0/0/2端口
    [R1-GigabitEthernet0/0/2]nat outbound 2000 address-group 1
    #启动NAT,并将ACL2000匹配的IP地址作为NAT的源地址,并套用地址池1进行地址转换

    结果验证:

    #=============================================================================#

    华为Easy IP配置

    实验要求:
    公司路由器外部接口G0/0/2是动态IP,要求内部网络10.1.1.0/24利用外部接口G0/0/2上网(访问Server3)。

    环境部署:
    PC1:
    IP:10.1.1.1 /24
    GW:10.1.1.254 /24
    Client1:
    IP:10.1.1.2 /24
    GW:10.1.1.254 /24
    Client2:
    IP:100.1.1.1 /24
    GW:100.1.1.254 /24
    Server1:
    IP:10.1.1.11 /24
    GW:10.1.1.254 /24
    Server2:
    IP:10.1.1.12 /24
    GW:10.1.1.254 /24
    R1:
    GE 0/0/0:
    IP:10.1.1.254 /24
    GE 0/0/1:
    IP:100.1.1.254 /24
    GE 0/0/2:
    IP:200.1.1.14 /28

    配置步骤:
    [R1]acl 2000 #创建编号为2000的基本ACL列表
    [R1-acl-basic-2000]rule 50 permit source 10.1.1.0 0.0.0.255
    #创建序号为50的条目,允许(permit)来自(source)10.1.1.0网段的所有主机通过
    [R1-acl-basic-2000]q #退出ACL模式
    [R1]int g 0/0/2 #进入GE 0/0/2端口
    [R1-GigabitEthernet0/0/2]nat outbound 2000
    #启动NAT,并将基本ACL2000列表匹配到的所有IP地址作为源地址进行NAT转换,且所有源地址都将转换为该端口地址进行外网访问

    结果验证:

    #=============================================================================#

    华为NAT Server配置

    试验要求:
    1)将内部地址10.1.1.11/24的80端口静态转换为公网地址200.1.1.11/28的80端口,以便被外网(Client2)访问;同时Server1和Client2可以互相ping通。
    2)将内部地址10.1.1.12/24的21端口静态转换为公网地址200.1.1.12/28的21端口,以便被外网(Client2)访问。

    环境部署:
    PC1:
    IP:10.1.1.1 /24
    GW:10.1.1.254 /24
    Client1:
    IP:10.1.1.2 /24
    GW:10.1.1.254 /24
    Client2:
    IP:100.1.1.1 /24
    GW:100.1.1.254 /24
    Server1:
    IP:10.1.1.11 /24
    GW:10.1.1.254 /24
    Server2:
    IP:10.1.1.12 /24
    GW:10.1.1.254 /24
    R1:
    GE 0/0/0:
    IP:10.1.1.254 /24
    GE 0/0/1:
    IP:100.1.1.254 /24
    GE 0/0/2:
    IP:200.1.1.14 /28

    配置步骤:
    [R1]int g 0/0/1 #进入GE 0/0/1端口
    [R1-GigabitEthernet0/0/1]nat server protocol tcp global 200.1.1.12 21 inside 10.1.1.12 21
    #创建NAT地址转换,全局(global)模式下,将10.1.1.12的TCP协议(protocol)21端口转换为200.1.1.12的TCP协议(protocol)的21端口
    [R1-GigabitEthernet0/0/1]nat server protocol tcp global 200.1.1.11 80 inside 10.1.1.11 80
    #创建NAT地址转换,全局(global)模式下,将10.1.1.11的TCP协议(protocol)80端口转换为200.1.1.11的TCP协议(protocol)的80端口
    [R1-GigabitEthernet0/0/1]nat server protocol icmp global 200.1.1.11 inside 10.1.1.11
    #创建NAT地址转换,全局(global)模式下,将10.1.1.11的icmp协议(protocol)转换为200.1.1.11的icmp协议(protocol)

    结果验证:

    转载于:https://blog.51cto.com/13935936/2311958

    展开全文
  • 网络地址转换--动态NAT配置

    万次阅读 多人点赞 2018-07-04 11:23:31
    2.1 实验目的(1)理解动态NAT和静态映射的区别;(2)掌握NAT地址池的配置;(3)掌握NAT转换中访问控制列表的应用;(4)掌握静态NAT配置2.2 实验原理1.动态NAT动态转换(亦称NAT pool)是指不建立内部地址和...

    2.1 实验目的

    1)理解动态NAT和静态映射的区别;

    2)掌握NAT地址池的配置;

    3)掌握NAT转换中访问控制列表的应用;

    4)掌握静态NAT的配置

    2.2 实验原理

    1.动态NAT

    动态转换(亦称NAT pool)是指不建立内部地址和全局地址的一对一的固定对应关系。而通过共享NAT地址池的IP地址动态建立NAT的映射关系。当内网主机需要进行NAT地址转换时,路由器会在NAT地址池中选择空闲的全局地址进行映射,每条映射记录是动态建立的,在连接终止时也被收回。

                       

      3  动态NAT的工作原理

    如图9-3所示,内网主机A的报文经过边缘路由器时,路由器会在预先配置好的NAT地址池中选出空闲的内部全局地址进行映射。如图9-3所示,NAT地址池中只有202.80.20.2是空闲的,所以路由器选取该地址和172.16.10.10建立映射关系,172.16.10.10ßà202.80.20.2。因此数据包1的源IP地址将会替换为202.80.20.2。数据包从外网返回则替换目的IP地址。

    2.动态NAT配置命令

       动态NAT的配置过程如表3所示:

        3  动态NAT的配置步骤

     

    配置说明

    命令

    步骤1

    配置内部接口、和外部接口

    //配置外部接口

    Router(config-if)#interface  interface-id

    Router(config-if)#ip nat outside

    //配置内部接口

    Router (config-if)#interface  interface-id

    Router (config-if)#ip nat inside

    步骤2

    配置转换地址池

    Router (config)#ip nat pool name start-ip end-ip

    {netmask x.x.x.x| prefix-length x }

    步骤3

    配置需要进行地址转换源IP访问控制列表

    Router(config) # access-list  number permit x.x.x.x(网络号)  x.x.x.x (子网掩码)

    步骤4

    配置NAT转换

    Router(config)# ip nat inside source list number pool pool-name

    步骤4

    检查NAT的运行结果

    Router #show ip nat translations

      例子:允许内部地址为192.168.20.0/24的网络进行转换,转换的地址池为

    210.20.20.10~210.20.20.15,子网掩码为255.255.255.0。配置命令如下:

     R1(config)# ip nat pool  NAT-POOL  210.20.20.10  210.20.20.15  netmask 255.255.25.0


    //主要配置以下参数:


    //地址池名称: TEST_POOL


    //地址池开始地址:210.20.20.10


    //地址池结束地址:210.20.20.15


    //地址池的子网掩码:255.255.255.0


      R1(config)# access-list 1 permit 192.168.20.0


      R1(config)# ip  nat  inside  source  list 1  pool NAT-POOL

    3.动态NAT配置实例

     网络拓扑图如图4所示:

                  

     4  动态NAT网络拓扑图

    地址表如表4所示:

    4 动态NAT网络IP地址表

    设备

    接口

    IP地址

    子网掩码

     

    R0

     Fa 0/0

    10.10.10.2

    /24

     Fa0/1

    192.168.1.1

    /24

     Fa1/0

    192.168.2.1

    /24

    R1

     S2/0

    210.38.220.1

    /24

     Fa0/0

    10.10.10.1

    /24

    R2

     S2/0DCE

    210.38.220.2

    /24

    PC1

     NIC

    192.168.1.10

    /24

    PC2

     NIC

    192.168.1.20

    /24

    PC3

     NIC

    192.168.2.10

    /24

    背景说明:对于一些公司,它们可能会一次性申请很多个公网IP来为公司各个部门提供上网服务。我们假设某公司申请了6个公网IP,所属网段为: 210.38.220.10à 210.38.220.15,子网掩码为255.255.255.0;合法的公IP地址不够每人分配一个,但该公司一般情况下有1/2的人员在外跑业务或做技术支持,在公司的员工也不会一直需要提供网络服务,据此,我们可以通过动态分配全局地址的地址转换技术来解决该公司的需要。

    配置要求:配置动态NAT,允许转换IP地址属于192.168.1.0/24的网段,其他网段不允许进行NAT转换。

    实验步骤:

    步骤1R0配置

       R0(config)# interface f0/0

       R0(config-if)# ip address 10.10.10.2  255.255.255.0  //配置接口IP地址

       R0(config-if)# no shutdown

       R0(config)# interface f0/1

       R0(config-if)# ip address 192.168.1.1  255.255.255.0  //配置接口IP地址

       R0(config-if)# no shutdown

       R0(config)# interface  f1/0

       R0(config-if)# ip address 192.168.2.1  255.255.255.0  //配置接口IP地址

       R0(config-if)# no shutdown

       R0(config-if)#ip route 0.0.0.0 0.0.0.0 f0/0   //配置R0默认路由。

    步骤2R1的配置。

       R1(config)# interface f0/0

       R1(config-if)# ip address 10.10.10.1  255.255.255.0  //配置接口IP地址

       R1(config-if)#ip nat inside                //配置f0/0为内部接口

       R1(config-if)# no shutdown

       R1(config)# interface s2/0

       R1(config-if)# ip address 210.38.220.1  255.255.255.255  //配置接口IP地址

    R1(config-if)#ip nat outside             //配置s2/0为外部接口

       R1(config-if)# no shutdown

       R0(config-if)#ip route 0.0.0.0 0.0.0.0  S2/0   //配置默认路由。

     R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255//配置匹配内网IP地址访问控制列表

     //配置NAT地址池

    R1(config)#ip nat pool TEST_POOL 210.38.220.10 210.38.220.15 netmask 255.255.255.0 

    R1(config)#ip nat inside source list 1 pool TEST_POOL //配置动态NAT转换

    步骤3R2的配置。

    R2(config)#int s2/0

    R2(config-if)#ip address 210.38.220.2  255.255.255.255

    R2(config-if)# clock rate 64000

    R2(config-if)#no shutdown

    步骤4检查配置结果与测试

    1)动态NAT的映射关系不是静态建立的,而是通过数据流触发建立的,因此每次建立的映射关系可能是不一样的,在没有触发流量的时候,查看nat映射表。

        R2#sh ip nat translations

          R2#

       可以看到映射表是空的,说明映射关系并没有建立。

       我们分别从PC1PC2触发流量,在观察NAT映射表的情况。

    R1#sh ip nat translations

    Pro  Inside global     Inside local       Outside local      Outside global

    icmp 210.38.220.10:21  192.168.1.10:21    210.38.220.2:21    210.38.220.2:21

    icmp 210.38.220.10:22  192.168.1.10:22    210.38.220.2:22    210.38.220.2:22

    icmp 210.38.220.11:15  192.168.1.20:15    210.38.220.2:15    210.38.220.2:15

    icmp 210.38.220.11:16  192.168.1.20:16    210.38.220.2:16    210.38.220.2:16

    可以看到192.168.1.10 à210.38.220.10192.168.1.20 à210.38.220.11,说明地址转换起到效果。

    2)使用debug命令查看到的转换过程。

    R1#debug ip nat

    IP NAT debugging is on

    R1#

    NAT: s=192.168.1.10->210.38.220.11, d=210.38.220.2 [21]   // s表示源地址转换

    NAT*: s=210.38.220.2, d=210.38.220.11->192.168.1.10 [32]  //d表示目的地址转

    NAT: s=192.168.1.10->210.38.220.11, d=210.38.220.2 [22]

    NAT*: s=210.38.220.2, d=210.38.220.11->192.168.1.10 [33]

     (3) 动态NAT映射表条目存在一定生存时间,时间超过时转换条目将会被自动删除。一对一的动态NAT超时时间为10分钟(600秒);基于端口的动态NAT超时时间为1分钟(60秒)。

    注意事项:

    1不要把inside和outside应用的接口弄错:

    2如果有条件,尽量不要用outside接口的全局地址作为内部全局地址,该接口地址的所有者是互联网服务提供商ISP。当线路变更时地址就会改变,就需要更改DNS记录了,如果是直接通过IP提供服务,那就更麻烦,而线路的变更是常有的。另外,路由器的outside接口有可能不是可用的地址,而是私有地址等。


    展开全文
  • 动态NAT配置实验(1)

    千次阅读 2021-11-30 15:41:10
    动态NAT配置: 允许172.16.0.0/16的网络获得200.100.150.3/24到200.100.150.20/24的公有地址 路由器r1: Router>en Router#conf t Router(config)#no ip domain-lookup //关闭域名解析 Router(config)#...
  • 以下内容摘自刚刚上市,史上最全面、最系统的的四本大型(每本平均近900页)网络设备新书之一《H3C路由器配置与管理完全手册》(第二版),其它三本分别是:《Cisco交换机配置与管理完全手册》(第二版)、《Cisco路由器...
  • NAT的配置:动态NAT配置[借鉴].pdf
  • gns3 动态nat 静态nat 实验配置工程文件 包含2691 ios 镜像文件
  • 实验24 动态NAT配置.doc

    2021-08-12 19:37:15
    实验24 动态NAT配置.doc
  • 在这里 路由协议配置的是静态路由 rip 协议 router rip network 192.168.3.0 network 200.1.1.0 ...动态路由NAT 地址池: 路由B中 routerB: Router&gt;en Router#conf t Enter configuration comman...
  • 配置静态NAT配置动态NAT

    千次阅读 2019-05-18 00:51:09
    配置静态NAT 随着接入Internet的计算机数量的不断猛增,IP地址资源也就愈加显得捉襟见肘。事实上,除了中国教育和科研计算机网(CERNET)外,一般用户几乎申请不到整段的C类IP地址。在其他ISP那里,即使是拥有几百台...
  • 复用动态NAT配置练习

    2013-06-16 13:58:48
    路由器,复用动态NAT配置练习,很好的应用实例
  • 配置动态NAT

    千次阅读 多人点赞 2019-05-02 11:27:04
    配置动态NAT 问题 在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1.1.10 方案 网络拓扑如图所示: 步骤 实现此案例需要按照如下步骤进行。 步骤一:动态NAT配置 1)删除...
  • 华为静态NAT、动态NAT、NAPT、Easy NAT配置实例

    万次阅读 多人点赞 2020-03-22 16:32:03
    动态NAT基于地址池来实现私有地址和公有地址的转换,转换是随机的 3,NAPT(网络地址端口转换) NAPT允许多个私网地址转换到同一个公有地址的不同端口,私网利用端口号来区分。 4,Easy IP:转换成出接口...
  • 动态NAT如何配置

    千次阅读 2020-04-08 22:17:10
    2.1 问题 将内部网络 10.1.1.0/24 转换为公网地址 200.1.1.1 ~ 200.1.1.11/28 上网(访问Server-1) ...1)配置公司内网终端设备 - PC1 PC1: 地址:10.1.1.1 掩码:255.255.255.0 网关:10.1.1.254 2)配...
  • 华为网络:动态NAT 静态nat 实验配置

    千次阅读 多人点赞 2020-04-14 22:16:00
    NAT简介 NAT(Network Address Translation,网络地址转换)是1994年提出的。当在专用网内部的一些主机本来已经分配到了本地IP地址(即仅在本专用网内使用的专用地址),但现在又想和因特网上的主机通信(并不需要...
  • 思科高级配置(配置动态NAT)

    万次阅读 2019-05-15 20:52:43
    问题 在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1...步骤一:动态NAT配置 1)删除静态NAT配置 tarena-R1(config)#no ip nat inside source static 192.168.0.10 201...
  • 接配置静态NAT进行动态NAT的配置 配置R1 //删掉静态配置的NAT ...//配置路由器提供NAT服务,配置动态NAT地址池 ip nat pool NAT 202.96.1.3 202.96.1.10 netmask 255.255.255.0 //配置动态NAT映射 ip nat insi
  • 配置动态NAT(案例)

    千次阅读 2019-05-27 15:54:28
    问题 在R1通过动态NAT实现企业内网192.168.0.0/24转换为公网地址201.1.1.2-201.1.1.5,访问200.1.1.10...步骤一:动态NAT配置 1)删除静态NAT配置 tarena-R1(config)#no ip nat inside source static 192.168.0.10...
  • 山石防火墙目的NAT配置举例
  • ip nat pool pool-name start-ip end-ip { netmask network | prefx-length prefix-lengh} 关键字netmask 或prefx-lengh指示哪些地址位于属于网络,哪些位于该地址范围内的主机。 步骤二:配置标准ACL、 范围太宽的...
  • H3C路由器动态NAT配置步骤全解析

    千次阅读 2013-08-20 23:46:00
    以下内容摘自刚刚上市,史上最全面、最系统的的四本大型(每本平均近900页)网络设备新书之一《H3C路由器配置与管理完全手册》(第二版),其它三本分别是:《Cisco交换机配置与管理完全手册》(第二版)、《Cisco...
  • 静态NAT+动态NAT+PAT配置

    千次阅读 2017-11-16 19:29:00
    静态NAT+动态NAT+PAT配置 拓扑图 总体配置配置路由器ip地址及实现外网互通 Router0 Router>enable Router#conf Router(config)#intf0/0 Router(config-if)#ipaddress192.168.1.1255.255.255.0 Router(c...
  • 动态NAT地址转换配置实验(中兴)

    千次阅读 2020-06-12 23:24:57
    动态NAT地址转换配置实验一、实验目的二、实验内容三、实验流程四、查看和验证五、实验总结 一、实验目的 1.掌握中兴动态NAT技术的基本原理和作用,及其数据的转发过程; 2.掌握动态NAT技术的基本原理和作用; 二、...
  • 华为Router 动态NAT地址转换配置

    万次阅读 多人点赞 2018-06-19 11:01:13
    一、组网需求:某公司A部门和B部门的私网用户和...A部门允许使用公网IP地址比较多(202.169.10.100~202.169.10.200),所以使用no-pat转换方式(只转换数据包的IP地址,并不使用端口号)的NAT方式替换A部门内部的主...
  • 动态NAT 拓扑图如下: 实验步骤 1、设置三层交换机sw sw#conf t Enter configuration commands, one per line. End with CNTL/Z. sw(config)#no ip routing sw(config)# 2、设置路由R1 R1#conf t Enter ...
  • 三种常见NAT配置办法,私有网络地址转换共有网络地址的实验操作详情,一看就会,配有详细的拓扑同,结合实际生产环境,实在又实用

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 133,645
精华内容 53,458
关键字:

动态nat配置