精华内容
下载资源
问答
  • 华为交换机接口模式

    2020-07-17 22:05:10
    ·1 将pc1/3划入access接口,pvid vlan 2,划入r1的0/0/0.1子接口,这样一个网段一个vlan ·2 将pc2/4/5/6划入一个网段,华为中,进入路由器的流量不带标签默认划入vlan1,r1的物理接口默认vlan1 ·3 pc2可以访问pc4...

    在这里插入图片描述

    思路

    ·1 将pc1/3划入access接口,pvid vlan 2,划入r1的0/0/0.1子接口,这样一个网段一个vlan
    ·2 将pc2/4/5/6划入一个网段,华为中,进入路由器的流量不带标签默认划入vlan1,r1的物理接口默认vlan1
    ·3 pc2可以访问pc4/5/6,pc4可以访pc5,不能访问pc6 -----pc2为vlan3,pvid3;pc4/5为vlan4,pvid4;pc5为vlan5,pvid5;
    ·4 pc2所连接口允许vlan3/4/5进入,pc4/5允许vlan3/4进入,pc5允许vlan3/5进入

    sw1

    接口所连pc
    pc1:
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type access
    [sw1-Ethernet0/0/1]port default vlan 2

    pc2:
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 3 to 5 定义允许进入的流量
    [sw1-Ethernet0/0/2]port hybrid pvid vlan 3

    sw1与sw2之间: 默认链路上pvid为vlan1
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port hybrid tagged vlan 2 3 4 5 出时标记的vlan

    [sw2]int e0/0/1
    [w2-Ethernet0/0/1]port link-type trunk
    [Ethernet0/0/1]port trunk allow-pass vlan 2 3 4 5

    [sw2]display port vlan active 查看允许列表

    sw2

    pc3:
    [sw2]int e0/0/2
    [w2-Ethernet0/0/2]port link-type access
    [sw2-Ethernet0/0/2]port default vlan 2

    pc4:
    [sw2-Ethernet0/0/2]int e0/0/3
    [sw2-Ethernet0/0/3]port hybrid pvid vlan 4
    [Ethernet0/0/3]port hybrid untagged vlan 3 4

    sw2与sw3之间
    [sw2-Ethernet0/0/3]int e0/0/4
    [sw2-Ethernet0/0/4]port link-type trunk
    [ernet0/0/4]port trunk allow-pass vlan 2 to 5

    sw3

    创建vlan:
    [sw3]vlan batch 2 to 5

    sw2与sw3之间:
    [sw3]int e0/0/1
    [sw3-Ethernet0/0/1]port hybrid tagged vlan 2 to 5

    pc5:
    [sw3-Ethernet0/0/1]int e0/0/2
    sw3-Ethernet0/0/2]port hybrid pvid vlan 4
    [sw3-Ethernet0/0/2]port hybrid untagged vlan 3 4

    pc6:
    [sw3-Ethernet0/0/2]int e0/0/3
    [sw3-Ethernet0/0/3]port hybrid pvid vlan 5
    3-Ethernet0/0/3]port hybrid untagged vlan 3 5

    sw1与r1接口

    [sw1]int g0/0/1
    sw1-GigabitEthernet0/0/1]port hybrid tagged vlan 2
    -GigabitEthernet0/0/1]port hybrid untagged vlan 2 to 5

    r1

    子接口:
    [r1]int g0/0/0.1
    [r1-GigabitEthernet0/0/0.1]dot1q termination vid 2 标定接收和标定的标签时vlan2
    [r1-GigabitEthernet0/0/0.1]ip a 192.168.1.1 24
    [r1-GigabitEthernet0/0/0.1]arp broadcast enable 开启arp功能

    物理接口
    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]ip a 192.168.2.1 24

    r1]dhcp enable 开启DHCP
    配置DHCP池塘
    [r1]ip pool a
    ip-pool-a]network 192.168.1.0 mask 24
    [r1-ip-pool-a]gateway-list 192.168.1.1
    [r1-ip-pool-a]dns-list 114.114.114.114 8.8.8.8
    [r1]ip pool v3
    -ip-pool-v3]network 192.168.2.0 mask 24
    [r1-ip-pool-v3]gateway-list 192.168.2.1
    [r1-ip-pool-v3]dns-list 114.114.114.114 8.8.8.8

    [r1]int g0/0/0
    [r1-GigabitEthernet0/0/0]dhcp
    [r1-GigabitEthernet0/0/0]dhcp select global
    [r1-GigabitEthernet0/0/0]int g0/0/0.1
    1-GigabitEthernet0/0/0.1]dhcp select global

    展开全文
  • 一、华为交换机接口模式详解 一、华为交换机VLAN部分的接口模式: 1、只要流量进入华为的设备将马上打上标签;-- 华为设备内部转发的流量均存在标签 2、华为设备交换机上所有的接口存在转发允许列表,只有被转发允许...

    一、华为交换机接口模式详解

    一、华为交换机VLAN部分的接口模式

    1、只要流量进入华为的设备将马上打上标签;-- 华为设备内部转发的流量均存在标签
    2、华为设备交换机上所有的接口存在转发允许列表,只有被转发允许列表允许的流量,才能从该接口进入或转出;
    3、从某个接口转出时,除查看允许列表外,还需要定义是否标记;
    4、若某个流量从交换机某个接口进入时,没有标签,将被标记上该接口pvlan id;
    5、若某个流量从交换机的某个接口进入时,存在标签,将匹配该接口的允许列表,若被允许可以进入,若未被允许将被丢弃;
    6、PC若接收到存在标记的流量,将丢弃;
    无论接口为任何模式,均匹配以上5条规则;

    数据帧从一个交换机接口进入时,先关注是否携带vlan id;
    1)携带 —关注list ,若允许,便携带封装进入
    2)未携带—封装PVID的VLAN号进入
    数据帧从一个交换机接口出去时;那么必须在vlan list 中存在
    再关注是否携带封装出
    U 剥离
    T 携带

    二、华为交换机三种接口模式

    1、接入模式:只能允许一个VLAN通过(允许列表无法直接定义);PVLAN就是允许VLAN;且一定为不标记
    [sw1]interface GigabitEthernet 0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type access
    2、中继模式:所有VLAN均可手动添加到允许列表中,默认仅pvlan在允许列表,且pvlan的出规则为不标
    记,其他VLAN出规则为标记;
    [sw1]interface GigabitEthernet 0/0/1
    [sw1-GigabitEthernet0/0/1]port link-type trunk
    3、混杂模式:所有VLAN均可手动添加到允许列表中,且可以在允许通过时,定义是否标记;
    默认PVLAN 为VLAN1,出向规则为不标记;一旦PVLAN被修改,那么需要手工添加该VLAN到允许列表,同时可以定义是否标记;
    [sw1]interface GigabitEthernet 0/0/1
    [sw1-GigabitEthernet0/0/1]port hybrid tagged vlan 2 to 3
    [sw1-GigabitEthernet0/0/1]port hybrid untagged vlan 4 to 5

    [sw1]display port vlan active 查看接口的VLAN转发规则;

    二、相关实验

    一、实验要求

    1、pc1和pc3所在接口为access,pvlan 为vlan2,且可以正常访问其他pc
    2、pc 2/4/5/6处于同一网段;其中2可以正常访问456;45可以互相访问,但不能访问6
    3、pc1/3与2456不在同一个网段
    4、所有pc通过DHCP获取ip地址

    二、实验拓扑

    在这里插入图片描述

    三、配置步骤

    1、根据题目要求首先对交换机与pc1/3相连的端口配置为access,所属为vlan2

     port link-type access
     port default vlan 2
    

    2、根据实验要求2,将pc2划分到vlan3,pc4/5划分到vlan4,pc6划分到vlan5
    ①pc2可以正常访问所有主机,即vlan2、3、4、5的标签都从与之相连的接口出来时都会被剥离

     port hybrid pvid vlan 3
     port hybrid untagged vlan 2 to 5
    

    ②pc4/5不可以访问6,其他可正常访问:根据要求可知交换机与4/5连接的端口需用混杂模式,不能访问pc6即数据帧从接口出是不剥离该标签(主机无法识别带标签的数据,故将此类数据丢弃)

    sw2:
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 4
     port hybrid untagged vlan 2 to 4  
     sw3:
     interface GigabitEthernet0/0/2
     port hybrid pvid vlan 5
     port hybrid untagged vlan 2 to 3 5
    

    ③DHCP分配地址:1/3属于vlan2,在路由器起虚接口即可用于分配地址;2/4/5/6不在同一个vlan但是在同一网段,无法使用虚接口对其分配地址,故用路由器的物理接口为其分配 (物理接口无法识别标签,所以路由器与交换机之间需要使用混杂模式,将vlan345的标签去掉)

    interface GigabitEthernet0/0/0
     ip address 192.168.3.1 255.255.255.0 
     dhcp select global
    #
    interface GigabitEthernet0/0/0.1
     dot1q termination vid 2
     ip address 192.168.2.1 255.255.255.0 
     arp broadcast enable
     dhcp select global
    dhcp enable
    #
    ip pool v2
     gateway-list 192.168.2.1 
     network 192.168.2.0 mask 255.255.255.0 
    #
    ip pool v345
     gateway-list 192.168.3.1 
     network 192.168.3.0 mask 255.255.255.0 
    
     sw1:
    interface GigabitEthernet0/0/3
     port hybrid tagged vlan 2
     port hybrid untagged vlan 3 to 5 
    

    四、实验结果

    pc1 ping其他pc
    pc1ping其他pc
    pc2 ping其他pc在这里插入图片描述
    pc4 ping 其他pc
    在这里插入图片描述
    pc6 ping其他pc
    在这里插入图片描述

    展开全文
  • 二三层切换简介基于接口板的硬件构造,某些形态设备上接口只能作为二层以太网接口,某些形态设备上接口只能作为三层以太网接口,而还有一些接口则比较灵活,可以改变其二三层模式:在二层模式下,该接口作为一个二层...

    二三层切换简介

    基于接口板的硬件构造,某些形态设备上接口只能作为二层以太网接口,某些形态设备上接口只能作为三层以太网接口,而还有一些接口则比较灵活,可以改

    变其二三层模式:在二层模式下,该接口作为一个二层以太网接口使用;在三层模式下,该接口作为一个三层以太网接口使用。

    配置注意事项

    • 缺省情况下,设备的以太网接口工作在二层模式,并且已经加入VLAN1。将接口转换为三层模式后,该接口并不会立即退出VLAN1,只有当三层协议

    UP后,接口才会退出VLAN1。

    • 以太网接口的二三层模式既可以在以太网接口视图下配置也可以在系统视图下配置。当两种视图下配置的二三层模式不同时,最新配置生效。

    • 连续执行portswitch、undo portswitch命令切换接口二三层工作模式的最小时间间隔是30秒。即切换接口工作在一种二三层模式后,用户需要等待至

    少30秒才能切换接口工作在另外一种二三层模式。

    • 如果接口上已经有业务配置存在(例如port link-type trunk配置),需要先将该接口下的业务配置全部清除才能执行命令切换接口的二三层模式。接

    口上只存在属性配置信息(例如shutdown、description配置),这些属性配置则无需清除,可以直接切换接口的二三层模式。

    • 对于V200R003及之前版本的设备,工作在三层模式的以太网接口不支持配置IP地址。

    • 本举例适用的产品和版本请参见举例适用的产品和版本。

    组网需求

    如图1所示,PC1、PC2、PC3和PC4分别属于不同网段,SwitchB、SwitchC、SwitchD、SwitchE分别为这四个网段的接入层交换机。用户希望使用SwitchA

    上的四个以太网物理接口作为这四个网段的网关接口。

    配置思路

    配置思路如下:

    • 将接口的工作模式切换为三层模式。

    组网图形

    92bb6f2d0b099bd67cb43079219cc214.png

    • 配置三层以太网接口的IP地址作为网关。

    操作步骤

    1. 配置接口切换到三层模式

    # 配置单个接口切换到三层模式。

    system-view

    [HUAWEI] sysname SwitchA

    [SwitchA] interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1] undo portswitch

    [SwitchA-GigabitEthernet1/0/1] quit

    # 配置以太网接口批量切换到三层模式。

    [SwitchA] undo portswitch batch gigabitethernet 1/0/2 to 1/0/4

    2. 配置三层接口的IP地址作为网关

    # 以配置GE1/0/1接口的IP地址作为网关为例。GE1/0/2、GE1/0/3、GE1/0/4的配置与GE1/0/1的类似,详见配置文件。

    [SwitchA] interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1] ip address 10.10.1.1 24

    [SwitchA-GigabitEthernet1/0/1] quit

    3. 验证配置结果

    在任意视图下执行命令display interface gigabitethernet 1/0/1,检查接口当前工作模式

    [SwitchA] display interface gigabitethernet 1/0/1

    ...

    Description:

    Route Port,The Maximum Frame Length is 9216

    Internet Address is 10.10.1.1/24

    ...

    如果回显字段为Switch Port,代表接口工作在二层模式;如果回显字段为Route Port,代表接口工作在三层模式。由上述回显字段可以看出接口工

    作在三层模式。

    同理,对于接口GE1/0/2、GE1/0/3和GE1/0/4也可以通过执行display interface gigabitethernet 1/0/2、display interface gigabitethernet

    1/0/3和display interface gigabitethernet 1/0/4命令查看接口当前工作模式。

    配置文件

    SwitchA的配置文件。

    #

    sysname SwitchA

    #

    interface GigabitEthernet1/0/1

    undo portswitch

    ip address 10.10.1.1 255.255.255.0

    #

    interface GigabitEthernet1/0/2

    undo portswitch

    ip address 10.10.2.1 255.255.255.0

    #

    interface GigabitEthernet1/0/3

    undo portswitch

    ip address 10.10.3.1 255.255.255.0

    #

    interface GigabitEthernet1/0/4

    undo portswitch

    ip address 10.10.4.1 255.255.255.0

    #

    return

    展开全文
  • undo negotiation auto #关闭自协商功能 范例: [S1]interface G 0/0/1 [S1-GigabitEthernet0/0/1]...duplex full #手动指定双工模式为全双工 speed xxx #手动配置接口速率为xxx 范例: [S1]interface E 0/0/1...

    undo negotiation auto   #关闭自协商功能

    范例:

    [S1]interface G 0/0/1 
    [S1-GigabitEthernet0/0/1]undo negotiation auto

     

    duplex full    #手动指定双工模式为全双工

     

    speed xxx  #手动配置接口速率为xxx

    范例: 
    [S1]interface E 0/0/1  
    [S1-Ethernet0/0/1]undo negotiation auto
    [S1-Ethernet0/0/1]

    [S1-Ethernet0/0/1]speed 10

    展开全文
  • Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间的连接端口; Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间的连接,也...
  • Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间的连接端口; Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间的连接,也...
  • 华为交换机私有hybird接口模式:(案例+原理详解) 实验说明: 准备:如图pc1 pc4同属于VLAN10,配置相应的ippc3 pc3同属于VLAN20 配置相应的ipClient 属于 VLAN30 配置pc1同网段ipPc1 pc4 client 属于同网段但是...
  • SwitchA配置 system-view[HUAWEI] sysname SwitchA[SwitchA] interface eth-trunk 1 # 创建Eth-Trunk1[SwitchA-Eth-Trunk1] mode lacp # 配置LACP模式[SwitchA-Eth-Trunk1] trunkport gigabtiethernet 0/0/1 to 0/0/...
  • 华为交换机的三种接口模式:1、access模式。2、trunk模式。3、hybrid模式。hybrid接口的工作原理。华为设备的各种接口模式应用场景及配置。一、什么是vlan?vlan就是虚拟局域网,是在二层交换机上将一个物理的LAN在...
  • 可以按照如下方式进行操作:1、...华为交换机常用命令:1、displaycurrent-configuration显示当前配置2、displayinterfaceGigabitEthernet1/1/4显示接口信息3、displaypacket-filterinterfaceGigabitEthernet1/1/4...
  • 华为交换机命令返回上一级命令:quit配置保存命令:save华为交换机命令<>sys进入配置模式[Quidway]discur;显示当前配置[Quidway]displaycurrent-configuration;显示当前配置[Quidway]displayinterfaces;...
  • 那么今天小编将指导大家完成华为交换机的vlan配置和vlanif接口的配置请自行准备好华为交换机和电脑并且让你的电脑和交换机连接上使用system-view命令进入[]模式创建一个vlan[Quidway]vlan 2添加端口[Quid...
  • 交换机根据连接对象不同,接口模式:2.1 access2.2 trunk2.3 Hybrid 1. 虚拟局域网:vlan vlan的好处/功能 1.划分广播域 2.管理方便 3.安全 MAC地址表三元素: 1.端口号 2.MAC地址 3.vlanid 华为支持的vlan数量是1-...
  • 华为交换机在使用的时候,很多情况下我们需要在三层交换机上配置一下DHCP中继服务,用以为下面的客户机提供DHCP中继服务,就是说三层交换机上可以为DHCP端口转发数据到指定的DHCP服务器上;而不会因为是跨VLAN就导致...
  • Hybrid接口是华为设备的特殊的二层接口模式,Hybrid接口和Trunk接口的相同之处是都可以允许多个VLAN的流量通过并打标签, 不同之处在于Hybrid接口可以允许多个VLAN的报文发送时不打标签。 1.1 概念和作用: Hybrid是...
  • 华为交换机的三种接口模式:1、access模式。2、trunk模式。3、hybrid模式。 hybrid接口的工作原理。 华为设备的各种接口模式应用场景及配置。 一、什么是vlan? vlan就是虚拟局域网,是在二层交换机上将一个物理的...
  • 华为的dhcp配置有三种方式,接口地址池、本地地址池、DHCP中继,今天分别做了三个实验的案例如下:接口地址池的方法:首先还是打开ensp新建工程,拉出一台交换机和一台电脑用线连接起来,开机。打开交换机LSW1的配置...
  • 满意答案lzz86226322013.10.05...(HUAWEI S3000)配置过程(// 后面为注释)1.改变中文模式language-mode chinese //习惯英语的可以不用此步骤2.进入系统试图system-view3.设置特权密码:super password cipher NIME...
  • 华为交换机VLAN

    2021-01-29 19:32:55
    华为VLAN部分的接口模式讲解: 1、 只要流量进入华为的设备将马上打上标签;-- 华为设备内部转发的流量均存在标签 2、 华为设备交换机上所有的接口存在转发允许列表,只有被转发允许列表允许的流量,才能从该接口...
  • [Quidway]sysname router_name 命名路由器(或交换机) [Quidway]delete 删除Flash ROM中的配置 [Quidway]save 将配置写入Flash ROM [Quidway]interface serial 0 进入接口配置模式 [Quidway]quit 退出接口模式到系统...
  • 其中Access、Trunk接口和Cisco技术并无差异,Hybrid接口是华为设备特有的接口模式。Hybrid接口和Trunk接口的相同之处是都可以允许多个VLAN的流量通过并打标签,不同之处在于Hybrid接口可以允许多个VLAN的报文发送时...
  • 华为交换机

    2020-01-10 11:47:50
    1,配置sw1交换机 <Huawei>sys ##进入系统视图模式 Enter system view, return user view with Ctrl+Z. [Huawei]sys sw1 ##修改名字 [sw1]vlan batch 10 20 ##创建vlan10 20 [sw1]int e0/0/1 ##进入接口 [sw1...
  • 因工作需要,近期浏览了关于华为交换机的操作指令,现整理一个详细的笔记供大家参考。 功能 华为命令 进入全局模式 system 显示当前配置 display current-configuration 显示版本信息 display version 显示vlan信息...
  • 华为交换机DHCP配置

    2021-04-08 15:57:28
    华为交换机DHCP配置 设备型号:华为交换机–S3700 时间:2021.3.19 环境描述:一台S3700交换机,要求1-10接口为vlan10,11-20接口为vlan20.vlan10下面的PC自动获取网段为192.168.10.0/24下的IP地址,vlan20下的PC自动...
  • 按端口划分vlanVlan是二层协议,仅可把二层以太网端口(物理以太网端口和eth-trunk链路口)划分到vlan中,划为交换机以太网端口虽然可以转换为三层模式(undo portswitch),但仍不能直接配置IP地址。二层以太网端口类型...
  • 华为交换机命令

    2020-04-25 15:51:46
    交换机 //用户视图 sys //j进入系统视图 [huawei]sys name jk // 给交换机命名 [huawei] int e0/0/1 //进入接口模式 [huawei-Gigabethernet-0-0-1]q //退出 接口 [name jk]qui...
  • 处理过程是不是需要先用port link-type命令一个一个的把端口模式改了呢?其实有一个更快捷的方式:使用port-group命令。[Huawei]port-group 1to10[Huawei-port-group-1to10]group-member GigabitEthernet 0/0/1 to ...
  • 1、概念以太网链路聚合Eth-Trunk简称链路聚合...2、模式1)手工模式Eth-Trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议的参与。2)LACP模式Eth-Trunk的建立是基于LACP协议的,LACP为交换数据的设备提...

空空如也

空空如也

1 2 3 4 5 ... 14
收藏数 268
精华内容 107
关键字:

华为交换机接口模式