精华内容
下载资源
问答
  • 基于端口划分vlan拓扑图PC ip 配置PC 5:192.168.1.5PC 6:192.168.1.6PC 7:192.168.1.7PC 8: 192.168.1.8交换机配置创建vlan10、vlan20system-view[Huawei]vlan 10[Huawei-vlan10]quit[Huawei]vlan 20[Huawei-vlan...

    基于端口划分vlan

    拓扑图

    630980967acb0361c2164f2bb6b13e6e.png

    PC ip 配置

    PC 5:192.168.1.5

    PC 6:192.168.1.6

    PC 7:192.168.1.7

    PC 8: 192.168.1.8

    交换机配置

    创建vlan10、vlan20

    system-view

    [Huawei]vlan 10

    [Huawei-vlan10]quit

    [Huawei]vlan 20

    [Huawei-vlan20]quit

    [Huawei]display vlan

    将端口设置为access口,并划入vlan

    [Huawei]interface Ethernet 0/0/1

    [Huawei-Ethernet0/0/1]port link-type access

    [Huawei-Ethernet0/0/1]port default vlan 10

    [Huawei-Ethernet0/0/1]quit

    [Huawei]interface Ethernet 0/0/2

    [Huawei-Ethernet0/0/2]port link-type access

    [Huawei-Ethernet0/0/2]port default vlan 20

    [Huawei-Ethernet0/0/2]quit

    [Huawei]interface Ethernet 0/0/3

    [Huawei-Ethernet0/0/3]port link-type access

    [Huawei-Ethernet0/0/3]port default vlan 20

    [Huawei-Ethernet0/0/3]quit

    [Huawei]interface Ethernet 0/0/4

    [Huawei-Ethernet0/0/4]port link-type access

    [Huawei-Ethernet0/0/4]port default vlan 10

    [Huawei-Ethernet0/0/4]quit

    查看vlan

    [Huawei]display vlan

    The total number of vlans is : 3

    --------------------------------------------------------------------------------

    U: Up; D: Down; TG: Tagged; UT: Untagged;

    MP: Vlan-mapping; ST: Vlan-stacking;

    #: ProtocolTransparent-vlan; *: Management-vlan;

    --------------------------------------------------------------------------------

    VID Type Ports

    --------------------------------------------------------------------------------

    1 common UT:Eth0/0/5(D) Eth0/0/6(D) Eth0/0/7(D) Eth0/0/8(D)

    Eth0/0/9(D) Eth0/0/10(D) Eth0/0/11(D) Eth0/0/12(D)

    Eth0/0/13(D) Eth0/0/14(D) Eth0/0/15(D) Eth0/0/16(D)

    Eth0/0/17(D) Eth0/0/18(D) Eth0/0/19(D) Eth0/0/20(D)

    Eth0/0/21(D) Eth0/0/22(D) GE0/0/1(D) GE0/0/2(D)

    10 common UT:Eth0/0/1(U) Eth0/0/4(U)

    20 common UT:Eth0/0/2(U) Eth0/0/3(U)

    VID Status Property MAC-LRN Statistics Description

    --------------------------------------------------------------------------------

    1 enable default enable disable VLAN 0001

    10 enable default enable disable VLAN 0010

    20 enable default enable disable VLAN 0020

    测试

    相同vlan可以联通

    PC>ping 192.168.1.8

    Ping 192.168.1.8: 32 data bytes, Press Ctrl_C to break

    From 192.168.1.8: bytes=32 seq=1 ttl=128 time=31 ms

    From 192.168.1.8: bytes=32 seq=2 ttl=128 time=16 ms

    From 192.168.1.8: bytes=32 seq=3 ttl=128 time=31 ms

    From 192.168.1.8: bytes=32 seq=4 ttl=128 time=32 ms

    From 192.168.1.8: bytes=32 seq=5 ttl=128 time=47 ms

    --- 192.168.1.8 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 16/31/47 ms

    不同vlan不同

    PC>ping 192.168.1.6

    Ping 192.168.1.6: 32 data bytes, Press Ctrl_C to break

    From 192.168.1.5: Destination host unreachable

    From 192.168.1.5: Destination host unreachable

    From 192.168.1.5: Destination host unreachable

    From 192.168.1.5: Destination host unreachable

    From 192.168.1.5: Destination host unreachable

    --- 192.168.1.6 ping statistics ---

    5 packet(s) transmitted

    0 packet(s) received

    100.00% packet loss

    展开全文
  • 基于端口划分VLAN实例

    2013-04-11 14:27:42
    基于端口划分VLAN的方法;查看VLAN划分情况。 工具/原料 · 1台Cisco1912交换机 · 4台PC机,4条双绞线 · 1台带有超级终端程序的PC机,以及Console电缆及转接器。 步骤/方法 1. 如图连接4台PC机...

    通过本实训可以学习到:

    基于端口划分VLAN的方法;查看VLAN划分情况。

    工具/原料

    ·         1Cisco1912交换机

    ·         4PC机,4条双绞线

    ·         1台带有超级终端程序的PC机,以及Console电缆及转接器。

    步骤/方法

    1.    如图连接4PC机至交换机1-4号以太网接口。

    2.     

     

    3.    4PC机分配IP地址如下所示:

    设置PC1IP地址:

    设置PC2IP地址:

    设置PC3IP地址:

    设置PC4IP地址:

    4.     

     

    5.     

     

    6.     

     

    7.     

     

    8.    测试网络连通性。

    PC1pingPC2机、PC3机、PC4机情况

    PC2pingPC1机、PC3机、PC4机情况

    PC3pingPC1机、PC2机、PC4机情况

    PC4pingPC1机、PC2机、PC3机情况

    9.     

     

    10.   

     

    11.   

     

    12.   

     

    13.  查看交换机默认VLAN情况:Ethernet接口仅有一个VLAN1VLAN,名为Default

    14.   

     

    15.  创建10号、20VLAN

    Switch(config)#vlan10 name NO1VLAN (创建VLAN10

    Switch(config)#vlan20 name NO2VLAN (创建VLAN20

    16.  将交换机1号、3号以太网接口划分到10VLAN2号、4号接口划分到20VLAN

    Switch(config)#interfaceethernet 0/1(进入E1端口子配置模式)

    Switch(config-if)#vlan-membershipstatic 10 (将E1口划入VLAN10

    Switch(config-if)#exit (返回全局模式)

    Switch(config)#interfaceethernet 0/2(进入E2端口子配置模式)

    Switch(config-if)#vlan-membershipstatic 20 (将E2口划入VLAN20

    Switch(config-if)#exit (返回全局模式)

    Switch(config)#interfaceethernet 0/3(进入E3端口子配置模式)

    Switch(config-if)#vlan-membershipstatic 10 (将E3口划入VLAN11

    Switch(config)#interface ethernet 0/4(进入E4端口子配置模式)

    Switch(config-if)#vlan-membership static 20 (将E4口划入VLAN20

    Switch(config-if)#end (返回特权模式)

    17.  使用show vlan指令查看当前VLAN划分情况。

    相比此前查看到的VLAN情况,Ethernet接口部分多了10号、20VLAN,并且13号接口属于10VLAN24号接口属于20VLAN

    18.   

     

    19.  重新测试网络连通性。

    20.  PC1pingPC3机依然是通的:

    21.   

     

    22.  PC1pingPC2机、PC4机此时却不通了:

    23.   

     

    24.  PC2pingPC4机依然是通的:

    25.   

     

    26.  PC2pingPC1机、PC3机此时却不通了:

    27.   

     

    注意事项

    ·         不具备实训条件可以使用RouterSim软件模拟

     

     

    展开全文
  • 通过该实验理解VLAN的基本原理,掌握按端口划分VLAN的方法,理解VLAN间通信的基本原理。
  • 现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分VLAN 3中。方案一:用户端口采用Access类型,交换机间连接端口采用Tru...

    图所示为一个小型企业局域网示例,拓扑结构中的两台交换机(SwitchA 和SwitchB)上各连接了许多进行不同业务操作的用户。现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分到VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分到VLAN 3中。

    593ce7ae5d321e2d8bce49a38cd5054a.png

    方案一:用户端口采用Access类型,交换机间连接端口采用Trunk类型(1)在SwitchA创建VLAN2和VLAN3,并将连接用户的端口类型都设置为Access类型,然后分别加入对应的VLAN中。SwitchB配置与SwitchA类似。

    system-view

    [HUAWEI]sysname SwitchA

    [SwitchA]vlan batch 2 3 !---批量创建VLAN 2和VLAN 3

    [SwitchA]interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1]port link-type access !---设置gigabitethernet1/0/1接口为Access类型

    [SwitchA-GigabitEthernet1/0/1]port default vlan 2 !---把gigabitethernet1/0/1接口加入到VLAN 2中

    [SwitchA-GigabitEthernet1/0/1]quit

    [SwitchA] interface gigabitethernet 1/0/2

    [SwitchA-GigabitEthernet1/0/2]port link-type access

    [SwitchA-GigabitEthernet1/0/2]port default vlan 3

    [SwitchA-GigabitEthernet1/0/2]quit

    (2)配置SwitchA与SwitchB连接的端口类型为Trunk,同时允许VLAN 2和VLAN 3通过。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interfacegigabitethernet 1/0/3

    [SwitchA-GigabitEthernet1/0/3]port link-type trunk

    [SwitchA-GigabitEthernet1/0/3]port trunk allow-pass vlan 2 to 3

    方案二:用户端口采用 Access 类型,交换机间连接端口采用带标签的 Hybrid类型。(1)把用户加入对应的VLAN中,配置方法同方案一中的第(1)步配置。(2)配置SwitchA与SwitchB连接的端口类型为Hybrid,并以Tagged(带标签)方式同时加入VLAN 2和VLAN 3中。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA]interfacegigabitethernet 1/0/3

    [SwitchA-GigabitEthernet1/0/3]port link-type hybrid

    [SwitchA-GigabitEthernet1/0/3]port hybrid Tagged vlan 2 to 3

    方案三:用户端口采用不带标签的 Hybrid 类型,交换机间连接端口采用 Trunk类型。(1)在SwitchA创建VLAN2和VLAN3,并将连接用户的端口类型都设置为Hybrid类型,然后分别以Untagged方式加入对应的VLAN中,并且把对应的VLAN ID设置这些Hybrid端口的PVID。SwitchB配置与SwitchA类似。

    system-view[HUAWEI]sysname SwitchA

    [SwitchA]vlan batch 2 3

    [SwitchA]interface gigabitethernet 1/0/1

    [SwitchA-GigabitEthernet1/0/1]port link-type hybrid !---设置gigabitethernet1/0/1接口为Hybrid类型

    [SwitchA-GigabitEthernet1/0/1]port hybrid Untagged vlan 2 !---把gigabitethernet 1/0/1接口以Untagged方式加入到VLAN 2中

    [SwitchA-GigabitEthernet1/0/1]port hybrid pvid vlan 2 !---设置gigabitethernet1/0/1接口的PVID为VLAN 2

    [SwitchA-GigabitEthernet1/0/1]quit

    [SwitchA]interface gigabitethernet 1/0/2

    配置方法同方案二中的第(2)步配置。验证配置结果如下。将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。经测试,证明User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。由此可确认配置是正确并成功的。

    展开全文
  • 思科基于端口划分VLAN

    千次阅读 2020-06-15 10:01:50
    我们将采用Cisco Packet Tracer进行拓扑搭建,如图: 然后对每一台主机进行IP地址、子网掩码、网关的配置 然后进行相关VLAN的配置: Switch>en Switch>...Enter configuration commands, ...Switch(config-vlan

    我们将采用Cisco Packet Tracer进行拓扑搭建,如图:
    在这里插入图片描述
    然后对每一台主机进行IP地址、子网掩码、网关的配置
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    然后进行相关VLAN的配置:
    Switch>en
    Switch>en
    Switch#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#vlan 10
    Switch(config-vlan)#name work
    Switch(config-vlan)#exit
    Switch(config)#vlan 20
    Switch(config-vlan)#name money
    Switch(config-vlan)#exit
    Switch(config)#int range f0/1-f0/2
    Switch(config-if-range)#switchport access vlan 10
    Switch(config-if-range)#exit
    Switch(config)#int range f0/3-4
    Switch(config-if-range)#switchport access vlan 20
    Switch(config-if-range)#end
    Switch#
    %SYS-5-CONFIG_I: Configured from console by console
    然后进行查看,命令为show vlan
    在这里插入图片描述
    然后我们继续进行Ping
    在这里插入图片描述
    在这里插入图片描述
    我们发现在同一个VLAN下面的主机可以通信,在不同VLAN下面的主机不能进行通信

    展开全文
  • 华为eNSP的基于端口划分VLAN

    千次阅读 2020-07-08 10:54:05
    我们将采用eNSP进行拓扑图的搭建: 查看端口对应VLAN 信息: 命令是:display port vlan active 完成!!!
  • 现要把连接在SwitchA上的User1和连接在SwitchB上的User2都划分VLAN 2中,而把连接在SwitchA上的User3和连接在SwitchB上的User4都划分VLAN 3中。方案一:用户端口采用Access类型,交换机间连接端口采用Tru...
  • 交换机基于端口划分vlan

    千次阅读 2018-05-02 15:01:20
    https://blog.csdn.net/u010603691/article/details/50542840
  • 华为交换机基于端口划分vlan

    万次阅读 2016-01-19 15:32:16
    1. 像集线器一样,交换机提供了大量可供线缆连接的端口,这样可以采用星型拓扑布线。 2. 像中继器、集线器和网桥那样,当它转发帧时,交换机会重新产生一个不失真的方形电信号。 3. 像网桥那样,交换机在每...
  • 拓扑图 方案一:用户端口采用Access类型,而交换机连接的端口采用Trunk类型 方案二:用户端口采用Access类型,而交换机... port hybrid tagged vlan 2 to 3 SwitchB与SwitchA 配置一样 方案三:用户端采用不...
  • 基于交换机端口划分VLAN

    千次阅读 2019-07-16 17:23:35
    一、VLAN的分类 1)基于端口的vlan ... 只有网卡才分配MAC地址,因此按照MAC地址划分VLAN实际上是将某些工作站和服务器划分给某个VLAN。实际上该VLAN是MAC地址的集合。当设备移动时,VLAN能自动识别...
  • VLAN 划分——基于交换机端口划分VLAN

    万次阅读 多人点赞 2018-05-12 16:23:20
    交换机作用是什么?我这里度娘一下:交换机(Switch)意为“开关”是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点...刚才提到了vlanvlan又是什么呢?同样度娘一下:VLAN(Virtual...
  • 交换机作用是什么?交换机(Switch)意为“开关”是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。...刚才提到了vlanvlan又是什么呢?VLAN(Virtual Local Are...
  • 交换机作用是什么?交换机(Switch)意为“开关”是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。...刚才提到了vlanvlan又是什么呢?VLAN(Virtual Local Are...
  • 首先了解VLANVLAN是英文Virtual Local Area Network的简称,又叫虚拟局域网,是一种通过将局域网内的设备逻辑地而不是物理地划分成一个个网段从而实现虚拟工作组的新兴技术。其实VLAN是为解决以太网的广播问题和...
  • 忆龙2009:基于端口VLAN简介

    千次阅读 2009-12-07 19:32:00
    基于端口划分VLAN是VLAN最简单、最有效的划分方法。它按照设备端口来定义VLAN成员,将指定端口加入到指定VLAN中之后,端口就可以转发指定VLAN的报文。 1. 端口的链路类型 根据端口在转发报文时对Tag标签的不同处理...
  • 基于IP划分VLAN

    千次阅读 2015-09-09 22:47:50
    划分vlan的方法:1、基于vlan2、基于端口3、基于网络协议,例如IP4、基于策略常见的是如上四种,当然还有其他方法,但并不多见。其实在企业中,我也是基本依据端口来划分VLAN划分VLAN的好处就不多赘述了,最重要的...
  • VLAN网关 接口 VLAN PC1 192.168.10.1/24 192.168.10.254/24 H3c-S1 GE1/0/1 10 PC2 192.168.20.1/24 192.168.20.254/24 H3c-S1 GE1/0/2 20 PC3 192.168.10.2/24 192.168.10.254/24 H3...
  • VLAN(Virtual Local Area Network,虚拟局域网)是将一个物理以太网结构在逻辑上划分成多个广播域的通信...在交换机上配置基于接口划分VLAN,把业务相同的用户的接口划分到同一VLAN。实现不同VLAN的不能进行二层通信
  • 关于交换机的配置模式,大体上可以分为两类:其一以CISCO交换机为代表的配置模式,其二以Huawei、H3C交换机为代表的配置模式。...总结来说,如果以在交换机上配置VLAN为例,可以参考以下基本原理或步骤: 交...
  • VLAN运行在交换机上,通过端口划分等方式对不同的冲突域进行分类,将各种存在物理差异的端口划分在一个虚拟的区间内。 ####VLAN的数据帧 VLAN的数据帧比一般以太网的数据帧多了一个4个字节的帧头,用于存储VLAN信息...
  • 基于策略划分VLAn也可称为Policy VLAN,是根据一定的策略进行VLAN划分的,可实现用户终端的即插即用功能,同时可为终端用户提供安全的数据隔离。这里的策略主要包括“基于MAC地址+IP地址”组合和“基于MAC地址+IP...
  • 配置过程:启用所有设备,配置好主机的IP地址,CLIENT1: 10.0.0.1/24 CLIENT2: 10.0.1.1/24 CLIENT3: 10.0.0.2/24 CLIENT4: 10.0.1.2/24VLAN 10 : CLIENT1CLIENT3VLAN 20: CLIENT2 CLIENT4实现VLAN10 内的主机可以...
  • Cisco Packet Tracer中在多交换机上配置基于端口VLAN 添加两台交换机和四台主机 主机0与主机1与交换机0接口fa0/1和fa0/11连接,分别划分VLAN10和 VLAN20中,IP分别为192.168.10.1和192.168.20.1 主机2与主机3...
  • 基于端口VLAN划分-Cisco模拟软件实现

    千次阅读 2018-04-04 10:30:45
    思维导图具体过程及命令交换机配置VLAN创建Switch>enable //进入特权模式 Switch#config //进入全局模式 Switch(config)#vlan 10 //创建VLAN 10 Switch(config-vlan)#name Math //命名 Switch(confi
  • 学过思科交换机的朋友,可能对基于策略划分VLAN的配置方法印象非常深,感觉确实比较复杂,先要配置VMPS以及VMPS数据库,但在华为交换机中,这种现象得到了彻底改变,因为它有了一种特殊的端口类型——Hybrid。...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 421
精华内容 168
关键字:

基于端口划分vlan